Tableau ワークスペース

Tableau ワークスペースは、メニュー、ツールバー、[データ] ペイン、カードとシェルフ、1 つ以上のシートで構成されます。シートは、ワークシート、ダッシュボード、またはストーリーのいずれかです。ダッシュボード ワークスペースまたはストーリー ワークスペースの詳細については、ダッシュボードの作成またはストーリー ワークスペースを参照してください。

ビデオを視聴する: Tableau での関連する概念について説明した無料トレーニング ビデオ「入門」から、4 分間の「The Tableau interface (Tableau インターフェイス)」をご覧ください。お使いの tableau.com アカウントを使用してサインインします。

Web 上で Tableau を使用している場合は、Creators: Web 作成入門およびTableau サイトの概要を参照してください。

ワークスペース領域

A. ワークブック名。ワークブックにはシートが含まれています。シートは、ワークシート、ダッシュボード、ストーリーのいずれかです。詳細については、ワークブックとシートを参照してください。

B. カードとシェルフ: ビューにデータを追加するには、フィールドをワークスペース内のカードおよびシェルフにドラッグします。

C. ツールバー: コマンドや分析およびナビゲーション ツールにアクセスするには、ツールバーを使用します。

D. ビュー: ビジュアライゼーション ("Viz" とも呼ばれます) を作成するワークスペース内のキャンバスです。

E. このアイコンをクリックすると [スタート] ページに移動し、ここでデータに接続できます。詳細については、スタート ページを参照してください。

F. サイドバー: ワークシートのサイドバー領域には、[データ] ペイン[アナリティクス] ペインが含まれています。

G. このタブをクリックすると、[データ ソース] ページに移動し、データが表示されます。詳細については、[データ ソース] ページを参照してください。

H. ステータス バー: 現在のビューに関する情報を表示します。

I. シート タブ: タブは、ワークブック内の各シートを表します。これには、ワークシート、ダッシュボード、およびストーリーが含まれます。詳細については、ワークブックとシートを参照してください。

先頭に戻る


Tableau ツールバー ボタン リファレンス

ビューを作成または編集する際、ビューの上部にあるツール バーを使用して共通のアクションを実行できます。

Tableau Desktop で、Tableau ツールバーを表示または非表示にするには、[ウィンドウ] > [ツールバーの表示] を選択します。

次の表では、各ツールバー ボタンの機能を説明します。一部のボタンは、すべての Tableau 製品では使用できません。Tableau Desktop の視覚キューとアイコンも参照してください。

ツールバー ボタン 説明

Tableau アイコン: スタート ページに移動します。詳細については、スタート ページを参照してください。

: Tableau Desktop のみ。

元に戻す: ワークブックで最後に行われた操作を元に戻します。元に戻せるアクションの回数に制限はありません。保存を行った後でも、ワークブックを最後に開いた時点まで戻れます。詳細については、元に戻す/やり直すを参照してください。

やり直す: [元に戻す] ボタンで、元に戻した最終のアクションを繰り返します。何度でもやり直すことができます。

保存: Tableau Desktop では、ワークブックに加えた変更を保存します。詳細については、作業内容の保存を参照してください。

Tableau Server または Tableau Online で変更を保存するには、[ファイル] > [保存] または [ファイル] > [名前を付けて保存] をクリックします。

新しいデータ ソース: Tableau Desktop では、新しい接続を作成したり、保存済みの接続を開いたりするための [接続] ペインを開きます。詳細については、データへの接続を参照してください。

Tableau Server または Tableau Online では、パブリッシュしたデータ ソースに接続できる [データ ソースに接続] ページを開きます。詳細については、Web 作成中のパブリッシュされたデータ ソースへの接続を参照してください。

自動更新の一時停止: 変更を加えたときに Tableau によってビューを更新するかどうかを制御します。ドロップダウン メニューを使用して、シート全体を自動更新するか、フィルターのみを使用します。詳細については、データの更新または自動更新の一時停止を参照してください。

更新を実行: 自動更新をオフにした場合に、データの手動クエリを実行してビューを更新します。ドロップダウン メニューを使用して、ワークシート全体を更新するか、フィルターのみを使用します。

: Tableau Desktop のみ。

新しいワークシート: 新しい空白のワークシートを作成し、ドロップダウン メニューを使用して、新しいワークシート、ダッシュボード、またはストーリーを作成します。

詳細については、新しいワークシート、ダッシュボード、およびストーリーの作成を参照してください。

複製: 現在のシートと同じビューを持つ新しいワークシートを作成します。詳細については、シートの複製を参照してください。

クリア: 現在のワークシートをクリアします。ドロップダウン メニューを使用して、フィルター、書式設定、サイズ変更、および軸範囲など、ビューの特定の構成要素をクリアします。

スワップ: [行] シェルフと [列] シェルフの間でフィールドを移動します。このボタンを使用すると常に [空の行を非表示][空の列を非表示] の設定が切り替わります。
昇順に並べ替え: ビューのメジャーに基づいて、選択したフィールドを昇順に並べ替えます。詳細については、視覚化内でのデータの並べ替えを参照してください。
降順に並べ替え: ビューのメジャーに基づいて、選択したフィールドを降順に並べ替えます。詳細については、視覚化内でのデータの並べ替えを参照してください。
合計: ビュー内のデータの総計と小計を計算できます。次のオプションから選択します。
  • 列の総計を表示: ビューのすべての列の合計を表示する行を追加します。

  • 行の総計を表示: ビューのすべての行の合計を表示する列を追加します。

  • 行の合計を左へ: 合計を示す列をクロスタブまたはビューの左へ移動します。

  • 列の合計を一番上へ: 合計を示す列をクロスタブまたはビューの一番上へ移動します。

  • すべての小計を追加: 列または行に複数のディメンションがある場合、ビューに小計行/小計列を挿入します。

  • すべての小計を削除: 小計行または小計列を削除します。

: Tableau Server および Tableau Online のみ。Tableau Desktop では、[分析] > [合計] をクリックします。詳細については、ビジュアライゼーションでの合計の表示を参照してください。

ハイライト: 選択したシートのハイライトをオンにします。値のハイライト方法を定義するには、ドロップダウン メニューからオプションを選択します。詳細については、[ハイライト] ツールバー ボタンを参照してください。

メンバーのグループ化: 選択した値を組み合わせてグループを作成します。複数のディメンションが選択されているときは、ドロップダウン メニューを使用して、特定のディメンションでグループ化するか、またはすべてのディメンションにわたってグループ化するかを指定します。詳細については、データのグループ化によりデータエラーの修正またはディメンション メンバーを組み合わせるを参照してください。

: Tableau Desktop のみ。Tableau Server および Tableau Online では、ツールヒントの [メンバーのグループ化] ボタンを使用してグループを作成します。

マーク ラベルを表示: 現在のシートのマーク ラベルの表示と非表示を切り替えます。詳細については、マーク ラベルの表示、非表示、および書式設定を参照してください。

軸の修正: 特定の範囲を表示しているロックされた軸とビュー内の最小値と最大値に基づいて範囲を調整する動的な軸を切り替えます。詳細については、軸の編集を参照してください。

: Tableau Desktop のみ。

ワークブックの書式設定: [ワークブックの書式設定] ペインを開き、ワークシート レベルではなく、ワークブック レベルで書式設定を指定することにより、ワークブックにあるすべてのビューのフォントとタイトルの外観を変更します。

: Tableau Server および Tableau Online のみ。Tableau Desktop では、[書式設定] > [ワークブック] をクリックします。詳細については、ワークブック レベルで書式設定を参照してください。

ウィンドウに合わせる: ウィンドウに表示するビューのサイズを指定します。[標準]、[幅を合わせる]、[高さを合わせる]、[ビュー全体] のいずれかを選択します。: このメニューは地理的マップ ビューでは使用できません。

視覚化のタイプによって、[セルのサイズ] コマンドの結果が異なります。Tableau Desktop で [セル サイズ] メニューにアクセスするには、[書式設定] > [セル サイズ] をクリックします。

カードの表示/非表示:ワークシートの特定のカードの表示と非表示を切り替えます。ドロップダウン メニューで表示または非表示にするカードを選択します。

Tableau Server および Tableau Online では、[タイトル][キャプション][フィルター]、および [ハイライター] の場合のみ、カードの表示と非表示を切り替えることができます。

プレゼンテーション モード: ビュー以外のすべて (シェルフ、ツールバー、[データ] ペインなど) の表示と非表示を切り替えます。詳細については、ワークスペースの再編成を参照してください。

: Tableau Desktop のみ。

ダウンロード: [ダウンロード] の下にあるオプションを使用して、他のアプリケーションで使用するためにビューの部分を取得します。
  • イメージ: 新しいブラウザー タブにビュー、ダッシュボード、またはストーリーをイメージとして表示します。
  • データ: ビューからのデータを 2 つのタブがある新しいブラウザー ウィンドウに表示します。[サマリー] は、ビューに表示されたフィールドの集計データを表示し、[参照元] は視覚化で選択されたマークの参照元データを表示します。新しいウィンドウが開かない場合は、ブラウザーのポップアップ ブロッカーを無効にする必要があります。
  • クロス集計: 視覚化で選択されたマークの参照元データを、後で Microsoft Excel で開くことのできる CSV (コンマ区切り値) ファイルに保存します。
  • PDF: 現在のビューを PDF として新しいブラウザー ウィンドウで開きます。ここから、ファイルに保存することができます。新しいウィンドウが開かない場合は、ブラウザーのポップアップ ブロッカーを無効にする必要があります。

: Tableau Server および Tableau Online のみ。

ワークブックを他のユーザーと共有: Tableau Server または Tableau Online にワークブックをパブリッシュします。詳細については、ワークブックをパブリッシュするためのシンプルな手順を参照してください。

: Tableau Desktop のみ。

表示形式: データ内のフィールド タイプで最適なビュー タイプをハイライトすることにより、ビュー タイプの選択を助けます。データに最適と判断される推奨グラフ タイプの周辺に、オレンジ色のアウトラインが表示されます。詳細については、表示形式を使用したビューの開始を参照してください。

先頭に戻る


サイドバー ([データ] ペイン) の表示と非表示

ワークシートを編集しているときは、サイドバーに [データ] ペインと [アナリティクス] ペインが含まれています。ビューで実行している内容 (データ、アナリティクス、ストーリー、ダッシュボード、レイアウト、書式設定) に応じて、さまざまなペインを表示できます。サイドバーについて理解しておくべき最も重要な事項は、ワークスペースのこの領域を展開または折りたたみできることです。

Tableau Desktop でサイドバーを非表示にするには、サイドバーの折りたたみ矢印をクリックします。

Web でサイドバーを非表示にするには、サイドバーの折りたたみ矢印をクリックします。

Tableau Desktop でサイドバーを表示するには、ワークスペース左下 (ステータス バー) の展開矢印をクリックします。

Web でサイドバーを表示するには、サイドバーの展開矢印をクリックします。

先頭に戻る


ステータス バーの情報

ステータス バーは Tableau ワークスペースの下部にあります。メニュー項目の説明と現在のビューの情報が表示されます。たとえば、下のステータス バーはビューに 143 のマークが 3 行と 12 列で表示されています。また、すべてのマークの SUM(Sales) が $2,297,201 であることを示しています。

[ウィンドウ] > [ステータス バーの表示] を選択すると、ステータス バーを非表示にできます。

Tableau では、ステータス バーの右下隅にエラーや警告を示す警告アイコンが表示されることがあります。次に可能性のある警告アイコンとその意味を示します。

警告アイコン 説明

クエリのキャンセルのインジケーター: 複数のクエリをキャンセルすると、データベースで引き続き実行されていてリソースを使用しているクエリの数がインジケーターに表示されます。

Tableau でクエリをキャンセルすると、クエリの処理を停止するようにデータベースに通知されます。ただし、一部のデータベースではキャンセルがサポートされていません (MS Excel、MS Access、Essbase、Microsoft Analysis Services 2000)。これらの種類のデータ ソースのいずれかを使用してクエリをキャンセルすると、クエリは Tableau によって破棄されますが、引き続きバックグラウンドで実行され、リソースを消費します。クエリを破棄すると、ワークブックの右下隅にインジケーターが表示され、実行中のクエリの数を示します (A graphic depicting the cancel query indicator that displays in the status bar.)。バックグラウンドで実行されるクエリが完了すると、インジケーターの数が減少します。実行中のクエリ数を監視し、その数が多くなり過ぎないように注意することは重要です。実行中のクエリ数が多くなると、Tableauと参照元データベースの両方でパフォーマンスが低下します。

注: テキスト、Microsoft Excel、および Microsoft Access のデータ ソースは、内部でロックが実行されるため、クエリのキャンセル後に一時的に使用できなくなる場合があります。再接続する前に、廃棄したクエリの処理が完了するまで待機する必要がある場合があります。

精度の警告: データベースのフィールドの精度が、Tableau でモデル化できる限度を越えている場合があります。その精度が Tableau でモデル化できる限度を越えている値を含んでいるビューにフィールドを追加すると、警告アイコン A graphic depicting a precision warning that displays in the status bar. がステータスバーの右下隅に表示されます。

たとえば、データベースの値の小数点以下の桁数が 22 桁で、Tableau では 15 桁までしかサポートしていないとします。このようなフィールドをビューに追加すると、精度警告が表示されます。警告をクリックすると、ビューで切り捨てられた小数点以下の桁数を含む詳細な情報が表示されます。

Tableau に表示されるデータの精度は、最初は必ずデータベースのデータに依存します。たとえば、データベースの値の小数点以下の桁数が 15 桁を越える場合、それらの値をビューに追加すると、値は切り捨てられ、精度警告が表示されます。

特別な値のインジケーター: データに NULL 値、不明な地理的場所、または対数軸上の負の値またはゼロ値が含まれる場合、この値はビューの右下隅にインジケーターと共に表示されます。インジケーターをクリックすると、これらの値を処理するオプションが表示されます。このインジケーターとこれらの値の処理方法の詳細については、NULL 値およびその他の特殊な値の取り扱いを参照してください。

先頭に戻る


このセクションの他の記事

フィードバックをくださりありがとうございます! フィードバックの送信中にエラが発生しました。もう一度やり直すか、メッセージをお送りください