Creators: Web 作成入門

Web での Tableau で実行可能なことはたくさんあります。Creator は、データに直接接続して、分析を強化したり、魅力的なデータ ビジュアライゼーションを作成したり、それらのインサイトを他のユーザーと共有したりできます。このガイドでは Tableau Online 環境での分析用データへの接続と準備、ワークブックの作成、それらのインサイトの他のユーザーとの共有を扱っています。

ユーザー レベルがわからない場合確認するには、イニシャルまたはプロフィール写真があるサイト右上隅のアイコンを選択し、[マイ アカウントの設定] を選択します。サイト ロールからは、ユーザーが CreatorExplorer、または Viewer (ビューアー) であるかがわかります。

ステップ 1: サインインとプロジェクトの参照

まず、ユーザー名とパスワードを入力して Tableau サイトにサインインします。次に、ナビゲーション ペインで [検索] をクリックして、サイト全体でアクセスできるすべてのコンテンツを表示します。

最初は、[上位プロジェクト] が表示されます。これらのプロジェクトを参照するか、他のコンテンツ タイプを選択できます。

Content type selection

ワークブック、データ ソース、データの役割、およびフローはプロジェクトに属しており、プロジェクトはネストされたプロジェクトにも含めることができます。デスクトップのフォルダーと同様、プロジェクトはサイトのコンテンツを並べ替え、管理するための方法です。既存のサイトに招待されている場合、チームメイトが作成したプロジェクトが表示される場合があります。

サイトには既定のプロジェクトがあり、追加プロジェクトを使用できない場合には、このプロジェクトを探索に使用できます。

ステップ 2: 新しいワークブックの作成とデータへの接続

一部の方法では、データを分析してワークブックを構築するためにデータに接続する必要があります。Creator は Tableau で Web 上のデータ ソースに直接接続したり、Tableau Desktop より Tableau Online にパブリッシュしたデータ ソースに接続することができます。

開始するには、[作成] ボタンをクリックして [ワークブック] を選択します。

Creat Workbook button

[データに接続] ウィンドウが表示されます。

Animation of Connect to Data window

データに接続でき、これによりワークブックが次のいくつかの方法で強化されます。

  • [ファイル] タブから Excel やテキストベースのデータ ソースをアップロードする

  • [コネクタ] タブからサーバーまたはクラウド データ ソースに接続する

  • [このサイト上] タブを使用してパブリッシュされたデータ ソースに接続する

  • Tableau Online で [ダッシュボード スターター] タブより Oracle Eloqua、Salesforce、ServiceNow ITSM、Marketo のデータを作成および分析する

Web 上のデータへの接続の詳細については、「Creators: Web 上のデータへの接続」を参照してください。

ステップ 3: データの準備

データに接続した後、[データ ソース] ページを使用して分析用データの準備を行います。

データ ソース ページの各部分

[データ ソース] ページには以下の 4 つのエリアがあります。 

  1. 左側のペイン: データの詳細を表示します。ファイル ベースのデータの場合は、左側のペインに、ファイル名とファイル内のワークシートが表示されることがあります。リレーショナル ベースのデータの場合は、左側のペインに、サーバー、データベースまたはスキーマ、およびデータベース内のテーブルが表示されることがあります。

  2. キャンバス: 接続先がリレーショナル データやファイル ベース データの場合は、通常、1 つまたは複数のテーブルをキャンバスにドラッグして、分析用に Tableau データ ソースを設定できます。

  3. データ グリッド: Tableau データ ソースに含まれているフィールド、およびデータの最初の 1,000 行を確認するには、グリッドを使用できます。

  4. メタデータ グリッド: ボタンを使用するとメタデータ グリッドに移動しますが、ここではデータ ソース内のフィールドが行として表示されるため、データ ソースの構造を簡単に確認できます。

[データ ソース] ページでは分析用データを次の方法で準備できます。 

  • データ ソース名の変更

  • Data Interpreter を使用したデータのクリーンアップ

  • テキスト ファイルのオプション設定

  • データの結合

  • データ列の編集

Web 上での分析用データの準備の詳細については、「Creators: Web 上のデータの準備」を参照してください。

データの分析準備が整い、画面下部にある [シート 1] をクリックすると、ビューを構築するための Tableau ワークスペースに移動します。

ステップ 4: ビューの作成

データに接続し、それを分析用に設定すると、データのビジュアル分析を作成する準備が整います。Tableau ではこれをビューと呼びます。Tableau Desktop を使用したことがあれば、ワークスペース領域はとても似ています。

ワークスペース領域

Tableau ワークスペースのレイアウトは以下のとおりです。

  1. ワークブック名。ワークブックにはシートが含まれています。シートは、ワークシート、ダッシュボード、ストーリーのいずれかです。詳細については、「ワークブックとシート」を参照してください。

  2. ページ シェルフ、フィルター シェルフ、マーク カード - ビューにデータを追加するには、フィールドをワークスペース内のカードおよびシェルフにドラッグします。詳細については、「シェルフとカードの参照」を参照してください。

  3. 列と行シェルフ: ビューにデータを追加するには、フィールドをワークスペース内のカードおよびシェルフにドラッグします。詳細については、「シェルフとカードの参照」を参照してください。

  4. ツールバー: コマンドや分析およびナビゲーション ツールにアクセスするには、ツールバーを使用します。「Tableau ツールバー ボタン リファレンス」を参照してください。

  5. ビュー: データの視覚化を作成するためのワークスペースです。

  6. サイドバー: ワークシートのサイドバー領域には、[データ] ペインと [アナリティクス] ペインが含まれています。

  7. [データ ソース] ページに移動します。詳細については、「Creators: Web 上のデータの準備」を参照してください。

  8. シート タブ: タブは、ワークブック内の各シートを表します。これには、ワークシート、ダッシュボード、およびストーリーが含まれます。

ビューの作成を開始するための異なる方法

フィールドをビューまたはシェルフにドラッグするときは常に、そのデータに関して質問します。質問は、さまざまなフィールドをドラッグする場所、フィールドのタイプ、フィールドをビューにドラッグした順序によって異なります。

質問を尋ねるごとに、回答を視覚的に表示するためにマークが付けられビューが変更されます (形状、テキスト、階層、表構造、軸、色)。

ワークシートで、データ ソースの列は[データ] ペインの左側にフィールドとして表示されます。[データ] ペインには、さまざまな異なる種類のフィールドが含まれています。 今、最も重要なものは [ディメンション][メジャー] です

ディメンションには通常、製品タイプや日付などのカテゴリー データが格納され、メジャーには、売上高や収益などの数値データが格納されます。(詳細については、「フィールド タイプ: ディメンションとメジャー、青と緑」を参照してください。)

ビューを構成する際、[データ] ペインのフィールドを追加します。これはさまざまな方法で行うことができます。例:

  • [データ] ペインからフィールドをドラッグし、各 Tableau ワークシートの一部であるカードとシェルフにドロップすることができます。

  • [データ] ペインで 1 つ以上のフィールドをダブルクリックできます。

  • [データ] ペインで 1 つ以上のフィールドを選択し、その後、選択したフィールドに適したグラフ タイプを特定する [表示形式] からグラフ タイプを選択することができます。詳細については、「表示形式を使用したビューの開始」を参照してください。

データのフィルタリング

ビューで特定のデータを表示する場合にのみ、フィルターが必要になるかもしれません。以下を含む、多くの方法でデータをフィルターできます。

フィールドを [フィルター] シェルフに追加すると、ビュー内にインタラクティブ フィルターが表示されます。その後、ビューに含めるまたは除外するアイテムを選択できます。

  • Web での Tableau でフィルターを作成するには、ディメンション、メジャー、または日付フィールドをフィルター シェルフにドラッグします。

    フィールドを [フィルター] シェルフに追加すると、ビュー内にインタラクティブ フィルターが表示されます。含めるまたは除外するアイテムをビューで選択したり、値の範囲を選択したりできます。

  • 1 つのマーク (データ ポイント) を選択してパブリッシュされたビューを操作したり、ビューをクリック アンド ドラッグして複数のマークを選択することもできます。表示されるツールヒントで、[保持] を選択してビュー内で選択したマークのみを保持するか、[除外] を選択して選択したマークをビューから削除することができます。

Tableau の操作順序など、Tableau でのフィルタリングの詳細については、「ビューからのデータのフィルター」を参照してください。

マーク カードを使用する

[マーク] カードを使用して、コンテキストや詳細をビューのマークに追加できます。[マーク] カードを使用してマーク タイプを設定し、データを色、サイズ、形状、詳細、テキストでエンコードします。

フィールドを [マーク] カードに追加した後は、フィールドの隣にあるアイコンをクリックして、使用しているプロパティを変更できます。また、[マーク] カードのプロパティ ボタンをクリックしてこれらの設定を変更することもできます。

多くのプロパティは、複数のフィールドを持つことができます。たとえば、[ラベル]、[詳細]、[ツールヒント]、および [色] には複数のフィールドを追加できます。[サイズ] および [形状] は、一度に 1 つのフィールドのみを持つことができます。詳細については、「ビュー内のマークの表示を制限する」を参照してください。

作業内容を元に戻す

Tableau は極めて柔軟で、非常に寛容でもあります。ビューを作成する際に、質問に回答していないパスを通ると、常に、探索の直前のポイントに戻すことができます。

  • 元に戻すまたはやり直すには、ツールバーで [元に戻す] または [やり直す] をクリックします。

ワークブックを開いた最終時点まで遡って元に戻すことができます。何度でも元に戻す、またはやり直すことができます。

Web 上のビューを構築および編集する

Tableau ではさまざまな方法でデータを探索できます。Web での特定のチャート タイプの構築に関する指示については、Web での Tableau ビューの編集を参照してください。または、Tableau でビジュアライゼーションを構築するのに役立つ多くの機能については、「ゼロからのデータ ビューの作成」を参照してください。

データ ビューの構築方法を説明した、6 分間の無料トレーニング ビデオ「ビジュアル分析入門トレーニング」 をご覧ください。お使いの tableau.com アカウントを使用してサインインします。

ステップ 5: 作業内容の提示

ストーリーを伝え、ビューで見つけたデータのインサイトについて他のユーザーを納得させる多くの方法があります。

作業の書式設定

ビューの部分、ワークブックのフォント、グラフの線を含め、ワークブックで表示されるものはほとんどすべて書式設定できます。

ダッシュボード

ダッシュボードは、さまざまなデータを同時に比較して監視できるように 1 つのスペースに表示された複数のワークシートとサポート情報の集合です。

新しいダッシュボード シートを開いてダッシュボードの作成を開始するには、ワークブックの一番下にある [新しいワークシート] アイコンをクリックします。

[ダッシュボード] エリアが左に表示され、ワークブックのシートをリストします。シート上のさまざまなビューを関連付けるために、ダッシュボードに 1 つ以上のビューを追加したり、Web ページ、空白スペース、およびレイアウト コンテナー、または双方向性を追加することができます。

ストーリー

ストーリーとは、情報を伝達するために組み合わせて使用することができる連続したワークシートとダッシュボードです。ストーリーを使用すると、どのように事実が結びついているか、決断によりデータを物語風に伝えるためのストーリーをどのように作成するかを見せることができるため、強力な説明を行ったり、背景を提供したり、決定と結果の関連を示したり、データでより強力な説明を加えることができます。

ストーリーを作成したり、ストーリーについて学習しましょう

ステップ 6: 作業内容の保存

[ファイル] > [名前を付けて保存] を選択して、いつでもワークブックを保存できます。ワークブックは作成されたフォルダーに保存されます。

後で別のワークブックを作成するためにデータ ソースを保存したり、チームのメンバーを有効にして各自が分析用にそのデータを使用することもできます。

データ ソースを保存するには、ワークスペースの [データ] タブで矢印が表示されるまでデータ ソース名にカーソルを合わせます。矢印を選択し、[保存] を選択します。

注: Web 上にデータ ソースを保存する場合、データ ソースは、[データに接続] ウィンドウのパブリッシュされたデータ ソースおよび [データ ソース] セクションに表示されます。

完了したら、[ファイル] > [閉じる] を選択してワークスペースを終了します。

ステップ 7: 共同作業と結果の共有

作業内容を共有し、最新の状態を保つ多くの方法があります。

共同作業

組織にいる他の CreatorExplorer は、プロジェクトへのアクセス権を付与される場合に、ワークブックやビューを編集または更新できます。アクセス権はサイト管理者により制御され、サイト管理者はプロジェクト パーミッションの設定、プロジェクト間でのコンテンツの移動、ユーザーのロールの変更を行うことができます。データ ソースを保存する場合、それらのユーザーはデータに接続し、そのデータを使用して新しいワークブックを作成できます。

ビューの共有とインサイト

サイトに保存されたすべてのビューおよびワークブックは、メールのリンクや他のアプリケーションで共有したり、Web ページ、ウィキ、Web アプリケーションに直接埋め込むことができます。

ユーザーがビューを見るには、Tableau Server または Tableau Online でそのビューにアクセスするパーミッションが必要です。

詳細:

フィードバックをくださりありがとうございます! フィードバックの送信中にエラが発生しました。もう一度やり直すか、メッセージをお送りください