ビューでのデータの探索と分析

ビューを探索および分析する準備が整ったら、Tableau で目的のデータを分離するのに役立つ一連の動的データ検査ツールを使用できます。たとえば、密集したデータ ビューでは、特定の地域に注目し、外れ値のグループを選択し、各マークの参照元データ ソース行を表示します。

ビデオを視聴する: Tableau での関連する概念について説明した、6 分間の無料トレーニング ビデオ「ビジュアル分析入門トレーニング」(Link opens in a new window)をご覧ください。お使いの tableau.com(Link opens in a new window) アカウントを使用してサインインします。

マークの選択によるビュー内のデータ ポイントのハイライト

ビューにハイライトを追加する最も簡単な方法は、ハイライトするマークを選択することです。ビューでマークを手動選択すると、他のマークはすべて薄く表示され、選択項目への注意を喚起することができます。選択内容はワークブックに保存されます。

選択ツールの使用方法の詳細については、マークの選択(Link opens in a new window)を参照してください。また、凡例のハイライト(Link opens in a new window)コンテキスト内のデータ ポイントをハイライトする(Link opens in a new window)[ハイライト] ツールバー ボタン(Link opens in a new window)、およびハイライト アクションも参照してください。

キーボードの Ctrl キーを押したまま (Mac では Command キー)、各マークを選択することで、複数のマークを選択できます。高度な選択ツールのいずれかを使用して、特定の形状内のマークを選択することもできます。

Eaxmple of selecting multiple marks in a view

マークとヘッダーを選択して、ビューに表示される内容をフィルターすることもできます。詳細については、ビューにデータ ポイントを含めるか、データを除外するよう選択しますおよびヘッダーを選択してデータをフィルターするを参照してください。

ツールヒントを使用した選択したマークの分析

ビュー内で 1 つまたは複数のマークを選択し、同じ部分にカーソルを合わせていると、ツールヒントにデータを調べるためのいくつかのオプションが表示されます。

Tableau Desktop のバージョン Web バージョン

Tooltip example for Tableau Desktop

Tooltip example for web authoring

ツールヒントには、ビュー内のマークに関する追加情報が表示され、ここから次のデータ分析オプションを使用できます。

ツールヒントに関する詳細については、ツールヒントを参照してください。

関連する分析ツールの詳細については、ビューのズームとパン、マークの選択、「マークの選択」、元に戻す/やり直すドロップ ラインを参照してください。

ツールヒントでのカテゴリ別のデータのハイライト

不連続 (カテゴリー) のディメンションまたはメジャーをツールヒントに含めると、これらを使用して同じ値を持つビューのマークを選択できます。ツールヒントの選択がワークシートで有効になっている場合、これらのフィールドにマウスをかざすと下線付きのテキストで表示されます。ツールヒントの選択をクリックすると、同じ値を持つビュー内のすべてのマークが選択されます。

下の例では、[Bill Shonely] ("Customer Name (顧客名)" の値) をツールヒントでクリックすると、そのビュー内で Bill Shonely を顧客として含めているすべてのマークが選択され、他のマークはすべて薄く表示されます。

Tooltip filter example

この機能を無効または有効にするには、[ツールヒントの編集] ダイアログ ボックスで、[カテゴリ別の選択を許可] チェック ボックスをオンにします。ツールヒントのプロパティ設定の詳細については、ツールヒントをマークに追加を参照してください。

マップ内のデータの探索

Tableau のマップは、世界中のデータをすばやく見つけて、分析できるように支援します。マップ ビューを探索および操作する方法は数通りあります。ビュー ツールバーからマークをズームイン、ズームアウト、パン、および選択したり、マップ検索を使用して世界中の場所を検索できます。

Tableau maps example

詳細については、マップ内のデータの探索マップ内の場所の検索、およびマップ内のデータ ポイントおよび位置間の距離の測定を参照してください。

アナリティクス オブジェクトのビューへの追加 (傾向線、予測値、リファレンス ラインおよびリファレンス バンド)

ワークスペースの左側に表示されている [アナリティクス] ペインから、リファレンス ライン、ボックス プロット、傾向線、予測などのオブジェクトをビューにドラッグできます。[データ] ペインと [アナリティクス] ペインを切り替えるには、サイド バーの上部にあるタブをクリックします。詳細については、高度な分析のビューへの適用 ([アナリティクス] ペイン)を参照してください。

Analytics pane

Tableau Desktop の [アナリティクス] ペイン

Tableau Desktop では、アナリティクス オブジェクトをビューに追加するオプションを [アナリティクス] ペインまたはメニュー、あるいはビューのコンテキストで使用できます。たとえば、軸を編集するときはリファレンス ラインおよびバンドを使用でき、傾向線と予測値は [アナリティクス] メニューから使用できます。

[アナリティクス] ペインでは、ドラッグ & ドロップでさまざまなオプションにアクセスできます。

Web では、ほとんどのアナリティクス オブジェクトを [アナリティクス] ペインから使用できます。

マーク データと再計算されたラインの比較

ビュー内に平均線、定数線、傾向線、リファレンスライン、リファレンスバンド、分布ライン、分析バンドなどのアナリティクス オブジェクトがあるときに、ビュー内で 1 つまたは複数のマークを選択すると、選択したマークをビュー全体のデータと照合した分析データの比較が即時に行えます。

たとえば、傾向線を含むビュー内でマークを選択すると、再計算された 2 つ目の傾向線が作成されます。この傾向線の値は選択したマークのみから決定されるため、この傾向線が示す傾向を全体の傾向と比較することができます。

Comparing two views with a recalculated trend line

アナリティクス オブジェクトが既に含まれているビュー内でマークを選択すると、再計算されたラインが既定で表示されます。Tableau Desktop で、再計算された線を作成しない場合、オフにすることができます。

再計算された線をオフにする (Tableau Desktop のみ):

  1. ビューのアナリティクス オブジェクトを選択し、[編集] をクリックします。

  2. [編集] ダイアログ ボックスで、[ハイライトまたは選択したデータ ポイントに対する再計算されたラインの表示] をオフにします。

    Edit dialog box selection

  3. または、ビューでアナリティクス オブジェクトを右クリック (Mac では Control を押しながらクリック) して [セットの In/Out を表示] を選択します。

    ビューに戻り、マークを選択またはハイライトすると、再計算されたラインは表示されません。詳細については、ハイライト アクション(Link opens in a new window)を参照してください。

再計算されたラインおよびハイライト アクション

再計算されたラインは、ワークシートとダッシュボードのどちらでも、ハイライト アクションと一緒に操作することもできます。

たとえば、1 つのシート内でマークを選択することによって、ダッシュボード内でハイライト アクションを作成すると、そのダッシュボード内の他のシート内のマークがハイライトされます。これらのシートに傾向線、リファレンスライン、その他のアナリティクス オブジェクトが含まれている場合、再計算されたラインは、ビューの更新時に表示されます。

Recalculated lines and higlight actions example

[データの詳細] を使用したビジュアライゼーション情報の表示

2019.3 以降、Tableau Catalog は、Tableau Online と Tableau Server に対する Data Management アドオンで使用できます。Tableau Catalog が環境で有効になっている場合、[データの詳細] ペインにビジュアライゼーション情報を表示できます。Tableau Catalog の詳細については、Tableau Server または Tableau Online ヘルプの「Tableau Catalog について」を参照してください。

パブリッシュされたビューを確認しており、お使いの環境で Tableau Catalog が有効になっている場合、ワークブックやダッシュボードのビュー上部にあるツールバーで [データの詳細] を選択すると、ビューで使用されているデータに関する情報を表示できます。詳細は次のとおりです。

  • 過去 12 週間にシートまたはダッシュボードが表示された回数を示すスパークライン。
  • ワークブックに関する情報 (名前、プロジェクト、作成者、変更日、データ品質に関する警告)。
  • シートまたはダッシュボードで使用されたデータ ソース。
  • 使用中のフィールドのリスト。フィールドを選択すると、説明や計算などのフィールド メタデータが表示されます。

Data Details example pane

[データの詳細] ペインのリンクをクリックすると、そのアイテムが別のウィンドウで開かれます。

ビュー、ワークブック、またはダッシュボードで使用されているいずれかのデータの系列にデータ品質に関する警告がある場合、[データの詳細] タブには、白い感嘆符を囲む青い円が表示されます。[データの詳細] タブ、次にデータ品質に関する警告をクリックし、警告の詳細を表示します。

See data quality warning details

高い可視性のデータ品質警告

データ アイテムの所有者や管理者が、データ品質に関する警告が重要であることを示すタグを付けた場合は、次のようになります。

  • 影響を受けるアセットが使用されているパブリッシュ済みのビューを開くと、[データの詳細] ペインへのリンクを含む通知が表示されます。

    Data quality warning info message appears on view
  • [データの詳細] ペイン (また、Tableau の他の場所) では、黄色の警告記号によってその警告の可視性が高まります。

    High visibility data quality warning on the Data Details pane

フィールドにはアップストリームの説明を表示できます。

ビューで使用されているフィールドにワークブック内の説明が含まれていなくても、説明が存在する場合は Catalog でアップストリームのフィールドまたは列から説明を検索して表示できます。パブリッシュされたデータ ソースがアップストリームであり、そこにこのフィールドの説明が含まれている場合、[データの詳細] ペインにはそのフィールドの説明が表示されます。説明が含まれていない場合は、このフィールドには、アップストリームのテーブル内でフィールドが参照する列からの説明が表示されます。

フィールドがアップストリーム ソースから説明を継承すると、説明の継承元を示す情報アイコンが [説明] の横に表示されます。

Information icon text describes where description came from

計算フィールド、グループ フィールド、またはセット フィールドなどの一部のフィールドでは、アップストリーム ソースからの説明の表示はサポートされていません。また、ワークブックとデータ ソースでは、アップストリームのフィールドや列の説明を表示することはできません。

説明の追加については、Web コンテンツの管理の「説明の追加または編集」を参照してください。

このセクションの他の記事

ありがとうございます!