Tableau のビジュアライゼーションを見て、どのようなデータが各マークまたはすべての Viz を構成しているかを考えたことがありますか? 一般的な Viz は基本的に、ビュー内のディメンションの構造に基づいて、集計されたメジャーで構成されています。Viz に表示されるすべてのマークには、基になる列と行のデータが含まれています。[データの表示] ウィンドウには、このデータが表形式で表示され、現在の選択または現在のビューに範囲が設定されます。

必要なパーミッションを持っている場合は、ワークシート、ダッシュボード内のシート または [データ ソース] ページで、参照元データを表示できます。ワークシートでは、[データの表示] ウィンドウをカスタマイズして、そのカスタマイズしたビューを CSV 形式でダウンロードできます。カスタマイズされた並べ替えの結果は、ダウンロードされたデータには含まれないことに注意してください。

既定では、[データの表示] ウィンドウには、Tableau Desktop では最大 10,000 行のデータが表示され、Tableau Online および Tableau Server では最大 200 行のデータが表示されます。

:Tableau バージョン 2020.2 以降、Tableau バージョン 2020.1 以前のデータ ソースを開くと、列の順序が異なる場合があります。[データの表示] ウィンドウでは列の表示方法が異なるため、データを CSV 形式にエクスポートすると列の順序が変わる場合があります。Tableau バージョン 2022.1 以降では、データをエクスポートする前に、列の順序を手動でカスタマイズできます。

関係と論理テーブルをサポートするには、このような [データの表示] ウィンドウの列の順序変更が必要となります。カスタマイズされた列の順序に依存するスクリプトを使用する場合は、データの表示に Tableau 拡張機能 API を使用して、参照元データを CSV 形式にダウンロードすることをお勧めします。

[データの表示] ウィンドウを開くことができる場所

[データの表示] ウィンドウに表示されるデータは、開いた場所のコンテキストによって異なります。

コンテキスト 範囲 方法

ワークシート: 選択した 1 つまたは複数のマーク

Tableau Online、Tableau Server、Tableau Desktop

ワークシートで、1 つ以上のマークを選択し、ツールヒント メニューから [データの表示] を選択すると、個々のマークまたはマークのグループに範囲が設定された参照元データが表示されます。

: [データの表示] ボタンを使用できるようにするには、ツールヒントで [コマンドボタンを含める] オプションを選択する必要があります。

このビューはカスタマイズしてダウンロードできます。

ビューで 1 つ以上のマークを選択し、ツールヒント メニューから [データの表示] を選択します。

データ ソース ページ:テーブルごと

Tableau Online、Tableau Server、Tableau Desktop

[データ ソース] ページで、データ ソース (左側のペイン) にリストされている各テーブルの [データの表示] を開くことができます。

このビューで列を移動および並べ替えることはできますが、データをダウンロードすることはできません。

[データ ソース] ページの左側のペインで、テーブルの横にある [データの表示] を選択します。

[カスタム SQL] ダイアログ ボックスの [結果のプレビュー] をクリックして、カスタム SQL の [データの表示] ウィンドウを表示することもできます。

ワークシート: ツールバーの ダウンロード ボタン

Tableau Online と Tableau Server

ワークシート (表示モードまたは編集モード) で、[ダウンロード] ボタン メニューから [データ] を選択すると、Viz で使用されているすべての参照元データが表示されます。

ダッシュボードでは、選択したワークシートに基づいて参照元データを表示できます。[ダウンロード] ボタンをクリックして [データ] オプションを使用可能にする前に、ダッシュボードでシートを選択します。

このビューはカスタマイズしてダウンロードできます。

[ダウンロード] ボタン メニューから、[データ] を選択します。

ワークシート: データ ペイン

Tableau Desktop のみ

ワークシートで、[データ] ペインの上部にある [データの表示] を選択すると、データ ソースの各フィールドの表形式のデータがテーブルごとに表示されます。

このビューはカスタマイズしてダウンロードできます。

[データ] ペインで、[検索] フィールドの横にある [データの表示] ボタンをクリックします。

ワークシート: 分析メニュー

Tableau Desktop のみ

ワークシートで、[分析] メニューから [データの表示] を選択すると、Viz で使用されるすべての参照元データが表示されます。Viz で使用されるメジャーに対応する 1 つまたは複数のテーブルが [タブ] ペインに一覧表示されます。

このビューはカスタマイズしてダウンロードできます。

[分析] メニューから、[データの表示] を選択します。

テキスト テーブルではない Viz では、ビューを右クリックして、[データの表示] を選択することもできます。

ワークシートで [データの表示] を開く

ワークシートで [データの表示] を開くと、[データの表示] ウィンドウの表示をカスタマイズして、そのカスタマイズされたビューをダウンロードできます。

[データの表示] ウィンドウには、ウィンドウの左側に複数のタブが表示されます。タブの数とタイプは、現在の範囲によって異なります。

  • [サマリー] タブには、ビューを定義するディメンションに加えて、マークを構成する集計メジャーまたはメジャーが表示されます。
  • ビューにメジャーが存在する各テーブルのタブ。このタブには、そのテーブルのすべてのフィールドが表示されます。[フル データ] タブは、単一テーブルのデータ ソースに対して表示されます。
    すべてのフィールドを表示するには、[フィールドを表示][(すべて)] を選択します。[(すべて)] をオンにすると、各タブには、ディメンションがどのテーブルから来ているかに関係なく、ビューを定義するすべてのディメンションが表示されます。
  • フィールド名は列のヘッダーとして表示されます。列の上部にカーソルを合わせると、ドロップダウン メニューと [並べ替え] ボタンが表示されます。列のヘッダーの任意の場所をクリックして、ドロップダウン メニューを表示することもできます。
  • ビューで使用される計算の一部は、タブにも表示されます。
    • 集計計算やテーブルをまたいだ計算など、[データ] ペインのテーブルに属していない計算。
    • LOD 計算 (FIXED または INCLUDEのみ) ([データ] ペインのテーブルに存在する場合でも)アドホック LOD 計算は、[データの表示] には表示されません。
    • 計算に使用される関連フィールドは、元のテーブルと計算自体の値に関係なく、すべて表示されます。

1 つまたは複数のマークの [データの表示] を Viz で開く

マークをクリックすると、そのツールヒントが表示されます。ツールヒント メニューで、[データの表示] アイコン をクリックします。複数のマークを同時に選択し、ツールヒント メニューの [データの表示] をクリックして、結合された [データの表示] の結果を表示することもできます。

: [データの表示] ボタンを使用できるようにするには、Viz のツールヒントで [コマンドボタンを含める] オプションを選択する必要があります。

ビュー全体の [データの表示] を開く

Tableau Online と Tableau Server

ビュー全体の参照元データを表示するには、表示モードまたは編集モードで、ツールバーの [ダウンロード] ボタンをクリックし、[データ] を選択します。ビューでマークを選択していないことを確認してください。選択している場合、データは選択した範囲に絞られます。

ダッシュボードでは、選択したワークシートに基づいて参照元データを表示できます。[ダウンロード] ボタンをクリックして [データ] オプションを使用可能にする前に、ダッシュボードでシートを選択します。

Tableau Desktop

ビュー全体の参照元データを表示するには、[分析] メニューから [データの表示] をクリックします。[データの表示] ウィンドウには、マークのデータの表示と似た結果が表示されますが、ビューに使用するすべてのデータが表示されます。

[データ] ペインの [データの表示] を開く

データ ソースの各フィールドの参照元データをテーブルごとに表示するには、[データ] ペイン上部の [検索] フィールドの横にある [データの表示] アイコン をクリックします。

[データ] ペインの [データの表示] は、Tableau Desktop でのみ開くことができます。

[データ ソース] ページで [データの表示] を開く

[データの表示] ウィンドウは、データ ソースのテーブルごとに開くことができます。分析前や分析中にデータ ソースのデータを表示すると、各テーブルの範囲、フィールドおよびその値、データに関する全体的な印象を把握しやすくなります。

[データ ソース] ページで [データの表示] を開くと、[データの表示] ウィンドウでフィールド列を移動および並べ替えることはできますが、データをダウンロードすることはできません。

[データ ソース] ページで、左ペインのテーブルやシートにカーソルを合わせると、[データの表示] アイコン が表示されます。

[データの表示] ウィンドウには、そのテーブルのデータが表示されます。

[データの表示] ウィンドウをカスタマイズする

ワークシートで [データの表示] を開くと、すべてのカスタマイズ オプションが利用可能になり、ダウンロードされているデータに使用できます。

カスタマイズした内容は、[データの表示] ウィンドウを閉じるまで保持されます。[データの表示] ウィンドウを閉じると、カスタマイズした内容がすべて破棄されます。

: [データ ソース] ページの [データの表示] で使用できるオプションは、フィールドの並べ替えと移動のみです。

 

オプション 方法 場所

フィールド列を表示または非表示にする

[フィールドを表示] をクリックして、フィールド名のチェックボックスをオンまたはオフにします。すべてのフィールドを表示するには、[(すべて)] を選択します。

現在表示されているフィールドの右側にフィールドが追加されます。

フィールド列を移動する

1 つ以上のフィールド列を選択し、ウィンドウの上部にある右矢印または左矢印をクリックします。または、ドロップダウン メニューを選択し、[右に移動][左に移動] をクリックします。

Tip: 隣接していない列をグループ化するには、Ctrl キーを押しながら列を選択し、選択した列を左または右に移動します。

フィールド列を削除する

フィールド列を選択し、ドロップダウン メニューから [削除] を選択します。または、[フィールドを表示] をクリックし、フィールドのチェックボックスをオフにして列を削除します。

データの並べ替え

列の上部にカーソルを合わせると、[並べ替え] ボタンが表示されます。[並べ替え] ボタンをクリックして、並べ替えを変更します。

必要に応じて、ドロップダウン メニューをクリックし、[昇順に並べ替え] または [降順に並べ替え] を選択します

: カスタマイズされた並べ替えの結果は、ダウンロードされたデータには含まれません。

表示される最大行数を編集する

既定では、[データの表示] ウィンドウには、Tableau Desktop では最初の 10,000 行までのデータが表示され、Tableau Online および Tableau Server では最初の 200 行までのデータが表示されます。

[データの表示] ウィンドウに表示される最大行数は、増やしたり減らしたりすることができます。この設定は、[ダウンロード] ボタンをクリックしたときにエクスポートされる行数には影響しません。

[行数] フィールドをクリックして編集します。矢印ボタンをクリックするか、キーボードの Enter キーを押して、変更を適用します。

別名を表示する

[設定] ボタンをクリックして、すべてのフィールド名の別名を表示または非表示にします。

[データの表示] ウィンドウからデータをダウンロードする

選択したタブのすべてのデータをエクスポートするには、[ダウンロード] ボタンをクリックします。

データは、現在の構成を [データの表示] ウィンドウとして使用して CSV ファイルにエクスポートされますが、[データの表示] ウィンドウに現在表示されている行数に制限されているわけではありません。

: カスタマイズされた並べ替えの結果は、ダウンロードされたデータには含まれません。

Null 値は空の文字列としてダウンロードされます。

: 自分がワークブックの作成者である場合に、閲覧者が参照元データをコピーできないようにするときは、ツールヒントのコマンド ボタンをオフにする(新しいウィンドウでリンクが開く)か、サマリー データまたはフル データをダウンロードするためのワークブックのパーミッション(新しいウィンドウでリンクが開く)を拒否することを検討してください。

[データの表示] ウィンドウからデータをコピーする

[データの表示] ウィンドウからデータの一部をコピーして、スプレッドシートやその他の Tableau ワークブック (実際には、テキストを貼り付けることができるすべての場所) で使用できます。Null 値は空の文字列としてコピーされます。

  • 目的のセルを選択し、Ctrl + C (Windows) または Command + C (Mac) を押してから、データをスプレッドシート、別の Tableau ワークブック、または選択した別の宛先に貼り付けます。

: 参照元データのすべての値をダウンロードする場合は、[ダウンロード] ボタンをクリックします。列を選択してコピーすると、[データの表示] ウィンドウに現在読み込まれている値のみがコピーされ、参照元データのすべての値が含まれない場合があります。

[データの表示] アイコンが表示されないのはなぜですか? 

マークの [データの表示] アイコンが見つからない場合は、ツールヒントとツールヒント メニューのコマンドのボタンがオンになってることを確認します。具体的には、[データの表示] ボタンをツールヒントで使用できるようにするには、Viz のツールヒントに対して [ツールヒントの表示] および [コマンド ボタンを含める] オプションを選択する必要があります。または、マークを右クリックして、ドロップダウン メニューから [データの表示] を選択します。この方法は、ツールヒントやコマンド ボタンが有効になっていない場合でも機能します。

パブリッシュされた Viz を表示していて、マークの [データの表示] アイコンが見つからない場合は、ツールヒントが有効になっていない、ツールヒント コマンド ボタンがオフになっている、または必要なパーミッションがない可能性があります。

ありがとうございます!