データへの接続

: バージョン 2020.4.1 以降では、Tableau Server および Tableau Online でフローの作成と編集を行えるようになりました。このトピックの内容は、特に記載がない限り、すべてのプラットフォームに適用されます。Web 上でのフローの作成の詳細については、「Web 上の Tableau Prep」を参照してください。

Tableau Prep は、一般的なタイプのデータ、Tableau データ抽出 (.hyper)、パブリッシュされたデータ ソースへの接続をサポートしています。

データ管理アドオン(Link opens in a new window)が Tableau カタログで有効になっている場合は、Tableau Server や Tableau Online に保存されているデータベースやテーブル、ファイルなどを検索して接続できるようになりました。Tableau Catalog の詳細については、Tableau Server(Link opens in a new window)Tableau オンライン(Link opens in a new window) ヘルプの「Tableau Catalog について」を参照してください。

新しいデータ コネクタは、Tableau Prep の新しいバージョンごとに追加されます。ただし、使用しているバージョンや、Web 上でフローを作成および編集しているかどうかなどによって、一部のコネクタを使用できない場合があります。使用できるコネクタの最新のリストを確認するには、Tableau Prep Builder を開くか、Web 上のフローを開始して [接続の追加] ボタンをクリックし、データに対応するコネクタが左側のペインの [接続] に記載されているかどうかを確認します。

: コネクタがサポートされていないバージョンでフローを開くと、フローを開くことはできますが、エラーが発生する可能性があったり、データ接続を削除しない限り実行されません。

ほとんどのコネクタはすべてのプラットフォームで同じように動作しますが、Tableau Prep で使用する場合は要件が異なる場合があります。このトピックではこれについて説明します。その他のコネクタについては、Tableau Desktop ヘルプの「サポートされているコネクタ(Link opens in a new window)」を参照してください。

フローの開始またはオープン

Tableau Desktop の場合と同じように、データに接続して新しいフローを開始します。既存のフローを開き、中止した時点に移動することもできます。

: 一部のコネクタでは、データへ接続するためにドライバーのダウンロードとインストールが必要な場合があります。ドライバーのダウンロード リンクとインストール指示を入手するには、Tableau Web サイトのドライバーのダウンロード(Link opens in a new window) ページを参照してください。

Tableau Prep Builder では、スタート ページの右側で最近のフローを表示してアクセスできるため、進行中の作業を簡単に見つけることができます。Web 上でフローを操作するとき、すべてのフローが [すべてのフロー] メニューの [探索] ページに表示されます。

データに接続したら、フローで操作するデータを識別するため、インプット ステップで別のオプションを使用します。次に、クリーニング ステップか他のステップ タイプを追加して、データを検証し、クリーンアップし、加工します。

フローに多数の異なるデータ ソース コネクタが含まれている場合、Tableau Prep を使用すると、どのコネクタとテーブルがインプット ステップに関連付けられているかを簡単に確認できます。入力ステップをクリックすると、関連するコネクタとデータ テーブルが [接続] ペインで強調表示されます。このオプションは Tableau Prep Builder バージョン 2020.1.1 で追加され、Web 上でフローを編集する場合についてもサポートしています。

新しいフローの開始

  1. Tableau Prep Builder を開き、[接続の追加] ボタンをクリックします。

    Web オーサリングでは、ホーム ページで [作成] > [フロー] をクリックするか、[探索] ページで [新規作成] > [フロー] をクリックします。次に [データへの接続] をクリックします。

  2. コネクタのリストより、ファイルの種類またはデータをホストするサーバーを選択します。プロンプトが表示される場合には、サインインおよびデータへのアクセスに必要な情報を入力します。

    : Web オーサリングでは、ファイル コネクタの一覧が異なる場合があります。

  3. [接続] ペインで次のいずれかを実行します。

    • ファイルに接続した場合は、テーブルをダブルクリックするか、[フロー] ペインにテーブルをドラッグしてフローを開始します。単一テーブルの場合、データをフローに追加すると、Tableau Prep は [フロー] ペインで自動的にインプット ステップを作成します。

      : Web オーサリングでは、ファイル接続の場合、ダウンロードできるファイルは一度に 1 つのみです。ファイル ネットワーク共有への直接接続は、現在サポートされていません。

    • データベースに接続した場合は、データベースかスキーマを選択してから、テーブルをダブルクリックするか、[フロー] ペインにテーブルをドラッグしてフローを開始します。

      : Tableau Prep Builder では、ワイルドカード検索を使用して、インプット ステップで 1 つのデータ ソースから複数のファイルまたはデータベース テーブルをユニオン化できます。Web オーサリングでは入力ユニオンを作成または編集することはできませんが、Tableau Prep Builder からパブリッシュされたフローではサポートされています。詳細については、「インプット ステップでのファイルおよびデータベース表のユニオン作成(Link opens in a new window)」を参照してください。

既存フローを開く

Tableau Prep Builder

[開始] ページで次のいずれかを実行します。

  • [最近のフロー] でフローを選択します。

  • [フローを開く] をクリックし、フロー ファイルに移動して開きます。

[ファイル] > [新規作成] または [ファイル] > [開く] をクリックして、新しいワークスペースを開きます。複数のフローで同時に作業する場合は、このオプションを使用して複数の Tableau Prep Builder ワークスペースを開くことができます。Tableau Prep Builder バージョン 2019.3.1 以前で [ファイル] > [開く] を選択すると、Tableau Prep Builder では現在開いているフローが選択した新しいフローに置き換えられます。

Web 上の Tableau Prep

  1. 既存のフローを開いて編集するには、[探索] ページで上部のドロップダウン メニューから [すべてのフロー] を選択し、リストからフローを選択します。

  2. [フローの概要] ページで、[編集] をクリックしてフローを編集します。

    フローが新しいタブで開きます。変更し始めると、数秒ごとに変更が自動的に保存され、変更したフローが下書きとして保存されます。下書きは、自分と管理者だけが表示できます。

    変更作業を終了したら、フローを閉じて後で変更を続けるか、フローをパブリッシュして変更を反映し、新しいバージョンのフローを作成します。

    他のツールと同様に、フローのパブリッシュでは先入れ方式を採用しています。他のユーザーが先にフローを変更して再パブリッシュした場合、その変更が先にコミットされます。ただし、[リビジョン履歴] ページを使用すると、履歴を追跡して以前のバージョンに戻すことができます。詳細については、Tableau Desktop ヘルプの「コンテンツのリビジョンの操作(Link opens in a new window)」を参照してください。

パブリッシュされたデータ ソースへの接続

データ ソースを Tableau Prep Builder (バージョン 2019.3.1 以降) から Tableau Server へ、または Tableau Desktop から Tableau Online へ、またはフローから出力としてパブリッシュすると、これらのパブリッシュされたデータ ソースに接続してフローの入力データ ソースとして使用できます。Web 上でフローを作成または編集する際に、パブリッシュされたデータ ソースに接続することもできます。

: パブリッシュされたデータ ソースがインプットとして含まれるフローをパブリッシュすると、パブリッシャーが既定のフロー所有者として割り当てられます。フローを実行するときは、フロー所有者を実行アカウントに使用します。実行アカウントの詳細については、「実行サービス アカウント(Link opens in a new window)」を参照してください。Tableau Server または Tableau Online でフロー所有者を変更できるのは、サイト管理者またはサーバー管理者だけです。

この機能を使用する場合は、次の要件が適用されます。

  • Tableau Server バージョン 2019.3 以降で使用可能なパブリッシュされたデータ ソースへの接続に完全に対応しています。以前のバージョンの Tableau Server でパブリッシュしたデータ ソースに接続する場合は、すべての機能を使用できない可能性があります。
  • バージョン 2020.4.1 以降では、Web 上でフローを作成または編集するときに、パブリッシュされたデータ ソースに接続できます。
  • パブリッシュされたデータ ソースに接続するには、サインインしている Tableau Server サイトで Explorer 以上の役割が割り当てられている必要があります。Web 上でフローを作成または編集できるのは作成者だけです。サイト ロールの詳細については、Tableau Server ヘルプの「ユーザーのサイト ロールの設定(Link opens in a new window)」を参照してください。
  • パブリッシュされたデータ ソースに接続するには、認証資格情報を埋め込む必要があります。データ ソースの認証資格情報が埋め込まれていない場合は、データ ソースを更新して埋め込み認証資格情報を追加する必要があります。
  • 多次元 (キューブ) データまたはユーザー フィルターを含むパブリッシュされたデータ ソースは、現在サポートされていません。
  • マルチサーバー接続はサポートされていません。次の操作を実行するには、同じサーバーまたはサイトへの接続を使用する必要があります。
    • パブリッシュされたデータ ソースに接続する。
    • フロー出力を Tableau Server または Tableau Online へパブリッシュする。
    • Tableau Server または Tableau Online でのフローの実行をスケジュールする。

パブリッシュされたデータ ソースに接続するには、次のバージョンの Tableau Prep の手順に従います。

Tableau Prep Builder バージョン 2020.2.1 以降
  1. Tableau Prep Builder を開き、[接続の追加] ボタンをクリックします。

  2. コネクタのリストから、[Tableau Server] を選択します。

  3. サインインしてサーバーまたはサイトに接続します。

  4. データ ソースを選択するか、検索オプションを使用してデータ ソースを検索し、フロー ペインにドラッグしてフローを開始します。[入力] ペインの [Tableau Server] タブに、パブリッシュされたデータ ソースの詳細が表示されます。

Tableau Prep Builder バージョン 2020.2.2 以降および Web 上

[接続] ペインから、Tableau Server や Tableau Online に保存されているパブリッシュされたデータ ソースなどに直接接続できます。Tableau Catalog が有効になっている Data Management アドオン(Link opens in a new window)を使用している場合は、データベースやテーブルを検索して接続し、説明、データ品質警告、証明書などのデータ ソースに関するメタ データを表示したりフィルター処理したりすることもできます。

Tableau Catalog の詳細については、Tableau Server(Link opens in a new window)Tableau オンライン(Link opens in a new window) ヘルプの「Tableau Catalog について」を参照してください。

  1. Tableau Prep Builder を開き、[接続の追加] ボタンをクリックします。

    Web オーサリングでは、ホーム ページで [作成] > [フロー] をクリックするか、[探索] ページで [新規作成] > [フロー] をクリックします。次に [データへの接続] をクリックします。

  2. [接続] ペインの [データの検索] から [Tableau Server] を選択します。

  3. サインインしてサーバーまたはサイトに接続します。

    Web オーサリングでは、サインインしているサーバーの [データの検索] ダイアログが開きます。

  4. [データの検索] ダイアログで、使用可能なパブリッシュされたデータ ソースのリストから検索します。フィルター オプションを使用して、接続のタイプと認定されたデータ ソースでフィルター処理します。

  5. 使用するデータ ソースを選択し、[接続] をクリックします。

    データ ソースに接続するパーミッションがない場合は、行と [接続] ボタンは灰色で表示されます。

    : Tableau Catalog が有効になっている Data Management アドオンを使用していない場合は、[コンテンツ タイプ] ドロップダウンは表示されません。パブリッシュされたデータ ソースのみがリストに表示されます。

  6. データ ソースが [フロー] ペインに追加されます。[接続] ペインで、追加のデータ ソースを選択するか、検索オプションを使用してデータ ソースを検索し、フロー ペインにドラッグしてフローを作成します。[入力] ペインの [Tableau Server] タブに、パブリッシュされたデータ ソースの詳細が表示されます。

  7. (オプション) Tableau Catalog が有効になっている Data Management アドオンを使用している場合は、[コンテンツ タイプ] ドロップダウンを使用してデータベースとテーブルを検索できます。

    右上隅のフィルター オプションを使用して、接続タイプ、データ品質の警告、認定などで結果をフィルター処理することができます。

クラウド データ ソースへの接続

Tableau Desktop の場合と同じように、Tableau Prep でもクラウド データ ソースに接続できます。ただし、クラウド データ ソースに接続するフローをパブリッシュし、サーバーのスケジュールに従ってフローを実行する場合は、Tableau Server または Tableau Online で認証資格情報を設定する必要があります。

[マイ アカウントの設定] ページの [設定] タブで認証資格情報を設定し、同じ認証資格情報を使用してクラウド コネクタ入力に接続します。

Tableau Prep Builder

フローをパブリッシュする場合は、[パブリッシュ] ダイアログで [編集] をクリックして接続を編集し、[認証] ドロップダウンで <認証資格情報> の [埋め込み] を選択します。

Tableau Prep Builder バージョン 2020.1.1 では、フローをパブリッシュするときにパブリッシュ ダイアログから認証資格情報を追加し、自動的にフローに埋め込むこともできます。詳細については、「Tableau Prep Builder からフローをパブリッシュする」を参照してください。

認証資格情報を保存しておらず、[認証] ドロップダウンで [ユーザーの確認] を選択した場合は、フローをパブリッシュした後で接続を編集し、Tableau Server または Tableau Online[接続] タブに認証資格情報を入力する必要があります。情報を入力しないと、実行時にフローが失敗します。

Web 上の Tableau Prep

Web オーサリングでは、上部のメニューの [ファイル] > [接続資格情報] で認証資格情報を埋め込むことができます。詳細については、「Web 作成でフローをパブリッシュする」を参照してください。

Tableau Prep Builderバージョン 2019.4.1 では、次のクラウド コネクタが追加され、Web 上でフローを作成または編集するときにも使用できます。

  • Box
  • DropBox
  • Google Drive
  • OneDrive

上記のコネクタを使用してデータへ接続する方法の詳細については、Tableau Desktop ヘルプでコネクタ固有の(Link opens in a new window)ヘルプ トピックを参照してください。

Salesforce データへの接続

Tableau Prep Builder (バージョン 2020.2.1 以降) および Web 上では、Tableau Desktop の場合と同じように Salesforce コネクタを使用してデータに接続できますが、いくつかの違いがあります。

  • Tableau Prep Builder は、どの結合タイプにも対応しています。
  • カスタム SOQL は現在対応していません。
  • 標準接続を使用した独自のカスタム接続の作成は、現在対応していません。
  • 既定のデータ ソース名を一意の名前にしたりカスタム名に変更したりすることはできません。
  • 保存した認証資格情報を使用して Tableau Server にフローをパブリッシュする場合、コネクタの OAuth クライアント ID とシークレットを使用して Tableau Server を構成する必要があります。詳細については、Tableau Server ヘルプの「Salesforce.com の OAuth を保存済みの認証資格情報に変更する(Link opens in a new window)」を参照してください。

Tableau Prep では、抽出を作成してデータをインポートします。現在、Salesforce では、抽出のみ対応しています。含まれているデータ量によっては、最初の抽出に時間がかかる場合があります。データの読み込み中は、インプット ステップにタイマーが表示されます。

Salesforce コネクタの使用に関する一般的な情報については、「Tableau Desktop と Web 作成のヘルプ」の「Salesforce(Link opens in a new window)」を参照してください。

Google BigQuery への接続

Tableau Prep Builder(バージョン 2019.3.1 以降) および Web 上では、Tableau Desktop の場合と同じように Google BigQuery を使用してデータに接続できます。

OAuth 認証資格情報を設定して、Tableau Prep が Google BigQuery と通信できるようにする必要があります。フローを Tableau Server または Tableau Online にパブリッシュする計画がある場合は、それらのアプリケーションに対しても OAuth 接続を構成する必要があります。

: Tableau Prep では、Google BigQuery のカスタマイズ属性の使用は現在サポートされていません。

SSL を設定して Google BigQuery に接続 (MacOS のみ)

Mac で Tableau Prep Builder を使用し、プロキシで Big Query に接続している場合は、SSL 設定を変更して Google BigQuery に接続する必要が生じる可能性があります。

: Windows ユーザーは、追加の手順は必要ありません。

Google BigQuery への OAuth 接続用に SSL を設定するには、次の手順を実行します。

  1. プロキシの SSL 証明書をファイル (proxy.cer など) にエクスポートします。証明書は Applications > Utilities > Keychain Access >System > Certificates (under Category) にあります。
  2. Tableau Prep Builder の実行に使用している Java のバージョンを特定します。例: /Applications/Tableau Prep Builder 2020.4.app/Plugins/jre/lib/security/cacerts

  3. ターミナル コマンド プロンプトを開き、お使いの Tableau Prep Builder バージョンに合わせて次のコマンドを実行します。

    : keytool コマンドは、Tableau Prep Builder の実行に使用している Java のバージョンが含まれるディレクトリから実行する必要があります。このコマンドを実行する前に、ディレクトリの変更が必要な場合があります。例: cd /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder 2020.1.1/Plugins/jre/bin。次に、keytool コマンドを実行します。

    keytool –import –trustcacerts –file /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder <version>/Plugins/jre/lib/security/cacerts -storepass changeit

    : keytool –import –trustcacerts –file /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder 2020.4.1/Plugins/jre/lib/security/cacerts -storepass changeit

keytool コマンドの実行時に FileNotFoundException (アクセスが拒否されました) と表示された場合は、引き上げられたアクセス許可でコマンドを実行してみてください。例: sudo keytool –import –trustcacerts –file /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder 2020.4.1/Plugins/jre/lib/security/cacerts -storepass changeit

Google BigQuery 認証資格情報を設定および管理する

インプット ステップで Google BigQuery への接続に使用する認証資格情報は、Tableau Server または Tableau Online で Google BigQuery の [マイ アカウントの設定] ページにある [設定] タブで設定される認証資格情報と一致する必要があります。

フローをパブリッシュするときに認証設定で別の認証資格情報を選択するか、何も選択しなかった場合、Tableau Server または Tableau Online でフローの接続を編集するまでフローが認証エラーで失敗します。

認証資格情報を編集するには、次の手順を実行します。

  1. Tableau Server または Tableau Online で、Google BigQuery 接続の [接続] タブにある [その他のアクション] をクリックします。
  2. [接続の編集] を選択します。
  3. [マイ アカウントの設定] ページの [設定] タブで設定した保存済みの認証資格情報を選択します。

認証資格情報の設定と管理に関する詳細については、次のトピックを参照してください。

「Tableau Desktop と Web 作成のヘルプ」の「アカウント設定の管理」(Link opens in a new window)

フローをパブリッシュするときに認証オプションを設定する方法については、「Tableau Prep Builder からフローをパブリッシュする(Link opens in a new window)」を参照してください。

Tableau Server または Tableau Online で接続エラーを解決する方法については、エラーを表示して解決する

SAP HANA への接続

Tableau Prep Builder (バージョン 2019.2.1 以降) および Web 上では、Tableau Desktop の場合と同じように SAP HANA を使用してデータに接続できますが、いくつかの違いがあります。

Tableau Desktop と同じ手順を使用してデータベースに接続します。詳細については、「SAP HANA(Link opens in a new window)」を参照してください。接続してテーブルを検索した後で、テーブルをキャンバスにドラッグし、フローの構築を開始します。

Tableau Prep では、フローを開くときに変数とパラメーターの入力を求める機能はサポートされていません。代わりに、[入力] ペインで [変数とパラメーター] タブをクリックし、使用する変数とオペランドを選択します。その後、事前設定された値のリストから選択するか、カスタム値を入力することで、データベースにクエリを実行して必要な値を返します。

: Tableau Prep Builder (バージョン 2019.2.2 以降) および Web 上では、初期 SQL を使用して接続をクエリできます。変数に複数の値がある場合は、ドロップダウン リストから必要な値を選択できます。

変数を追加することもできます。[変数] セクションでプラス ボタン をクリックし、変数とオペランドを選択してからカスタム値を入力します。

: このコネクタはバージョン 2019.2 以降の Tableau server でのみ利用できます。このコネクタを使用する Tableau Prep Builder でフローを作成して、以前のバージョンのサーバーにフローをパブリッシュすることはできます。ただし、Tableau Server のスケジュール機能を使用してフローを実行することはできません。代わりに、コマンド ライン インターフェイスを使用してフローを実行すると、データを最新の状態に保つことができます。コマンド ラインからのフロー実行の詳細については、「コマンド ラインからフロー出力ファイルを更新(Link opens in a new window)」を参照してください。バージョンの互換性の詳細については、「Tableau Prep とのバージョン互換性(Link opens in a new window)」を参照してください。

空間ファイルと空間データベースへの接続 (バージョン 2020.4.1 以降)

Tableau Prep Builder の場合、またはWeb 上でフローを作成または編集する場合、空間ファイルおよび空間データ ソースに接続できます。

Tableau Prep は以下の接続タイプをサポートしています。

  • 空間ファイル形式
    • Tableau Prep Builder: Esri シェープファイル、Esri File Geodatabases、KML、TopoJSON、GeoJSON、抽出、MapInfo MID/MIF、TAB ファイル、圧縮されたシェープファイル。
    • Tableau Server および Tableau Online: 圧縮されたシェープファイル、KML、TopoJSON、GeoJSON、Esri File Geodatabases、抽出。
  • 空間データベース (Amazon Redshift、Microsoft SQL Server、Oracle、PostgreSQL)。

標準の結合を使用して空間テーブルと非空間テーブルを組み合わせ、抽出 (.hyper) ファイルに空間データを出力することもできます。Tableau Prep の空間関数、交点を介した空間結合、マップ ビューなどでの空間データの視覚化は、現在サポートされていません。

サポート済みクリーニング操作

シェープ ファイル データを操作する場合、一部のクリーニング操作はサポートされません。Tableau Prep では、シェイプ ファイル データに次のクリーニング操作のみ使用できます。

  • フィルタ: Null 値または不明な値のみの削除
  • フィールド名の変更
  • フィールドの複製
  • 保持するフィールド
  • フィールドの削除
  • 計算フィールドの作成

接続する前に

空間ファイルに接続する前に、以下のファイルが同じディレクトリに存在することを確認します。

  • Esri シェープファイル: フォルダーには Esri シェープファイルの .zip ファイルおよび .shp、.shx、.dbf、.prj などのファイルが含まれている必要があります。
  • Esri File Geodatabases: フォルダーには File Geodatabase の .gdb ファイル、または File Geodatabases の .gdb の .zip ファイルが含まれている必要があります。
  • KML ファイル: フォルダーには .kml file ファイルが含まれている必要があります (他のファイルは不要です)。
  • GeoJSON ファイル: フォルダーには .geojson ファイルが含まれている必要があります (他のファイルは不要です)。
  • TopoJSON ファイル: フォルダー .json ファイルまたは .topojson ファイルが含まれている必要があります (他のファイルは不要です)。

空間ファイルへの接続

  1. 次のいずれかを実行します。

    • Tableau Prep Builder を開き、[接続の追加] ボタンをクリックします。
    • Tableau Server または Tableau Online を開きます。[エクスプローラ] メニューの [新規作成] > [フロー] をクリックします。
  2. コネクタのリストから [空間ファイル] を選択します。

    空間フィールドには空間データ タイプが割り当てられており、変更はできません。フィールドを空間ファイルから取得する場合、フィールドにはデフォルトのフィールド名 "Geometry" が割り当てられます。フィールドを空間データベースから取得する場合、データベースのフィールド名が表示されます。Tableau がデータのタイプを判断できない場合、フィールドは "Null" と表示されます。

ODBC を使用した接続 (Tableau Prep Builderバージョン 2019.2.2 以降)

: このコネクタ タイプは、Web オーサリングではサポートされていません。

[接続] ペインにリストされていないデータ ソースへ接続する必要がある場合は、SQL 標準をサポートするその他のデータベース (ODBC) コネクタを使用して任意のデータ ソースに接続し、ODBC API を実装できます。その他のデータベース (ODBC) コネクタを使用したデータへの接続は、そのコネクタを Tableau Desktop で使用する場合と似ていますが、いくつかの相違点があります。

  • 接続できるのは、DSN (データ ソース名) オプションを使用する場合のみです。

  • Tableau Server でフローをパブリッシュして実行するには、サーバーが一致する DSN を使用して構成されている必要があります。

    : その他のデータベース (ODBC) コネクタを含むフローのコマンド ラインからの実行は、現在サポートされていません。

  • Windows と MacOS の両方に単一の接続エクスペリエンスがあります。ODBC ドライバー (Windows) の接続属性の確認を求める機能はサポートされていません。

  • Tableau Prep Builder で対応しているのは 64 ビット ドライバーのみです。

接続する前に

その他のデータベース (ODBC) コネクタを使用してデータに接続するには、データベース ドライバーをインストールして、DSN (データ ソース名) の設定と構成を行う必要があります。Tableau Server にフローをパブリッシュして実行するには、サーバーが一致する DSN を使用して構成されている必要があります。

重要: Tableau Prep Builder でサポートされているのは、64 ビットドライバーのみです。32 ビット ドライバーの設定と構成を既に行っており、ドライバーで 32 ビット版と 64 ビット版の同時インストールが許可されていない場合は、32 ビット版をアンインストールしてから 64 ビット版をインストールする必要があります。

  1. ODBC データ ソース アドミニストレーター (64 ビット) (Windows) または ODBC Manager ユーティリティ (MacOS) のいずれかを使用して DSN を作成します。

    お使いの Mac にユーティリティがインストールされていない場合は、www.odbcmanager.net(Link opens in a new window) などからダウンロードするか、odbc.ini ファイルを手動で編集できます。

  2. ODBC データ ソース アドミニストレーター (64 ビット) (Windows) または ODBC Manager ユーティリティ (MacOS) で、新しいデータ ソースを追加してからデータ ソースのドライバーを選択し、[完了] をクリックします。

  3. [ODBC Driver Setup (ODBC ドライバーのセットアップ)] ダイアログで、サーバー名、ポート、ユーザー名、パスワードなどの構成情報を入力します。[テスト] (ダイアログにこのオプションがある場合) をクリックして接続が正しく設定されていることを確認してから、構成を保存します。

    : Tableau Prep Builder では、接続属性の確認を求める機能はサポートされていません。DNS の構成時にこの情報を設定する必要があります。

    次の例では、MySQL Connector の構成ダイアログを示します。

その他のデータベース (ODBC) を使用した接続

  1. Tableau Prep Builder を開き、[接続の追加] ボタンをクリックします。

  2. コネクタのリストから、[その他のデータベース (ODBC)] を選択します。

  3. [その他のデータベース (ODBC)] ダイアログで、ドロップダウン リストから DSN を選択し、ユーザー名とパスワードを入力します。次に、[サインイン] をクリックします。

  4. [接続] ペインで、ドロップダウン リストからデータベースを選択します。

コネクタ プラグインを使用した ODBC ベースおよび JDBC ベースのデータへの接続 (バージョン 2020.4.1 以降)

: 接続ダイアログ v2 を使用するコネクタ プラグインはまだサポートされていないため、データ ソースへの接続試行は失敗します。接続ダイアログ v2 の詳細については、Tableau コネクタ SDK の「接続ダイアログ V2 を使用した接続ダイアログの構築」(Link opens in a new window)を参照してください。

Tableau Prep でデータの組み込みコネクタが提供されていない場合は、Tableau コネクタ SDK で作成したコネクタ プラグインを使用して ODBC ベースのデータや JDBC ベースのデータに接続できます。コネクタ プラグインは、Tableau Prep Builder のデータや、Tableau Server で Web 上のデータに接続する場合にサポートされています。

コネクタによっては、追加のドライバーをインストールする必要があります。接続プロセス中にメッセージが表示された場合は、そのメッセージに従って必要なドライバーをダウンロードしてインストールします。コネクタ プラグインは現在 Tableau Online では使用できません。

コネクタ プラグイン ディレクトリ

コネクタ プラグインを使用するには、コネクタ .taco ファイルをダウンロードして次のディレクトリに追加します。

  • Tableau Prep Builder:
    • Windows: C:\Users\<Windows ユーザー>\Documents\My Tableau Prep Repository\Connectors
    • MacOS: /Users/<ユーザー>/Documents/My Tableau Prep Repository/Connectors
  • Tableau Server (フロー Web オーサリング): <Tableau_Server_インストール_ディレクトリ>/data/tabsvc/flowqueryservice/Connectors
  • Tableau Server (Tableau Prep Conductor): <Tableau_Server_インストール_ディレクトリ>/data/tabsvc/flowprocessor/Connectors

コネクタ プラグインの使用に関する一般的な情報については、Tableau Desktop ヘルプの「Tableau Server へのコネクタの追加(Link opens in a new window)」を参照してください。

カスタム SQL を使用したデータへの接続

データベースから必要な情報を把握し、SQL クエリの記述方法を理解している場合は、Tableau Desktop の場合と同じように、カスタム SQL クエリを使用してデータに接続できます。カスタム SQL を使用すると、テーブル間でデータのユニオンを作成したり、フィールドを再キャストしてクロスデータベース結合を実行したり、分析のためにデータを再構築またはデータのサイズを圧縮したりすることができます。

  1. データ ソースに接続し、[接続] ペインの [データベース] フィールドでデータベースを選択します。

  2. [カスタム SQL] リンクをクリックして [カスタム SQL] タブを開きます。

  3. テキスト ボックスにクエリを入力するか貼り付け、[実行] をクリックしてクエリを実行します。

  4. フロー ペインにクリーニング ステップを追加して、カスタム SQL クエリの関連フィールドだけがフローに追加されることを確認します。

初期 SQL を使用した接続のクエリ

Tableau Prep Builder (バージョン 2019.2.2 以降) および Web 上では、サポートするデータベースへの接続が確立されたときに実行する初期 SQL コマンドを指定できます。たとえば、Amazon Redshift に接続する場合、データベースへの接続時に、インプット ステップでフィルターを追加するときのように、SQL ステートメントを入力してフィルターを適用できます。SQL コマンドは、データがサンプリングされ Tableau Prep に読み込まれる前に適用されます。

Tableau Prep Builder (バージョン 2020.1.3 以降) および Web 上では、アプリケーション名、バージョン、およびフロー名などのデータを渡すパラメーターを含めることにより、データ ソースをクエリするときに追跡データを含めることもできます。

初期 SQL の実行

データを更新して初期 SQL コマンドを実行するには、次のいずれかの操作を行います。

  • 初期 SQL コマンドを変更し、接続を再確立してインプット ステップを更新します。
  • フローを実行します。初期 SQL コマンドは、すべてのデータを処理する前に実行されます。
  • Tableau Server または Tableau Online 上でフローを実行します。初期 SQL は、フローが実行されるたびにデータの読み込み操作の一部として実行されます

: Tableau Server または Tableau Online でスケジュールを設定してフローを実行するには、データ管理アドオン(Link opens in a new window)が必要です。Data Management アドオン の詳細については、「Data Management アドオンの使用(Link opens in a new window)」を参照してください。

  1. [接続] ペインで、リストから初期 SQL をサポートするコネクタを選択します。
  2. [初期 SQL の表示] リンクをクリックしてダイアログを展開し、SQL ステートメントを入力します。

初期 SQL ステートメントへのパラメーターのインクルード

Tableau Prep Builder (バージョン 2020.1.3 以降) および Web 上では、次のパラメーターをデータ ソースに渡すことにより、Tableau Prep アプリケーション、バージョン、およびフロー名に関する詳細情報を追加できます。TableauServerUser および TableauServerUserFull パラメーターは現在サポートされていません。

パラメーター 説明 戻り値
TableauApp データ ソースへのアクセスに使用されるアプリケーション。

Prep Builder

Prep Conductor

TableauVersion アプリケーションのバージョン番号。

Tableau Prep Builder: 正確なバージョンを返します。例: 2020.4.1

Tableau Prep Conductor: Tableau Prep Conductor が有効になっているメジャー サーバー バージョンを返します。例: 2020.4

FlowName Tableau Prep Builder での .tfl ファイルの名前。 例: Entertainment Data_Cleaned

Data Interpreter を使用したファイルのクリーニング

Microsoft Excel ファイルを操作する場合、Data Interpreter を使用してデータのサブテーブルを検出したり、関係のない情報を削除して分析用データの準備を行うことができます。Data Interpreter をオンにすると、これらのサブテーブルを検出し、[接続] ペインの [テーブル] セクションで新しいテーブルとしてリストに記載します。その後、[フロー] ペインにドラッグできます。

Data Interpreter をオフにすると、これらのテーブルは [接続] ペインから削除されます。これらのテーブルがフローで既に使用されている場合は、データの欠落のためフローでエラーが発生します。

: 現在、Data Interpreter は Excel スプレッドシートのサブテーブルのみを検出します。テキスト ファイルとスプレッドシートの開始行の指定はサポートされていません。また、データ インタープリターが検出したテーブルは、ワイルドカード ユニオンの検索結果に含まれません。

以下の例は、[接続] ペインで Excel スプレッドシートに Data Interpreter を使用した結果を示しています。Data Interpreter が 2 つの追加サブテーブルを検出しました。

Data Interpreter 使用前 Data Interpreter 使用後

Data Interpreter を使用するには、以下の手順を完了します。

  1. [データへの接続][Microsoft Excel] の順に選択します。

  2. ファイルを選択し、[開く] をクリックします。

  3. [Data Interpreter の使用] チェック ボックスを選択します。

  4. 新しいテーブルを [フロー] ペインにドラッグし、フローに含めます。古いテーブルを削除するには、古いテーブルのインプット ステップを右クリックし、[削除] を選択します。

このセクションの他の記事

ありがとうございます! フィードバックの送信中にエラが発生しました。もう一度やり直してください。