作業の保存と共有

: バージョン 2020.4 以降では、Tableau Server および Tableau Online でフローを作成および編集できるようになりました。このトピックの内容は、特に記載がない限り、すべてのプラットフォームに適用されます。Web 上でのフローの作成について詳しくは、「Web 上の Tableau Prep」を参照してください。

作業内容はフローのどの時点でも手動で保存することができます。または、Web 上でフローを作成または編集する際に Tableau で自動的に保存されるようにすることもできます。Web 上でフローを操作する場合、いくつかの相違点があります。

Tableau Prep Builder Web 上の Tableau Prep
  • Tableau Desktop でフロー内のデータのプレビューを表示します。
  • 直接ファイル接続をフロー入力に含めるか、ファイルをパッケージ化してパッケージ化されたフローをサーバーにパブリッシュします。
  • フローをファイル、パブリッシュされたデータ ソース、またはデータベース (バージョン 2020.3.1 以降) に出力します。
  • Web 上でフローを作成および操作します。
  • フロー入力用のファイルをアップロードし、さまざまなデータ ソースに接続します。
  • フローをパブリッシュされたデータ ソースまたはデータベースに出力します。

データを最新の状態に保つために、フローを Tableau Prep Builder やコマンド ラインから手動で実行することができます。また、Tableau Server または Tableau Online でパブリッシュされたフローを手動で実行するか、スケジュールに従って実行することもできます。フローの実行について詳しくは、「フローの実行」を参照してください。

フローの保存

Tableau Prep Builder では、追加の操作を実行する前に、フローを保存して作業内容をバックアップできます。フローは Tableau Prep フロー (.tfl) ファイル形式で保存されます。

Tableau Desktop でワークブックをパッケージして共有するのと同様に、ローカル ファイル (Excel、テキスト ファイル、Tableau 抽出) をフローと一緒にパッケージして他のユーザーに共有することもできます。ローカル ファイルのみをフローと一緒にパッケージできます。データベース接続のデータなどは含まれません。

Web 作成では、ローカルファイルは自動的にフローと一緒にパッケージ化されます。ファイルへの直接接続はまだサポートされていません。

パッケージド フローを保存すると、フローはパッケージド Tableau Flow ファイル (.tflx) として保存されます。

  • フローを保存するには、トップ メニューから [ファイル] > [保存] を選択します。

  • Tableau Prep Builder では、データ ファイルをフローと一緒にパッケージ化するには、トップ メニューから次のいずれかを実行します。

    • [ファイル] > [パッケージド フローのエクスポート] を選択します。

    • [ファイル] > [名前を付けて保存] を選択します。その後、[名前を付けて保存] ダイアログで、[種類を指定して保存] ドロップダウン メニューより [パッケージド Tableau Flow ファイル] を選択します。

Web 上でフローを自動的に保存する

Tableau Server バージョン 2020.4 以降でサポートされています。

Web 上でフローを作成または編集する場合、フローに変更を加えると (データ ソースに接続してステップを追加するなど)、その作業は数秒ごとに下書きとして保存されるため、作業が失われることはありません。

フローは現在サインインしているサーバーにのみ保存できます。1 つのサーバーでフローの下書きを作成して、別のサーバーに保存またはパブリッシュすることはできません。フローをサーバー上の別のプロジェクトにパブリッシュする場合は、[ファイル] > [Publish As (名前を付けてパブリッシュ)] オプションを使用して、ダイアログからプロジェクトを選択します。

フローの下書きは、パブリッシュしてサーバー上のプロジェクトにアクセスするパーミッションを持つすべてのユーザーが使用できるようになるまで、自分以外のユーザーには表示できません。ステータスが下書きになっているフローには、下書きのバッジが付けられているため、進行中のフローは簡単に見つけることができます。フローがパブリッシュされていない場合は、下書きのバッジの横の [Never Published (パブリッシュされていない)] バッジが表示されます。

フローをパブリッシュした後にフローを編集してもう一度パブリッシュすると、新しいバージョンが作成されます。[リビジョン履歴] ダイアログでフローのバージョンのリストを確認できます。[検索] ページで、[アクション] メニューをクリックし、[リビジョン履歴] を選択します。

リビジョン履歴の管理について詳しくは、Tableau Desktop ヘルプの「コンテンツのリビジョンの操作(Link opens in a new window)」を参照してください。

: 自動保存は既定で有効化されています。管理者がサイトで自動保存を無効にすることは可能ですが、推奨されてません。自動保存をオフにするには、Tableau Server REST API メソッドの「サイトの更新」を使用して、flowAutoSaveEnabled 属性を false に設定します。詳しくは、「Tableau Server REST API サイトのメソッド: サイトの更新(Link opens in a new window)」を参照してください。

ファイルの自動復元

Tableau Prep Builder バージョン 2020.3.3 以降でサポートされています。

既定では、Tableau Prep Builder でアプリケーションがフリーズまたはクラッシュした場合、開いているフローの下書きが自動的に保存されます。フローの下書きは マイ Tableau Prep リポジトリ[Recovered Flow (復元されたフロー)] フォルダーに保存されます。次回アプリケーションを開くと、ダイアログに復元されたフローの選択可能なリストが表示されます。復元されたフローを開いて中断した場所から続行するか、必要がない場合は復元されたフロー ファイルを削除することができます。

: [Recovered Flow (復元されたフロー)] フォルダーの中にフローを復元した場合、このダイアログは、そのフォルダーが空になるまでアプリケーションを開くたびに表示されます。

この機能を有効にしたくない場合、管理者としてインストール中またはインストール後にオフにすることができます。この機能をオフにする方法については、Tableau Desktop および Tableau Prep の導入ガイドにある「ファイルの復元をオフにする(Link opens in a new window)」を参照してください。

Tableau Desktop でフロー出力を表示する

: このオプションは Web 上では使用できません。

データのクリーニングを行う際に、進捗を Tableau Desktop で表示して確認したいと思うことがあるかもしれません。Tableau Desktop でフローを開くと、Tableau Prep Builder が永続的な Tableau .hyper ファイルと Tableau データ ソース (.tds) ファイルを作成します。ファイルは Tableau リポジトリのデータ ソース ファイルに保存されるので、いつでもデータを試すことができます。

Tableau Desktop でフローを開くと、選択したステップまで、操作が適用された状態のフローの作業中のデータ サンプルが表示されます。

: データを試すことはできますが、Tableau ではデータのサンプルのみが表示されるため、ワークブックをパッケージド ワークブック (.twbx) として保存することはできません。Tableau でデータを操作する準備ができたら、フローの出力ステップを作成して出力をファイルに保存するか、パブリッシュされたデータ ソースとして保存してから、Tableau の完全なデータ ソースに接続します。

Tableau Desktop でデータ サンプルを表示するには、次の手順を実行します。

  1. データを表示するステップを右クリックし、コンテキスト メニュ-から [Tableau Desktop でプレビュー] を選択します。

  2. Tableau Desktop が [シート] タブで開きます。

データ抽出ファイルとパブリッシュされたデータ ソースを作成する

重要: Tableau Prep Builder バージョン 2020.3.1 以降では、フロー出力用に Tableau データ抽出 (.tde) ファイルを使用できなくなりました。Server バージョン 2020.3 以降にパブリッシュされ、このファイル タイプに出力されるフローは、変換してから、Hyper 抽出 (.hyper) ファイル タイプに出力する必要があります。そうしない場合は、フローの実行に失敗します。フローが Tableau Server または Tableau Online にパブリッシュされる場合、フローの実行エラーを回避するために、フローをダウンロードして、出力タイプを変更し、フローを再パブリッシュします。

フロー出力を生成するには、フローを実行します。フローを実行すると、変更内容がデータ セット全体に適用されます。フローを実行すると、Tableau データ ソース (.tds) および Tableau データ抽出 (.hyper) ファイルが作成されます。

注: データ抽出やパブリッシュされたデータ ソースは、Tableau Server バージョン 10.0 以降、または Tableau Online にパブリッシュできます。

Tableau Prep Builder

フロー出力から抽出ファイルを作成して、Tableau Desktop で使用したり、データをサード パーティに共有したりできます。抽出ファイルは以下の形式で作成できます。

  • Hyper 抽出 (.hyper): これは最新の Tableau 抽出ファイル タイプですが、Tableau Desktop または Tableau Server バージョン 10.5 以降でのみ使用できます。

  • コンマ区切り値 (.csv): データをサード パーティと共有するには、抽出を .csv ファイルに保存します。エクスポートされた CSV ファイルは、BOM 付きの UTF-8 でエンコードされます。

  • Microsoft Excel (.xlsx): バージョン 2021.1.2 以降、フロー データを Microsoft Excel スプレッドシートに出力できます。レガシーの Microsoft Excel .xls のファイル タイプには対応していません。

Web 上での Tableau Prep Builder

出力をパブリッシュされたデータ ソースとして Tableau Server または Tableau Online にパブリッシュすることで、データのクリーニング、加工、組み合わせを行ったデータへの一元的なアクセスが可能になります。

また、フロー出力をデータベースに保存すると、クリーニングを行って準備が整ったフロー データを使ってテーブル データを作成、置換、または追加することができます。詳しくは、「フロー出力データを外部データベースに保存する」を参照してください。

増分更新を使用してフローを実行することもできます。このオプションを使用すると、時間とリソースを節約でき、全データ セットではなく、新規データのみを更新できます。増分更新を使用して、フローを構成して実行する方法について詳しくは、「増分更新を使用したフロー データの更新」を参照してください。

: Tableau Prep Builder の出力を Tableau Server にパブリッシュするには、Tableau Server REST API を有効にする必要があります。詳しくは、Tableau Rest API ヘルプの「REST API の要件 (英語)(Link opens in a new window)」を参照してください。セキュア ソケット レイヤー (SSL) 暗号化証明書を使用するサーバーにパブリッシュするには、Tableau Prep Builder を実行しているマシンで追加構成ステップが必要です。詳しくは、Tableau Desktop および Tableau Prep Builder 導入ガイドの「インストールの前に(Link opens in a new window)」を参照してください。

抽出ファイルを作成する

: この出力オプションは、Web 上でフローを作成または編集する場合は使用できません。

  1. ステップでプラス アイコン をクリックし、[出力の追加] を選択します。

    以前にフローを実行したことがある場合は、出力ステップでフローの実行 ボタンをクリックします。そうすると、フローが実行され、出力が更新されます。

    [出力] ペインが開き、データのスナップショットが表示されます。

  2. 左側のペインで、[Save output to (出力の保存先)] ドロップダウン リストから [ファイル] を選択します。以前のバージョンで [ファイルに保存] を選択します。

  3. [参照] ボタンをクリックし、[名前を付けて抽出を保存] ダイアログでファイル名を入力して [許可] をクリックします。

  4. [Output type (出力タイプ)] フィールドで、次の出力タイプから選択します。

    • Tableau データ抽出 (.hyper)

    • コンマ区切り値 (.csv)

  5. (Tableau Prep Builder バージョン 2020.2.1 以降) [書き込みオプション] セクションで、既定の書き込みオプションを表示して、新しいデータをファイルに書き込み、必要に応じて変更します。詳しくは、「書き込みオプションの構成」を参照してください。

    • [テーブルの作成]: このオプションでは、新しいテーブルが作成されるか、既存のテーブルが新しい出力に置き換えられます。

    • [テーブルに追加]: このオプションでは、既存のテーブルに新しいデータが追加されます。テーブルが存在しない場合は、新しいテーブルが作成され、以降の実行でこのテーブルに新しい行が追加されます。

      : [テーブルに追加] では、.csv の出力タイプには対応していません。対応している更新の組み合わせについて詳しくは、「フロー更新オプション」を参照してください。

  6. [フローの実行] をクリックしてフローを実行し、抽出ファイルを生成します。

Microsoft Excel ワークシートへの抽出を作成する

Tableau Prep Builder バージョン 2021.1.2 以降でサポートされています。この出力オプションは、現在 Tableau Server や Tableau Online ではサポートされていません。

フロー データを Microsoft Excel ワークシートに出力するには、新しいワークシートを作成するか、既存のワークシートにデータを追加・置換できます。以下の条件が適用されます。

  • 対応しているファイル形式は Microsoft Excel .xlsx のみです。
  • ワークシートの行はセル A1 から始まります。
  • データを追加したり置換する場合、最初の行はヘッダーと見なされます。
  • ヘッダー名は、新しいワークシートを作成するときに追加されますが、既存のワークシートにデータを追加する場合は追加されません。
  • 既存のワークシートの書式や式は、フロー出力に適用されません。
  • 名前付きのテーブルや範囲への書き込みは、現在対応していません。

Microsoft Excel ワークシート ファイルにフロー データを出力する

  1. ステップでプラス アイコン をクリックし、[出力の追加] を選択します。

    以前にフローを実行したことがある場合は、出力ステップでフローの実行 ボタンをクリックします。そうすると、フローが実行され、出力が更新されます。

    [出力] ペインが開き、データのスナップショットが表示されます。

  2. 左側のペインで、[Save output to (出力の保存先)] ドロップダウン リストから [ファイル] を選択します。

  3. [参照] ボタンをクリックし、[名前を付けて抽出を保存] ダイアログでファイル名を入力するか選択して、[許可] をクリックします。

  4. [Output type (出力タイプ)] フィールドで [Microsoft Excel (.xlsx)] を選択します。

  5. [ワークシート] フィールドで、結果を書き込むワークシートを選択するか、フィールドに新しい名前を入力して、[新しいテーブルの作成] をクリックします。
  6. [書き込みオプション] セクションで、次のいずれかのオプションを選択します。

    • テーブルの作成: フロー データが含まれるワークシートを作成するか、ファイルが既に存在する場合は再作成します。

    • テーブルに追加: 既存のワークシートに新しい行を追加します。ワークシートが存在しない場合は、ワークシートが作成され、フローの実行時にそのワークシートに行が追加されます。

    • データの置換: 既存のワークシートの最初の行を除く既存のデータをすべてフローのデータに置き換えます。

      ワークシートが既に存在する場合、フィールドの比較には、ワークシート内のフィールドと一致するフローのフィールドが表示されます。新規のワークシートの場合は、1 対 1 のフィールド一致が表示されます。一致しないフィールドは無視されます。

  7. [フローの実行] をクリックしてフローを実行し、Microsoft Excel 抽出ファイルを生成します。

パブリッシュされたデータ ソースを作成する

  1. ステップでプラス アイコン をクリックし、[出力の追加] を選択します。

    : Tableau Prep Builder では、以前パブリッシュされたデータ ソースが更新され、データ ソースに含まれている可能性のあるデータ モデリング (計算フィールドや番号書式など) が維持されます。データ ソースを更新できない場合は、代わりにデータ ソースが置き換えられます。

  2. [出力] ペインが開き、データのスナップショットが表示されます。

  3. [Save output to (出力の保存先)] ドロップダウン リストから [パブリッシュされたデータ ソース] (以前のバージョンの [データ ソースとしてパブリッシュ]) を選択します。次のフィールドを完了します。

    • サーバー(Tableau Prep Builder のみ): データ ソースとデータ抽出のパブリッシュを行うサーバーを選択します。サーバーにサインインしていない場合は、サインインするよう求められます。

      : Tableau Prep Builder バージョン 2020.1.4 以降では、ユーザーがサーバーにサインインした後、アプリケーションを閉じるときに、Tableau Prep Builder によりサーバー名と認証資格情報が記憶されます。次回アプリケーションを開くと、既にサーバーにサインインしています。

      Mac では、Tableau Prep Builder が SSL 証明書を安全に使用して Tableau Server や Tableau Online 環境に接続できるよう、Mac キーチェーンへのアクセスを提供するよう求められることがあります。

      Tableau Online に出力している場合は、サイトがホストされているポッドを「serverUrl」に含める必要があります。たとえば、「https://online.tableau.com」ではなく「https://eu-west-1a.online.tableau.com」となります。

    • プロジェクト: データ ソースと抽出を読み込むプロジェクトを選択します。

    • 名前: ファイル名を入力します。

    • 説明: データ ソースの説明を入力します。

  4. (Tableau Prep Builder バージョン 2020.2.1 以降) [書き込みオプション] セクションで、既定の書き込みオプションを表示して、新しいデータをファイルに書き込み、必要に応じて変更します。詳しくは、「書き込みオプションの構成」を参照してください。

    • [テーブルの作成]: このオプションでは、新しいテーブルが作成されるか、既存のテーブルが新しい出力に置き換えられます。

    • [テーブルに追加]: このオプションでは、既存のテーブルに新しいデータが追加されます。テーブルが存在しない場合は、新しいテーブルが作成され、以降の実行でこのテーブルに新しい行が追加されます。

  5. [フローの実行] をクリックしてフローを実行し、データ ソースをパブリッシュします。

フロー出力データを外部データベースに保存する

Tableau Prep Builder ではバージョン 2020.3.1 以降、Tableau Server または Tableau Online では、バージョン 2020.4 以降でサポートされています。

重要: この機能を使用すると、外部データベースのデータを完全に削除したり、置き換えたりできます。データベースに書き込むためのパーミッションがあることを確認してください。
データの損失を防ぐために、[カスタム SQL] オプションを使用してテーブル データのコピーを作成し、フロー データをテーブルに書き込む前にコピーを実行できます。

Tableau Prep Builder または Web でサポートされているコネクタからデータに接続して、外部データベースにデータを出力できます。これにより、フローが実行されるたびに、フローのクリーニングされた準備済みのデータを使用して、データベース内のデータを追加または更新できます。この機能は、増分更新と完全更新の両方のオプションで使用できます。増分更新を構成する方法について詳しくは、増分更新を使用したフロー データの更新を参照してください。

フロー出力を外部データベースに保存すると、Tableau Prep は次の処理を実行します。

  1. 行を生成し、データベースに対して SQL コマンドを実行します。
  2. 出力データベースの一時テーブル (または Snowflake に出力する場合はステージング領域) にデータを書き込みます。
  3. 操作が成功すると、データは一時テーブル (または Snowflake のステージング領域) から宛先テーブルに移動されます。
  4. ユーザーがデータをデータベースに書き込んだ後に実行する必要のある SQL コマンドを実行します。

SQL スクリプトが失敗すると、フローは失敗します。ただし、データはデータベース テーブルに引き続き読み込まれます。フローの実行をもう一度やり直すか、データベースで SQL スクリプトを手動で実行して適用することができます。

出力オプション

データベースにデータを書き込むときに、次のオプションを選択できます。テーブルがまだ存在しない場合は、フローが最初に実行されるときにテーブルが作成されます。

  • [テーブルに追加]: このオプションでは、既存のテーブルにデータが追加されます。テーブルが存在しない場合、フローが最初に実行されるときにテーブルが作成され、後続のフローが実行されるたびにそのテーブルにデータが追加されます。
  • [テーブルの作成]: このオプションでは、フローのデータで新しいテーブルが作成されます。テーブルが既に存在する場合、テーブルと、テーブルに定義されている既存のデータ構造またはプロパティは削除され、フロー データ構造を使用する新しいテーブルに置き換えられます。フローに存在するフィールドは、新しいデータベース テーブルに追加されます。
  • [データの置換]: このオプションでは、既存のテーブルのデータが削除され、フローのデータに置き換えられますが、データベース テーブルの構造とプロパティは保持されます。テーブルが存在しない場合、フローが最初に実行されるときにテーブルが作成され、後続のフローが実行されるたびにテーブル データが置き換えられます。

その他のオプション

書き込みオプションに加えて、カスタム SQL スクリプトを含めるか、データベースに新しいテーブルを追加できます。

  • カスタム SQL スクリプト: カスタム SQL を入力し、データがデータベース テーブルに書き込まれる前か後、または前後にスクリプトを実行するかどうかを選択します。これらのスクリプトを使用すると、フロー データがテーブルに書き込まれる前にデータベース テーブルのコピーを作成したり、インデックスを追加したり、他のテーブル プロパティを追加したりすることができます。
  • [新しいテーブルの追加]: 既存のテーブル リストからテーブルを選択するのではなく、一意の名前を持つ新しいテーブルをデータベースに追加します。既定のスキーマ (Microsoft SQL Server と PostgreSQL) 以外のスキーマを適用する場合は、構文 [schema name].[table name] を使用してスキーマを指定できます。

サポートされるデータベースとデータベース要件

Tableau Prepでは、選択した数のデータベースのテーブルへのフロー データの書き込みをサポートしています。Tableau Online のスケジュールに従って実行されるフローは、クラウドでホストされている場合にのみ、これらのデータベースに書き込むことができます。

一部のデータベースには、データの制限や要件があります。Tableau Prep では、ピーク パフォーマンスを維持するため、サポートされているデータベースにデータを書き込む際に、いくつかの制限が設けられる場合があります。次の表に、フロー データを保存できるデータベースと、データベースの制限または要件を示します。これらの要件を満たさないデータを使用すると、フローの実行時にエラーが発生する可能性があります。

: フィールドの文字数制限の設定はまだサポートされていません。ただし、文字制限の制約を含むテーブルをデータベースに作成し、[データの置換] オプションを使用して、データベース内のテーブル構造を維持したまま、データを置き換えることができます。

データベース 要件または制限
Amazon Redshift
  • 照合順序はサポートされていません。詳細については、Amazon Redshift(Link opens in a new window) のドキュメントを参照してください。
  • フィールド名は、すべて小文字に変換されます。
  • テキスト フィールド値には最大 8192 文字を書き込むことができます。長い値は切り詰められます。
Google BigQuery
  • Tableau では、テーブルへの出力として最大 2GB を書き込むことができます。

Microsoft SQL Server
  • テキスト フィールド値には最大 3072 文字を書き込むことができます。長い値は切り詰められます。

MySQL
  • テキスト フィールド値には最大 8192 文字を書き込むことができます。長い値は切り詰められます。
Oracle
  • フィールド名とテーブル名は 30 文字以内にする必要があります。
  • テキスト フィールド値には最大 1000 文字を書き込むことができます。長い値は切り詰められます。
  • フィールド名に特殊文字を使用すると、エラーが発生する場合があります。
PostgreSQL
  • テキスト フィールド値には最大 8192 文字を書き込むことができます。長い値は切り詰められます。
Snowflake
  • テキスト フィールド値には最大 8192 文字を書き込むことができます。長い値は切り詰められます。
  • Tableau Prep でデータベース ウェアハウスにデータを書き込めるようにするには、ウェアハウス オプションを自動再開に設定する必要があります。詳しくは、Snowflake ドキュメントの「Auto-suspension and Auto-resumption (自動中断と自動再開)(Link opens in a new window)」を参照してください。

Teradata
  • テキスト フィールド値には最大 1000 文字を書き込むことができます。長い値は切り詰められます。

フロー データをデータベースに保存する

: Windows 認証を使用したデータベースへのフロー出力の書き込みはサポートされていません。この認証方法を使用する場合は、ユーザー名とパスワードを使用するように接続認証を変更する必要があります。

フローをパブリッシュするときに、データベースの認証資格情報を埋め込むことができます。認証資格情報の埋め込みの詳細については、「Tableau Prep Builder からフローをパブリッシュする」のデータベースセクションを参照してください。

  1. ステップでプラス アイコン をクリックし、[出力の追加] を選択します。
  2. [Save output to (出力の保存先)] ドロップダウン リストから [データベース テーブル] を選択します。
  3. [設定]タブで、次の情報を入力します。
    • [接続] ドロップダウン リストで、フロー出力の書き込みに使用するデータベース コネクタを選択します。サポートされているコネクタのみが表示されます。これらのコネクタは、フロー入力に使用したコネクタと同じコネクタか、別のコネクタです。別のコネクタを選択すると、サインインを求めるメッセージが表示されます。

      重要: 選択したデータベースへの書き込みパーミッションがあることを確認してください。パーミッションがないと、フローでデータが部分的にしか処理されない可能性があります。

    • [データベース] ドロップダウン リストで、フローの出力データを保存するデータベースを選択します。
    • [テーブル] ドロップダウン リストで、フローの出力データを保存するテーブルを選択します。選択した [書き込みオプション」 に応じて、新しいテーブルが作成されたり、フロー データによってテーブル内の既存のデータが置き換えられたり、フロー データが既存のテーブルに追加されたりします。

      データベースに新しいテーブルを作成するには、フィールドに一意のテーブル名を入力し、[新しいテーブルの作成] をクリックします。選択した書き込みオプションに関係なく、フローを初めて実行すると、フローと同じスキーマを使用してデータベースにテーブルが作成されます。

  4. [出力] ペインには、データのスナップショットが表示されます。フィールドの比較には、テーブル内のフィールドと一致する、フローのフィールドが表示されます (テーブルが既に存在する場合)。テーブルが新規の場合は、1 対 1 のフィールド一致が表示されます。

    フィールドの不一致がある場合は、ステータス メモにエラーが表示されます。

    • [一致なし: フィールドは無視されます]: フィールドはフロー内に存在しますが、データベースには存在しません。[テーブルの作成] 書き込みオプションを選択して完全更新を実行しない限り、フィールドはデータベース テーブルに追加されません。完全更新を実行すると、フローのフィールドがデータベース テーブルに追加され、フロー出力スキーマが使用されます。
    • [一致なし: フィールドに Null 値が含まれます]: フィールドはデータベースに存在しますが、フローには存在しません。フローは、フィールドがあるデータベース テーブルに Null 値を渡します。フローにフィールドが存在するが、フィールド名が異なるため、フィールドが一致しない場合は、クリーニング ステップに移動し、データベースのフィールド名と一致するようにフィールド名を編集できます。フィールド名を編集する方法について詳しくは、「クリーニング操作の適用」を参照してください。
    • [エラー: フィールドのデータ型が一致しません]: フローのフィールドと、出力の書き込み先のデータベース テーブルのフィールドに割り当てられるデータ型が一致する必要があります。一致しない場合、フローの実行に失敗します。クリーニング ステップに移動し、フィールドのデータ型を編集すると、この不一致を修正できます。データ型の変更について詳しくは、「データに割り当てられたデータ型の確認」を参照してください。
  5. 書き込みオプションを選択します。完全更新用と増分更新用に別のオプションを選択できます。フロー実行方法を選択するとオプションが適用されます。増分更新を使用したフローの実行について詳しくは、「増分更新を使用したフロー データの更新」を参照してください。
    • [テーブルに追加]: このオプションでは、既存のテーブルにデータが追加されます。テーブルが存在しない場合、フローが最初に実行されるときにテーブルが作成され、後続のフローが実行されるたびにそのテーブルにデータが追加されます。
    • [テーブルの作成]: このオプションでは、新しいテーブルが作成されます。同じ名前のテーブルが既に存在する場合は、既存のテーブルが削除され、新しいテーブルに置き換えられます。テーブルに定義されている既存のデータ構造やプロパティも削除され、フロー データ構造に置き換えられます。フローに存在するフィールドは、新しいデータベース テーブルに追加されます。
    • [データの置換]: このオプションでは、既存のテーブルのデータが削除され、フローのデータに置き換えられますが、データベース テーブルの構造とプロパティは保持されます。
  6. (オプション) [カスタム SQL] タブをクリックし、SQL スクリプトを入力します。データがテーブルに書き込まれる [Before (前)][After (後)] に、実行するスクリプトを入力できます。

  7. [フローの実行] をクリックしてフローを実行し、選択したデータベースにデータを書き込みます。

 

このセクションの他の記事

ありがとうございます!