Windows 上の Internet Explorer 11 および Internet Explorer の互換モードはサポートされていません。

バージョン 2020.4 以降、Tableau Prep ではフローの Web 作成がサポートされています。これにより、Tableau Prep BuilderTableau Server、または Tableau Cloud を使用して、データのクリーニングと準備を行うフローを作成できます。また、Web 上でフローを手動で実行することができ、データ管理 は必要ありません。

Web 上でも Tableau Prep Builder の同じ機能の大部分がサポートされていますが、フローを作成して操作する場合には、いくつかの相違点があります。

重要: Web 上でフローを作成および編集するには、Creator ライセンスが必要です。ただし、データ管理 は、Tableau Prep Conductor を使用してスケジュールに従ってフローを実行する場合にのみ必要です。Tableau Prep Conductor を使用して構成および使用する方法については、Tableau Server(新しいウィンドウでリンクが開く) または Tableau Cloud(新しいウィンドウでリンクが開く) ヘルプの「Tableau Prep Conductor」を参照してください。

インストールと展開

ユーザーが Web 上でフローを作成および編集できるようにするには、サーバーでいくつかの設定を構成する必要があります。これらの各設定の詳細については、「Web 上でのフローの作成と操作」(新しいウィンドウでリンクが開く)を参照してください。

  • Web 作成: ユーザーが Tableau Server または Tableau Cloud でフローを作成および編集できるかどうかを制御します。
  • 今すぐ実行: [今すぐ実行] オプションを使用して、ユーザーまたは管理者のみが手動でフローを実行できるかどうかを制御します。Web 上でフローを手動で実行するには、データ管理 は必要はありません。
  • Tableau Prep Conductor: データ管理 がライセンスされている場合、このオプションを有効にすると、ユーザーはフローをスケジュールおよび追跡できます。
  • Tableau Prep 拡張機能 (バージョン 2021.2.0 以降): ユーザーが Einstein Discovery に接続してフロー内のデータに対して予測モデルを適用および実行できるかどうかを制御します。
  • 自動保存: この機能は既定で有効になっており、数秒ごとにユーザーのフロー作業を自動的に保存します。

Tableau Server では、管理者は Tableau Prep のフロー作成プロセスの構成を微調整できます。詳細については、「Tableau Prep のフローの作成」を参照してください。

サンプル データと処理の制限

Web 上のフローを操作する際のパフォーマンスを維持するために、フローに含めることができるデータの量に制限が適用されます。

以下の制限が適用されます。

  • ファイルに接続する場合、最大ファイル サイズは 1 GB です。
  • すべてのデータを含めるデータ サンプリング オプションは使用できません。既定のサンプル データの制限は 100 万行です。
  • 大きなデータ セットを使用する場合にユーザーが選択できる最大行数は、管理者によって構成されます。ユーザーは、その制限までの行数を選択できます。詳細については、「tsm configuration set のオプション」(新しいウィンドウでリンクが開く)を参照してください。

Web 上で利用可能な機能

Web 上でフローを作成および編集すると、ナビゲーションおよび特定の機能の可用性に多少の相違点があることがわかります。ほとんどの機能はすべてのプラットフォームで利用できますが、一部の機能は Tableau Server または Tableau Cloud で制限が設けられているか、まだサポートされていません。次の表に相違点がある機能を示します。

メジャー エリア 例外 Tableau Prep Builder Tableau Server Tableau Cloud
データへの接続(新しいウィンドウでリンクが開く) 一部のコネクタは、Web 上でサポートされていない場合があります。サーバーの [接続] ウィンドウを開いて、サポートされているコネクタを確認します。
フローの構築と編成(新しいウィンドウでリンクが開く)  
データ サンプルのサイズの設定(新しいウィンドウでリンクが開く) Tableau Server および Tableau Cloud では、データ サンプルのサイズは管理者が設定した制限に従います
インプット ステップのファイルおよびデータベース表のユニオン作成(新しいウィンドウでリンクが開く) インプット ユニオンは、Tableau Server や Tableau Cloud で編集または作成することはできません。Tableau Prep Builder のみ。
データのクリーニングと加工(新しいウィンドウでリンクが開く)  
データ グリッドの値のコピー(新しいウィンドウでリンクが開く) Tableau Prep Builder はバージョン 2022.3.1 から、Tableau Server は 2022.3 から、Tableau Cloud は 2022.2 (8月) から利用可能です。
データの集計、結合またはユニオン(新しいウィンドウでリンクが開く)  
フローでの R および Python スクリプトの使用(新しいウィンドウでリンクが開く) Tableau Cloud でフローを作成または編集する場合、スクリプト ステップを追加することはできません。これは現在、Tableau Prep Builder および Tableau Server でのみサポートされています。
再利用可能なフロー ステップの作成(新しいウィンドウでリンクが開く)  
Web 上でフローを自動的に保存する(新しいウィンドウでリンクが開く)   該当しません
ファイルの自動復元(新しいウィンドウでリンクが開く)   該当しません 該当しません
Tableau Desktop でフロー出力を表示する(新しいウィンドウでリンクが開く)  
抽出ファイルを作成する(新しいウィンドウでリンクが開く)  
Microsoft Excel ワークシートへの抽出を作成する(新しいウィンドウでリンクが開く)  
カスタム SQL クエリへの接続(新しいウィンドウでリンクが開く)  
パブリッシュされたデータ ソースを作成する(新しいウィンドウでリンクが開く)  
フロー出力を外部データベースに保存する(新しいウィンドウでリンクが開く)  
Einstein Discovery 予測をフローに追加する(新しいウィンドウでリンクが開く)  

自動保存と下書き作業

サーバー上でフローを作成または編集すると、数秒ごとに作業が下書きとして保存されるため、クラッシュが発生した場合や、誤ってタブを閉じた場合でも、作業が失われることはありません。

下書きは、サインインしているサーバーとプロジェクトに保存されます。下書きを別のサーバーに保存またはパブリッシュすることはできませんが、[ファイル] > [Publish As (名前を付けてパブリッシュ)] メニュー オプションを使用すると、そのサーバー上の別のプロジェクトにフローを保存できます。

下書きのコンテンツは、パブリッシュするまで自分以外のユーザーには表示できません。変更内容をパブリッシュした後にそれを元に戻す必要がある場合は、[リビジョン履歴] ダイアログを使用して以前パブリッシュしたバージョンを表示し、元に戻すことができます。Web 上でのフローの保存の詳細については、「Web 上でフローを自動的に保存する」(新しいウィンドウでリンクが開く)を参照してください。

Web上でフローをパブリッシュする

Web 上でフローをゼロから作成する場合でも、既存のフローを編集する場合でも、フローを実行する前にパブリッシュする必要があります。

  • フローの下書きはサインインするサーバーにのみパブリッシュできます。
  • [ファイル] メニューの [Publish As (名前を付けてパブリッシュ)] をクリックすると、下書きを別のプロジェクトにパブリッシュできます。
  • フローのデータベース接続に認証資格情報を埋め込むことで、フローの実行時に認証資格情報を手動で入力しなくても、フローを実行できます。

認証資格情報の埋め込み

注: 認証資格情報の埋め込みは、サーバー上でフローを実行する場合にのみ適用されます。現在、認証資格情報は、データベースに接続されているフローを編集する際に手動で入力する必要があります。認証資格情報の埋め込みは、サーバー レベルまたはサイト レベルではなく、フロー レベルでのみ設定できます。

次のいずれかを実行します。

  • トップ メニューから、[ファイル] > [接続の認証資格情報] > [Embeded in Published Flow (パブリッシュされたフローへの埋め込み)] の順に選択します。

  • フローをパブリッシュする場合は、[認証資格情報の埋め込み] チェック ボックスをオンにします。このオプションは、[Publish As (名前を付けてパブリッシュ)] を選択して新しいプロジェクトに初めてフローをパブリッシュしたとき、または他のユーザーが最後にパブリッシュしたフローを編集するときに表示されます。

フローのパブリッシュ

フローをパブリッシュすると、それが現在のバージョンのフローになり、プロジェクトにアクセスできる他のユーザーが実行および表示できます。パブリッシュされていないフローやフローの下書きに対して行った変更内容は、フローをパブリッシュするまで自分以外のユーザーには表示できません。フローのステータスの詳細については、「Web 上でフローを自動的に保存する」(新しいウィンドウでリンクが開く)を参照してください。

フローをパブリッシュするには、次のいずれかを実行します。

  • トップメニューから、[ファイル] > [パブリッシュ] または[ファイル] > [Publish As (名前を付けてパブリッシュ)] を選択します。

  • 上部のバーで [パブリッシュ] ボタンをクリックするか、ドロップダウン矢印をクリックして [Publish As (名前を付けてパブリッシュ)] を選択します。

実行可能なユーザー

  • サーバー管理者、サイト管理者 Creator、および Creator は、完全な接続およびパブリッシュ アクセスを許可します。
  • Creator は、Web 作成タスクを実行できます。
ありがとうございます!