Guida introduttiva a Tableau Prep Builder

Nota: a partire dalla versione 2020.4.1, un utente Creator può anche creare e modificare flussi sul Web. Questa esercitazione è stata progettata utilizzando Tableau Prep Builder, ma le procedure possono essere eseguite anche sul Web, con alcune eccezioni specificate di seguito.

Questa esercitazione introduce alle operazioni comuni disponibili in Tableau Prep. Utilizzando gli insiemi di dati campione forniti con Tableau Prep, ti illustreremo la procedura di creazione di un flusso per Sample Superstore. Questa guida utilizza la versione più recente di Tableau Prep Builder. Se utilizzi una versione precedente, i risultati possono essere diversi.

Fai attenzione ai suggerimenti lungo il percorso per ottenere informazioni su come Tableau Prep ti aiuta a pulire e modellare i dati per l'analisi.

Per installare Tableau Prep Builder prima di continuare con questa guida, vedi Installare Tableau Desktop o Tableau Prep Builder dall'interfaccia utente(Link opens in a new window) nella Guida alla distribuzione di Tableau Desktop e Tableau Prep Builder. In alternativa, puoi scaricare la versione di prova gratuita(Link opens in a new window).

File di esempio

Per completare le attività di questa esercitazione, è necessario installare Tableau Prep Builder o, se il Web authoring è abilitato nel server versione 2020.4 o successiva, è anche possibile eseguire i passaggi sul Web.

Dopo aver installato Tableau Prep Builder nel computer, è anche possibile trovare i file di esempio nel seguente percorso:

  • (Windows) C:\Program Files\Tableau\Tableau Prep Builder <version>\help\Samples\en_US\Superstore Files
  • (Mac) /Applications/Tableau Prep Builder <version>.app/Contents/help/Samples/en_US/Superstore Files

In alternativa, scarica i file di esempio da questi collegamenti e crea una directory Samples e una sottodirectory South. Sarà necessario effettuare tale operazione se esegui questa esercitazione sul Web.

Scarica nella directory Samples Scarica nella sottodirectory South

Questa è la situazione...

Lavori nella sede centrale di una grande catena di vendita al dettaglio. Il tuo capo vuole analizzare le vendite dei prodotti e i profitti degli ultimi quattro anni dell'azienda. Suggerisci di usare Tableau Desktop per farlo. Il tuo capo pensa che sia un'ottima idea e vuole che tu lo faccia bene.

Quando inizi a raccogliere tutti i dati necessari, noti che i dati sono stati raccolti e monitorati in modo diverso per ogni regione. Noti anche molti casi di inserimento dati creativo nei vari file: una regione ha addirittura un file separato per ogni anno!

Prima di poter iniziare ad analizzare i dati in Tableau, dovrai eseguire una seria pulizia dei dati. Si prospetta una serata lunga.

Mentre scruti i menù dei ristoranti per ordinare qualcosa per cena, ti ricordi che Tableau ha introdotto un nuovo prodotto, chiamato Tableau Prep, che potrebbe aiutarti nelle attività di pulizia dei dati.

Scarichi il prodotto, ti registri per una versione di prova gratuita(Link opens in a new window) e decidi di fare un tentativo.

1. Connettersi ai dati

All'apertura di Tableau Prep Builder viene visualizzata una pagina iniziale con un riquadro Connessioni, proprio come su Tableau Desktop.

Per iniziare, il primo passo è quello di connettersi ai dati e creare una fase di input. A partire da lì inizierai a generare un flusso di lavoro o "flusso", come viene chiamato in Tableau Prep, aggiungendo ulteriori fasi per eseguire azioni sui dati durante la procedura.

Suggerimento: la fase di input è il punto di ingestione dei dati e il punto di partenza del flusso. È possibile avere più fasi di input. Alcune di esse possono includere più file di dati. Per ulteriori informazioni sulla connessione ai dati, consulta Connettersi ai dati(Link opens in a new window).

I tuoi file di dati di vendita per le diverse regioni sono memorizzati in diversi formati, mentre gli ordini dal Sud sono in realtà più file. Controllando il riquadro Connessioni, noti che hai a disposizione molte scelte per connetterti ai dati. Fantastico!

Dal momento che le altre regioni hanno un file di dati per ognuno dei quattro anni, decidi di affrontare prima i file del Sud.

  1. Nel riquadro Connessioni, fai clic sul pulsante Aggiungi connessione.

    In Web authoring, nella pagina Home fai clic su Crea > Flusso oppure nella pagina Esplora fai clic su Nuovo > Flusso. Fai clic su Connetti ai dati.

  2. I file sono in formato .csv, per cui seleziona File di testo nell'elenco delle connessioni.

  3. Individua la directory dei file. Nella sottodirectory Orders South seleziona il primo file orders_south_2015.csv e fai clic su Apri per aggiungerlo al flusso. (Per la posizione dei file, consulta Riassunto e risorse.)

    Dopo aver effettuato la connessione al primo file, l'area di lavoro Tableau Prep Builder si apre e viene suddivisa in due sezioni principali. il riquadro Flusso in alto e il riquadro Input in basso.

    In modo molto simile a Tableau Desktop, il riquadro Flusso è un'area di lavoro in cui puoi interagire visivamente con i dati e creare il flusso. Il pannello Input contiene opzioni di configurazione sulle modalità di ingestione dei dati. Il pannello mostra anche i campi, i tipi di dati ed esempi dei valori per il tuo insieme di dati.

    Vedremo come interagire con questi dati nella sezione successiva.

    Suggerimento: per le tabelle singole, Tableau Prep crea automaticamente una fase di input nel riquadro Flusso quando si aggiungono dati al flusso. In alternativa, aggiungi tabelle trascinandole sul pannello Flusso.

  4. Ci sono ancora tre file per gli ordini nel Sud e il modo in cui li combini dipende da dove stai lavorando.

    In Tableau Prep Builder:

    1. Potresti aggiungere ciascun file singolarmente, ma vuoi unire tutti i file in una unica fase di input, per cui fai clic sulla scheda Più file nel riquadro Input.
    2. Vedrai un'opzione Unione metacaratteri. Selezionala.

      Noti che la directory in cui è stato selezionato il file è già popolata e che gli altri file necessari sono elencati nella sezione File inclusi nel riquadro Input.

      Suggerimento: l'utilizzo di un'unione con caratteri jolly è un ottimo modo per connettersi e combinare più file da una singola origine dati con un nome e una struttura simili. Per utilizzare questa opzione, i file devono trovarsi nella stessa directory padre o figlia. Se non vedi subito i file di cui hai bisogno, modifica i criteri di ricerca. Per ulteriori informazioni, consulta Unificare file e tabelle di database nella fase di input(Link opens in a new window).

    3. Fai clic su Applica per aggiungere i dati da questi file alla fase di input orders_south_2015.

    4. I file per le altre regioni sono tutti file a tabella singola, per è possibile selezionare tutti i file in una sola volta e aggiungerli al flusso.

      Nota: sul Web, i file possono essere caricati solo singolarmente.

    In Tableau Server o Tableau Online:

    L'opzione per i caratteri jolly non è attualmente disponibile per Tableau Server o Tableau Online. Vuoi comunque includere tutti i file del Sud e gestire i dati allo stesso modo, quindi combinarli può essere utile.

    1. Ripeti i passaggi 2 e 3 per aggiungere il resto dei file dalla sottodirectory Orders South.
    2. Combinali con una fase di unione. Per ulteriori dettagli, consulta Unificare file e tabelle di database nella fase di input(Link opens in a new window).
      1. Trascina Orders_South_2016 su Orders_South_2015 e rilascialo sull'opzione Unione.

      2. Trascina Orders_South_2017 sopra la nuova fase di unione e rilascialo su Aggiungi. Ripeti questo passaggio con il file finale.

  5. Aggiungi i file rimanenti.

    In Tableau Prep Builder:

    • Apri File Explorer o Finder e passa alla directory dei file. Usa CTRL+clic (Command-clic su Mac) per selezionare i seguenti file, quindi trascinali e rilasciali nel riquadro di Flusso per aggiungerli al flusso. (Per la posizione dei file, consulta Riassunto e risorse.)
      • Orders_Central.csv
      • Orders_East.xlsx
      • Orders_West.csv

    Nota: questi sono tipi di file diversi. Se non li vedi tutti, assicurati che il programma di gestione dei file sia impostato per la visualizzazione di tutti i tipi di file.

    In Tableau Server o Tableau Online:

    • Segui i passaggi 2 e 3 per aggiungere Orders_Central.csv e Orders_West.csv.
    • Nel riquadro Connessioni, fai clic sul pulsante Aggiungi connessione. Fai clic su Microsoft Excel e seleziona Orders_East.xlsx.

Controlla il tuo lavoro: guarda "Connettersi ai dati" in azione.

Fai clic sull'immagine per riprodurla

2. Esplorare i dati

Ora che sono stati caricati i file di dati in Tableau Prep, sei sicuro di voler combinare insieme tutti i file. Prima di procedere, tuttavia, potrebbe essere una buona idea dare prima loro un'occhiata per individuare eventuali problemi.

Quando selezioni una fase di input nel riquadro Flusso, puoi visualizzare le impostazioni utilizzate per inserire i dati, i campi inclusi e un'anteprima dei valori.

Questo è un buon momento per decidere quanti dati vuoi includere nel tuo flusso e rimuovere o filtrare i campi che non ti interessano. Puoi anche modificare i tipi di dati assegnati in modo errato.

Suggerimento: se stai lavorando con insiemi di dati di grandi dimensioni, Tableau Prep introduce automaticamente un campione dei dati per massimizzare le prestazioni. Se non visualizzi i dati previsti, potrebbe essere necessario regolare il campione. È possibile farlo nella scheda Campione dati. Per ulteriori informazioni sulla configurazione delle opzioni dei dati e delle dimensioni del campione, consulta Impostare la dimensione del campione di dati(Link opens in a new window).

Nel riquadro Flusso, quando selezioni ogni fase e analizzi gli insiemi di dati, noti alcune cose che desideri correggere in un secondo momento e una cosa che puoi correggere subito nella fase Input.

  • Seleziona la fase di input Orders_West.

    • Il campo Stato utilizza abbreviazioni per il nome dello stato. Altri file lo indicano per intero, quindi dovrai correggere in un secondo momento.

    • Ci sono molti campi che iniziano con Right_. Questi campi sembrano essere duplicati degli altri. Non vuoi includere questi campi duplicati nel tuo flusso. Questo è qualcosa che puoi risolvere subito nella fase di Input:

      Per risolvere il problema, deseleziona la casella di controllo per tutti i campi che iniziano con Right_. In questo modo, si ordina a Tableau Prep di ignorare questi campi e di non includerli nel flusso.

      Suggerimento: quando esegui le operazioni di pulizia in un passaggio, come la rimozione dei campi, Tableau Prep traccia le modifiche nel riquadro Modifiche e aggiunge un'annotazione (contrassegnata da una piccola icona) nel riquadro del flusso per consentire di tenere traccia delle azioni eseguite sui dati. Nelle fasi di input, l'annotazione si aggiunge anche in ogni campo.

  • Nel riquadro Flusso, fai clic sulla fase di input Orders_Central per selezionarla. Nel riquadro Input, noti i seguenti problemi:

    • Le date dell'ordine e le date di spedizione sono separate in campi per mese, giorno e anno.

    • Alcuni campi hanno tipi di dati diversi dagli stessi campi di altri file.
    • Non ci sono campi Regione.

    Sarà necessario fare un po' di pulizia su questi campi prima di poter combinare questo file con gli altri. Tuttavia, non puoi risolvere il problema nella fase di Input, quindi ti segni di farlo in un secondo momento.

  • Seleziona la fase di input Orders_East.

    I campi in questo file sembrano allinearsi piuttosto bene con gli altri file. Tuttavia, i valori Vendite sembrano avere tutti il codice valuta incluso. Dovrai sistemare anche questo più tardi.

Ora che hai identificato alcuni fattori di disturbo nei tuoi insiemi di dati, la fase successiva consiste nell'esaminare i dati un po' più da vicino e ripulirli dai problemi trovati, in modo da poter combinare e modellare i dati e generare un file di output da poter usare per l'analisi.

3. Pulire i dati

In Tableau Prep, l'esame e pulizia dei dati è un processo iterativo. Dopo aver deciso con quale insieme di dati lavorare, la fase successiva consiste nell'esaminare e operare su tali dati applicandovi varie operazioni di pulizia, sagomatura e combinazione. Applica queste operazioni aggiungendo fasi al flusso. Per ulteriori informazioni sulle opzioni di pulizia, consulta Pulire e dare forma ai dati(Link opens in a new window).

Le fasi sono disponibili in diverse varianti, a seconda di cosa stai cercando di fare. Ad esempio, aggiungi una fase di pulizia ogni volta che desideri applicare operazioni di pulizia ai campi come filtraggio, unione, divisione, ridenominazione e così via. Aggiungi una fase di aggregazione ai campi del gruppo e aggregati e modifica il livello di dettaglio dei dati. Per ulteriori informazioni sui diversi tipi di fasi e sui relativi usi, consulta Creare e organizzare il flusso(Link opens in a new window).

Suggerimento: quando aggiungi fasi al flusso, si genera automaticamente una linea di flusso per collegare le fasi l'una all'altra. Sposta, rimuovi o aggiungi linee di flusso secondo le tue necessità.

Quando esegui il flusso, questi punti di collegamento servono per far sapere a Tableau Prep quali fasi sono collegate e in quale ordine si applicano nel flusso. Se manca una linea di flusso, questo si interrompe, visualizzando un errore.

Pulizia di Orders_Central

Per risolvere i problemi riscontrati in precedenza e per vedere se ce ne sono altri, inizia con l'aggiunta di una fase di pulizia alla fase di input Orders_Central.

  1. Nel riquadro Flusso seleziona Orders_Central, quindi esegui una di queste operazioni:

    • Fai clic sull'icona del segno più e aggiungi una fase di pulizia. A seconda della versione in uso, questa opzione di menu è denominata Aggiungi passaggio, Aggiungi fase di pulizia o Fase di pulizia.
    • Fai clic sulla fase di pulizia consigliata (Tableau Prep Builder versione 2020.3.3 e successive e sul Web)

    Quando aggiungi una fase di pulizia al flusso, l'area di lavoro cambia e si vedono i dettagli dei dati.

    A. Riquadro Flusso, B. Barra degli strumenti, C. Riquadro Profilo, D. Griglia di dati

    L'area di lavoro è ora divisa in tre parti: il riquadro Flusso, il riquadro Profilo con una barra degli strumenti e la griglia Dati.

    Il riquadro Profilo mostra la struttura dei dati, riassumendo i valori dei campi in contenitori, in modo da poter vedere rapidamente i valori correlati e individuare valori erratici e valori NULL. La griglia Dati mostra il dettaglio del livello di riga per i tuoi campi.

    Suggerimento: ogni campo nel riquadro Profilo viene visualizzato su una scheda di profilo. Utilizza il menu Altre opzioni (freccia a discesa nelle versioni precedenti) in ogni scheda per visualizzare e selezionare le diverse opzioni di pulizia disponibili per quel tipo di campo. Puoi anche ordinare i valori del campo, modificare il tipo di dati, assegnare un ruolo dati al campo o trascinare e rilasciare le schede di profilo e le colonne nella griglia Dati per riorganizzarle.

    Pulisci i dati con campi calcolati

    A questo insieme di dati manca un campo Regione. Poiché gli altri insiemi di dati hanno questo campo, dovrai aggiungerlo per poter combinare i dati in seguito. Per fare questo, utilizza un campo calcolato.

  2. Nella barra degli strumenti, fai clic su Crea campo calcolato.

  3. Nell'editor di calcolo, assegna il nome Regione al campo calcolato. Inserisci quindi "Centrale" (incluse le citazioni) e fai clic su Salva.

    La possibilità di utilizzare i campi calcolati per modellare i dati ti piace molto. Noti con piacere che Tableau Prep utilizza lo stesso linguaggio dell'editor di calcolo di Tableau Desktop.

    Suggerimento: quando si apportano modifiche ai campi e ai valori, Tableau Prep ne tiene traccia nel riquadro Modifiche sulla sinistra. Viene aggiunta anche un'icona (annotazione) che rappresenta la modifica alla fase di pulizia nel flusso e al campo nel riquadro Profilo. Esamineremo il riquadro Modifiche dopo aver apportato ulteriori modifiche.

    Successivamente, devi risolvere il problema dei campi della data dell'ordine e della data di spedizione separati. Devi combinarli in due campi singoli, uno per la Data dell'ordine e uno per la Data di spedizione, in modo da allinearli con gli stessi campi degli altri insiemi di dati. Verificare che le tabelle contengano gli stessi campi ti permetterà di combinare le tabelle tramite un'unione in un secondo momento.

    Utilizza di nuovo un campo calcolato per fare questo in un unico e semplice passaggio.

  4. Nella barra degli strumenti, fai clic su Crea campo calcolato per combinare i campi Anno dell'ordine, Mese dell'ordine e Giorno dell'ordine in un campo con il formato "MM/GG/AAAA".

  5. Nell'editor di calcolo, assegna il nome Data ordine al campo calcolato. Inserisci quindi il seguente calcolo e fai clic su Salva:

    MAKEDATE([Order Year],[Order Month],[Order Day])

    Ora hai a disposizione un nuovo campo per la data dell'ordine, devi rimuovere i campi esistenti, in quanto non sono più necessari.

    Ci sono molti campi nel riquadro Profilo. Noti una casella di ricerca nell'angolo in alto a destra della barra degli strumenti. Ti chiedi se puoi usarla per trovare rapidamente i campi da rimuovere. Decidi di fare un tentativo.

  6. Nel riquadro Profilo, nella casella di ricerca, digita Ordine.

    Tableau Prep fa scorrere rapidamente in vista tutti i campi con Ordine nel nome. Wow!

  7. Usa CTRL+clic o Command+clic (macOS) per selezionare i campi per Anno ordine, Mese ordine e Giorno ordine. Quindi, fai clic con il pulsante destro del mouse sui campi selezionati e seleziona Rimuovi (Rimuovi campo nelle versioni precedenti) dal menu per procedere alla rimozione.

  8. Ripeti ora i passaggi 4 e 7 per creare un unico campo Data di spedizione. Prova da solo o segui i passaggi qui sotto per aiutarti.

    • Nella barra degli strumenti, fai clic su Crea campo calcolato per combinare i campi Anno di spedizione, Mese di spedizione e Giorno di spedizione in un campo con il formato "MM/GG/AAAA".

    • Assegna il nome Data di spedizione al campo calcolato e inserisci il calcolo MAKEDATE([Ship Year],[Ship Month],[Ship Day]). Quindi fai clic su Salva.

    • Rimuovi i campi Anno di spedizione, Mese di spedizione e Giorno di spedizione. Per rimuovere i campi, cerca i campi, selezionali e fai clic su Rimuovi (Rimuovi campo nelle versioni precedenti) dal menu.

    Suggerimento: Tableau Prep riassume i dati nel riquadro Profilo in contenitori per aiutarti a visualizzarne rapidamente la forma, trovare i valori erratici, individuare relazioni tra i campi e così via.

    In questo scenario, le date di ordine e spedizione possono ora essere riassunte per anno. Ciascun contenitore rappresenta un anno a partire da gennaio dell'anno di inizio fino al gennaio dell'anno successivo ed è etichettato di conseguenza. Poiché ci sono date di vendita e date di spedizione che cadono nell'ultima parte del 2018 e 2019, avremo un contenitore per quei dati etichettato di conseguenza con l'anno finale 2019 e 2020.

    Per modificare questa vista in base alle date effettive, fai clic sul menu Altre opzioni (freccia a discesa nelle versioni precedenti) nella scheda Profilo e seleziona Dettagli.

    Interazione diretta con i campi per la pulizia dei dati

    I tuoi dati cominciano ad avere un bell'aspetto. Tuttavia, quando finisci di rimuovere i campi in eccesso per le date di ordine e spedizione, noti un paio di problemi nel campo Sconti.

    • Il campo è assegnato a un tipo di dati Stringa invece che ad un tipo di dati Numero (decimale).

    • In assenza di sconto, è presente un valore di campo Nessuno invece di un valore numerico.

    Questo causerà un problema nella combinazione dei file, quindi è meglio risolverlo subito.

  9. Cancella la ricerca e inserisci sconti nella casella di ricerca per trovare il campo.

  10. Seleziona il campo Sconti, fai doppio clic sul valore del campo Nessuno e modificalo nel valore numerico 0.

  11. Per modificare il tipo di dati per il campo Sconto da Stringa a Numero (decimale), fai clic su Abc e seleziona Numero (decimale) dal menu a discesa.

  12. Infine, assegna un nome alla fase per tenere traccia di quello che hai fatto. Nel riquadro Flusso, fai doppio clic sul nome del passo Pulizia 1 e digita Correggi date/nomi del campo.

Revisione delle modifiche

Hai apportato molte modifiche a questo insieme di dati e inizi a preoccuparti di non ricordare tutto quello che hai fatto. Mentre guardi il tuo lavoro, noti una colonna a sinistra del riquadro Profilo chiamata Modifiche.

Fai clic sulla freccia per aprirla e, per la tua gioia, si apre un elenco di tutte le modifiche che hai appena apportato. Mentre scorri le modifiche nell'elenco, noti che le puoi cancellare, modificare o addirittura spostare per cambiare l'ordine in cui le hai apportate.

Ti piace il fatto che puoi facilmente trovare le modifiche apportate in ogni fase della generazione del flusso e sperimentarne l'ordine per sfruttare al massimo i tuoi dati.

Controlla il tuo lavoro: guarda "Pulire Orders_Central" in azione.

Fai clic sull'immagine per riprodurla

Ora che hai pulito un file, dai un'occhiata agli altri file per vedere quali altri problemi devi risolvere.

Decidi di esaminare il file Excel Orders_East.

Pulizia di Orders_East

Osservando i campi del file Orders_East, questi sembrano prevalentemente allineati con gli altri file, a eccezione del campo Vendite. Per dare un'occhiata più da vicino e verificare se ci sono altri problemi da risolvere, aggiungi una fase di pulizia alla fase di input Orders_East.

  1. Nel riquadro Flusso seleziona Orders_East, quindi esegui una di queste operazioni:

    • Fai clic sull'icona del segno più e aggiungi una fase di pulizia. A seconda della versione in uso, questa opzione di menu è denominata Aggiungi passaggio, Aggiungi fase di pulizia o Fase di pulizia.
    • Fai clic sulla fase di pulizia consigliata (Tableau Prep Builder versione 2020.3.3 e successive e sul Web).

    Osservando il campo Vendite, noti subito che il codice valuta USD è stato incluso con i numeri di vendita: Tableau Prep ha interpretato questi valori del campo come una stringa.

    Dovrai rimuovere il codice valuta da questo campo e cambiare il tipo di dati se vuoi ottenere dati di vendita precisi.

    Correggere il tipo di dati è facile, sai già come farlo. Tuttavia, ci sono oltre 2000 righe uniche di dati di vendita: correggere ogni singola riga per rimuovere il codice della valuta sembra scomodo.

    Ma questo è Tableau Prep: decidi di controllare il menu a discesa per vedere se è disponibile un'opzione per risolvere il problema.

    Quando fai clic su Altre opzioni (freccia a discesa nelle versioni precedenti) per il campo Vendite, appaiono un'opzione di menu denominata Pulisci e un'opzione sotto di essa per rimuovere le lettere. Decidi di provarci e vedere cosa succede.

  2. Seleziona il campo Vendite. Fai clic sul menu Altre opzioni (freccia a discesa nelle versioni precedenti) e seleziona Pulisci > Rimuovi lettere.

    Wow! L'opzione di pulizia ha immediatamente rimosso il codice valuta da tutti i campi. Ora basta solo cambiare il tipo di dati da Stringa a Numero (decimale) per dare un bell'aspetto al file.

  3. Fai clic sul tipo di dati per il campo Vendite e seleziona Numero (decimale) dall'elenco a discesa per modificare il tipo di dati.

  4. Il resto del file sembra a posto. Assegna un nome alla fase di pulizia per tenere traccia del tuo lavoro. Ad esempio, Modifica tipo di dati.

Dopodiché passi all'ultimo file, Orders_West, per vedere se ci sono problemi da risolvere.

Pulizia di Orders_West

Osservando i campi del file Orders_West, questi sembrano prevalentemente allineati con gli altri file, ma ricordi di aver notato che il campo Stati usava abbreviazioni per i valori invece di indicare il nome dello stato per intero. Per combinare questo file con gli altri, devi risolvere il problema. Aggiungi quindi una fase di pulizia alla fase di input Orders_West.

  1. Nel riquadro Flusso seleziona Orders_West, quindi esegui una di queste operazioni:

    • Fai clic sull'icona del segno più e aggiungi una fase di pulizia.
    • Fai clic sulla fase di pulizia consigliata (Tableau Prep Builder versione 2020.3.3 e successive e sul Web).
  2. Scorri o utilizza la ricerca per trovare il campo Stato.

    Noti che tutti i valori del nome dello stato usano l'abbreviazione breve. Ci sono solo 11 valori univoci per questo campo. Puoi cambiarle manualmente, ma forse Tableau Prep ha un altro modo per farlo?

    Facendo clic sul menu Altre opzioni (freccia a discesa nelle versioni precedenti) per il campo, puoi notare un'opzione denominata Raggruppa valori (Raggruppa e sostituisci nelle versioni precedenti). Quando lo selezioni, appaiono diverse opzioni:

    • Selezione manuale

    • Pronuncia

    • Caratteri comuni

    • Spelling

    I nomi degli stati non si assomigliano, non sono scritti in modo errato e non condividono gli stessi caratteri, per cui decidi di provare l'opzione Selezione manuale.

    Suggerimento: fai doppio clic sul nome o sul valore di un campo per modificare un singolo valore. Per modificare più valori, seleziona tutti i valori e utilizza l'opzione del menu Modifica valori con il tasto destro del mouse. Se invece desideri mappare uno o più valori su valori specifici, utilizza l'opzione Raggruppa valori nel menu a discesa.
    Per ulteriori informazioni sulla modifica e il raggruppamento dei valori, consulta Modificare i valori di campo(Link opens in a new window).

  3. Seleziona il campo Stato. Fai clic sulla freccia a discesa e seleziona Raggruppa valori (Raggruppa e sostituisci nelle versioni precedenti) > Selezione manuale.

    Si apre una scheda a due colonne: l'editor di Raggruppa valori. La colonna a sinistra mostra i valori correnti dei campi, mentre la colonna a destra mostra i campi disponibili per la mappatura dei campi a sinistra.

    Desideri mappare le abbreviazioni dello stato sulla versione estesa del nome dello stato, ma non disponi di questi valori nell'insieme di dati Orders_West. Ti chiedi se puoi modificare direttamente il nome e magari aggiungerlo lì, quindi fai un tentativo.

  4. Nell'editor di Raggruppa valori, nel riquadro di sinistra, fai doppio clic su AZ per evidenziare il valore e digita Arizona. Premi quindi Invio per aggiungere la modifica.

    Tableau Prep ha creato un valore mappato per il nuovo valore Arizona e mappato automaticamente il valore precedente, AZ. L'impostazione di una relazione mappata per questi valori ti permette di risparmiare tempo se ottieni più dati immessi in questo modo provenienti da questa regione.

    Suggerimento: aggiungi valori di campo che non sono nel campione di dati per impostare relazioni di mapping per organizzare i dati. Se aggiorni l'origine dati e sono presenti nuovi dati, puoi aggiungerli alla mappatura senza correggere manualmente ogni valore.

    Quando aggiungi manualmente un valore che non è nel campione di dati, il valore è contrassegnato con un punto rosso per aiutarti a identificarlo facilmente.

  5. Ripeti questi passaggi per mappare ogni stato sulla versione estesa del suo nome.

    Abbreviazione Nome stato
    AZ Arizona
    CA California
    CO Colorado
    ID Idaho
    MT Montana
    NM Nuovo Messico
    NV Nevada
    OR Oregon
    UT Utah
    WA Washington
    WY Wyoming

    Fai quindi clic su Fine per chiudere l'editor di Raggruppa valori.

    Dopo aver mappato tutti gli stati, osservi il riquadro Modifiche e noti che è presente solo una voce invece di 11.

    Tableau Prep ha raggruppato le azioni simili per un campo. Questo ti piace, perché così sarà più facile trovare le modifiche apportate all'insieme di dati in un secondo momento.

    Correggere i valori del campo Stato era l'unica modifica che dovevi apportare qui.

  6. Assegna un nome alla fase di pulizia per tenere traccia del tuo lavoro. Ad esempio, Rinomina stati.

Hai fatto una gran pulizia dei file e non riesci a credere a quanto sia stato facile e veloce. Alla fine, potresti riuscire a essere a casa per cena! Per assicurarti di non perdere tutto il lavoro fatto finora, salva il flusso.

Nota: se lavori sul Web, le modifiche vengono salvate automaticamente, creando una bozza di flusso. Fai clic sul titolo della bozza per assegnare un nome alla bozza. Per maggiori informazioni sul Web authoring, consulta Tableau Prep sul Web.

Fai clic su File > Salva o File > Salva con nome. Salva il file come file di flusso (.tfl) e dagli un nome. Ad esempio, My Superstore.

Suggerimento: oltre a come file di flusso (.tfl), salva i flussi come file pacchetto (.tflx) includendo i tuoi file di dati locali per condividere il flusso e i file con qualcun altro. Per maggiori informazioni sul salvataggio e la condivisione dei flussi, consulta Salvare e condividere il lavoro(Link opens in a new window).

4. Combinare i dati

Ora che tutti i file sono stati ripuliti, sei finalmente pronto a combinarli tutti.

Poiché tutti i file hanno campi simili dopo la pulizia, per recuperare tutte le righe in un'unica tabella, devi unire le tabelle.

Ti ricordi che era disponibile un'opzione per le fasi denominata Unione, ma ti domandi se puoi semplicemente trascinare e rilasciare le fasi per unirle. Decidi di fare un tentativo e vedere cosa accade.

Unificare i dati

  1. Segui i passaggi in base alla posizione in cui stai lavorando.

    Tableau Prep Builder

    • Nel riquadro Flusso trascina la fase di pulizia Rinomina stati nella fase di pulizia Tipo di dati modificato e rilasciala sull'opzione Unione.

      È stato aggiunto un nuovo passaggio di Unione al flusso da parte di Tableau Prep Builder. Fantastico! Adesso vuoi aggiungere anche gli altri file a questa unione.

    Tableau Server o Tableau Online

    • Nel riquadro Flusso trascina la fase di pulizia Rinomina stati nella fase di unione creata in precedenza per i file South e rilasciala sull'opzione Aggiungi.

      Puoi vedere che Tableau Prep ha aggiunto i nuovi file all'unione precedente. Fantastico! Adesso vuoi aggiungere anche gli altri file a questa unione.

  2. Trascina la fase di pulizia successiva nel flusso sulla fase Unione, quindi rilasciala su Aggiungi per aggiungerla all'unione esistente.

  3. Trascina il passaggio rimanente (la fase di input orders_south_2015 se lavori in Tableau Prep Builder o la fase di pulizia se lavori sul Web) nella nuova fase Unione. Rilasciala su Aggiungi per aggiungerla all'unione esistente.

    Ora tutti i tuoi file sono riuniti in un'unica tabella. Nel riquadro Flusso seleziona la nuova fase Unione per vedere i risultati.

    In Tableau Prep Builder:

    In Tableau Server o Tableau Online:


    Noti che Tableau ha abbinato in automatico i campi con gli stessi nomi e tipi.

    Vedi anche che i colori assegnati alle fasi del flusso sono usati nei profili di unione per indicare la provenienza del campo e appaiono anche nella banda colorata che attraversa la parte superiore di ciascun campo per indicare se esiste in quella tabella.

    Noti che è stato aggiunto un nuovo campo, chiamato Nomi tabelle, che elenca le tabelle da cui provengono tutte le righe dell'unione.

    Nel riquadro di riepilogo compare anche un elenco di campi senza corrispondenza e noti subito che i campi Prodotto e Sconti appaiono solo nel file Orders_Central.

  4. Per dare un'occhiata più da vicino a questi campi, nel riquadro Risultati unione, seleziona la casella di controllo Mostra solo campi senza corrispondenza.

    Osservando i dati del campo, noti subito che i dati sono gli stessi, ma il nome del campo è diverso. Si potrebbe semplicemente rinominare il campo, ma ti chiedi se è possibile trascinare e rilasciare i campi per unirli. Decidi di fare un tentativo e vedere cosa accade.

  5. Seleziona il campo Prodotto, trascinalo e rilascialo nel campo Nome prodotto per unire i due campi. Dopo l'unione, i campi non appaiono più nel riquadro.

  6. Ripeti questo passaggio per unire il campo Sconti con il campo Sconto.

    L'unico campo senza corrispondenza è ora il campo Percorsi file. In Tableau Prep Builder, questo campo mostra i percorsi dei file per l'unione di metacaratteri che hai fatto per gli ordini di vendita dal Sud. Decidi di tenere questo campo perché contiene informazioni utili.

    Suggerimento: esistono diverse opzioni per la correzione di campi senza corrispondenza dopo un'unione. Se Tableau Prep rileva una possibile corrispondenza, la evidenzierà in giallo. Per unire i campi, passa con il mouse sul campo evidenziato e fai clic sul pulsante con il simbolo più che appare.

    Per ulteriori modi per unire i campi in un'unione, consulta Correggere i campi che non corrispondono.

  7. Deseleziona la casella di controllo Mostra solo i campi senza corrispondenza per mostrare tutti i campi inclusi nell'unione.

  8. Assegna un nome alla fase di unione per rappresentare cosa è incluso nell'unione. Ad esempio, Tutti gli ordini.

Controlla il tuo lavoro: guarda "Unione dei dati" in azione.

Fai clic sull'immagine per riprodurla

Sei un genio delle pulizie! Mentre stai ammirando i risultati del tuo lavoro di pulizia, ti chiama il tuo capo. Ha dimenticato di dirti di includere nella tua analisi eventuali resi dei prodotti. Spera che questo non crei troppi problemi. Con Tableau Prep nel tuo toolkit, non è un problema.

Pulire i dati relativi ai resi dei prodotti

Osservando il file Excel dei resi dei prodotti inviato dal capo, sembra un po' disordinato. Aggiungi il nuovo file return_reasons new al flusso per dare un'occhiata più da vicino.

  1. Nel riquadro Connessioni, fai clic su Aggiungi connessione. Seleziona Microsoft Excel e passa ai file di dati di esempio in uso per questo esercizio. Consulta File di esempio per scaricare il file.

  2. Seleziona return reasons_new.xlsx, quindi fai clic su Apri per aggiungere il file al riquadro di flusso.

    In questo file, ci sono solo quattro campi da includere nel flusso: ID ordine, ID prodotto, Motivo del reso e Note.

  3. Nel riquadro Input per returns_new deseleziona la casella di controllo nella parte superiore della prima colonna a sinistra per deselezionarle tutte. Seleziona quindi la casella di controllo per i campi ID ordine, ID prodotto, Motivo del reso e Note.

  4. Rinomina la fase di input per rappresentare meglio i dati inclusi in questo input. Nel riquadro Flusso, fai doppio clic sul nome della fase di input Returns_new e digita Resi (tutti).

    Osservando i valori dei campi campione, noti che il campo Note sembra avere molti dati diversi combinati insieme.

    Dovrai fare un po' di pulizia in questo file prima di procedere con qualsiasi altra operazione con i dati, quindi aggiungi una fase di pulizia per controllarlo.

  5. Nel riquadro Flusso seleziona la fase di input Resi (tutti), quindi fai clic sull'icona del segno più o sulla fase di pulizia consigliata per aggiungere una fase di pulizia.

    Nel riquadro Profilo ridimensiona il campo Note in modo da poter visualizzare meglio le voci. A tale scopo, fai clic e trascina il bordo esterno destro del campo verso destra.

  6. Nel campo Note, utilizza la barra di scorrimento visiva a destra dei valori del campo per esaminarli.

    Noti alcuni problemi:

    • Alcune delle voci hanno uno spazio in eccesso nella voce. Questo può portare alla lettura del campo come valore NULL.

    • Sembra che il nome dell'approvatore sia incluso nella voce delle note del reso. Per lavorare meglio con questi dati, ti servono quelle informazioni inserite in un campo separato.

    Per risolvere il problema degli spazi in eccesso, ti ricordi che c'era un'opzione di pulizia per rimuovere gli spazi finali, così decidi di provarla per vedere se può essere d'aiuto.

  7. Seleziona il campo Note. Fai clic sul menu Altre opzioni (freccia del menu a discesa nelle versioni precedenti) e seleziona Pulisci > Elimina spazi.

    Sì! Ha fatto esattamente quello che volevi che facesse. Gli spazi in eccesso sono spariti.

    Adesso vuoi creare un campo separato per il nome dell'approvatore. Noti un'opzione Dividi valori nel menu, quindi decidi di provare.

  8. Seleziona il campo Note. Fai clic sul menu Altre opzioni (freccia a discesa nelle versioni precedenti) e seleziona Dividi valori > Divisione automatica.

    Questa opzione ha fatto esattamente quello che speravi: ha diviso automaticamente le note dei resi e il nome dell'approvatore in campi separati.

    Proprio come in Tableau Desktop, Tableau Prep ha assegnato automaticamente un nome ai campi. Dovrai quindi rinominare i nuovi campi in qualcosa di rilevante.

  9. Seleziona il campo Note-Split 1. Fai doppio clic sul nome del campo e digita Note dei resi.

  10. Ripeti questo passaggio per il secondo campo e rinominalo in Approvatore.

  11. Infine, rimuovi il campo Note originale, poiché non ne hai più bisogno. Seleziona il campo Note, fai clic sul menu Altre opzioni (freccia a discesa nelle versioni precedenti) e seleziona Rimuovi (Rimuovi campo nelle versioni precedenti) dal menu.

    Osservando il nuovo campo Approvatore, noti che i valori del campo elencano gli stessi nomi, ma sono inseriti in modo diverso. Li vuoi raggruppare per eliminare varianti multiple dello stesso valore.

    Forse l'opzione Raggruppa valori (Raggruppa e sostituisci nelle versioni precedenti) può essere d'aiuto in questo senso?

    Ti ricordi che c'era un'opzione Caratteri comuni. Poiché questi valori condividono le stesse lettere, decidi di provarla.

  12. Seleziona il campo Approvatore. Fai clic sul menu Altre opzioni (freccia a discesa nelle versioni precedenti) e seleziona Raggruppa valori (Raggruppa e sostituisci nelle versioni precedenti) > Caratteri comuni.

    Questa opzione ha raggruppato per te tutte le varianti di ogni nome. È proprio quello che volevi fare.

    Dopo aver controllato gli altri nomi per assicurarti che siano raggruppati correttamente, fai clic su Fine per chiudere l'editor di Raggruppa valori.

    Il file ha proprio un bell'aspetto.

  13. Assegna un nome alla fase di pulizia per tenere traccia del tuo lavoro. Ad esempio, Note pulite.

Ora che i dati dei resi dei prodotti sono stati ripuliti, li vuoi aggiungere ai dati degli ordini dai file uniti. Molti di questi campi, però, non esistono nei file unificati. Per aggiungere questi campi (colonne di dati) al tuo insieme di dati unificato, devi utilizzare un join.

Creare un join tra i dati

Quando si crea un join di dati, i file devono avere almeno un campo in comune. I tuoi file condividono i campi ID ordine e ID prodotto, quindi puoi creare un join in questi campi per vedere tutte le righe che li hanno in comune. Hai visto un'opzione per creare un join quando hai creato l'unione tramite il trascinamento della selezione, ora prova ad usarla.

  1. Nel riquadro Flusso, trascina la fase Note pulite sulla fase di unione Tutti gli ordini e rilasciala su Join.

    Quando crei un join dei file, Tableau Prep ne mostra i risultati nel Profilo del join.

    Lavorare con i join può essere difficile. Spesso hai bisogno di una vista chiara dei fattori inclusi nel join, come i campi utilizzati per unire i file, il numero di righe incluse nei risultati ed eventuali campi che non sono inclusi o sono valori nulli.

    Mentre esamini i risultati del join in Tableau Prep, sei felice di vedere così tante informazioni e interattività a portata di mano.

    Suggerimento: esplora e interagisci con il tuo join sul riquadro all'estrema sinistra del profilo del join. Puoi anche correggere i valori direttamente nei riquadri Clausole join ed eseguire operazioni di pulizia nel riquadro Risultati join.

    Fai clic nel diagramma Tipo di join per provare diverse configurazioni di join e vedi il numero di righe incluse o escluse nel tuo join per ogni tabella nella sezione Riepilogo risultati join.

    Seleziona i campi che vuoi includere nel join nella sezione Clausole join applicate o aggiungi le clausole join suggerite nella sezione Suggerimenti per le clausole join.

    Per ulteriori informazioni su come lavorare con i join, consulta Aggregare, creare un join o unificare i dati(Link opens in a new window).

    Noti che hai oltre 13.000 righe escluse dai tuoi file Tutti gli ordini. Una volta creato il join, Tableau Prep ha eseguito automaticamente il join sul campo ID prodotto, ma desideravi aggiungere anche il campo ID ordine.

    Mentre esamini il pannello sinistro del profilo del join, noti che ID ordine è nell'elenco delle clausole del join consigliate, quindi lo aggiungi subito da lì.

  2. Nel riquadro a sinistra del profilo Join, nella sezione Clausole del join consigliate, seleziona ID ordine = ID ordine e fai clic sul pulsante con l'icona del più per aggiungere la clausola del join.

    Siccome il Tipo di join è impostato su un join interno (l'impostazione predefinita per Tableau Prep), il join include solo i valori presenti in entrambi i file. Tu, però, vuoi tutti i dati dei file degli Ordini e i dati dei resi di tali file. Dovrai quindi cambiare il tipo di join.

  3. Nella sezione Tipo di join, fai clic sul lato del diagramma per includere tutti gli ordini. Nell'esempio qui sotto, fai clic sul lato sinistro del diagramma per modificare il tipo di join in un join A sinistra e includere tutti i dati dalla fase di unione Tutti gli ordini e tutti i dati corrispondenti dalla fase Note pulite.

    Ora hai tutti i dati dei file degli ordini di vendita e tutti i dati dei resi applicabili a tali ordini. Osservando il riquadro Clausole join, noti i valori distinti che non esistono nell'altro file.

    Ad esempio ci sono molte righe dell'ordine (mostrate in rosso) che non hanno dati dei resi corrispondenti. Ti piace essere in grado di esplorare il tuo join a questo livello di dettaglio.

    Sei ansioso di iniziare ad analizzare questi dati in Tableau Desktop, ma noti alcuni risultati del join da ripulire prima di procedere. Meno male che sai cosa fare!

    Suggerimento: vuoi sapere se i tuoi dati sono sufficientemente puliti? In Tableau Prep Builder, visualizza i dati in anteprima in Tableau Desktop in qualsiasi fase del flusso per controllarli.

    Fai semplicemente clic con il tasto destro del mouse sulla fase nel riquadro Flusso e seleziona Anteprima in Tableau Desktop dal menu.

    Puoi effettuare esperimenti con i dati e le eventuali modifiche apportate in Tableau Desktop non riscriveranno l'origine dati in Tableau Prep Builder. Per ulteriori informazioni, consulta Visualizzare l'output del flusso in Tableau Desktop(Link opens in a new window).

  4. Prima di iniziare a pulire i risultati del join, assegna il nome Ordini+Resi alla fase di join e salva il flusso.

Pulire i risultati del join

Nota: per pulire i campi del join, puoi eseguire le operazioni di pulizia direttamente nella fase di join. Ai fini di questa esercitazione, aggiungeremo una fase di pulizia per permetterti di visualizzare chiaramente le operazioni di pulizia. Se desideri provare a eseguire questi passaggi direttamente nella fase di unione, salta i passaggi 1 e 3 indicati di seguito.

Quando hai unito le due fasi, sono stati aggiunti i campi in comune ID ordine e ID prodotto a entrambe le tabelle.

Vuoi conservare il campo ID prodotto di tutti gli ordini e il campo ID ordine del file dei resi, rimuovendo i campi duplicati provenienti da tali file. Inoltre, nel file di output non sono necessari i campi Percorsi file e Nomi tabelle, quindi rimuoveremo anche questi campi.

Suggerimento: quando unisci le tabelle utilizzando campi esistenti in entrambi i file, Tableau Prep include entrambi i campi e rinomina il campo duplicato del secondo file aggiungendo "-1" o "-2" al nome del campo. Ad esempio, Order ID e Order ID-1.

  1. Nel riquadro Flusso seleziona Ordini+Resi, fai clic sull'icona del segno più e aggiungi una fase di pulizia.

  2. Nel riquadro Profilo, seleziona e rimuovi i seguenti campi:

    • Nomi tabelle

    • ID ordine

    • Percorsi file (solo Tableau Prep Builder)

    • ID prodotto-1

  3. Rinomina il campo ID ordine-1 in ID ordine.

    Hai un certo numero di valori NULL dove il prodotto è stato reso, ma non erano indicati approvatori o note di reso. Per facilitare l'analisi di questi dati, vuoi aggiungere un campo con un valore di e No per indicare se il prodotto è stato reso.

    Questo campo non esiste, ma puoi aggiungerlo creando un campo calcolato.

  4. Nella barra degli strumenti, fai clic su Crea campo calcolato.

  5. Nomina il campo Reso?, quindi inserisci il seguente calcolo e fai clic su Salva.

    If ISNULL([Return Reason])=FALSE THEN "Yes" ELSE "No" END

    Per la tua analisi, vorresti anche conoscere il numero di giorni necessari per spedire un ordine, ma non hai nemmeno quel campo.

    Tuttavia, hai tutte le informazioni di cui hai bisogno per crearlo, quindi aggiungi un altro campo calcolato.

  6. Nella barra degli strumenti, fai clic su Crea campo calcolato.

  7. Nomina il campo Giorni per spedizione, quindi inserisci il seguente calcolo e fai clic su Salva.

    DATEDIFF('day',[Order Date],[Ship Date])

  8. Assegna il nome Ordini puliti+Resi.

  9. Salva il flusso.

5. Eseguire il flusso e generare l'output

I tuoi dati hanno un bell'aspetto: sei pronto a generare il tuo file di output per iniziare ad analizzarli in Tableau Desktop. Tutto quello che devi fare è eseguire il flusso e generare il file di estrazione. Per fare questo, è necessario aggiungere una fase Output.

A seconda di dove stai lavorando, puoi inviare l'output del flusso in un file (solo Tableau Prep Builder), in un'origine dati pubblicata o in un database.

  1. Nel riquadro di flusso seleziona Pulisci Ordini+Resi, fai clic sull'icona del segno più e seleziona Output (Aggiungi output nelle versioni precedenti).

    Quando aggiungi una fase di output, si apre il riquadro Output, che mostra un'istantanea dei dati. Qui puoi selezionare il tipo di output che desideri generare e specificare il nome e posizione in cui desideri salvare il file.

    Il percorso predefinito si trova nella repository My Tableau Prep Builder nella cartella di origini di dati.

  2. Nel riquadro sinistro, nell'elenco a discesa Salva output in, a seconda di dove stai lavorando, esegui una di queste operazioni:

    Tableau Prep Builder

    1. Seleziona File (seleziona Salva su file nelle versioni precedenti).
    2. Fai clic sul pulsante Sfoglia, quindi, nella finestra di dialogo Salva estrazione con nome, immetti un nome per il file, ad esempio Orders_Returns_Superstore, e fai clic su Accetta.
    3. Nel campo Tipo di output seleziona un tipo di output. Seleziona Estrazione dati Tableau (.hyper) per Tableau Desktop o Valori separati da virgole (.csv) se vuoi condividere l'estrazione con terze parti.

    Tableau Server o Tableau Online

    1. Seleziona Origine dati pubblicata.
    2. Seleziona un progetto.
    3. Immetti un nome per il file, ad esempio Orders_Returns_Superstore.

    Suggerimento: si possono scegliere varie opzioni quando si genera l'output dal flusso. Puoi generare un file di estrazione (solo Tableau Prep Builder), pubblicare i dati come origine dati su Tableau Server o Tableau Online o scrivere i dati in un database. Per maggiori informazioni sulla generazione di file di output, consulta Creare file di estrazione dati e origini dati pubblicate(Link opens in a new window).

  3. Nella sezione Opzioni di scrittura visualizza le opzioni per la scrittura dei nuovi dati nei file. Poiché desideri utilizzare il valore predefinito (Crea tabella) e sostituire la tabella con l'output del flusso, non vi è alcuna modifica da apportare in questo caso.

    Suggerimento: a partire dalla versione 2020.2.1, puoi scegliere come scrivere i dati del flusso nella tabella. Sono disponibili due opzioni: Crea tabella o Aggiungi alla tabella. Per impostazione predefinita, Tableau Prep utilizza l'opzione Crea tabella e sovrascrive i dati della tabella con i nuovi dati al momento dell'esecuzione del flusso. Se scegli Aggiungi alla tabella, Tableau Prep aggiunge i dati del flusso alla tabella esistente, in modo da consentire di tenere traccia dei dati nuovi e di quelli cronologici a ogni esecuzione del flusso. Per maggiori informazioni, consulta Configurare le opzioni di scrittura.

  4. Fai clic su Esegui flusso nel riquadro Output o fai clic sul pulsante Esegui flusso nel riquadro di flusso per generare l'output.

    Nota: se stai lavorando sul Web, fai clic su Pubblica per pubblicare la bozza del flusso. È possibile eseguire solo i flussi pubblicati.

  5. Al termine dell'esecuzione del flusso, una finestra di dialogo di stato mostra se il flusso è stato eseguito correttamente e il tempo di esecuzione. Fai clic su Fatto per chiudere la finestra di dialogo.

    Se lavori sul Web, passa alla pagina Esplora > Tutti i flussi e individua il flusso. Puoi visualizzare lo stato dell'esecuzione del flusso nella pagina Panoramica del flusso.

    Per mantenere aggiornati i dati, puoi eseguire il flusso manualmente o utilizzare la riga di comando. Se Data Management Add-on e Tableau Prep Conductor sono abilitati, puoi anche eseguire il flusso in base a una pianificazione in Tableau Server o Tableau Online.

    A partire da Tableau Prep Builder versione 2020.2.1 e sul Web, è anche possibile scegliere di aggiornare tutti i dati ogni volta che viene eseguito il flusso oppure eseguire il flusso utilizzando l'aggiornamento incrementale ed elaborare ogni volta solo i nuovi dati.

    Per maggiori informazioni sull'aggiornamento dei dati, consulta i seguenti argomenti:

Riassunto e risorse

Sei una rockstar della preparazione dati! Hai preso dei dati sporchi e li hai trasformati in scioltezza! In un attimo, hai pulito e preparato dati provenienti da più insiemi e li hai trasformati in un unico insieme di dati, pulito ed elegante, con cui ora puoi lavorare in Tableau Desktop per eseguire le tue analisi.

Vuoi fare altra pratica? Prova a replicare il resto del flusso di esempio per Superstore utilizzando i file di dati trovati qui:

Inoltre, potrai trovare i file nel seguente percorso nel computer dopo l'installazione di Tableau Prep Builder:

  • (Windows) C:\Program Files\Tableau\Tableau Prep Builder <version>\help\Samples\en_US\Superstore Files
  • (Mac) /Applications/Tableau Prep Builder <version>.app/Contents/help/Samples/en_US/Superstore Files

Vuoi più formazione? Guarda i nuovi video di formazione(Link opens in a new window) per Tableau Prep Builder, dai un'occhiata a queste fantastiche risorse(Link opens in a new window) o segui un corso di formazione in presenza(Link opens in a new window).

Desideri maggiori informazioni sugli argomenti trattati? Scopri altri argomenti nella Guida online di Tableau Prep.

Altri articoli in questa sezione

Grazie per il tuo feedback. Si è verificato un errore durante l'invio del feedback. Riprova.