Configurare l’insieme di dati

Nota: a partire dalla versione 2020.4.1, è ora possibile creare e modificare flussi in Tableau Server e Tableau Cloud. Il contenuto di questo argomento si applica a tutte le piattaforme, a meno che non venga indicato diversamente. Per maggiori informazioni sulla creazione di flussi sul web, consulta Tableau Prep sul web nella Guida di Tableau Server(Il collegamento viene aperto in una nuova finestra) e Tableau Cloud(Il collegamento viene aperto in una nuova finestra).

Per determinare la quantità di dati con cui lavorare nel flusso, puoi configurare l’insieme di dati. Quando ti connetti ai dati o trascini le tabelle nel riquadro Flusso, a quest’ultimo viene aggiunta automaticamente una fase di input.

Nella fase di input puoi decidere quali e quanti dati includere nel flusso. È sempre la prima fase all’interno del flusso.

Se sei connesso a un file di testo o Excel, puoi anche aggiornare i dati dalla fase di input. Per ulteriori informazioni, consulta Aggiungere altri dati nella fase di input(Il collegamento viene aperto in una nuova finestra).

Nella fase di input puoi:

  • Fare clic con il pulsante destro del mouse o premere Cmd-clic (MacOS) nel riquadro con il flusso per rinominare o rimuovere la fase.
  • Unificare più file nella stessa directory principale o sottodirectory. Per ulteriori informazioni, consulta Unificare file e tabelle di database nella fase di input.
  • (versione 2023.1 e successive) Includi i numeri di riga generati automaticamente in base all’ordinamento originale del tuo insieme di dati. Consulta Includere i numeri di riga dell’insieme di dati.
  • Cercare i campi.
  • Visualizzare l’anteprima dei valori dei campi.
  • Configurare le proprietà dei campi modificando il nome del campo oppure configurare le impostazioni del testo per i file di testo.

    Nota: i valori dei campi che includono le parentesi quadre vengono automaticamente convertiti in parentesi tonde.

  • Configura il campione di dati inserite nel flusso. Consulta Impostare la dimensione del campione di dati.
  • Rimuovi i campi non necessari. Puoi sempre tornare alla fase di input e includerli in un secondo momento.
  • Nascondi i campi che non hai l’esigenza di pulire, ma che desideri comunque includere nell’output del flusso. Puoi mostrarli in qualsiasi momento se necessario.
  • Applica i filtri ai campi selezionati. 
  • Modifica il tipo di dati del campo per le connessioni dati che lo supportano.
  • (versione 2023.3 e successive) È possibile impostare l’intestazione e la riga di inizio per i file CSV.
  • (versione 2024.1 e successive) È possibile impostare l’intestazione e la riga di inizio per i file Excel.

Includere i numeri di riga dell’insieme di dati

Supportato in Tableau Prep Builder versione 2023.1 e successive e sul Web per i file di Microsoft Excel e di testo (.csv).

Nota: questa opzione non è attualmente supportata per i file inclusi in un’unificazione di input.

A partire dalla versione 2023.1, Tableau Prep genera automaticamente i numeri di riga in base all’ordinamento originale dei dati che puoi includere come nuovo campo nel flusso. Questo è disponibile solo per i tipi di file Microsoft Excel o testo (.csv).

Nelle versioni precedenti, se volevi includere questi numeri di riga, dovevi aggiungerli manualmente all’origine prima di aggiungere l’insieme di dati al flusso.

Questo campo viene generato nella fase di input quando ti connetti ai tuoi dati. Per impostazione predefinita, è escluso dal flusso, ma è possibile includerlo con un clic. Se scegli di includerlo, si comporta come qualsiasi altro campo e può essere utilizzato nelle operazioni di flusso e nei campi calcolati.

Tableau Prep supporta anche la funzione ROW_NUMBER per i campi calcolati. Questa funzione è utile quando nell’insieme di dati sono presenti campi che possono definire l’ordinamento, ad esempio ID riga o Timestamp. Per ulteriori informazioni sull’utilizzo di questa funzione, consulta Creare calcoli Level of Detail, di classificazione e di sezione.

Aggiungere il campo Numero di riga origine al flusso

  1. Fai clic con il pulsante destro del mouse o Cmd-clic (MacOS) sul campo oppure fai clic sul menu Altre opzioni e seleziona Includi campo.

    Anteprima dei dati:

    Elenco dei campi:

  2. L’elenco delle modifiche viene cancellato, il campo fa ora parte dei dati del flusso ed è possibile visualizzare i numeri di riga generati nelle successive fasi del flusso.

Dettagli del numero di riga origine

Quando includi il file Numero di riga origine nel tuo insieme di dati, si applicano le seguenti opzioni e considerazioni.

  • I numeri di riga dell’origine dati vengono applicati prima di qualsiasi campione o filtro dei dati.
  • Questo crea un nuovo campo chiamato Numero di riga origine che persiste per tutto il flusso. Questo nome campo non è localizzato, ma può essere rinominato in qualsiasi momento.
  • Se esiste già un campo con questo nome, il nuovo nome campo viene incrementato di 1. Ad esempio Numero di riga origine-1, Numero di riga origine-2 e così via.
  • È possibile modificare il tipo di dati del campo nelle fasi successive.
  • È possibile utilizzare questo campo nelle operazioni di flusso e nei calcoli.
  • Questo valore viene rigenerato per l’intero insieme di dati ogni volta che i dati di input vengono aggiornati o il flusso viene eseguito.
  • Questo campo non è disponibile per le unificazioni di input.

Impostare l’intestazione e la riga di inizio dei dati

Supportato in Tableau Prep Builder versione 2023.3 e successive e sul Web per i file di testo (.csv) e nella versione 2024.1 e successive per i file Excel (.xls).

Puoi impostare una riga specifica come riga di intestazione dei campi e la riga in cui iniziano i dati per i file Excel e di testo (.csv).

Quando ci si connette a file Excel o di testo, uno scenario comune è che i file vengano formattati con metainformazioni nelle prime righe per renderli leggibili. Per impostazione predefinita, Tableau Prep interpreta le prime righe dei file CSV come riga di intestazione dei campi. I file Excel vengono interpretati in base ai tipi di campi e alle righe vuote. Tableau Prep può selezionare una riga come intestazione o non includere alcuna riga di intestazione.

Ad esempio, dai seguenti file, STORE DETAILS viene interpretato come la riga di intestazione.

Puoi escludere le informazioni sui metadati (1) e fornire la struttura corretta dello schema per i dati impostando la riga 3 come intestazione (2) e la riga 4 come riga da cui iniziare i dati.

File CSV:

File Excel:

Ad esempio, di seguito sono mostrate le impostazioni predefinite per l’intestazione della riga e la riga di inizio:

Di seguito sono riportati i dati con i metadati esclusi:

Nota: l’anteprima dei dati non riflette le modifiche alle impostazioni del campione di dati.

Configurare l’intestazione e la riga di inizio

Utilizzando la vista di input Anteprima dei dati, puoi ispezionare visivamente la struttura dello schema dei dati e impostare l’intestazione e le righe iniziali per escludere i metadati dai dati dell’origine di input.

Puoi impostare la riga di inizio dei dati su qualsiasi valore superiore a quello della riga di intestazione. Per impostazione predefinita, Tableau Prep imposta la riga di inizio dei dati sul numero consecutivo successivo alla riga di intestazione. Qualsiasi riga tra la riga di intestazione e la riga di inizio dei dati viene ignorata.

Nota: Anteprima dei dati e Interprete dei dati si escludono a vicenda. Interprete dei dati rileva solo le sotto-tabelle nei fogli di calcolo Excel e non supporta la riga di inizio per i file di testo e i fogli di calcolo.

  1. Seleziona la fase di input.
  2. Dalla barra degli strumenti fai clic sulla vista di input Anteprima dei dati.
  3. Per la riga che desideri impostare come intestazione, fai clic sul menu Altre opzioni e seleziona Imposta come intestazione.
  4. Per la riga che desideri impostare come riga di inizio dei dati, fai clic sul menu Altre opzioni e seleziona Imposta come inizio dei dati. Per impostazione predefinita, la riga di inizio dei dati è impostata sul numero di riga consecutivo successivo. 

    Il menu Opzioni intestazione visualizza la riga di intestazione e il numero di riga per la riga di inizio dei dati. Facoltativamente, è possibile impostare l’intestazione e la riga di inizio direttamente nella finestra di dialogo Opzioni intestazione.

Più schemi in un singolo file

Se un singolo file include più origini dati, puoi creare una fase di input aggiuntiva connettendoti alla stessa origine dati, quindi impostare l’intestazione e la riga di inizio dei dati per la seconda origine dati. Ad esempio, il file seguente contiene un’origine dati che inizia alla riga numero 3 (1) con un secondo schema distinto che inizia alla riga numero 28 (2).

Per questo tipo di origine dati attieniti alla procedura seguente.

  1. Seleziona la prima fase di input.
  2. Dalla barra degli strumenti fai clic sulla vista di input Anteprima dei dati.
  3. Per la riga che desideri impostare come intestazione, fai clic sul menu Altre opzioni e seleziona Imposta come intestazione.
  4. Per la riga che desideri impostare come riga di inizio dei dati, fai clic su Altre opzioni e seleziona Imposta come inizio dei dati. Per impostazione predefinita, la riga di inizio dei dati è impostata sul numero di riga consecutivo successivo.
  5. Seleziona la fase di input successiva.
  6. Ripeti i passaggi precedenti per impostare l’intestazione e la riga di inizio per ulteriori origini dati.

    Qualsiasi riga tra la riga di intestazione e la riga di inizio dei dati viene ignorata.

Unificare più tabelle

Supportato in Tableau Prep Builder versione 2024.1 e successive e sul Web per i file di testo (.csv).

Puoi unificare più tabelle da origini dati che hanno la stessa struttura dello schema e la stessa riga di metadati.

  1. Connettiti ai file e seleziona la prima fase di input.
  2. Dalla barra degli strumenti fai clic sulla vista di input Anteprima dei dati.
  3. Per la riga che desideri impostare come intestazione, fai clic su Altre opzioni e seleziona Imposta come intestazione.
  4. Per la riga che desideri impostare come riga di inizio dei dati, fai clic su Altre opzioni e seleziona Imposta come inizio dei dati.
  5. Fai clic sulla scheda Tabelle e seleziona Unificazione tabelle multiple.
  6. Fai clic su Applica per unificare i file e mantenere la selezione dell’intestazione e della riga per tutti i file nell’unificazione di input. Ciò presuppone che la struttura dei file e lo schema tra i file di input unificati siano gli stessi.

Connettersi a una query SQL personalizzata

Se il tuo database supporta l’uso di SQL personalizzato, viene visualizzato SQL personalizzato nella parte inferiore del riquadro Connessioni. Fai doppio clic su SQL personalizzato per aprire la scheda SQL personalizzato, in cui è possibile inserire query per preselezionare i dati e utilizzare operazioni specifiche per le origini. Una volta che la query ha recuperato l’insieme di dati, puoi selezionare i campi da includere, applicare filtri o modificare il tipo di dati prima di aggiungere i dati al flusso.

Per maggiori informazioni sull’utilizzo di SQL personalizzato, consulta Utilizzare SQL personalizzato per connettersi ai dati.

Applicare operazioni di pulizia in una fase di input

Solo alcune operazioni di pulizia sono disponibili in una fase di input. Puoi effettuare una qualsiasi delle seguenti modifiche nell’elenco dei campi di input. Le modifiche vengono monitorate nel riquadro Modifiche e le annotazioni appaiono a sinistra della fase di input nel riquadro Flusso e nell’elenco dei campi di input.

  • Nascondi campo: nascondi i campi invece di rimuoverli per ridurre il disordine del flusso. Puoi sempre mostrarli se necessario. I campi nascosti verranno comunque inclusi nell’output durante l’esecuzione del flusso.
  • Filtro: utilizza l’editor di calcolo per filtrare i valori. In alternativa, a partire dalla versione 2023.1, puoi utilizzare la finestra di dialogo Filtro data relativa per specificare rapidamente gli intervalli di date per qualsiasi campo data o data e ora.
  • Rinomina campo: nel campo Nome campo, fai doppio clic (o clic tenendo premuto il tasto Ctrl su Mac) sul nome del campo e inseriscine uno nuovo.
  • Cambia tipo di dati: fai clic sul tipo di dati per il campo e seleziona un nuovo tipo di dati dal menu. Questa opzione è attualmente supportata per origini dati Microsoft Excel, file di testo e PDF, Box, Dropbox, Google Drive e OneDrive. Tutte le altre origini dati possono essere modificate in una fase di pulizia.

Selezionare i campi da includere nel flusso

Nota: a partire dalla versione 2023.1 è possibile selezionare più campi per nasconderli, mostrarli, rimuoverli o includerli. Nelle versioni precedenti, è possibile lavorare con un campo alla volta e selezionare o deselezionare le caselle di controllo per includere o rimuovere i campi.

Il riquadro Input ti mostra un elenco di campi del tuo insieme di dati. Per impostazione predefinita, sono inclusi tutti i campi tranne il campo generato automaticamente, Numero di riga origine. Utilizza la vista Anteprima dei dati o Elenco per gestire i campi.

  • Cerca: consente di trovare i campi.
  • Nascondi campi: nasconde i campi che desideri includere nell’output del flusso, ma che non è necessario pulire.
    • Nell’elenco dei campi fai clic sull’icona a forma di occhio o seleziona Nascondi campi dal menu Altre opzioni.
    • Nell’anteprima dei dati seleziona Nascondi campi dal menu Altre opzioni.

    I campi vengono elaborati dal flusso in fase di esecuzione. Puoi anche mostrarli in qualsiasi momento se necessario. Per maggiori informazioni, consulta Nascondere i campi.(Il collegamento viene aperto in una nuova finestra)

  • Includi campi: nasconde i campi che desideri includere nell’output del flusso, ma che non è necessario pulire.
    • Nell’elenco dei campi seleziona una o più righe e fai clic con il pulsante destro del mouse, Cmd-clic (MacOS) o fai clic sul menu Altre opzioni, quindi seleziona Includi campi per aggiungere campi contrassegnati come rimossi.
    • Nell’anteprima dei dati fai clic sul menu Altre opzioni sul campo che desideri includere, quindi seleziona Includi campo.
  • Rimuovi campi:
    • Nell’elenco dei campi seleziona una o più righe e fai clic con il pulsante destro del mouse, Cmd-clic (MacOS), fai clic sulla "X" o fai clic sul menu Altre opzioni, quindi seleziona Rimuovi campi per rimuovere i campi che non desideri includere nel flusso.
    • Nell’anteprima dei dati fai clic sul menu Altre opzioni per il campo che desideri rimuovere, quindi seleziona Rimuovi campo.

Applicare filtri ai campi nella fase di Input

Applica i filtri nella fase di input per ridurre la quantità di dati importati dalle tue origini dati. Puoi ottenere l’efficienza delle prestazioni interattive e un campione di dati più utile eliminando i dati che non vuoi elaborare quando esegui il flusso.

Nella fase di input è possibile applicare filtri utilizzando l’editor di calcolo. A partire dalla versione 2023.1, puoi anche utilizzare la finestra di dialogo Filtro data relativo per specificare un intervallo di date esatto di valori da includere per i tipi di campo data e data e ora. Per ulteriori informazioni, consulta "Filtro data relativa" in Filtrare i dati(Il collegamento viene aperto in una nuova finestra).

Puoi utilizzare altre opzioni di filtro nel passaggio Pulisci o in altri tipi di passaggio. Per ulteriori informazioni, vedi Filtrare i dati(Il collegamento viene aperto in una nuova finestra).

Applicare un filtro di calcolo

  1. Nella barra degli strumenti fai clic su Filtra valori. Utilizza uno dei seguenti metodi per filtrare i dati:
    • Nell’elenco dei campi fai clic su Altre opzioni dal nome del campo, quindi seleziona Filtro > Calcolo.

    • Nell’anteprima dei dati fai clic sul menu Altre opzioni dal nome del campo, quindi seleziona Filtro > Calcolo.

  2. Inserisci i tuoi criteri di filtro nell’editor di calcolo.

Applicare un filtro data relativa

  1. Seleziona un campo con un tipo di dati Data o Data e ora e utilizza uno dei seguenti metodi per applicare un filtro date relative.
    • Nell’elenco dei campi fai clic con il pulsante destro del mouse, Cmd-clic (MacOS) oppure fai clic sul menu Altre opzioni dalla colonna Nome campo e seleziona Filtro > Date relative.
    • Nell’anteprima dei dati fai clic sul menu Altre opzioni dal campo, quindi seleziona Filtro > Date relative.
  2. Nella finestra di dialogo Filtro date relative specifica l’esatto intervallo di anni, trimestri, mesi, settimane o giorni che vuoi includere nel flusso. Puoi configurare anche un riferimento relativo a una data specifica e includere valori NULL.

    Nota: per impostazione predefinita, il filtro opera in relazione alla data in cui il flusso viene eseguito o visualizzato in anteprima all’interno dell’esperienza di creazione.

Modificare i nomi dei campi

Utilizza uno dei seguenti metodi per modificare il nome di un campo.

Nella griglia di campo e nel riquadro di flusso a sinistra della fase di Input viene aggiunta un’annotazione. Le modifiche vengono tracciate anche nel riquadro Modifiche.

  • Nell’elenco dei campi seleziona un campo dalla colonna Nome campo, quindi fai clic su Rinomina campo. Digita il nuovo nome nel campo.
  • Nell’anteprima dei dati seleziona un campo, quindi fai clic su Rinomina campo. Digita il nuovo nome nel campo.

Modificare i tipi di dati

Attualmente supportata per origini dati Microsoft Excel, file di testo e PDF, Box, Dropbox, Google Drive e OneDrive. Tutte le altre origini dati possono essere modificate in una fase di pulizia.

Nota: il tipo di dati per il numero di riga di origine (versione 2023.1 e successive) può essere modificato solo in una fase di pulizia o in un altro tipo di fase.

Per modificare il tipo di dati di un campo, esegui i seguenti passaggi:

  1. Fai clic sul tipo di dati del campo.
  2. Seleziona il nuovo tipo di dati dal menu.
    • Anteprima dei dati:
    • Vista campo:
  3. Puoi inoltre modificare il tipo di dati per i campi in altri tipi di fasi nel flusso o assegnare ruoli di dati per aiutare a convalidare i valori dei campi. Per ulteriori informazioni sulla modifica del tipo di dati o sull’utilizzo dei ruoli dati, vedi Rivedi i tipi di dati assegnati ai tuoi dati(Il collegamento viene aperto in una nuova finestra) e Utilizzare i ruoli dati per convalidare i dati(Il collegamento viene aperto in una nuova finestra).

Configurare le proprietà del campo

Quando lavori con i file di testo, viene visualizzata la scheda Impostazioni, in cui puoi modificare la connessione e configurare le proprietà del testo, come il separatore di campo per i file di testo. È inoltre possibile modificare la connessione del file nel riquadro Connessioni o configurare le impostazioni per l’aggiornamento incrementale. Per maggiori informazioni sull’impostazione dell’aggiornamento incrementale per il flusso, consulta Aggiornare i dati del flusso tramite l’aggiornamento incrementale.

Quando lavori con file di testo o Excel, puoi correggere i tipi di dati che sono stati estrapolati in modo errato prima ancora di iniziare il flusso. I tipi di dati possono sempre essere modificati nelle fasi successive nel riquadro Profilo dopo aver avviato il flusso.

Configurare le impostazioni del testo nei file di testo

Per modificare le impostazioni utilizzate per analizzare i file di testo, seleziona una delle seguenti opzioni:

  • La prima riga contiene l’intestazione (predefinita): seleziona questa opzione per utilizzare la prima riga come etichetta del campo.

  • Genera nomi campo automaticamente: seleziona questa opzione se desideri che Tableau Prep Builder generi automaticamente le intestazioni dei campi. La convenzione di denominazione dei campi segue lo stesso modello di Tableau Desktop. Ad esempio F1, F2 e così via.

  • Separatore di campo: seleziona un carattere dall’elenco da utilizzare per separare le colonne. Seleziona Altro per inserire un carattere personalizzato.

  • Qualificatore di testo: seleziona il carattere che racchiude i valori del file.

  • Insieme di caratteri: seleziona l’insieme di caratteri che descrive la codifica del file di testo.

  • Impostazioni locali: seleziona la directory da utilizzare per l’analisi dei file. Questa impostazione indica il separatore di decimali e migliaia da utilizzare.

Impostare la dimensione del campione di dati

La selezione di righe stratificate è supportata in Tableau Prep Builder versione 2023.3 e successive.

Per impostazione predefinita, Tableau Prep determina il numero massimo di righe necessarie per esplorare e preparare in modo efficace i dati per un campione rappresentativo dell’insieme di dati. In base all’algoritmo di campionamento di Tableau Prep, maggiore è il numero di campi presenti nei dati di input, minore è il numero di righe consentite. Quando i dati vengono campionati, il campione risultante può includere o meno tutte le righe necessarie, a seconda di come il campione è stato calcolato e restituito. Ad esempio, per impostazione predefinita, Tableau Prep utilizza il metodo Selezione rapida per campionare i dati. Utilizzando questo metodo, vengono caricate le righe superiori e, se l’insieme di dati è di grandi dimensioni e i dati sono strutturati in ordine cronologico, potresti vedere i primi dati campionati, ma non una rappresentazione completa di tutti i dati. Se non vedi i dati che avevi previsto, puoi modificare le impostazioni del campione di dati per eseguire nuovamente la query.

Quando si creano o si modificano flussi con Web authoring, il numero massimo di righe che un utente può selezionare quando si utilizzano insiemi di dati di grandi dimensioni è configurato dall’amministratore. Per maggiori informazioni, consulta Dati campione e limiti di elaborazione nella Guida di Tableau Server(Il collegamento viene aperto in una nuova finestra) o Tableau Cloud(Il collegamento viene aperto in una nuova finestra).

Preparazione dei dati per il campionamento

Se sai che determinati valori non sono richiesti per la tua analisi, rimuovi i campi nella fase di input in modo che i dati non vengano inclusi quando crei o esegui il flusso.

Se disponi di un insieme di dati di grandi dimensioni che attiva il campionamento, la rimozione dei campi nella fase di input implica un aumento del numero di righe caricate da Tableau Prep. Quando il campionamento non viene applicato, la rimozione dei campi nella fase di input consente di ridurre il volume di dati caricato da Tableau Prep.

Dopo aver rimosso i campi e i valori non necessari dall’insieme di dati, puoi modificare la quantità di dati caricati per il campionamento o il metodo di campionamento.

Modifica delle impostazioni del campione di dati

Il campionamento di dati facilita l’esperienza interattiva e rende la modifica del flusso più efficiente rispetto alla profilazione di tutti i dati e all’applicazione delle modifiche a insiemi di dati più estesi mentre si lavora. Tutti i dati vengono utilizzati quando esegui il flusso. Qualsiasi modifica apportata nella sezione di campionamento viene applicata al flusso corrente.

Per convalidare i dati dopo la pulizia e la modellazione, esegui il flusso e visualizza l’output in Tableau Desktop.

Nota: esegui il flusso completo anziché visualizzare il campione in Tableau Desktop, in modo da poter visualizzare tutti i dati. Se noti valori imprevisti o errati che non erano nel campione, puoi tornare a Tableau Prep per risolvere il problema.

  1. Rimuovi i campi e i valori non necessari dall’insieme di dati.
  2. Seleziona una fase di input, quindi fai clic sulla scheda Campione dati.

  3. Seleziona il numero di righe che desideri caricare per il campionamento dei dati. Il numero di righe che scegli influisce sulle prestazioni.

    • Automatico (impostazione predefinita): carica i dati rapidamente e calcola automaticamente il numero di righe in modo che i dati siano sufficienti per un campione. Il numero di righe caricate è uguale o inferiore a 393.216.
    • Specifica: tipicamente utilizzato per caricare un numero limitato di righe, in modo da poter comprendere la struttura dei dati e ridurre i tempi di caricamento. Specifica un numero di righe inferiore a 1 milione.

      Nota: in Web authoring il numero massimo di righe che un utente può selezionare quando si utilizzano insiemi di dati di grandi dimensioni è configurato dall’amministratore. Un utente può selezionare il numero di righe fino a tale limite.

    • Massimo: carica quanti più dati possibile per la selezione di righe, che è pari o inferiore a 1.048.576. Assicurati di soddisfare i requisiti per prestazioni elevate per insiemi di dati di grandi dimensioni.
  4. Seleziona il metodo da utilizzare per il numero di righe restituite per il campionamento. Le opzioni Casuale o Stratificato possono influire sulle prestazioni.

    Nota: la selezione della riga è supportata solo se l’origine dati di input supporta il campionamento casuale. Se l’origine dati non supporta il campionamento casuale, viene utilizzato il metodo predefinito Selezione rapida.

    • Selezione rapida (impostazione predefinita): campiona i dati in base alle prestazioni poiché le righe vengono restituite il più rapidamente possibile. Alcune righe potrebbero non essere incluse nel campione. Le righe utilizzate per il campionamento potrebbero essere il primo N numero di righe oppure quelle che il database aveva memorizzato da una query precedente. Anche se questo è quasi sempre un risultato più rapido rispetto al campionamento casuale, può restituire un campione distorto (ad esempio dati relativi a un solo anno anziché a tutti gli anni presenti nei dati, se i record sono ordinati cronologicamente).

    • Casuale: consente di campionare un insieme di dati di grandi dimensioni e restituire una rappresentazione generale dell’intera selezione di righe. Tableau Prep restituisce righe casuali in base a tutte le righe selezionate caricate. Questa opzione può influire sulle prestazioni quando i dati vengono recuperati per la prima volta.

    • Stratificato: consente di raggruppare i dati in base a un campo specifico e quindi campionarli all’interno di ciascun sottogruppo. Prep restituisce il numero richiesto di righe distribuite nel campo selezionato per un raggruppamento il più possibile equo. In alcuni casi, in base all’origine dati, per alcuni valori per il campo possono esistere più righe di altri.
  5. Esempi

    Questi esempi si basano sull’insieme di dati degli indicatori mondiali globali incluso in Tableau Prep. Il primo campione utilizza l’opzione Automatico per il numero di righe e Casuale per il metodo di campionamento o il numero di righe da restituire per il campionamento.

    Con questi valori selezionati, 3.000 righe vengono selezionate in modo casuale e utilizzate per rappresentare l’intero insieme di dati.

    Il secondo campione utilizza l’opzione Specifica per il numero di righe e Stratificato per il metodo di campionamento. Il numero specificato di righe è impostato su un valore pari a 7 e il campo Tasso di natalità viene utilizzato per il raggruppamento.

    I nuovi valori di campionamento mostrano una distribuzione unificata di 7 righe di valori univoci in tutti i campi.

Grazie per il tuo feedback.Il tuo feedback è stato inviato. Grazie!