Nota: a partire dalla versione 2020.4.1, è ora possibile creare e modificare flussi in Tableau Server e Tableau Online. Il contenuto di questo argomento si applica a tutte le piattaforme, a meno che non venga indicato in modo specifico. Per maggiori informazioni sull'authoring di flussi sul Web, consulta Tableau Prep sul Web nella Guida di Tableau Server(Il collegamento viene aperto in una nuova finestra) e Tableau Online(Il collegamento viene aperto in una nuova finestra).

Dopo esserti connesso alle origini dati e aver iniziato a costruire il tuo flusso, potresti voler aggiornare le connessioni dati quando arrivano nuovi dati. È inoltre possibile unificare o creare join di insiemi di dati nella fase di input per rendere più efficiente il lavoro con origini dati di dimensioni maggiori.

Aggiornare i dati nella fase di Input

Se dopo aver iniziato a lavorare con il flusso, i dati nei file o nelle tabelle di input cambiano, puoi aggiornare la fase di Input per introdurre i nuovi dati.

Tipi di passaggi di inserimento dei file

Nota: questa opzione non è ancora supportata sul Web.

Per aggiornare le fasi di input dei file, esegui una di queste operazioni:

  • Nel riquadro di flusso del menu in alto, fai clic sul pulsante Aggiorna per aggiornare tutte le fasi di Input. Per aggiornare una singola fase di input, fai clic sulla freccia a discesa accanto al pulsante di aggiornamento e seleziona la fase di Input dall'elenco.

  • Nel riquadro di flusso, fai clic con il tasto destro del mouse sulla fase di Input che desideri aggiornare e seleziona Aggiorna dal menu.

Tipi di fasi di input di file, database o estrazioni di Tableau

Per aggiornare le fasi di input di database o estrazioni Tableau, esegui una di queste operazioni:

  • Prova a modificare la connessione.

    Nota: per mantenere le prestazioni, Tableau Prep campiona grandi insiemi di dati. Se i dati vengono campionati, è possibile che i nuovi dati vengano visualizzati o meno nel riquadro del profilo. Puoi modificare le impostazioni relative alle modalità di campionamento dei dati nella scheda Campione dati nella fase di input, ma ciò potrebbe influire sulle prestazioni. Per ulteriori informazioni sull'impostazione della dimensione del campione dati, consulta Impostare la dimensione del campione di dati(Il collegamento viene aperto in una nuova finestra).

    1. Nel riquadro Connessioni, fai clic con il tasto destro del mouse o Ctrl+click (macOS) sull'origine dati e seleziona Modifica.

    2. Ristabilisci la connessione accedendo al database o selezionando di nuovo il file o l'estratto di Tableau.

  • Rimuovi e aggiungi nuovamente la fase di Input al flusso.

    1. Nel riquadro di flusso, fai clic con il tasto destro del mouse sulla fase di Input che desideri aggiornare e seleziona Rimuovi dal menu.

      Questo metterà temporaneamente il flusso in uno stato di errore.

    2. Connettiti nuovamente al file aggiornato.

    3. Trascina la tabella nel riquadro di flusso in cima alla seconda fase nel flusso in cui desideri aggiungere la fase di input. Rilasciala sull'opzione Aggiungi per riconnetterla al flusso.

Unificare file e tabelle di database nella fase di input

Le unificazioni di input possono essere modificate e create solo in Tableau Prep Builder, ma possono essere pianificate per l'esecuzione sul Web.

Quando lavori con più file o tabelle di database da una singola origine dati, puoi applicare filtri per cercare i file o utilizzare una ricerca con caratteri jolly per trovare le tabelle, quindi unificare i dati per includere tutti i dati di file o tabelle nella fase di input. Perché possano venire unificati, i file devono trovarsi nella stessa directory o sottodirectory.

Nota: questa opzione non è disponibile per le estrazioni di Tableau.

I nuovi file aggiunti alla stessa cartella che corrispondono ai criteri di filtro vengono automaticamente inclusi nell'unificazione la volta successiva che apri il flusso o lo esegui dalla riga di comando.

I file di flusso in pacchetti (.tflx) non raccolgono automaticamente nuovi file perché i file sono già inclusi nel pacchetto con il flusso. Per includere nuovi file per i flussi in pacchetti, apri il file di flusso (.tfl) in Tableau Prep Builder per raccogliere i nuovi file e crea un pacchetto del flusso per includere i nuovi dati del file.

Per unificare le tabelle di database, le tabelle devono essere nello stesso database e la connessione al database deve supportare una ricerca con caratteri jolly. I seguenti database supportano questo tipo di unificazione:

  • Amazon Redshift

  • Microsoft SQL Server

  • MySQL

  • Oracle

  • PostgreSQL

Se aggiungi o rimuovi file o tabelle dopo aver creato l'unificazione, puoi aggiornare la fase di input per aggiornare il flusso con i dati nuovi o modificati.

Se devi unificare dati provenienti da diverse origini dati, puoi farlo tramite una fase di unificazione. Per ulteriori informazioni sulla creazione di fasi di unificazione, vedi Unificare i dati(Il collegamento viene aperto in una nuova finestra).

Unificare file

Per impostazione predefinita, Tableau Prep Builder unifica tutti i file .csv nella stessa directory del file .csv a cui sei collegato o tutti i fogli nel file di Excel a cui sei collegato.

Se desideri modificare l'unificazione predefinita, puoi specificare criteri di filtro aggiuntivi per trovare i file o i fogli da includere nell'unificazione.

Criteri di filtro principali

In Tableau Prep Builder 2022.1.1 e versioni precedenti, è possibile selezionare uno dei seguenti criteri:

  • Cerca in: seleziona la directory da utilizzare per la ricerca dei file. Seleziona la casella di controllo Includi sottocartelle per includere i file nella sottodirectory della cartella genitore.

  • File: seleziona se includere o escludere i file che corrispondono ai criteri di ricerca dei caratteri jolly.

  • Modello corrispondente (xxx*): inserisci un modello di ricerca di caratteri jolly per trovare i file che includono quei caratteri nel nome. Ad esempio, inserendo ordin* vengono restituiti tutti i file che includono "ordin" nel nome del file. Lascia vuoto questo campo per includere tutti i file nella directory specificata.

Filtri aggiuntivi

Supportato in Tableau Prep Builder versione 2022.2.1 e successive e per i flussi pubblicati in Tableau Online.

Nota: se utilizzi filtri aggiuntivi nel flusso, la pianificazione del flusso è attualmente disponibile solo utilizzando Tableau Online. Puoi eseguire il flusso manualmente in Tableau Prep Builder o tramite l'interfaccia della riga di comando. Questa funzionalità non è compatibile con Tableau Server versione 2022.1 e precedenti.

A partire da Tableau Prep Builder versione 2022.2.1 e successive, le opzioni di filtro durante la ricerca di file da unificare sono cambiate. Anche se è ancora necessario specificare una directory e una sottodirectory in cui eseguire la ricerca, ora è possibile impostare più filtri per eseguire una ricerca più dettagliata.

Queste opzioni di filtro si applicano ai tipi di file di testo, Microsoft Excel e statistici. È possibile selezionare più filtri. Ogni filtro viene applicato separatamente, nell'ordine in cui vengono selezionati, dall'alto verso il basso. Al momento, i filtri non possono essere spostati una volta aggiunti, ma puoi eliminare e aggiungere i filtri in base alle esigenze.

Seleziona uno dei seguenti filtri:

Filtro Descrizione
Nome file Seleziona Corrispondente o Non corrispondente per un modello per il nome del file. Ad esempio, "ordini*".
Dimensione del file

Filtra i file selezionando Intervallo di dimensioni o Classificazione per dimensione.

Intervallo di dimensioni: seleziona una delle seguenti opzioni:

  • Specifica un intervallo di valori.
  • Seleziona un operatore Minore di, Minore o uguale a, Maggiore o uguale a o Maggiore di e applicalo a un singolo valore.

Classificazione per dimensione: includi o escludi gli N file più grandi o più piccoli.

Data di creazione

Filtra i file selezionando Intervallo di date, Data relativa o Classificazione per data.

Intervallo di date: seleziona una delle seguenti opzioni:

  • Specifica un intervallo di data e ora.
  • Seleziona un operatore Prima, Prima o uguale a, Dopo o uguale a o Dopo e applicalo a un singolo valore.

Data relativa: includi o escludi un intervallo esatto di anni, trimestri, mesi, settimane o giorni. Puoi configurare anche un riferimento relativo a una data specifica.

Nota: i periodi di date "Ultimo" includono l'unità di tempo corrente completa, anche se alcune date non sono ancora trascorse. Ad esempio, se selezioni l'ultimo mese e la data corrente è il 7 gennaio, Tableau mostrerà le date dall'1 gennaio al 31 gennaio.

Classificazione per data: includi o escludi gli N file più recenti o meno recenti.

Data di modifica

Filtra i file selezionando Intervallo di date, Data relativa o Classificazione per data.

Intervallo di date: seleziona una delle seguenti opzioni:

  • Specifica un intervallo di data e ora.
  • Seleziona un operatore Prima, Prima o uguale a, Dopo o uguale a o Dopo e applicalo a un singolo valore.

Data relativa: includi o escludi un intervallo esatto di anni, trimestri, mesi, settimane o giorni. Puoi configurare anche un riferimento relativo a una data specifica.

Nota: i periodi di date "Ultimo" includono l'unità di tempo corrente completa, anche se alcune date non sono ancora trascorse. Ad esempio, se selezioni l'ultimo mese e la data corrente è il 7 gennaio, Tableau mostrerà le date dall'1 gennaio al 31 gennaio.

Classificazione per data: includi o escludi gli N file più recenti o meno recenti.

Nota: le istruzioni seguenti variano in base alla versione di Tableau Prep Builder.

Creare un'unificazione di input

Applicabile a Tableau Prep Builder versione 2022.2.1 e successive

  1. Fai clic sul pulsante Aggiungi connessione e in Connetti fai clic su File di testo per i file .csv, su Microsoft Excel per i file Excel o su File statistico per i file statistici, quindi seleziona un file da aprire.

  2. Nel riquadro Input seleziona la scheda Tabelle, quindi seleziona Unificazione tabelle multiple.

  3. Seleziona una cartella in cui eseguire la ricerca. Puoi anche includere tutte le sottocartelle elencate in una determinata directory per espandere la ricerca.
  4. Fai clic su Aggiungi filtro file e seleziona una delle seguenti opzioni:

    • Nome file: immetti un modello per il nome di cui eseguire la ricerca.
    • Dimensione del file: esegui la ricerca per intervallo di dimensioni o classificazione per dimensione.
    • Data di creazione: esegui la ricerca per intervallo di date, data relativa o classificazione per data.
    • Data di modifica: esegui la ricerca per intervallo di date, data relativa o classificazione per data.
  5. Fai di nuovo clic su Aggiungi filtro file per aggiungere altri filtri.

    I risultati del filtro sono mostrati nella sezione Tabelle incluse.

  6. Fai clic su Applica per unificare i file.

Quando aggiungi una nuova fase al flusso, puoi visualizzare tutti i file aggiunti all'insieme di dati nel campo Percorsi dei file del riquadro Profilo. Il campo viene aggiunto automaticamente.

Creare un'unificazione di input (versione 2022.1.1 e precedenti)
  1. Fai clic sul pulsante Aggiungi connessione e in Connetti fai clic su File di testo per i file .csv o su Microsoft Excel per i file Excel, quindi seleziona un file da aprire.

  2. Nel riquadro Input seleziona la scheda File multipli, quindi seleziona Unificazione con caratteri jolly.

    L'esempio seguente mostra un'unificazione di input che utilizza un modello corrispondente. Il segno più sull'icona del file nella fase di input Orders_Central nel riquadro Flusso indica che questa fase include un'unificazione di input. I file nell'unificazione sono elencati nella sezione File inclusi.

  3. Utilizza le opzioni di ricerca, file e modelli corrispondenti per trovare i file che desideri unificare.

  4. Fai clic su Applica per unificare i file.

Quando aggiungi una nuova fase al flusso, puoi visualizzare tutti i file aggiunti all'insieme di dati nel campo Percorsi dei file del riquadro Profilo. Il campo viene aggiunto automaticamente.

Unire tabelle dei database

Supportato in Tableau Prep Builder versione 2018.3.1 e successive

Nota: l'interfaccia per l'unificazione di input per le tabelle di database è stata aggiornata in Tableau Prep Builder versione 2022.2.1. Le opzioni potrebbero essere diverse a seconda della versione in uso.

  1. Fai clic sul pulsante Aggiungi connessione e, in Connetti, connettiti a un database che supporta le unificazioni di input.

  2. Trascina una tabella nel pannello di flusso.

  3. Nel riquadro Input seleziona la scheda Tabelle, quindi seleziona Unificazione tabelle multiple.

    Nelle versioni precedenti seleziona la scheda Tabelle multiple, quindi seleziona Unificazione con caratteri jolly.

  4. Nel campo Tabelle seleziona Includi o Escludi dall'opzione a discesa, quindi inserisci un modello di corrispondenza per trovare le tabelle da unificare.

    Nelle versioni precedenti utilizza le opzioni di ricerca, Tabelle e Modello corrispondente.

    Solo le tabelle visualizzate nel riquadro Connessioni della sezione Tabelle possono essere incluse nell'unificazione. L'unificazione di input non effettua ricerche negli schemi o nella connessione del database per trovare le tabelle.

  5. Fai clic su Applica per unificare i dati delle tabelle.

    Quando aggiungi una nuova fase al flusso, puoi visualizzare tutte le tabelle aggiunte all'insieme di dati nel campo Nomi delle tabelle del riquadro Profilo. Il campo viene aggiunto automaticamente.

Unire i campi dopo un'unificazione

Dopo aver creato un'unificazione nella fase di input, potresti voler unire i campi. Hai la possibilità di farlo in qualsiasi fase successiva, a esclusione delle fasi di Input o Output. Per ulteriori informazioni, consulta Ulteriori opzioni di unione di campo(Il collegamento viene aperto in una nuova finestra).

Creare un join dei dati nella fase di input

In Tableau Prep Builder (versione 2019.3.1 e successive) e sul Web, quando ci si connette a database che includono tabelle con dati di relazione, Tableau Prep ora può rilevare e mostrare quali campi di una tabella sono identificati come identificatore univoco e quali sono identificati come campi correlati, nonché mostrare i nomi delle tabelle correlate per tali campi.

Nel riquadro Input viene visualizzata una nuova colonna denominata Chiavi collegate, la quale mostra le seguenti relazioni, se esistenti:

  • Identificatore univoco. Questo campo identifica in modo univoco ogni riga della tabella. In una tabella possono essere presenti più identificatori univoci. I valori nei campi devono essere univoci e non possono essere vuoti o nulli.

  • Campo correlato. Questo campo mette in relazione una tabella con un'altra tabella del database. Questo campo mette in relazione una tabella con un'altra tabella del database.

  • Identificatore univoco e campo correlato. Il campo è un identificatore univoco in questa tabella e può inoltre essere correlato a un'altra tabella all'interno del database.

Puoi sfruttare queste relazioni per trovare e aggiungere rapidamente le tabelle correlate al tuo flusso o creare join dalla fase di input. Questa funzione è disponibile per qualsiasi connettore di database supportato in cui sono definite le relazioni tra tabelle.

  1. Connettiti a un database, ad esempio Microsoft SQL Server, contenente dati di relazione per i campi, ad esempio identificatori univoci o campi correlati (chiave esterna).
  2. Nel riquadro Input fai clic su un campo contrassegnato come campo correlato o come identificatore univoco e campo correlato.

    Viene visualizzata una finestra di dialogo che riporta un elenco di tabelle correlate.

  3. Porta il puntatore del mouse sulla tabella che desideri aggiungere o con cui creare un join e fai clic sul pulsante più per aggiungere la tabella al flusso, oppure fai clic sul pulsante Join per creare un join con la tabella selezionata.

    Se si crea un join, Tableau Prep utilizza la relazione di campo definita per creare un join delle tabelle e visualizzare un'anteprima delle clausole di join che verranno utilizzate per la creazione del join.

  4. In alternativa, puoi creare il join delle tabelle correlate dal menu nel riquadro Flusso. Fai clic sull'icona del segno più , quindi seleziona Aggiungi join per visualizzare un elenco delle tabelle correlate. Tableau Prep crea il join in base ai campi che costituiscono la relazione tra le due tabelle.

    Nota: se la tabella non ha relazioni di tabella definite, questa opzione non è disponibile.

Per ulteriori informazioni sull'uso dei join, vedi Creare un join tra i dati(Il collegamento viene aperto in una nuova finestra).

Grazie per il tuo feedback.