Prise en main de Tableau Prep Builder

Remarque : Tableau Prep version 2019.1.2 a modifié son nom en Tableau Prep Builder. Si vous utilisez une version antérieure du produit, vous verrez toujours « Tableau Prep » dans le produit.

Ce didacticiel décrit les opérations courantes disponibles dans Tableau Prep Builder. En vous basant sur les exemples d'ensembles de données fournis avec Tableau Prep Builder, vous allez procéder à la création d'un flux pour l'exemple Superstore. Ce didacticiel utilise la version la plus récente de Tableau Prep Builder. Si vous utilisez une version plus ancienne, vos résultats peuvent différer.

Consultez les conseils au fur et à mesure pour découvrir comment Tableau Prep Builder vous aide à nettoyer et à organiser vos données en vue de vos analyses.

Pour installer Tableau Prep Builder avant de poursuivre ce didacticiel, consultez Installer Tableau Prep ou Tableau Prep Builder depuis l'interface utilisateur(Link opens in a new window) dans le Guide de déploiement de Tableau Desktop et de Tableau Prep Builder. Vous pouvez aussi télécharger la version d'essai gratuit(Link opens in a new window).

Exemples de fichiers

Pour effectuer les tâches décrites dans ce didacticiel, vous aurez besoin d'installer Tableau Prep Builder et de télécharger les fichiers de données de l'exemple Superstore sur un emplacement unique :

Vous pouvez également trouver les fichiers à l'emplacement suivant sur votre ordinateur après avoir installé Tableau Prep Builder :

  • (Windows) C:\Program Files\Tableau\Tableau Prep Builder <version>\help\Samples\en_US\Superstore Files
  • (Mac) /Applications/Tableau Prep Builder <version>.app/Contents/help/Samples/en_US/Superstore Files
  • Scénario...

    Vous travaillez au siège social d'une grande chaîne de magasins. Votre responsable souhaite que vous analysiez les ventes de produits et les bénéfices réalisés par l'entreprise au cours des quatre dernières années. Vous lui suggérez d'utiliser Tableau Desktop pour cette mission. Votre responsable approuve votre idée avec enthousiasme et souhaitez que vous vous mettiez au travail immédiatement.

    Vous commencez à collecter toutes les données dont vous allez avoir besoin, mais vous vous rendez compte que les données ont fait l'objet d'une collecte et d'un suivi différents pour chaque région. Vous remarquez aussi qu'il y a un grand nombre d'entrées de données fantaisistes dans les différents fichiers et qu'une région a même un fichier séparé pour chaque année.

    Avant de pouvoir commencer à analyser des données dans Tableau, vous devez donner un bon coup de nettoyage aux données. La nuit va être longue.

    En cherchant de quoi vous sustenter dans les menus de restaurants, il vous revient à l'esprit que Tableau a récemment lancé un nouveau produit appelé Tableau Prep Builder. Voilà qui pourrait vous aider dans votre tâche herculéenne de nettoyage des données.

    Vous vous inscrivez à un essai gratuit(Link opens in a new window) et décidez de voir ce qui se passe.

    1. Se connecter aux données

    La première chose que vous voyez lorsque vous ouvrez Tableau Prep Builder est une page de démarrage comportant un volet Connexions, tout comme Tableau Desktop.

    Pour vous lancer, la première étape consiste à vous connecter à vos données et à créer l'étape des données entrantes. À partir de là, vous commencez à créer un workflow, ou « flux » dans la terminologie Tableau Prep Builder, et à ajouter d'autres étapes pour agir sur vos données au fur et à mesure.

    Conseil : l'étape des données entrantes est le point d'ingestion pour vos données et le point de départ de votre flux. Vous pouvez avoir plusieurs étapes de données entrantes, et certaines peuvent inclure plusieurs fichiers de données. Pour plus d'informations sur la connexion aux données, consultez Se connecter aux données(Link opens in a new window).

    Vos fichiers de données sur les ventes pour les différentes régions sont stockés dans différents formats, et vos commandes pour la région Sud sont dispersées sur plusieurs fichiers. Vous consultez le volet Connexions et vous constatez que vous disposez de nombreux choix pour vous connecter aux données. Formidable !

    Étant donné que vos autres régions ont un fichier pour l'ensemble des quatre années de données, vous décidez de vous attaquer en premier à la région Sud.

    1. Dans le volet Connexions, cliquez sur le bouton Ajouter une connexion.

    2. Les fichiers sont des fichiers .csv, donc sélectionnez Fichier texte dans la liste de connexions.

    3. Accédez au répertoire de vos fichiers, sélectionnez le premier fichier orders_south_2015.csv et cliquez sur Ouvrir pour l'ajouter à votre flux. (Pour connaître l'emplacement des fichiers, consultez Finalisation et ressources.)

      Après que vous vous êtes connecté à votre premier fichier, l'espace de travail Tableau Prep Builder s'ouvre, divisé en deux sections principales. Le volet Flux en haut et le volet Entrée en bas.

      Dans Tableau Prep Builder, le volet Flux est votre espace de travail, très semblable à celui de Tableau Desktop, où vous pouvez interagir avec vos données visuellement et créer votre flux. Le volet Entrée contient les option de configuration relatives à l'ingestion des données. Il affiche également les champs, les types de données et les exemples de valeurs depuis votre ensemble de données.

      Nous examinerons comment vous pouvez interagir avec ces données dans la section suivante.

      Conseil : pour les tables simples, Tableau Prep Builder crée automatiquement une étape des données entrantes pour vous dans le volet Flux lorsque vous ajoutez des données à votre flux. Sinon, vous pouvez utiliser la fonction glisser-déposer pour ajouter des tables au volet Flux.

    4. Vous avez trois autres fichiers pour vos commandes de la région Sud. Vous pourriez ajouter chaque fichier individuellement, mais votre but est de combiner tous les fichiers en une seule étape des données entrantes. Vous cliquez donc sur l'onglet Plusieurs fichiers dans le volet Entrée.

    5. Vous voyez s'afficher une option pour l'Union de caractères génériques. Sélectionnez-la.

      Vous notez que le répertoire où vous avez sélectionné votre fichier est déjà renseigné et que les autres fichiers dont vous avez besoin sont répertoriés dans la section Fichiers inclus du volet des données entrantes.

      Conseil : une union avec caractère générique est très utile pour se connecter à plusieurs fichiers depuis une seule source de données avec nom et structure similaires, et les combiner. Pour utiliser cette option, les fichiers doivent être dans le même répertoire parent ou enfant. Si vous ne voyez pas les fichiers dont vous avez besoin, modifiez vos critères de recherche. Pour plus d'informations, consultez Réunir des fichiers et des tables de base de données dans l'étape des données entrantes(Link opens in a new window).

    6. Cliquez sur Appliquer pour ajouter les données de ces fichiers à l'étape des données entrantes orders_south_2015.

    7. Les fichiers des autres régions sont tous des fichiers d'une seule table si bien que vous pouvez les sélectionner tous à la fois et les ajouter à votre flux.

    8. Ouvrez l'Explorateur de fichiers ou le Finder et accédez au répertoire de fichiers. Faites un Ctrl+clic (Cmd+clic sur MacOS) pour sélectionner les fichiers suivants et faites un glisser-déposer sur le volet Flux pour les ajouter à votre flux. (Pour connaître l'emplacement des fichiers, consultez Finalisation et ressources.)

      • Orders_Central.csv
      • Orders_East.xlsx
      • Orders_West.csv

      Remarque : ce sont différents types de fichiers. Si vous ne voyez pas tous ces fichiers, assurez-vous que votre explorateur de fichiers ou votre Finder est configuré pour afficher tous les types de fichiers.

    Vérifier votre travail : visionnez « Se connecter aux données » en action.

    Cliquez sur l'image pour le rejouer

    2. Explorer vos données

    Maintenant que les fichiers de données sont chargés sur Tableau Prep Builder, vous avez bien l'intention de combiner tous les fichiers ensemble. Avant de le faire, il serait avisé de commencer par les examiner et voir si vous repérez des problèmes.

    Lorsque vous sélectionnez l'étape des données entrantes dans le volet Flux, vous pouvez voir les paramètres utilisés pour rassembler les données, les champs inclus et certaines valeurs échantillonnées.

    C'est un bon moment pour déterminer la quantité de données que vous souhaitez inclure dans votre flux, et supprimer ou filtrer les champs que vous ne souhaitez pas conserver. Vous pouvez aussi modifier les types de données qui n'ont pas été correctement affectés.

    Conseil : si vous travaillez avec des ensembles de données volumineux, Tableau Prep Builder propose automatiquement un échantillon de données afin de maximiser les performances. Si vous ne voyez pas les données attendues, vous devrez peut-être ajuster l'échantillon. Vous pouvez le faire dans l'onglet Échantillon de données. Pour plus d'informations sur la configuration de vos options de données et la taille des échantillons, consultez Définir la taille de votre échantillon de données(Link opens in a new window).

    Dans le volet Flux, à mesure que vous sélectionnez chaque étape et examinez chaque ensemble de données, vous remarquez quelques points à corriger plus tard, et un point que vous pouvez corriger maintenant dans l'étape Entrée.

    • Dans le volet Flux, cliquez sur l'étape des données entrantes Orders_Central pour la sélectionner. Dans le volet Entrée, vous remarquez les problèmes suivants :

      • Les dates de commande et les dates d'expédition sont séparées en champs pour le mois, le jour et l'année.

      • Certains champs présentent des types de données différents dans d'autres fichiers.

      • Il n'y a pas de champ pour la Région.

      Vous devez nettoyer ces champs avant de pouvoir combiner ce fichier avec les autres fichiers. Mais vous ne pouvez pas le faire à l'étape des données entrantes, donc vous faites une note pour plus tard.

    • Sélectionnez l'étape des données entrantes Orders_East.

      Les champs de ce fichier semblent correctement alignés avec les autres fichiers. Par contre, il semble que le code de devise soit inclus dans toutes les valeurs Sales (Ventes). Encore un point que vous devrez corriger aussi plus tard.

    • Sélectionnez l'étape des données entrantes Orders_West. Il y a également quelques problèmes dans ce fichier.

      • Le champ State (État) utilise des abréviations pour le nom de l'État. Dans d'autres fichiers, le nom apparaît en entier, il vous faudra donc corriger ce point plus tard.

      • Beaucoup de champs commencent par Right_. Ces champs semblent être des doublons d'autres champs. Vous ne souhaitez pas inclure ces champs en double dans votre flux. Voici un point que vous pouvez corriger ici dans l'étape des données entrantes :

        Pour le corriger maintenant, désélectionnez la case à cocher pour tous les champs commençant par Right_. Ceci indique à Tableau Prep Builder d'ignorer ces champs et de ne pas les inclure dans le flux.

        Conseil : lorsque vous effectuez des opérations de nettoyage dans une étape, par exemple en supprimant des champs, Tableau Prep Builder enregistre vos modifications dans le volet Modifications et ajoute une annotation (sous la forme d'une petite icône) dans le volet Flux pour que vous disposiez d'un suivi des actions effectuées sur vos données. Pour les étapes des données entrantes, une annotation est également ajoutée à chaque champ.

        Dans Tableau Prep Builder version 2018.3.1 et versions ultérieures, les opérations de nettoyage sont disponibles dans la plupart des étapes de votre flux. Dans les versions antérieures, la plupart des opérations de nettoyage devaient être effectuées dans une étape de nettoyage.

    Maintenant que vous avez identifié ce qui pose problème dans vos ensembles de données, l'étape suivante consiste à examiner vos données d'un peu plus près et à nettoyer les problèmes que vous avez repérés. Vous pourrez ainsi combiner et organiser vos données et générer un fichier de sortie qui servira pour votre analyse.

    3. Nettoyer vos données

    Dans Tableau Prep Builder, l'examen et le nettoyage de vos données est un processus itératif. Une fois que vous avez déterminé sur quel ensemble de données vous voulez travailler, l'étape suivante consiste à l'examiner et à agir sur ces données en leur appliquant diverses opérations de nettoyage, de réorganisation et de combinaison. Vous appliquez ces opérations en ajoutant des étapes à votre flux. Pour plus d'informations sur les options de nettoyage dans Tableau Prep Builder, consultez Nettoyer et organiser les données(Link opens in a new window).

    Les étapes peuvent varier, selon ce que vous comptez faire. Par exemple, ajoutez une étape de nettoyage dès que vous souhaitez appliquer des opérations de nettoyage à vos champs, par exemple filtrer, fusionner, fractionner, renommer, etc. Ajoutez une étape d'agrégation pour regrouper et agréger des champs, et modifiez le niveau de détail de vos données. Pour plus d'informations sur les différents types d'étapes et leurs utilisations, consultez Créer et organiser votre flux(Link opens in a new window).

    Conseil : lorsque vous ajoutez des étapes à votre flux, une ligne de flux est automatiquement ajoutée pour connecter les étapes les unes aux autres. Vous pouvez déplacer ces lignes de flux et les supprimer ou les ajouter en fonction de vos besoins.

    Lorsque vous exécutez votre flux, ces points de connexion sont requis pour que Tableau Prep Builder puisse savoir quelles étapes sont connectées et dans quel ordre ces étapes s'appliquent dans le flux. S'il manque une ligne de flux, le flux sera interrompu et une erreur s'affichera.

    Nettoyer Orders_Central

    Pour résoudre les problèmes que vous avez remarqués précédemment, et pour voir s'il n'y a pas d'autres problèmes, commencez par ajouter une étape de nettoyage à l'étape des données entrantes Orders_Central.

    1. Dans le volet Flux, sélectionnez Orders_Central, cliquez sur l'icône plus et ajoutez une étape de nettoyage. Selon votre version, cette option de menu est Ajouter une étape, Ajouter une étape de nettoyage ou Étape de nettoyage.

      Lorsque vous ajoutez une étape de nettoyage à votre flux, l'espace de travail change et vous voyez les détails de vos données.

      A. Volet Flux, B. Barre d'outils, C. Volet Profil, D. Grille de données

      L'espace de travail est désormais divisé en trois parties : le volet Flux, le volet Profil avec une barre d'outils et la Grille de données.

      Le volet Profil vous montre la structure de vos données, en résumant les valeurs de champs dans des classes afin que vous puissiez voir rapidement les valeurs associées et repérer les données atypiques ainsi que les valeurs null. La Grille de données vous montre le niveau de détail des lignes pour vos champs.

      Astuce : chaque champ du volet Profil s'affiche dans un volet Profil. Utilisez le menu Options supplémentaires(flèche déroulante dans les versions antérieures) sur chaque fiche pour voir et sélectionner les différentes options de nettoyage disponibles pour ce type de champ. Vous pouvez également trier les valeurs de champ, modifier le type de données, affecter un type de données au champ, ou faire glisser-déposer les fiches Profil et les colonnes dans la grille de Données pour les réorganiser.

      Nettoyer les données avec les champs calculés

      Il manque un champ pour Region dans cet ensemble de données. Étant donné que les autres ensembles de données possèdent ce champ, vous devrez l'ajouter afin de pouvoir combiner vos données ultérieurement. Pour cela, vous devrez utiliser un champ calculé.

    2. Dans la barre d'outils, cliquez sur Créer un champ calculé.

    3. Dans l'éditeur de calcul, nommez le champ calculé Région. Entrez ensuite "Central" (y compris les guillemets) et cliquez sur Enregistrer.

      Vous apprécierez la flexibilité qu'offrent les champs calculés pour organiser vos données. Vous constatez avec plaisir que Tableau Prep Builder utilise le même langage d'éditeur de calcul que Tableau Desktop.

      Conseil : lorsque vous apportez des modifications à vos champs et valeurs, Tableau Prep Builder les mémorise dans le Suivi des modifications. Une icône (annotation) représentant la modification est également ajoutée à l'étape de nettoyage dans le flux et au champ dans le volet Profil. Nous allons examiner le Suivi des modifications après avoir apporté d'autres modifications.

      Ensuite, vous souhaitez vous occuper des champs séparés de date de commande et date d'expédition. Vous souhaitez les combiner en deux champs uniques, un pour Order Date (Date de commande) et un pour Ship Date (Date d'expédition) afin qu'ils soient alignés avec les mêmes champs dans les autres ensembles de données. En veillant à ce que vos tables contiennent les mêmes champs, vous pourrez combiner ultérieurement les tables à l'aide d'une union.

      Vous pouvez utiliser un champ calculé pour le faire en une seule étape facile.

    4. Dans la barre d'outils, cliquez sur Créer un champ calculé pour combiner les champs Order Year (Année de commande), Order Month (Mois de commande) et Order Day (Jour de commande) en un champ au format « MM/DD/YYYY ».

    5. Dans l'éditeur de calcul, nommez le champ calculé Date de commande. Entrez ensuite le calcul suivant, puis cliquez sur Enregistrer :

      MAKEDATE([Order Year],[Order Month],[Order Day])

      Maintenant que vous avez un nouveau champ pour votre date de commande, vous souhaitez supprimer les champs existants, étant donné qu'ils sont devenus inutiles.

      Le volet Profil comporte de nombreux champs. Vous remarquerez une zone Recherche en haut à droite de la barre d'outils. Vous vous demandez si vous pouvez l'utiliser pour trouver rapidement les champs que vous souhaitez supprimer. Vous décidez de tenter l'opération.

    6. Dans le volet Profil, dans la zone de recherche Order (Commande).

      Tableau Prep Builder fait rapidement défiler tous les champs qui contiennent Order dans la vue. Parfait !

    7. Faites un Ctrl+clic (Cmd+clic sur MacOS) pour sélectionner les champs pour Order Year, Order Month et Order Day. Faites ensuite un clic droit sur les champs sélectionnés et sélectionnez Supprimer (Supprimer le champ dans les versions précédentes) dans le menu pour les supprimer.

    8. Répétez maintenant les étapes 4 à 7 ci-dessus pour créer un seul champ pour Ship Date (Date d'expédition). Essayez de vous-même ou utilisez les étapes ci-dessous pour vous aider.

      • Dans la barre d'outils, cliquez sur Créer un champ calculé pour combiner les champs Ship Year (Année d'expédition), Ship Month (Mois d'expédition) et Ship Day (Jour d'expédition) en un champ au format « MM/DD/YYYY ».

      • Nommez le champ calculé Ship Date et entrez le calcul MAKEDATE([Ship Year],[Ship Month],[Ship Day]). Cliquez ensuite sur Enregistrer.

      • Supprimez les champs Ship Year, Ship Month et Ship Day. Recherchez les champs, sélectionnez-les et sélectionnez Supprimer(Supprimer le champ dans les versions précédentes) dans le menu pour supprimer les champs.

      Conseil : Tableau Prep Builder résume les données dans le volet Profil en classes pour vous aider à voir rapidement la forme de vos données, repérer les données atypiques, identifier les relations entre les champs, etc.

      Dans ce scénario, les dates de commande et d'expédition peuvent désormais être résumées par année. Chaque classe représente une année depuis janvier de l'année de début à janvier de l'année suivante, et est étiquetée en conséquence. Étant donné que certains dates de ventes et dates d'expédition tombent dans la dernière partie de 2018 et 2019, nous avons une classe étiquetée avec l'année de fin 2019 et 2020 en conséquence.

      Pour modifier cette vue sur les dates réelles, cliquez sur le menu Options supplémentaires (flèche déroulante dans les versions précédentes) dans la fiche Profil et sélectionnez Détails.

      Interagir directement avec les champs pour nettoyer vos données

      Vos données commencent à prendre forme. Mais au moment où vous finissez de supprimer les champs supplémentaires pour les dates de commande et d'expédition, vous remarquez que le champ Discounts présente plusieurs problèmes.

      • Il est affecté à un type de données Chaîne au lieu d'un type de données Nombre (décimal).

      • Une valeur de champ affiche Aucun au lieu d'une valeur numérique pour l'absence de remise.

      Ceci générera un problème lors de la combinaison de vos fichiers. Vous avez donc intérêt à corriger aussi ce problème.

    9. Effacez votre recherche et entrez disc dans la zone de recherche pour trouver le champ.

    10. Sélectionnez le champ Discounts, double-cliquez sur la valeur de champ Aucun, et modifiez sur la valeur numérique 0.

    11. Pour modifier le type de données du champ Remise de Chaîne en Nombre (décimal), cliquez sur Abc et sélectionnez Nombre (décimal) dans le menu déroulant.

    12. Enfin, nommez votre étape pour vous aider à vous souvenir de ce que vous avez fait dans cette étape. Dans le volet Flux, double-cliquez sur le nom de l'étape Nettoyage 1 et entrez Correction dates/noms de champs.

    Vérifier vos modifications

    Vous avez apporté de nombreuses modifications à cet ensemble de données et vous commencez à vous inquiéter de ne pas mémoriser tout ce que vous avez fait. Lorsque vous examinez votre travail, vous voyez une colonne à gauche du volet Profil qui est intitulée Modifications.

    Vous cliquez sur la flèche pour l'ouvrir et vous avez la bonne surprise de voir la liste de toutes les modifications que vous avez apportées. Lorsque vous faites défiler les modifications dans la liste, vous notez que vous pouvez supprimer ou modifier vos modifications ou même les déplacer pour changer l'ordre dans lequel vous les avez effectuées.

    Vous appréciez de pouvoir retrouver facilement les modifications que vous avez effectuées à chaque étape lors de la création de votre flux et de pouvoir expérimenter avec l'ordre de ces modifications pour tirer le meilleur parti de vos données.

    Vérifier votre travail : visionnez « Nettoyer Orders_Central » en action.

    Cliquez sur l'image pour le rejouer

    Maintenant que vous avez nettoyé un fichier, vous examinez les autres fichiers pour voir si vous avez besoin de corriger d'autres problèmes.

    Vous décidez d'examiner ensuite le fichier Excel de Orders_East.

    Nettoyer Orders_East

    En examinant les champs du fichier Orders_East, la plupart des champs semblent être alignés avec les autres fichiers, à l'exception du champ Sales (Ventes). Pour examiner les choses de plus près et pour voir s'il n'y a pas d'autres problèmes, vous ajoutez une étape de nettoyage à l'étape des données entrantes Orders_East.

    1. Dans le volet Flux, sélectionnez Orders_East, cliquez sur l'icône plus et ajoutez une étape de nettoyage. Selon votre version, cette option de menu est Ajouter une étape, Ajouter une étape de nettoyage ou Étape de nettoyage.

      En examinant le champ Sales, vous constatez rapidement que le code de devise USD a été inclus avec les chiffres de vente et que Tableau Prep Builder a interprété ces champs comme une chaîne.

      Vous devez supprimer le code de devise de ce champ et modifier le type de données si vous souhaitez obtenir des données de vente exactes.

      Il est facile de corriger le type de données, vous savez déjà comment procéder. Par contre, il y a plus de 2000 lignes uniques de données de ventes et il serait fastidieux de corriger chaque ligne individuellement pour en supprimer le code de devise.

      Mais vous utilisez Tableau Prep Builder, et vous décidez de vous reporter au menu déroulant pour voir si une option peut faire cela pour vous.

      Lorsque vous cliquez sur Options supplémentaires (flèche déroulante dans les anciennes versions) du champ Sales, vous voyez s'afficher une option de menu intitulée Nettoyer et une option en-dessous pour supprimer des lettres. Vous décidez de tenter l'opération et de voir ce qui se passe.

    2. Sélectionnez le champ Sales. Cliquez sur le menu Options supplémentaires(flèche déroulante dans les versions précédentes) et sélectionnez Nettoyer > Supprimer des lettres.

      Épatant ! Cette option de nettoyage a instantanément supprimé le code de devise de chaque champ. Vous n'avez maintenant plus qu'à modifier le type de données de Chaîne en Nombre (décimal) et ce champ aura bonne allure.

    3. Cliquez sur le type de données dans le champ Ventes et sélectionnez Nombre (décimal) dans la liste déroulante pour modifier le type de données.

    4. Le reste du fichier ne semble pas poser de problème. Nommez votre étape de nettoyage pour vous souvenir de votre travail, par exemple Changement du type de données.

    Ensuite, vous examinez votre dernier fichier Orders_West pour voir s'il y a des problèmes à corriger.

    Nettoyer Orders_West

    Lorsque vous examinez les champs du fichier Orders_West, la plupart des champs semblent alignés avec les autres fichiers, mais vous vous rappelez que le champ States (États) utilise des abréviations pour les valeurs au lieu du nom complet de l'État. Pour combiner ce fichier avec les autres fichiers, vous devez corriger ce problème. Vous ajoutez ainsi une étape de nettoyage à l'étape des données entrantes Orders_West.

    1. Dans le volet Flux, sélectionnez Orders_West, cliquez sur l'icône plus et ajoutez une étape de nettoyage.

      Faites défiler ou utilisez la recherche pour trouver le champ State (État). Vous constatez que les valeurs de noms d'État utilisent l'abréviation courte. Il n'y a que 11 valeurs uniques pour ce champ. Vous pourriez modifier manuellement chacune d'elles, mais peut-être que Tableau Prep Builder a prévu une autre méthode ?

      Vous cliquez sur le menu Options supplémentaires (flèche déroulante dans les versions précédentes) pour le champ et vous voyez une option appelée Regrouper les valeurs (Regrouper et remplacer dans les versions précédentes). Quand vous la sélectionnez, plusieurs options s'affichent :

      • Sélection manuelle

      • Prononciation

      • Caractères communs

      • Orthographe

      Les noms des États n'ont pas la même sonorité, leur orthographe est correcte, et ils ne partagent pas les mêmes caractères. Vous décidez donc d'essayer l'option Sélection manuelle.

      Astuce : vous pouvez double-cliquer sur un nom de champ ou une valeur de champ pour modifier une seule valeur. Pour modifier plusieurs valeurs, vous pouvez sélectionner toutes les valeurs et utiliser l'option du menu contextuel Modifier les valeurs. Mais si vous souhaitez associer une ou plusieurs valeurs à des valeurs spécifiques, utilisez l'option Regrouper les valeurs dans le menu déroulant.
      Pour plus d’informations sur la modification et le regroupement de valeurs de champ, voir Modifier des valeurs de champ(Link opens in a new window).

    2. Sélectionnez le champ State. Cliquez sur la flèche déroulante et sélectionnez Regrouper les valeurs (Regrouper et remplacer dans les versions précédentes) > Sélection manuelle.

      Une fiche de deux colonnes s'ouvre. Il s'agit de l'Éditeur Regrouper les valeurs. La colonne sur la gauche affiche les valeurs du champ actuel et la colonne sur la droite affiche les champs disponibles à associer aux champs sur la gauche.

      Vous souhaitez associer les abréviations d'État à la version de complète du nom de l'État, mais vous ne trouvez pas ces valeurs dans l'ensemble de données Orders_West. Vous vous demandez si vous pouvez simplement modifier le nom directement et peut-être l'ajouter ici, et vous vous lancez.

    3. Dans l’Éditeur Regrouper les valeurs dans le volet gauche, double-cliquez sur AZ pour surligner la valeur et tapez Arizona. Appuyez ensuite sur Entrée pour ajouter votre modification.

      Tableau Prep Builder a créé une valeur associée pour votre nouvelle valeur Arizona et a automatiquement associé l'ancienne valeur, AZ, avec elle. Si vous avez configuré une relation d'association pour ces valeurs, vous gagnerez du temps dans le cas où d'autres valeurs de cette région sont entrées de cette manière.

      Astuce : vous pouvez ajouter des valeurs de champ qui ne sont pas dans votre échantillon de données pour configurer des relations d'association et organiser ainsi vos données. Si vous actualisez votre source de données et que de nouvelles données sont ajoutées, vous pouvez ajouter les nouvelles données à l'association au lieu de corriger manuellement chaque valeur.

      Lorsque vous ajoutez manuellement une valeur qui ne figure pas dans votre échantillon de données, la valeur est marquée avec un point rouge pour vous aider à l'identifier facilement.

    4. Répétez ces étapes pour associer chaque État avec la version complète de son nom.

      Abréviation Nom de l'État
      AZ Arizona
      CA California
      CO Colorado
      ID Idaho
      MT Montana
      NM New Mexico
      NV Nevada
      OR Oregon
      UT Utah
      WA Washington
      WY Wyoming

      Cliquez ensuite sur Terminé pour fermer l’Éditeur Regrouper les valeurs.

      Une fois que tous les États sont associés, vous consultez le volet Modifications et vous constatez qu'il n'y a qu'une seule entrée au lieu de 11.

      Il semble que Tableau Prep Builder regroupe ensemble les actions similaires appliquées à un champ. La méthode vous plaît parce qu'elle vous aidera à retrouver plus facilement les modifications que vous avez apportées à votre ensemble de données.

      La correction des valeurs du champ State était la seule modification que vous aviez à faire ici.

    5. Nommez votre étape de nettoyage pour vous souvenir de votre travail, par exemple Renommer les États.

    Vous avez effectué un grand nettoyage de vos données et vous êtes stupéfait de voir à quel point cette opération était facile et rapide. Vous allez même pouvoir rentrer à temps pour le dîner ! Pour être sûr de ne pas perdre le travail effectué jusqu'à ce point, enregistrez votre flux.

    Cliquez sur Fichier > Enregistrer ou Fichier > Enregistrer sous. Enregistrez votre fichier en tant que fichier de flux (.tfl) et donnez-lui un nom, par exemple Mon Superstore.

    Astuce : lorsque vous enregistrez vos fichiers de flux (.tfl), vous pouvez soit les enregistrer en tant que fichier de flux (.tflx), soit compresser vos fichiers de données locales avec eux pour partager le flux et les fichiers avec une autre personne. Pour plus d'informations sur l'enregistrement et le partage de vos flux, consultez Enregistrer et partager votre travail(Link opens in a new window).

    4. Combiner vos données

    Maintenant que tous les fichiers sont nettoyés, vous voilà prêt à les combiner tous.

    Parce que tous les fichiers ont des champs similaires après vos efforts de nettoyage, pour regrouper toutes les lignes dans une seule table, vous devez unir les tables.

    Vous vous rappelez qu'il existe une option d'étape intitulée Union, mais vous vous demandez si vous pouvez simplement faire glisser et déposer les étapes pour les réunir. Vous décidez d'essayer et de voir ce que cela donne.

    Réunir vos données

    1. Dans le volet Flux, faites glisser l'avant-dernière étape de nettoyage sur la dernière étape de nettoyage de votre flux et déposez-la sur l'option Union . Par exemple, faites glisser l'étape de nettoyage Renommer les États vers l'étape Type de données modifié et déposez-la dans l'option Union.

      Vous voyez que Tableau Prep Builder a ajouté une nouvelle étape Union à votre flux. Formidable ! Vous souhaitez maintenant ajouter aussi les autres fichiers à cette union.

    2. Faites glisser la deuxième étape de nettoyage dans le flux jusqu'à la nouvelle étape Corriger les dates/noms des champs dans la nouvelle étape Union puis déposez-la sur Ajouter pour l'ajouter à l'union existante.

    3. Faites glisser l'étape orders_south_2015 vers la nouvelle étape Union. Faites-la glisser sur Ajouter pour l'ajouter à l'union existante.

      Tous vos fichiers sont maintenant combinés en une seule table ! Dans le volet Flux, sélectionnez la nouvelle étape Union pour voir vos résultats.

      Vous notez que Tableau Prep Builder a automatiquement associé les champs présentant les mêmes noms et types.

      Vous voyez aussi que les couleurs affectées aux étapes dans le flux sont utilisées dans les profils d'union pour indiquer la provenance du champ et apparaissent aussi dans la bande colorée en haut de chaque champ pour vous indiquer si ce champ existe dans cette table.

      Vous notez qu'un nouveau champ appelé Table Names (Noms des tables) a été ajouté. Il répertorie les tables d'où proviennent toutes les lignes de l'union.

      Une liste des champs discordants s'affiche également dans le volet Résumé et il vous apparaît aussitôt que les champs Product et Discounts apparaissent uniquement dans le fichier Orders_Central.

    4. Pour examiner ces champs de plus près, dans le volet Résultats de l'union, sélectionnez la case à cocher Afficher uniquement les champs sans correspondance.

      En examinant les données de champ, vous verrez que les donnés sont identiques, mais que le nom du champ est différent. Vous pourriez simplement renommer le champ, mais vous vous demandez s'il ne serait pas possible de simplement faire glisser et déposer ces champs pour les fusionner. Vous décidez d'essayer et de voir ce que cela donne.

    5. Sélectionnez le champ Product et faites un glisser-déposer sur le champ Product Name pour fusionner les champs. Une fois fusionnés, les champs n'apparaissent plus dans le volet.

    6. Répétez cette étape pour fusionner le champ Discounts avec le champ Discount.

      Le seul champ qui n'a pas de correspondance maintenant est le champ File Paths (Chemins d'accès des fichiers). Ce champ affiche les chemins d'accès des fichiers pour l'union de caractères génériques que vous avez réalisée pour vos commandes de ventes de la région Sud. Vous décidez de garder ce champ parce qu'il contient des informations utiles.

      Conseil : vous disposez de plusieurs options pour corriger des champs discordants après une union.

      Selon la version de Tableau Prep Builder que vous utilisez, vous pouvez sélectionner un champ dans la liste Champs discordants (version 2018.2.1 et versions ultérieures) et s'il détecte une correspondance possible, Tableau Prep Builder la surlignera en jaune. Pour fusionner les champs, survolez le champ surligné et cliquez sur le bouton Plus qui apparaît.

      Pour d'autres manières de fusionner des champs dans une union, consultez Corriger les champs non concordants.

    7. Désactivez la case à cocher Afficher uniquement les champs sans correspondance pour afficher tous les champs inclus dans l'union.

    8. Nommez votre étape Union pour indiquer le travail couvert par cette union, par exemple Toutes les commandes.

    Vérifier votre travail : visionnez « Réunir vos données » en action.

    Cliquez sur l'image pour le rejouer

    Vous êtes un génie du nettoyage ! Pendant que vous admirez le résultat de votre travail, votre responsable vous appelle. Il a oublié de mentionner qu'il souhaite que vous incluiez tous les retours de produit dans votre analyse. Il espère que cette manipulation ne vous demandera pas trop de travail. Avec Tableau Prep Builder dans votre trousse d'outils, vous êtes paré.

    Nettoyer les données de retours de produits

    Vous examinez le fichier Excel des retours de produits que votre responsable vous a envoyé. Il est un peu confus. Vous ajoutez le nouveau fichier return_reasons new à votre flux pour l'examiner de plus près.

    1. Dans le volet Connexions, cliquez sur Ajouter une connexion. Sélectionnez Microsoft Excel et accédez aux fichiers de l'exemple de données Superstore (consultez Exemples de fichiers pour télécharger le fichier).

    2. Sélectionnez return reasons_new.xlsx, puis cliquez sur Ouvrir pour ajouter le fichier au volet Flux.

      Dans ce fichier de votre flux, vous ne souhaitez inclure que 4 champs : Order ID (ID de commande), Product ID (ID de produit), Return Reason (Motif du retour) et Notes (Remarques).

    3. Dans le volet Entrée de returns_new, désactivez la case à cocher en haut de la grille de champ pour désactiver toutes les cases à cocher. Sélectionnez ensuite la case à cocher des champs Order ID, Product ID, Return Reason et Notes.

    4. Renommez l'étape des données entrantes afin de mieux refléter les données incluses dans cette entrée. Dans le volet Flux, double-cliquez sur le nom de l'étape Returns_new et entrez Returns (all).

      En examinant les échantillons de valeurs de champ, vous remarquez que le champ Notes semble combiner beaucoup de données différentes.

      Vous allez devoir faire du nettoyage dans ce fichier avant tout autre travail sur les données. Vous ajoutez donc une étape de nettoyage pour vérifier.

    5. Dans le volet Flux, sélectionnez l’étape des données entrantes Renvoie (tout), cliquez sur l'icône Plus , puis ajoutez une étape.

      Dans le volet Profil, redimensionnez le champ Notes afin de mieux voir les entrées. Pour cela, cliquez sur le bord extérieur droit du champ et faites-le glisser vers la droite.

    6. Dans le champ Remarques, utilisez la barre de défilement visuelle à droite des valeurs de champ pour scanner les valeurs.

      Vous notez quelques points problématiques :

      • Il y a un espace supplémentaire dans certaines entrées. Cela peut entraîner la lecture du champ comme étant une valeur null.

      • Il semble que le nom de l'approbateur soit inclus dans l'entrée des remarques sur le retour. Pour mieux travailler avec ces données, vous souhaitez placer ces informations dans un champ séparé.

      Pour éliminer les espaces supplémentaires, vous vous rappelez qu'il existe une option de nettoyage permettant de supprimer les espaces de fin. Vous décidez de l'essayer pour voir si cela peut résoudre le premier problème et supprimer les espaces supplémentaires.

    7. Sélectionnez le champ Remarques. Cliquez sur le menu Options supplémentaires (flèche déroulante dans les versions précédentes) et sélectionnez Nettoyer > Supprimer des espaces.

      Oui ! L'opération s'est déroulée comme vous le souhaitiez. Les espaces supplémentaires ont disparu !

      Vous souhaitez ensuite créer un champ séparé pour le nom de l'approbateur. Vous voyez une option Scinder les valeurs dans le menu et vous décidez de l'utiliser.

    8. Sélectionnez le champ Remarques. Cliquez sur le menu Options supplémentaires(flèche déroulante dans les versions précédentes) et sélectionnez Scinder les valeurs > Scission automatique.

      Cette option a fonctionné exactement comme vous le souhaitiez. Elle a automatiquement scindé les remarques sur les retours et le nom de l'approbateur en des champs séparés.

      Comme dans Tableau Desktop, Tableau Prep Builder a automatiquement attribué un nom à ces champs. Vous devez donc renommer ces champs en un nom descriptif.

    9. Sélectionnez le champ Remarques-Scission 1. Double-cliquez sur le nom du champ et entrez Remarques sur les retours.

    10. Répétez cette étape pour le second champ et renommez-le en Approbateur.

    11. Enfin, supprimez le champ Notes d'origine puisque vous n'en avez plus besoin. Sélectionnez le champ Notes, cliquez sur le menu Options supplémentaires (flèche déroulante dans les versions précédentes) et sélectionnez Supprimer (Supprimer le champ dans les versions précédentes) dans le menu.

      En examinant le nouveau champ Approver (Approbateur), vous remarquez que les valeurs de champ répertorient les mêmes noms mais sont entrées différemment. Vous souhaitez les regrouper pour éliminer les variations multiples de la même valeur.

      Peut-être que l'option Regrouper les valeurs (Regrouper et remplacer dans les versions précédentes) peut vous aider ?

      Vous vous souvenez qu'il existe une option pour les Caractères communs. Étant donné que ces valeurs partagent les mêmes lettres, vous décidez d'essayer cette option.

    12. Sélectionnez le champ Approver. Cliquez sur le menu Options supplémentaires (flèche déroulante dans les versions précédentes) et sélectionnez Regrouper les valeurs (Regrouper et remplacer dans les versions précédentes) > Caractères communs.

      Cette option a regroupé toutes les variations de chaque nom pour vous. C'était exactement le résultat recherché.

      Après avoir vérifié les autres noms pour vous assurer qu'ils sont correctement regroupés, cliquez sur Terminé pour fermer l'Éditeur Regrouper les valeurs.

      Ce fichier se présente bien.

    13. Nommez votre étape de nettoyage pour vous souvenir de votre travail, par exemple Remarques nettoyées.

    Maintenant que les données de retours de produits sont toutes nettoyées, vous souhaitez ajouter ces données aux données de commandes depuis vos fichiers réunis. Par contre, un grand nombre de ces fichiers n'existe pas dans les fichiers réunis. Pour ajouter ces champs (colonnes de données) à votre ensemble de données réunies, vous devez utiliser une liaison.

    Lier vos données

    Pour que vous puissiez lier des données, les fichiers doivent avoir au moins un champ en commun. Vos fichiers partagent les champs Order ID et Product ID si bien que vous pouvez lier ces champs pour voir toutes les données que ces champs ont en commun. Vous vous souvenez qu'il existe une option permettant de créer une liaison lorsque vous avez créé votre union à l'aide d'un glisser-déposer. Vous décidez de l'essayer.

    1. Dans le volet Flux, faites glisser l'étape Remarques nettoyées sur l'étape d'union Toutes les commandes et faites-la glisser sur Liaison.

      Lorsque vous liez les fichiers, Tableau Prep Builder affiche le résultat de votre jointure dans Profil de jointure.

      L'utilisation de liaisons peut se révéler complexe. Vous voulez souvent avoir une vue claire des facteurs qui sont inclus dans la liaison, par exemple les champs utilisés pour lier les fichiers, le nombre de lignes inclus dans les résultats et tous les champs qui ne sont pas inclus ou qui sont des valeurs null.

      Lorsque vous vérifiez les résultats d'une jointure dans Tableau Prep Builder, vous êtes ravi d'avoir accès à autant d'informations et d'interactivité.

      Conseil : le volet tout à gauche du profil de liaison vous permet d'explorer la liaison et d'interagir avec elle. Vous pouvez également modifier des valeurs directement dans les volets Clauses de jointure et effectuer d'autres opérations de nettoyage dans le volet Résultats de la jointure.

      Cliquez sur le schéma Type de liaison pour essayer différentes configurations de liaison et voir le nombre de lignes incluses ou exclues dans votre liaison pour chaque table dans la section Résumé des résultats de liaison.

      Sélectionnez les champs à lier dans la section Clauses de jointure appliquées ou ajoutez les clauses de jointure suggérées dans la section Recommandations sur les clauses de jointure.

      Pour plus d'informations sur l'utilisation de jointures, consultez Agréger, lier ou réunir des données(Link opens in a new window).

      Vous voyez que vous avez plus de 13 000 lignes exclues de vos fichiers All Orders (Toutes les commandes). Lorsque vous avez créé votre jointure, Tableau Prep Builder a automatiquement créé une jointure sur le champ Product ID, mais vous souhaitiez également créer une jointure sur le champ Order ID.

      Lorsque vous examinez le volet gauche du profil de liaison, vous constatez que Order ID figure dans la liste des clauses de liaison recommandées, donc vous l'y ajoutez rapidement depuis ce point.

    2. Dans le volet gauche du profil de Liaison, dans la section Recommandations relatives aux clauses de liaison, sélectionnez Order ID = Order ID, puis cliquez sur le bouton Plus pour ajouter la clause de liaison.

      Le Type de jointure étant défini sur une jointure interne (paramètre par défaut pour Tableau Prep Builder), la jointure inclut uniquement des valeurs qui existent dans les deux fichiers. Mais vous souhaitez toutes vos données des fichiers Orders ainsi que les données de retours pour ces fichiers. Vous avez donc besoin de modifier le type de liaison.

    3. Dans la section Type de jointure , cliquez sur le côté du diagramme pour inclure toutes les commandes. Dans l'exemple ci-dessous, cliquez sur le côté gauche du diagramme pour changer le type de jointure en jointure gauche et inclure toutes les données de l'étape union Toutes les commandes et toutes les données correspondantes de l'étape Remarques nettoyées .

      Vous avez maintenant toutes les données des fichiers de commandes de ventes et toutes les données de retours s'appliquant à ces commandes. Vous consultez le volet Clauses de liaison et vous voyez des valeurs distinctes qui n'existent pas dans l'autre fichier.

      Par exemple, plusieurs lignes de commandes (affichées en rouge) n'ont pas de données de retour correspondantes. Vous appréciez de pouvoir explorer ce niveau de détail dans votre liaison.

      Vous avez hâte de démarrer votre analyse de ces données dans Tableau Desktop, mais vous remarquez quelques résultats dans la liaison que vous souhaitez nettoyer au préalable. Par chance, vous savez comment vous y prendre !

      Astuce : vous vous demandez si le nettoyage de vos données est assez poussé ? Vous pouvez prévisualiser vos données dans Tableau Desktop depuis toute étape de votre flux pour vous en assurer.

      Il vous suffit de faire un clic droit sur l'étape dans le volet Flux et de sélectionner Aperçu dans Tableau Desktop dans le menu.

      Vous pouvez expérimenter avec vos données. Toutes les modifications que vous apportez dans Tableau Desktop ne seront pas retranscrites dans votre source de données dans Tableau Prep Builder. Pour plus d'informations, consultez Afficher votre échantillon de données dans Tableau(Link opens in a new window).

    4. Avant de lancer le nettoyage de vos résultats de liaison, nommez votre étape de liaisonCommandes+Retours et enregistrez votre flux.

    Nettoyer vos résultats de liaison

    Remarque : pour nettoyer les champs dans votre jointure, vous pouvez effectuer des opérations de nettoyage directement dans l'étape Lier. Dans l'optique de ce didacticiel, nous allons ajouter une étape de nettoyage afin que vous puissiez voir clairement vos opérations de nettoyage. Si vous souhaitez effectuer ces étapes directement dans l'étape de jointure, ignorez les étapes 1 et 3 ci-dessous.

    Lorsque vous avez lié les deux étapes, les champs communs Order ID et Product ID ont été ajoutés aux deux tables.

    Vous souhaitez conserver le champ Product ID de toutes vos commandes et le champ Order ID du fichier des retours, et supprimer les champs en double issus de ces fichiers. Vous n'avez pas besoin des champs Chemins d'accès de fichiers et Noms de tables dans votre fichier de sortie, donc vous supprimez également ces champs.

    Conseil : lorsque vous liez des tables en utilisant des champs qui existent dans les deux fichiers, Tableau Prep Builder intègre les deux champs et renomme le champ en double du second fichier en ajoutant un « -1 » ou un « -2 » au nom du champ, par exemple Order ID et Order ID-1.

    1. Dans le volet Flux, sélectionnez Commandes+Retours, cliquez sur l'icône plus et ajoutez une étape de nettoyage.

    2. Dans le volet Profil, sélectionnez et supprimez les champs suivants :

      • Table Names

      • Order ID

      • File Paths

      • Product ID-1

    3. Renommez le champ Order ID-1 en Order ID.

      Vous avez plusieurs valeurs null là où le produit a été retourné, mais sans remarque sur le retour ni indication de l'approbateur. Pour faciliter l'analyse de ces données, vous souhaitez afficher un champ avec une valeur de Oui et Non pour indiquer si le produit a été retourné.

      Vous n'avez pas ce champ, donc vous pouvez l'ajouter en créant un champ calculé.

    4. Dans la barre d'outils, cliquez sur Créer un champ calculé.

    5. Nommez le champ Retourné?, entrez le calcul suivant puis cliquez sur Enregistrer.

      If ISNULL([Return Reason])=FALSE THEN "Yes" ELSE "No" END

      Pour votre analyse, vous voudriez aussi connaître le nombre de jours nécessaires à l'expédition d'une commande, mais vous ne disposez pas non plus de ce champ.

      Vous avez par contre toutes les informations nécessaires pour le créer, donc vous ajoutez un autre champ calculé pour le créer.

    6. Dans la barre d'outils, cliquez sur Créer un champ calculé.

    7. Nommez le champ Jours avant expédition, entrez le calcul suivant puis cliquez sur Enregistrer.

      DATEDIFF('day',[Order Date],[Ship Date])

    8. Nommez votre étape Nettoyer Commandes+Retours.

    9. Enregistrez votre flux.

    5. Exécuter votre flux et générer une sortie

    Vos données se présentent bien et vous êtes prêt à générer votre fichier de sortie pour commencer à l'analyser dans Tableau Desktop. Il vous suffit d'exécuter votre flux et de générer votre fichier d'extrait. Pour cela, ajoutez une étape Sortie.

    1. Dans le volet Flux, sélectionnez le flux Nettoyer Commandes+Retours, cliquez sur l'icône plus et sélectionnez Sortie (Ajouter une sortie dans les versions précédentes).

      Lorsque vous ajoutez une étape Sortie, le volet Sortie s'ouvre et affiche un instantané de vos données. Vous pouvez sélectionner ici le type de sortie que vous souhaitez générer et spécifier le nom du fichier et son emplacement d'enregistrement.

      L'emplacement par défaut est le référentiel My Tableau Prep Builder dans votre dossier de sources de données.

    2. Dans le volet gauche de la liste déroulante Enregistrer la sortie sur, sélectionnez Fichier (sélectionnez Enregistrer dans le fichier dans les versions précédentes).

    3. Cliquez sur le bouton Parcourir, puis dans la boîte de dialogue Enregistrer l'extrait sous, entrez un nom pour le fichier, par exemple Commandes_Retours_Superstore, et cliquez sur Accepter.

    4. Dans le champ Type de sortie, sélectionnez l'un des types de sortie suivants. Selon la version de Tableau Desktop que vous utilisez, vous avez le choix entre les options suivantes :

      • Tableau Data Extract (.hyper) pour Tableau Desktop version 10.5 et versions ultérieures.

      • Extrait de données Tableau (.tde) pour Tableau Desktop version 10.0 à 10.4.

      • Fichiers de valeurs séparées par des virgules (.csv) si vous souhaitez partager l'extrait avec un tiers.

      Astuce : vous avez plusieurs options lorsque vous générez une sortie à partir de votre flux. Vous pouvez générer un fichier d'extrait ou vous pouvez publier vos données en tant que source de données sur Tableau Server ou Tableau Online. Pour plus d'informations sur la génération de fichiers de sortie, consultez Créer et publier des extraits de données et des sources de données(Link opens in a new window).

    5. Dans la section Options d’écriture, affichez les options pour écrire les nouvelles données dans vos fichiers. Vous souhaitez utiliser le paramètre par défaut (Créer la table) et remplacer la table par votre sortie de flux, il n’y a donc rien à changer ici.

      Conseil : depuis la version 2020.2.1, vous pouvez choisir la façon dont vous souhaitez réécrire vos données de flux sur votre table. Vous pouvez choisir parmi deux options : Créer une table ou Ajouter une table. Par défaut, Tableau Prep Builder utilise l’option Créer une table et remplace vos données de table par de nouvelles données lorsque vous exécutez votre flux. Si vous choisissez Ajouter une table, Tableau Prep Builder ajoute les données de flux à la table existante afin que vous puissiez suivre à la fois les données nouvelles et les données historiques sur chaque exécution de flux. Pour plus d'informations, consultez Configurer les options d’écriture.

    6. Dans le volet Sortie, cliquez sur Exécuter le flux ou cliquez sur le bouton Exécuter le flux dans le volet Flux pour générer votre sortie.
    7. Une fois que le flux a fini de s'exécuter, une boîte de dialogue d'état montre si le flux s'est correctement exécuté et indique la durée de l'exécution. Cliquez sur Terminé pour fermer la boîte de dialogue.

      Pour garder vos données à jour, vous pouvez exécuter le flux manuellement dans Tableau Prep Builder ou utiliser la ligne de commande. Si vous disposez du module Data Management Add-on et que Tableau Prep Conductor est activé, vous pouvez également publier le flux sur Tableau Server ou Tableau Online et exécuter votre flux de manière programmée.

      Depuis la version 2020.2.1, vous pouvez également choisir d’actualiser toutes vos données à chaque fois que le flux est exécuté, ou d’exécuter votre flux en utilisant l’actualisation incrémentielle et de traiter uniquement vos nouvelles données à chaque fois.

      Pour savoir comment garder vos données à jour, consultez les rubriques suivantes :

    Finalisation et ressources

    Vous êtes un champion de la préparation de données ! Vous avez pris des données désordonnées et vous les avez réorganisées haut la main. En un temps record, vous avez nettoyé et préparé vos données à partir de plusieurs ensembles de données et vous les avez transformées en un ensemble de données léger et propre avec lequel vous pouvez maintenant travailler dans Tableau Desktop pour faire votre analyse.

    Vous souhaitez continuer à vous exercer ? Essayez de répliquer le reste de l'exemple de flux Superstore en utilisant les fichiers de données disponibles à cette adresse :

    Vous pouvez également trouver les fichiers à l'emplacement suivant sur votre ordinateur après avoir installé Tableau Prep Builder :

    • (Windows) C:\Program Files\Tableau\Tableau Prep Builder <version>\help\Samples\en_US\Superstore Files
    • (Mac) /Applications/Tableau Prep Builder <version>.app/Contents/help/Samples/en_US/Superstore Files

    Vous voulez approfondir votre formation ? Visionnez les vidéos de formation(Link opens in a new window) de Tableau Prep Builder, consultez ces ressources(Link opens in a new window) précieuses ou suivez un cours de formation en présentiel(Link opens in a new window).

    Vous souhaitez plus d'informations sur les rubriques traitées ici ? Consultez les autres rubriques dans le système d'aide en ligne de Tableau Prep Builder.

    Autres articles de cette section

    Merci de vos commentaires ! Erreur lors de la soumission de votre commentaire. Réessayez ou envoyez-nous un message.