儲存您的工作

在 Tableau 中分析資料或與資料進行交互時,您可以隨時儲存您的工作。

適用於 Tableau Desktop

在 Tableau Desktop 中,可使用以下幾種方法來儲存您的工作:

  • 自動儲存工作簿 - 自動將工作簿儲存在與原始檔案相同的位置。如果發生當機,即可使用復原的版本。

  • 儲存工作簿 - 儲存所有開啟的工作表。
  • 儲存已封裝工作簿 - 將工作簿連同所有引用的本機檔案資料來源和影像儲存在單個檔案內。

  • 儲存書籤 - 儲存當前工作表。

您可與同事共用工作簿和書籤,前提是他們能夠存取工作簿使用的相關資料來源。如果您的同事無法存取資料來源,則您可以儲存已封裝工作簿。

自訂欄位(例如,分級度量、計算欄位、群組和集)與工作簿和書籤一起儲存。

自動儲存工作簿

Tableau Desktop 每隔幾分鐘即會為您自動儲存工作,不會再出現因 Tableau 意外關閉而遺失數小時工作的情況。此功能預設為啟用,但您可以透過 [說明] > [設定和效能] > [啟用自動儲存] 下的工具列將其關閉。

附註:若未看到此選項,表示您的系統管理員可能已停用此功能。

如果 Tableau 當機,系統將自動建立工作簿的復原版本,其副檔案名為 .twbr,並儲存在原始檔案所在的相同位置,或儲存在 [我的 Tableau 存放庫] 資料夾中。新工作簿在儲存時將命名為 [Book1] 加一個數字 ID。重新開啟 Tableau 時,復原對話方塊將顯示一個已復原檔案的清單,您可以選取並開啟這些檔以繼續執行流程。

您也可以從同一個對話方塊中刪除不需要的檔案。

有關如何在安裝期間開啟或關閉此功能的詳情,請參閱 tableau Desktop 部署指南中的安裝之前(Link opens in a new window)

儲存工作簿

開啟 Tableau Desktop 時,它會自動建立一個新工作簿。工作簿儲存您建立的工作,由一個或多個工作表群組成。每個工作表都包含一個特定資料檢視。

儲存 Tableau 工作簿:

  1. 選取 [檔案] > [儲存]

  2. [另存新檔] 對話方塊中,指定工作簿的檔案名。

預設情況下,Tableau 使用 .twb 副檔案名來儲存。預設情況下,Tableau 將工作簿儲存在 [我的 Tableau 存放庫] 的 [Workbooks] 資料夾中。您可以在 [文件] 資料夾中找到此存放庫。不過,您可以選取將 Tableau 工作簿儲存到任何目錄。

Tableau 檔案名不得包含以下任何字元:正斜杠 (/)、反斜線 (\)、大於號 (>)、小於號 (<)、星號 (*)、問號 (?)、雙引號 (")、分隔號符號 (|)、冒號 (:) 或分號 (;)。

若要儲存開啟的工作簿的副本:

  • 選取 [檔案] > [另存新檔] ,並使用新名稱儲封存。

儲存已封裝工作簿

已封裝工作簿包含工作簿以及所有本機檔案資料來源和背景影像的副本。該工作簿不再連結到原始資料來源和影像。將以 .twbx 檔案副檔案名來儲存這些工作簿。其他使用者可以使用 Tableau Desktop 或 Tableau Reader 開啟已封裝工作簿,不需要存取工作簿所包含的資料來源。

若要瞭解有關如何將工作簿另存新檔為已封裝工作簿的更多資訊,請參閱已封裝工作簿(Link opens in a new window)

儲存書籤

可以將單個工作表儲存為 Tableau 書籤。儲存書籤時,Tableau 將建立工作表的快照。使用 [書籤] 功能表可以從任何工作簿存取書籤。開啟已加入書籤的工作表時,會將工作表以最初加入書籤時的狀態新增到工作簿。它決不會自動更新或變更。如果您有經常使用的工作表,則使用書籤會非常方便。

儲存 Tableau 書籤:

  1. 選取 [視窗] > [書籤] > [建立書籤]

  2. 在 [建立書籤] 對話方塊中,指定書籤檔案名和位置。

Tableau 使用 .tbm 副檔案名來儲封存。預設位置為 Tableau 存放庫的 [Bookmarks] 資料夾。不過,您可以選取任何位置儲存書籤。未存儲在 Tableau 存放庫中的書籤不會顯示在 [書籤] 功能表中。

將書籤組織到資料夾中的方法與組織檔案或文件的方法相同。這在您有大量需要管理的書籤時十分有用。例如,您可以基於員工姓名、產品類型或銷售結果來組織書籤。透過新建資料夾、重新命名現有資料夾、重新命名現有書籤檔案等,可以組織書籤。

刪除書籤的方法與刪除電腦上其他任何檔案的方法相同。從 Tableau 存放庫中的 [Bookmarks] 資料夾刪除書籤後,下次啟動 Tableau 時,會將該書籤從 [書籤] 功能表移除。

附註: 書籤通常是工作表的快照,包括資料連線、格式設定等;書籤不包括參數值以及 [頁面] 架上的當前頁面設定。

用於 Web 製作

在 Tableau Server 或 Tableau Online 上建立、編輯檢視以及與檢視進行交互時,有幾種不同的方法可用於儲存您的工作:

  • 儲存工作簿 - 將工作簿儲存在您指定的專案中。

  • 儲存工作簿的副本 - 將工作簿的副本儲存在您指定的專案中。

  • 將變更另存新檔為自訂檢視 - 將變更另存新檔為自訂檢視,此自訂檢視與原始檢視相關並且會在原始檢視更新時進行更新。

儲存工作簿

當您在 Tableau Server 或 Tableau Online 上建立新的工作簿或編輯現有工作簿時,您可以隨時儲存工作。

若要儲存工作簿:

  • 在 Web 編輯模式下,選取 [檔案] > [儲存]

    附註: 如果從未儲存過工作簿,則必須選取 [檔案] > [另存新檔]

儲存現有工作簿的副本

有時,您不想用您的變更來覆蓋現有檢視。在這種情況下,您可以儲存現有工作簿的副本。執行此操作時,現有工作簿保持不變,並且會建立一個副本,供您根據需要進行編輯。

附註:如果儲存現有工作簿的副本,則在更新或重新發佈原始工作簿時不會更新此副本。刪除原始檢視時也不會刪除它。如果您想建立一個隨原始檢視一起更新的檢視,請參閱將變更另存新檔為自訂檢視部分。

若要儲存工作簿副本:

  1. 在 Web 編輯模式下,選取 [檔案] > [另存新檔]

  2. 在開啟的 [儲存工作簿] 對話方塊中,執行以下操作:

    1. 對於 [名稱] : 輸入工作簿的名稱。

    2. 對於 [專案] : 選取要在其中儲存工作簿的專案。

    3. (可選)選取 [將工作表顯示為標籤] ,以將工作簿中的所有工作表、儀表板和故事顯示為單獨的標籤。

    4. 按一下 [儲存]

    附註:將資料來源發佈到 Tableau Server 或 Tableau Online 的人員可能還設定了認證,此認證用於存取即將儲存的工作簿中所包含的已發佈資料來源。這些驗證選項應顯示在 [儲存工作簿] 對話方塊中。有關詳情,請參閱 [設定認證以存取您發佈的資料] (Link opens in a new window)主題中的驗證類型。

將變更另存新檔為自訂檢視

如果您發現每次開啟檢視時都對檢視進行相同的變更,則可能需要考慮將變更另存新檔為自訂檢視。此選項在 Web 編輯模式下不可用,但在開啟檢視與其進行交互時可以存取。

自訂檢視不會變更原始檢視,但與它相關。如果原始檢視更新或重新發佈,則自訂檢視也將更新。

您還可以選取您的自訂檢視是對其他使用者可見(公共),還是僅對您可見(私有)。

有關自訂檢視及其建立方法的詳情,請參閱使用自訂檢視(Link opens in a new window)

另請參閱

使用自訂檢視(Link opens in a new window)

此區段的其他文章

感謝您的意見回饋! 提交意見回饋時發生錯誤。重試或傳送訊息給我們