Tableau 工作区

Tableau 工作区包含菜单、工具栏、“数据”窗格、卡和功能区以及一个或多个工作表。表可以是工作表、仪表板或故事。有关仪表板或故事工作区的详细信息,请参见创建仪表板故事工作区

观看视频:若要查看 Tableau 中演示的相关概念,请观看时长 4 分钟的入门(链接在新窗口中打开)免费培训视频中的 Tableau 界面(链接在新窗口中打开)。使用 tableau.com(链接在新窗口中打开) 帐户登录。

如果在 Web 上使用 Tableau。请参见Creator:Web 制作入门指南浏览 Tableau 站点

工作区区域

A. 工作簿名称。工作簿包含工作表,后者可以是工作表、仪表板或故事。有关详细信息,请参见工作簿和工作表

B. 卡和功能区 - 将字段拖到工作区中的卡和功能区,以将数据添加到您的视图中。

C. 工具栏 - 使用工具栏访问命令以及分析和导航工具。

D. 视图 - 此区域为工作区中的画布,您可以在其中创建可视化项。

E. 单击此图标转到“开始”页面,您可以在其中连接到数据。有关详细信息,请参见开始页面

F. 侧栏 - 在工作表中,侧栏区域包含“数据”窗格“分析”窗格

G. 单击此选项卡可转到“数据源”页面并查看数据。有关详细信息,请参见“数据源”页面

H. 状态栏 - 显示有关当前视图的信息。

I. 工作表标签 - 标签表示工作簿中的每个工作表。这可能包括工作表、仪表板和故事。有关详细信息,请参见工作簿和工作表

返回顶部


Tableau 工具栏按钮参考

创建或编辑视图时,可以使用视图顶部的工具栏执行常见操作。

在 Tableau Desktop 中,您可以通过选择“窗口”>“显示工具栏”来隐藏或显示 Tableau 工具栏。

下表说明了每个工具栏按钮的功能。某些按钮并非在所有 Tableau 产品中都有。另请参见Tableau Desktop 中的视觉提示和图标

工具栏按钮 说明

Tableau 图标:导航到开始页面。有关详细信息,请参见开始页面

注意:仅限 Tableau Desktop。

撤消:反转工作簿中的最新操作。您可以无限次撤消,返回到您上次打开工作簿时,即使是在保存之后也是如此。有关详细信息,请参见撤消和重做

重做:重复通过“撤消”按钮撤消的上一次操作。您可以重做无限次。

保存:在 Tableau Desktop 中,保存对工作簿所做的更改。有关详细信息,请参见保存您的工作

在 Tableau Server 或 Tableau Online 中,单击“文件”>“保存”“文件”>“另存为”以保存所做的更改。

新建数据源:在 Tableau Desktop 中,打开“连接”窗格,您可以在其中创建新连接或打开已保存的连接。有关详细信息,请参见连接到数据

在 Tableau Server 或 Tableau Online 中,打开“连接到数据源”页面,您可以在其中连接到已发布的数据源。有关详细信息,请参见在进行 Web 制作时连接到发布的数据源

暂停自动更新:控制进行更改时 Tableau 是否更新视图。使用下拉菜单自动更新整个工作表,或只使用筛选器。有关详细信息,请参见刷新数据或暂停自动更新

运行更新:运行手动数据查询,以便在关闭自动更新后用所做的更改对视图进行更新。使用下拉菜单更新整个工作表,或只使用筛选器。

注意:仅限 Tableau Desktop。

新建工作表:创建新的空白工作表,使用下拉菜单创建新的工作表、仪表板或故事。

有关详细信息,请参见创建新工作表、仪表板或故事

复制:创建一个包含当前工作表中所包含的相同视图的新工作表。有关详细信息,请参见复制工作表

清除:清除当前工作表。使用下拉菜单清除视图的特定部分,如筛选器、格式设置、大小调整和轴范围。

交换:交换“行”功能区和“列”功能区上的字段。始终使用此按钮来交换“隐藏空行”“隐藏空列”设置。
升序排序:根据视图中的度量,以所选字段的升序来应用排序。有关详细信息,请参见在可视化项中对数据进行排序(链接在新窗口中打开)
降序排序:根据视图中的度量,以所选字段的降序来应用排序。有关详细信息,请参见在可视化项中对数据进行排序(链接在新窗口中打开)
合计:您可以计算视图中数据的总计和小计。从以下选项中选择:
  • 显示列总计:添加一行,显示视图中所有列的合计。

  • 显示行总计:添加一列,显示视图中所有行的合计。

  • 行合计移至左侧:将显示合计的行移至交叉表或视图的左侧。

  • 列合计移至顶部:将显示合计的列移至交叉表或视图的顶部。

  • 添加所有小计:如果在一列或一行中有多个维度,则在视图中插入小计行和列。

  • 移除所有小计:移除小计行或列。

注意:仅限 Tableau Server 和 Tableau Online。在 Tableau Desktop 中,单击“分析”>“总计”。有关详细信息,请参见在可视化项中显示合计

突出显示:启用所选工作表的突出显示。使用下拉菜单上的选项定义突出显示值的方式。有关详细信息,请参见突出显示工具栏按钮

组成员:通过合并所选值来创建组。选择多个维度时,使用下拉菜单指定是对特定维度进行分组,还是对所有维度进行分组。有关详细信息,请参见通过将数据分组来纠正数据错误或合并维度成员

注意:仅限 Tableau Desktop。在 Tableau Server 和 Tableau Online 中,使用工具提示上的“组成员”按钮来创建组。

显示标记标签:在显示和隐藏当前工作表的标记标签之间切换。有关详细信息,请参见显示、隐藏标记标签以及设置标记标签的格式

固定轴 - 在仅显示特定范围的锁定轴以及基于视图中的最小值和最大值调整范围的动态轴之间切换。有关详细信息,请参见编辑轴

注意:仅限 Tableau Desktop。

设置工作簿格式:打开“设置工作簿格式”窗格,通过在工作簿级别而不是在工作表级别指定格式设置,在工作簿内的每个视图中更改字体和标题的外观。

注意:仅限 Tableau Server 和 Tableau Online。在 Tableau Desktop 中,单击“设置格式”>“工作簿”。有关详细信息,请参见在工作簿级别设置格式

适合:指定如何在窗口内调整视图大小。选择“标准适合”、“适合宽度”、“适合高度”或“整个视图”。注意:此菜单在地理地图视图中不可用。

根据可视化项的类型,“单元格大小”命令具有不同效果。若要访问 Tableau Desktop 中的“单元格大小”菜单,请单击“设置格式”>“单元格大小”

显示/隐藏卡:在工作表中显示和隐藏特定卡。在下拉菜单上选择要隐藏或显示的每个卡。

在 Tableau Server 和 Tableau Online 中,您只能显示和隐藏“标题”“说明”“筛选器”“荧光笔”卡。

演示模式:在显示和隐藏视图(即功能区、工具栏、“数据”窗格)之外的所有内容之间切换。有关详细信息,请参见重新组织工作区

注意:仅限 Tableau Desktop。

下载:使用“下载”下面的选项捕获视图的某些部分以在其他应用程序中使用。
  • 图像:在新的浏览器标签中将视图、仪表板或故事显示为图像。
  • 数据:在新浏览器窗口中使用两个标签显示视图中的数据:摘要(显示视图中所显示的字段的聚合数据)和基础(显示可视化项中所选标记的基础数据)。如果新窗口未打开,则您可能需要禁用浏览器的弹出窗口阻止程序。
  • 交叉表:将可视化项中所选标记的基础数据保存为 CSV(逗号分隔值)文件,然后可在 Microsoft Excel 中打开该文件。
  • PDF:在新的浏览器窗口中将当前视图作为 PDF 打开。从该窗口中,您可以将视图保存为文件。如果新窗口未打开,则您可能需要禁用浏览器的弹出窗口阻止程序。

注意:仅限 Tableau Server 和 Tableau Online。

与其他人共享工作簿:将工作簿发布到 Tableau Server 或 Tableau Online。有关详细信息,请参见用于发布工作簿的简单步骤

注意:仅限 Tableau Desktop。

智能显示: 通过突出显示最适合数据中的字段类型的视图类型来帮助您选择视图类型。最适合您的数据的建议图表类型周围会显示一个橙色轮廓。有关详细信息,请参见使用“智能显示”启动视图

返回顶部


显示和隐藏侧栏(“数据”窗格)

在编辑工作表时,侧栏包含“数据”窗格和“分析”窗格。根据要在视图中进行的操作,您可能会看到不同的窗格(“数据”、“分析”、“故事”、“仪表板”、“布局”、“格式”)。关于侧栏最重要的一点是您可以在工作区中展开和折叠此区域。

要在 Tableau Desktop 中隐藏侧栏,请单击侧栏中的折叠箭头。

要在 Web 上隐藏侧栏,请单击侧栏中的折叠箭头。

要在 Tableau Desktop 中显示侧栏,请单击工作区左下方中的展开箭头(在状态栏中)。

要在 Web 上显示侧栏,请单击侧栏中的展开箭头。

返回顶部


状态栏信息

状态栏位于 Tableau 工作区的底部。它显示菜单项说明以及有关当前视图的信息。例如,下面的状态栏显示该视图拥有 143 个标记,在 3 行和 12 列中显示。它还显示视图中所有标记的 SUM(Sales) 为 $2,297,201。

可以通过选择“窗口”>“显示状态栏”来隐藏状态栏。

有时,Tableau 会在状态栏的右下角显示警告图标,以指示错误或警告。下面是可能的警告图标及其含义。

警告图标 说明

取消查询指示符:在取消多个查询时,会出现一个指示器,显示有多少查询仍在数据库上运行并在使用资源。

在 Tableau 中取消某一查询时,将会通知数据库停止处理该查询。不过,某些数据库并不支持取消(MS Excel、MS Access、Essbase、Microsoft Analysis Services 2000)。如果您取消使用这些数据源类型之一的查询,则 Tableau 会放弃该查询,但该查询仍将在后台运行并使用资源。当您放弃查询时,工作簿的右下角会显示一个指示符,显示仍在运行的查询数 描绘状态栏中显示的取消查询指示符的图形。。随着后台中查询的完成,该数字将减小。监视正在运行的查询的数目并控制该数字不会过高十分重要,否则,您会发现 Tableau 和基础数据库的性能将会下降。

注意:取消查询后,文本、Microsoft Excel 和 Microsoft Access 数据源可能会暂时不可用,因为在内部执行了锁定。您可能必须一直等到放弃的查询完成才能重新连接。

精度警告:某些字段在数据库中的精度超过 Tableau 可以建模的精度。将字段添加到包含比 Tableau 可以建模的精度更高的精度值的视图时,状态栏右下角会显示一个警告图标 描绘状态栏中显示的精度警告的图形。

例如,数据库中的某个值可能有 22 个小数位,但 Tableau 仅支持最多 15 个小数位。将该字段添加到视图中时,将会看到精度警告。如果您单击该警告,则可看到更多详细信息,包括视图中截断的小数位数。

请记住,Tableau 中显示的数据的精度始终首先取决于数据库中的数据。如果数据库中的值超出 15 个小数位,则将它们添加到视图中时,值将被截断,并且显示精度警告。

注意:关系数据库的数据提取总是使用 Hyper 双精度类型,从不使用 Hyper 数字类型。因此,如果您创建关系数据库的数据提取,则只能获得 15 位精度。您可以写入 Hyper API 并使用数字类型获得最多 18 位精度。如需了解相关信息,请参见 Hyper API 文档中的数字类型(链接在新窗口中打开)

特殊值指示符:如果您的数据包含空值、未知地理位置或对数轴上包含负值或零值,这些值将通过一个指示器显示在视图的右下角。单击该指示器可查看有关如何处理这些值的选项。若要了解有关此指示器以及如何处理这些值的详细信息,请参见处理 Null 值和其他特殊值

返回顶部


此部分中的其他文章

感谢您的反馈!