使用 Tableau Server 或 Tableau Online 连接到数据

您可以使用 Tableau Server 或 Tableau Online 通过 Tableau Desktop 或 Web 浏览器连接到数据。各个过程略有不同。

从 2019.3 开始,Tableau Server 和 Tableau Online 的数据管理加载项中提供了 Tableau Catalog。在环境中启用了 Tableau Catalog 后,除了通过 Tableau Server 或 Tableau Online 连接到发布的数据源外,您还可以通过 Tableau Desktop 上的“搜索数据”结果连接到数据库和表。有关 Tableau Catalog 的详细信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

并且,从版本 2019.3.1 开始,Tableau Prep Builder 可以连接到已发布的数据源,并使用它们作为流程的输入数据源。如果有启用了Tableau Catalog数据管理加载项,还可以从“搜索数据”结果中连接到数据库和表,就像 Tableau Desktop 一样。有关详细信息,请参见 Tableau Prep Builder 帮助中的连接到发布的数据源(Link opens in a new window)

通过 Tableau Desktop 连接

注意:从 2019.3 开始,“连接”窗格上的“Tableau Server”已移到窗格顶部的“搜索数据”下。选择此选项可从 Tableau Desktop 连接到 Tableau Server 或 Tableau Online。

  1. 启动 Tableau Desktop,并在“连接”窗格上的“搜索数据”下选择“Tableau Server”
  2. 若要连接到 Tableau Server,请输入服务器的名称,然后选择“连接”

    若要连接到 Tableau Online,请在“快速连接”下选择“Tableau Online”

    Tableau Server Sign In dialog box

    提示:如果您未注销,Tableau Desktop 将保存您的服务器连接,因此可以跳过步骤 3。如果在 Tableau Server 上启用了 Kerberos,并且您的计算机具有有效的凭据,您也可以跳过该步骤。有关详细信息,请参见使 Tableau Desktop 自动保持连接到 Tableau Server 或 Online

  3. 若要登录:
    • 对于 Tableau Server,输入您的用户名和密码。
    • 对于 Tableau Online,输入您的电子邮件地址和密码。
  4. 从已发布数据源列表中选择一个数据源。(您没有“连接”权限的数据显示为灰色。)

    注意:如果选择多维数据集(多维)数据源,则“创建本地副本”对话框将出现,您必须创建数据的本地副本,然后才能开始分析。

    Search for Data page

    使用“搜索”框来搜索数据。或者,您可以通过选择列标题对列表进行排序。当您将鼠标光标悬停在标题上时,支持排序的列标题带有下划线。您还可以选择筛选器图标以按“连接类型”和“已认证”筛选数据。

    Filter options

    启用 Tableau Catalog 后,

    • 您可以从“数据源”“数据库和文件”“表”中进行选择来搜索数据。
    • Content Type drop-down menu

    • 您可以按“数据质量警告:所有资产”、“未包含警告的资产”和“包含警告的资产”来筛选资产。
      Data quality warning drop-down menu
    • 您可以筛选经过认证的资产。
      Certified check box

    注意:“搜索数据”结果中,您可以使用 Tableau Desktop 支持的一部分数据连接器进行连接。如果数据源、数据库、文件或表呈灰色显示,则无法从 Tableau Server 或 Tableau Online 中连接。不过,如果有正确的权限,您可以通过 Tableau Desktop 的“连接”窗格进行连接。

  5. 选择要连接的数据后,单击“连接”
  6. 选择工作表标签以开始分析。

发布到 Tableau Server 或 Tableau Online 的数据源在“数据”窗格中以 Tableau 图标显示。

Example of Tableau icon

举例来说,您可能想要下载数据源的本地副本以便能够脱机工作,或在不修改原稿的情况下对数据源进行更改。若下载本地副本,请在“数据”菜单中选择数据源,然后选择“创建本地副本”。数据源的一个副本将添加至“数据”窗格。

登录到 Mac

如果在 Mac 上使用 Tableau Desktop,则在输入服务器名称进行连接时,请使用完全限定的域名(例如 mydb.test.ourdomain.lan)而不是相对域名(例如 mydb 或 mydb.test)。

或者,可以将域添加到 Mac 计算机的“搜索域”的列表中,以便在您连接时,只需要提供服务器名称。若要更新“搜索域”的列表,请转到“系统首选项”>“网络”>“高级”,然后打开“DNS”选项卡。

在进行 Web 制作时连接到发布的数据源

创建和自定义数据连接供 Tableau 使用的 Tableau Desktop 用户可以将自己的数据源发布到 Tableau Server 或 Tableau Online。通过发布可以在同事之间共享数据;包括在那些不使用 Tableau Desktop 但有权在 Web 编辑环境中编辑工作簿的同事之间共享。

如果您有权在浏览器中编辑工作簿,请按照以下步骤在登录到 Tableau Server 或 Tableau Online 时连接到发布的数据源。有关详细信息,请参见在 Web 上编辑 Tableau 视图在 Web 上使用 Tableau

注意:若要连接到数据,您需要创建和编辑视图的权限。

向现有视图添加更多数据

  1. 在 Tableau Server 或 Tableau Online 站点上,选择一个要编辑的视图。
  2. 在编辑模式下,单击“新建数据源”图标
  3. “连接到数据”页面中,您可以看到和选择的选项取决于您的权限:
    • 此站点上。从列表中选择一个已发布数据源,然后选择“添加数据源”

      如果在环境中启用了 Tableau Catalog,您可以从“内容类型”下拉列表中选择“数据源”“数据库和文件”“表”。然后选择要连接到的数据,并单击“连接”

    • 文件。拖放文件或从计算机上载一个文件。
    • 连接器。使用列出的连接器之一连接到数据。

创建包含已发布数据源的工作簿

您也可以在创建新工作簿时连接到发布的数据源:

  1. 在 Tableau Server 或 Tableau Online 站点上,导航到“浏览”页面,并从下拉列表中选择“所有数据源”
  2. 在列表中,选中要使用的数据旁边的复选框。
  3. 在页面顶部,从“操作”下拉菜单中选择“新建工作簿”

有关在 Web 上制作时连接到数据的详细信息,请参见 Creator:连接到 Web 上的数据

感谢您的反馈! 提交反馈时出错。请重试,或向我们发送消息