您可以在 Web 上使用 Tableau 執行很多操作。作為 Creator,您可以直接連線到資料來增強您的分析、建立絕妙的資料視覺效果,以及與其他人共用見解。在本指南中,我們將討論 Tableau Online 環境、連線到資料並準備要分析的資料、建立工作簿以及與其他人共用見解。

不確定自己的使用者層級是哪種?若要進行檢查,請選取網站右上角帶有您的姓名首字母縮寫或個人資料影像的圖示,並選取「我的帳戶設定」。網站角色指明您是 CreatorExplorer 還是 Viewer

步驟 1:登入及探索專案

若要開始使用,請輸入您的使用者名稱和密碼,以登入您的 Tableau 網站。然後,在巡覽窗格中按一下「探索」,以查看您在整個網站中可存取的所有內容。

一開始,您會看到頂層專案。您可以瀏覽這些專案或選取其他內容類型。

內容類型選取

工作簿、資料來源、資料角色和流程可以儲存到名為「專案」的位置。專案還可以包含巢狀專案。與桌面的資料夾很像,可以透過專案對網站中的內容進行排序和管理。如果您曾經被邀請存取過某個現有網站,您可能會看到您的隊友建立的項目。

除了專案之外,還可以將工作簿私下儲存到名為「個人空間」的位置。可以使用個人空間來建立或瀏覽工作簿,並在您準備好與他人共用時將它們移動到專案中。有關更多資訊,請參閱在個人空間中建立和編輯私人內容

若其他專案對您不可用,則個人空間和預設專案都可供您用於探索。

從 2019.3 版開始,Tableau Server 和 Tableau Online 的資料管理附加元件提供 Tableau Catalog。當您的環境中已啟用 Tableau Catalog 時,除了巡覽及連線至「探索」的資料,您還可以巡覽並連線至「外部資產」中更多類型的資料,例如,資料庫和資料表。有關 Tableau Catalog 的詳細資訊,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

步驟 2:建立新工作簿並連線到資料

在某種程度上,您將需要連線到資料,以便對其進行分析並組建工作簿。作為 Creator,Tableau 允許您直接連線到 Web 上的資料來源,或者可以連線到透過 Tableau Desktop 發佈到 Tableau Online 的資料來源

若要開始,請按一下「新增」按鈕並選取「工作簿」

「建立工作簿」按鈕

連線到資料」視窗將出現。

連線至「資料」視窗

您可以透過若干方式連線到可增強您的工作簿的資料:

  • 「此網站上」索引標籤連線到發行資料來源。

    啟用具有 Tableau Catalog 的資料管理附加元件之後,您可以使用「此網站上」連線至資料庫和資料表,以及資料來源。

  • 「檔案」索引標籤上傳 Excel 或以文字為基礎的資料來源。
  • 「連接器」索引標籤連線到伺服器或雲端資料來源。

  • 在 Tableau Online 上,透過「Dashboard Starters」索引標籤快速製作並對來自 LinkedIn Sales Navigator、Oracle Eloqua、Salesforce、ServiceNow ITSM 和 Marketo 的資料進行分析。

若要瞭解有關連線到 Web 上的資料的詳情,請參閱 Creator:連線到 Web 上的資料

Tableau Catalog 使用者從外部資產建立工作簿

啟用具有 Tableau Catalog 的資料管理附加元件之後,您可以在「外部資產」頁面上建立目錄支援的連線時,建立新工作簿:

「外部資產」索引標籤上的「新增工作簿」按鈕

從資料庫和資料表頁面:

資料庫和資料表頁面上的「新增工作簿」按鈕

如果目錄不支援連線,則不會顯示新工作簿

步驟 3:準備資料

連線到資料之後,使用資料來源頁面來準備要分析的資料。

資料來源頁面的各個部分

資料來源頁面

資料來源頁面有四個部分: 

  1. 左側窗格:顯示有關資料的詳情。對於以檔案為基礎的資料,左側窗格可能顯示檔案名和檔案中的工作表。對於關係資料,左側窗格可能會顯示伺服器、資料庫或架構以及資料庫中的表。

  2. 畫布:連線到多數關係資料和基於檔案的資料時,您可以將一個或多個表拖到畫布區域來設定要分析的 Tableau 資料來源。

  3. 資料網格:您可以使用資料網格檢視欄位以及 Tableau 資料來源中所包含的前 1,000 列資料。

  4. 中繼資料網格:按一下按鈕將轉到中繼資料網格,該網路將資料來源中的欄位顯示為列,以便您能夠檢視其結構。

可透過以下方式在資料來源頁面中準備要分析的資料: 

  • 重命名資料來源

  • 使用 Data Interpreter 清理資料

  • 設定文字檔案選項

  • 建立資料的關聯

  • 編輯列

若要瞭解有關在 Web 上準備要分析的資料的詳情,請參閱 Creator:在 Web 上準備資料

資料準備就緒可進行分析後,按一下螢幕底部的「工作表 1」轉到 Tableau 工作區以組建檢視。

步驟 4:製作檢視

您已連線到資料,並設定了要分析的資料,現在即可建立資料的可視分析。Tableau 將此稱為檢視。如果之前使用過 Tableau Desktop,工作區區域非常相似。

工作區區域

這是 Tableau 工作區的佈局:

  1. 工作簿名稱。工作簿包含工作表,後者可以是工作表、儀表板窗格或本文。有關詳情,請參閱工作簿和工作表

  2. 「頁面」架、「篩選條件」架、「標記」卡片 - 將欄位拖到工作區中的卡片和架,以將資料新增到您的檢視中。有關詳情,請參閱架和卡

  3. 「欄」和「列」架 - 將欄位拖到工作區中的卡和架,以將資料新增到您的檢視中。有關詳情,請參閱架和卡

  4. 工具列 - 使用工具列存取命令以及分析和巡覽工具。請參閱 Tableau 工具列按鈕參考

  5. 檢視 - 這是您在其中建立資料視覺效果的工作區。

  6. 側欄 - 在工作表中,側欄區域包含「資料」窗格和「分析」窗格。

  7. 轉到資料來源頁面。有關詳情,請參閱 Creator:在 Web 上準備資料

  8. 工作表索引標籤 - 標籤表示工作簿中的每個工作表。這可能包括工作表、儀表板窗格和故事。

從 Tableau 2020.2 版開始:在「資料」窗格的每個表格或資料夾中,灰色線會分隔維度(上方)和度量(下方)。「資料」窗格將不再使用「維度」「度量」標籤。

開始組建檢視的不同方式

每次將欄位拖到檢視中或架上時,都會提出一個有關該資料的問題。問題將因您將各個欄位拖到何處、欄位的類型以及將欄位拖到檢視中所採用的順序而異。

對於您提出的每個問題,檢視將發生變化,使用標記(圖形、文字、階層、表結構、軸、色彩)以直觀方式呈現答案。

在工作表中,資料來源中的列顯示為「資料」窗格中左側的欄位。「資料」窗格包含各種不同按表格組織的欄位。

在組建檢視時,您透過「資料」窗格新增欄位。可透過不同方式來達到此目的。例如:

  • 將欄位從「資料」窗格拖放到屬於每個 Tableau 工作表的卡和架上。

  • 以在「資料」窗格中按兩下一個或多個欄位。

  • 「資料」窗格中選取一個或多個欄位,然後從「智慧顯示」中選取一種圖表類型,後者可確定適合於您所選的欄位的圖表類型。有關詳細資訊,請參閱顯示

篩選資料

您可能需要篩選資料以便只在檢視中顯示一定數量的資料。可透過多種方式來篩選資料,其中包括:

當您向「篩選條件」架新增欄位時,檢視中將出現一個互動式篩選條件。然後,您可以選取要在檢視中包括或排除的項。

  • 若要在 Web 上透過 Tableau 建立篩選條件,請將維度、量值或日期欄位拖到「篩選條件」架。

    當您向「篩選條件」架新增欄位時,檢視中將出現一個互動式篩選條件。您可以選取要在檢視中包括或排隊的項,或者選取一個值範圍。

  • 您也可以透過選取單一標記(資料點)與發佈的檢視交互,或者在檢視中按一下並拖動以選取若干標記。在出現的工具提示上,您可以選取「僅保留」以僅在檢視中保留所選標記,或者選取「排除」以從檢視中移除所選標記。

關於在Tableau 中的篩選更多詳情,包括 Tableau 的操作順序,請參閱篩選檢視中的資料

使用「標記」卡片

您可以使用「標記」卡片將上下文和詳情新增至檢視中的標記。使用「標記」卡片設定標記類型,並使用色彩、大小、圖形、文字和詳情對資料進行編碼。

將欄位新增到「標記」卡片後,可以按一下該欄位旁的圖示以變更它所使用的屬性。您還可以按一下「標記」卡片中的屬性按鈕來變更這些設定。

很多屬性都可以有多個欄位。例如,您可以向「標籤」、「詳情」、「工具提示」和「色彩」新增多個欄位。「大小」和「圖形」一次只能有一個欄位。有關更多信息,請參閱標記屬性參考

復原您的工作

Tableau 非常靈活,也極為寬容。在組建檢視時,如果採用了未回答您的問題的路徑,您始終可以復原至探究過程中的上一個點。

  • 若要復原或重做,請按一下工具列上的「復原」或「重做」

您可以一直復原至上次開啟工作簿的時間。您可以復原或重做無限次。

在 Web 上組建和編輯檢視

可透過多種方式在 Tableau 中探索資料。有關在 Web 上組建特定圖表類型的說明,請參閱在 Web 上編輯 Tableau 檢視,或者,若要瞭解可幫助您在 Tableau 中組建視覺效果的更多功能,請參閱組建和瀏覽資料檢視

有關組建資料檢視的 6 分鐘演練視訊,請觀看視覺分析入門(連結在新視窗開啟)免費訓練視訊。使用 tableau.com 帳戶登入。

步驟 5:展示您的工作

可透過多種方式,用您在檢視中找到的資料見解來講述本文或說服他人。

設定工作內容的格式

您可以為在工作簿上看到的幾乎任何內容(包括檢視的各個部分、工作簿的字型和圖形線條)設定格式。

儀表板

儀表板窗格是顯示在單一位置的多個工作表和支援資訊的集合,它便於您同時比較和監視不同資料。

若要開啟新儀表板窗格工作表並開始建立儀表板窗格,請按一下工作簿底部的「新建儀表板窗格」圖示:

「儀表板窗格」區域會出現在左側,並且會列出您的工作簿中的工作表。您可以向儀表板窗格中新增一個或多個檢視、新增像網頁、空白空間和佈局容器這樣的物件,或者新增交互性以關聯工作表上的不同檢視。

故事

本文是一個包含一系列共同作用以傳達資訊的工作表和儀表板窗格的工作表。您可以使用故事揭示各種事實之間的關係以及決策與結果的關係,從而使用資料建立一個極具吸引力的案例。

建立本文詳細瞭解本文

步驟 6:儲存您的工作

您可以隨時透過選取「檔案」>「另存新檔為」來儲存工作簿。工作簿將儲存到建立它的資料夾中。

您也可以儲存資料來源以稍後建立另一個工作簿,或者使您的團隊成員能夠使用該資料進行自己的分析。

若要儲存資料來源,請將游標暫留在工作區內「資料」索引標籤中的資料來源名稱上,直至出現一個箭頭。選取該箭頭,並選取「儲存」

附註:在 Web 上儲存資料來源時,它將在「連線到資料」視窗以及「資料來源」部分中顯示為發行資料來源。

完成後,選取「檔案」>「關閉」以結束工作區。

步驟 7:協作和共用您的發現

可透過多種方式共用您的工作和保持更新。

協作

若組織中的其他 CreatorExplorer 有權存取工作簿所在的專案,則他們可以編輯或更新您的工作簿和檢視。存取由網站的管理員加以控制,後者可以設定項目使用權限、在專案之間移動內容以及變更使用者的角色。如果儲存了資料來源,則這些使用者可以連線到您的資料並使用它來建立新工作簿。

共用檢視和見解

每個儲存到網站的檢視或工作簿都可以透過電子郵件中的連結和其他應用程式來共用,或者直接嵌入到網頁、wikis 和 Web 應用程式中。

若要檢視檢視,使用者必須在 Tableau Server 或 Tableau Online 中具有存取共用檢視的使用權限。

瞭解如何:

感謝您的意見回饋!