使用 [標記] 卡控制檢視中標記的色彩、大小、形狀、詳細資料、文字和工具提示。將欄位拖到 [標記] 卡上的按鈕可對標記資料進行編碼。按一下 [標記] 卡上的按鈕以開啟 [標記] 屬性。如需有關標記的資訊,請參閱變更檢視中標記的類型[標記] 卡

附註:[標記] 卡上維度欄位的順序是從上到下的層次結構,並且會影響檢視中的排序。當在檢視中對標記進行排序時,Tableau 會首先考慮最上方的維度欄位,然後考慮 [標記] 卡上欄位下方的維度。

為標記指派色彩

若要為檢視中的標記指派色彩,請執行以下操作之一:

  • 在 [標記] 卡上按一下 [色彩] ,然後從功能表中選取一種色彩。

    這會將檢視中的所有標記更新為您選取的色彩。所有標記都有預設色彩,即使 [標記] 卡的 [色彩] 上沒有欄位時也是如此。對於大多數標記,藍色為預設色彩;對於文字,黑色為預設色彩。

  • 「資料」窗格中,將欄位拖曳至「標記」卡的「色彩」

    Tableau 將根據欄位的值和成員為標記套用不同的色彩。舉例來說,如果將諸如 [Category] (類別)等離散欄位(藍色欄位)放在 [色彩] 上,則檢視中的標記將按類別細分,每種類別指派有一種色彩。

    如果將諸如 SUM(sales) 等連續欄位放在 [色彩] 上,則會根據其銷售額值為檢視中的每個標記著色。

編輯色彩

變更調色盤或自訂向標記應用色彩的方式:

  • 在 [標記] 卡上,按一下 [色彩] > [編輯色彩]

有關詳情,請參閱調色盤和效果

變更標記的大小

若要變更檢視中標記的大小,請執行以下操作之一:

  • 在 [標記] 卡上按一下 [大小],然後將滑塊向左或向右移動。

    如下表所述,大小滑塊對不同標記的影響方式不同。

    標記類型 說明
    圓、方塊、形狀、文字 使標記變大或變小。
    條、甘特條 使條變寬或變窄。
    使線變粗或變細。
    多邊形 多邊形的大小不可變更。
    圓形圖 使圓形圖的整體尺寸變大或變小。

    使用 [大小] 滑塊變更標記大小時,不會修改資料檢視的大小。但是,如果變更檢視大小,標記大小可能隨之改變以適應新的格式。例如,如果使表變大,標記也可能變大。

  • [資料] 窗格中,將欄位拖到 [標記] 卡上的 [大小]

如果將離散欄位放在 [標記] 卡的 [大小] 上,Tableau 會根據該維度中的成員分隔標記,並為每個成員指派一個唯一大小。由於大小具有固定的順序(從小到大),因此分類大小最適合年份或季度之類的有序資料。

對離散欄位資料進行大小編碼將採用與 [詳細資料] 屬性相同的方式分隔標記,然後為每個標記提供附加資訊(大小)。有關詳情,請參閱按維度成員分隔檢視中的標記將分類大小編碼新增到檢視時,Tableau 會顯示一個圖例,其中顯示指派給 [大小] 目標上的欄位中包含的每個成員的大小。可以使用 [編輯大小] 對話方塊修改這些大小的分佈方式。

如果將連續欄位放在 [標記] 卡的 [大小] 上,Tableau 會使用連續範圍以不同大小繪製每個標記。將為最小值指派最小標記,最大值由最大標記表示。

將定量大小編碼新增到檢視時,Tableau 會顯示一個圖例,其中顯示按其指派大小的值範圍。可以使用 [編輯大小] 對話方塊修改這些大小的分佈方式。

編輯標記大小

編輯標記的大小或變更向檢視中的標記應用大小的方式:

  1. 在 [大小] 圖例卡(當您將欄位新增到 [標記] 卡上的 [大小] 時,該卡將出現)上,按一下右上角的下拉箭頭,並選取 [編輯大小]

    有關圖例詳情,請參閱圖例

  2. 在出現的 [編輯大小] 對話方塊中進行變更,然後按一下 [確定]

    可用選項取決於應用了大小的欄位是連續欄位還是離散欄位。

    對於連續欄位,您可以執行以下操作:

    • 對於 [大小變化] ,按一下下拉清單並選取以下選項之一:

      • 自動 — 選取最適合您的資料的對應。如果資料是數位並且不過零(均為正數或負數),則使用 [從零開始] 對應。否則,使用 [按範圍] 對應。

      • 按範圍 — 使用資料中的最小值和最大值確定大小分佈。例如,如果欄位的值範圍為 14 到 25,則大小會分佈在此範圍內。

      • 從零開始 — 將從零開始內插大小,將最大標記大小指派給距離零最遠的資料值的絕對值。

    • 使用範圍滑塊可以調整大小的分佈。從 [大小變化] 下拉式功能表中選取 [從零開始] 對應後,將停用下滑塊,因為它始終設定為零。

    • 選取 [反轉] 可向最小值指派最大標記,並向最大值指派最小標記。如果要從零開始對應大小,則此選項將不可用,因為最小標記始終指派給零。

    • 若要修改大小的分佈,請選中 [圖例中的開始值] [範圍的結束值] 核取方塊並鍵入範圍的開始和結束值。

      對於離散欄位,您可以執行以下操作:

      • 使用範圍滑塊可以調整大小的分佈。

      • 選取 [反轉] 可向最小值指派最大標記,並向最大值指派最小標記。

連續軸標記大小調整

對於標記類型為 [條] 並且 [列] [欄] 上都有連續(綠色)欄位的檢視,Tableau 將支援用於調整條已固定的軸上條標記大小的附加選項和預設值。

  • 長條圖中的條標記預設情況下是連續的(標記之間無空格),並且進行了大小調整以相符資料桶的大小。有關範例,請參閱組建長條圖

  • 如果 [大小] 上有欄位,則透過使用 [大小] 上的欄位,可以確定條已固定的軸上的條標記寬度。為此,請按一下 [大小] 卡並選取 [固定]

  • 如果 [大小] 上沒有欄位,則可以用軸單位指定條已固定的軸上的條標記寬度。為此,請按一下 [大小] 卡、選取 [固定],然後在 [以軸單位表示的寬度] 欄位中鍵入數字。

  • 當條已固定的軸上有連續日期欄位時,可以將標記的寬度設定為與日期欄位的層級相符。例如,如果連續日期欄位的層級為 [月],則條的寬度正好為一個月 - 即,有 31 天的月份比有 30 天的月份稍寬一些。透過按一下 [大小] 卡、選取 [固定] ,然後在 [以天數表示的寬度] 欄位中鍵入一個數位,您可以設定條的寬度,但所產生的條寬度未考慮不同時長單位,例如月和年。

為標記新增標籤或文字

向視覺效果中新增標記標籤或文字:

  • [資料] 窗格中,將欄位拖到 [標記] 卡上的 [標籤] [文字]

使用文字表時,[標籤] 架將替換為 [文字],後者允許您查看與資料檢視關聯的數位。對資料檢視進行文字編碼的效果取決於使用維度還是度量。

  • 維度 — 將維度放在 [標記] 卡的 [標籤] [文字] 上時,Tableau 會根據該維度中的成員分隔標記。文字標籤由維度成員名稱控制。

  • 度量 - 將度量放在 [標記] 卡的 [標籤] [文字] 上時,文字標籤由度量值控制。度量可以彙總,也可以分解。但是,對度量進行分解通常用處不大,因為這樣做通常會導致文字重疊。

[文字] 是文字表的預設標記類型,該表也稱為交叉表或樞紐分析表。

按維度成員分隔檢視中的標記

分隔檢視中的標記(或增大細微性):

  • [資料] 窗格中,將維度拖到 [標記] 卡上的 [詳情]

將維度放置到 [標記] 卡的 [詳細資料] 時,系統將根據維度的成員來分隔資料檢視中的標記。與將維度放置到 [列] [欄] 架不同,將該維度放置到 [標記] 卡的 [詳細資料] 上時,無需變更表結構即可顯示更多資料。

向標記中新增工具提示

工具提示是將游標暫留在檢視中的一個或多個標記上時顯示詳情。工具提示還為快速篩選或移除所選內容或查看基礎資料提供便利。您可以編輯工具提示,使它同時包含靜態和動態文字。您也可以修改在工具提示中包括哪些欄位,以及是否希望能夠使用這些欄位來選取檢視中的標記。

有關在工具提示內顯示工作表中的視覺效果(工具提示內部視覺效果)的詳情,請參閱在工具提示中建立檢視(工具提示內部視覺效果)

新增工具提示

  1. 將一個欄位拖到 [標記] 卡上的 [工具提示] 中。

  2. 按一下 [標記] 卡上的工具提示,以開啟 [編輯工具提示] 對話方塊,在此,您可以新增文字、重新排列工具提示內容以及插入更多欄位。

附註: 維度是使用 ATTR 彙總新增到工具提示的,這意味著工具提示有時可能顯示為一個星號。該星號表示有多個維度成員應用于您所指向的標記。例如,一個標記可表示所有地區的彙總銷售額。將 [Region] 欄位新增到工具提示時會顯示一個星號,因為該標記表示多個地區。若要避免顯示星號,請將該維度新增到 [標記] 卡上的 [詳細資料] 或在檢視中的其他位置使用該維度,以確保標記處於同一詳細層級。

工具提示選項

開啟 [編輯工具提示] 對話方塊之後,您可以選取一些選項以格式化檢視中的工具提示並設定其行為。您可以選取如下選項。

  • 設定工具提示格式: 工具提示是在每張工作表上指定的,並且可以使用 [編輯工具提示] 對話方塊頂端的工具設定工具提示格式。

  • 新增動態文字: 使用該對話方塊頂端的 [插入] 功能表可新增動態文字,例如欄位值、工作表屬性等。[插入] 功能表上的 [所有欄位] 命令會將檢視中使用的所有欄位名稱和值新增到檢視中任何標記的工具提示中。

  • 顯示工具提示: 預設情況下將顯示工具提示。如果您更希望隱藏自動工具提示,請清除 [顯示工具提示] 核取方塊。

  • 設定工具提示行為: 透過在 [顯示工具提示] 核取方塊旁邊的下拉清單中選取下列選項之一,來設定工具提示的行為方式:

    • 回應式 - 即時顯示工具提示:選取此選項可以在您將游標暫留在檢視中的標記時立即顯示工具提示。這是所有檢視的預設值。

      使用此選項,顯示的工具提示沒有命令按鈕。您必須先按一下檢視中的標記才能看到命令按鈕。

    • 暫留時 - 暫留時顯示工具提示:選取此選項可以僅在將游標放在標記上後才顯示工具提示。不過,對於此選項,命令按鈕會出現在工具提示上,而無需您進行任何進一步的動作(除非您以其他方式在 [編輯工具提示] 對話方塊中指定)。

  • 顯示命令: 選取 [包括命令按鈕] 核取方塊,以在工具提示頂端新增 [只保留] [排除] [群組成員] [建立集] [檢視資料] 按鈕。這些命令按鈕顯示在 Tableau Desktop 中,以及在將檢視發佈到 Web 時或在行動裝置上查看檢視時顯示。

    有關成員分組詳情,請參閱透過將資料分組來糾正資料錯誤或合併維度成員。有關建立集合的詳情,請參閱建立集合(連結在新視窗開啟)

  • 從工具提示中選取檢視中的標記。選中 [允許按類別選取] 核取方塊,以便能夠透過按一下工具提示中的離散欄位來選取檢視中具有相同值的標記。如果選中此核取方塊,您可以使用此功能,在將 Tableau Desktop 中的檢視中發佈到 Web 或在行動裝置上查看檢視時選取該檢視中的標記。

  • 新增或移除欄位: 若要在使用自動工具提示時新增和移除欄位,可在檢視中的一個架上以右鍵按一下(在 Mac 上,Control+按一下)相應欄位,然後選取 [包含在工具提示中]

附註: 僅當您尚未自訂工具提示時, [包含在工具提示中] 選項才可用。如果已自訂工具提示,則可以返回到自動工具提示,方法是在 [標記] 卡上按一下 [工具提示] ,然後在 [編輯工具提示] 對話方塊中按一下 [重設]

變更標記的形狀

變更標記的形狀:

  • [資料] 窗格中,將欄位拖到 [標記] 卡上的 [形狀]

如果將維度放在 [標記] 卡的 [形狀] 上,Tableau 會根據該維度中的成員分隔標記,並為每個成員指派一種唯一的形狀。Tableau 還顯示一個形狀圖例,該圖例顯示每個成員名稱和關聯的形狀。如果將度量放在 [標記] 卡的 [形狀] 上,則該度量會轉換為離散度量。

形狀編碼資料採用與 [詳細資料] 屬性相同的方式分隔標記,然後為每個標記提供附加資訊(形狀)。如果 [列] [欄] 架的最內層欄位都是度量,則形狀是預設標記類型。

在下面的檢視中,標記將根據 [Customer Segment] 維度的成員分隔到不同的形狀中。每個形狀分別反映了該客戶細分市場對利潤和銷售額的貢獻。

編輯形狀

預設情況下,有十個唯一的形狀用於對維度進行編碼。如果您有 10 個以上的成員,則形狀會重複使用。除了預設調色盤之外,您還可以從其他各種形狀調色盤中進行選取,包括填充形狀、箭頭,甚至天氣符號。

  1. 按一下 [標記] 卡上的 [形狀] ,或者在該圖例的卡功能表上選取 [編輯形狀]

  2. 在 [編輯形狀] 對話方塊中,在左側選取成員,然後在右側的調色盤中選取新形狀。也可以按一下 [指派調色盤] 快速為欄位成員指派形狀。

使用右上方的下拉式功能表選取其他形狀調色盤。

附註: 形狀編碼將在使用同一資料來源的多個工作表之間共用。例如,如果要定義由方塊表示的 [傢俱] 產品,則此類產品將在工作簿中的所有其他檢視中自動顯示為方塊。若要為欄位設定預設形狀編碼,請在 [資料] 窗格中以右鍵按一下(在 Mac 上,Control+按一下)該欄位,並選取 [預設屬性] > [形狀]

使用自訂形狀

可以向工作簿中新增自訂形狀,方法是將形狀影像檔複製到位於 Documents 資料夾下的 Tableau Repository 內的 Shapes 資料夾中。使用自訂形狀時,它們將隨工作簿一起儲存。這樣便可與他人共用工作簿。

  1. 建立形狀影像檔。每個形狀都應儲存為它自己的檔案,並且可以是一些影像格式中的任何格式,包括點陣圖 (.bmp)、可移植網路圖形 (.png)、.jpg 和圖形交換格式 (.gif)。

  2. 將形狀檔複製到位於 Documents 資料夾下的 My Tableau Repository\Shapes 資料夾內的新資料夾中。該資料夾的名稱將用作 Tableau 中的調色盤名稱。在以下範例中,將建立兩個新調色盤: [Maps] 和 [My Custom Shapes] 。

  3. 在 Tableau 中,按一下圖形圖例上的下拉箭頭,然後選取 [編輯圖形]

  4. 在下拉清單中選取新的自訂調色盤。如果您在 Tableau 執行期間修改了形狀,可能需要按一下 [重新載入形狀]

  5. 可以一次為成員指派一個形狀,也可以按一下 [指派調色盤] 自動為成員指派形狀。

附註: 可以透過按一下 [重設] 按鈕復原為預設調色盤。如果開啟的工作簿使用了您沒有的自訂形狀,則該工作簿會顯示這些自訂形狀,因為這些形狀是作為該工作簿的一部分儲存的。不過,可以在 [編輯形狀] 對話方塊中按一下 [重新載入形狀] ,改用您的存放庫中的形狀。

下面是一些同時使用了預設和自訂形狀調色盤的檢視範例。

關於建立自訂形狀的提示

建立自訂形狀時,您可以執行一些操作來改進形狀在檢視中狀的外觀和功能。如果您要建立自己的形狀,建議您按照以下準則建立圖示或剪貼畫。

  • 建議大小 - 除非您計劃使用 [大小] 將形狀真的設定為大尺寸,否則應該嘗試使原始形狀大小接近 32 x 32 圖元。然而,原始大小取決於您希望能夠在 Tableau 中使用的大小範圍。可以在 Tableau 中透過按一下 [標記] 卡上的 [大小] 來調整形狀大小,也可以使用 [格式] 功能表上的儲存格大小選項。

  • 新增色彩編碼 - 如果您也打算使用 [色彩] 對形狀進行編碼,則應該使用透明背景。否則,不僅僅是符號,整塊影像區域都將填充色彩。GIF 和 PNG 檔案格式都支援透明度。GIF 檔支援 100% 透明的單色透明度,而 PNG 檔案支援 alpha 通道,此通道包含可用於影像中的所有圖元的透明度層級範圍。當 Tableau 色彩對符號進行編碼時,不會修改每個圖元的透明程度,所以您可以維護光滑的邊緣。

    附註:請避免在影像周圍包括太多透明度。使自訂形狀的大小盡可能接近影像的大小。影像邊緣周圍的額外透明圖元可能會對靠近影像的暫留或按一下行為造成負面影響,特別是在自訂形狀彼此覆蓋的情況下。當實際形狀區域比可視區域大時,對於使用者而言,可能會使形狀的暫留和按一下行為變得更加困難,並且更難預測。

  • 檔案格式 - Tableau 不支援增強中繼檔案格式 (.emf) 的符號。形狀影像檔可採用以下格式之一:形狀影像檔可採用以下格式之一:.png、.gif、.jpg、.bmp 和 .tiff。

在標記之間繪製路徑

[標記] 卡下拉式功能表中選取 [線] [多邊形] 標記類型時, [路徑] 屬性可用。有關如何變更視覺效果中所顯示標記的類型詳情,請參閱變更檢視中標記的類型

您可以使用 [標記] 卡上的 [路徑] 屬性來變更線標記的類型(線性、階梯或跳躍),或透過使用特定繪製順序連線標記來對資料進行編碼。使用度量或維度都可以對資料進行路徑編碼。

  • 維度 — 將維度放在 [標記] 卡的 [路徑] 上時,Tableau 會根據該維度中的成員連線標記。如果維度為日期,則由日期順序控制繪製順序。如果維度包含客戶名稱或產品類型等文字,則繪製順序由資料來源中的成員順序控制。透過變更成員的排序順序,可以變更連線資料點的順序。有關詳情,請參閱在視覺效果中對資料進行排序(連結在新視窗開啟)

  • 度量 - 將度量放在 [標記] 卡的 [路徑] 上時,Tableau 會根據該度量的值連線標記。可對度量進行彙總或分解。

變更線類型(線性、階梯、跳躍)

當標記類型設定為線( [自動] 或 [線] )時,您可以按一下 [標記] 卡中的 [路徑] 屬性來變更線類型。

為在一段時間內保持不變並且變化或增量顯著的數值資料(例如帳戶餘額、庫存量或利率)使用這些線類型。階梯線非常適合用於強調變化的量級。跳躍線可幫助強調資料點之間變化的持續時間。

  1. 在 [標記] 卡中按一下 [路徑]
  2. 選取 [線性] [階梯] [跳躍] 以變更線類型。

建立路徑編碼檢視

要建立有用的路徑編碼檢視,資料表應至少包含一個度量。您無法建立僅連線一種分類資料(維度)的路徑。

下面的檢視是使用 2010 年大西洋海域的暴風雨資料建立的。該檢視對由暴風雨日期確定的路徑使用了線標記。這樣您會看到暴風雨所經過的路線。如果將連續日期放在 [標記] 卡的 [路徑] 上,這會告訴 Tableau 按時間順序繪製線條。有關詳情,請參閱在 Tableau 中建立顯示隨時間變化的路徑的地圖在 Tableau 中建立顯示起點和終點之間的路徑的地圖

感謝您的意見回饋!