Ao instalar o Tableau Desktop e o Tableau Prep Builder, existem vários recursos que são ativados por padrão. Por exemplo, com o Tableau Desktop, as atualizações automáticas de produtos ou a capacidade de salvar automaticamente as pastas de trabalho do usuário estão incluídas como parte da instalação. Mas você pode ter alguns recursos aos quais você não deseja que os usuários tenham acesso, como a capacidade de fazer upload de arquivos e de logs de despejo com falhas. É possível desativar alguns desses recursos como administrador.

Para o Windows, você também pode configurar o conteúdo personalizado para exibição no painel Descobrir, substituir as pastas de trabalho do acelerador padrão pelas personalizadas e desativar alguns recursos durante a instalação. Para obter uma lista desses recursos, consulte as Instalar com a linha de comando em Instalação do Tableau Desktop e Tableau Prep Builder na linha de comando.

No Mac, é possível configurar o conteúdo de painel Descobrir personalizado, substituir as pastas de trabalho do acelerador padrão pelas personalizadas ou desativar alguns recursos somente após a conclusão do processo. Para configurar conteúdo personalizado para o painel Descobrir, substituir as pastas de trabalho de amostra padrão pelas personalizadas ou alterar configurações após a instalação (tanto Windows quanto Mac), você pode alterar o registro ou o arquivo .plist e reiniciar o aplicativo para ver suas alterações.

Para implantar as alterações em computadores remotos, exporte as configurações do registro (Windows) ou arquivo .plist (Mac), modifique as configurações que deseja desativar e crie um script automático com o arquivo modificado para transferir as atualizações para cada computador com o Tableau Desktop instalado.

Importante: sempre faça uma cópia de segurança do arquivo de registro antes de fazer quaisquer alterações. A edição incorreta do registro do Windows pode danificar o computador.

Definir o idioma de exibição (opcional)

Ao executar o Tableau Desktop ou Tableau Prep Builder pela primeira vez, ele reconhece a localidade do computador com a configuração Localidade do usuário e usa o idioma adequado caso haja suporte. Se você estiver usando um idioma incompatível, o padrão do aplicativo é o inglês.

É possível configurar o Tableau Desktop ou o Tableau Prep Builder para exibir a interface do usuário (menus, mensagens, entre outros) em um idioma diferente ao selecionar Ajuda > Escolher idioma no menu superior. Reinicie o aplicativo para aplicar a alteração.

Desktop

Prep Builder

No Tableau Prep Builder, o formato de exibição de números e datas se baseia na localidade do sistema operacional da máquina na qual o aplicativo está instalado. No Tableau Desktop, você pode configurar a formatação de data e número para as pastas de trabalho. Para obter mais informações, consulte Idioma e localidade(O link abre em nova janela) na ajuda do usuário do Tableau.

Alterar o local do Meu repositório do Tableau (opcional)

Durante a instalação, o Tableau Desktop e o Tableau Prep Builder criam automaticamente uma estrutura de pasta do Meu repositório do Tableau <application> na pasta de documentos do seu computador. Caso precise mover esse repositório para outro local, por exemplo, porque foi solicitado a ter os dados em um servidor de rede, em vez de no computador, é possível especificar um novo local e direcionar o Tableau Desktop e o Tableau Prep Builder para a nova pasta.

Ao definir uma nova localização para seu repositório, as seguintes regras são aplicadas:

  • A nova pasta deve ser um diretório.

  • É necessário ter permissões para gravar na nova pasta.

  • A nova pasta não pode estar localizada na estrutura de pasta Meu repositório do Tableau existente.

Observação: alterar o local do repositório não move os arquivos contidos no repositório original. Em vez disso, o Tableau cria um novo repositório onde você possa armazenar seus arquivos.

  1. Abra o Tableau Desktop ou o Tableau Prep Builder.

  2. No menu superior, selecione Arquivo >Local do repositório.

  3. Na caixa de diálogo Selecionar a pasta do repositório , selecione uma nova pasta que agirá como o novo local do repositório.

  4. Reinicie o aplicativo para usar o novo repositório.

Configure o painel Descoberta para mostrar conteúdo personalizado (somente no Tableau Desktop)

Por padrão, o Tableau fornece informações como links para treinamento, publicações de blog e visualizações públicas no painel Descoberta no Tableau Desktop para ajudar seus usuários a começar a usar o Tableau. O painel Descoberta aparece na inicialização e persiste na página Iniciar para que esses links e informações estejam sempre disponíveis aos seus usuários.

No entanto, em vez disso, você pode querer usar o painel Descoberta para mostrar o conteúdo específico para sua empresa. Para fazer isso, você pode criar sua própria página da Web para o conteúdo que está hospedado em um servidor Web que você fornece usando uma URL habilitada por https, em seguida, use a chave DiscoverPane e um valor DiscoverPaneURL para substituir o conteúdo padrão fornecido pela Tableau pelo conteúdo da sua página personalizada da Web.

Observação: para otimizar os resultados, não use páginas da Web que incluam Javascript ou redirecionamentos.

Para ajudar você a começar rapidamente, o Tableau Desktop fornece um modelo(O link abre em nova janela) que forma o mesmo layout que o painel Descobrir fornecido pela Tableau. Basta baixar o modelo e substituir os links pelo conteúdo personalizado. O modelo inclui uma seção para métricas, estrutura de layout e links para conteúdo.

Windows

Você pode configurar o painel Descobrir para apontar para sua página Web personalizada durante a instalação, usando a linha de comando ao adicionar nela a propriedade DISCOVERPANEURL="<https://YourWebPage.com>". Se você quiser configurar o painel Descobrir para usar seu conteúdo personalizado após a instalação estiver concluída, siga as etapas abaixo. Reinicie o aplicativo para ver suas alterações.

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe).

  3. Navegue até o seguinte caminho de registro:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>. Por exemplo, Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2020.1

  4. Clique com o botão direito na sua versão do Tableau e selecione Nova > Chave e nomeie-a DiscoverPane.

  5. No painel direito da nova chave DiscoverPane, clique com o botão direito do mouse e selecione Novo > Valor de cadeia de caracteres e nomeie-a como DiscoverPaneURL .

  6. Clique com o botão direito do mouse no novo valor de cadeia de caracteres DiscoverPaneURL e selecione Modificar. Em seguida, na caixa de diálogo Editar cadeia de caracteres do campo Dados do valor, digite a URL para sua página personalizada da Web. Seu conteúdo deve ser hospedado usando uma URL habilitada por https. O uso de uma URL habilitada por http não é compatível.

     Por exemplo, https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm.

  7. Para redefinir o painel Descobrir de volta ao conteúdo padrão do Tableau Desktop, modifique o valor do DiscoverPaneURL e limpe a URL personalizada da página da Web que você inseriu, deixando o campo Dados de valor em branco. Quando você reiniciar Tableau Desktopo painel Descobrir mostrará o conteúdo padrão do Tableau.

Mac

Modifique /Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist ao adicionar uma chave DiscoverPane e um valor DiscoverPaneURL. Reinicie o aplicativo para ver suas alterações.

  1. Defina o valor para sua URL personalizada executando o seguinte comando no prompt de comando Terminal. Use as mesmas letras maiúsculas e minúsculas, como mostrado abaixo.

    defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL <https://YourWebPageURL>

    Por exemplo, no Tableau Desktop 2020.1, use o comando a seguir:

    defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL https://help.tableau.com/current/desktopdeploy/en-us/desktop_deploy_user.htm

  2. Para redefinir o painel Descobrir de volta ao conteúdo padrão do Tableau Desktop, execute este comando:

    defaults write com.tableau.Tableau-<version> DiscoverPane.DiscoverPaneURL “ ”

    Quando você reiniciar Tableau Desktop o painel Descobrir mostrará o conteúdo padrão do Tableau.

Substituir as pastas de trabalho do acelerador pelas personalizadas (somente Tableau Desktop)

Por padrão, o Tableau fornece três aceleradores em pacotes para ajudar os usuários a explorá-lo. (Antes da versão 2022.2, esses aceleradores eram chamados de pastas de trabalho de amostra.) A partir da versão 2021.3, você pode criar até cinco pastas de trabalho em pacote direcionadas a seus usuários específicos e substituir os aceleradores que o Tableau fornece na página inicial, seção Aceleradores por suas pastas de trabalho personalizadas.

Observação: ao instalar o Tableau Server, você pode optar por incluir pastas de trabalho de amostra no site Padrão. Se você selecionou a opção Incluir amostras durante a instalação, é possível publicar pastas de trabalho de amostras personalizadas no Tableau Desktop para o projeto de Amostras do Tableau no seu servidor.

As pastas de trabalho de amostra personalizadas deve atender aos seguintes requisitos:

  • Você pode incluir no máximo cinco pastas de trabalho de amostra por vez.
  • Apenas arquivos de pasta de trabalho em pacote (.twbx) são aceitos.
  • As pastas de trabalho devem ser armazenadas em um diretório em uma máquina local à qual o Tableau e o usuário tenham acesso de leitura. Diretórios de rede não são aceitos.
  • Os nomes dos arquivos da pasta de trabalho não podem conter os caracteres ‘, “, <, >, ou &.

Observação: as amostras personalizadas não são persistentes ao atualizar para uma nova versão de lançamento (por exemplo, 2021.4). Você precisará especificar o caminho do arquivo para suas amostras personalizadas, ao instalar sua atualização por meio da linha de comando ou modificar o registro (Windows) ou .plist (MacOS) após a atualização.

Antes de começar

Windows e Mac

Crie um diretório em sua máquina local, onde as amostras são armazenadas, e adicione até cinco arquivos de pasta de trabalho de amostra (.twbx).

Você pode substituir os arquivos de pasta de trabalho, conforme necessário, mas cinco é o número máximo de pastas de trabalho que podem ser mostrados na página Início. Para obter informações sobre a substituição de pastas de trabalho personalizadas, consulte Gerenciar pastas de trabalho personalizadas .

Windows

Na linha de comando

Quando instalar usando a linha de comando, adicione a propriedade CUSTOMSAMPLESDIR="path to directory".

Por exemplo: tableauDesktop-64bit-2021-3-0.exe /quiet /norestart ACCEPTEULA=1 CUSTOMSAMPLESDIR="C:\Users\mkim\Documents\My Tableau Repository\CustomSamples"

Ao iniciar o Tableau, você deve ver seus exemplos personalizados na página inicial.

Pós-instalação do registro

Para configurar o diretório de amostras personalizadas após a conclusão da instalação, siga as etapas abaixo. Reinicie o aplicativo para ver suas alterações.

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe).

  3. Navegue até o seguinte caminho de registro:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>. Por exemplo, Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2021.3

  4. Crie uma nova pasta chamada Amostras . Clique com o botão direito do mouse na pasta da versão do Tableau, selecione Novo > Chave e renomeie a nova pasta.

  5. Clique com o botão direito do mouse na pasta Amostras que você acabou de criar e selecione Novo > Valor da cadeia de caracteres e nomeie como CustomSamplesDir.

  6. Clique com o botão direito do mouse no novo valor de cadeia de caracteres CustomSamplesDir e selecione Modificar. Em seguida, na caixa de diálogo Editar cadeia de caracteres no campo Dados do valor, insira o caminho completo do arquivo do Windows para o diretório que você configurou anteriormente.

  7. Reinicie o Tableau Desktop para ver suas alterações. A seção agora é intitulada Suas pastas de trabalho personalizadas.

  8. Para redefinir de volta ao conteúdo padrão do Tableau Desktop, modifique o valor do CustomSamplesDir e limpe a caminho do diretório que você inseriu, deixando o campo Dados do valor em branco. Quando você reiniciar o Tableau Desktop, a seção Aceleradores na página inicial mostrará o conteúdo padrão do Tableau.

Mac

Modifique /Users/<local user>/Library/Preferences/com.tableau.Tableau-<version>.plist ao adicionar uma chave Samples.CustomSamplesDir e um valor de caminho de diretório de amostra. Reinicie o aplicativo para ver suas alterações.

  1. Defina o valor para sua o diretório de amostras personalizadas executando o seguinte comando no prompt de comando Terminal. Use as mesmas letras maiúsculas e minúsculas, como mostrado abaixo.

    defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir <your directory path>

    Por exemplo, no Tableau Desktop 2021.3, use o comando a seguir:

    defaults write com.tableau.Tableau-2021.3.0 Samples.CustomSamplesDir "/Users/mkim/Documents/My Tableau Repository/CustomSamples"

  2. Para redefinir de volta ao conteúdo padrão do Tableau Desktop, execute este comando:

    defaults write com.tableau.Tableau-<version> Samples.CustomSamplesDir “ ”

    Quando você reiniciar Tableau Desktopo painel Descobrir mostrará o conteúdo padrão do Tableau.

Gerenciar pastas de trabalho personalizadas

Quando você adiciona pastas de trabalho de amostra personalizadas ao Tableau Desktop, um arquivo custom.manifest e imagens em miniatura da planilha são gerados automaticamente na pasta de amostras personalizadas que você criou ao abrir o aplicativo pela primeira vez.

Ao substituir pastas de trabalho de amostra personalizadas por novas pastas de trabalho, você precisará excluir o arquivo custom.manifest para que um novo arquivo possa ser gerado. A exclusão das imagens em miniatura da planilha é opcional.

  1. Navegue até a pasta de amostras personalizadas em seu diretório local.
  2. Exclua o arquivo custom.mainfest.
  3. Exclua ou mova as pastas de trabalho e quaisquer imagens em miniatura da planilha (opcional) para essas pastas de trabalho da pasta de amostras personalizadas.
  4. Adicione suas novas pastas de trabalho em pacote (.twbx) à sua pasta de amostras personalizadas.
  5. Reinicie o aplicativo.

Desativar atualizações de produtos

O recurso Atualizações de produtos permite que os usuários recebam atualizações de forma automática ou verifiquem e instalem atualizações de manutenção conforme são disponibilizadas. Para desativar as atualizações de produto após a instalação do Tableau Desktop, será necessário atualizar a chave AutoUpdateAllowed no registro (Windows) ou no arquivo .plist (Mac) em cada computador em que o Tableau estiver instalado.

Windows

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe).

  3. Defina a chave do registro AutoUpdateAllowed para 0. A tabela a seguir lista a localização da chave em diferentes produtos.

Produto Localização (Tableau e Windows de 64 bits)

Tableau Desktop

HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\AutoUpdate

Tableau Desktop Public Edition

HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Public <version>\AutoUpdate

Tableau Reader

HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau Reader <version>\AutoUpdate

Para habilitar as atualizações novamente, realize o mesmo procedimento, alterando a chave do registro para 1 em vez de 0.

Mac

Execute um dos seguintes comandos no prompt de comando do Terminal.

Produto Comando
Tableau Desktop defaults write com.tableau.Tableau-<version> AutoUpdate.AutoUpdateAllowed "0"

Por exemplo, no Tableau Desktop 2019.1, use o comando a seguir:

defaults write com.tableau.Tableau-2019.1 AutoUpdate.AutoUpdateAllowed "0"

Tableau Desktop Public Edition defaults write com.tableau.Tableau-Public-<version> AutoUpdate.AutoUpdateAllowed "0"
Tableau Reader defaults write com.tableau.Tableau-Reader-<version> AutoUpdate.AutoUpdateAllowed "0"

Para habilitar as atualizações de produto novamente, execute o mesmo comando, especificando 1 em vez de 0.

Desativar recuperação de arquivos

O recurso de recuperação de arquivos permite que o Tableau Desktop e o Tableau Prep Builder (versão 2020.3.3 e posteriores) salvem as pastas de trabalho ou os arquivos de fluxo do usuário, para que ele não perca seu trabalho caso o aplicativo pare de funcionar inesperadamente. Ao abrir o Tableau novamente, uma caixa de diálogo é exibida com uma lista dos arquivos recuperados. O usuário pode abrir os arquivos recuperados e continuar de onde havia parado ou pode excluir qualquer arquivo não desejado. Se os arquivos forem excluídos, quaisquer alterações feitas desde a última vez que o trabalho foi salvo serão descartadas.

Se todos os arquivos recuperados da lista forem excluídos para o Tableau Desktop ou da pasta Fluxos recuperados para o Tableau Prep Builder, a caixa de diálogo de recuperação não será mais exibida até sejam gerados novos arquivos recuperados.

O recurso de recuperação de arquivos é habilitado por padrão. Se você quiser desabilitá-lo, poderá alterar a configuração da propriedade AUTOSAVE (Tableau Desktop) ou a configuração maestro.appSettings.autosave (Tableau Prep Builder). Clique na guia do produto para exibir as etapas de desativação da recuperação de arquivos.

Quando você desativar o recurso de recuperação de arquivos, a opção de menu Habilitar salvamento automático não ficará disponível para o usuário. Caso queira habilitar novamente o recurso após a instalação, é possível usar uma atualização de registro (ou .plist para Mac) para alterar a configuração da propriedade AUTOSAVE em cada computador em que o Tableau estiver instalado. Para obter mais informações sobre como controlar essa configuração durante a instalação na linha de comando, consulte Instalar com a linha de comando(O link abre em nova janela).

Para desativar a recuperação de arquivos depois de instalar o Tableau Desktop, será necessário atualizar a chave AutosaveAllowed no registro (Windows) ou no arquivo .plist (Mac) em cada computador em que o Tableau estiver instalado.

Windows

  1. Como administrador do computador onde o Tableau Desktop está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe).

  3. Defina a chave do registro AutosaveAllowed para 0.

    Localização da chave de registro: HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Autosave

Para habilitar a recuperação de arquivos novamente, realize o mesmo procedimento, mas defina a chave de registro AutosaveAllowed como 1, em vez de 0.

Mac

Execute o seguinte comando no prompt de comando do Terminal.

defaults write com.tableau.Tableau-<version> Autosave.AutosaveAllowed "0"

Por exemplo, no Tableau Desktop 2020.3, use o comando a seguir:

defaults write com.tableau.Tableau-2020.3 Autosave.AutosaveAllowed "0"

Para habilitar a recuperação de arquivos novamente, execute o mesmo comando, especificando Autosave.AutosaveAllowed "1" em vez de "0".

Durante a instalação, você pode desativar o recurso de recuperação de arquivos na linha de comando (Windows) ou desmarcando a caixa de seleção Habilitar recuperação de falhas na etapa Tipo de instalação da seção de instalação personalizada (MacOS). Para obter informações sobre como desativar o recurso de recuperação de arquivos durante a instalação, consulte Antes de começar.

Para habilitar ou desativar o recurso de recuperação de arquivos após a instalação do Tableau Prep Builder, você deve alterar a propriedade para a configuração maestro.appSettings.autosave de cada computador em que o Tableau Prep Builder foi instalado.

Windows

  1. Como administrador do computador em que o Tableau Prep Builder foi instalado, navegue até a pasta app. Por exemplo:

    C:\Program Files\Tableau\Tableau Prep Builder 2020.3\resources\app

  2. Na pasta app, abra o arquivo application.properties.

  3. Defina maestro.appSettings.autosave=false

Para habilitar a recuperação de arquivos novamente, realize o mesmo procedimento, mas defina maestro.appSettings.autosave=true.

Mac

  1. Navegar até /Library/Application Support/Tableau Prep Builder/

  2. Abra o arquivo application.properties em um editor de texto.

  3. Alterar maestro.appSettings.autosave=true para maestro.appSettings.autosave=false

  4. Salvar as alterações e fechar o arquivo.

Para habilitar a recuperação de arquivos novamente, realize o mesmo procedimento, mas altere maestro.appSettings.autosave=false para maestro.appSettings.autosave=true.

Desativar relatórios de uso

O Tableau coleta dados que nos ajudam a aprender como nossos produtos estão sendo usados, para que possamos melhorar os recursos existentes e desenvolver novos. Todos os dados de uso são coletados e tratados de acordo com a Política de privacidade(O link abre em nova janela). Se você não quiser participar dessa opção, poderá desativá-la durante ou após a instalação.

Para obter informações sobre os tipos de dados coletados, consulte Dados de uso do Tableau(O link abre em nova janela).

Caso não queira participar dessa opção, é possível desativá-la ao desmarcar a caixa de seleção durante a instalação ou na linha de comando (Windows), ao adicionar uma linha de comando que inclua a propriedade SENDTELEMETRY="0".

Para obter informações sobre como desabilitar essa opção na interface do usuário, consulte Instalar com a interface do usuário(O link abre em nova janela). Para obter informações sobre como desabilitar esta opção na linha de comando, consulte Instalar com a linha de comando.

Mesmo quando você desabilitar o envio de dados de uso do produto, determinados dados básicos do produto são enviados ao Tableau. Se você não quiser enviar dados básicos do produto para o Tableau, também poderá desativar essa opção. Para obter mais informações, consulte Dados básicos do produto.

Para desativar essa opção após a instalação, faça o seguinte:

No produto

  1. Abra o Tableau Desktop.

  2. No menu superior, selecione Ajuda >Configurações e desempenho.

  3. Clique em Não enviar dados de uso do produto.

No registro

Para desativar relatórios de uso no nível do sistema, siga as instruções para o seu sistema operacional.

Windows

Abra um prompt de comando e execute o seguinte comando:

REG ADD "HKLM\Software\Tableau\<Tableau Version>\Telemetry" /v TelemetryEnabled /t REG_DWORD /d 0

Como alternativa, siga as etapas a seguir:

  1. Como administrador do computador onde o Tableau Desktop está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe).

  3. Defina a chave do registro TelemetryEnabled para 0.

    Localização da chave de registro: HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Telemetry

Para habilitar os relatórios de uso novamente, realize o mesmo procedimento, alterando a chave do registro para 1 em vez de 0.

Mac

Execute o seguinte comando no prompt de comando do Terminal.

defaults write com.tableau.Tableau-<version> Telemetry.TelemetryEnabled "0"

Por exemplo, no Tableau Desktop 2019.4, use o comando a seguir:

defaults write com.tableau.Tableau-2019.4 Telemetry.TelemetryEnabled "0"

Para habilitar os relatórios de uso novamente, execute o mesmo comando, especificando 1 em vez de 0.

Para desativar essa opção após a instalação, faça o seguinte:

No produto

  1. Abra o Tableau Prep Builder como administrador.

    • Windows: clique com o botão direito do mouse no aplicativo e selecione Executar como administrador.
    • MacOS : no prompt de comando do Terminal, executesudo /Applications/Tableau\ Prep\ Builder\ <version>.app/Contents/MacOS/Tableau\ Prep\ Builder.
  2. No menu superior, selecione Ajuda >Configurações e desempenho.

  3. Clique em Não enviar dados de uso do produto.

    Observação: na versão 2019.3.2 e anterior, clique em Compartilhar dados de uso para aprimorar o Tableau Prep Builder para desmarcar a caixa de seleção

No arquivo de propriedades

Windows

  1. Navegue até a pasta do aplicativo no diretório em que o Tableau Prep Builder está instalado. Por exemplo, C:\Program Files\Tableau\Tableau Prep Builder <version>\resources\app

  2. Abra o arquivo telemetryConfig.properties em um editor de texto.

  3. Alterar maestro.telemetry.enabled=true para maestro.telemetry.enabled=false

  4. Salvar as alterações e fechar o arquivo.

Mac

Para Mac, essa configuração é específica do usuário. Esta configuração não se aplica a nenhum outro usuário no sistema, a menos que ele reinstale o aplicativo.

  1. Navegar até ~/Library/Application Support/Tableau Prep Builder/

  2. Abra o arquivo telemetryConfig.properties em um editor de texto.

  3. Alterar maestro.telemetry.enabled=true para maestro.telemetry.enabled=false

  4. Salvar as alterações e fechar o arquivo.

Desativar relatórios de erro

Se o Tableau Desktop ou o Tableau Prep Builder tiver um problema e encerrar inesperadamente, os arquivos de despejo e os registros serão gerados e colocados na pasta Logs no repositório Meu Tableau ou Meu Tableau Prep Builder. Esta opção é habilitada por padrão.

Os dados nesses arquivos podem incluir informações específicas da máquina, um instantâneo do conteúdo da memória no momento da falha (isso pode incluir detalhes da atividade do aplicativo, informações da conexão de dados, ações tomadas pelo usuário ou dados em execução no Tableau) e informações identificáveis dos clientes.

Se a sua organização estiver sujeita aos regulamentos de privacidade de dados, será possível desabilitar essa opção. Você precisará concluir diferentes etapas para desabilitar essa opção para o Tableau Desktop versus o Tableau Prep Builder. Clique nas guias abaixo para visualizar as instruções do aplicativo.

Para o Tableau Desktop, a próxima vez que o usuário abrir o aplicativo, um aviso na caixa de diálogo é aberto, que permite ao usuário realizar uma das seguintes ações:

  • Fazer upload de arquivos com falhas.

  • Recusar o upload de arquivos com falhas.

  • Desativar permanentemente o upload de arquivos com falhas.

Se o usuário carregar os arquivos, eles serão compactados juntos em um pacote criptografado usando uma chave RSA de 2048 bits e enviados para o Tableau, para que um engenheiro possa analisar e identificar os problemas que causaram a falha.

O pacote criptografado inclui:

  • Arquivos de despejo com falhas (.dmp)

  • Arquivo de registro com erro relacionado à falha (.log)

  • Arquivo de manifesto com erro relacionado à falha (.log)

Caso a empresa esteja sujeita a regulamentos de privacidade de dados, é possível desabilitar a exibição dessa solicitação ao editar o registro (Windows) ou executar um script (Mac) em cada desktop para impedir que os usuários façam o upload dos arquivos de despejo e registros com falhas.

Windows

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe)

  3. Defina a chave do registro CrashReportUpload para 2.

    Localização da chave de registro: HKEY_CURRENT_USER\Software\Tableau\<version>\Prompts

Mac

Execute o seguinte comando no prompt de comando do Terminal:

defaults write com.tableau-<TABLEAU VERSION>.plist Prompts.CrashReportUpload -string 2

Por exemplo, no Tableau Desktop 2019.1, use o comando a seguir:

defaults write com.tableau.Tableau-2019.1.plist Prompts.CrashReportUpload -string 2

Para o Tableau Prep Builder no Windows, você pode desativar a opção de relatórios de erros durante a instalação ao desmarcar a caixa de seleção Habilitar relatórios de erros na caixa de diálogo Personalizar ou, na linha de comando, incluir a propriedade CRASHDUMP="0".

Para desativá-la após a instalação, adicione a linha maestro.enable_fault_reporting=false na seção de propriedades do aplicativo do arquivo application.properties.

Este arquivo está localizado em C:\Program Files\Tableau\<Tableau Prep Builder version>\resources\app .

Desativar objetos de página da Web no painel (apenas Tableau Desktop)

Os objetos de página da Web exibem URLs de destino em uma seção do painel. Durante a instalação, consulte Instalar com a linha de comando para desativar o visor de URLs nesses objetos. Após a instalação, conclua as etapas abaixo.

Windows

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe)

  3. Defina a chave do registro WebViewToggleWebZonesEnabled para 0.

    Localização da chave de registro: HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\<version>\Settings

Mac

Execute o seguinte comando no prompt de comando do Terminal.

defaults write /Library/Preferences/com.tableau.Tableau-<version>.plist Settings.WebViewToggleWebZonesEnabled -integer 0

Por exemplo, no Tableau Desktop 2020.4, use o comando:

defaults write /Library/Preferences/com.tableau.Tableau-2020.4.plist Settings.WebViewToggleWebZonesEnabled -integer 0

Para reabilitar os objetos de página da Web execute o mesmo comando, especificando -integer 1 em vez de -integer 0.

Desabilitar as extensões de painel (somente no Tableau Desktop)

As extensões de painel aumentam a funcionalidade do painel com a ajuda de aplicativos da Web criados pelo Tableau e por desenvolvedores de terceiros. A partir da versão 2019.4 do Tableau Desktop, o Tableau aceita dois tipos de extensões de painel: as extensões habilitadas para rede, que são executadas em servidores Web localizados dentro ou fora da sua rede local e com acesso completo à Web, e as extensões de área restrita, que são executadas em um ambiente protegido sem acesso à Web. Para obter mais informações, consulte Usar extensões de painel(O link abre em nova janela) e Segurança de extensão - Práticas recomendadas para implantação(O link abre em nova janela).

Por padrão, todos os tipos de extensões de painel são habilitados. Se deseja desativar as extensões de painel durante a instalação em cada desktop, defina as propriedades a seguir. Para obter mais informações, consulte Instalar com a linha de comando(O link abre em nova janela).

  • DISABLEEXTENSIONS="1": desabilita todos os tipos de extensão de painel.
  • DISABLENETWORKEXTENSIONS="1": desabilita apenas as extensões habilitadas para rede. Se DISABLEEXTENSIONS estiver definido como "0", os usuários ainda poderão usar as extensões de área restrita.

Desativar todas as extensões de painel após a instalação

Para desativar todas as extensões de painel após a instalação, edite o registro (Windows) ou execute um script (MacOS) em cada desktop de acordo com as instruções abaixo.

Windows

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe)

  3. Defina a chave do registro DisableExtensions para 1.

    Localização da chave de registro: HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\DisableExtensions

Mac

Execute o seguinte comando no prompt de comando do Terminal:

defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableExtensions "1"

Por exemplo, no Tableau Desktop 2019.4, use o comando a seguir:

defaults write com.tableau.tableau-2019.4.plist Settings.Extensions.DisableExtensions "1"

Desativar extensões habilitadas para rede após a instalação

Para desativar apenas as extensões de painel habilitadas para rede após a instalação, edite o registro (Windows) ou execute um script (MacOS) em cada desktop seguindo as instruções abaixo.

Windows

  1. Como administrador do computador onde o Tableau está instalado, faça um backup do arquivo de registro antes de alterá-lo.

  2. Abra o Editor do Registro (regedit.exe)

  3. Defina a chave do registro DISABLENETWORKEXTENSIONS para 1.

    Localização da chave de registro: HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\Settings\Extensions\DisableNetworkExtensions

Mac

Execute o seguinte comando no prompt de comando do Terminal:

defaults write com.tableau.tableau-<TABLEAU VERSION>.plist Settings.Extensions.DisableNetworkExtensions "1"

Por exemplo, no Tableau Desktop 2019.4, use o comando a seguir:

defaults write com.tableau.tableau-2019.4.plist Settings.Extensions.DisableNetworkExtensions "1"

Agradecemos seu feedback!