Creator: 웹 작성 시작

Tableau에는 웹에서 수행할 수 있는 작업이 매우 많습니다. Creator는 데이터에 직접 연결하여 강력한 분석을 수행하고, 놀라운 데이터 비주얼리제이션을 만들고, 이러한 심층 정보를 다른 사람들과 공유할 수 있습니다. 이 가이드에서는 Tableau Online 환경, 분석할 데이터의 연결 및 준비, 통합 문서 만들기와 심층 정보를 다른 사람들과 공유하는 것에 대해 다룹니다.

자신의 사용자 수준이 무엇인지 확실하지 않습니까? 사용자 수준을 확인하려면 사이트의 오른쪽 위에서 자신의 이니셜이나 프로필 이미지가 있는 아이콘을 선택하고 내 계정 설정을 선택합니다. 사이트 역할에서 자신이 Creator, Explorer 또는 Viewer(뷰어)인지 알 수 있습니다.

1단계: 로그인 및 프로젝트 탐색

시작하려면 사용자 이름 및 암호를 입력하여 Tableau 사이트에 로그인합니다. 그런 다음 탐색 패널에서 탐색을 클릭하여 사이트 전체에서 액세스 권한이 있는 모든 콘텐츠를 표시합니다.

처음에는 최상위 프로젝트가 표시됩니다. 이러한 프로젝트를 탐색하거나 다른 콘텐츠 유형을 선택할 수 있습니다.

Content type selection

통합 문서, 데이터 원본, 데이터 역할 및 흐름은 프로젝트에 속하며 프로젝트에는 중첩된 프로젝트가 포함될 수 있습니다. 바탕 화면의 폴더와 마찬가지로 프로젝트는 사이트의 콘텐츠를 정렬하고 관리하는 방법입니다. 기존 사이트에 초대된 경우 팀 멤버가 만든 프로젝트가 표시될 수 있습니다.

사이트에는 기본 프로젝트가 있으며 추가 프로젝트를 사용할 수 없는 경우 이 프로젝트를 탐색에 사용할 수 있습니다.

2단계: 새 통합 문서 만들기 및 데이터에 연결

데이터를 분석하고 통합 문서를 작성하려면 어떤 방식으로든 데이터에 연결해야 합니다. Creator는 웹에서 직접 데이터 원본에 연결하거나 Tableau Desktop을 통해 Tableau Online에 게시된 데이터 원본에 연결할 수 있습니다.

시작하려면 만들기 단추를 클릭하고 통합 문서를 선택합니다.

Creat Workbook button

데이터에 연결 창이 나타납니다.

Animation of Connect to Data window

다음과 같은 여러 방법으로 통합 문서의 기반이 되는 데이터에 연결할 수 있습니다.

  • Excel 또는 텍스트 기반 데이터 원본 업로드 - 파일 탭 사용

  • 서버 또는 클라우드 데이터 원본에 연결 - 커넥터 탭 사용

  • 게시된 데이터 원본에 연결 - 이 사이트 기반 탭 사용

  • Tableau Online의 대시보드 스타터 탭에서 Oracle Eloqua, Salesforce, ServiceNow ITSM 및 Marketo의 데이터를 빠르게 작성하고 분석

웹의 데이터에 연결하는 것에 대해 자세히 알아보려면 Creator: 웹에서 데이터에 연결을 참조하십시오.

3단계: 데이터 준비

데이터에 연결되면 데이터 원본 페이지를 사용하여 분석에 사용할 데이터를 준비합니다.

데이터 원본 페이지의 구성

데이터 원본 페이지는 네 개의 영역으로 구성되어 있습니다. 

  1. 왼쪽 패널: 데이터에 대한 세부 정보를 표시합니다. 파일 기반 데이터인 경우 왼쪽 패널에 파일 이름과 파일의 워크시트가 표시될 수 있습니다. 관계형 기반 데이터인 경우 왼쪽 패널에 서버, 데이터베이스 또는 스키마와 데이터베이스의 테이블이 표시될 수 있습니다.

  2. 캔버스: 대부분의 관계형 데이터와 파일 기반 데이터에 연결한 경우 하나 이상의 테이블을 캔버스 영역에 끌어 놓아 분석에 사용할 Tableau 데이터 원본을 설정할 수 있습니다.

  3. 데이터 그리드: 데이터 그리드를 사용하면 Tableau 데이터 원본에 포함된 필드와 데이터의 첫 1,000개 행을 검토할 수 있습니다.

  4. 메타데이터 그리드: 이 단추를 사용하면 데이터 원본의 필드가 행으로 표시되어 데이터 원본의 구조를 파악할 수 있는 메타데이터 그리드가 표시됩니다.

데이터 원본 페이지에서 다음과 같은 방법으로 분석에 사용할 데이터를 준비할 수 있습니다. 

  • 데이터 원본 이름 바꾸기

  • 데이터 해석기를 사용하여 데이터 지우기

  • 텍스트 파일 옵션 설정

  • 데이터 조인

  • 데이터 열 편집

웹에서 분석에 사용할 데이터를 준비하는 것에 대해 자세히 알아보려면 Creator: 웹에서 데이터 준비를 참조하십시오.

분석에 사용할 데이터가 준비되었으면 화면 아래쪽에 있는 시트 1을 클릭하여 Tableau 작업 영역으로 이동하고 뷰를 작성합니다.

4단계: 뷰 작성

데이터에 연결하고 분석에 사용할 수 있도록 설정했습니다. 이제 데이터의 시각적 분석을 만들 준비가 되었습니다. Tableau에서는 이러한 시각적 분석을 라고 합니다. Tableau Desktop을 사용한 적이 있다면 작업 영역이 매우 익숙할 것입니다.

작업 영역

Tableau 작업 영역의 레이아웃은 다음과 같습니다.

  1. 통합 문서 이름. 통합 문서에는 시트가 포함되어 있습니다. 시트는 워크시트, 대시보드 또는 스토리일 수 있습니다. 자세한 내용은 통합 문서 및 시트를 참조하십시오.

  2. 페이지 선반, 필터 선반, 마크 카드 - 작업 영역의 카드 및 선반으로 필드를 끌어 놓아 뷰에 데이터를 추가합니다. 자세한 내용은 선반 및 카드를 참조하십시오.

  3. 열 및 행 선반 - 작업 영역의 카드 및 선반으로 필드를 끌어 놓아 뷰에 데이터를 추가합니다. 자세한 내용은 선반 및 카드를 참조하십시오.

  4. 툴바 - 툴바를 사용하여 명령과 분석 및 탐색 도구에 액세스합니다. 자세한 내용은 Tableau 툴바 단추 참조를 참조하십시오.

  5. - 데이터 비주얼리제이션을 만들 수 있는 작업 영역입니다.

  6. 사이드 바 - 워크시트에서 사이드 바 영역에는 데이터 패널 및 분석 패널이 포함됩니다.

  7. 데이터 원본 페이지로 이동합니다. 자세한 내용은 Creator: 웹에서 데이터 준비를 참조하십시오.

  8. 시트 탭 - 탭은 통합 문서의 각 시트를 나타냅니다. 이 탭에는 워크시트, 대시보드 및 스토리가 포함될 수 있습니다.

뷰 작성을 시작하는 다양한 방법

필드를 뷰나 선반에 끌어 놓을 때마다 해당 데이터에 대한 질문을 하게 됩니다. 질문은 다양한 필드를 끌어 놓는 위치, 필드 유형 및 뷰에 필드를 끌어 놓는 순서에 따라 달라집니다.

질문을 할 때마다 뷰가 변경되어 답을 시각적으로 표시합니다. 이 과정에서 마크(모양, 텍스트, 계층, 테이블 구조, 축, 색상)가 사용됩니다.

워크시트에서 데이터 원본의 열은 데이터 패널 왼쪽에 필드로 표시됩니다. 데이터 패널에는 다양한 종류의 필드가 포함됩니다. 지금은 차원측정값이 가장 중요한 필드입니다.

일반적으로 차원에는 제품 유형, 날짜 등의 범주형 데이터가 포함되고 측정값에는 매출, 수익 등의 숫자 데이터가 포함됩니다. (자세한 내용은 필드 유형: 차원 및 측정값, 파란색 및 녹색을 참조하십시오.)

뷰를 작성할 때는 데이터 패널의 필드를 추가합니다. 이 작업은 여러 가지 방법으로 수행할 수 있습니다. 예를 들면 다음과 같습니다.

  • 데이터 패널에서 필드를 끌어와 모든 Tableau 워크시트에 포함되는 카드 및 선반에 놓습니다.

  • 데이터 패널에서 하나 이상의 필드를 두 번 클릭합니다.

  • 데이터 패널에서 하나 이상의 필드를 선택하고 선택한 필드에 해당하는 차트 유형을 식별하는 표현 방식에서 차트 유형을 선택합니다. 자세한 내용은 표현 방식을 참조하십시오.

데이터 필터링

데이터를 필터링하여 뷰에 특정 양의 데이터만 표시하고 싶을 수 있습니다. 이러한 경우 다양한 방법으로 데이터를 필터링할 수 있습니다.

필터 선반에 필드를 추가하면 뷰에 대화형 필터가 나타납니다. 그런 다음 뷰에 포함하거나 제외할 항목을 선택할 수 있습니다.

  • 웹에서 Tableau를 사용하여 필터를 만들려면 차원, 측정값 또는 날짜 필드를 필터 선반에 끌어 놓습니다.

    필터 선반에 필드를 추가하면 뷰에 대화형 필터가 나타납니다. 뷰에서 포함하거나 제외할 항목을 선택하거나 값 범위를 선택할 수 있습니다.

  • 단일 마크(데이터 요소)를 선택하여 게시된 뷰에서 상호 작용하거나 뷰에서 클릭하고 끌기로 여러 마크를 선택할 수 있습니다. 도구 설명이 나타나면 '이 항목만 유지'를 선택하여 뷰에서 선택한 마크만 유지하거나 '제외'를 선택하여 뷰에서 선택한 마크를 제거합니다.

Tableau 작업 순서를 비롯하여 Tableau의 필터링에 대한 자세한 내용은 뷰에서 데이터 필터링을 참조하십시오.

마크 카드 사용

마크 카드를 사용하여 뷰의 마크에 컨텍스트 및 세부 정보를 추가할 수 있습니다. 마크 카드를 사용하여 마크 유형을 설정하고 색상, 크기, 모양, 세부 정보 및 텍스트로 데이터를 인코딩합니다.

필드를 마크 카드에 추가한 후 필드 옆에 있는 아이콘을 클릭하여 마크가 사용 중인 속성을 변경할 수 있습니다. 마크 카드에서 속성 단추를 클릭하여 이러한 설정을 변경할 수도 있습니다.

필드를 여러 개 가진 속성이 많이 있습니다. 예를 들어 레이블, 세부 정보, 도구 설명 및 색상에 여러 필드를 추가할 수 있습니다. 크기 및 모양은 필드를 한 번에 하나만 가질 수 있습니다. 자세한 내용은 마크 속성 참조를 참조하십시오.

작업 실행 취소

Tableau는 매우 유연하며 전혀 까다롭지 않습니다. 뷰를 작성할 때 질문에 대한 답을 얻지 못하는 경로인 경우 언제라도 실행 취소하여 이전 탐색 지점으로 되돌릴 수 있습니다.

  • 실행 취소하거나 다시 실행하려면 툴바에서 실행 취소 또는 다시 실행 을 클릭합니다.

통합 문서를 연 마지막 시점까지 모든 작업을 실행 취소할 수 있습니다. 원하는 만큼 실행 취소하거나 다시 실행할 수 있습니다.

웹에서 뷰 작성 및 편집

Tableau에서 여러 가지 방법으로 데이터를 탐색할 수 있습니다. 웹에서 특정 차트 유형을 작성하는 것에 대한 지침은 웹에서 Tableau 뷰 편집을 참조하십시오. Tableau에서 비주얼리제이션을 작성하는 데 도움이 되는 다양한 기능에 대해 자세히 알아보려면 데이터 뷰 작성 및 탐색을 참조하십시오.

데이터 뷰 작성에 대한 6분간의 단계별 안내를 보려면 Getting Started with Visual Analytics(시각적 분석 시작하기) 무료 교육 동영상을 시청하십시오. tableau.com 계정을 사용하여 로그인합니다.

5단계: 작업 프레젠테이션

뷰에서 발견한 데이터에 대한 심층 정보를 스토리로 만들거나 다른 사용자에게 설득할 수 있는 여러 가지 방법이 있습니다.

작업 서식 지정

뷰 요소, 통합 문서 글꼴, 그래프 라인 등을 비롯하여 통합 문서에 표시되는 거의 모든 항목에 서식을 지정할 수 있습니다.

대시보드

대시보드란 다양한 데이터를 동시에 비교하고 모니터링할 수 있도록 단일 공간에 표시된 여러 워크시트 및 지원 정보 모음입니다.

새 대시보드 시트를 열고 대시보드를 만들려면 통합 문서 맨 아래에 있는 새 대시보드 아이콘을 클릭합니다.

왼쪽에 대시보드 영역이 나타나고 통합 문서의 시트가 나열됩니다. 대시보드에 하나 이상의 뷰를 추가하거나, 웹 페이지, 빈 공간, 레이아웃 컨테이너 같은 개체를 추가하거나, 시트에서 다양한 뷰를 대화식으로 연관시킬 수 있습니다.

스토리

스토리는 정보를 전달하기 위해 함께 사용되는 일련의 워크시트와 대시보드를 포함하는 시트입니다. 스토리를 사용하여 팩트가 어떻게 연결되는지를 보여 줌으로써 사례를 보다 매력적으로 구성할 수 있으며, 데이터를 설명하거나, 컨텍스트를 제공하거나, 의사 결정과 결과의 관계를 보여주거나, 설득력 있는 사례를 구성하는 스토리를 만들 수 있습니다.

스토리 만들기 또는 스토리에 대해 자세히 알아보기를 참조하십시오.

6단계: 작업 저장

언제든지 파일 > 다른 이름으로 저장을 선택하여 통합 문서를 저장할 수 있습니다. 통합 문서는 통합 문서를 만든 폴더에 저장됩니다.

데이터 원본을 저장하여 나중에 다른 통합 문서를 만들거나 팀 멤버가 고유한 분석을 위해 해당 데이터를 사용하게 만들 수도 있습니다.

데이터 원본을 저장하려면 작업 영역의 데이터 탭에서 화살표가 나타날 때까지 데이터 원본 이름을 마우스오버합니다. 화살표를 선택하고 저장을 선택합니다.

참고: 웹에서 데이터 원본을 저장하면 데이터에 연결 창과 데이터 원본 섹션에 게시된 데이터 원본으로 나타납니다.

마쳤으면 파일 > 닫기를 선택하여 작업 영역을 종료합니다.

7단계: 협업 및 결과 공유

작업을 공유하고 최신 상태를 유지하는 여러 방법이 있습니다.

협업

조직의 다른 Creator 또는 Explorer는 프로젝트에 대한 액세스 권한이 부여된 경우 사용자의 통합 문서 및 뷰를 편집하거나 업데이트할 수 있습니다. 액세스 권한은 사이트 관리자가 제어하며, 사이트 관리자는 프로젝트 사용 권한을 설정하고, 프로젝트 간에서 콘텐츠를 이동하고, 사용자의 역할을 변경할 수 있습니다. 데이터 원본을 저장하면 권한이 있는 사용자가 데이터에 연결하고 이를 사용하여 새 통합 문서를 만들 수 있습니다.

뷰 및 심층 정보 공유

사이트에 저장된 모든 뷰 또는 통합 문서는 이메일 및 기타 응용 프로그램의 링크를 통해 공유하거나, 웹 페이지, Wiki 및 웹 응용 프로그램에 직접 내장할 수 있습니다.

뷰를 보려면 사용자에게 Tableau Server 또는 Tableau Online에서 해당 뷰에 액세스할 수 있는 사용 권한이 있어야 합니다.

방법 알아보기:

피드백을 제공해 주셔서 감사합니다! 피드백을 제출하는 동안 오류가 발생했습니다. 다시 시도하거나 메시지를 보내주십시오.