连接到数据

注意:从版本 2020.4.1 开始,您现在可以在 Tableau ServerTableau Online 中创建和编辑流程。除非特别指出,本主题中的内容适用于所有平台。有关在 Web 上制作流程的详细信息,请参见Web 上的 Tableau Prep

Tableau Prep 支持连接到常用类型的数据,以及 Tableau 数据提取 (.hyper) 和已发布数据源。

如果有启用了 Tableau Catalog 的数据管理加载项(Link opens in a new window),您还可以搜索并连接到存储在 Tableau Server 或 Tableau Online 上的数据库和表。有关 Tableau Catalog 的详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“关于 Tableau Catalog”。

每个新版本的 Tableau Prep 都添加了新的数据连接器。但是,根据您正在使用的版本或是否在 Web 上创建和编辑流程,某些连接器可能不可用。若要查看最新的可用连接器列表,请打开 Tableau Prep Builder 或在 Web 上启动流程,并单击“添加连接” 按钮,确定适用于您的数据的连接器是否列在左侧窗格中的“连接”下。

注意:如果在连接器不受支持的版本中打开流程,流程可能会打开,但是,除非移除了数据连接,否则流程可能会出现错误或无法运行。

虽然大多数连接器的工作方式在所有平台上都相同,但有些连接器在 Tableau Prep 中使用它们时有不同的要求,本主题对此进行说明。对于所有其他连接器,请参见 Tableau Desktop 帮助中的支持的连接器(Link opens in a new window)

启动或打开流程

通过连接到数据启动新流程,就像在 Tableau Desktop 中一样。您也可以打开一个现有流程,并选择在何处停止。

注意:某些连接器可能会要求您下载并安装驱动程序,然后才能连接到数据。请参见 Tableau 网站上的驱动程序下载(Link opens in a new window)页面获取驱动程序下载链接以及安装说明。

Tableau Prep Builder 中,您可以直接在开始页面上查看和访问最近的流程,因此可以轻松地找到正在进行的工作。在 Web 上处理流程时,所有流程都方便地列在“浏览”页面的“所有流程”菜单下。

连接到数据之后,在输入步骤中使用不同的选项来确定要在流程中处理的数据。然后添加清理步骤或其他步骤类型来检查、清理和调整数据。

当您的流程包含许多不同的数据源连接器时,Tableau Prep 可帮助您轻松查看哪些连接器和表与输入步骤关联。单击“输入”步骤时,关联的连接器和数据表会在“连接”窗格中突出显示。此选项是 Tableau Prep Builder 版本 2020.1.1 中新增的,在 Web 上编辑流程时也受支持。

开始新流程

  1. 打开 Tableau Prep Builder 并单击“添加连接” 按钮。

    在 Web 制作中,从“主页”中单击“创建”>“流程”,或从“浏览”页面中单击“新建”>“流程”。然后单击“连接到数据”

  2. 从连接器列表中,选择文件类型或托管您的数据的服务器。如果出现提示,请输入所需的信息以登录并访问数据。

    注意:在 Web 制作中,文件连接器列表可能不同。

  3. “连接”窗格中,执行以下操作之一:

    • 如果连接到文件,请双击表或将表拖到“流程”窗格以开始流程。对于单个表,Tableau Prep 会在您将数据添加到流程时自动为您在“流程”窗格中创建输入步骤。

      注意:在 Web 制作中,对于文件连接,您一次只能下载一个文件。当前不支持直接到文件网络共享。

    • 如果连接到数据库,请选择数据库或架构,然后双击表或将表拖到“流程”窗格以开始流程。

      注意:在 Tableau Prep Builder 中,可以使用通配符搜索将输入步骤中的单个数据源中的多个文件或数据库表合并。 在 Web 制作中,您无法创建或编辑输入并集,但在从 Tableau Prep Builder 发布的流程中则支持它们。有关详细信息,请参见在输入步骤中合并文件和数据库表(Link opens in a new window)

打开现有流程

Tableau Prep Builder

“开始”页面中执行以下操作之一:

  • “最近的流程”下,选择一个流程。

  • 单击“打开流程”,导航到流程文件并将其打开。

您也可以单击“文件”>“新建”“文件”>“打开”打开新工作区。如果要同时处理多个流程,您可以使用这些选项打开多个 Tableau Prep Builder 工作区。在 Tableau Prep Builder 版本 2019.3.1 及更低版本中,如果选择“文件”> “打开”Tableau Prep Builder 会将当前打开的流程替换为您选择的新流程。

Web 上的 Tableau Prep

  1. 若要打开和编辑现有流程,请在“浏览”页面上从顶部下拉菜单中选择“所有流程”,然后从列表中选择流程。

  2. “流程概述”页面上,单击“编辑”以编辑流程。

    您的流程将在新选项卡中打开。一旦您开始进行更改,Tableau 就会每隔几秒钟自动保存一次更改,并将修改后的流程保存为草稿。草稿仅对您和管理员可见。

    完成后,可以关闭流程并稍后继续进行更改,或者发布流程以应用更改,从而创建流程的新版本。

    与其他工具一样,流程发布使用先入方法。如果其他用户在您之前修改并重新发布流程,则首先提交其更改。但是,您可以使用“修订历史记录”页面跟踪并还原到以前的版本。有关详细信息,请参见 Tableau Desktop 帮助中的处理内容修订(Link opens in a new window)

连接到发布的数据源

如果将数据源从 Tableau Prep Builder(版本 2019.3.1 及更高版本)发布到 Tableau ServerTableau Online,或者从 Tableau Desktop 中或从流程中以输出形式进行发布,您可以连接到这些发布的数据源,并将它们用作流程的输入数据源。在 Web 上创建或编辑流程时,您也可以连接到发布的数据源:

注意:在发布包括发布的数据源作为输入的流程时,系统会将发布者指派为默认流程所有者。当流程运行时,它将为“运行身份”帐户使用流程所有者。有关“运行身份”帐户的详细信息,请参见运行身份服务帐户(Link opens in a new window)。只有站点或服务器管理员才能在 Tableau ServerTableau Online 中更改流程所有者。

使用此功能时,以下要求适用:

  • 完全支持连接到 Tableau Server 版本 2019.3 及更高版本上可用的已发布数据源。如果连接到 Tableau Server 的早期版本上发布的数据源,则所有功能可能不可用。
  • 从版本 2020.4.1 开始,在 Web 上创建或编辑流程时,您可以连接到已发布的数据源。
  • 您必须在您登录到的 Tableau Server 站点中分配有 Explorer 或更高角色,才能连接到发布的数据源。只有 Creator 才能在 Web 上创建或编辑流程。有关站点角色的详细信息,请参见 Tableau Server 帮助中的设置用户的站点角色(Link opens in a new window)
  • 必须嵌入凭据才能连接到已发布的数据源。如果没有为数据源嵌入凭据,请更新数据源以包括嵌入的凭据。
  • 包含多维(多维数据集)数据或包含用户筛选器的已发布数据源当前不受支持。
  • 不支持多服务器连接。必须使用相同的服务器或站点连接来执行以下操作:
    • 连接到发布的数据源。
    • 将流程输出发布到 Tableau ServerTableau Online
    • 计划流程以在 Tableau ServerTableau Online上运行。

若要连接到已发布数据源,请按照 Tableau Prep 版本的说明进行操作:

Tableau Prep Builder 版本 2020.2.1 及更高版本
  1. 打开 Tableau Prep Builder 并单击“添加连接” 按钮。

  2. 从连接器列表中,选择“Tableau Server”

  3. 登录以连接到服务器或站点。

  4. 选择数据源或使用搜索选项查找数据源,并将其拖到流程窗格以启动流程。“输入”窗格中的“Tableau Server”选项卡显示有关已发布数据源的详细信息。

Tableau Prep Builder 版本 2020.2.2 及更高版本以及在 Web 上

您可以直接从“连接”窗格连接到存储在 Tableau Server 或 Tableau Online 上的已发布数据源及更多数据源。如果有启用了 Tableau Catalog 的数据管理加载项(Link opens in a new window),则还可以搜索和连接到数据库和表,以及查看或按有关数据源的元数据(例如说明、数据质量警告和认证)进行筛选。

有关 Tableau Catalog 的详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“关于 Tableau Catalog”。

  1. 打开 Tableau Prep Builder 并单击“添加连接” 按钮。

    在 Web 制作中,从“主页”中单击“创建”>“流程”,或从“浏览”页面中单击“新建”>“流程”。然后单击“连接到数据”

  2. “连接”窗格上的“搜索数据”下,选择“Tableau Server”

  3. 登录以连接到服务器或站点。

    在 Web 制作中,“搜索数据”对话框将针对您登录的服务器打开。

  4. “搜索数据”对话框中,从可用已发布数据源的列表中进行搜索。使用筛选器选项按连接类型和认证数据源进行筛选。

  5. 选择要使用的数据源,然后单击“连接”

    如果您没有连接到数据源的权限,则行和“连接”按钮显示为灰色。

    注意:如果没有启用了 Tableau Catalog 的数据管理加载项,则不会显示“内容类型”下拉列表。列表中只会显示已发布数据源。

  6. 数据源已添加到“流程”窗格中。在“连接”窗格中,您可以选择其他数据源或使用搜索选项查找数据源,并将其拖到流程窗格以构建流程。“输入”窗格中的“Tableau Server”选项卡显示有关已发布数据源的详细信息。

  7. (可选)如果有启用了 Tableau Catalog 的数据管理加载项,请使用“内容类型”下拉列表来搜索数据库和表。

    您可以使用右上角的筛选器选项按连接类型、数据质量警告和认证来筛选结果。

连接到云数据源

您可以在 Tableau Prep 中像 Tableau Desktop 那样连接到云数据源,但如果计划发布连接到云数据源的流程并在服务器中按计划运行这些流程,则需要在 Tableau ServerTableau Online 中配置凭据。

您可以在“我的帐户设置”页面的“设置”选项卡中设置凭据,然后使用这些相同的凭据连接到云连接器输入。

Tableau Prep Builder

发布流程时,在“发布”对话框上单击“编辑”以编辑连接,然后在“身份验证”下拉列表中,选择“嵌入”<您的凭据>。

发布流程时,您还可以通过发布对话框(Tableau Prep Builder 版本 2020.1.1)直接添加凭据,然后在发布时自动将它们嵌入到流程中。有关详细信息,请参见从 Tableau Prep Builder 中发布流程

如果尚未设置已保存的凭据并在“身份验证”下拉列表中选择 “提示用户”,则在发布流程后,您必须编辑连接并在Tableau ServerTableau Online 中的“连接”选项卡中输入凭据,否则流程将在运行时失败。

Web 上的 Tableau Prep

在 Web 制作中,可以从顶部菜单中的“文件”>“连接凭据”下嵌入凭据。 有关详细信息,请参见在 Web 制作中发布流程

Tableau Prep Builder 版本 2019.4.1 中,添加了以下云连接器,在 Web 上创建或编辑流程时也可用:

  • Box
  • DropBox
  • Google Drive
  • OneDrive

有关如何使用这些连接器连接到数据的详细信息,请参见 Tableau Desktop 帮助中特定于连接器(Link opens in a new window)的帮助主题。

连接到 Salesforce 数据

就像 Tableau Desktop 一样,Tableau Prep Builder(版本 2020.2.1 及更高版本以及在 Web 上)支持使用 Salesforce 连接器来连接到数据,但有几点不同。

  • Tableau Prep Builder 支持您要执行的任何联接类型。
  • 当前不支持自定义 SOQL。
  • 当前不支持使用标准连接创建自己的自定义连接。
  • 不能将默认数据源名称更改为唯一名称或自定义名称。
  • 如果计划将在 Tableau Server 上发布流程并希望使用已保存的凭据,则服务器管理员必须使用 OAuth 客户端 ID 和连接器上的密文配置 Tableau Server。有关详细信息,请参见 Tableau Server 帮助中的将 Salesforce.com OAuth 更改为使用已保存凭据(Link opens in a new window)
  • 若要对使用 Salesforce 连接器的流程输入运行增量刷新,您必须使用 Tableau Prep Builder 版本 2021.1.2 或更高版本。有关使用增量刷新的详细信息,请参见使用增量刷新来刷新流程数据

Tableau Prep 通过创建数据提取来导入数据。Salesforce 当前仅支持数据提取。初始数据提取可能需要一些时间,具体取决于包含的数据量。在加载数据时,您将在“输入”步骤中看到计时器。

有关使用 Salesforce 连接器的详细信息,请参见 Tableau Desktop 和 Web 制作帮助的 Salesforce(Link opens in a new window)

连接到 Google BigQuery

Tableau Prep Builder(版本 2019.3.1 及更高版本)和 Web 上,支持使用 Google BigQuery 连接到数据,就像 Tableau Desktop 一样。

您必须配置 OAuth 凭据,使 Tableau Prep 能够与 Google BigQuery 通信。如果打算将流程发布到 Tableau ServerTableau Online,还必须为这些应用程序配置 OAuth 连接。

注意:Tableau Prep 当前不支持使用 Google BigQuery 自定义属性。

配置 SSL 以连接到 Google BigQuery(仅限 MacOS)

如果您在 Mac 上使用 Tableau Prep Builder,并且正在使用代理连接到 Big Query,则可能需要修改 SSL 配置以连接到 Google BigQuery

注意:Windows 用户不需要执行额外的步骤。

若要为 Google BigQuery OAuth 连接配置 SSL,请完成以下步骤:

  1. 将代理的 SSL 证书导出到文件,例如 proxy.cer。您可以在Applications > Utilities > Keychain Access >System > Certificates (under Category)中找到您的证书。
  2. 找到用于运行 Tableau Prep Builder 的 java 版本。例如:/Applications/Tableau Prep Builder 2020.4.app/Plugins/jre/lib/security/cacerts

  3. 打开“终端”命令提示符,并针对您的 Tableau Prep Builder 版本运行以下命令:

    注意:keytool 命令必须从包含用于运行 Tableau Prep Builder 的 java 版本的目录中运行。在运行此命令之前,您可能需要更改目录。例如,cd /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder 2020.1.1/Plugins/jre/bin。然后运行 keytool 命令。

    keytool –import –trustcacerts –file /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder <version>/Plugins/jre/lib/security/cacerts -storepass changeit

    示例: keytool –import –trustcacerts –file /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder 2020.4.1/Plugins/jre/lib/security/cacerts -storepass changeit

如果在运行 keytool 命令时收到 FileNotFoundexception(拒绝访问),请尝试使用提升的权限运行该命令。 例如:sudo keytool –import –trustcacerts –file /Users/tableau_user/Desktop/SSL.cer -keystore Tableau Prep Builder 2020.4.1/Plugins/jre/lib/security/cacerts -storepass changeit

设置和管理您的 Google BigQuery 凭据

在“输入”步骤中用于连接到 Google BigQuery 的凭据必须与您在 Tableau ServerTableau Online 中适用于 Google BigQuery 的“我的帐户设置”页面的“设置”选项卡中设置的凭据匹配。

如果发布流程时在身份验证设置中选择不同的凭据或不选择凭据,则在 Tableau Server 或 Tableau Online 中编辑流程连接之前,该流程将失败。

若要编辑凭据,请执行以下操作:

  1. Tableau ServerTableau Online 中的“连接” 选项卡上,针对 Google BigQuery 连接单击“更多操作”
  2. 选择“编辑连接”
  3. 选择在“我的帐户设置”页面的“设置”选项卡中设置的已保存凭据。

有关设置和管理凭据的详细信息,请参见以下主题:

Tableau Desktop 和 Web 制作帮助中的管理您的帐户设置(Link opens in a new window)

从 Tableau Prep Builder 中发布流程(Link opens in a new window),了解有关发布流程时设置身份验证选项的信息。

查看和解决错误,了解有关在 Tableau ServerTableau Online 中解决连接器错误的信息。

连接到 SAP HANA

就像 Tableau Desktop 一样,Tableau Prep Builder(版本 2019.2.1 及更高版本以及在 Web 上)支持使用 SAP HANA 来连接到数据,但有几点不同。

使用在 Tableau Desktop 中使用的相同过程连接到数据库。有关详细信息,请参见SAP HANA(Link opens in a new window)。连接并搜索表之后,将表拖到画布上以开始构建流程。

不支持在 Tableau Prep 中打开流程时的变量和参数提示。相反,在“输入”窗格中,单击“变量和参数”选项卡并选择要使用的变量和操作数,然后从预设值列表中选择,或者输入自定义值来查询数据库并返回所需的值。

注意:从 Tableau Prep Builder(版本 2019.2.2)开始以及在 Web 上,您可以使用初始 SQL 来查询连接,并且,如果某个变量有多个值,您可以从下拉列表中选择所需的值。

也可以添加其他变量。单击“变量”部分中的加号按钮 并选择一个变量或操作数,然后输入自定义值。

注意:此连接器仅在 Tableau Server 版本 2019.2 及更高版本中受支持。如果在 Tableau Prep Builder 中创建使用此连接器的流程,并将流程发布到早期服务器版本,则您可以发布流程,但无法使用 Tableau Server 中的计划功能运行流程。作为替代,您可以使用命令行界面运行流程以使数据保持最新。有关如何通过命令行运行流程的详细信息,请参见通过命令行刷新流程输出文件(Link opens in a new window)有关版本兼容性的详细信息,请参见与 Tableau Prep 的版本兼容性(Link opens in a new window)

连接到空间文件和数据库(版本 2020.4.1 及更高版本)

您可以在 Tableau Prep Builder 中或在 Web 上创建或编辑渡海中时连接到空间文件和空间数据源。

Tableau Prep 支持以下连接类型:

  • 空间文件格式
    • Tableau Prep Builder:Esri Shapefile、Esri 文件地理数据库、KML、TopoJSON、GeoJSON、数据提取、MapInfo MID/MIF、TAB 文件和压缩的 shapefile。
    • Tableau ServerTableau Online:压缩的 shapefile、KML、TopoJSON、GeoJSON、Esri 文件地理数据库和数据提取。
  • 空间数据库(Amazon Redshift、Microsoft SQL Server、Oracle 和 PostgreSQL)。

还可以使用标准联接将空间表与非空间表合并,并将空间数据输出到数据提取 (.hyper) 文件。当前不支持 Tableau Prep 中地图视图早的空间函数、通过相交进行空间联接和可视化空间数据。

支持的清理操作

使用形状文件数据时,不支持某些清理操作。在使用形状文件数据时,Tableau Prep 中只有以下清理操作可用。

  • 筛选器:仅移除 Null 或未知值
  • 重命名字段
  • 复制字段
  • 仅保留字段
  • 移除字段
  • 创建计算字段

连接之前

在连接到空间文件之前,请确保以下文件在同一目录中:

  • Esri Shapefile:文件夹必须包含 .shp、.shx、.dbf 和 .prj 文件,以及 Esri shapefile 的 .zip 文件。
  • Esri 文件地理数据库:文件夹必须包含文件地理数据库的 .gdb 或者文件地理数据库的 .gdb 的 .zip。
  • KML 文件:文件夹必须包含 .kml 文件。(不需要其他文件。)
  • GeoJSON 文件:文件夹必须包含 .geojson 文件(不需要其他文件)。
  • TopoJSON 文件:文件夹必须包含 .json 或 .topojson 文件。(不需要其他文件。)

连接到空间文件

  1. 执行以下操作之一:

    • 打开 Tableau Prep Builder 并单击“添加连接” 按钮。
    • 打开 Tableau ServerTableau Online。从“浏览”菜单中,单击“”>“流程”
  2. 从连接器列表中,选择“空间文件”

    将为空间字段分配空间数据类型,并且无法更改。如果字段来自空间文件,则会为该字段分配默认字段名称“Geometry”。如果字段来自空间数据库,将显示数据库字段名称。如果 Tableau 无法确定数据类型,则该字段将显示为“Null”。

使用 ODBC 进行连接(Tableau Prep Builder 版本 2019.2.2 及更高版本)

注意:Web 制作尚不支持此连接器类型。

如果需要连接到“连接”窗格中未列出的数据源,您可以使用支持 SQL 标准并实现 ODBC API 的“其他数据库 (ODBC)”连接器连接到任何数据源。使用“其他数据库 (ODBC)”连接器连接到数据的工作方式与您在 Tableau Desktop 中使用该连接器的方式类似,但有一些不同之处:

  • 您只能使用 DSN(数据源名称)选项进行连接。

  • 若要在 Tableau Server 中发布并运行流程,必须使用匹配的 DSN 配置服务器。

    注意:目前不支持从包含“其他数据库 (ODBC)”连接器的命令行中运行流程。

  • Windows 和 MacOS 上的连接体验是一致的。不支持 ODBC 驱动程序 (Windows) 的提示连接属性。

  • Tableau Prep Builder 仅支持 64 位驱动程序。

连接之前

若要使用“其他数据库 (ODBC)”连接器连接到数据,您必须安装数据库驱动程序,并设置和配置 DSN(数据源名称)。若要将流程发布到 Tableau Server 并运行流程,也必须使用匹配的 DSN 配置服务器。

重要信息:Tableau Prep Builder 仅支持 64 位驱动程序。如果已设置并配置了 32 位驱动程序,则您可能需要将其卸载,然后安装 64 位版本(如果驱动程序不允许同时安装两个版本)。

  1. 使用 ODBC 数据源管理器(64 位) (Windows) 或 ODBC 管理器实用工具 (MacOS) 创建 DSN。

    如果 Mac 上未安装该实用工具,您可以下载一个(例如从 www.odbcmanager.net(Link opens in a new window) 下载),或者可以手动编辑 odbc.ini 文件。

  2. ODBC 数据源管理器(64 位)(Windows) 或 ODBC 管理器实用工具 (MacOS) 中,添加一个新数据源,然后选择适用于数据源的驱动程序,并单击“完成”

  3. “ODBC 驱动程序设置”对话框中,输入诸如服务器名称、端口、用户名和密码之类的配置信息。单击“测试”(如果对话框有该选项)验证您的连接是否设置正确,然后保存您的配置。

    注意:Tableau Prep Builder 不支持提示连接属性,因此您必须在配置 DNS 时设置此信息。

    此示例显示 MySQL 连接器的配置对话框。

使用“其他数据库 (ODBC)”进行连接

  1. 打开 Tableau Prep Builder 并单击“添加连接” 按钮。

  2. 从连接器列表中,选择“其他数据库 (ODBC)”

  3. “其他数据库 (ODBC)”对话框中,从下拉列表中选择一个 DSN,并输入用户名和密码。然后单击“登录”

  4. “连接”窗格中,从下拉列表中选择您的数据库。

使用连接器插件连接到基于 ODBC 和 JDBC 的数据(版本 2020.4.1 及更高版本)

注意:尚不支持使用 Connection Dialog v2 的连接器插件,并且连接到数据源的尝试将失败。有关 Connection Dialog v2 的详细信息,请参见 Tableau 连接器 SDK 中的使用 Connection Dialog V2 构建连接对话框(Link opens in a new window)

如果 Tableau Prep 未提供适用于您的数据的内置连接器时,您可以使用通过 Tableau 连接器 SDK 创建的连接器插件连接到基于 ODBC 和 JDBC 的数据。连接器插件在连接到数据(在 Tableau Prep Builder 上)以及在 Web 上(在 Tableau Server 中)受支持。

某些连接器需要安装额外的驱动程序。如果在连接过程中出现提示,请按照提示下载并安装所需的驱动程序。连接器插件当前不能与 Tableau Online 一起使用。

目录中的连接器插件

若要使用连接器插件,请下载连接器 .taco 文件,并将其添加到以下目录:

  • Tableau Prep Builder:
    • Windows:C:\用户\<Windows 用户>\文档\我的 Tableau Prep 存储库\Connectors
    • MacOS:/用户/<用户>/文档/我的 Tableau Prep 存储库/Connectors
  • Tableau Server(流程 Web 制作):<Tableau_Server 安装目录>/data/tabsvc/flowprocessor/Connectors
  • Tableau Server (Tableau Prep Conductor):<Tableau Server 安装目录>/data/tabsvc/flowprocessor/Connectors

有关使用连接器插件的一般信息,请参见 Tableau Desktop 帮助中的使用 Tableau 连接器 SDK 构建的连接器插件(Link opens in a new window)

使用自定义 SQL 连接到数据

如果您确切地知道数据库中需要的信息并了解如何编写 SQL 查询,可以使用自定义 SQL 查询连接到数据,就像在 Tableau Desktop 中一样。您可以使用自定义 SQL 跨表合并数据、重新转换字段以执行跨数据库联接、重构或减小数据大小以进行分析等。

  1. 连接到您的数据源,并在“连接”窗格的“数据库”字段中,选择一个数据库。

  2. 单击“自定义 SQL”链接以打开“自定义 SQL”选项卡。

  3. 键入查询或将查询粘贴到文本框中,然后单击“运行”以运行查询。

  4. 在流程窗格中添加一个清理步骤,以便仅将自定义 SQL 查询中的相关字段添加到流程中。

使用初始 SQL 查询连接

在 Tableau Prep Builder(版本 2019.2.2 及更高版本)和 Web 上,您可以指定一个初始 SQL 命令,该命令将在连接到支持它的数据库时运行。例如,在连接到 Amazon Redshift 时,您可以输入 SQL 语句,以便在连接到数据库时应用筛选器,就像在“输入”步骤中添加筛选器一样。SQL 命令将在数据抽样之前应用,并加载到 Tableau Prep 中。

从 Tableau Prep Builder(版本 2020.1.3)开始以及在 Web 上,还可以包括参数来传递应用程序名称、版本和流程名称数据,以在查询数据源时包括跟踪数据。

运行初始 SQL

若要刷新数据并运行初始 SQL 命令,请执行以下操作之一:

  • 更改初始 SQL 命令并通过重新建立连接刷新“输入”步骤。
  • 运行流程。初始 SQL 命令在处理所有数据之前运行。
  • 在 Tableau Server 或 Tableau Online 上运行流程。初始 SQL 在每次流程运行时加载数据的过程中

注意:需要数据管理加载项(Link opens in a new window)以在 Tableau ServerTableau Online 上按计划运行流程。有关 数据管理加载项 的详细信息,请参见使用数据管理加载项(Link opens in a new window)

  1. 在“连接”窗格的列表中选择一个支持初始 SQL 的连接器。
  2. 单击“显示初始 SQL”链接展开对话框,并输入您的 SQL 语句。

在初始 SQL 语句中包括参数

在 Tableau Prep Builder(版本 2020.1.3 及更高版本)以及在 Web 上,您可以将以下参数传递给数据源,以添加有关 Tableau Prep 应用程序、版本和流程名称的其他详细信息。当前不支持 TableauServerUserTableauServerUserFull 参数。

参数 说明 返回的值
TableauApp 用于访问数据源的应用程序。

Prep Builder

Prep Conductor

TableauVersion 应用程序版本号。

Tableau Prep Builder:返回确切的版本。例如 2020.4.1

Tableau Prep Conductor:返回已启用 Tableau Prep Conductor 的主要服务器版本。例如 2020.4

FlowName Tableau Prep Builder 中 .tfl 文件的名称 示例:Entertainment Data_Cleaned

使用 Data Interpreter 清理您的文件

处理 Microsoft Excel 文件时,您可以使用 Data Interpreter 来检测数据中的子表,以及移除无关信息来帮助准备数据进行分析。打开 Data Interpreter 时,它将检测这些子表,并将其列为“连接”窗格的“表”部分中的新表。然后,您可以将它们拖到“流程”窗格中。

如果关闭 Data Interpreter,则会从“连接”窗格中移除这些表。如果已在流程中使用了这些表,则会由于缺少数据而导致流程错误。

注意:当前 Data Interpreter 只会检测 Excel 电子表格中的子表,不支持为文本文件和电子表格指定起始行。此外,Data Interpreter 检测到的表不包括在通配符并集搜索结果中。

下面的示例显示在 “连接”窗格中对 Excel 电子表格使用 Data Interpreter 的结果。Data Interpreter 检测到两个额外的子表。

使用 Data Interpreter 之前 使用 Data Interpreter 之后

若要使用 Data Interpreter,请完成以下步骤:

  1. 选择“连接到数据”,然后选择“Microsoft Excel”

  2. 选择您的文件,并单击“打开”

  3. 选中“使用 Data Interpreter”复选框。

  4. 将新表拖到“流程”窗格以将其包括在流程中。若要移除旧表,请右键单击旧表的输入步骤,并选择“移除”

此部分中的其他文章

感谢您的反馈!