Wenn Sie eine Tableau-Visualisierung sehen, fragen Sie sich, welche Daten den einzelnen Markierungen oder sogar der gesamten Visualisierung zugrunde liegen? Eine typische Visualisierung besteht im Wesentlichen aus aggregierten Kennzahlen, die auf der Struktur der Dimensionen in der Ansicht basieren. Jeder Markierung, die Sie in einer Visualisierung sehen, liegen Spalten- und Zeilendaten zugrunde. Das Fenster für die Datenansicht zeigt diese Daten in einem Tabellenformat an, das sich auf die aktuelle Auswahl oder die aktuelle Ansicht bezieht.

Wenn Sie über die erforderlichen Berechtigungen verfügen, können Sie die zugrunde liegenden Daten in einem Arbeitsblatt, in Blättern eines Dashboards oder auf der Seite "Datenquelle" anzeigen. Im Arbeitsblatt können Sie das Fenster für die Datenansicht anpassen und diese angepasste Ansicht im CSV-Format herunterladen. Beachten Sie, dass die benutzerdefinierten Sortierergebnisse nicht in den heruntergeladenen Daten enthalten sind.

Standardmäßig zeigt das Fenster für die Datenansicht bis zu 10.000 Datenzeilen in Tableau Desktop und bis zu 200 Datenzeilen in Tableau Online und Tableau Server an.

Hinweis: Wenn Sie ab Tableau, Version 2020.2, eine Datenquelle aus Tableau, Version 2020.1, oder einer früheren Version öffnen, kann die Spaltenreihenfolge abweichen. Spalten werden im Fenster für die Datenansicht möglicherweise unterschiedlich angezeigt und die Spaltenreihenfolge kann beim Exportieren in das CSV-Format abweichen. In Tableau, Version 2022.1, und höheren Versionen können Sie die Spaltenreihenfolge manuell anpassen, bevor Sie die Daten exportieren.

Diese Änderung der Art und Weise, wie die Spaltenreihenfolge im Fenster "Daten anzeigen" behandelt wird, ist erforderlich, um Beziehungen und logische Tabellen zu unterstützen. Wenn Sie Skripts verwenden, die von einer benutzerdefinierten Spaltenreihenfolge abhängen, empfehlen wir die Verwendung der Tableau-Erweiterungs-API für "Daten anzeigen", um zugrunde liegende Daten im CSV-Format herunterzuladen.

Hier können Sie das Fenster für die Datenansicht öffnen

Die Daten, die im Fenster für die Datenansicht angezeigt werden, variieren je nach Kontext, in dem Sie das Fenster öffnen.

Kontext Bereich Wie?

Arbeitsblatt: Ausgewählte Markierung oder Markierungen

Tableau Online, Tableau Server, Tableau Desktop

Wenn Sie in einem Arbeitsblatt eine oder mehrere Markierungen auswählen und dann "Daten anzeigen" aus dem QuickInfo-Menü wählen, werden die zugrunde liegenden Daten angezeigt, die sich auf die einzelne Markierung oder eine Gruppe von Markierungen beziehen.

Hinweis: Die Option Befehlsschaltflächen einbeziehen muss für QuickInfos ausgewählt sein, damit die Schaltfläche "Daten anzeigen" verfügbar ist.

Diese Ansicht kann angepasst und heruntergeladen werden.

Wählen Sie eine oder mehrere Markierungen in der Ansicht aus und wählen Sie dann im QuickInfo-Menü Daten anzeigen aus.

Datenquellenseite: Pro Tabelle

Tableau Online, Tableau Server, Tableau Desktop

Auf der Seite "Datenquelle" können Sie für jede in der Datenquelle aufgeführte Tabelle (linker Bereich) die Datenansicht öffnen.

Sie können Spalten in dieser Ansicht verschieben und sortieren, aber Sie können die Daten nicht herunterladen.

Wählen Sie "Daten anzeigen" neben einer Tabelle im linken Bereich der Seite "Datenquelle".

Sie können das Fenster für die Datenansicht für benutzerdefinierte SQL auch anzeigen, indem Sie im Dialogfeld "Benutzerdefiniertes SQL" auf Ergebnisvorschau klicken.

Arbeitsblatt: Schaltfläche "Herunterladen" in der Symbolleiste

Tableau Online und Tableau Server

Wenn Sie in einem Arbeitsblatt (im Anzeige- oder Bearbeitungsmodus) Daten aus dem Menü der Schaltfläche "Herunterladen" auswählen, werden alle zugrunde liegenden Daten angezeigt, die in einer Visualisierung verwendet werden.

In einem Dashboard können die zugrunde liegenden Daten auf der Grundlage des ausgewählten Arbeitsblatts angezeigt werden. Wählen Sie ein Blatt im Dashboard aus, bevor Sie auf die Schaltfläche "Herunterladen" klicken, damit die Option "Daten" verfügbar ist.

Diese Ansicht kann angepasst und heruntergeladen werden.

Wählen Sie im Menü der Schaltfläche "Herunterladen" die Option Daten.

Arbeitsblatt: Datenbereich

Nur Tableau Desktop

Wenn Sie in einem Arbeitsblatt oben im Datenbereich die Option "Daten anzeigen" wählen, werden tabellarische Daten für jedes Feld in der Datenquelle, aufgelistet nach Tabellen, angezeigt.

Diese Ansicht kann angepasst und heruntergeladen werden.

Klicken Sie im Datenbereich neben dem Suchfeld auf die Schaltfläche "Daten anzeigen".

Arbeitsblatt: Menü "Analyse"

Nur Tableau Desktop

Wenn Sie in einem Arbeitsblatt die Option "Daten anzeigen" aus dem Menü "Analyse" auswählen, werden alle zugrunde liegenden Daten angezeigt, die in einer Visualisierung verwendet werden. Die entsprechende(n) Tabelle(n) für die in der Visualisierung verwendeten Kennzahlen sind im Bereich "Registerkarten" aufgeführt.

Diese Ansicht kann angepasst und heruntergeladen werden.

Wählen Sie im Menü "Analyse" die Option Daten anzeigen aus.

Bei Visualisierungen, die keine Texttabellen sind, können Sie auch mit der rechten Maustaste auf die Ansicht klicken und dann Daten anzeigen auswählen.

Öffnen von "Daten anzeigen" in einem Arbeitsblatt

Wenn Sie die Datenansicht in einem Arbeitsblatt öffnen, können Sie die Anzeige des Fensters für die Datenansicht anpassen und diese angepasste Ansicht herunterladen.

Das Fenster für die Datenansicht zeigt mehrere Registerkarten auf der linken Seite des Fensters an. Die Anzahl der Registerkarten und die Art der Registerkarten hängen vom aktuellen Bereich ab.

  • Auf der Registerkarte Zusammenfassung werden die Dimensionen angezeigt, die die Ansicht definieren, sowie die aggregierte(n) Kennzahl(en), die die Markierung bildet bzw. bilden.
  • Eine Registerkarte für jede Tabelle, aus der eine Kennzahl in der Ansicht vorhanden ist, auf der alle Felder aus dieser Tabelle angezeigt werden. Die Registerkarte Vollständige Daten wird für einzelne Tabellendatenquellen angezeigt.
    Um alle Felder anzuzeigen, wählen Sie (Alle) unter Felder anzeigen aus. Wenn (Alle) ausgewählt ist, werden auf jeder Registerkarte auch alle Dimensionen angezeigt, welche die Ansicht definieren, unabhängig davon, aus welcher Tabelle sie stammen.
  • Feldnamen werden als Spaltenüberschriften angezeigt. Bewegen Sie den Mauszeiger in die Nähe des oberen Rands einer Spalte, um das Dropdown-Menü und die Schaltfläche "Sortieren" anzuzeigen. Sie können auch irgendwo in eine Spaltenüberschrift klicken, um das Dropdown-Menü anzuzeigen.
  • Einige in der Ansicht verwendete Berechnungen können auch auf Registerkarten angezeigt werden:
    • Nicht zu einer Tabelle im Datenbereich gehörende Berechnungen, etwa aggregierte Berechnungen oder Berechnungen, die Tabellen umfassen.
    • LOD-Berechnungen (nur FIXED oder INCLUDE), auch wenn sie sich in einer Tabelle im Datenbereich befinden. Ad-hoc-LOD-Berechnungen werden in "Daten anzeigen" nicht angezeigt.
    • Neben dem Wert der Berechnung an sich werden alle in der Berechnung verwendeten relevanten Felder angezeigt, unabhängig von der zugehörigen ursprünglichen Tabelle.

Öffnen von "Daten anzeigen" in einer Visualisierung für eine oder mehrere Markierungen

Klicken Sie auf eine Markierung, um ihre QuickInfo anzuzeigen. Klicken Sie im QuickInfo-Menü auf das Symbol "Daten anzeigen" . Sie können auch mehrere Markierungen gleichzeitig auswählen und dann im QuickInfo-Menü auf "Daten anzeigen" klicken, um die kombinierten Ergebnisse von "Daten anzeigen" anzuzeigen.

Hinweis: Die Option Befehlsschaltflächen einbeziehen muss für QuickInfos in der Visualisierung ausgewählt sein, damit die Schaltfläche "Daten anzeigen" verfügbar ist.

Öffnen von "Daten anzeigen" für die gesamte Ansicht

Tableau Online und Tableau Server

Um die zugrunde liegenden Daten für die gesamte Ansicht im Anzeige- oder Bearbeitungsmodus anzuzeigen, klicken Sie in der Symbolleiste auf die Schaltfläche Herunterladen und wählen Sie dann Daten aus. Stellen Sie sicher, dass in der Ansicht keine Markierungen ausgewählt sind, andernfalls werden die Daten auf Ihre Auswahl beschränkt.

In einem Dashboard können die zugrunde liegenden Daten auf der Grundlage des ausgewählten Arbeitsblatts angezeigt werden. Wählen Sie ein Blatt im Dashboard aus, bevor Sie auf die Schaltfläche "Herunterladen" klicken, damit die Option "Daten" verfügbar ist.

Tableau Desktop

Um die zugrunde liegenden Daten für die gesamte Ansicht anzuzeigen, wählen Sie Daten anzeigen im Menü Analyse aus. Das Fenster "Daten anzeigen" wird mit ähnlichen Ergebnissen für die Anzeige von Daten für eine Markierung angezeigt, aber stattdessen zeigt es alle Daten an, die in der Ansicht verwendet werden.

Öffnen von "Daten anzeigen" für den Datenbereich

Um die zugrundeliegenden Daten für jedes Feld in der Datenquelle, aufgelistet nach Tabellen, anzuzeigen, klicken Sie auf das Symbol "Daten anzeigen" oben im Datenbereich neben dem Suchfeld.

Sie können "Daten anzeigen" für den Datenbereich nur in Tableau Desktop öffnen.

Öffnen von "Daten anzeigen" auf der Datenquellenseite

Das Fenster "Daten anzeigen" kann pro Tabelle für die Datenquelle geöffnet werden. Das Anzeigen von Daten für die Datenquelle vor oder während der Analyse kann nützlich sein, um Ihnen einen Eindruck vom Umfang der einzelnen Tabellen, ihren Feldern und deren Werten sowie einen allgemeinen Eindruck von den Daten zu vermitteln.

Wenn Sie "Daten anzeigen" auf der Datenquellenseite öffnen, können Sie die Feldspalten im Fenster "Daten anzeigen" verschieben und sortieren, aber Sie können die Daten nicht herunterladen.

Zeigen Sie auf der Datenquellenseite mit der Maus auf eine Tabelle oder ein Blatt im linken Bereich, um das Symbol "Daten anzeigen" anzuzeigen. Klicken Sie dann auf das Symbol.

Im Fenster "Daten anzeigen" werden die Daten für diese Tabelle angezeigt.

Anpassen des Fensters "Daten anzeigen"

Alle Anpassungsoptionen sind verfügbar, wenn Sie "Daten anzeigen" in einem Arbeitsblatt öffnen und werden für heruntergeladene Daten verwendet.

Die von Ihnen vorgenommenen Anpassungen bleiben bestehen, bis Sie das Fenster "Daten anzeigen" schließen. Durch Schließen des Fensters "Daten anzeigen" werden alle Anpassungen verworfen.

Hinweis: Auf der Datenquellenseite sind die Sortierung und das Verschieben von Feldern die einzigen verfügbaren Optionen für "Daten anzeigen".

 

Option Wie? Hierbei gilt

Feldspalten ein- oder ausblenden

Klicken Sie auf Felder anzeigen und aktivieren oder deaktivieren Sie einen Feldnamen. Um alle Felder anzuzeigen, wählen Sie (Alle).

Felder werden rechts neben den aktuell angezeigten Feldern hinzugefügt.

Feldspalten verschieben

Wählen Sie eine oder mehrere Feldspalten aus und klicken Sie dann auf den Rechts- oder Linkspfeil oben im Fenster. Oder wählen Sie das Dropdown-Menü aus und klicken Sie auf Nach rechts verschieben und Nach links verschieben.

Tipp: Um nicht benachbarte Spalten zu gruppieren, drücken Sie die Strg-Taste, während Sie die Spalten markieren, und verschieben Sie dann die markierten Spalten nach links oder rechts.

Feldspalten entfernen

Markieren Sie eine Feldspalte und wählen Sie dann aus dem Dropdown-Menü Entfernen aus. Oder klicken Sie auf Felder anzeigen und deaktivieren Sie das Feld, um seine Spalte zu entfernen.

Sortieren von Daten

Bewegen Sie den Mauszeiger in die Nähe des oberen Rands einer Spalte, um die Schaltfläche "Sortieren" anzuzeigen. Klicken Sie auf die Schaltfläche "Sortieren", um die Sortierung zu ändern.

Klicken Sie optional auf das Dropdown-Menü und wählen Sie Aufsteigend sortieren oder Absteigend sortieren aus.

Hinweis: Benutzerdefinierte Sortierergebnisse sind in den heruntergeladenen Daten nicht enthalten.

Die maximale Anzahl angezeigter Zeilen bearbeiten

Standardmäßig werden im Fenster "Daten anzeigen" die ersten 10.000 Datenzeilen in Tableau Desktop und die ersten 200 Datenzeilen in Tableau Online und Tableau Server angezeigt.

Sie können die maximale Anzahl der im Fenster "Daten anzeigen" angezeigten Zeilen erhöhen oder verringern. Diese Einstellung hat keine Auswirkung auf die Anzahl der exportierten Zeilen, wenn Sie auf die Schaltfläche Herunterladen klicken.

Klicken Sie in das Feld für die Anzahl der Zeilen, um es zu bearbeiten. Klicken Sie auf die Pfeilschaltfläche oder drücken Sie die Eingabetaste auf Ihrer Tastatur, um die Änderung zu übernehmen.

Aliase anzeigen

Klicken Sie auf die Schaltfläche Einstellungen, um Aliase für alle Feldnamen ein- oder auszublenden.

Herunterladen von Daten aus dem Fenster "Daten anzeigen"

Um alle Daten für die ausgewählte Registerkarte zu exportieren, klicken Sie auf die Schaltfläche Herunterladen.

Die Daten werden in eine CSV-Datei exportiert, wobei die aktuelle Konfiguration des Fensters "Daten anzeigen" verwendet wird und keine Beschränkung auf die Anzahl der derzeit im Fenster "Daten anzeigen" angezeigten Zeilen besteht.

Hinweis: Benutzerdefinierte Sortierergebnisse sind in den heruntergeladenen Daten nicht enthalten.

Nullwerte werden als leere Zeichenfolgen heruntergeladen.

Hinweis: Wenn Sie der Autor einer Arbeitsmappe sind und sicherstellen möchten, dass Ihre Zielgruppe die zugrunde liegenden Daten nicht kopieren oder herunterladen kann, sollten Sie ggf. die Befehlsschaltflächen in den QuickInfos deaktivieren(Link wird in neuem Fenster geöffnet) oder Arbeitsmappenberechtigungen(Link wird in neuem Fenster geöffnet) zum Download der Zusammenfassung oder vollständigen Daten verweigern.

Kopieren von Daten aus dem Fenster "Daten anzeigen"

Sie können Teile der Daten im Fenster "Daten anzeigen" kopieren, um sie in einem Arbeitsblatt oder in einer anderen Tableau-Arbeitsmappe (wirklich überall, wo Sie Text einfügen können) zu verwenden. NULL-Werte werden als leere Zeichenfolgen kopiert.

  • Wählen Sie die gewünschten Zellen aus und drücken Sie Strg+C (Windows) oder Befehlstaste+C (Mac) und fügen Sie die Daten dann in ein Arbeitsblatt, eine andere Tableau-Arbeitsmappe oder ein anderes Ziel Ihrer Wahl ein.

Hinweis: Wenn Sie sämtliche Werte in den zugrunde liegenden Daten herunterladen möchten, klicken Sie auf die Schaltfläche Herunterladen. Beim Auswählen und Kopieren einer Spalte werden nur Werte kopiert, die derzeit im Fenster "Daten anzeigen" geladen sind, und möglicherweise sind dann nicht alle Werte in den zugrunde liegenden Daten enthalten.

Warum kann das Symbol "Daten anzeigen" nicht angezeigt werden? 

Wenn Sie das Symbol "Daten anzeigen" für eine Markierung nicht finden können, überprüfen Sie, ob QuickInfos und Schaltflächen für das QuickInfo-Menü aktiviert sind. Insbesondere müssen die Optionen QuickInfos anzeigen und Befehlsschaltflächen einbeziehen für QuickInfos in der Visualisierung ausgewählt sein, damit die Schaltfläche "Daten anzeigen" in einer QuickInfo verfügbar ist. Klicken Sie alternativ mit der rechten Maustaste auf eine Markierung und wählen Sie Daten anzeigen aus dem Dropdown-Menü aus. Diese Methode funktioniert, wenn QuickInfos oder Befehlsschaltflächen nicht aktiviert sind.

Wenn Sie eine veröffentlichte Visualisierung betrachten und das Symbol "Daten anzeigen" für eine Markierung nicht finden können, kann es sein, dass die QuickInfos nicht aktiviert sind, dass die Befehlsschaltflächen für die QuickInfos deaktiviert wurden oder dass Sie nicht über die erforderlichen Berechtigungen verfügen.

Vielen Dank für Ihr Feedback!