管理 Tableau Bridge 的通知
已排程的重新整理可能因為各種原因而失敗。如果您是資料來源擁有者,務必多加注意這類失敗,以便排除任何問題並盡可能彌補資料新鮮度的落差。
如果站台管理員啟用通知,所有您擁有的資料來源發生重新整理失敗時,您就會收到通知。使用 Bridge 重新整理或 Bridge 舊計劃輔助資料來源重新整理時,會收到的通知類型、收到通知的時間以及您可以設定的通知將與 Tableau 通知不同。
如何接收 Bridge 通知
Bridge 作業失敗通知透過 Tableau 的統一通知平台傳遞,該平台為其他 Tableau 通知提供支援。以前,Bridge 僅透過電子郵件傳送這些通知。現在,除了電子郵件之外,有關 Bridge 作業失敗的通知(比如用戶端中斷連線、擷取重新整理失敗、準備流程失敗和虛擬連線失敗)會與其他 Tableau 通知一起顯示。
Bridge 通知會傳送給與電子郵件通知相同的受眾:網站管理員與資料來源擁有者。
接收這些通知不需要額外的設定。確保在一般通知偏好設定中選取 Tableau 核取方塊。
與 Bridge 通知的差異
超過超時限制時會傳送超時重新整理失敗電子郵件。與直接在 Tableau Cloud 上執行的重新整理不同,Bridge 重新整理會在 24 小時(預設)之後超時。但是,重新整理的超時限制可以經由站台管理員透過每個 Bridge 用戶端增加(或減少)。有關詳情,請參閱變更 Bridge 用戶端設定。
Bridge 相關的重新整理問題通知會傳送給特定接收者,具體取決於失敗類型:
RAS 失敗:這些通知與排程後重新整理 (RAS) 失敗相關,這表示作業已成功傳送至 Bridge 用戶端,但在用戶端電腦上處理期間或之後失敗。通知會僅傳送給資料來源擁有者。站台管理員不會收到這些通知。
- 重新整理作業失敗:擷取重新整理因下面列出的原因之外的原因而失敗(這是作業到達用戶端後發生的所有失敗的統稱)。
- Bridge 用戶端未執行: 連結到資料來源的 Bridge 用戶端未執行,但集區中的其他用戶端處於活動狀態時。
- 重新整理未完成:排程的重新整理在指定時間之後未完成。
邊緣集區失敗:這些通知與邊緣集區失敗相關,這意味著由於集區容量或用戶端可用性問題,排程的重新整理作業在傳送到 Bridge 用戶端之前未能執行。這些通知會傳送給資料來源擁有者和站台管理員。
- Bridge 集區已滿:資料擷取重新整理因為集區已滿而無法執行。
- Bridge 集區中沒有用戶端: 沒有向集區指派 Bridge 用戶端。
- Bridge 集區中沒有正在執行的用戶端: Bridge 用戶端已指派到集區,但目前沒有一個用戶端在執行。這包括集區中的單一用戶端未執行,或指派多個用戶端但全部處於非使用中狀態的情況。
針對特定的資料來源,Tableau Cloud 在第一天傳送的電子郵件中會包含前五個連續的重新整理相關失敗(亦即重新整理失敗,警是原因是用戶端未執行,或重新整理尚未完成)。如果資料來源在第一天之後繼續出現重新整理問題,Tableau Cloud 會每天傳送一封電子郵件。
資料來源擁有者可在一天內收到最多 10 封電子郵件,每個資料來源一封電子郵件,其中包含有效和連續的重新整理問題。一天的時間段是 24 個小時,從第一次重新整理問題時開始。
依賴於使用 Bridge 將資料保持為最新狀態的資料來源的檢視或工作簿不支援資料重新整理啟動的訂閱電子郵件。更多資訊,請參閱缺少訂閱電子郵件。
設定集區
由於Bridge 集區和負載平衡問題,資料擷取重新整理可能會失敗。站點管理員可以新增新集區或修改集區容量來設定和管理 Bridge 用戶端的集區。有關詳細資訊,請參閱設定集區和管理 Bridge 集區的大小。
在用戶端未執行時停止接收通知
預設情況下,Tableau Cloud 會在連結到擷取資料來源的 Bridge 用戶端並未執行而無法啟動排程重新整理時,向資料來源擁有者發出通知。
您可能會收到此電子郵件的原因主要有兩個:
執行用戶端的電腦未開機。
擷取資料來源會持續與不再使用的用戶端相關聯。
如果任何這些原因適用於您的情況:
確認 Bridge 用戶端是否正在執行,以及
如果您是站台管理員,請從站台中刪除未使用的用戶端。如果您不是網站管理員,則可以從用戶端中刪除資料來源。有關詳情,請參閱排程的重新整理似乎會未按排程執行:。
