控制视图中标记的外观

使用“标记”卡控制视图中标记的颜色、大小、形状、细节、文本和工具提示。将字段拖到“标记”卡上的按钮可对标记数据进行编码。单击“标记”卡上的按钮以打开“标记”属性。有关标记的相关信息,请参见更改视图中标记的类型“标记”卡

注意:“标记”卡上维度字段的顺序从上到下分层,并且会影响视图中的排序。Tableau 在视图中对标记进行排序时,首先考虑最上面的维度字段,然后考虑“标记”卡上其下方的维度。

为标记分配颜色

若要为视图中的标记分配颜色,请执行以下操作之一:

  • 在“标记”卡上单击“颜色”,然后从菜单中选择一种颜色。

    这会将视图中的所有标记更新为您选择的颜色。所有标记都有默认颜色,即使“标记”卡的“颜色”上没有字段时也是如此。对于大多数标记,蓝色为默认颜色;对于文本,黑色为默认颜色。

  • “数据”窗格中,将字段拖到“标记”卡上的“颜色”

    Tableau 将根据字段的值和成员为标记应用不同的颜色。举例来说,如果将诸如“Category”(类别)等离散字段(蓝色字段)放在“颜色”上,则视图中的标记将按类别细分,每种类别分配有一种颜色。

    如果将诸如“SUM(sales)”等连续字段放在“颜色”上,则会根据其销售额值为视图中的每个标记着色。

编辑颜色

更改调色板或自定义向标记应用颜色的方式:

  • 在“标记”卡上,单击“颜色”>“编辑颜色”

有关详细信息,请参见调色板和效果

更改标记的大小

若要更改视图中标记的大小,请执行以下操作之一:

  • 在“标记”卡上单击“大小”,然后将滑块向左或向右移动。

    如下表所述,大小滑块对不同标记的影响方式不同。

    标记类型 说明
    圆、方块、形状、文本 使标记变大或变小。
    条、甘特条 使条变宽或变窄。
    线 使线变粗或变细。
    多边形 多边形的大小不可更改。
    饼图 使饼图的整体尺寸变大或变小。

    使用“大小”滑块更改标记大小时,不会修改数据视图的大小。但是,如果更改视图大小,标记大小可能随之改变以适应新的格式。例如,如果使表变大,标记也可能变大。

  • “数据”窗格中,将字段拖到“标记”卡上的“大小”

如果将离散字段放在“标记”卡的“大小”上,Tableau 会根据该维度中的成员分隔标记,并为每个成员分配一个唯一大小。由于大小具有固定的顺序(从小到大),因此分类大小最适合年份或季度之类的有序数据。

对离散字段数据进行大小编码将采用与“详细信息”属性相同的方式分隔标记,然后为每个标记提供附加信息(大小)。有关详细信息,请参见按维度成员分隔视图中的标记将分类大小编码添加到视图时,Tableau 会显示一个图例,其中显示分配给“大小”目标上的字段中包含的每个成员的大小。可以使用“编辑大小”对话框修改这些大小的分布方式。

如果将连续字段放在“标记”卡的“大小”上,Tableau 会使用连续范围以不同大小绘制每个标记。将为最小值分配最小标记,最大值由最大标记表示。

将定量大小编码添加到视图时,Tableau 会显示一个图例,其中显示按其分配大小的值范围。可以使用“编辑大小”对话框修改这些大小的分布方式。

编辑标记大小

编辑标记的大小或更改向视图中的标记应用大小的方式:

  1. 在“大小”图例卡(当您将字段添加到“标记”卡上的“大小”时,该卡将出现)上,单击右上角的下拉箭头,并选择“编辑大小”

    有关图例的详细信息,请参见图例

  2. 在出现的“编辑大小”对话框中进行更改,然后单击“确定”

    可用选项取决于应用了大小的字段是连续字段还是离散字段。

    对于连续字段,您可以执行以下操作:

    • 对于“大小变化”,单击下拉框并选择以下选项之一:

      • 自动 — 选择最适合您的数据的映射。如果数据是数字并且不过零(均为正数或负数),则使用“从零开始”映射。否则,使用“按范围”映射。

      • 按范围 — 使用数据中的最小值和最大值确定大小分布。例如,如果字段的值范围为 14 到 25,则大小会分布在此范围内。

      • 从零开始 — 将从零开始内插大小,将最大标记大小分配给距离零最远的数据值的绝对值。

    • 使用范围滑块可以调整大小的分布。从“大小变化”下拉菜单中选择“从零开始”映射后,将禁用下滑块,因为它始终设置为零。

    • 选择“反转”可向最小值分配最大标记,并向最大值分配最小标记。如果要从零开始映射大小,则此选项将不可用,因为最小标记始终分配给零。

    • 若要修改大小的分布,请选中“图例中的开始值”“范围的结束值”复选框并键入范围的开始和结束值。

      对于离散字段,您可以执行以下操作:

      • 使用范围滑块可以调整大小的分布。

      • 选择“反转”可向最小值分配最大标记,并向最大值分配最小标记。

连续轴标记大小调整

对于标记类型为“条”并且“行”“列”上都有连续(绿色)字段的视图,Tableau 将支持用于调整条已固定的轴上条标记大小的附加选项和默认值。

  • 直方图中的条标记默认情况下是连续的(标记之间无空格),并且进行了大小调整以匹配数据桶的大小。有关示例,请参见生成直方图

  • 如果“大小”上有字段,则通过使用“大小”上的字段,可以确定条已固定的轴上的条标记宽度。为此,请单击“大小”卡并选择“固定”

  • 如果“大小”上没有字段,则可以用轴单位指定条已固定的轴上的条标记宽度。为此,请单击“大小”卡、选择“固定”,然后在“以轴单位表示的宽度”字段中键入数字。

  • 当条已固定的轴上有连续日期字段时,可以将标记的宽度设置为与日期字段的级别匹配。例如,如果连续日期字段的级别为“月”,则条的宽度正好为一个月 - 即,有 31 天的月份比有 30 天的月份稍宽一些。通过单击“大小”卡、选择“固定”,然后在“以天数表示的宽度”字段中键入一个数字,您可以配置条的宽度,但所产生的条宽度未考虑不同时长单位,例如月和年。

为标记添加标签或文本

向可视化项中添加标记标签或文本:

  • “数据”窗格中,将字段拖到“标记”卡上的“标签”“文本”

使用文本表时,“标签”功能区将替换为“文本”,后者允许您查看与数据视图关联的数字。对数据视图进行文本编码的效果取决于使用维度还是度量。

  • 维度 — 将维度放在“标记”卡的“标签”“文本”上时,Tableau 会根据该维度中的成员分隔标记。文本标签由维度成员名称控制。

  • 度量 - 将度量放在“标记”卡的“标签”“文本”上时,文本标签由度量值控制。度量可以聚合,也可以解聚。但是,对度量进行解聚通常用处不大,因为这样做通常会导致文本重叠。

“文本”是文本表的默认标记类型,该表也称为交叉表或数据透视表。

按维度成员分隔视图中的标记

分隔视图中的标记(或增大粒度):

  • “数据”窗格中,将维度拖到“标记”卡上的“详细信息”

将维度放置到“标记”卡的“详细信息”时,系统将根据维度的成员来分隔数据视图中的标记。与将维度放置到“行”“列”功能区不同,将该维度放置到“标记”卡的“详细信息”上时,无需更改表结构即可显示更多数据。

向标记中添加工具提示

工具提示是将光标悬停在视图中的一个或多个标记上时显示的详细信息。工具提示还为快速筛选或移除所选内容或查看基础数据提供便利。您可以编辑工具提示,使它同时包含静态和动态文本。您也可以修改在工具提示中包括哪些字段,以及是否希望能够使用这些字段来选择视图中的标记。

有关在工具提示内显示工作表中的可视化项(工具提示内部可视化项)的详细信息,请参见在工具提示中创建视图(工具提示内部可视化项)

添加工具提示

  1. 将一个字段拖到“标记”卡上的“工具提示”中。

  2. 单击“标记”卡上的工具提示,以打开“编辑工具提示”对话框,在此,您可以添加文本、重新排列工具提示内容以及插入更多字段。

注意: 维度是使用 ATTR 聚合添加到工具提示的,这意味着工具提示有时可能显示为一个星号。该星号表示有多个维度成员应用于您所指向的标记。例如,一个标记可表示所有地区的聚合销售额。将“Region”字段添加到工具提示时会显示一个星号,因为该标记表示多个地区。若要避免显示星号,请将该维度添加到“标记”卡上的“详细信息”或在视图中的其他位置使用该维度,以确保标记处于同一详细级别。

工具提示选项

打开“编辑工具提示”对话框之后,您可以选择一些选项以格式化视图中的工具提示并配置其行为。您可以选择如下选项。

  • 设置工具提示格式: 工具提示是在每张工作表上指定的,并且可以使用“编辑工具提示”对话框顶部的工具设置工具提示格式。

  • 添加动态文本: 使用该对话框顶部的“插入”菜单可添加动态文本,例如字段值、工作表属性等。“插入”菜单上的“所有字段”命令会将视图中使用的所有字段名称和值添加到视图中任何标记的工具提示中。

  • 显示工具提示: 默认情况下将显示工具提示。如果您更希望隐藏自动工具提示,请清除“显示工具提示”复选框。

  • 配置工具提示行为: 通过在“显示工具提示”复选框旁边的下拉列表中选择下列选项之一,来配置工具提示的行为方式:

    • 响应式 - 即时显示工具提示:选择此选项可以在您将光标悬停在视图中的标记时立即显示工具提示。这是所有视图的默认值。

      使用此选项,显示的工具提示没有命令按钮。您必须先单击视图中的标记才能看到命令按钮。

    • 悬停时 - 悬停时显示工具提示:选择此选项可以仅在将光标放在标记上后才显示工具提示。不过,对于此选项,命令按钮会出现在工具提示上,而无需您进行任何进一步的操作(除非您以其他方式在“编辑工具提示”对话框中指定)。

  • 显示命令: 选择“包括命令按钮”复选框,以在工具提示顶部添加“只保留”“排除”“组成员”“创建集”“查看数据”按钮。这些命令按钮显示在 Tableau Desktop 中,以及在将视图发布到 Web 时或在移动设备上查看视图时显示。

    有关成员分组的详细信息,请参见通过将数据分组来纠正数据错误或合并维度成员。有关创建集的详细信息,请参见创建集(链接在新窗口中打开)

  • 从工具提示中选择视图中的标记。选中“允许按类别选择”复选框,以便能够通过单击工具提示中的离散字段来选择视图中具有相同值的标记。如果选中此复选框,您可以使用此功能,在将 Tableau Desktop 中的视图中发布到 Web 或在移动设备上查看视图时选择该视图中的标记。

  • 添加或移除字段: 若要在使用自动工具提示时添加和移除字段,可在视图中的一个功能区上右键单击(在 Mac 上按住 Control 单击)相应字段,然后选择“包含在工具提示中”

注意: 仅当您尚未自定义工具提示时,“包含在工具提示中”选项才可用。如果已自定义工具提示,则可以返回到自动工具提示,方法是在“标记”卡上单击“工具提示”,然后在“编辑工具提示”对话框中单击“重置”

更改标记的形状

更改标记的形状:

  • “数据”窗格中,将字段拖到“标记”卡上的“形状”

如果将维度放在“标记”卡的“形状”上,Tableau 会根据该维度中的成员分隔标记,并为每个成员分配一种唯一的形状。Tableau 还显示一个形状图例,该图例显示每个成员名称和关联的形状。如果将度量放在“标记”卡的“形状”上,则该度量会转换为离散度量。

形状编码数据采用与“详细信息”属性相同的方式分隔标记,然后为每个标记提供附加信息(形状)。如果“行”“列”功能区的最内层字段都是度量,则形状是默认标记类型。

在下面的视图中,标记将根据“Customer Segment”维度的成员分隔到不同的形状中。每个形状分别反映了该客户细分市场对利润和销售额的贡献。

编辑形状

默认情况下,有十个唯一的形状用于对维度进行编码。如果您有 10 个以上的成员,则形状会重复使用。除了默认调色板之外,您还可以从其他各种形状调色板中进行选择,包括填充形状、箭头,甚至天气符号。

  1. 单击“标记”卡上的“形状”,或者在该图例的卡菜单上选择“编辑形状”

  2. 在“编辑形状”对话框中,在左侧选择成员,然后在右侧的调色板中选择新形状。也可以单击“分配调色板”快速为字段成员分配形状。

使用右上方的下拉菜单选择其他形状调色板。

注意: 形状编码将在使用同一数据源的多个工作表之间共享。例如,如果要定义由方块表示的“家具”产品,则此类产品将在工作簿中的所有其他视图中自动显示为方块。若要为字段设置默认形状编码,请在“数据”窗格中右键单击(在 Mac 上按住 Control 单击)该字段,并选择“默认属性”>“形状”

使用自定义形状

可以向工作簿中添加自定义形状,方法是将形状图像文件复制到位于 Documents 文件夹下的 Tableau Repository 内的 Shapes 文件夹中。使用自定义形状时,它们将随工作簿一起保存。这样便可与他人共享工作簿。

  1. 创建形状图像文件。每个形状都应保存为它自己的文件,并且可以是一些图像格式中的任何格式,包括位图 (.bmp)、可移植网络图形 (.png)、.jpg 和图形交换格式 (.gif)。

  2. 将形状文件复制到位于 Documents 文件夹下的 My Tableau Repository\Shapes 文件夹内的新文件夹中。该文件夹的名称将用作 Tableau 中的调色板名称。在以下示例中,将创建两个新调色板:“Maps”和“My Custom Shapes”。

  3. 在 Tableau 中,单击图形图例上的下拉箭头,然后选择“编辑图形”

  4. 在下拉列表中选择新的自定义调色板。如果您在 Tableau 运行期间修改了形状,可能需要单击“重新加载形状”

  5. 可以一次为成员分配一个形状,也可以单击“分配调色板”自动为成员分配形状。

注意: 可以通过单击“重置”按钮恢复为默认调色板。如果打开的工作簿使用了您没有的自定义形状,则该工作簿会显示这些自定义形状,因为这些形状是作为该工作簿的一部分保存的。不过,可以在“编辑形状”对话框中单击“重新加载形状”,改用您的存储库中的形状。

下面是一些同时使用了默认和自定义形状调色板的视图示例。

关于创建自定义形状的提示

创建自定义形状时,您可以执行一些操作来改进形状在视图中状的外观和功能。如果您要创建自己的形状,建议您按照以下准则创建图标或剪贴画。

  • 建议大小 - 除非您计划使用“大小”将形状真的设置为大尺寸,否则应该尝试使原始形状大小接近 32 x 32 像素。然而,原始大小取决于您希望能够在 Tableau 中使用的大小范围。可以在 Tableau 中通过单击“标记”卡上的“大小”来调整形状大小,也可以使用“格式”菜单上的单元格大小选项。

  • 添加颜色编码 - 如果您也打算使用“颜色”对形状进行编码,则应该使用透明背景。否则,不仅仅是符号,整块图像区域都将填充颜色。GIF 和 PNG 文件格式都支持透明度。GIF 文件支持 100% 透明的单色透明度,而 PNG 文件支持 alpha 通道,此通道包含可用于图像中的所有像素的透明度级别范围。当 Tableau 颜色对符号进行编码时,不会修改每个像素的透明程度,所以您可以维护光滑的边缘。

    注意:请避免在图像周围包括太多透明度。使自定义形状的大小尽可能接近图像的大小。图像边缘周围的额外透明像素可能会对靠近图像的悬停或单击行为造成负面影响,特别是在自定义形状彼此覆盖的情况下。当实际形状区域比可视区域大时,对于用户而言,可能会使形状的悬停和单击行为变得更加困难,并且更难预测。

  • 文件格式 - Tableau 不支持增强元文件格式 (.emf) 的符号。形状图像文件可采用以下格式之一:形状图像文件可采用以下格式之一:.png、.gif、.jpg、.bmp 和 .tiff。

在标记之间绘制路径

“标记”卡下拉菜单中选择“线”“多边形”标记类型时,“路径”属性可用。有关如何更改可视化项中所显示标记的类型的详细信息,请参见更改视图中标记的类型

您可以使用“标记”卡上的“路径”属性来更改线标记的类型(线性、阶梯或跳跃),或通过使用特定绘制顺序连接标记来对数据进行编码。使用度量或维度都可以对数据进行路径编码。

  • 维度 — 将维度放在“标记”卡的“路径”上时,Tableau 会根据该维度中的成员连接标记。如果维度为日期,则由日期顺序控制绘制顺序。如果维度包含客户名称或产品类型等文字,则绘制顺序由数据源中的成员顺序控制。通过更改成员的排序顺序,可以更改连接数据点的顺序。有关详细信息,请参见在可视化项中对数据进行排序(链接在新窗口中打开)

  • 度量 - 将度量放在“标记”卡的“路径”上时,Tableau 会根据该度量的值连接标记。可对度量进行聚合或解聚。

更改线类型(线性、阶梯、跳跃)

当标记类型设置为线(“自动”或“线”)时,您可以单击“标记”卡中的“路径”属性来更改线类型。

为在一段时间内保持不变并且变化或增量显著的数值数据(例如帐户余额、库存水平或利率)使用这些线类型。阶梯线非常适合用于强调变化的量级。跳跃线可帮助强调数据点之间变化的持续时间。

  1. 在“标记”卡中单击“路径”
  2. 选择“线性”“阶梯”“跳跃”以更改线类型。

创建路径编码视图

要创建有用的路径编码视图,数据表应至少包含一个度量。您无法创建仅连接一种分类数据(维度)的路径。

下面的视图是使用 2010 年大西洋海域的暴风雨数据创建的。该视图对由暴风雨日期确定的路径使用了线标记。这样您会看到暴风雨所经过的路线。如果将连续日期放在“标记”卡的“路径”上,这会告诉 Tableau 按时间顺序绘制线条。有关详细信息,请参见在 Tableau 中创建显示随时间变化的路径的地图在 Tableau 中创建显示起点和终点之间的路径的地图

此部分中的其他文章

感谢您的反馈!