Excel

この記事では、Tableau を Microsoft Excel ファイルのデータに接続してデータ ソースを設定する方法について説明します。Tableau は .xls および xlsx ファイルに接続します。

.csv ファイルに接続するには、テキスト ファイル コネクターを使用します。

接続してデータ ソースを設定する

  1. Tableau を開き、[接続][Excel] をクリックします。

  2. 接続する Excel ワークブックを選択し、[開く] をクリックします。

    注:Tableau 2020.2 以降、従来の Excel 接続とテキスト接続はサポートされなくなりました。レガシー接続の使用に代わる方法については、Tableau コミュニティの「Legacy Connection Alternatives」ドキュメントを参照してください。

  3. [データ ソース] ページで、次の手順を行います。

    1. (任意) ページ上部にある既定のデータソース名を選択し、Tableau で使用する一意のデータソース名を入力します。たとえば、データの他のユーザーが、どのデータ ソースに接続するか推測するのに役立つ命名規則を使用します。

    2. Excel ファイルに 1 つの表が含まれる場合は、シート タブをクリックして分析を開始します。

      カスタム SQL を使用して、データ ソース全体ではなく、特定のクエリに接続します。詳細については、カスタム SQL クエリへの接続を参照してください。

      また、ワークシートに接続するのと同じ方法で、名前付き範囲または Excel の表 (Excel リストとも呼ばれる) に接続できます。名前付き範囲と Excel の表関数は両方とも、Tableau では表です。

      Excel で名前付き範囲を作成するには、セルの範囲を選択し、[数式] タブの [名前の定義] を選択します。Excel で名前付き範囲を作成するのと同じように、Excel でセルの範囲を選択し、[挿入] > [表] を選択することで Excel の表を作成できます。Tableau で名前付き範囲または Excel の表に接続すると、以下に示すように、[データ ソース] ページでシートの隣にアイコンが表示されます。

      各データ ソースに固有の名前がある場合は、複数の Excel ワークブックに同時に接続できます。

    注:Tableau は Excel でのピボット テーブルをサポートしていません。

Microsoft Excel データ ソースの例

以下は、Microsoft Excel データ ソースの例です。

注:Excel ファイルに長さ 254 文字を超える列が含まれている場合、Tableau Desktop は Tableau Desktop Desktop 8.2 以前で作成されたワークブックでこれらのフィールドを使用することができません。また、レガシー接続を使用してこのデータに接続することもできません。Tableau Desktop に接続する前に、それらの列を削除するか、254 文字以内に変更してください。または、Excel データ ソースをアップグレードしてください。データ ソースのアップグレード方法の詳細については、データ ソースのアップグレードを参照してください。

データの追加

表を追加したり、別のデータベースのデータに接続したりして、データ ソースにデータを追加できます。

  • 現在のファイルからデータを追加するには、次の手順を実行します。左ペインから追加する表をキャンバスにドラッグして、結合またはユニオンでデータを組み合わせます。詳細については、データの結合またはデータのユニオン作成を参照してください。

  • 異なるデータベースからデータを追加するには、次の手順を実行します。左ペインで [接続] の横にある [追加] をクリックします。詳細については、データの結合を参照してください。

    左ペインに必要なコネクターがリストされていない場合は、[データ] > [新しいデータ ソース] を選択して新しいデータ ソースを追加します。詳細については、データのブレンドを参照してください。

Excel の表オプションの設定

Excel の表オプションは接続の範囲になっています。表のオプションを変更するには、キャンバスで表のドロップダウン矢印をクリックし、データの最初の行にフィールド名を含めるかどうかを指定します。その場合、これらの名前が Tableau のフィールド名になります。フィールド名が含まれていない場合は、Tableau によって自動的に生成されます。これらのフィールド名は後で変更できます。

Data Interpreter を使用してデータをクリーンアップする

データ ソースを分析用に最適化すると役立つ可能性があることを Tableau が検出した場合、Data Interpreter を使用するよう求めるプロンプトが表示されます。Data Interpreter は試用できるサブテーブルを検出し、分析で後から問題の原因となる可能性がある一意の書式設定を削除できます。詳細については、Excel、CSV、PDF、および Google スプレッドシートからのデータインタープリターを使用するデータのクリーニングを参照してください。

.ttde ファイルおよび .hhyper ファイルについて

コンピューターのディレクトリを移動していると、.ttde または .hhyper ファイルに気づくかもしれません。お使いのデータに接続する Tableau データ ソースを作成すると、Tableau は .ttde または .hhyper ファイルを作成します。このファイルはシャドー抽出としても知られ、Tableau Desktop でデータ ソースの読み込み速度を向上させるのに使用されます。シャドー抽出には参照元データや標準的な Tableau 抽出に似た他の情報が含まれますが、シャドー抽出は別の形式で保存されているため、データの復元には使用できません。

特定の状況では、コンピューターからシャドー抽出を削除する必要がある場合があります。詳細については、Tableau ナレッジ ベースの「シャドウ抽出によるディスクの容量の低下」を参照してください。

値の計算方法の変更

バージョン 10.5 以降、抽出データ ソースおよびライブ接続を Excel のようなファイルベースのデータに使用するデータ ソースを使用する場合に、データの値を以前のバージョンとは異なる方法で計算できます。この変更によって、バージョン 10.4 (またはそれ以前) およびバージョン 10.5 (またはそれ以降) のビューに表示されるデータとマークの違いを確認できます。この変更の目的は、Excel データ ソースの効率性およびスケーラビリティを改善することです。詳細については、ビュー内の値とマークの変更を参照してください。

Excel データ ソースでのこの変更の一例となるのが、大文字と小文字の区別です。バージョン 10.4 (またはそれ以前) では、値の比較および並べ替えで文字列値の大文字と小文字が区別されておらず、したがって単一の文字列値として同一と見なされ、保存されていました。バージョン 10.5 以降も、比較および並べ替えでは値の大文字と小文字が区別されていません。ただし、保存の際は値の大文字と小文字が区別されます。これにより、データ ソース ページに値が表示されるときにはっきりと区別できるようになります。

たとえば、データに値 "House"、"HOUSE"、"houSe" が含まれる列があるとします。使用する Tableau のバージョンによって、次の文字列値が表示されます。

  • バージョン 10.4 以前では、データ ソース ページとビューの両方に「House」、「House」、「House」と表示されます。

  • バージョン 10.5 以降では、データ ソース ページに「House」、「HOUSE」、「houSe」と表示されます。ただし、ビューでは引き続き「House」、「House」、「House」と表示されます。

結合の実行時にデータの大文字と小文字の区別を維持する必要がある場合、[データ] メニューから [大文字と小文字の維持 (Excel)] オプションを有効にできます。このオプションの詳細については、データの結合(新しいウィンドウでリンクが開く)を参照してください。

関連項目

このセクションの他の記事

ありがとうございます!