管理 Tableau Bridge 的通知

由于各种原因,计划刷新可能会失败。作为数据源所有者,了解这些刷新失败情况非常重要,这样您就能排查任何问题并最大限度地缩短数据新鲜度中的差距。

如果站点管理员已启用,您会收到有关您拥有的所有数据源刷新失败情况的电子通知。当通过 Bridge 刷新或 Bridge 旧版计划来帮助刷新数据源时,您接收的通知的类型、接收通知的时间以及您可以配置的通知与其他 Tableau 通知不同。

您如何接收 Bridge 通知

Bridge 作业失败通知通过 Tableau 的统一通知平台传递,该平台也为您的其他 Tableau 通知提供支持。以前,Bridge 仅通过电子邮件发送这些通知。现在,除了电子邮件之外,有关 Bridge 作业失败的通知(例如客户端断开连接、数据提取刷新失败、Prep 流程失败和虚拟连接失败)会与其他 Tableau 通知一起显示。

Bridge 通知发送给与电子邮件通知相同的受众:站点管理员和数据源所有者。

无需进行其他设置即可接收这些通知。确保在常规通知首选项中选中“Tableau”复选框。

与 Bridge 通知的差异

  • 超过超时限制时,将发送超时刷新失败电子邮件。与直接在 Tableau Cloud 上运行的刷新不同,Bridge 刷新将在 24 小时后超时(默认值)。不过,站点管理员可以通过每个 Bridge 客户端增加(或减少)刷新的超时限制。有关详细信息,请参见更改 Bridge 客户端设置。

  • 根据故障类型,将与 Bridge 相关的刷新问题通知发送给特定收件人:

    • RAS 故障:这些通知与计划刷新 (RAS) 失败相关,这意味着作业已成功发送到 Bridge 客户端,但在客户端计算机上处理期间或之后失败。通知只会发送给数据源所有者。站点管理员不会收到这些通知。

      • 刷新作业失败:当数据提取刷新由于以下原因以外的原因失败时(这是作业在客户端上运行时发生的所有失败)。
      • Bridge 客户端未运行:当链接到数据源的 Bridge 客户端未运行,但池中的其他客户端处于活动状态时。
      • 刷新未完成:如果计划刷新在指定的时间后未完成。
    • 边缘池故障:这些通知与边缘池故障相关,这意味着由于池容量或客户端可用性问题,计划的刷新作业在发送到 Bridge 客户端之前未能运行。这些通知发送给数据源所有者和站点管理员。

      • Bridge 池容量已满:当数据提取刷新由于池容量已满而无法运行时,将收到此通知。
      • Bridge 池中没有客户端:未将任何 Bridge 客户端分配给池。
      • Bridge 池中没有正在运行的客户端:Bridge 客户端已分配给池,但当前没有任何客户端在运行。这包括池中的单个客户端未运行的情况,或者分配了多个客户端但所有客户端都处于非活动状态的情况。
  • 对于特定数据源,Tableau Cloud 会在第一天发送有关前五个连续的刷新相关失败的电子邮件(即,刷新失败、由于客户端未运行而出现警报,或者由于刷新未完成而出现警报)。如果在第一天后数据源仍然有刷新问题,Tableau Cloud 将每天发送一封电子邮件。

  • 数据源所有者一天中最多可能收到 10 封电子邮件,具有活动或连续刷新问题的每个数据源一封电子邮件。一天的时间段是 24 个小时,从第一次出现刷新问题时开始。

  • 依靠 Bridge 数据提取数据源使数据保持最新的视图或工作簿不支持由数据刷新发起的订阅。有关详细信息,请参见缺少订阅电子邮件。

配置池化

数据提取刷新可能会因为 Bridge 池和负载平衡的问题而失败。站点管理员可以通过添加新池或修改池化容量来配置和管理 Bridge 客户端的池化。有关更多信息,请参见配置池和管理 Bridge 池的大小。

在客户端未运行时停止接收通知

默认情况下,Tableau Cloud 配置为在计划刷新由于链接到数据源的 Bridge 客户端未运行而无法启动时向数据源所有者发出通知。

您可能会收到此电子邮件的原因主要有两个:

  • 客户端从中运行的计算机未打开。

  • 数据提取数据源继续与不再使用的客户端关联。

如果以下任何原因适用于您的情况:

  • 确认 Bridge 客户端是否正在运行,以及

  • 如果您是站点管理员,请从站点中删除未使用的客户端。如果您不是站点管理员,则可以从客户端中删除数据源。有关详细信息,请参见计划刷新似乎未按计划运行:。

感谢您的反馈!您的反馈已成功提交。谢谢!