Gestire gli avvisi per Tableau Bridge

Un aggiornamento pianificato può non riuscire per diversi motivi. In qualità di proprietario di un’origine dati, è importante conoscere questi errori di aggiornamento, in modo da poter risolvere eventuali problemi e ridurre al minimo le possibilità di dati non aggiornati.

Se la funzionalità è stata abilitata dall’amministratore del sito, ricevi avvisi tramite e-mail sugli errori di aggiornamento per tutte le origini dati di cui sei il proprietario. Quando gli aggiornamenti per le origini dati sono facilitati tramite le pianificazioni di aggiornamento di Bridge o le pianificazioni legacy di Bridge, il tipo di avvisi che ricevi, il momento in cui li ricevi e gli avvisi che puoi configurare sono diversi dagli altri avvisi di Tableau.

Modalità di ricezione degli avvisi di Bridge

Le notifiche degli errori dei processi di Bridge vengono inviate tramite la piattaforma di notifica unificata di Tableau, la stessa piattaforma su cui si basano le altre notifiche di Tableau. In precedenza, Bridge inviava queste notifiche solo tramite e-mail. Ora gli avvisi relativi agli errori dei processi di Bridge, come la disconnessione del client o gli errori di aggiornamento delle estrazioni, del flusso di preparazione e della connessione virtuale, vengono visualizzati insieme alle altre notifiche di Tableau, oltre a essere inviati tramite e-mail.

Gli avvisi di Bridge vengono inviati agli stessi destinatari degli avvisi tramite e-mail: gli amministratori del sito e i proprietari dell’origine dati.

Per ricevere queste notifiche non è necessaria alcuna configurazione aggiuntiva. Assicurati che la casella di controllo di Tableau sia selezionata nelle preferenze generali per le notifiche.

Differenze rispetto agli avvisi di Bridge tramite e-mail

  • Le email di errore di aggiornamento del timeout vengono inviate quando viene superato il limite di timeout. A differenza degli aggiornamenti eseguiti direttamente su Tableau Cloud, il timeout degli aggiornamenti di Bridge avviene dopo 24 ore (impostazione predefinita). Tuttavia, un limite di timeout per gli aggiornamenti può essere aumentato (o diminuito) tramite ogni client Bridge da un amministratore del sito. Per maggiori informazioni, consulta Modificare le impostazioni del client Bridge.

  • Le notifiche per i problemi di aggiornamento correlati a Tableau Bridge vengono inviate a destinatari specifici a seconda del tipo di errore:

    • Errori RAS: questi avvisi si riferiscono a un errore di aggiornamento dopo la pianificazione (Refresh after Schedule , RAS), ovvero il processo è stato inviato correttamente al client Bridge, ma non è riuscito durante o dopo l’elaborazione nel computer client. Le notifiche vengono inviate solo al proprietario dell’origine dati. Gli amministratori del sito non ricevono queste notifiche.

      • Processo di aggiornamento non riuscito: quando un aggiornamento dell’estrazione non riesce per motivi diversi da quelli elencati di seguito; si tratta del problema degli errori che si verificano una volta che il processo viene trasferito al client.
      • Client Bridge non in esecuzione: quando il client Bridge collegato all’origine dati non è in esecuzione, ma altri client nel pool sono attivi.
      • Aggiornamento incompleto: quando un aggiornamento pianificato non è stato completato dopo un determinato periodo di tempo.
    • Errori del pool perimetrale: questi avvisi si riferiscono a un errore del pool perimetrale, ovvero il processo di aggiornamento pianificato non è stato eseguito prima che fosse possibile inviarlo al client Bridge a causa di problemi relativi alla capacità del pool o alla disponibilità del client. Queste notifiche vengono inviate al proprietario dell’origine dati e all’amministratore del sito.

      • Pool di bridge a capacità massima: quando gli aggiornamenti dell’estrazione non possono essere eseguiti perché il pool ha raggiunto la capacità massima.
      • Nessun client nel pool di Bridge: al pool non è assegnato alcun client Bridge.
      • Nessun client in esecuzione nel pool di Bridge: al pool sono assegnati client Bridge ma nessuno di questi è attualmente in esecuzione. Questa notifica riguarda sia il caso in cui l’unico client assegnato al pool non è in esecuzione che il caso in cui al pool sono assegnati più client e tutti sono inattivi.
  • Per una particolare origine dati, Tableau Cloud invia le e-mail per i primi cinque problemi consecutivi relativi all’aggiornamento (ad esempio, errori di aggiornamento, avvisi di client non in esecuzione o avvisi di aggiornamento non ancora completato) il primo giorno. Se l’origine dati continua ad avere problemi di aggiornamento dopo il primo giorno, Tableau Cloud invia un’e-mail al giorno.

  • Il proprietario di un’origine dati può ricevere fino a 10 e-mail in un giorno, ovvero un’e-mail per origine dati con problemi di aggiornamento attivi e consecutivi. Il periodo di tempo di un giorno è 24 ore a partire dal primo errore di aggiornamento.

  • Le e-mail delle sottoscrizioni avviate dall’aggiornamento dei dati non sono supportate per le viste o le cartelle di lavoro che si basano su origini dati di estrazione di Bridge per mantenere aggiornati i dati. Per maggiori informazioni, consulta E-mail di sottoscrizione mancanti.

Configurare il pooling

Gli aggiornamenti delle estrazioni possono non riuscire a causa di problemi con il pool Bridge e il bilanciamento del carico. Gli amministratori del sito possono configurare e gestire il pool per i client Bridge aggiungendo un nuovo pool o modificandone la capacità. Per ulteriori informazioni, consulta Configurare i pool e Gestire le dimensioni del pool di Bridge.

Interrompere la ricezione di avvisi quando un client non è in esecuzione

Per impostazione predefinita, Tableau Cloud è configurato per inviare una notifica ai proprietari delle origini dati quando gli aggiornamenti pianificati non possono essere avviati perché il client Bridge collegato all’origine dati non è in esecuzione.

Ci sono due motivi principali per cui potresti ricevere questa e-mail:

  • Il computer sul quale il client deve essere eseguito non è acceso.

  • Le origini dati estratte continuano a essere associate a un client non più in uso.

Se uno di questi motivi è applicabile alla tua situazione:

Grazie per il tuo feedback.Il tuo feedback è stato inviato. Grazie!