自定义视图是应用了所选内容和筛选器的视图的副本。您可以使用自定义视图来保存您的筛选器、排序或所选内容,而无需更改原始视图。如果您每次打开 Tableau Server 或 Tableau Online 视图时都会更改该视图,则自定义视图是一个很好的选择。

使用自定义视图时的注意事项:

  • 自定义视图不会更改原始视图。

  • 如果原始视图更新或重新发布,则自定义视图也会更新。

  • 同样,如果从服务器中删除原始视图,也将删除您的自定义视图。

  • 如果您更改原始视图中的组或集,您的相关自定义视图不会更改。

  • 若要更改基础工作簿,请参见在 Web 上编辑 Tableau 视图

创建自定义视图

  1. 打开要自定义的单独视图。

  2. 筛选数据、更改排序、选择特定标记、放大或缩小,或者添加修改内容。

  3. 在工具栏中选择“视图”

  4. “自定义视图”对话框中,输入自定义视图的名称。

  5. (可选)选择“设为我的默认视图”,然后选择“使其对其他人可见”

  6. 单击“保存”

  7. 在视图的工具栏中,选择“共享”以与其他用户共享。若要将其添加到工作簿上显示的公共自定义视图列表中,请参见将自定义视图设为公共或私有

管理自定义视图

您可以查看在工作簿或 Tableau Online 和 Tableau Server 中的单个视图上创建的自定义视图。如果您有发布权限,则可以查看为工作簿创建的所有自定义视图。站点和服务器管理员可以删除其他用户的自定义视图或更改所有者。

管理工作簿自定义视图

您可以通过从工具栏中或在“自定义视图”选项卡上选择“视图”,在“自定义视图”菜单中查看在工作簿上创建的任何自定义视图。若要查看工作簿的自定义视图,请完成以下步骤。

  1. 选择要查看的工作簿。
  2. 选择“自定义视图”选项卡。

  3. 选择要查看的自定义视图,或按名称、所有者、原始标题等筛选可用视图。

 

保存的自定义视图

保存自定义视图后,它会出现在“我的视图”下。原始视图和其他人创建的视图出现在“其他视图”下。若要查看保存的自定义视图,请完成以下步骤。

  1. 在工具栏中选择“视图”。当前选定的视图显示时带有灰色背景。

更改默认视图

  1. 选择工具栏中的“视图”,然后在“自定义视图”对话框的右下角选择“管理”

  2. 选择自定义视图名称旁边的

  3. 选择“完成”

将自定义视图设为公共或私有

自定义视图默认情况下设置为私有。如果自定义视图的状态为私有,则只有您可以查看该视图。如果您的站点角色是 Explorer 或 Creator,并且您具有正确的工作簿权限,则可以将视图设为公共。公共视图允许有权访问原始视图的任何人在“其他视图”列表中查看您的自定义版本。

注意:私有自定义视图在“其他视图”列表中是隐藏的。您可以与有权访问原始视图的任何人共享 URL。

  1. 在工具栏中选择“视图”

  2. 选择“管理”

  3. 选择公共或私有图标。

    • 公共图标 指明视图对其他人可见。

    • 私有图标 指明只有您才能看到视图。

  4. 单击“Done”(完成)

删除自定义视图

管理员和 Creator 可以随时删除自定义视图。删除自定义视图不会影响原始视图。若要从工作簿的“自定义视图”选项卡中删除自定义视图,请完成以下步骤。

  1. 选择要查看的工作簿。

  2. 选择“自定义视图”选项卡。

  3. 选择特定的自定义视图。

  4. 从“操作”下拉菜单中,选择“删除”

  5. 若要完成,请选择“删除”

使用“自定义视图”对话框删除自定义视图

Creator 还可以从可视化项内的“自定义视图”对话框中删除自定义视图。若要从“自定义视图”对话框中删除自定义视图,请完成以下步骤。

  1. 在工具栏中,选择“视图”

    工具栏中的“视图”下拉菜单。

  2. 选择“管理视图”

    “自定义视图”对话框中的“管理视图”按钮。

  3. 在自定义视图名称旁边,选择删除图标

    “管理视图”对话框中的“删除”图标。

  4. 选择“删除”

注意:删除自定义视图也会删除基于该自定义视图的任何订阅。

感谢您的反馈!