Edit Tableau Views on the Web

If you can see the Edit button when you are looking at a view in Tableau Online or Tableau Server, that means you can make changes to it. Depending on your access level and permissions, you can:

  • Edit an existing published workbook and add worksheets for views, dashboards, and stories.

  • Create and edit a new workbook based on a published data source.

  • Edit an existing workbook and add worksheets in the browser, or by opening the workbook in Tableau Desktop.

  • Connect to different published data sources while editing. For details, see Connect to Published Data Sources while Web Editing.

For more information about how to build different types of charts and views in Tableau, see Build Charts and Analyze Data(Link opens in a new window).

Edit a published view

  1. Sign in to a site, then either open the workbook that contains the view you want to edit, or show All Views from the Explore page.

  2. Open the view.

  3. Click Edit in the view toolbar.

    When you click Edit, the view opens in web authoring mode.

    Now you can edit the view.

    Note: If you have Tableau Desktop version 2021.2 or later, you can also open the workbook in Tableau Desktop and edit there. Select the Edit in in Desktop icon in the authoring toolbar to open, then publish the workbook to the site when you're finished.

    To learn how to build a chart or dashboard, see Step 4 in Creators: Get Started with Web Authoring and Explore and Analyze Data in a View.

  4. The Save options available to you will vary depending on your permissions set by your Tableau site administrator.

    • To close the view without saving your changes, select File > Close.

    • To save your work in the current workbook, select File > Save.

    • To save your work as a new workbook, select File > Save As. Creators can select a location to save the workbook, either in a project or to their private Personal Space. Explorers can only save to Personal Space. For more information about Personal Space, see Create and Edit Private Content in Personal Space.

    Note: if you edited a workbook in Tableau Desktop and want to publish your changes, select Server > Publish Workbook and select Publish. The workbook’s location and name will be populated in the Publish dialog.

Create a new workbook on the web from a published data source

  1. Sign in to a site on Tableau Online or Tableau Server.

  2. Either open the project that contains the data source you want to use, or show All Data Sources.

  3. Click the next to the data source name to open the actions menu, then click New Workbook.

    New Workbook button

    A new, blank workbook opens in the Tableau Server web editing environment.

Thanks for your feedback!