Gérer les alertes pour Tableau Bridge
Une actualisation programmée peut échouer pour diverses raisons. En tant que propriétaire de source de données, il est important d’être conscient de ces échecs d’actualisation afin de résoudre les problèmes et de minimiser les lacunes dans l’actualisation des données.
Si l’option est activée par votre administrateur de site, vous recevrez des alertes concernant les échecs d’actualisation pour toutes les sources de données que vous possédez. Lorsque les actualisations de vos sources de données sont facilitées par les actualisations Bridge ou par les anciennes programmations Bridge, le type d’alertes que vous recevez, le moment où vous les recevez et les alertes que vous pouvez configurer diffèrent des autres alertes Tableau.
Comment reçoit-on les alertes Bridge?
Les notifications d’échec des tâches Bridge sont envoyées par la plateforme de notification unifiée de Tableau, la même plateforme qui alimente vos autres notifications Tableau. Auparavant, Bridge envoyait ces notifications par courriel uniquement. Désormais, les alertes concernant les échecs des tâches Bridge, comme la déconnexion d’un client, les échecs d’actualisation d’extraits, les échecs de flux Tableau Prep et les échecs de connexion virtuelle, apparaissent en même temps que vos autres notifications Tableau, en plus d’être envoyées par courriel.
Les alertes Bridge sont envoyées aux mêmes destinataires que les alertes courriel : les administrateurs de site et les propriétaires de sources de données.
Aucune configuration supplémentaire n’est requise pour recevoir ces notifications. Assurez-vous que la case Tableau est cochée dans vos préférences générales de notification.
Différences avec les alertes Bridge
Les courriels d’échec de l’actualisation du délai d’expiration sont envoyés lorsque le délai d’expiration est dépassé. À la différences des actualisations qui s’exécutent directement sur Tableau Cloud, les actualisations Bridge expirent au terme d’un délai de 24 heures (par défaut). Cependant, un administrateur de site peut augmenter (ou diminuer) le délai d’expiration des actualisations pour chaque client Bridge. Pour plus d’informations, consultez Modifier les paramètres du client Bridge.
Les notifications pour les problèmes d’actualisation liés à Bridge sont envoyées à des destinataires spécifiques en fonction du type d’échec :
Défaillances RAS: ces alertes se rapportent à un échec d’actualisation après programmation (Refresh after Schedule, RAS), ce qui signifie que la tâche a été envoyée avec succès au client Bridge, mais a échoué pendant ou après le traitement sur la machine cliente. Les notifications sont envoyées uniquement au propriétaire de la source de données. Les administrateurs de site ne reçoivent pas ces notifications.
- Échec de la tâche d’actualisation : lorsqu’une actualisation d’extrait échoue pour d’autres raisons que celles énumérées ci-dessous (il s’agit du fourre-tout pour les échecs qui se produisent une fois que la tâche est du côté du client).
- Le client Bridge n’est pas en cours d’exécution : lorsque le client Bridge lié à la source de données n’est pas en cours d’exécution, mais que d’autres clients du pool sont actifs.
- Actualisation incomplète : lorsqu’une actualisation programmée n’est pas terminée après une durée spécifiée.
Défaillances du pool Edge : ces alertes se rapportent à une défaillance du pool Edge, ce qui signifie que la tâche d’actualisation planifiée n’a pas pu s’exécuter avant de pouvoir être envoyée au client Bridge en raison de problèmes liés à la capacité du pool ou à la disponibilité du client. Ces notifications sont envoyées au propriétaire de la source de données et à l’administrateur du site.
- Le pool Bridge a atteint sa capacité : lorsque les actualisations d’extraits ne peuvent pas être exécutées car le pool a atteint sa capacité.
- Aucun client dans le pool Bridge : aucun client Bridge n’est affecté au pool.
- Aucun client en cours d’exécution dans le pool Bridge : les clients Bridge sont affectés au pool, mais aucun d’entre eux n’est actuellement en cours d’exécution. Cela inclut les cas où un seul client du pool n’est pas en cours d’exécution, ou ceux où plusieurs clients sont affectés mais qu’ils sont tous inactifs.
Pour une source de données spécifique, Tableau Cloud envoie des courriels au sujet des cinq premiers échecs consécutifs liés à l’actualisation (à savoir échecs d’actualisation, alertes parce que le client n’est pas en cours d’exécution ou alertes parce que l’actualisation n’est pas encore terminée) le premier jour. Si la source de données continue de rencontrer des problèmes d’actualisation après le premier jour, Tableau Cloud envoie un courriel par jour.
Un propriétaire de source de données peut recevoir jusqu’à 10 courriels, un courriel par source de données rencontrant des problèmes d’actualisation actifs et consécutifs, en une journée. La durée d’une journée est de 24 heures à compter de l’heure du premier échec d’actualisation.
Les courriels d’abonnement initiés par l’actualisation des données ne sont pas pris en charge pour les vues ou les classeurs qui s’appuient sur des sources de données d’extrait Bridge pour garder les données à jour. Pour plus d’information, consultez Courriels d’abonnement manquants.
Configurer la mise en pool
Les actualisations d’extraits peuvent échouer en raison de problèmes concernant le pool Bridge et l’équilibrage de charge. Les administrateurs de site peuvent configurer et gérer la mise en pool pour les clients Bridge en ajoutant un nouveau pool ou en modifiant la capacité de mise en pool. Pour plus d’information, consultez Configurer les pools et Gérer la taille du pool Bridge.
Cesser de recevoir des alertes lorsqu’un client ne s’exécute pas
Par défaut, Tableau Cloud est configuré pour alerter les propriétaires de sources de données lorsque les actualisations programmées ne peuvent pas démarrer car le client Bridge lié à la source de données n’est pas en cours d’exécution.
Deux raisons principales peuvent déclencher l’envoi de ce courriel :
L’ordinateur depuis lequel le client s’exécute n’est pas allumé.
La source de données de l’extrait continue d’être associée à un client qui n’est plus utilisé.
Si l’une de ces raisons s’applique à votre situation :
Confirmez si le client Bridge est en cours d’exécution, et
Si vous êtes un administrateur de site, supprimez les clients inutilisés du site. Si vous n’êtes pas un administrateur de site, vous pouvez supprimer la source de données du client. Pour plus d’informations, consultez Les actualisations programmées semblent s’exécuter en dehors du calendrier :.
