사용자 인터페이스에서 Tableau Desktop 또는 Tableau Prep Builder 설치

참고: Tableau Server 설치 방법에 대한 자세한 내용을 찾고 있다면 Tableau Server 도움말의 설치 및 구성 섹션을 대신 참조하십시오.

이 항목에서는 사용자 인터페이스에서 Tableau Desktop 또는 Tableau Prep Builder를 설치하고 활성화하는 방법에 대해 설명합니다. 명령줄에서 제품을 설치하고 활성화하는 방법에 대한 자세한 내용은 명령줄에서 Tableau Desktop 및 Tableau Prep Builder 설치를 참조하십시오.

시작하기 전에

Tableau Desktop 또는 Tableau Prep Builder를 설치하려면 Creator 제품 키와 설치하려는 버전의 설치 프로그램이 필요합니다. Creator 제품 키와 함께 포함되는 응용 프로그램에 대한 자세한 내용은 Tableau 요금 페이지를 참조하십시오.

참고: 기존 Tableau Desktop 고객은 Tableau Desktop 전용 제품 키(문자 TD로 시작하는 키 번호)를 가지고 있을 수 있습니다. Tableau Prep Builder를 설치하려면 개별 제품 키가 필요합니다. Tableau 관리자 또는 Tableau 지원으로 문의하십시오.

가지고 있는 키의 종류를 알아보려면 제품 키의 위치에서 기존 사용자에 대한 지침을 참조하십시오.

설치 프로그램의 위치

중요: 버전 10.5부터 Tableau Desktop, Tableau Reader 및 Tableau Public(데스크톱)은 64비트 운영 체제에서만 실행됩니다. Tableau Prep Builder는 64비트 운영 체제에서만 사용할 수 있습니다. 32비트 운영 체제에 Tableau Desktop을 설치하려는 경우 제품 다운로드 및 릴리스 정보 페이지를 열고 10.4 이하 버전에 대한 설치 프로그램을 다운로드한 후 해당 버전에 대한 Tableau Desktop 배포 가이드의 지침을 따르십시오.

가장 최신 버전의 Tableau Desktop 또는 Tableau Prep Builder를 구하려면 고객 포털 페이지로 이동하십시오. 제품 다운로드 섹션에서 해당하는 링크를 클릭하여 제품 및 운영 체제에 대한 설치 프로그램을 다운로드합니다.

제품 다운로드 및 릴리스 정보 페이지에서 모든 제품 및 버전에 대한 설치 프로그램을 찾을 수 있습니다.

  1. 제품 다운로드 및 릴리스 정보 페이지를 열고 페이지 왼쪽의 목록에서 Tableau Desktop 또는 Tableau Prep Builder를 선택합니다.

  2. 설치하려는 버전을 클릭합니다.

  3. 페이지의 파일 다운로드 섹션에서 운영 체제에 대한 설치 프로그램을 클릭하여 다운로드합니다.

제품 키의 위치

설치 프로세스를 마친 후 Tableau Desktop 및 Tableau Prep Builder를 활성화하려면 제품 키가 필요합니다. 제품 키는 항상 고객 포털에서 확인할 수 있습니다.

참고: 고객 포털 페이지에 로그인하는 데 문제가 있거나 제품 키를 찾는 데 도움이 필요한 경우 고객 서비스 팀에 문의하고 사용자 이름, 회사, 전화 번호 및 이메일 주소를 제공하십시오.

신규 사용자

  1. Tableau 웹 사이트에서 이메일 주소와 암호를 사용하여 고객 포털 페이지에 로그인합니다. 포털에 처음으로 로그인하는 데 필요한 정보는 제품 구매 후 Tableau가 보내는 환영 이메일로 전송됩니다.

  2. Tableau 고객 포털 페이지의 맨 위에서 My Keys(내 키)를 클릭합니다.

  3. 할당된 제품 키가 나열된 테이블이 열립니다. 표의 Key Name(키 이름) 열에서 제품 키를 복사합니다. 이 키를 사용할 수 있도록 준비하고 안전하게 보관하십시오.

    참고: 이 예제에는 실제 키가 나와 있지 않습니다. 하이라이트된 영역이 키가 나열되는 위치입니다.

기존 사용자

  1. Tableau Desktop 또는 Tableau Prep Builder의 기존 버전을 엽니다.

  2. 상단 메뉴에서 도움말 > 제품 키 관리를 클릭합니다.

  3. 표의 제품 키 열에서 제품 키를 복사합니다. 이 키를 사용할 수 있도록 준비하고 안전하게 보관하십시오.

    제품 키 관리 대화 상자를 열어 키를 볼 수 없는 경우 고객 포털에 로그인하고 위의 신규 사용자용 지침을 따르십시오.

제품 키가 없는 경우 14일간 사용할 수 있는 무료 평가판을 사용하거나, 대신 Tableau Desktop Public Edition을 다운로드하십시오. 학생 또는 교사인 경우 교육 프로그램 페이지로 이동하여 라이선스를 요청하고 Tableau Desktop 또는 Tableau Prep Builder 복사본을 다운로드하는 방법에 대한 지침을 받으십시오.

제품 설치

설치 프로그램의 위치에 나와 있는 지침을 사용하여 설치 프로그램을 다운로드합니다. Mac의 경우 설치 프로그램은 다운로드 폴더에 다운로드됩니다.

참고: 설치 프로그램은 운영 체제 표시 언어 설정을 기반으로 사용자 인터페이스를 감지하여 표시합니다.

Tableau Desktop 또는 Tableau Prep Builder 설치에 Windows 설치 프로그램(.msi 파일)이 필요한 배포 도구를 사용하는 경우 Windows (MSI) 설치 프로그램 추출 및 실행의 지침에 따라 Tableau 설치 프로그램 .exe 파일에서 .msi 파일을 추출할 수 있습니다.

아래에서 설치하려는 제품에 대한 탭을 클릭하여 설치 단계를 확인하십시오.

  1. Tableau Desktop을 설치하려는 컴퓨터에 관리자로 로그인합니다.

  2. 운영 체제에 따라 다음 중 하나를 수행합니다.

    • Windows: 설치 프로그램을 실행하고 화면에 표시되는 메시지에 따릅니다.

    • Mac: 디스크 이미지 파일(.DMG)을 열고 설치 프로그램 패키지(.PKG)를 두 번 클릭하여 설치를 시작합니다.

    일부 데이터 원본의 드라이버는 Tableau Desktop을 설치할 때 자동으로 설치됩니다. 자세한 내용은 설치 전 수행할 작업 항목에서 Tableau Desktop 및 Tableau Prep Builder와 함께 설치되는 데이터베이스 드라이버 섹션을 참조하십시오.

  3. 사용량 보고 기능을 사용하거나 사용하지 않도록 설정하려면 다음 중에서 운영 체제에 맞는 단계를 완료하십시오.

    이 옵션을 사용하면 제품 개선에 사용할 사용 패턴 데이터를 수집할 수 있습니다. 이 옵션에 대한 자세한 내용과 설치 후 이 옵션을 해제하는 방법에 대해서는 사용 현황 보고 해제를 참조하십시오.

    Windows

    • 이 제품을 개선할 수 있도록 사용 현황 데이터를 Tableau와 공유 확인란을 선택하거나 선택 취소합니다.

    Mac

    • 설치 유형 단계에서 설치 마법사의 왼쪽 아래에 있는 사용자 지정을 클릭합니다. 제품 사용 현황 데이터 전송 확인란을 선택하거나 선택 취소합니다.

      Mac에서는 이 페이지에서 설정을 변경하여 설치를 사용자 지정할 수도 있습니다.

  4. (선택 사항) Windows에서 설치를 사용자 지정하려면 설치 시작 화면에서 사용자 지정을 클릭하고 다음 옵션을 변경합니다.

    • 설치 위치: Tableau Desktop을 설치할 다른 위치를 지정합니다.

      중요: 설치 위치에 사용자 지정 디렉터리를 지정하고 이후의 릴리스를 동일한 위치에 설치할 계획이라면 설치할 버전별 하위 폴더를 지정해야 합니다. 그렇지 않은 경우 먼저 이전 버전을 제거해야 합니다. 동일한 하위 디렉터리에 여러 버전을 동시에 설치하는 것은 지원되지 않습니다.

    • 바탕 화면 바로 가기 만들기: 자동으로 Tableau 바탕 화면 바로 가기를 만들지 않으려면 이 확인란을 선택 취소합니다.

    • 시작 메뉴 바로 가기 만들기: 자동으로 시작 메뉴에 Tableau 바로 가기를 추가하지 않으려면 이 확인란을 선택 취소합니다.

    • Tableau 제품 업데이트 확인: 제품 업데이트 기능을 사용하지 않으려면 이 확인란을 선택 취소합니다. 이 기능은 유지 관리 업데이트를 확인하고 자동으로 설치합니다. 설치 시 이 옵션을 사용하지 않도록 설정한 경우 사용자의 메뉴 옵션도 사용하지 않도록 설정됩니다. 제품 업데이트 기능에 대한 자세한 내용은 Tableau Desktop에 대한 제품 업데이트 제어를 참조하십시오.

    • 데이터베이스 드라이버 설치: 자동으로 데이터베이스 드라이버를 설치하지 않으려면 이 확인란을 선택 취소합니다. 명령줄에서 하나 이상의 드라이버를 사용하지 않도록 설정할 수도 있습니다. 이 옵션에 대한 자세한 내용은 설치 프로그램 속성을 참조하십시오.

  5. 설치를 클릭하여 설치를 시작합니다. 문제가 있다면 Tableau Desktop 또는 Tableau Prep Builder 설치 문제 해결을 참조하십시오.

설치가 완료된 후 제품 사용을 시작하려면 제품을 활성화하고 등록해야 합니다. 자세한 내용은 제품 활성화 및 등록을 참조하십시오.

중요: Tableau Prep Builder는 Tableau Desktop과 함께 작동하도록 설계되었기 때문에 Tableau Desktop과 동일한 컴퓨터에 Tableau Prep Builder를 설치하는 것이 좋습니다.

Tableau Server를 실행하는 동일한 컴퓨터에 Tableau Prep Builder를 설치하지 마십시오. SRM(서버 리소스 관리자)은 Tableau Server 프로토콜 서버 프로세스와 Tableau Prep Builder 프로토콜 서버 프로세스를 구분할 수 없습니다. 컴퓨터 리소스가 고갈되면 SRM이 복구 메커니즘이 없는 Tableau Prep Builder에 속한 프로토콜 서버 프로세스를 종료할 수 있습니다.

  1. Tableau Prep Builder를 설치하려는 컴퓨터에 관리자로 로그인합니다.

  2. 운영 체제에 따라 다음 중 하나를 수행합니다.

    • Windows: 설치 프로그램을 실행하고 화면에 표시되는 메시지에 따릅니다.

    • Mac: 디스크 이미지 파일(.DMG)을 연 후 설치 프로그램 패키지(.PKG)를 두 번 클릭하여 설치를 시작합니다.

  3. 메시지가 나타나면 사용권 계약을 수락하여 설치를 계속합니다.

  4. 사용량 보고 기능을 사용하거나 사용하지 않도록 설정하려면 다음 중에서 운영 체제에 맞는 단계를 완료하십시오.

    이 옵션을 사용하면 제품 개선에 사용할 사용 패턴 데이터를 수집할 수 있습니다. 이 옵션에 대한 자세한 내용과 설치 후 이 옵션을 해제하는 방법에 대해서는 사용 현황 보고 해제를 참조하십시오.

    Windows

    • 이 제품을 개선할 수 있도록 사용 현황 데이터를 Tableau와 공유 확인란을 선택하거나 선택 취소합니다.

    Mac

    • 설치 유형 단계에서 설치 마법사의 왼쪽 아래에 있는 사용자 지정을 클릭합니다. 제품 사용 현황 데이터 전송 확인란을 선택하거나 선택 취소합니다.

  5. (선택 사항) 설치를 사용자 지정하려면 Windows의 설치 시작 화면이나 Mac의 설치 유형 단계에서 사용자 지정을 클릭하고 다음 옵션을 변경합니다.

    • 설치 위치(Windows만 해당): Tableau Prep Builder를 설치할 다른 위치를 지정합니다.

    • 바탕 화면 바로 가기 만들기: Windows에서 자동으로 Tableau Prep Builder 바탕 화면 바로 가기를 만들지 않으려면 이 확인란을 선택 취소합니다. Mac에서 Tableau Prep Builder 바탕 화면 바로 가기를 자동으로 만들려면 이 확인란을 선택합니다.

    • 시작 메뉴 바로 가기 만들기(Windows만 해당): 자동으로 시작 메뉴에 Tableau Prep Builder 바로 가기를 추가하지 않으려면 이 확인란을 선택 취소합니다.

    • 오류 보고 사용(Windows만 해당):Tableau Prep Builder에 문제가 발생하여 예기치 않게 종료된 경우 충돌 덤프 파일 및 로그가 생성되어 내 Tableau Prep Builder 리포지토리 > 로그내 Tableau Prep Builder 리포지토리 > 로그 > crashdumps 파일에 배치됩니다.

      설치 중에 이 옵션을 해제하려면 설치 중에 이 확인란을 선택 취소합니다. 설치한 후 이 옵션을 해제하려면 오류 보고 해제를 참조하십시오.

    • 데이터베이스 드라이버 설치: 자동으로 데이터베이스 드라이버를 설치하지 않으려면 확인란 하나(Windows) 또는 여러 개(Mac)를 선택 취소합니다.

  6. 설치를 클릭하여 제품 설치를 시작합니다.

제품 활성화 및 등록

중요: Tableau 라이선스 서비스가 2018년 10월 6일에 새로운 데이터 센터로 이동했습니다. 따라서 licensing.tableau.com 또는 licensing.tableausoftware.com에 액세스해야 하는 특수 구성(예: 정적 IP 허용 목록)이 필요한 모든 환경을 업데이트해야 합니다. 자세한 내용은 Tableau 커뮤니티를 참조하십시오.

설치 프로세스를 마친 후 다음 단계는 제품을 등록하고 활성화하는 것입니다. 제품을 활성화하려면 앞서 저장한 제품 키가 필요합니다.

제품을 설치하는 컴퓨터가 인터넷에 연결되어 있으면 설치 프로세스에서 제품 활성화를 안내합니다.

인터넷에 연결되어 있지 않은 컴퓨터에서 제품을 설치하거나 회사 방화벽 또는 프록시가 licensing.tableau.com 사이트에 액세스하지 못하도록 차단하는 경우 몇 가지 추가 단계를 완료하여 오프라인에서 제품을 활성화해야 합니다. Tableau Prep Builder를 오프라인으로 활성화하려면 Tableau Desktop을 사용해야 합니다.

버전을 업그레이드하는 중이며 마지막으로 오프라인 활성화를 완료한 이후 유지 관리 비용(Tableau Desktop만 해당)을 지불한 경우 아래 절차를 계속하기 전에 이메일로 Tableau 고객 서비스에 문의하여 업데이트된 제품 키를 받으십시오.

오프라인 활성화에 대한 자세한 내용은 오프라인으로 제품 활성화를 참조하십시오.

명령줄에서 제품을 활성화하고 등록하는 방법에 대한 자세한 내용은 Tableau Desktop 및 Tableau Prep Builder 활성화Tableau Desktop 및 Tableau Prep Builder 등록을 참조하십시오.

  1. 설치 프로세스를 마친 후 Tableau Desktop을 엽니다. 제품을 등록하고 활성화할 수 있는 Tableau 등록 양식이 시작됩니다.

  2. 등록 양식의 필드를 채운 다음 Tableau 활성화를 클릭합니다.

  3. 제품 키 입력 필드에서 기존 텍스트를 삭제하고 제품 키의 위치 절차에서 제품 키를 저장한 위치에서 제품 키를 복사하여 텍스트 상자에 붙여 넣은 다음 활성화를 클릭합니다.

    활성화 프로세스를 완료하는 두 번째 화면이 나타납니다. 계속을 클릭하여 프로세스를 마칩니다.

    Tableau가 제품 키를 인증하는 사이트에 연결할 수 없는 경우 활성화를 완료할 수 없으며, 오프라인에서 제품을 활성화해야 합니다. 오프라인으로 제품 활성화의 지침에 따라 활성화 프로세스를 완료합니다.

  1. Tableau Prep Builder를 시작합니다.

  2. Tableau Prep Builder 활성화를 클릭합니다.

  3. 제품 키를 입력하고 활성화를 클릭합니다.

  4. 등록 양식을 완성한 다음 등록을 클릭합니다.

등록이 완료되면 Tableau Prep Builder가 열리고 데이터 준비를 시작할 수 있습니다.

Tableau Prep Builder를 처음 사용하십니까? 시작하기 자습서를 통해 첫 번째 흐름을 작성하는 방법을 배워보십시오.

오프라인으로 제품 활성화

인터넷에 연결되어 있지 않은 컴퓨터에서 제품을 설치하거나 회사 방화벽 또는 프록시가 licensing.tableau.com 사이트에 대한 액세스를 제한하는 경우 아래의 단계를 완료하여 제품을 활성화해야 합니다. 이 절차의 모든 단계를 완료하려면 인터넷에 액세스할 수 있는 다른 컴퓨터에 액세스해야 합니다.

Tableau Prep Builder를 오프라인으로 활성화하려면 제품 키가 필요하며 오프라인인 동일한 컴퓨터에 Tableau Desktop 버전 2018.1 이상이 설치되어 있어야 합니다.

  1. Tableau 활성화 대화 상자에서 활성화를 클릭합니다.

  2. 오프라인 활성화에 사용할 수 있도록 파일을 저장하라는 메시지가 나타납니다. 저장을 클릭합니다.

    참고: 방화벽 또는 프록시 제한 때문에 오프라인 활성화 프로세스를 수행하는 경우 활성화 파일을 저장하라는 메시지가 나타나지 않을 수 있습니다. 이 경우에는 수동으로 네트워크에서 컴퓨터 연결을 끊고 이 절차를 다시 시작하면 활성화 파일을 저장하라는 메시지가 나타납니다.

  3. 인터넷에 연결된 컴퓨터에서 액세스할 수 있는 위치에 파일을 저장합니다. 기본 파일 이름(offline.tlq)을 사용합니다.

  4. 끝내기를 클릭합니다.

  5. 인터넷에 연결된 컴퓨터에서 웹 브라우저를 열고 Tableau 웹 사이트의 활성화 페이지로 이동합니다.

  6. 오프라인 활성화 지침에 따라 offline.tlq 파일을 제출하고 activation.tlf 파일을 만듭니다.

  7. activation.tlf 파일을 저장하고 해당 파일을 Tableau Desktop이 설치된 컴퓨터로 복사합니다.

  8. 오프라인 컴퓨터에서 activation.tlf 파일을 두 번 클릭하여 오프라인 활성화를 수행합니다.

  1. Tableau Desktop을 시작합니다.

  2. 상단 메뉴에서 도움말 > 제품 키 관리를 선택합니다.

  3. 제품 키 관리 대화 상자에서 활성화를 클릭합니다.

  4. Tableau Prep Builder 제품 키를 입력하고 활성화를 클릭합니다.

  5. Tableau Desktop이 오프라인 상태를 감지하고 다음 메시지를 표시합니다. 저장을 클릭하여 활성화 파일을 만듭니다.

  6. 오프라인 컴퓨터에서 액세스할 수 있는 위치에 파일을 저장합니다. 기본 파일 이름(offline.tlq)을 사용합니다.

  7. 인터넷에 연결된 컴퓨터에서 웹 브라우저를 열고 Tableau 웹 사이트의 활성화 페이지로 이동합니다.
  8. 지침에 따라 방금 만든 (offline.tlq) 파일을 선택하고 업로드하여 activation.tlf 파일을 만듭니다. Tableau Prep Builder를 활성화하려면 이 파일이 필요합니다.

  9. 활성화 파일 업로드를 클릭합니다. 업로드가 성공했음을 알리는 확인 대화 상자가 표시됩니다.

  10. 확인 대화 상자에서 활성화 파일을 다운로드하는 링크를 클릭하여 활성화 프로세스를 완료합니다.

  11. Tableau Desktop을 닫습니다.

  12. Tableau Prep Builder를 시작합니다. 등록 프로세스 양식을 작성하여 제품을 등록하라는 메시지가 표시됩니다. 이전에 Tableau 제품을 등록한 경우 필드가 자동으로 채워질 수 있습니다.

기본 설정 변경

설치 중에 Tableau는 표시 언어 및 리포지토리 위치에 대한 기본 설정을 구성합니다. 이러한 설정을 변경하려면 설치가 완료된 후에 이 작업을 수행할 수 있습니다.

Tableau에서 사용량 보고 또는 자동 제품 업데이트(Tableau Desktop만 해당) 같은 특정 기능을 기본적으로 사용할 수도 있습니다. 이러한 기능을 해제하는 방법 등에 대한 자세한 내용은 설치 후 설치 설정 변경을 참조하십시오.

표시 언어 설정(선택 사항)

Tableau Desktop 또는 Tableau Prep Builder를 처음 실행하면 사용자 로캘 설정을 사용하여 컴퓨터 로캘이 인식되고 지원되는 경우 적절한 언어가 사용됩니다. 지원되지 않는 언어를 사용하는 경우 응용 프로그램이 기본값인 영어로 설정됩니다.

상단 메뉴에서 도움말 > 언어 선택을 선택하여 사용자 인터페이스(메뉴, 메시지 등)가 다른 언어로 표시되도록 Tableau Desktop 또는 Tableau Prep Builder를 구성할 수 있습니다. 변경 사항을 적용하려면 응용 프로그램을 다시 시작합니다.

Tableau Prep Builder의 경우 숫자 및 날짜의 표시 형식은 응용 프로그램이 설치되어 있는 컴퓨터의 운영 체제 로캘에 기반합니다. Tableau Desktop의 경우 통합 문서에 대한 날짜 및 숫자 형식을 구성할 수 있습니다. 자세한 내용은 Tableau 사용자 도움말에서 언어 및 로캘을 참조하십시오.

내 Tableau 리포지토리 위치 변경(선택 사항)

Tableau Desktop 및 Tableau Prep Builder를 설치하면 설치하는 동안 컴퓨터의 문서 폴더에 내 Tableau <application> 리포지토리 폴더 구조가 자동으로 만들어집니다. 로컬 컴퓨터 대신 네트워크 서버에 데이터를 유지해야 하는 경우와 같이, 이 리포지토리를 다른 위치로 이동해야 한다면 새 위치를 지정하고 Tableau Desktop 또는 Tableau Prep Builder에서 새 폴더를 가리킬 수 있습니다.

리포지토리의 새 위치를 설정할 때 다음 규칙이 적용됩니다.

  • 새 폴더는 디렉터리여야 합니다.

  • 새 폴더에 쓸 수 있는 사용 권한이 있어야 합니다.

  • 새 폴더는 기존 내 Tableau 리포지토리 폴더 구조 내부에 위치할 수 없습니다.

참고: 리포지토리 위치를 변경해도 원래 리포지토리에 포함된 파일은 이동하지 않습니다. 대신 파일을 저장할 수 있는 새 리포지토리가 만들어집니다.

  1. Tableau Desktop 또는 Tableau Prep Builder를 엽니다.

  2. 상단 메뉴에서 파일 >리포지토리 위치를 선택합니다.

  3. 리포지토리 폴더 선택 대화 상자에서 새 리포지토리 위치로 작동할 새 폴더를 선택합니다.

  4. 새 리포지토리를 사용하려면 응용 프로그램을 다시 시작하십시오.

의견을 주셔서 감사합니다! 피드백을 제출하는 동안 오류가 발생했습니다. 다시 시도하거나 메시지를 보내십시오.