Ideally, everybody in an organization can run the same version of Tableau Desktop or Tableau Server, but that's not always possible. In a large organization, different individuals or groups might need to use different versions of Tableau products.

This article describes compatibility considerations and how Tableau Desktop, Tableau Prep Builder, and Tableau Server can work together.

Note: This article discusses only Tableau products that are still eligible for technical support. Tableau provides technical support on each version of the product for 24 months after release. For a list of versions and their support schedules, see the Support Services(Link opens in a new window) page on the Tableau website

Compatibility between Tableau Desktop and Tableau Server

Compatibility issues typically arise only between release upgrade versions of Tableau product rather than maintenance releases. For example, if you are using Tableau Desktop 2022.1 and others are using Tableau Desktop 2021.4, or if you need to publish to Tableau Server and it is still running version 2021.1, you can encounter compatibility issues.

Important Tableau products are not always released at the same time. For example, a new upgrade release of Tableau Desktop might be available, but a compatible version of Tableau Server might not be available for several months. When installing a new version Tableau Desktop, make sure it is compatible with Tableau Server.

A workbook created with any version of Tableau Desktop can connect to any supported version of Tableau Server. But once you are connected, compatibility can be an issue depending on the version you are using and the action you're performing.

Publishing from Tableau Desktop to Tableau Server

You can publish workbooks and data sources to Tableau Server if the version of Tableau Server is the same or newer than the version of Tableau Desktop. For example, you can publish workbooks and data sources from Tableau Desktop 2021.2 to Tableau Server 2021.2, Tableau Server 2021.3, or Tableau Server 2021.4.

But if Tableau Server is running an earlier versions than Tableau Desktop, you will be prompted to downgrade the workbook before you can publish it to Tableau Server. For example, you can downgrade a workbook created on Tableau Desktop version 2022.1 to publish it to Tableau Server version 2021.3. For more information about how to downgrade your workbook, see Downgrade your workbook in this article.

Downloading workbooks from Tableau Server

A workbook downloaded from Tableau Server has the same version as the version of Tableau where it was last edited. For example, suppose Amanda is running Tableau Desktop 2021.2 and publishes a workbook to Tableau Server 2021.3. If Zachary is also running Tableau Desktop 2021.2, he can connect to Tableau Server, download the workbook, and open it.

However, there are some scenarios where compatibility issues can arise:

  • If someone else edits and saves the workbook on the server, the workbook is updated to that version of Tableau Server.

  • If someone downloads the workbook from Tableau Server to a newer version of Tableau Desktop and edits, saves, and publishes it, the workbook is updated to the newer version of Tableau Desktop.

For example, suppose Elizabeth publishes a workbook from Tableau Desktop 2021.2 to Tableau Server 2021.3. Ted downloads the workbook from Tableau Server to Tableau Desktop 2021.3. He edits and republishes the workbook back to the server. The workbook is now updated to the newer version. Zachary and Elizabeth, who are both using Tableau Desktop 2021.2 can download the workbook but can't open it because the workbook has been updated to Tableau version 2021.3.

Connecting to published extracts

Extracts that use a .tde file format are automatically upgraded to the .hyper format when they are refreshed (full or incremental) or appended to. For more information about the .hyper extract format, see Extract Upgrade to .hyper Format(Link opens in a new window).

For previous versions of Tableau Server, any published workbook or data source with an extract created in Tableau Desktop retains its original version when it's refreshed or appended to on Tableau Server.

Connecting to Tableau Server-based data sources

Workbooks in Tableau Desktop can use data sources that have been published to later versions of Tableau Server. However, if you connect to a data source that uses features that aren't in that earlier version of Tableau Desktop, those fields are unavailable.

Workbooks created in Tableau Desktop can always use data sources from an earlier version of Tableau Server. For example, a Tableau Desktop 2022.1 workbook can use data sources from Tableau Server 2021.1.

Compatibility between versions of Tableau Desktop

Tableau Desktop users can share workbooks—for example, by emailing them or copying them to a location on the company network. But if two users are using different versions of Tableau Desktop, sharing isn't always possible. The rule is simple:

  • A newer version of Tableau Desktop can open a workbook created with an older version.

  • An older version of Tableau Desktop can't open a workbook created with a newer version.

For example, suppose Amanda creates a Tableau workbook with version 2021.3 of Tableau Desktop and sends it to Zachary, who has version 2022.1 of Tableau Desktop. Zachary will be able to open that workbook, but he'll see this warning message:

The workbook will be upgraded when it is saved. The upgraded file can't be read by earlier versions of the application.

If Zachary edits and saves the workbook and sends it back to Amanda, he will need to downgrade the workbook first so that she can open it. If not, the load will fail when Amanda tries to open it in Tableau Desktop version 2021.3, because the workbook is now a 2022.1 workbook.

For more information about downgrading your workbook between Tableau Desktop versions, see Downgrade your workbook in this article.

Working with Tableau extracts

A newer version of Tableau Desktop can open an extract created with an older version but an older version of Tableau Desktop can't open an extract created with a newer version.

However if you create a .tde extract in an older version and open the workbook in Tableau Desktop 10.5 and later and refresh (full or incremental) or append to the extract, it will be converted to the .hyper format and the workbook will become incompatible with older versions of Tableau.

Note: Starting in version 2020.3, Tableau Data Extract (.tde) files are no longer supported and should be converted to a .hyper format.

For more information about the .hyper extract format, see Extract Upgrade to .hyper Format(Link opens in a new window).

Downgrade your workbook

If you need to publish your workbook to an earlier version of Tableau Server or share your workbook with someone using an earlier version of Tableau Desktop, you can downgrade your workbook to a previous version. The downgraded workbook can be opened in the selected version and later.

Tableau only supports downloading product versions for 24 months after release. Versions older than 24 months have reached their End of Life and are no longer provided.

Export workbook to previous version

You can export your workbook to a different version of Tableau using File > Export As Version in Tableau Desktop, or select Download > Tableau Workbook in the toolbar of a workbook in Tableau Online or Tableau Server. For more information, see Export Views and Workbooks.

Downgrade workbook for Tableau Server

If you are using a newer version of Tableau Desktop and an older version of Tableau Server, you can downgrade the workbook to the older Tableau Server version during publishing.

When you publish the workbook, you will see a warning message that tells you that the workbook will be downgraded.

If you continue to publish the workbook, any features or functionality that aren't available in the older version are removed for compatibility. You may need to add back the features that were removed when the workbook was downgraded.

Note: This option doesn't apply to data sources.

Tableau Prep Builder Compatibility

For details about Tableau Prep Builder compatibility, see Version Compatibility with Tableau Prep in the Tableau Prep Builder help.

Tableau Prep Conductor

Tableau Prep Conductor was introduced as part of the Data Management Add-on in Tableau Server version 2019.1.

  • To schedule flows to run on Tableau Server, you must be using Tableau Server version 2019.1 or later and Tableau Prep Conductor must be enabled.
  • To schedule flows to run on Tableau Online, you must be using Tableau Online version 2019.3 or later and Tableau Prep Conductor must be enabled.
  • Publishing from a newer version of Tableau Prep Builder to an older version of Tableau Server can result in compatibility issues. For example, new features added in Tableau Prep Builder version 2021.3.1 may not be compatible with Tableau Server version 2021.2 but would be compatible with Tableau Server version 2021.4 and any later major versions of Tableau Server, such as version 2022.1.

Compatibility between different versions of Tableau Prep Builder and Tableau Server

Publishing from a newer version of Tableau Prep Builder to an older version of Tableau Server can result in compatibility issues. For example, new features added in Tableau Prep Builder version 2021.3.1 may not be compatible with Tableau Server version 2021.2 but would be compatible with Tableau Server version 2021.4 and any later major versions of Tableau Server, such as version 2022.1.

In Tableau Server, Tableau Prep Conductor detects the features that are included in a flow when it has been published. If it finds features that it doesn't support, the flow can still be published to Tableau Server, but the flow can't be run, scheduled, or added to a task. Tableau Online is updated automatically on a regular basis, so is generally compatible with all versions of Tableau Prep Builder.

If you have an older version of Tableau Server, you can still run incompatible flows manually in Tableau Prep Builder or using the command line. For more information about using this process, see, Refresh flow output files from the command line.

Compatibility between different versions of Tableau Prep Builder

You may encounter compatibility issues when you try to open a flow between newer and older versions of Tableau Prep Builder or even when opening flows in the same version of Tableau Prep Builder using different computers.

For example:

  • The flow includes input connectors or features that aren't supported in the version where the flow is opened.
  • The machine that you use to open the flow doesn't have the required input connectors installed or has a driver version for the connector that isn't compatible. Tableau Prep Builder requires 64-bit drivers to be installed to work with flow input connectors. If compatibility is an issue, when you try to open the flow, the flow may open but contains errors or the flow won't open at all and you receive an error message.

Tableau Online Compatibility

Tableau Online is a secure, cloud-based solution for sharing, distributing, and collaborating on content created in Tableau. Tableau Online servers are typically upgraded when a new major version of Tableau is released. When this happens, you need to consider how to maintain compatibility with your existing environment, which can contain Tableau Desktop installations, Tableau Bridge, and any existing scripts or processes that use the Tableau command-line utilities, such as tabcmd and the Tableau data extract utility.

For information on what constitutes a major upgrade, see Upgrade Tableau Desktop and Tableau Prep Builder.

When to upgrade Tableau Desktop and Tableau Bridge to work with Tableau Online

After Tableau Online is upgraded to a new major version, you can still publish data sources and workbooks from earlier versions of Tableau Desktop. However, you will need to upgrade to the latest major version of Tableau Desktop to do the following:

  • Download and open a published workbook that has been edited and saved in the Tableau Online web editing environment.

  • Make a local copy of a data source.

  • If multi-factor authentication (MFA) is enabled with Tableau authentication, Bridge clients must be running Tableau Bridge version 2021.1 and later. For more information about Tableau with MFA, see About multi-factor authentication and Tableau Online(Link opens in a new window).

If you try to use such a workbook or data source in a Tableau Desktop version that is earlier than that of the Tableau Online servers, you will receive the following error:

This file was created by a newer version of Tableau. Please upgrade Tableau Desktop to the version (or greater) that the file was saved in.

The latest Tableau Bridge client is installed when you install a new major version of Tableau Desktop. It starts automatically and resumes any extract refreshes that you set up with the previous versions.

When to upgrade tabcmd for site administration

If you use tabcmd to administer your Tableau Online site—for example, to automate the tasks of uploading workbooks, managing users, and so on—you will need the most recent version of tabcmd to run these tasks. Using an outdated version of tabcmd will cause errors and unpredictable results.

For more information and the current supported version of tabcmd, see Install tabcmd(Link opens in a new window) in the Tableau Online help.

Use the Tableau data extract utility for refreshing data sources

The Tableau data extract command-line utility is installed automatically with Tableau Desktop. If you use this tool to push data to a published data source on Tableau Online, consider the following requirements:

  • You will need to use the site ID instead of the site name.

    The site ID is part of the Tableau Online URL. For example, in the following, the site ID is WidgetWorks:

    https://online.tableau.com/t/WidgetWorks/view/projects

    For more information about the -t option, see Automate Extract Refresh Tasks(Link opens in a new window) in the Tableau Online help.

  • After you publish a data source to Tableau Online, you must refresh the data in the published data source using the data extract utility that comes with the Tableau Desktop version that matches the Tableau Online version.

Thanks for your feedback!