Tableau 新增功能

瀏覽新功能摘要來瞭解當前支援的版本。

檢閱版本資訊與已知問題

最佳作法是檢閱您要安裝或升級到的 Tableau Desktop 版本的版本資訊。這對於升級最重要,因為它可以幫助您瞭解版本變更的影響,但是初次安裝 Tableau Desktop 的客戶也可以在已修正問題的清單中找到有用的資訊。

版本 2020.3 中新增

安裝和部署 Tableau

升級時保留最近的工作簿與設定

現在,當您將 Tableau Desktop 升級至下一個主要版本時,您最近的工作簿以及您最近的連線清單,和「探索」窗格中的任何組織特定設定,皆會自動匯入並還原至「開始」頁面。在先前版本中,即使您仍可在「我的 Tableau 存放庫」找到工作簿,但您的「開始」頁面會是空的。

連線到資料並準備資料

關係、資料建模,以及「資料」窗格的增強功能

Tableau 已在 2020.2 版本中引進「關係」。關係是在 Tableau 中一種充滿彈性的新方式,可以合併多資料表分析的資料。現在資料來源可在新邏輯層中支援多表資料模型。Tableau 可識別資料來源中的各別資料表,並在原生層級為每個資料表執行彙總。若要深入瞭解關係與資料建模,請參閱此「新增功能」主題中的使用關係來合併資料以進行多資料表分析

在 2020.3 中,您可以根據導出欄位建立關係,並使用關係定義中的運算子,比較用於關係的欄位。

在「資料來源」頁面中,您現在可以利用拖放來移動和取代資料模型中的資料表。

在「資料」窗格中,已新增篩選條件進行搜尋,讓您更容易尋找相關欄位。

此外,您現在可以使用將「資料詮釋」與包含多個相關資料表的資料來源搭配使用。必須針對「資料詮釋」正確設定關係的「基數」和「參考完整性」,才能分析多資料表的相關資料。

覆寫跨資料庫聯結的功能限制

透過允許 Tableau 使用您所連線的資料庫代替 Hyper 執行聯結,可以改善從單一檔案連線和單一資料庫連線聯結資料時的效能。但必須滿足某些條件,才能使用此選項。

為了讓您能夠在使用此選項時,體驗並確定最佳效能組態,身為管理員,您現在可以覆寫檔案大小、聯結類型,以及單一檔案連線限制,並強制 Tableau 使用即時資料庫連線以執行聯結。

有關詳情,請參閱改進對跨資料庫聯接的效能

結合空間檔案與聯集聯結

使用 Tableau 2020.3,探索地理資料比以往更加靈活。現在,只要空間檔案位於相同的資料來源並採用單一資料表格式,即可結合空間檔案與聯集聯結。有關詳情,請參閱合併資料(Link opens in a new window)

設計檢視和分析資料

使用預測建模函數建立預測模型和預測

使用兩個新的表計算函數,MODEL_QUANTILE 和 MODEL_PERCENTILE,您可以利用功能強大的統計引擎來進行預測,並從您的資料產生預測,以及識別未預期的值,這些操作皆使用熟悉的表計算介面。

可以在所有詳細層級篩選、彙總和轉換資料,輸入和預測會自動重新計算,以符合畫面上的資料。有關詳情,請參閱預測建模函數在 Tableau 中的運作方式。或者,參閱此部落格文章,使用預測建模函數在 Tableau 中產生預測

指定清除「參數動作」選擇時的值

現在,使用參數動作時,您可以同時清除視覺效果中的選擇和指定參數值。之前,作者無法在互動期間直接指定視覺效果傳回的參數值。如需更多資訊,請參閱參數動作

輕鬆重新整理動態參數的資料來源

之前,只有在已開啟工作簿,而且初次連線至欄位資料來源時,才可以評估動態參數查詢。現在,只需按一下按鈕,即可立即從工作簿中評估查詢。在 Tableau Desktop 中,只要按 F5,或從資料來源的內容功能表選取「重新整理」即可。在 Tableau Online 或 Tableau Server 中,按一下工具列中的「資料來源重新整理」按鈕。有關動態參數及如何使用這些參數的詳情,請參閱此部落格文章

集合控制項的增強功能

請記住,使用集合控制項,您的受眾藉由直接與檢視中的卡片互動,即可新增或移除集合成員。現在,您的集合控制項將遵循您檢視中的任何內容篩選條件。如果您是使用內容篩選條件處理大量資料來源來改善效能,並將集合的領域範圍縮小到僅包含相關資料的企業,此功能特別重要。在 Web 在製作環境中,現在也可以使用集合控制項。有關集合控制項的詳情,請參閱建立集合

使用儀表板物件下載交叉資料表檔案

使用「下載」物件(先前稱為「匯出」物件),儀表板檢視者現在可以將選取的資料表下載為交叉資料表檔案。雖然您可以在 Tableau Desktop、Tableau Online 或 Tableau Server 中製作時新增「下載」物件,但只能從 Web 瀏覽器下載交叉資料表。

有關詳情,請參閱新增儀表板窗格物件並設定其選項

比較欄位與 IN 運算子

輕鬆比較值清單與新的 IN 邏輯函數。在布林計算中,IN 運算子將採用兩個或兩個以上的欄位,如何任一欄位中的值相同,則會傳回「true」。IN 運算子結合了集合交集的功能,以及邏輯函數的靈活性和速度。有關詳情,請參閱邏輯函數(Link opens in a new window)

在 Web 上準備、製作和檢視資料

在 Tableau Online 或 Tableau Server 篩選檢視和資料來源中的資料

您現在可以在 Tableau Online 或 Tableau Server 中製作的同時,建立、編輯和移除工作簿與資料來源的篩選資料。這些改善項目包括分類、離散和相對日期篩選條件。若要在工作簿上設定篩選條件,請將欄位拖曳到篩選條件架。

如果您具有編輯資料來源的權限,可以藉由選取「資料來源」索引標籤,建立資料來源篩選條件。在「篩選條件」下,選取「新增」

有關詳情,請參閱篩選檢視中的資料篩選資料來源中的資料

在 Tableau Online 或 Tableau Server 將交叉資料表下載至 Excel

您現在可以在使用 Tableau Online 和 Tableau Server 時,將檢視下載為 .xlsx 檔案格式。此下載選項會保留數值格式,包括國際分隔字元。有關詳情,請參閱下載檢視和工作簿

在 Tableau Online 或 Tableau Server 使用 Mapbox 或 WMS 服務連線

自 Tableau 2020.3 起,您現在可以使用 Mapbox 或 WMS 伺服器連接發佈工作簿。有關詳情,請參閱使用 Mapbox 地圖(Link opens in a new window)使用 Web 地圖服務 (WMS) 伺服器(Link opens in a new window)

Tableau Online 和 Tableau Server 中相對日期篩選條件的協助工具改進

現在,在 Web 製作環境中,相對日期篩選條件既可以透過鍵盤存取,也與螢幕助讀程式相容。您可以在這裡找到 Tableau 協助工具的更多資訊。

在 Tableau Online 或 Tableau Server 建立篩選條件和「轉到工作表」動作

第一次,您可以在 Tableau Online 和 Tableau Server 中製作時,建立動作。現在,可以從儀表板和個別工作表使用「篩選」和「轉到工作表」動作。在 Web 製作模式中,已大幅簡化對選定欄位的篩選程序,可讓您指定來源和目標欄位,而無需開啟單獨的對話方塊。

有關詳情,請參閱篩選動作從一個檢視巡覽到另一個檢視、儀表板或本文

使用資料問答 (Ask Data) 精確縮小日期範圍

您現在可以精簡現有查詢,以顯示特定日期。「時段」選項會顯示一個連續日期範圍;「日期值」選項會顯示可在多個時段重複的範圍。(例如,若要查看多個年度的 Q1 綜合銷售績效,請在「日期值」下,選擇「季度」。)

有關詳情,請參閱調整日期篩選條件

使用資料問答 (Ask Data) 以自然語言顯示建議的問題

如果您是資料來源擁有者或 Tableau 管理員,您現在可以利用使用者熟悉的語言顯示建議的問題,而非顯示為正式的查詢。使用者可以按一下顯示的文字,或是在「資料問答 (Ask Data)...」方塊中輸入文字。

有關詳情,請參閱自訂建議的問題

在 Tableau Online 和 Tableau Server 進行協作和探索

尋找與您分享的項目

與您分享項目時,該項目會新增至您的「與我分享」頁面。如此一來,以後可方便尋找分享項目,而無需搜尋您的信箱或請求另一個連結。有關詳情,請參閱共用 Web 內容

Shared with Me page

資料重新整理時取得訂閱

您現在可以將電子郵件訂閱的頻率設為只有在資料重新整理時傳送。使用訂閱,可讓您按照選擇的頻率和排程,接收檢視或工作簿的電子郵件快照。將頻率設為「資料重新整理時」,表示您會知道電子郵件中的快照包含最新資料。有關詳情,請參閱建立檢視或工作簿訂閱

為 PDF 訂閱選擇新選項

您現在可以在 Tableau Online 或 Tableau Server 中建立或修改檢視或工作簿的訂閱時,選擇 PDF 附件的頁面大小和方向。有關詳情,請參閱建立檢視或工作簿訂閱

整理收藏夾的協助工具改善

您現在可以使用鍵盤來執行拖放互動,以整理您的收藏夾。有關詳情,請參閱 Tableau 在 Web 上的鍵盤協助工具

附加元件

Tableau Catalog 更新 - 資料管理附加元件的一部分

Tableau Catalog 包含在適用於 Tableau Server 和 Tableau Online 的單獨授權資料管理附加元件中。有關 Tableau Catalog 的詳情,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

此版本包括以下特色:

在 Tableau Desktop 查看資料品質警告 - 當您在 Tableau Desktop 中開啟具有資料品質警告的工作簿時,警告圖示(藍色圓圈或帶有驚嘆號的黃色三角形)會出現在工作簿之資料表頁面上的「資料」索引標籤中。有關詳情,請參閱 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 說明中的《設定資料品質警告》。

已新增「敏感資料」警告類型 - 您可以使用這項新的警告類型,為您組織中的敏感資料設定資料品質警告。有關詳情,請參閱 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 說明中的《設定資料品質警告》。

內嵌資產列在外部資產中 - 您現在可以看見內嵌資產列在「外部資產」頁面中。有關詳情,請參閱 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 說明的《內嵌資產出現在外部資產中》。

標記外部資產 - 為資料庫、資料表和欄新增標籤,此外,也可讓您使用個人身分資訊 (PII) 標記資料表和欄。有關詳情,請參閱標籤項目

已在以前版本中新增

版本 2020.2 中新增

連線到資料並準備資料

使用關係來合併資料以進行多資料表分析

關係是在 Tableau 中一種充滿彈性的新方式,可以合併多資料表分析的資料。現在資料來源可在新邏輯層中支援多表資料模型。Tableau 可識別資料來源中的各別資料表,並在原生層級為每個資料表執行彙總。

建立者可以使用關係合併表。使用邏輯資料表之間的關係即可更方便地以正確的詳細層級瀏覽與分析多資料表的資料,無需編寫專用計算來控制平均值和總計等彙總。在分析期間,Tableau 會根據工作表目前的內容查詢資料,並僅引入目前視覺效果所需的資料。

使用資料表之間的關係的資料來源之範例。邏輯層中的資料表可做為資料模型實體層中資料表的容器。

為支援多資料表分析,已變更 Tableau 介面中的多個部分。工作表中的「資料來源」頁面(畫布、資料網格)、「檢視資料」視窗與「資料」窗格均已更新,以支援多資料表分析體驗。有關詳細資訊,請參閱介面的各部分變更(Link opens in a new window)

有關關係和資料來源變更的詳情,請參閱以下主題:

觀看視訊:有關資料來源增強功能的概觀,以及在 Tableau 中使用關係的介紹,請參閱這則 5 分鐘的視訊。

在此 Tableau 部落格文章中深入瞭解關係查詢的運作方式:關係,第 1 部分:在 Tableau 中導入新的資料建模(Link opens in a new window)

設定 Proxy 以連線到 Snowflake

您可以使用自訂驅動程式參數欄位來設定透過 Proxy 連線至 Snowflake。請參閱 Snowflake

連線到 Azure Synapse Analytics(新連接器名稱)

微軟已重新命名其產品,因此 Tableau 的連接器也已重新命名。Azure SQL 資料倉儲連接器現在稱為 Azure Synapse Analytics。請參閱 Azure SQL Synapse Analytics

連線到 Esri ArcGSI Server

現在您可以讓 Tableau 連線到 Esri ArcGIS Server。請參閱Esri ArcGIS Server

連線到 Oracle 的空間欄位

您現在可以連線到 Oracle 資料來源中的空間資料欄位。如需詳細資訊,請參閱連線到資料庫中的空間資料(Link opens in a new window)

設計檢視和分析資料

新增集合控制項以便使用者快速修改集合的成員

透過「集合控制項」,您的受眾無需編輯模式即可選擇集合的成員。使用者只需直接與檢視中的卡片互動,即可新增或刪除集合成員。再加上「集合動作」,您便擁有兩種功能強大的輔助功能,可讓您輕鬆視覺化所關注的集合。

有關詳情,請參閱建立集合,或查看此部落格文章,運用集合控制項在易於使用的套件中進行強大的分析

透過直接與視覺效果互動,從集合新增或刪除值

現在,使用「集合動作」,您和您的受眾即可使用視覺效果本身為集合新增值或從集合中刪除值。與視覺效果互動並選取要加入或排除的標記即可。再加上新的「集合控制項」功能,您便擁有兩種強大的方法可深入了解資料。

有關詳情,請參閱集合動作

以「資料詮釋」控制用於分析的欄位

現在您可以指定在分析期間要針對哪些欄位建立模型。有了可選擇要在詮釋中加入及排除哪些欄位的能力,儀表板作者便可隱藏冗餘結果並新增預設排除的欄位。

有關詳情,請參閱使用「資料詮釋」功能檢查檢視中的詮釋視窗的組成

在 Web 上準備、製作和檢視資料

使用瀏覽器上傳並開啟工作簿

使用者現在無需透過 Tableau Desktop、REST API 或 TabCmd 發佈,即可將 Tableau 工作簿上傳到 Tableau 網站。在 Tableau 網站中,擁有可以發佈站台角色的 Creator 或 Explorer 使用者,可以選取「新建」>「上傳工作簿」將 .twb 或 .twbx 檔(最多 50 MB)上傳至專案。有關詳情,請參閱將工作簿上傳到 Tableau 站台

為「資料問答」(Ask Data) 自訂建議的問題

資料來源擁有者和 Tableau 管理員可資料來源的建議問題,根據組織中的使用者需求量身定制。有關詳情,請參閱自訂建議的問題

透過「資料問答」(Ask Data) 新增多個資料來源的同義字

當欄位或值在整個組織中具有類似的用法時,您可以使用資料角色跨多個資料來源套用相同的同義字。例如,如果每個子公司的業務部門皆使用相同名稱,或如果產品線有一致的子產品集合,則資料角色是一個很好的選擇。

對同義詞使用資料角色可以節省大量時間,因為您可以在 Tableau Online 或 Tableau Server 中集中管理這些同義詞。從「資料問答」(Ask Data) 中,您可以發佈新的資料角色,並套用「資料問答」(Ask Data) 或 Tableau Prep(Link opens in a new window) 中建立的現有角色。

有關詳情,請參閱為多個資料來源新增同義字

整理您最喜愛的內容

拖放卡片即可為喜愛的內容建立自訂排序。在 Tableau Online 或 Tableau Server 上的網格檢視中與收藏夾互動時,可使用此選項。有關詳情,請參閱標記我的最愛

Favorites reorder drag and drop

建立指標以追蹤資料

指標有助於追蹤資料的變更。您可以在 Tableau Online 或 Tableau Server 上的檢視中建立指標。使用指標監視金鑰編號,例如每日銷售額。有關詳情,請參閱建立指標以及指標疑難排解

Multiple metrics cards

使用 Tableau Online 和 Tableau Server 進行協作

儀表板下載至交叉資料表的改進功能

現在您可以下載到儀表板的交叉資料表,無需先選擇工作表。先前該按鈕已停用,直到您選取要匯出為 .csv 檔案的工作表為止。現在您可以選取「下載 -> 交叉資料表」,從選項清單中選擇適當的工作表。有關匯出至交叉資料表的詳情,請參閱從 Tableau Desktop 匯出資料

編輯圖例及工具提示的增強功能

在版本 Tableau 2020.2 中,即使在您登出後,調整和變更工具提示的位置也會保持不變。有關詳情,請參閱設定標題、說明、工具提示和圖例的格式(Link opens in a new window)

附加元件

Tableau Catalog 更新 - 資料管理附加元件的一部分

Tableau Catalog 包含在適用於 Tableau Server 和 Tableau Online 的單獨授權資料管理附加元件中。有關 Tableau Catalog 的詳情,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

此版本包括以下特色:

提高重要警告的可見性 - 您可以將資料品質警告設定為高度可見,以便受警告影響的視覺效果使用者看到通知,且警告在 Tableau 的其他位置會以更明顯的黃色顯示。有關詳情,請參閱 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 說明中的「設定資料品質警告」,以及瀏覽和分析檢視中的資料中的「使用資料詳細資訊查看視覺效果資訊」。

儀表板顯示在「歷程」窗格中 - 當您選擇歷程中的「儀表板」項目時,可以看到下游儀表板的清單。有關詳情,請參閱 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 說明中的「使用歷程進行影響分析」。

依照「認證」和資料品質警告篩選外部資產 - 除了使用搜尋來縮小外部資產的選擇之外,您現在還可以依照「已認證」和資料品質警告篩選資料庫、檔案和表。

連線時提供更多的篩選條件 - 連線到資料時,您可以依照連線類型篩選資料庫和表。

2020.1 版新增功能

安裝和部署 Tableau

自訂「探索」窗格

現在,您可以自訂在 Tableau Desktop 的「開始」頁面上顯示的「探索」窗格,以便顯示您的自訂內容,而不是預設情況下顯示的連結、部落格文章和 Tableau 新聞。只要建立在您所提供的 Web 伺服器上託管的專屬網頁,然後使用新的 DISCOVERPANEURL 安裝屬性來指向它即可。當您啟動 Tableau Desktop 時,就會改為顯示您自己的自訂內容。為了協助您快速入門,Tableau Desktop 提供的範本(Link opens in a new window)與 Tableau 提供的「探索」窗格建模相同的配置。只需下載範本,並將連結替換為自訂內容即可。

使用此功能可提供您組織專屬內容的連結和資訊,讓您的使用者更輕鬆快速地開始使用 Tableau。

若要在從命令列 (Windows) 安裝期間將 Tableau Desktop 設定為顯示您的自訂探索窗格內容,請加入屬性 DISCOVERPANEURL="https://yourwebpageURL"。如果您要在安裝完成後更新探索窗格內容,請針對安裝 Tableau Desktop 的每一台電腦,藉由設定至您的自訂 URL 的 DiscoverPaneURL 來新增 DiscoverPane 機碼,或在 .plist (MacOS) 中進行變更。

附註:此功能目前僅適用於 Tableau Desktop

有關詳情,請參閱《Tableau Desktop 和 Tableau Prep 部署指南》中的安裝程式屬性(Link opens in a new window)在安裝之後變更安裝設定(Link opens in a new window)

支援登入型授權管理

以登入為基礎的授權管理 可協助您在 Tableau ServerTableau Online 上管理具有 Creator 角色之使用者的授權。具有 Explorer 或 Viewer 角色的使用者不能使用此功能。如果使用角色型訂閱搭配 Tableau ServerTableau Online,您就可以使用 以登入為基礎的授權管理 來簡化授權管理,藉此免除使用個別的 Tableau DesktopTableau Prep Builder 產品金鑰。您只需要為內部 Tableau Server 管理一或多個產品金鑰;如果是 Tableau Online,則完全不需要管理任何產品金鑰。

連線到資料並準備資料

Salesforce 連接器有更新項目

我們更新了 Salesforce 連接器,提供更快的效能、更高的靈活性以及更多的資料讓您運用。首先,我們改變了連接至 Salesforce 資料的方式;連接器現在會根據資料集的大小動態切換 API,進而大幅提高效能。此外,Salesforce 連接器現在支援使用 SOQL 語言,使用方式與現在使用自訂 SQL 的方式相同,從而提高了分析的靈活性。最後,您現在能連接至其他資料物件,如 Salesforce 活動歷史記錄和行銷活動影響,藉此在 Tableau 中提供更多資料讓您查看和瞭解。

設計檢視和分析資料

使用動態參數自動重新整理參數

現在,您可以將參數的目前值設定為單值、與檢視無關之計算的結果。此外,您還可以依據資料來源欄來重新整理參數的值(或網域)清單。這表示,每次開啟工作簿且 Tableau 連線到參數引用的資料來源時,工作簿中引用該參數的每個位置都會使用最新的值或網域。

有關詳情,請參閱這篇說明動態參數的部落格文章。另請參閱建立參數

使用緩衝區函數在地圖上以視覺化方式呈現區域

以往,要找出一個點周圍的區域需要進行複雜的計算,且不能保證準確。使用新的緩衝區函數,我們可以定義從想要視覺化的點算起的精確距離。此區域將能準確反映地圖的實際區域,即使檢視因地圖投影而扭曲的點也同樣準確。有關詳情,請參閱空間函數(Link opens in a new window)

為表示轉場製作動畫

為視覺效果設定動畫,以充分突顯資料中不斷變化的模式、顯示峰值和異常值,並查看資料點如何群集和分離。

動畫會在篩選、排序和縮放設定、不同頁面,以及對於篩選條件、參數和設定動作所做的變更之間,進行視覺轉場。隨著視覺效果動畫對這些變化的回應,觀看者可以更清楚地看到資料有何不同,進而幫助他們做出更明智的決策。有關詳情,請參閱設置動畫格式

將儀表板窗格匯出為 PDF、PowerPoint 或影像

新的匯出物件可讓您的受眾快速建立儀表板的 PDF 檔案、PowerPoint 投影片或 PNG 影像。樣式和格式選項類似於巡覽物件(以前稱為「按鈕」物件)。您可以選擇顯示文字或影像、指定自訂邊框和背景顏色,以及提供資訊內容工具提示。

有關詳情,請參閱新增儀表板窗格物件並設定其選項

在「資料詮釋」中檢視狀態

「資料詮釋」視窗現在包含一個狀態列,提供說明警示、訊息和調查欄位的摘要。在寬資料集(> 500 欄)上使用「資料詮釋」時,效能應該也會提高。此外,「資料詮釋」視窗現在可以調整大小。

有關詳情,請參閱使用「資料詮釋」功能檢查檢視資料詮釋:狀態資訊

在 Web 上準備、製作和檢視資料

自動將行動電話配置新增到新的儀表板窗格

Web 製作環境現在包括預設為選取的命令:「儀表板」>「將行動電話配置新增到新的儀表板」。在大多數情況下,自動產生的行動電話配置是小型螢幕的理想選擇,但您可以隨時在 Tableau Desktop 中加以編輯。有關詳情,請參閱針對不同裝置類型建立儀表板窗格配置

改善 Web 上的工具提示格式設定

改善工具提示格式設定功能後,在 Web 上設定工作簿的格式變得更加容易。現在,您可以在工具提示中加入視覺效果,以及在 Web 製作環境中設定工作簿格式時自訂縮排。有關詳情,請參閱在工具提示中建立檢視(工具提示內部視覺效果)(Link opens in a new window)

附加元件

Tableau Catalog 更新 - 資料管理附加元件的一部分

Tableau Catalog 包含在適用於 Tableau Server 和 Tableau Online 的單獨授權資料管理附加元件中。有關 Tableau Catalog 的詳情,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

此版本包括以下特色:

新增連接器 - 從外部資產連接到更多資料。我們新增了對以下連接器的支援:Google Big Query、Google Drive、Google Sheets、Box、Dropbox 和 OneDrive。

建立工作簿 - 從「外部資產」頁面或從資料庫或表格頁面建立工作簿,以便進行目錄支援的連線。有關詳情,請參閱 Creator:Web 製作入門中的「Tableau Catalog 使用者從外部資產建立工作簿」。

篩選已認證和資料品質警告 - 依「認證」來篩選資料來源、資料庫、檔案和表格,依連線來篩選資料來源,以及依資料品質警告來篩選資料庫和表格。有關詳情,請參閱 Creator:連線到 Web 上的資料中的「開啟『連線至資料』頁面」,或是使用 Tableau Server 或 Tableau Online 連線至資料中的「從 Tableau Desktop 連線」。

增強「資料詳細資訊」窗格 -

  • 您會看到一張迷你圖,顯示過去 12 週內檢視過工作表或儀表板窗格的次數。
  • 很容易看到檢視上有警告。
  • 展開欄位可查看其中繼資料,例如說明或計算。
  • 若工作簿中的欄位繼承其說明時,請查看說明的來源。

    有關詳情,請參閱瀏覽和分析檢視中的資料中的「使用資料詳細資訊查看視覺效果資訊」。

已於版本 2019.4 中新增

安裝和部署 Tableau

與 Tableau 共用使用方式資料

Tableau 會收集有助於我們瞭解產品使用情況的資料,以便我們可以改進現有功能並開發新功能。所有使用方式資料會根據 Tableau 隱私權政策(Link opens in a new window)收集並處理。但是,如果您不想參加,則可以退出。

退出選項已變更。預設情況下啟用使用方式資料收集。如果您不想參與,請在安裝後從安裝程式或自訂安裝程式 (MacOS) 對話方塊或「説明」功能表中選取不傳送產品使用方式資料核取方塊。

有關詳細資訊,請參閱 Tableau Desktop 和 Tableau Prep 部署指南中的關閉使用方式報告(Link opens in a new window)

不再為 MacOS 自動安裝預設資料庫驅動程式

在 Mac 上安裝 Tableau Desktop 時,我們僅自動安裝 PostgreSQL 資料庫驅動程式。如果您需要其他驅動程式來連線到資料,則可以從驅動程式下載(Link opens in a new window)頁面安裝它們。

連線到資料並準備資料

新增支援六個資料連接器

使用以下連接器將 Tableau 連線到資料:

新增支援連接器外掛程式

您可以使用透過 Tableau Connector SDK 建立的連接器連接到資料。有關詳細資訊,請參閱使用 Tableau Connector SDK 組建的連接器外掛程式 有關 Tableau Connector SDK 的資訊,請參閱 GitHub 上的 Tableau Connector SDK(Link opens in a new window)

在 Tableau 中轉換 SAP HANA 層級階層

當您將 Tableau 連線至具有層級階層的 SAP HANA 計算檢視時,SAP HANA 層級階層的結構就會出現在「資料」窗格中。如果您要修改 Tableau 中的 SAP HANA 層級階層,您必須將其轉換為使用者階層。如需詳細資訊,請參閱將 SAP HANA 層級階層轉換為使用者階層

設計檢視和分析資料

製作最多 50 個欄位的資料表,並水準捲動

現在,您可以製作最多 50 個欄位的寬資料表。此外,具有離散欄位的寬資料表現在可以水準捲動。

要變更列和水準列標籤的最大數量,作者必須在 Tableau Desktop 中使用「資料表選項」對話方塊。

有關更多詳細資料,請參閱定義表結構。另外,請參見 datavis.blog(Link opens in a new window) 上 Tableau Public 大使 Marc Reid 的有關 50 欄資料表(Link opens in a new window)的帖子。

解釋資料考慮的更多資料

解釋資料現在分析資料來源中可能影響標記值的未視覺化量值。解釋顯示來源視覺效果中所有標記的目標量值與未視覺化量值之間的關係。

現在可以分析具有彙總類型 AGG 的計算欄位(例如比率計算)。對於所有未視覺化的維度和量值解釋,未視覺化的計算欄位被視為解釋的候選欄位。

從工作表移至相關儀表板和故事

要快速轉到儀表板和出現工作表的本文,請以滑鼠右鍵按一下工作表索引標籤並開啟新的適用於功能表。將此視為儀表板和本文中可用的轉到工作表命令的配套。結合使用這兩個功能,您可以快速優化工作表設計和資料,以更好地適應儀表板版面配置和本文點。

有關詳細資訊,請參閱在工作表、儀表板窗格與本文之間巡覽

輕鬆識別和選取父版面配置容器

從每個儀表板物件的功能表中,現在顯示父版面配置容器的自訂名稱,以便輕鬆識別和選取它們。

有關詳細資訊,請參閱使用配置容器組合專案

自動將電話版面配置新增到現有儀表板

要在開啟缺少電話版面配置的舊儀表板時自動建立電話版面配置, 請選擇儀表板 > 將電話版面配置新增到現有儀表板

有關詳情,請參閱自動新增行動電話配置

使用沙箱化儀表板擴充確保資料安全

新的沙箱化儀表板擴充在受保護的環境中執行,無法存取 Web 上的任何其他資源或服務。作為作者,您可以快速將沙箱化擴充合併到儀表板中,因為它們不需要 Tableau 管理員的批准。

要查看所有可用的沙箱化擴充,請造訪 extensiongallery.tableau.com(Link opens in a new window)

有關詳情,請參閱使用儀表板擴充程式

巢狀排序的增強功能

對離散量值和維度執行巢狀排序,其輕鬆程度與使用 Tableau Desktop 的巢狀排序(Link opens in a new window)功能一樣。

使用 WMS 或 Mapbox 背景地圖時改進工作流程

使用新的簡化地圖對話方塊將地圖方塊或 Web 地圖服務背景地圖新增到視覺效果。每個背景地圖現在都可以直接從「背景地圖」功能表存取。

有關詳情,請參閱使用 Web 地圖服務 (WMS) 伺服器(Link opens in a new window)使用 Mapbox 地圖(Link opens in a new window)

在 Web 上準備、製作和檢視資料

探索建議的檢視

Tableau Server 和 Tableau Online 上的新「建議」頁面為您推薦檢視以供瀏覽。建議可以幫助您在網站上找到以前可能不會遇到的有用內容。有關詳情,請參閱在您的 Tableau 網站上探索建議的檢視

Recommendations

為「資料問答」(Ask Data) 從建議類別中選擇

為幫助您使用「資料問答」(Ask Data) 快速回答問題,我們將建議分為四類:基本資料分析、日期和時間、篩選器和視覺效果類型。這些建議為您的分析提供一個很好的起點,您在以後可以輕鬆地根據需要進行修訂。

有關詳情,請參閱使用「資料問答」(Ask Data)自動組建檢視

共用指向「資料問答」(Ask Data) 視覺效果的連結

您可以快速共用「資料問答」(Ask Data) 視覺效果,甚至無須儲存工作表。只需按一下查詢方塊上方的連結圖示,然後複製任何有權存取資料來源的人員都可以檢視的連結。

使用「資料問答」(Ask Data) 比較隨時間變化的差異

現在,「資料問答」(Ask Data) 允許您將時間段與「上年同期」、「上季度同期」等字詞進行比較,或按月、周或日進行類似比較。差異可以以絕對數位或百分比表示。

有關詳細資訊,請參閱 隨時間進行比較差異

在手機上查看優化的工作表

當您在行動電話上查看單個工作表時,Tableau 會自動顯示篩選條件、圖例和其他卡片的垂直排列。

在 Web 上編輯工具提示

現在,在使用您在 Tableau Desktop 中學習的相同過程在 Web 上編輯工作簿時,您可以格式化、編輯和使用工具提示。

有關詳情,請參閱設定標題、說明、工具提示和圖例的格式

使用地圖圖層自訂 Web 上的地圖

地圖圖層允許您使用 Tableau 的 Web 編輯功能自訂地圖的外觀。

如需更多資訊,請參閱自訂地圖的外觀

使用 Tableau Online 和 Tableau Server 進行協作

透過 Tableau 網站快速共用內容

透過新的共用功能,您無需撰寫單獨的電子郵件,即可透過 Tableau 網站與他人共用內容。此外,如果對檢視進行修改,透過選取篩選條件或標記,將在共用時捕獲這些變更。有關詳情,請參閱共用 Web 內容

Share menu option

要求內容的存取權限

您現在可以要求存取您無權查看的專案、工作簿或檢視的內容。當有人要求存取權限時,Tableau 會將電子郵件路由傳送到控制該內容權限的人員。例如,如果要求的工作簿位於在專案級別(鎖定專案)控制權限的專案中,則專案擁有者將收到一封電子郵件,其中包含要求相關資訊、指向要求內容的連結以及有關如何授予存取或管理權限的說明。

有關存取選項詳情,請參閱管理 Web 項目

Tableau Online 和 Tableau Server 中檢視器的協助工具改進

在 Tableau Online 或 Tableau Server 中選取指向檢視或工作簿的連結時,可以使用螢幕閱讀器或鍵盤來導覽工具列功能表,進行協作、與可存取的檢視交互或使用「跳至內容」選項跳過導覽面板和工具列,並直接跳轉到檢視。此更新還新增鍵盤導覽的焦點指示器。以前,需要嵌入檢視才能在此層級存取體驗。有關詳細資訊,請參閱 Tableau 在 Web 上的鍵盤協助工具 ,或參閱常見問題解答:協助工具(Link opens in a new window)以瞭解 Tableau 的協助工具合規性報告 (VPAT)。

在 2019.3 版中新增

新增支援義大利文

Tableau 已新增支援義大利文。您現在可使用下列十一種語言之一設定 Tableau 顯示的使用者介面

  • 中文(簡體)
  • 中文(繁體)
  • 英文(英國)
  • 英文(美國)
  • 法文
  • 德文
  • 義大利文
  • 日文
  • 韓文
  • 葡萄牙文
  • 西班牙文

如需更多資訊,請參閱 Tableau Desktop 的「設定您的顯示語言」或 Tableau Online 及 Tableau Server 的「變更語言及地區設定」

除了在所有 Tableau 產品中新增義大利文之外,「說明」也同樣支援這些語言。若要以您偏好的語言讀取說明,請巡覽至「Tableau 說明」主頁的底部,然後從頁尾選取語言。

Menu of language options

說明設計

更輕鬆地提供意見反應

每個「說明」頁面的右下角都會顯示一個藍色的「傳送意見反應」圖示,讓您能夠更輕鬆地傳送關於主題內容的意見反應。按一下該圖示,讓我們知道主題是否對您有幫助,您也可以對需要改善的內容發表評論。

連線到資料並準備資料

使用資料庫連線執行跨資料庫聯結

在先前的版本中,在檔案與資料庫之間執行跨資料庫聯結時,Tableau 會將資料來源中的所有資料拉入 Hyper 中,並在此執行聯結。根據資料集合的大小,這項操作可能需要一些時間。

現在,若要改善效能,可以選擇允許 Tableau 使用您所連線的資料庫執行聯結。如果選擇此選項,Tableau 會確定更快的選項(Hyper 或連線的資料庫)。如果 Tableau 使用連線的資料庫執行聯結,則會將檔案資料來源中的資料複製到連線資料庫的暫存資料表中。選取這個選項之前,確定資料庫來自信任的來源。

若要查看這個新選項,請在「資料來源」索引標籤中,從支援的檔案類型新增一個連線,並從受支援的資料來源新增一個連線。此版本支援下列檔案類型及資料來源:

檔案類型

  • Microsoft Excel
  • PDF
  • 文字檔(.csv、.txt、.tsv 或 .tab)

資料來源

  • Microsoft SQL Server
  • Oracle
  • PostgreSQL
  • Vertica

「跨資料庫聯結」選項顯示在畫布的右上角。若要變更執行跨資料庫連接的方式,請按一下「編輯」

「跨資料庫聯結」對話方塊中,選取您要使用的選項。

選取的選項將顯示在畫布中。您可以隨時變更選擇。此選項在 Tableau Desktop 中可用,在 Tableau Server 中可用於 Web 編輯。

如需有關設定跨資料庫聯結處理選項的詳細資訊,請參閱改進對跨資料庫聯接的效能(Link opens in a new window)

使用 Tableau Catalog 連線至資料庫和資料表(需要資料管理附加元件)

Tableau Catalog 是資料管理附加元件的一部分,適用於 Tableau Server 和 Tableau Online。在環境中啟用 Tableau Catalog 時,除了連線到 Tableau Server 和 Tableau Online 上的發行資料來源之外,您還可以從 Tableau Desktop 上的「搜尋資料」連線至資料庫和資料表。有關詳情,請參閱使用 Tableau Server 或 Tableau Online 連線至資料。有關 Tableau Catalog 的資訊,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

Tableau Server 會隨新的「搜尋資料」頁面在「連線」窗格中上移

在 Tableau Desktop 的「連線」窗格中,「Tableau Server」會移動至窗格頂端,「搜尋資料」下方。選取「Tableau Server」以連線至 Tableau Online 或 Tableau Server。

連線到 Tableau Server 2019.3 或更高版本時,可以在「搜尋資料」頁面上搜尋和選取要連線的發行資料來源。當您在環境中啟用 Tableau Catalog(需要資料管理附加元件)時,您也可以搜尋並連線到資料庫和表格。

有關詳情,請參閱使用 Tableau Server 或 Tableau Online 連線至資料。有關 Tableau Catalog 的資訊,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

連線到網路上的空間檔案以及其他空間連接器改進項目

在 Tableau Server 或 Tableau Online 中使用 Web 製作時,會連線到空間檔案。若為 Creator,您可以在建立新工作簿和連線至資料時,在「檔案」索引標籤中上傳只需要一個檔案(以 .zip 封裝的 .kml、.geojson、.topojson、Esri shapefile,以及副檔名為 .gdb.zip 的 Esri 檔案地理資料庫)的空間檔案格式。在 Tableau Desktop 中,您現在可以連線到 .zip 資料夾和 Esri 檔案地理資料庫資料夾中的 shapefile。有關詳情,請參閱 Creator:連線到 Web 上的資料以及依據空間檔案建立 Tableau 地圖

連線到 Databricks

使用 Databricks 連接器將 Tableau 連線到 Databricks 資料庫。有關詳情,請參閱 Databricks

改善到 TabPy 的連線

客戶可以啟用 TabPy 的基本驗證,需要使用者名稱和密碼才能連線。記錄改善可更詳細地追蹤使用者執行的程式碼。有關詳情,請參閱透過分析擴充功能傳遞運算式

設計檢視和分析資料

使用「資料詮釋」功能探索並檢查檢視

使用「資料詮釋」功能檢查、發現和深入剖析視覺效果中的標記。「資料詮釋」功能藉由對統計標記提出統計詮釋為您提供瞭解資料的新視窗(包括未在目前檢視中使用的資料來源處的潛在相關資料)。

具有編輯權限的 Creator 和 Explorer 在桌面上編輯檢視或是在 Tableau Online 或 Tableau Server 中編輯網頁上的檢視時可以使用「資料詮釋」功能。

詮釋提供關於影響標記值之資料點的資訊和視覺效果。您可以開啟視覺效果以進一步探索。有關詳情,請參閱使用「資料詮釋」功能檢查檢視

透過簡化工作流程建立行動電話配置

若要永遠建立工作簿電話配置,請選取「儀表板」>「新增行動電話配置到新的儀表板」。(此命令先前標記為「自動產生行動電話配置」。)

按一下新的鎖頭圖示,快速切換自動 和手動 行動電話配置,您也可以透過快顯功能表選取:

  • 「自動產生配置」可將任意變更自動同步到預設儀表板以節省時間。

  • 「編輯配置」可建立完全獨立於儀表板的配置,讓您可以手動新增及排列項目。

    如果您已選擇編輯行動電話配置,請選取「最佳化配置」以快速最佳化篩選器的位置、移除空白區域等。(此命令之前標記為「重新排列配置」。)

有關詳情,請參閱針對不同裝置類型建立儀表板窗格配置

在 ISO-8601 日曆和標準西曆之間快速切換

透過 Tableau 2019.3,您現在可以從「日期屬性」對話方塊在使用以週為基準的 ISO-8601 日曆和標準西曆之間進行切換。

ISO-8601 以週為基準的日曆可用於建立 4-4-5 季度,這種方式可將每個季度分為 4、4 和 5 周(財務和零售報告中一種常用的系統)。

有關詳情,請參閱 ISO-8601 以週為基準的日曆(Link opens in a new window)

更多可用於參數動作的彙總

參數動作現在支援串聯(Link opens in a new window)、第一四分位和第三四分位彙總。此外,您現在可以在建立和編輯參數動作時建立參數。

使用 MAKEPOINT 轉換投影座標至緯度/經度

將投影座標轉換成緯度和經度,以用於空間分析和空間聯結。在即時資料來源上建立此函數時,此函數可讓您使用計算欄位來加入其他空間檔案的資料,方便建立空間分析的資料來源。有關詳情,請參閱空間函數在 Tableau 中聯接空間檔案

使用 DISTANCE 測量地圖上點之間的距離

使用空間函數 Distance,計算地圖上兩個相關點之間的距離。您可以指定公里、英里、公尺或英尺為測量單位。這個函數只能使用即時資料來源建立。有關詳情,請參閱空間函數

在 Web 上準備、製作和檢視資料

在 Web 製作時使用 Tableau Catalog 連線至資料庫和資料表(需要資料管理附加元件)

Tableau Catalog 可在 Tableau Online 和 Tableau Server 的資料管理附加元件中使用。當在您的環境中啟用Tableau Catalog時,除了從「此網站上」索引標籤巡覽及連線至發行資料來源,您還可以連線至更多類型的資料,例如,資料庫和資料表。有關詳情,請參閱 Creator:連線到 Web 上的資料。有關 Tableau Catalog 的詳情,請參閱 Tableau ServerTableau Online 說明中的「關於 Tableau Catalog」。

將「資料問答」(Ask Data)內嵌到網頁

使用「資料問答」(Ask Data) 詢問問題之後,工具列中將顯示「內嵌程式碼」圖示。按一下以複製程式碼,您可以將其合併到任何網頁中。

當內嵌「資料問答」(Ask Data) 的網頁載入時,「資料問答」(Ask Data) 會在不開啟視覺效果的情況下開啟資料來源,等待使用者詢問問題。

若要檢視網頁中內嵌的「資料問答」(Ask Data),使用者必須具有 Tableau 授權和權限才能連線到資料來源。

有關詳情,請參閱在網頁中內嵌「資料問答」(Ask Data)

透過「資料問答」(Ask Data)調整相對日期篩選器

若要透過「資料問答」(Ask Data)調整相對日期篩選器,請按一下「最後一個」、「上一個」、「下一個」或「下列」等文字。有關詳情,請參閱自訂欄位及其資料

透過「資料問答」(Ask Data)在上下文中顯示最大和最小異常值

當您指定如「前 5 個國家」等數值限制時,「資料問答」(Ask Data)現在可以在完整維度清單的內容中顯示異常值。

有關詳情,請參閱數值限制(上界值和下界值)

透過「資料問答」(Ask Data)新增欄位值同義字

如果您是資料來源擁有者或 Tableau 管理員,您之前只能新增欄位名稱同義字,現在您還可以新增欄位值同義字。有關詳情,請參閱新增資料問答 (Ask Data) 的同義字

搜尋您的網站時會提供改善的搜尋結果

當您在 Tableau Online 和 Tableau Server 上搜尋時,現在可以檢視搜尋結果的完整頁面。這些結果是依類型區分成區段,且可以篩選和排序結果,以提高精確度。有關詳情,請參閱搜尋 Tableau 網站

Search results page

設定內容篩選器

您現在可以建立內容篩選條件(「篩選條件」架中的「新增到內容」選項)和相依篩選條件(檢視中顯示之篩選條件控制項中的「僅限相關值」選項)。

儲存並發布資料來源和工作簿

以 PDF 附件接收訂閱

訂閱按照您設定的間隔以電子郵件向您傳送檢視或工作簿的快照,現在您可以用 PDF 附件接收這些快照。若要將訂閱設定為 PDF,在 Tableau Online 或 Tableau Server 中建立訂閱時,請選取「格式」>「PDF」「影像和 PDF」。有關詳情,請參閱建立檢視或工作簿訂閱

從選取的工作簿工作表建立 PowerPoint 檔案

當您想要從 Tableau 工作簿或儀表板建立 PowerPoint 檔案時,您可以選取要包含的工作表和本文。每個選取的工作表(如果匯出本文,則為本文點)都會變為產生的 PowerPoint 檔案中的投影片。有關詳情,請參閱從 Tableau Desktop 將檢視匯出到另一個應用程式

使用 Tableau Online 和 Tableau Server 進行協作

共用更多其他內容類型

除了之前便可共用的檢視之外,專案、工作簿、資料來源及流程都有方便共用的連結。有關詳情,請參閱共用 Web 內容

Share menu option

2019.2 版新增功能

自訂語言

Tableau 支援十種不同的語言供您選用

Tableau 已新增支援兩個語言:繁體中文和英文(英國)。您現在可將 Tableau 顯示的使用者介面設定為下列十種語言之一:

  • 中文(簡體)
  • 中文(繁體)
  • 英文(英國)
  • 英文(美國)
  • 法文
  • 德文
  • 日文
  • 韓文
  • 葡萄牙文
  • 西班牙文

如需更多資訊,請參閱 Tableau Desktop 的「設定您的顯示語言」或 Tableau Online 及 Tableau Server 的「變更語言及地區設定」

除了在所有 Tableau 產品中提供兩種新語言之外,「說明」也同樣支援這些語言。若要以您偏好的語言讀取說明,請巡覽至「Tableau 說明」主頁的底部,然後從頁尾選取語言。

Menu of language options

說明設計

更輕鬆地提供意見反應

每個「說明」頁面的右下角都會顯示一個藍色的「傳送意見反應」圖示,讓您能夠更輕鬆地傳送關於主題內容的意見反應。按一下該圖示,讓我們知道主題是否對您有幫助,您也可以對需要改善的內容發表評論。

連線到資料並準備資料

連線至 PostgreSQL + PostGIS 和 Pivotal Greenplum + PostGIS 空間資料

使用 Tableau,透過 PostGIS 擴展程式連線至 Pivotal Greenplum 或 PostgreSQL 中的空間資料。透過這些新的空間連接器,您可以使用 CustomSQL 篩選並驗證空間資料,或使用 RAWSQL_SPATIAL 函數來傳回空間物件以進行進階空間分析。如需詳細資訊,請參閱連線到資料庫中的空間資料

使用 Marketo 連接器的新增功能

Marketo 連接器包括以下新功能:

  • 使用大量 API 擷取所有活動、潛在客戶及潛在客戶清單 - <清單名稱> 表格的資料,從而減少 API 調用的數量。
  • 支援使用「每日 API 使用情況」和「每週 API 使用情況」表格擷取所進行的 API 調用的數量,以便您可以監控 API 使用情況而不超出您的配額。
  • 存取所有 Marketo 表格,允許您存取之前不可用的資料。

有關 Marketo 連接器的資訊,請參閱 Marketo

使用 SSL 連線至 TabPy 外部服務

在以前版本中,不支援至 TabPy 的 SSL 連線。在 Tableau Server 2019.2 中,您可以設定 SSL 連線。使用 Python 語言建立視覺效果,以便在安全環境中進行進階分析和機器學習。可以從 Tableau Server 遠端裝載 TabPy,而且您可以設定 SSL 連線以保護傳送中的資料。有關詳情,請參閱透過分析擴充功能傳遞運算式

設計檢視和分析資料

使用參數動作以互動方式設定參數值

使用參數動作,讓您的對象透過與是節效果直接互動的方式來變更參數值,例如按一下或選取標記。您可以使用參數動作驅動參考線、計算、篩選條件與 SQL 查詢。如需更多資訊,請參閱參數動作

參數動作為不使用計算即可建立摘要值和統計資料開啟新的可能性。您可以設定參數動作,以便讓使用者選取自動彙總為單個參數值的多個標記。例如,參數動作可以顯示當前選定標記的 AVG(Sales) 或 COUNTD(Orders)。

使用向量磚背景地圖平移、縮放和探索

Tableau 中的地圖現在使用向量標題以更快速地瀏覽地理資料。當您平移和縮放、標籤和圖示動態調整或調整形狀以適合檢視時,地圖顯示現在更加銳利和平滑。新的向量平鋪地圖可取代支援 Tableau 背景地圖的基礎技術,提供更加流暢和清晰的體驗。Tableau 地圖的背景製圖也已更新。

使用新地圖樣式和圖層自訂您的地圖外觀

您可以使用三種新的內置地圖樣式自訂 Tableau 地圖的外觀:街道、衛星和戶外。每種樣式均包含新的地圖圖層選項,例如興趣點和建築物輪廓,以便您可以自訂分析所顯示的資訊。如需更多資訊,請參閱自訂地圖的外觀

建立空間欄位並使用具有 MakePoint 的空間聯結

使用函數 MakePoint 將文字檔案、Excel 或其他資料來源的經度/緯度值轉換為空間欄位。此函數允許您透過使用導出欄位在空間上聯結經度/緯度資料;使彙總資料變得很輕鬆。有關詳情,請參閱空間函數在 Tableau 中聯接空間檔案

使用 MakeLine 建立起點-終點地圖

使用空間函數 MakeLine 將地圖上的相關點轉換為起點-終點地圖有關詳情,請參閱空間函數

更換儀表板中的工作表

您可以快速選取儀表板工作表並將其更換為其他工作表,同時保留任何填補、邊界或背景顏色,以及整體版面配置。

如需更多資訊,請參閱建立儀表板,並新增或更換工作表

將文字用於儀表板中的巡覽按鈕

按鈕物件可讓您的受眾從一個儀表板巡覽至另一個儀表板或其他工作表或本文。之前,這些按鈕盡可顯示影像,但現在您可以顯示文字以指示按鈕的目標。

如需更多資訊,請參閱「巡覽」和「下載」物件的詳細選項

在儀表板中顯示及隱藏浮動容器

顯示/隱藏按鈕允許儀表板檢視器切換浮動版面配置容器的可見性,僅在必要時顯示它們。當您想暫時隱藏篩選條件群組以顯示更多視覺效果時,這些按鈕特別有用。

如需更多資訊,請參閱按一下按鈕以顯示和隱藏浮動容器

自訂參考線工具提示

新增自訂文字和欄位至參考線工具提示。如需更多資訊,請參閱參考線、區間、分佈和盒(Link opens in a new window)

停用排序圖示

現在您可以停用檢視中的排序圖示,此圖示允許您在發行之前控制檢視的排序。有關詳情,請參閱在視覺效果中對資料進行排序(Link opens in a new window)

在 Web 上準備、製作和檢視資料

透過「資料問答」(Ask Data) 以對話形式詢問問題

如果您在「資料問答」(Ask Data) 中遇到新問題,可以以自然的會話風格快速修改現有問題。在顯示為「調整您的問題或清除全部以重新開始」文字方塊中,執行以下動作之一:

  • 以「依國家地區」或「12月」等措辭來新增功能。
  • 輸入「以 [新欄位名稱] 取代 [現有欄位名稱]」來取代欄位
  • 輸入「移除 [欄位名稱]」以移除欄位
  • 輸入「重設」或「清除」以清除視覺效果。

如需更多資訊,請參閱採取對話方式重述您的問題

使用「資料問答」(Ask Data) 套用簡單的計算

為增強資料分析,「資料問答」(Ask Data) 支援兩種量值之間的簡單計算,您可以使用以下符號套用這些計算:

+ 會加總量值

- 會計算兩值之間的差值

* 會計算乘積

/ 會計算相除結果

有關更多資訊,請參閱套用簡單計算

從「資料問答」(Ask Data) 建立多個工作表

您可以從資料來源中快速建立多個不同的 viz,然後將它們儲存在新的工作簿中。在「資料問答」(Ask Data) 中任何 viz 的下方,只需按一下已命名工作表右側的「新增工作表」圖示。

如需更多資訊,請參閱使用其他視覺效果新增工作表

看看其他人使用「資料問答」(Ask Data) 的方式

如果您是資料來源擁有者或 Tableau 管理員,「資料問答」(Ask Data) 會提供儀表板,其中顯示最常用的查詢和欄位、使用者按過的視覺效果結果數量以及其它有用資訊。篩選條件可讓您將資料縮小至特定使用者和時間範圍。這些統計資料可幫助您優化資料來源,從而提高使用者的成功率。

如需更多資訊,請參閱瞭解使用者如何搭配資料來源使用「資料問答」(Ask Data)

「資料問答」(Ask Data) 的其他增強功能

  • 「資料問答」(Ask Data) 現在支援熱度圖 viz,其非常適合從多個維度和量值中顯示極端值。

  • 當您將滑鼠指針暫留在左側的連續測量上時,工具提示中會出現長條圖,快速顯示可用值的範圍。

  • 「日期」、「年份」和「月份」等術語現在保留用於分析函數,因此應避免出現在欄位名稱中。如需保留術語的完整清單,請參閱「資料問答」(Ask Data) 用於分析函數的欄位名稱」
  • 欄位名稱的同義字現在僅能由資料來源擁有者以及 Tableau 管理員變更,從而為使用者提供更一致的體驗。有關詳情,請參閱新增資料問答 (Ask Data) 的同義字

在網頁製作中建立、編輯及移除參數

現在,在網頁製作中,您可以建立參數來替換計算、篩選以及參考線中的常數值。有關詳情,請參閱建立參數

以檢視器角色儲存自訂檢視表

先前建立自訂檢視需要 Creator 或 Explorer 授權,但現在 Viewer 也可以建立。任何具有自訂檢視 URL 的使用者,都可以檢視篩選條件以及其他套用的變更。不過,「自訂檢視」對話方塊中只會顯示 Creator 及 Explorer 建立的公用自訂檢視。

有關詳情,請參閱使用自訂檢視

在 Tableau Online 和 Tableau Server 中使用帶儲存程序的參數

在 Tableau Online 或 Tableau Server 中建立資料來源時,現在可以將帶參數的儲存程序新增到聯結。當儲存程序包括參數時,您將看到一個對話方塊,顯示在資料庫中定義的參數及其類型,並編輯這些參數值。如需更多資訊,請參閱使用預存程式

在狀態列中查看檢視的總標記及更多內容

瀏覽器左下角的狀態列顯示作者有關其檢視的資訊,包括選定的標記與總標記、列和欄以及彙總的比較。如需有關狀態列的更多資訊,請參閱「狀態列資訊」。

網頁製作中的拖曳欄位功能表

在網頁上建立或編輯檢視時,您可以使用拖曳欄位功能表變更欄位的彙總。只需在任何卡片或架(如列、欄或篩選條件)上右鍵按一下+拖曳(在 macOS 上,左鍵按一下+選項+拖曳),然後選取您需要的彙總類型。這會使用您選取的彙總將欄位拖曳到卡片或架上。

儲存並發布資料來源和工作簿

將本文匯出至 PowerPoint

現在,當您使用「匯出為 PowerPoint」來匯出工作簿時,每個本文點均將在 Tableau 生成的 PowerPoint 檔案中成為單獨的投影片。如需有關將工作簿匯出為 PowerPoint 的更多資訊,請參閱從 Tableau Desktop 將檢視匯出到另一個應用程式

使用 Tableau Online 和 Tableau Server 進行協作

探索 Tableau Server 和 Tableau Online 的新介面

您的 Tableau 網站現在易於開始使用,並且透過多個新頁面和巡覽變更,可輕鬆找到相關內容。

快速存取最重要的內容

登入 Tableau Online 或 Tableau Server 時,您將看到一個新的「主頁」頁面。在主頁上,您可以看到最近檢視的視覺效果,找到最新的我的最愛內容,並發現您的網站上最受歡迎的內容,以上內容都在一個位置。頁面頂端的歡迎橫幅以及動作是根據您的網站角色量身定做的,以幫助您開始使用。

Home page content overview

專用的「我的最愛」「最近」頁面可讓您存取所有最重要的內容。使用每個頁面右側上的排序和篩選條件選項來找到您尋找的確切內容。透過按一下內容的星號圖示來隨時新增或移除我的最愛內容。除主頁頁面,您還可以從左側巡覽面板存取「我的最愛」和「最近」頁面。

輕鬆巡覽您的網站

透過新的左側巡覽面板,您可以在網站上的重要頁面之間快速跳轉,包括「探索」頁面,在此頁面上您可以於一個位置查看網站上的所有內容。巡覽面板與螢幕大小相對應,可以折疊以提供最佳的瀏覽空間。

Navigation panel collapsing

以最少的中斷檢視您的資料

當您在 Tableau Online 或 Tableau Server 中探索或製作視覺效果時,左側巡覽面板會消失,為您提供更多空間進行分析。緊湊的標題允許您巡覽專案階層、搜尋網站並根據需要存取我的最愛內容。

Visualization header showing favorites

如需有關巡覽 Tableau 網站的更多資訊,請參閱瀏覽 Tableau 網站

訂閱現有的資料驅動警示

當您在任何檢視中選取「警示」時,新的面板會顯示您正在檢視的 viz 已經存在的警示。只需選取「新增我」來將您自己新增至現有警示。若要建立對其他人可見的警示,請在建立警示時選取「對其他人可見」。在 2019.2 之前建立的警示對其他人不可見,但可以更新為對其他人可見的警示。如需瞭解更多資訊,請參閱從 Tableau Online 或 Tableau Server 中傳送資料驅動型通知

2019.1 版新增功能

說明設計

Right-navigation 功能表

已經進行更新以協助您瀏覽我們的內容,包括可用於快速掃描和選取頁面上不同主題的最新右側功能表。

連線到資料並準備資料

連線至 Azure SQL 資料倉儲

使用 Azure SQL 資料倉儲連接器將 Tableau 連線至 Azure SQL 資料倉儲資料庫。有關詳情,請參閱 Azure SQL Synapse Analytics

連線至 Google Ads

您現在可以將 Tableau 連線到 Google Ads 帳戶。有關詳情,請參閱 Google Ads(Link opens in a new window)

連線至 Google Drive

使用 Google Drive 連接器直接存取 Google Drive 上的一般檔案。有關詳情,請參閱 Google Drive(Link opens in a new window)

連線至 MariaDB 

使用 MariaDB 連接器將 Tableau 連線到 MariaDB 資料。有關詳情,請參閱 MariaDB

將 SSL 與 TIBCO Data Virtualization 連接器搭配使用

您現在可以使用 SSL 將 Tableau 連線到 TIBCO Data Virtualization。有關詳情,請參閱 TIBCO 資料虛擬化

使用新的 Snowflake 連接器功能

Snowflake 連接器現在支援使用 OAuth 作為驗證方法。布林值、中位數和百分位函數支援也已新增。如需有關將 Tableau 連線至 Snowflake 資料倉儲的資訊,請參閱 Snowflake

將整合式驗證與 Denodo 連接器搭配使用

當您將 Tableau 連線至 Denodo 時,可以使用整合式驗證作為驗證方法。有關詳情,請參閱 Denodo

處理 Microsoft Excel 資料時保留區分大小寫

如果在執行聯結時需要保留資料的區分大小寫,例如區分假名的日文資料,您可以從「資料」功能表啟用「保留字元大小寫 (Excel)」選項。啟用此選項時,Tableau 將唯一標識大小寫不同的值,而不會將這些值組合起來,產生不同的列數。

如需詳細資訊,請參閱關於使用多連線資料來源(Link opens in a new window)

設計檢視和分析資料

改善兩個軸的排序和其他巢狀排序

Tableau Desktop 2019.1 對巢狀排序功能進行了重大改進。巢狀排序的新功能包括兩個軸的排序、透過排序對話方塊存取巢狀排序以及選取一個要執行巢狀排序的單一欄位。有關詳情,請參閱在視覺效果中對資料進行排序(Link opens in a new window)

新的地圖地理編碼資料

Tableau 地圖的地理編碼資料庫已進行更新。雖然大部份地圖的顯示與之前版本的 Tableau 仍然相同,但在某些情況下,資料的形狀會稍有不同或包含不同的地理編碼資料。如需特定位置資料的相關資訊,請參閱支援的地圖資料(Link opens in a new window)

為儀表板項目提供唯一名稱以方便識別

若要更清楚地區分儀表板項目,您現在可以使用「配置」窗格的「專案階層」區域或畫布上每個物件的下拉式功能表來重新命名這些項目。

有關詳情,請參閱單獨儀表板專案的大小、位置並對其進行重新排序和重新命名

靈活鎖定儀表板的 Web 內容

這是第一次您可以指定 URL 動作的精確目標,在新的瀏覽器標籤頁或網頁物件之間進行選擇。如果儀表板有多個網頁物件,您可以使用唯一的 URL 動作對準每個物件,建立視覺化的動態設計。現在您可以更容易重新命名多個網頁物件。

在此範例中,在檢視中選取標記會將緯度和經度參數傳遞到兩個不同的網頁物件,每個物件都由唯一的 URL 動作對準。(令人驚豔的網站影像由 earth.nullschool.net(Link opens in a new window) 提供。)

有關詳情,請參閱使用 URL 動作開啟網頁在儀表板中以互動方式顯示網頁

自動建立行動電話配置

預設情況下,每當您建立新的儀表板時,都會自動產生最佳化的行動電話配置。若要針對特定儀表板建立配置,請從「儀表板」選單,取消選區「自動產生行動電話配置」

預設的「使用自動配置」選項可將任意變更自動同步到預設儀表板以節省時間。如果您選擇「自行編輯配置」,電話配置會完全獨立,因此您必須手動新增和排列項目以反映「預設」儀表板的變更。

有關詳情,請參閱針對不同裝置類型建立儀表板窗格配置

在 Web 上準備、製作和檢視資料

享用改善的內容瀏覽

Tableau Online 和 Tableau Server 2019.1 可為您提供一種瀏覽共用內容的新方式。當您開啟專案時,您可以在單個網格或清單中看到專案包含的所有內容 — 工作簿、檢視、資料來源、流程及巢狀專案。尋找內容變得更加簡單,因為您不再需要瀏覽不同內容類型的單獨頁面。有關詳情,請參閱瀏覽 Tableau 網站

Project showing a mixture of content types

「資料問答」(Ask Data)以自動建立視覺效果

「資料問答」(Ask Data)推出了一種與資料互動的全新方式,讓您可在 Tableau 中鍵入問題並立即得到回應。回答以自動資料視覺效果的形式呈現,不需要手動拖放欄位或了解資料結構的細微差別。

「資料問答」(Ask Data)可讓您自然地提出複雜的問題,支援如時間系列和空間分析等關鍵分析概念以及如「去年」、「最早」和「最熱門」等交談片語的理解。

所有具有資料來源直接存取權限的使用者角色都可以使用「資料問答」(Ask Data):建立者、檔案總管和互動者。

有關詳情,請參閱使用「資料問答」(Ask Data)自動組建檢視

使用新的雲端連接器進行 Web 製作

使用 Box、Dropbox、Google Drive、Google BigQuery 和 OneDrive 連接器將 Tableau Online 或 Tableau Server 連線至您的資料。有關詳情,請參閱 Creator:連線到 Web 上的資料

使用這些改善項目準備 Web 製作資料

在 2019.1 中,Tableau Online 或 Tableau Server 中連線至新資料來源的作者現在可以執行初始 SQL連線到自訂 SQL 查詢以及新增聯結計算,以解決聯結中的欄位之間不相符的問題。

使用向量磚背景地圖平移、縮放和探索

在 Tableau Online 或 Tableau Public 上建立或發佈的地圖現在使用向量圖塊以更快速地瀏覽地理資料。當您平移和縮放、標籤和圖示動態調整或調整形狀以適合檢視時,地圖顯示現在更加銳利和平滑。新的向量平鋪地圖可取代支援 Tableau 背景地圖的基礎技術,提供更加流暢和清晰的體驗。Tableau 地圖的背景製圖也已更新。

檢視 Tableau Online 和 Tableau Public 中新的人口統計資料

Tableau Online 和 Tableau Public 中的人口統計資料來源更新,與 Tableau Desktop 不同。如果您的地圖使用 Tableau Desktop 中的人口統計資料層,當該地圖發佈到 Tableau Online 或 Tableau Public 時,您可能會注意到一些小差異,包括時間段和圖例中的值中斷。此外,發佈到 Tableau Online 或 Tableau Public 時,使用「區塊群組」資料層選項的地圖將自動更新為「人口普查」。當地圖發佈到 Tableau Online 或 Tableau Public 時,Tableau Desktop 中顯示的六個人口統計資料層將缺少:

  • 人口增長投影
  • 家庭增長投影
  • 住宅單元增長投影
  • 有效購買所得(中位數)
  • 內建年結構(中位數)
  • 居住時間(平均年數)

從 Tableau Desktop 向 Tableau Server 發佈地圖不會造成任何差異。

在桌面和行動裝置配置之間切換

如果 Tableau Online 或 Tableau Server 使用者發現行動電話或平板電腦配置太過局限,則可以按一下工具列中的「查看桌面配置」。此切換按鈕可讓使用者隨時切換回行動裝置配置。

有關詳情,請參閱確認裝置將顯示哪個配置

篩選條件改善

使用 Ctrl+ 按一下(在 Mac 上為 control-按一下)可在檢視多值篩選器中選取多個值。選取的值可以不連續,並以灰色反白顯示指示。選取值時,您可以按一下其中任意一個核取方塊以同時清除或選擇值。

儲存並發布資料來源和工作簿

將工作簿匯出和下載至 PowerPoint

只要按一下即可將工作簿中的所有檢視和儀表板匯出至 PowerPoint。此選項會透過工作簿每個工作表中的靜態影像建立新的 PowerPoint 檔案。從 Tableau Online 或 Tableau Server 產生檔案時,新的 PowerPoint 檔案會提供返回工作簿的連結,讓您能夠查看最新資料並與之互動。若要最佳化 PowerPoint 影像,請在儀表板配置中選取「大小」>「PowerPoint (1600x900)」。有關詳情,請參閱從 Tableau Desktop 將檢視匯出到另一個應用程式

在 Web 上預覽裝置配置

若要查看設計在行動裝置上的顯示方式,請在發佈完成時,按一下瀏覽器中的「預覽裝置配置」。然後在視覺效果上方選擇裝置類型,並在右側功能表中選擇特定儀表板。

有關詳情,請參閱用於發佈工作簿的全面步驟

使用 Tableau Online 和 Tableau Server 進行協作

訂閱暫停時通知我

當您訂閱檢視或工作簿時,會定期收到該內容的電子郵件快照。現在,如果您的訂閱因某些原因失敗,您將收到電子郵件通知,其中包含繼續或刪除失敗通知的連結。有關詳情,請參閱建立檢視或工作簿訂閱

已在版本 2018.3 中新增

說明重新設計

搜尋、巡覽和配置改進

產品說明內的搜尋結果已擴展為包括所有 Tableau 產品和說明文章的結果。說明版面設定和巡覽(例如目錄位置和瀏覽路徑)已更新,提供更加一致的跨產品說明體驗。

連線到資料並準備資料

在多個資料表中儲存擷取資料

您可以設定在多個資料表中儲存擷取資料。在多個資料表中儲存擷取資料可能會改善效能並有助於減小檔案大小。有關詳情,請參閱決定應以何種方式存儲擷取資料

新增其他資料庫 (JDBC) 連接器

使用其他資料庫 (JDBC)連接器連線至未列於「連線」和使用實施 JDBC (Java 資料庫連線) 標準的資料庫驅動程式下的檔案或資料庫類型。有關詳情,請參閱其他資料庫 (JDBC)

新支援的空間檔案

使用空間檔案連接器連線至 TopoJSON 檔案、Esri 檔案地理資料庫以及使用空間檔案連接器的多層 KML(鎖眼標記語言)檔案。有關詳情,請參閱依據空間檔案建立 Tableau 地圖

設計檢視和分析資料

建立密度地圖和圖表

在 Tableau Desktop、Tableau Online 或T ableau Server 中建立與互動

使用密度標記建立可協助您識別資料中的「作用點」的地圖和圖表。密度標記可讓使用者洞察到密集填入的資料,並將其視覺化為平滑表面,該表面可顯示可能由於重疊標記而隱藏的模式或相對集中度。如需有關建立密度地圖和圖表的詳細資訊,請參閱在 Tableau 中建立顯示趨勢或密度的熱度圖使用密度標記(熱度圖)組建密度標記

使用集合動作讓受眾變更設定值

在 Tableau Desktop 中建立內容以在 Tableau Desktop、Tableau Server 或 Tableau Online 中進行互動

透過與視覺效果上的標記直接互動,讓受眾選取集合中的值。您可以使用集合動作以視覺化方式驅動計算,並使用多面比較分析(例如,比例筆刷)建立視覺效果。

集合動作可跨多個集合使用,以獲得更複雜的互動。在此範例中,集合和導出欄位與類別和子類別的集合動作共同協作以根據所選標記更新視覺效果。當使用者按一下類別時,會顯示其子類別。當使用者按一下子類別時,會顯示其製造商。有關詳情,請參閱集合動作

您必須在 Tableau Desktop 中建立集合動作,才能在 Tableau Online 和 Tableau Server 中使用。

加密的 RServe 連線

從 Tableau Desktop 從加密通道連線至 RServe 作為外部服務。使用 SSL/TLS 安全連線傳輸資料以進行 RServe 整合。有關詳情,請參閱透過分析擴充功能傳遞運算式

更加輕鬆地從儀表板導覽

兩個新的儀表板功能讓導覽至其他工作表變得更加輕鬆。這兩個功能都可以保留所選篩選器和標記,並讓您導覽至作為單獨檢視發佈的工作表(不包括可見索引標籤)。

  • 按鈕物件提供從某個儀表板到另一個儀表板或其他工作表或本文的快速導覽方式。若要顯示按鈕的目的地,請新增當使用者滑鼠暫留在物件上時顯示的自訂影像和資訊性工具提示文字。

    有關詳情,請參閱新增儀表板窗格物件並設定其選項

  • 您只能在 Tableau Desktop 中建立「轉到工作表」動作,該動作讓使用者在按一下標記或工具提示功能表項目時,導覽到其他儀表板、工作表或本文。

    有關詳情,請參閱動作和儀表板

儀表板透明工作表背景

若要讓工作表變為透明,請將其背景色彩設定為「無」。透過將透明工作表與透明篩選器、螢光筆和參數組合以視覺化方式整合整個儀表板的元素。有關詳情,請參閱以視覺方式將元素與透明度整合

自動重新排列行動電話配置

當您調整行動電話配置上的儀表板項目時,按一下「行動電話」右側的快顯功能表,然後選取「重新排列配置」以最佳化篩選器的位置、移除空白區域等等。

在下面的範例中,篩選器會自動向更高位置移動,讓使用者不需要向下捲動也可以看見它們。

有關詳情,請參閱針對不同裝置類型建立儀表板窗格配置

在 Web 上準備、製作和檢視資料

改進的內容瀏覽

利用 Tableau Online 和 Tableau Server 2018.3,您可以快速預覽我們經過重新組織的 Web 製作環境 (UI)。新的 UI 使您能在一個網格或清單中查看多種內容類別型(檢視、工作簿、資料來源、流程、專案)。例如,您現在可以查看特定項目及其子專案內的所有內容。

這種新的體驗旨在使內容發現更加直觀,並且是一組旨在改進自助服務和 Tableau 內容管理的計畫變更中的第一項。

若要試用新的 UI,請要求管理員啟用我們已針對其提供的網站層級設定。有關詳情,請參閱 Tableau Server 2018.3 說明中的預覽更新的內容瀏覽體驗(Link opens in a new window)(本文也適用於 Tableau Online)。

能夠使用新 UI 之後,登入到我們的早期回饋(Link opens in a new window)網站。您可以在這裡與我們分享您的想法並取得我們的定期開發更新。

將影像物件新增至儀表板

現在,您可以在 Web 上製作內容時將影像新增至儀表板。新的影像物件可讓您調整影像最適大小、新增在按一下影像時開啟的目標 URL 以及新增替代文字,以改善使用螢幕助讀程式之使用者的協助工具。

在 Web 上檢視儀表板時,按一下「編輯」。從左側的「物件」部份,將「影像」拖曳至右側的儀表板。

有關詳情,請參閱新增儀表板窗格物件並設定其選項

複製為交叉表

若要在 Tableau Online 或 Tableau Server 基於當前工作表中的資料建立新的交叉表工作表,請以右鍵按一下(在 Mac 上,Control + 按一下)工作表標籤,並選取「複製為交叉表」。此動作會向工作簿中插入一個新工作表,並用原始工作表中的資料交叉表檢視來填充該工作表。

建立、移動和調整註釋

透過以右鍵按一下檢視(在工作表或儀表板中),然後選取註釋類型:點、標記或區域。按一下註釋以選取它,然後拖曳以移動或按一下選取控點以調整大小。再次以右鍵按一下註解可編輯或移除註解。

版本 2018.2 中新增

安裝和部署 Tableau

獨立於 Tableau Desktop 安裝 Tableau Bridge

Tableau Bridge 現在是獨立於 Tableau Desktop 進行安裝的獨立使用者端。有關 Tableau Bridge 要求、與 Tableau Desktop 以前版本的相容性以及安裝過程的詳細資訊,請參閱 Tableau Online 說明中的安裝 Tableau Bridge

附註:如果將 Tableau Bridge 與 Tableau Desktop 安裝在同一台電腦上,您可以從「伺服器」功能表中啟動 Tableau Bridge,就像您在以前版本中所做的一樣。

連線到資料並準備資料

聯結空間檔案

您現在可以聯接兩個空間檔案、空間資料庫表(僅限 Microsoft SQL Server)或跨兩個資料來源的空間欄位。有關詳情,請參閱在 Tableau 中聯接空間檔案

Intuit QuickBooks Online 連接器的增強功能

Intuit QuickBooks Online 連接器有若干變更和增強,可為您提供更多靈活性。「Sales and Expenses Line Items」(銷售額和支出行項目)表中加入了新的事務類型:「Vendor Credit」(供應商貸項)、「Credit Memo」(貸項通知單)、「Journal Entry」(日記帳分錄)、「Deposit」(保證金)、「Estimate」(估算)、「Bill Payment」(帳單付款)、「Payment」(付款)、「Purchase Order」(採購訂單)和「Refund Receipt」(退款收據)。此外,「Credit Memo」(貸項通知單)和「Vendor Credit」(供應商貸項)中新增了帳號資訊。

個別事務表現在有名為「Transaction Type」(事務)的新欄位,使您能將其他表聯接到「Sales and Expenses Line Items」(銷售額和支出行項目)表。

設計檢視和分析資料

透過按一下執行嵌套排序

您現在可以使用嵌套排序操作,而不必建立計算欄位或合併維度。有關詳情,請參閱巢狀排序(Link opens in a new window)

使用儀表板擴展程式擴展功能

借助協力廠商開發者建立的自訂物件,擴展程式可以增加儀表板功能。利用擴展程式,您可以向儀表板中新增獨特的功能,或直接將它們與 Tableau 外部的應用程式整合。

新增擴展程式很容易。在 Tableau Desktop 中或者 Tableau Online 或 Tableau Server 的 Web 製作模式下,只需將「擴展程式」物件拖到儀表板即可。然後,按一下「擴展程式庫」以從所有可用擴展程式中選取,或者按一下「我的擴展程式」以選取您之前下載的擴展程式。(若要直接瀏覽擴展程式庫,請轉到 extensiongallery.tableau.com(Link opens in a new window)。)

有關詳情,請參閱使用儀表板擴充程式

將儀表板項目與網格可視對齊

為了呈現視覺效果一致的設計,請在網格上排列儀表板項目和調整其大小。選取「儀表板」>「顯示網格」,或透過按 G 鍵快速開啟和關閉網格。

有關詳情,請參閱單獨儀表板專案的大小、位置並對其進行重新排序和重新命名

使用方向鍵精確地調整浮動專案的位置和大小

若要精確放置浮動項目,可按方向鍵移動 1 個圖元,或按 Shift + 方向鍵移動 10 個圖元。若要調整專案大小,請將 Alt (Windows) 或 Option (macOS) 新增到上面的快捷方式。

在拖動浮動儀表板項目時查看預覽

為了讓您對移動的項目在新位置中的外觀了然於心,在您拖動這些項目時將會出現預覽。

將透明的篩選器、參數和螢光筆以浮動方式放在儀表板上

若要直觀地將篩選器、參數和螢光筆連線到相關資料,請將現在預設為透明的這些項目浮動放置。文字始終保持完全不透明,從而保持易讀性。

有關詳情,請參閱平鋪或浮動放置儀表板專案

針對行動裝置自動優化儀表板配置

當您建立裝置配置時,Tableau Desktop 現在可自動針對裝置類型進行優化,調整儀錶專案的排列方式,使其最適合於電話或平板電腦。通常,這些自動配置將滿足移動使用者的所有需求,但您始終能進一步自訂配置。

有關詳情,請參閱針對不同裝置類型建立儀表板窗格配置

在對數軸上顯示負值

在 Tableau Desktop 和 Web 製作中,當您為軸選取「對數」標度時,您現在可以選取指定「對稱」以在對數標度軸上顯示包含 0 或負值的資料。若要瞭解相關詳細資訊,請參閱將軸標度變更為倒序或對數

在計算欄位中使用 ISO 8601 日期標準

建立日期計算時,您現在可以選取使用 ISO 8601 國際標準來解析計算。有關詳情,請參閱日期函數(Link opens in a new window)

在 Web 上準備、製作和檢視資料

用於 Web 製作的鍵盤快速鍵

使用鍵盤快速鍵在 Web 上快速建立和編輯檢視。有關詳情,請參閱用於 Web 製作的快捷方式

建立多連線資料來源和跨資料庫聯接

向資料來源中新增另一個連線,並使用跨資料庫聯接來合併不同資料庫中的表。可以儲存您的多連線資料來源以供組織中的其他人使用。若要瞭解有關跨資料庫聯接的詳細資訊,請參閱聯結資料(Link opens in a new window)

在 Web 上合併資料

可以建立新的並集,並新增到 Tableau Online 和 Tableau Server 中同一連線中的並集。若要瞭解詳細資訊,請參閱合併資料(Link opens in a new window)

在 Web 上對資料進行樞紐分析

在 Web 上處理基於檔案的資料來源時,您可以對資料進行樞紐分析,從交叉表格式轉換為分列格式。有關詳情,請參閱樞紐分析表資料(從資料欄到列)(Link opens in a new window)

在 Web 上複製資料

透過選取值然後按 Ctrl+C (Windows) 或 (Command+C) (macOS) 來複製資料網格中的值。或者,若要複製中繼資料網格中的值,請選取這些值,以右鍵按一下,並選取「複製」。

結構描述搜尋

使用結構描述搜尋在「資料」窗格中快速尋找欄位。

註解改進

透過以右鍵按一下檢視(在工作表或儀表板中),然後選取點或標記註解來建立和刪除註解。再次以右鍵按一下註解可編輯或移除註解。

軸上的「編輯軸」按鈕

現在可透過兩種方式開啟「編輯軸」對話方塊。將遊標暫留在靠近軸頂端(垂直軸)或右側(水準軸)的位置,並按一下出現的下拉箭頭。或者按兩下軸。

更好地控制排序

您現在可以透過在檢視中的「列」或「欄」功能區上以右鍵按一下維度欄位來存取「排序」對話方塊。

使用 Tableau Online 和 Tableau Server 進行協作

借助 @提及讓同事加入資料對話

若要讓使用者參與到討論您在檢視中找到引人注目的資料的對話中來,請在註解中 @提及他們。在您開始輸入名稱時,組織中具有 Tableau 帳戶的相符使用者將出現在清單中,您可從中進行選取。有關詳情,請參閱向檢視新增註解

在自訂檢視上快速建立資料通知

如果變更了檢視(例如,透過調整篩選器),您現在可以建立通知,而無需先儲存自訂檢視。有關詳情,請參閱從 Tableau Online 或 Tableau Server 中傳送資料驅動型通知

儲存並發布資料來源和工作簿

檢查您的工作簿在舊版本中的外觀

在將工作簿匯出到舊版本的 Tableau 之前,務必要瞭解工作簿將受到怎樣的影響。「檔案」>「匯出為」命令現在能讓您了然於心,告知您工作簿是否將受到影響,以及哪些功能不受支援。

版本 2018.1 中新增

Tableau 授權

新的以使用者為基礎的的短期授權現在可用

Tableau 現在提供了不同類型以使用者為基礎的的短期授權,以各種價位授予一系列 Web 製作及其他能力。這樣,組織將能更靈活地使用適合的授權來滿足不同使用者的資料分析和視覺化需求。若要瞭解詳情,請參閱以使用者為基礎的的授權,或者,若要檢視每個授權的能力,請參閱 Tableau 定價

安裝和部署 Tableau

透過命令列註冊 Tableau Desktop

透過命令列安裝 Tableau Desktop 時(適用於 Windows),您現在可以在安裝過程中註冊產品,而不必透過使用者介面或單獨的命令列操作來完成新使用者註冊。

新增一個包含安裝程式選項 REGISTER=“1” 的命令列。在安裝過程中,安裝程式將執行 -register 過程,並新增註冊資訊。此過程使用登入以下位置中的註冊資訊:HKEY_CURRENT_USER\Software\Tableau\Registration\Data.

有關向登入和 -register 屬性的屬性設定中新增註冊資訊的資訊,請參閱部署 Tableau Desktop(Link opens in a new window)中的「註冊 Tableau Desktop」和「安裝程式屬性」。

Mac OS 系統需求

Mac 版 Tableau Desktop 版本 2018.1 需要 Mac OS X 10.11 El Capitan 或更高版本。所有 Tableau Desktop 版本 10.0 至 10.5 均與 Mac OS X 10.10 Yosemite 相容。

連線到資料並準備資料

支援 SAP NetWeaver Business Warehouse 的遠端設定檔案

Tableau 現在支援使用位於遠端 HTTP 伺服器上的橫向 XML 檔案。

連線到 Microsoft SQL Server 中的空間資料行

現在,當您在 Tableau 中連線到可以在連線到 Microsoft SQL Server 時,將能使用空間列。您也可以使用自訂 SQL 和 RAWSQL 在 Tableau 中執行進階空間分析。有關詳情,請參閱連線到資料庫中的空間資料

新連接器名稱

從 Tableau 開始,Cisco Information Server 連接器已重新命名為 TIBCO Data Virtualization

設計檢視和分析資料

應用階梯線和跳躍線

透過在「標記」卡中按一下「路徑」屬性,將「線」標記類型變更為階梯線或跳躍線。

階梯線和跳躍線可幫助您查看和比較一段時間內的變化的增量模式。為在一段時間內保持不變並且變化或增量顯著的數值資料(例如帳戶餘額、庫存量或利率)使用這些線類型。有關詳情,請參閱在標記之間繪製路徑

分析物件提示

「分析」窗格中,可用的分析物件會因視覺效果中資料的當前狀態而異。例如,如果檢視包含堆疊標記,則無法將趨勢線應用於檢視。「分析」窗格中的工具提示解釋了某個分析物件不可用的原因,或者會提供有關要在檢視中使用該物件所需進行操作的提示。

篩選分層資料

當檢視中的資料包含分層結構時,這些欄位的篩選器可以使用「分層結構中的所有值」選項。您的篩選體驗現在將與分層結構中的父/子關係相適應。

有關篩選選項的詳細資訊,請參閱為篩選條件卡交互和外觀設定選項

隱藏工具提示內部視覺效果工作表

您現在可以隱藏用作工具提示內容視覺效果的工作表,用相同的方式也可以隱藏故事或儀表板中使用的工作表。在用作工具提示內容視覺效果的目標工作表中,按一下「隱藏」

若要再次顯示工具提示內部視覺效果工作表,請在源工作表中按一下「取消隱藏所有工作表」。有關工具提示內部視覺效果的更多詳細資訊,請參閱在工具提示中建立檢視(工具提示內部視覺效果)

重新調整儲存的叢集

叢集另存為群組,以便您能夠在其他工作表和工作簿中使用,但是它們不會自動重新整理。在基礎資料發生變化時,您現在可以使用「重新調整」選項來重新整理和重新計算已儲存叢集的資料。請參閱在資料中尋找叢集中的重新調整儲存的叢集,瞭解相關詳細資訊。

為不同的數值資料類型同步雙軸

在包含雙軸的圖表中,您現在可以同步不匹配的數值資料類型的雙軸。例如,您可以同步一個使用整數資料類型的軸和一個使用小數資料類型的軸。

僅使用箭頭在故事中巡覽

如果喜歡簡潔明瞭的巡覽樣式,請選取新的僅箭頭選項。有關詳情,請參閱建立故事

依據生成的及自訂緯度和經度欄位建立雙軸(分層)地圖

您現在可以依據 Tableau 生成的緯度和經度欄位與自訂緯度和經度欄位的組合來建立雙軸地圖。有關詳情,請參閱透過產生的緯度和經度欄位與自訂緯度和經度欄位的組合建立雙軸地圖

在 Web 上製作和檢視資料

在 Web 上連線到資料

利用 Creator 使用者授權,您可以在瀏覽器中直接連線到資料。上傳 Excel 或文字型資料來源、連線到雲端資料庫中或企業中的伺服器上儲存的資料,或連線到儲存到網站的已發佈資料。有關詳情,請參閱 Creator:在 Web 上連線到資料

在 Web 上準備資料

透過 Creator 使用授權,使用「資料來源」索引標籤來準備資料進行分析。建立聯結、新增新資料來源、使用 Data Interpreter 清理資料等。有關詳情,請參閱建立者:在 Web 上準備資料

在 Web 上調整標題大小

調整列標題的寬度和欄標題的高度。

向內嵌檢視中新增可存取工具列

作者可以啟用可存取工具列,以便所有使用者都能新增註解、下載檢視或將其與其他人共用。有關詳情,請參閱針對協助工具製作檢視中的發佈和內嵌檢視

其他 Web 製作增強功能

  • 「顯示」現在可用於儀表板。
  • 按兩下註解可編輯其文字。
  • 隱藏或顯示工具提示內部視覺效果工作表。在用作工具提示內容視覺效果的目標工作表中,按一下「隱藏」。若要再次顯示工具提示內部視覺效果工作表,請在源工作表中按一下「取消隱藏所有工作表」
  • 透過使用「階層中的所有值」篩選選項來篩選檢視中的階層式資料。
  • 透過在「標記」卡中按一下「路徑」屬性,將「線」標記類型變更為階梯線或跳躍線。
  • 按兩下軸可編輯軸設定。

使用 Tableau Online 和 Tableau Server 進行協作

使用儀表板樣板快速分析以雲端為基礎的資料

如果使用 Tableau Online,儀表板起始範本可幫助您快速製作和分析基於雲端的系統(如 Salesforce、ServiceNow、Marketo 和 Eloqua)中的資料。只需建立一個新工作簿,並選取若干針對關鍵業務指標量身定制的美觀、資訊豐富的設計即可。有關詳情,請參閱以雲端為基礎資料的 Dashboard Starter

透過刪除註解來簡化討論區對話

如果註解不必要或不準確,您可以快速將其刪除。只需按一下右上角的 X。有關詳情,請參閱向檢視新增註解

版本 10.5 中新增

安裝和部署 Tableau

透過命令列啟用 Tableau Desktop

透過命令列安裝 Tableau Desktop 時,您現在不必透過使用者介面完成啟用流程即可啟用產品,而是可以新增一個包括安裝程式選項 ACTIVATE_KEY "<key>" 的命令列。在安裝過程中,安裝程式將執行 -activate 並應用您提供的產品金鑰來自動啟用產品。

有關透過命令列安裝 Tableau Desktop 的詳情,請參閱部署 Tableau Desktop(Link opens in a new window)

透過命令列關閉驅動程式下載 (Windows)

安裝 Tableau Desktop 時,將會為您自動安裝大多數常用驅動程式。若要阻止自動安裝全部或部分這些驅動程式,您可以在安裝期間關閉該選項。

  • 若要阻止自動安裝所有驅動程式,請執行以下操作之一:

    • 在安裝過程中,從安裝程式螢幕中按一下「自訂」。然後清除「安裝資料庫驅動程式: Microsoft SQL Server、 PostreSQL 和 Amazon Redshift」核取方塊。

    • 從命令列中設定 DATABASEDRIVERS = "0"

  • 若要阻止自動安裝一個或多個這些驅動程式,請執行以下操作:

    • 保持選中「安裝資料庫驅動程式: Microsoft SQL Server、PostreSQL 和 Amazon Redshift」核取方塊,或從命令列中設定 DATABASEDRIVERS = "1"

    • 新增一個命令列,並將 DRIVER_MSSQLDRIVER_POSTGRESDRIVER_REDSHIFT 設定為「0」以禁用單獨的驅動程式。

有關透過命令列安裝 Tableau Desktop 的詳情,請參閱部署 Tableau Desktop(Link opens in a new window)

桌面作業系統需求(64 位元取代 32 位元)

從版本 10.5 開始,Tableau Desktop、Tableau Reader 和 Tableau Public(桌上出版)只能在 64 位元作業系統上執行。版本 10.4 是 Tableau Desktop、Tableau Reader 和 Tableau Public 支援 32 位元 Windows 作業系統的最後一個版本。

連線到資料並準備資料

擷取使用新的 .hyper 格式

從版本 10.5 開始,當您建立擷取時,它將使用新的 .hyper 格式。這種新格式的擷取利用改善的資料引擎,後者支援的分析和查詢效能與之前的資料引擎相同,但適用於更大的擷取。同樣,如果使用版本 10.5 對 .tde 擷取執行擷取任務,擷取將升級為 .hyper 擷取。有關詳情,請參閱擷取升級為 .hyper 格式

值計算方式的變更

為了提高資料來源效率和可擴展性,並生成與商用資料庫一致的結果,版本 10.5 中資料來源中值的計算方式可能不同。在某些情況下,這些變化可能會導致版本 10.4(及更早版本)與版本 10.5(及更高版本)之間檢視中的值和標記出現差異。這適用於擷取資料來源,並且可能適用於多連線資料來源、使用以檔案為基礎的資料即時連線的資料來源、連線到 Google Sheets 資料的資料來源、以雲端為基礎的資料來源、純擷取資料來源以及 WDC 資料來源。有關詳情,請參閱檢視中值和標記的變化

Google 驗證方法更新

從 2017 年 10 月開始,對於部分 Tableau 連接器,Google 的更新安全性要求變更了連線工作流。現在,當連線到使用 Oauth 驗證的資料時,Tableau 會在外部預設瀏覽的選項卡中開啟。受影響的連接器包括 Google SheetsGoogle BigQueryGoogle AnalyticsDropboxOneDriveBox

新的 Box 連接器

使用 Box 連接器可連線到 Box 資料。有關詳情,請參閱Box

對 IBM DB2 和 BigInsights 資料庫 SSL 驗證的支援

您現在可以使用 SSL 驗證連線到 IBM DB2 和 IBM BigInsights 資料庫。有關詳情,請參閱IBM DB2IBM BigInsights

使用擷取 API

您可以使用 Extract API 2.0 建立 .hyper 擷取。對於以前使用 Tableau SDK 執行的任務(例如發佈擷取),您可以使用 Tableau Server REST API 或 Tableau Server 使用者端 (Python) 庫。對於重新整理任務,您也可以使用 Tableau Server REST API。有關詳情,請參閱Tableau Hyper API

SAP HANA 的容錯移轉支援

Tableau 支援連線到設定為進行容錯移轉的伺服器。有關詳情,請參閱SAP HANA

SAP Sybase ASE 的 SSO 支援

您現在可以使用單一登入 (SSO) 連線到 SAP Sybase ASE 資料。有關詳情,請參閱SAP Sybase ASE

OData V4 支援

Tableau 現在支援 Odata 版本 4.0。有關詳情,請參閱OData

Oracle Eloqua 連接器更新

Oracle Eloqua 連接器現在支援累加式重新整理、對包含超過 250 個欄位的表進行驗證,並支援更多的表。有關詳情,請參閱Oracle Eloqua

設計檢視和分析資料

在工具提示中顯示視覺效果

當您製作檢視並尋找方法向受眾展示有關資料的更多詳細資訊時,您可以在工具提示中內嵌視覺效果(即「工具提示內部視覺效果」)。

當您在工具提示中顯示相關檢視時,可以幫助您的受眾更深入地瞭解資料,同時可最大限度地提高目前檢視的可用空間。有關詳情,請參閱在工具提示中建立檢視(工具提示內部視覺效果)

冪次趨勢線

向檢視中新增趨勢線時,現在可以使用「冪次」選項。若要瞭解相關詳細資訊,請參閱向視覺效果中新增趨勢線以及趨勢線模型類型中的「冪次」模型類型。

地圖資料更新和新增

在 Tableau 10.5 中,東南亞、中美洲和南美洲新增了一些城市。

包括 2018 至 2023 年統計預測的人口統計資料現在可用。

美國行政管理和預算局定義的美國核心基礎統計區域 (CBSA) 和大都市統計區域

(MSA) 已更新到 2015 年定義。

美國郵遞區號現在已有更新。

此外,中國現在已有以下更新:

  • 北京、重慶、上海和天津地區在「二級行政區域/郡/縣」地理角色中不再包含市級行政區。

  • 中國的「二級行政區域」功能(地級市、地區、盟、自治州)在 Tableau 中被視為市。這些區域的中心點也包括在「城市」地理角色中。

  • 其他城市(例如鐵門關市)現在包括在「城市」地理角色中。

  • 「一級和二級行政區域名稱」功能現在與中華人民共和國國家統計局發佈的名稱一致。

將儀表板維度擴展到 10,000 圖元

為了針對非常大的螢幕或垂直行動裝置配置優化設計,您現在可以將儀表板寬度和高度擴展到 10,000 圖元。

發佈資料來源和工作簿

在 Tableau Desktop 中降級工作簿

如果將 Tableau Desktop 中的工作簿升級到較新版本,您現在可以將其降級到以前的版本,以便使用 Tableau Desktop 10.2 及更高版本的使用者仍然能夠開啟該工作簿。若要降級工作簿,請在 Tableau Desktop 中選取「檔案」>「匯出為」,並選取要降級到的版本。然後將其儲存到「我的 Tableau 存放庫」或所選位置。

降級的工作簿可在所選版本及更高版本中開啟。將工作簿降級時,任何以前版本中不可用的功能將被移除。

有關版本相容性的詳情,請參閱使工作簿相容於舊版本

附註:對於其包含的 Tableau 擷取已在 10.5 中重新整理的工作簿,此功能不可用。擷取已轉換為使用新的 .hyper 格式,而此格式無法降級回 .tde 格式。

在 Web 製作中新建

編輯軸

您現在可以在 Web 上編輯軸。若要在 Web 上開啟「編輯軸」對話方塊,請在檢視中按兩下軸。「編輯軸」對話方塊中可用的選項包括「同步雙軸」、清除軸範圍(「重設」)以及編輯刻度線。您還可以在欄位上下文功能表(在「列」或「欄」架上以右鍵按一下度量欄位)中啟用或停用「雙軸」

其他增強功能

  • 向儀表板中新增文字物件並對其進行編輯。

  • 編輯工作表和儀表板標題。按兩下標題開啟「編輯標題」對話方塊。

  • 編輯趨勢線並檢視趨勢模型的說明。若要檢視趨勢模型,請將遊標暫留在趨勢線的任何部分上。若要在 Web 上編輯趨勢線,請按一下趨勢線並將遊標保持在原處,然後按一下「編輯」功能表。

  • 趨勢線現在包括「冪次」選項。

  • 透過將一個維度拖到「資料」窗格中的另一個維度上來建立階層。

  • 為欄位設定預設色彩屬性。

  • 對於定量色彩圖例,提供了進階設定(未包括日期)。

使用 Tableau Online 和 Tableau Server 進行協作

為使用者設定檔案上傳自訂影像

預設情況下,使用者和組現在具有反映其前兩個首字母的設定檔案影像。為了說明您直觀地區分設定檔案類型,使用者影像是圓形的,而組影像是方形的。

使用者設定檔案支援自訂影像。若要上傳影像,請轉到您的「帳戶設定」頁面,並按一下您姓名旁邊的當前影像或首字母。

如果您的組織使用 Active Directory,則預設設定檔案影像來自該系統。但在 Active Directory 下一次與 Tableau server 同步之前,會暫時顯示兩個字母的影像。

在組中訂閱使用者,並新增自訂訊息

若要快速訂閱多個使用者,您可以選取 Tableau 管理員建立的整個組。組中的每個使用者將會被單獨訂閱,使收件人清單保持完全可自訂。

您還可以向訂閱電子郵件中新增自訂訊息,闡明其內容。

有關詳情,請參閱建立檢視或工作簿訂閱

在 Tableau Online 或 Tableau Server 上重命名工作簿

無需只是為了重命名工作簿而將其重新發佈。現在,您可以在 Tableau Online 或 Tableau Server 上直接重命名工作簿。重命名時,工作簿 URL 保持不變,因此已共用的任何連結仍然有效。

只需巡覽到主「工作簿」區域,按一下工作簿右上角的彈出功能表,並選取「重命名」

若要重命名工作簿,使用者需要「儲存」使用權限。對於您擁有的工作簿,您將預設擁有該使用權限,但可能需要為其他使用者新增該使用權限。有關詳情,請參閱 Tableau 網站管理員說明中的設定權限和擁有權

版本 10.4 中新增

安裝和部署 Tableau

在安裝過程中刪除以前版本的 Tableau Desktop(僅限 Windows)

從命令列安裝最新版本的 Tableau Desktop 或 Tableau Reader 時,現在可以從機器中自動刪除這些應用程式的以前安裝版本。從版本 10.4 開始,可以將 REMOVEINSTALLEDAPP 安裝程式屬性設定設定為「1」,並且在安裝過程中,安裝程式將檢測並刪除先前安裝的 9.3 之後的任何版本。如果電腦已安裝了 Tableau Desktop 或 Tableau Reader 9.2 或更早版本,則將不會自動卸載這些版本。您必須改為手動卸載它們。

附註:Tableau Public 不使用此安裝程式屬性,因為它總是在安裝新版本時刪除以前的版本。

有關如何使用命令列設定安裝程式屬性的詳細資訊,請參閱 Tableau Desktop 部署指南中的部署 Tableau Desktop(Link opens in a new window)

降級並將工作簿發佈到較早版本的 Tableau Server

在以前的版本中,當 Tableau Desktop 和 Tableau Server 使用不同的應用程式主要版本時,向 TableBook Server 發佈工作簿可能會有問題。例如,如果嘗試將 Tableau Desktop 10.3 中製作的工作簿發佈到執行於 10.2 版本的 Tableau Server,則會收到如下所示的錯誤。

現在,在 Tableau Desktop 10.4(Windows 和 Mac)中,如果將工作簿發佈到較早版本的 Tableau Server(10.2 及更高版本)時,而會收到一條警告訊息,此訊息告訴您工作簿將降級到您正在發佈到的版本。系統會刪除工作簿中所包含但舊版本中未提供的任何特性或功能,以保持相容性。

附註:將工作簿發佈到 Tableau Server 10.1 及更早版本時,新的降級選項不可用。

你仍然可以在當前版本的 Tableau Desktop 中開啟降級的工作簿,但是可能需要新增回工作簿降級時刪除的功能。有關相容性的詳細資訊,請參閱 Tableau Desktop 部署指南中的 Tableau Desktop 和 Tableau Server 之間的版本相容性(Link opens in a new window)

連線到資料並準備資料

認證和推薦的資料來源

你有沒有想過你是否可以信任你的基礎資料,或者希望可以避免建立一個全新的資料來源?使用其他人之前發佈的經過認證的推薦資料來源,信心十足地快速製作 Tableau 檢視。

Tableau Online 和 Tableau Server 都支援已認證資料來源。這些資料來源由網站管理員和項目負責人仔細選取,並顯示獨特的認證徽章。將遊標暫留在徽章上,瞭解誰認證了資料來源,閱讀他們提供的任何描述性說明,並確認連線類型。

以下是當您在 Tableau Desktop 中連線到資料時已認證資料來源的外觀。

以下介紹如何識別 Tableau Online 或 Tableau Server 中的認證資料來源。

Tableau Server 支援已推薦資料來源這些資料來源包括個人認證的資料來源,以及根據組織的使用模式為您自動選取的其他資料來源。當您登入到 Tableau Server 時,可以存取 Tableau Desktop 中資料來源設定頁面右側的推薦資料來源。

連接器子集支援推薦的資料來源。有關詳情,請參閱使用已認證和已推薦資料來源及表

新的 Denodo 連接器

使用 Denodo 連接器連線到 Denodo 資料。有關詳情,請參閱 Denodo

Mac 上的其他資料庫 (ODBC) 連接器

如果您要連線的資料庫驅動程式實施 ODBC 標準時,那麼現在可以使用 Mac 上的其他資料庫 (ODBC) 連接器連線到資料庫。有關詳情,請參閱其他資料庫 (ODBC)

Oracle 連接器支援 SSL

設定 Oracle 使用者端後,您現在可以在本地使用 SSL 連線到 Oracle。有關詳情,請參閱Oracle

SAP GUI 7.4 支援

Tableau 支援新的 SAP UI 橫向 XML 格式。有關詳情,請參閱對 SAPUILandscape.xml 的支援

建立沒有特殊授權的 SAP BW 擷取

從 10.4 開始,您可以建立 SAP BW 擷取,而不需要特殊的產品金鑰。在 10.4 之前,SAP BW 擷取是不受支援的測試版功能。有關詳情,請參閱對 SAP BW 擷取的支援

設計檢視和分析資料

精確的儀表板間距,帶邊框和背景色彩控制

如果您以前使用空白物件來完善儀表板設定,則您真的會非常喜歡新的間距控制項。利用填補,您可以精確地在儀表板上放置各個項,同時邊框和背景色彩可使其非常醒目。

A. 外邊距 B. 藍色邊框 C. 帶淺藍色背景的內邊距

為了幫助您快速生成有吸引力的配置,預設的外部填充針對不同類型的儀表板項進行了優化。配置容器預設情況下沒有外部填充,工作表和物件有四個圖元,整個儀表板有八個圖元,用於無故障地匯出影像和 PDF。

過去,相鄰的儀表板項至少被四個圖元進行分隔,但現在您可以指定零外部填充來建立無縫設計。

Tableau Desktop 以及 Tableau Server 和 Tableau Online 的 Web 製作工作區中都提供了儀表板間距。有關詳情,請參閱在專案周圍新增邊距、邊框和背景色

Windows 對高 DPI 的支援

如果在 Windows 電腦上啟用了 DPI 縮放,現在可以自信地製作檢視,並且知道它們在 100% 縮放比例下可以像在 200% 縮放比例下一樣漂亮。

高 DPI 縮放之前 高 DPI 縮放之後

對線性幾何圖形的支援

從 Tableau 10.4 開始,您可以連線到包含線性幾何圖形的空間檔案。

若要使用線性幾何圖形建立地圖,請執行以下操作:

  1. 連線到空間資料。

  2. 巡覽到工作表。

  3. 「資料」窗格中,按兩下「Geometry」(幾何圖形)欄位。

    您可以對大小和色彩進行編碼,並向檢視新增更多詳細資料層級。

    有關詳情,請參閱依據空間檔案建立 Tableau 地圖(Link opens in a new window)

地圖資料更新和新增

在 Tableau 10.4 中,有 32,000 多個新的美國城市可用。此外,現在支援以下 NUTS 代碼:

  • DE401
  • DEB3I
  • DEG0I
  • DK012
  • DK021
  • EL641
  • ES521
  • HU321
  • NL230
  • NL327
  • AT113
  • FR623
  • AT322
  • LI000

MATLAB 整合

您可以使用 SCRIPT_ 函數存取 Tableau 中的 MATLAB® 模型(部署在 MATLAB 生產伺服器上),或者使用 MATLAB 預處理資料,並將該資料儲存到 Tableau 擷取中以便進一步分析。

有關詳情,請參閱放置 MATLAB 模型和演算法以在 Tableau 中使用(Link opens in a new window)以及透過分析擴充功能傳遞運算式

內嵌檢視中符合 WCAG 標準的下拉式篩選器

在內嵌檢視中存取時,單值(下拉)和多值(下拉)篩選器現在符合 WCAG 標準。

有關詳情,請參閱組建無障礙資料檢視製作無障礙檢視

在 Web 製作中新建

在 Web 上開啟檢視工具列

在以前的版本中,當在 Web 上製作時,您只能在使用地圖檢視時查看和使用「檢視工具列」。現在,您可以在 Web 製作過程中為工作簿中的任何檢視或儀表板開啟檢視工具列。

從頂端功能表中,選取「工作表」>「顯示檢視工具列」,並選取選項。

從儀表板中,選取要顯示檢視工具列的儀表板區域,然後執行以下操作之一:

  • 從頂端功能表中,選取「工作表」>「顯示檢視工具列」

  • 選取下拉箭頭,然後從上下文功能表中選取適當的選項。

在 Web 上編輯群組

從 Tableau 版本 10.4 開始,您可以編輯群組。

若要編輯群組,請在「資料」窗格中,以右鍵按一下群組欄位,並選取「編輯群組」

在開啟的「編輯群組」對話方塊中,可以在現有群組中新增或刪除成員,以及在群組欄位中建立新群組。您也可以選取「包括其他群組」。

在 Web 上建立別名

從 Tableau 版本 10.4 開始,您可以為維度中的成員建立別名,以使其標籤在檢視中以不同方式顯示。

若要為欄位建立別名,請執行以下操作:

  1. 「資料」窗格中,以右鍵按一下一個維度,並選取「別名」

  2. 在「編輯別名」對話方塊的「值(別名)」以下,選取成員並輸入新名稱。

設定線條格式

當您在 Web 上製作時,您可以快速變更工作簿中的所有列。選取「格式」>「工作簿」,然後展開「設定工作簿格式」中的「線條」部分,並進行選取。有關詳情,請參閱在工作簿層級設定格式

儀表板和故事的 RTF 編輯

您現在可以在 Web 上編輯儀表板標題和區域,以及故事標題和說明。

為此,請按兩下它們,然後在開啟的對話方塊中更新文本。

有關詳情,請參閱設定標題、說明、工具提示和圖例的格式(Link opens in a new window)

分享和協作

Tableau Server 和 Tableau Online 上的增強註解

註解已經完全重新設計,以啟動有關資料發現的對話。新的「註解」窗格顯示在檢視右側,而不是底部,因此您可以同時查看討論和資料。個人資料圖片也會自動顯示,可幫助您快速識別其他使用者。若要與他們共用已篩選的檢視,請新增互動式快照以及您的註解,以反白顯示您要描述的資料。

您在桌上型電腦瀏覽器中新增的任何註解也會出現在 Tableau Mobile 中(反之亦然),因此您可以輕鬆地在行動中與同事溝通。即使修改包含內容的工作簿(只要檢視名稱保持不變),檢視仍將保留註解。

有關詳情,請參閱向檢視新增註解

瞭解誰在 Tableau Server 和 Tableau Online 上查看了檢視

如果您擁有自己的檢視,則可以快速找出組織中何人查看了您的檢視。在主網站頁面頂端,按一下「檢視」。然後將遊標暫留在您感興趣的具體檢視中,從右上角的功能表中選取「誰查看了此檢視?」

版本 10.3 中新增

說明重新設計

合併的說明系統

從版本 10.3 開始,Tableau Desktop 說明現在稱為 Tableau 說明。Tableau 說明包含與在 Tableau Desktop、Tableau Server 和 Tableau Online 中分析和使用資料相關的所有說明主題。此說明適用於建立工作簿或資料來源並發佈它們的人員,以及想要在 Tableau 中查看檢視、與檢視交互和共用檢視的人員。

我們歡迎您提供有關此變更的回饋,以及您可能具有的關於如何使我們的內容更好的任何回饋或想法。請使用任何頁面頂端的回饋欄(「此頁面是否有幫助?」),以開啟註解欄位並提交您的回饋。

在 Web 上使用 Tableau提供了曾位於 Tableau Server 和 Tableau Online 說明中的主題連結。

連線到資料並準備資料

連線到 .pdf 檔案

現在,您可以使用 PDF 檔案連接器來連線到 .pdf 檔案中的表。有關詳情,請參閱 PDF 檔案

合併更多資料

您可以合併 .pdf 檔案以及 Aster Database、Cloudera Hadoop、Hortonworks Hadoop、IBM DB2、IBM PDA (Netezza)、Pivotal Greenplum Database、SAP Sybase ASE、SAP Sybase IQ 和 Teradata 中的表。有關聯集的詳情,請參閱合併資料

推薦的表和聯接

當您設定 Tableau 資料來源或修改現有資料來源時,看看組織中的其他人在表中填充了什麼內容會很有說明。當您(從 Tableau Desktop 中)登入到 Tableau Server 的同時連線到資料庫時,左側窗格中,「推薦」清單將顯示在發佈到 Tableau Server 的資料來源和工作簿中最常用的表。

將推薦的表新增到畫布後,經常聯接到其中的其他表將顯示在「推薦」清單中。按兩下一個表以自動在表之間建立推薦聯接,預設情況下,將使用最常用的欄位和聯接類型。附註:如果在資料庫中指定了外部索引鍵,它們將覆蓋這些推薦聯結。

連接器子集支援推薦的表和聯接。有關詳情,請參閱使用已認證和已推薦資料來源及表

新連接器

新的 Amazon Athena 連接器

使用 Amazon Athena 連接器連線到 Amazon Athena 資料。有關詳情,請參閱 Amazon Athena

新的 Dropbox 連接器

使用 Dropbox 連接器連線 Dropbox 上的資料。有關詳情,請參閱 Dropbox

新的 MongoDB BI 連接器

使用 MongoDB BI 連接器連線到 MongoDB BI 資料。有關詳情,請參閱 MongoDB BI 連接器

新的 OneDrive 連接器

使用 OneDrive 連接器連線到 OneDrive 上的資料。有關詳情,請參閱 OneDrive

新的 ServiceNow ITSM 連接器

使用 ServiceNow ITSM 連接器連線到 ServiceNow ITSM 資料。有關詳情,請參閱 ServiceNow ITSM

JSON 結構描述更新

Tableau 會掃描 JSON 檔案的前 10,000 列中的資料,並從該過程中推斷結構描述。有時,列中存在沒有為建立推斷結構描述而掃描的更多欄位。現在,Tableau 會指明檢測到您可能希望包含在分析中的其他欄位的時間。有關詳情,請參閱JSON 檔案

設計檢視和分析資料

按兩下縮放

在以前的版本中,當您按兩下為 X 和 Y 軸都使用連續度量的檢視(也稱為定量/定量檢視,例如散點圖),並且檢視工具列已關閉時,Tableau 將會自動放大。

這會產生令人困惑的使用者體驗。現在,對於這些定量/定量非地圖檢視類型,當您按兩下檢視時,預設情況下 Tableau 不再放大。此變更適用於新工作簿和升級的工作簿。對於表和交叉表圖表類型,按兩下縮放功能預設情況下也處於關閉狀態。

工具提示選取

此功能使您能按類別從工具提示中選取檢視中類似的標記。工具提示中包括的任何離散維度或度量將變為活動連結,您可以按一下連結來選取檢視中具有相同值的其他標記。

下面的範例演示如何透過按一下工具提示中的「Machines」(機器)來選取檢視中具有相同子類(本例中為「Machines」)的所有標記。

此功能可在 Tableau Desktop、Tableau Server 和 Tableau Mobile 上工作。對於新工作表,該功能預設情況下已啟用,而對於升級的工作表則預設禁用。若要禁用或啟用該功能,請在工作表層級按一下標記卡上的「工具提示」,開啟「編輯工具提示」對話方塊,然後清除或選中「允許按類別選取」核取方塊。

有關詳情,請參閱在工具提示中按類別反白顯示資料

離散日期篩選器的最新日期預設

可以設定離散日期篩選器以篩選到資料來源中的最新日期值。可以使用此設定確保資料來源中的最近日期在篩選器中處於選定狀態。有關詳情,請參閱「篩選離散日期」的最新日期預設,位於篩選檢視中的資料中「篩選日期」(桌面)下面。

在 Tableau Server 和 Tableau Online 上,檢視在瀏覽器中第一次載入時將應用預設值,但在重新整理瀏覽器或資料時不會應用預設值。

將表計算篩選器應用於總計

當您顯示總計,並且想要將一個表計算篩選器應用于總計時,現在可以在該篩選器的下拉式功能表中選取「應用於總計」(在「篩檢程式」功能區上)。此選項使您能定義何時應將表計算篩選條件應用於合計。有關詳情,請參閱 AirWatch 說明中的「篩選器表計算」(篩選檢視中的資料中)。

地圖資料更新和新增

針對 Tableau 版本 10.3 更新了以下資料:

  • 對 2016 年最終命名方案更新了法國地區名稱。

  • NUTS(地域統計單位命名法)代碼和機場代碼不再需要國家/地區作為父項即可在地圖上進行地理編碼。

  • 荷蘭陸地和省份已更新。

  • 使用 2016 年的資料更新了澳大利亞 LGA。

此外,盧旺達地區(uturere)現在受 Tableau 支援,並且可以使用「縣」地理角色進行地理編碼。還新增了紐西蘭郵遞區號的多邊形。有關 Tableau 支援的其他地圖資料的更多資訊,請參閱Tableau 支援用於構建地圖檢視的位置資料(Link opens in a new window)

均勻分佈配置容器項

將配置容器新增到儀表板後,您可以(在桌面上和在 Web 製作中)使用「均勻分佈」命令使其包含的項均勻間隔。有關詳情,請參閱設定儀表板大小和設定

輕鬆存取故事動作

當您將滑鼠懸停在故事巡覽區域上時,會出現新的故事工具列。使用它來復原故事變更、對故事點應用更新、刪除故事點,或者利用當前定制故事點建立一個新故事點。

使用數位進行故事巡覽

故事「配置」選項卡包含一個新的巡覽選項:「數字」。使用此選項可使故事巡覽器顯示一系列數位,而不是說明框或點。有關詳情,請參閱建立故事

Web 製作的新增功能

從版本 10.3 開始,Tableau Server 和 Tableau Online 的 Web 製作主題現在位於 Tableau 說明中。若要查看以前版本中的 Web 製作功能,請參閱 Tableau Server 新增功能

編輯定量色彩圖例

您現在可以在 Web 製作中編輯連續色彩圖例的調色盤。您可以從「標記」卡中或透過按一下圖例上的下拉箭頭開啟「編輯色彩」對話方塊。

標記卡片: 圖例:

您還可以透過輸入十六進位值為起始和結束色彩設定自訂色彩。

在分離的圖例上編輯色彩

當您為檢視中的度量建立單獨的色彩圖例時,您不再僅限於從 Tableau Desktop 中發佈檢視後只能使用預設調色盤或指派給每個色彩圖例的調色盤。

在 Web 製作模式下,您可以為每個圖例選取不同的調色盤。按一下圖例上的下拉箭頭以開啟「編輯色彩」對話方塊,然後選取調色盤。您還可以使用十六進位值設定自訂的開始和結束色彩。

自訂使用者與您的地圖交互的方式

在 Web 製作模式下,您現在可以使用「地圖選項」對話方塊,透過以下方式來自訂受眾與地圖檢視的對話模式。

  • 顯示地圖示度
  • 隱藏地圖搜尋
  • 隱藏檢視工具列
  • 關閉平移和縮放

有關詳情,請參閱自訂使用者與地圖的對話模式(Link opens in a new window)

在 Web 上設定數位格式

現在,您可以在 Tableau Server 和 Tableau Online 上指定檢視中度量的基本數位格式。有關詳情,請參閱在 Tableau Server 或 Tableau Online 上設定數位和 Null 值的格式(Link opens in a new window)

建立故事

在 Web 製作模式下,您現在可以建立故事以講述資料,提供上下文,示範決策與結果的關係,或者只是建立一個極具吸引力的案例。有關詳情,請參閱建立故事

建立和編輯資料桶

在 Tableau Server 和 Tableau Online 中依據連續度量建立資料桶並編輯它們,這類似於您在 Tableau Desktop 中的操作方法。有關詳情,請參閱依據連續度量建立資料桶

在檢視中將欄位拖到「顯示」

選取感興趣的維度和度量並將其拖到檢視區域。「顯示」檢視會自動建立。然後,您可以按一下其他「顯示」選項來嘗試不同的檢視類型。

在檢視中向上和向下切入連續的層次結構

在具有連續層次結構的檢視中,將滑鼠暫留在連續軸上的標題附近以顯示 + 和 - 控制項。按一下以向下或向上切入。

儲存資料來源

現在,您可以選取將已發佈工作簿中內嵌的資料來源另存為 Tableau Server 和 Tableau Online 上其他使用者可以連線到的已發佈的單獨資料來源。儲存資料來源時,可以選取更新工作簿以連線到新儲存的資料來源。

 

分享和協作

Tableau Online 和 Tableau Server 中資料驅動的通知

當資料達到您的重要業務閾值時,資料驅動型通知會自動向您指定的關鍵人員傳送電子郵件通知。除甘特圖和地圖之外,您可以對所有圖表類型設定通知。

首先,選取圖表的連續數位軸:

然後按一下工具列中的「通知」:

出現「建立通知」快顯視窗時,設定觸發通知電子郵件的資料條件和閾值。在檢視中,紅線顯示了閾值相對於當前資料的所在位置。只需指定電子郵件主題行、計畫和收件人,即可開始提醒您的組織注意關鍵指標。

若要管理您擁有或接收的通知,請按一下 Tableau Online 或 Tableau Server 頁面右上角的名稱,按一下「我的內容」,然後按一下「通知」

有關詳情,請參閱從 Tableau Online 或 Tableau Server 中傳送資料驅動型通知

版本 10.2 中新增

安裝和部署 Tableau

連線到資料並準備資料

設計檢視和分析資料

發佈資料來源和工作簿

在 Mac 上安裝 Tableau Desktop 嚮導

新的可自訂的安裝嚮導將指導您完成安裝過程。預設情況下,它會安裝最常用的資料庫驅動程式(Amazon Redshift、MySQL、Oracle、PostgreSQL、Simba Spark 和 Simba SQL),並建立桌面快捷方式。

有關安裝 Tableau Desktop 的詳細資訊,請參閱 Tableau Desktop 部署指南(Link opens in a new window)

檢查產品維護更新

您現在可以隨時檢查這些更新,而不必等待產品維護更新可供下載的通知,或者在關閉提示之後卻又希望自己沒有關閉。只需從 Tableau Desktop 的「說明」功能表中選取「檢查產品更新」,Tableau 將會檢查以確定是否有更新的維護發佈版本可用。將顯示以下選項之一:

  • 如果有新的更新,則會顯示一個對話方塊,使您能夠下載並安裝最新更新。

  • 如果沒有新的更新,則會顯示一條訊息,指明未找到新的更新。

  • 如果更新已在進行,則會顯示一條訊息,指明正在進行更新。

適用于自動更新過程的 3 天等待期同樣也適用於此功能。如果為 Tableau 關閉了自動更新,則此選項不可用。有關如何為產品管理自動更新的詳細資訊,請參閱 Tableau Desktop 部署指南中的控制產品更新(Link opens in a new window)

自動儲存工作簿

Tableau Desktop 現在每隔幾分鐘即會為您自動儲存工作,不再會出現因為 Tableau 意外關閉而丟失數小時工作的情況。

新的自動儲存功能預設情況下已啟用。如果 Tableau 當機,系統將自動建立工作簿的復原版本,其副檔名為 .twbr,並儲存在原始檔案所在的相同位置,或儲存在「My Tableau Repository/Workbooks」資料夾中。新工作簿在儲存時將命名為「Book1」加一個數字 ID。重新開啟 Tableau 時,復原對話方塊將顯示一個已復原檔案的清單,您可以選取並開啟這些檔以繼續執行流程。您也可以從同一個對話方塊中刪除不需要的檔案。

使用者可透過 Tableau Desktop 中的「說明」功能表開啟或關閉此功能。管理員也可以透過從命令列中變更 AUTOSAVE 安裝程式屬性設定來關閉此功能。如果管理員關閉此功能,則無法從「說明」功能表中使用「自動儲存」選項。

有關如何使用命令列開啟或關閉自動儲存功能的詳細資訊,請參閱 Tableau Desktop 部署指南中的部署 Tableau Desktop(Link opens in a new window)

對跨資料庫聯接的 Salesforce 支援

Salesforce 支援使用跨資料庫聯接來合併表。有關詳情,請參閱聯結資料中的「聯集不同資料庫中的表」部分。

合併更多資料

您可以合併 Amazon Redshift、Google BigQuery、HP Vertica、Microsoft SQL、MySQL、Oracle 和 PostgreSQL 資料庫中的表。您還可以合併 JSON 檔案。有關聯集的詳情,請參閱合併資料

可擴展的標記卡

如果您曾經處理過需要在標記卡上有大量欄位的檢視,但因為不滾動就無法看到所有欄位而感到沮喪,標記卡現在得到了增強,可以解決此問題。標記卡現在會自動擴展來填充所有可用空白空間。

按度量顯示圖例

如果在檢視中包括「度量值」「度量名稱」欄位,您現在可以按度量對資料進行色彩編碼,從而使您能夠進一步區分資料的各個部分。

在以前的版本中,當您使用這些欄位並將「度量值」新增到「標記」卡上的「色彩」時,Tableau 將建立應用於檢視中所有標記的單一色彩圖例。現在,當您將「度量值」拖到「標記」卡上的「色彩」時,您可以選取為檢視中的每個度量建立單獨色彩圖例的選項,然後為每個度量選取唯一的調色盤。

還可透過選取合併圖例的選項來輕鬆地合併獨立色彩圖例。當您在合併圖例和單獨圖例之間切換時,Tableau 甚至能記住您的調色盤。

單一合併圖例

以下的範例演示當您將「度量值」拖到「標記」卡上的「色彩」時的預設行為。Tableau 將建立適用於檢視中所有標記的單一色彩圖例。

在「標記」卡上,按一下「度量值」欄位上的下拉箭頭,然後從上下文功能表中選取「使用單獨圖例」,為每個度量建立一個圖例。Tableau 將為每個圖例分配預設調色盤,但您可以根據需要對其進行編輯,如下面的範例中所示。

多個圖例

若要將單獨圖例重新合併為適用於所有度量的單一圖例,請在「標記」卡上按一下「度量值」欄位上的下拉箭頭,並從上下文功能表中選取「合併圖例」

改善的日期識別

如果您的日期值被解讀為字串或整數,請將欄位的資料類型變更為「日期」「日期和時間」,而不是建立計算來變更其類型。有關詳情,請參閱將欄位轉換為日期欄位

連線到空間檔案

您現在可以連線到 Shapefile、MapInfo 表、KML(鎖眼標記語言)檔案,以及 Tableau Desktop 中的 GeoJSON 檔案。有關詳情,請參閱依據空間檔案建立 Tableau 地圖(Link opens in a new window)主題,以及空間檔案(Link opens in a new window)範例連接器主題。

連線到更多 Presto 資料

除了從 Teradata 中連線到 Presto 141t 之外,對於 Presto 版本 0.148,Tableau 現在可以連線到 Presto 本地和 Amazon EMR Presto 實例。有關 Presto 連接器的詳細資訊,請參閱Presto

新 SharePoint 清單連接器

使用 SharePoint 清單連接器連線到 SharePoint 清單。有關詳情,請參閱Sharepoint 清單

新 Apache Drill 連接器

使用 Apache Drill 連接器連線到 Apache Drill 資料。有關詳情,請參閱Apache Drill

在 Mac 上連線到 Aster Database

您可以在 Mac 上連線到 Aster Database。您可以從 Tableau 網站上的驅動程式下載(Link opens in a new window)頁下載 Mac 的驅動程式。

在地圖上顯示標度

您現在可以在地圖上顯示標度,使受眾能夠瞭解您的資料點之間的距離。有關詳情,請參閱顯示地圖示度(Link opens in a new window)

地理編碼地域統計單位命名法 (NUTS) 代碼

您現在可以使用「NUTS 歐洲」地理角色對 Tableau 中的 NUTS 1 - 3 級代碼進行地理編碼。

為欄位分配「NUTS 歐洲」地理角色:

  • 在「資料」窗格中,按一下欄位旁邊的資料類型圖示,選取「地理角色」,然後從清單中選取「NUTS 歐洲」

有關詳情,請參閱 Tableau 中的地理角色類型(Link opens in a new window)

地圖資料更新和新增

印度地區和郵遞區號、紐西蘭郵遞區號、澳大利亞 LGA 以及沙烏地阿拉伯城市資料已更新。

此外,Tableau 現在可自動識別以下城市和國家/地區的二級行政區域,並可使用「郡/縣」地理角色對其進行地理編碼。有關詳情,請參閱Tableau 支援用於構建地圖檢視的位置資料(Link opens in a new window)

  • 柏林
  • 布吉納法索
  • 衣索比亞
  • 幾內亞
  • 幾內亞比索
  • 印尼
  • 象牙海岸
  • 馬來西亞
  • 馬里
  • 緬甸
  • 奈及利亞
  • 挪威
  • 菲律賓
  • 塞內加爾
  • 獅子山
  • 甘比亞
  • 多哥
  • 尚比亞

使用計算自訂聯接以解決欄位之間的格式不匹配

聯接中所使用欄位之間的格式不匹配通常可能會導致聯接中斷,或使您無法首先建立聯接。在許多情況下,可透過使用計算自訂聯接的方式來解決欄位之間的格式不匹配。有關詳情,請參閱聯結資料

使用 Tableau Online 快速共用內容

若要與其他人快速共用內容,請註冊 Tableau Online 的免費試用版:按一下「工具列」中的「共用」按鈕,然後按一下「建立網站」。(如果您已經登入到 Tableau Online 或 Tableau Server,按一下「共用」按鈕時將顯示標準發佈選項。)

將資料匯出為 CSV

將您在 Tableau 中合併和準備的所有資料匯出為 CSV 檔案,而無需首先建立或使用基準檔案。有關詳情,請參閱從 Tableau Desktop 匯出資料

新的關聯函數和協方差函數

提供了三個新的彙總函式:

  • CORR:返回兩個運算式的皮爾森相關係數。

  • COVAR:返回兩個運算式的樣本協方差。

  • COVARP:返回兩個運算式的總體協方差。

有關詳情,請參閱Tableau 函數(按字母順序)(Link opens in a new window)

此外,還提供了三個相關的表計算函數:

  • WINDOW_CORR:返回定義窗口內兩個運算式的皮爾森相關係數。

  • WINDOW_COVAR:返回定義視窗內兩個運算式的樣本協方差。

  • WINDOW_COVARP:返回定義窗口內兩個運算式的總體協方差。

有關詳情,請參閱表計算函數

Mac 上的 TLS 相互驗證

Tableau Desktop for Mac 現在支援 Tableau Server 的 TLS 雙向驗證。如果您的組織使用使用者端憑證進行電腦或使用者驗證,並且在 Tableau Server 上啟用了相互驗證,則您可以像使用支援 TLS 雙向驗證的任何其他應用程式一樣進行驗證。Windows 上的 Tableau Desktop 也支援 TLS 雙向驗證。

使用數位進行故事點巡覽

現在,您可以指定數位作為受眾逐步瀏覽您的故事的方式。如果您有大量的個別故事點並且希望避免使用巡覽器上的捲軸,這可能很有用。

有關故事配置和格式設定的詳細資訊,請參閱建立故事

在整個工作簿中設定行的格式

您可以透過按一下「格式」>「工作簿」在一個位置快速變更工作簿中每個檢視的行格式。如果對工作簿的行設定進行變更,則「設定工作簿格式」窗格中該設定的旁邊將出現一個灰色的點。

有關詳情,請參閱在工作簿層級設定格式

在 Web 上支援符合 WCAG 標準的檢視

您在 Tableau Desktop 中創作、發佈到 Tableau Server 或 Tableau Online 並嵌入在符合 WCAG 標準的網頁中的嵌入式檢視現在符合 WCAG 2.0 AA 一致性規範和第 508 節的標準。

WCAG 一致性規範還不支援在 Tableau Desktop、Tableau Reader 或 Tableau Public 中向使用者提供的檢視。WCAG 一致性規範還不支援透過 Tableau Server 或 Tableau Online 在 Web 上建立或編輯的檢視。

內嵌檢視的以下部分符合 WCAG 標準:

  • 工作表索引標籤

  • 工作表的檢視區域

  • 標題和說明

  • 分類圖例

  • 單個值(清單)篩選器(即選項按鈕)和多個值(清單)篩選器(即核取方塊)。

  • 「檢視資料」視窗

嵌入檢視中 Tableau 介面的某些方面尚未得到支援,例如其他篩選器類型、參數和檢視工具列。在視覺效果中使用這些控制項可能會讓使用輔助技術的使用者很難完全理解您的檢視。

還支援為嵌入檢視使用鍵盤巡覽、輔助技術的程式設計上下文(使用 ARIA 角色)、非文本元素的替代文本和對比度標準,以及登入 Tableau Server 或 Tableau Online 時的驗證。

有關建立可存取檢視的詳細資訊,請參閱設計無障礙檢視的最佳做法製作無障礙檢視

支援 SAP BW 單一登入

您可以設定從 Tableau 到 SAP NetWeaver Business Warehouse(SAP BW)的單一登入 (SSO) 支援。有關詳情,請參閱 Tableau Server 說明中的為 SAP BW 啟用單一登入(Link opens in a new window)

感謝您的意見回饋! 提交意見回饋時發生錯誤。重試或傳送訊息給我們