本教程將引導您完成在 Tableau 中建立地圖時可能執行的一些常見工作。

您將學習如何連線並聯接地理資料;在 Tableau 中設定該資料的格式;建立位置階層;組建和轉譯基本地圖檢視;以及在路線上應用關鍵地圖特徵。

如果您不熟悉 Tableau 中的地圖組建功能,從此處開始學習非常適合。

步驟 1:連線到地理資料

地理資料有許多形狀和格式。開啟 Tableau Desktop 時,開始頁面將在左側 [連線] 窗格中顯示可用的連接器。您將透過這些連接器來連線到資料。

可透過連線到空間檔來處理地理資料,或者可以連線到存儲在試算表、文字檔中或伺服器上的位置資料。

空間檔(例如 Shapefile 或 geoJSON 檔)包含實際幾何圖形(點、線或多邊形),而文字檔或試算表包含經緯度座標格式的點位置,或者包含在引入 Tableau 時將連線到地理編碼(資料引用的存儲幾何圖形)的指定位置。

有關 Tableau 支援的連線的完整清單,請參閱 Tableau 網站上的資料連線(連結在新視窗開啟)清單。

對於此教程,您將連線到 Tableau Desktop 附帶的一個 Excel 檔案。它包含 Tableau 可進行地理編碼的位置名稱。當您組建地圖檢視時,位置名稱將根據您指派給欄位的地理角色引用存儲在 Tableau Map Service 中的幾何圖形。在本教程的後面部分,您將詳細瞭解有關地理角色的資訊。

  1. 開啟 Tableau Desktop。

  2. 在 [連線] 窗格中,按一下 [Excel]

  3. 巡覽到 文件 > 我的 Tableau 存放庫 > 資料來源,然後開啟 Sample - Superstore.xls 文件。

連線到資料來源後,螢幕將如下所示:

此頁面名為 [資料來源] 頁面,您可在其中準備要在 Tableau 中使用的位置資料。

您可以在 [資料來源] 頁面中執行以下一些工作,但必須執行所有這些操作才能建立地圖檢視:

  • 新增其他連線和聯接資料
  • 向資料來源中新增多個工作表
  • 為欄位指派或變更地理角色
  • 變更列的資料類型(例如,從數位變更為字串)
  • 重命名列
  • 拆分列,例如將完整的位址拆分為表示街道、城市、市/縣和郵遞區號的多個列

有關 [資料來源] 頁面以及可在該頁面上執行的一些工作的詳情,請參閱設定資料來源(連結在新視窗開啟)部分中的主題。

步驟 2:聯接資料

資料通常包含在多個資料來源或工作表中。只要這些資料來源或工作表有共有的列,您就可以在 Tableau 中聯接它們。聯結是一種在這些公共欄位上合併相關資料的方法。使用聯結合併資料後會產生一個通常可透過新增資料欄進行橫向擴展的虛擬表。

對於地理資料(特別是空間資料),通常必須進行聯接。例如,您可以將包含美國俄勒岡州各個學區自訂地理位置的 KML 檔案與一個 Excel 試算表聯結,該試算表包含有關這些學區的人口資訊。

對於此範例,您將聯接 Sample-Superstore 資料來源中的兩個工作表。

  1. 在 [資料來源] 頁面左側的 [工作表] 下,按兩下 [Orders] (訂單)

  2. 在 [工作表] 下,按兩下 [People] (人員)

    Tableau 將使用兩個試算表中都有的 [Region] (區域)列作為聯接欄位,在兩個試算表之間建立內聯接。現在,有一名指派到資料來源中的每個位置以及區域的銷售人員。

    若要編輯此聯接,請按一下聯接圖示(兩個圓圈)。您可以在開啟的 [聯接] 對話方塊中編輯聯接。有關在 Tableau 中聯接資料的詳情,請參閱聯結資料(連結在新視窗開啟)

步驟 3:在 Tableau 中設定地理資料的格式

設定資料來源之後,您可能需要準備地理資料以在 Tableau 中使用。建立地圖檢視時,並非必須要執行所有這些程式,但就準備在 Tableau 中使用的地理資料而言,它卻是很重要的資訊。

根據想要建立的地圖類型,您必須為欄位(或列)指派某些資料類型、資料角色和地理角色。

例如,在大多數情況下,您的緯度和經度欄位的資料類型應為數字(小數)資料角色應為度量,並且指派有緯度經度地理角色。所有其他地理欄位的資料類型應為字串資料角色應為維度,並且指派有相應的地理角色。

附註:如果連線到空間檔,則會建立一個 [幾何圖形] 欄位。該欄位的資料角色應為度量。

此步驟演示如何設定地理資料的格式以滿足此條件。

變更欄的資料類型

第一次連線到地理資料時,Tableau 會為所有欄指派資料類型。這些資料類型包括數位(小數)、數位(整數)、日期和時間、日期、字串以及布林值。有時 Tableau 無法正確設定這些資料類型,您需要對其進行編輯。例如,Tableau 可能會為郵遞區號欄指派 [數位(整數)] 資料類型。若要建立地圖檢視,郵遞區號資料的資料類型必須為 [字串] 。

變更欄的資料類型:

  1. 在 [資料來源] 頁面上,按一下郵遞區號的資料類型圖示(地球),並選取 [字串]

    有關資料類型的詳情,請參閱資料類型(連結在新視窗開啟)

為地理資料指派地理角色

在 Tableau 中,地理角色將欄位中的每個值與經度和緯度值關聯。為欄位指派正確的地理角色後,Tableau 將透過尋找已安裝地理編碼資料庫中已經內建的符合,將緯度和經度值指派給該欄位中的每個位置。由此 Tableau 可以知道在地圖上的何處繪製您的位置。

為某個欄位(例如 [市/縣] )指派地理角色時,Tableau 將建立一個 [緯度(產生)] 欄位和一個 [經度(產生)] 欄位。

有時會為您的資料自動指派地理角色,本例中便是如此。由於列包括一個地球圖示,因此您可以確定您的資料已指派有地理角色。

如果未自動指派地理角色,您可以為欄位手動指派一個角色。對於此範例,您無需這樣做,但務必要瞭解如何操作,以便您能夠為自己的資料指派地理角色。

指派或編輯地理角色:

  1. 在 [資料來源] 頁面上,按一下地球圖示。

  2. 選取 [地理角色] ,然後選取最適合於您的資料的角色。

    例如,在本例中, [Country] (國家/地區)欄未指派有地理角色,因此將指派 [國家/地區] 地理角色。

附註:如果在為資料指派地理角色時遇到困難,或者您的資料不是 Tableau 地圖伺服器中內建的資料,您可以執行一些操作,將這些資料引入 Tableau。請參閱指派地理角色(連結在新視窗開啟)

從維度變更為度量

連線到地理資料時,Tableau 還會為所有欄指派資料角色。列可以是維度或者度量。大多數情況下,緯度和經度列應為度量。對於特殊情況,例如,假設您想要在地圖上繪製資料來源中的每個位置,但無法向上或向下切入某個詳細資料層級(例如從城市向上或向下切入到市/縣),則列可以是維度。點分佈(連結在新視窗開啟)圖就是這種情況的一個很好的例子。

其餘地理資料應為維度。

對於此範例,您無需變更列的資料角色,但務必要瞭解如何操作,以便您能夠為自己的資料變更資料角色。請在此處隨意練習。您可以隨時撤銷所做的變更。

變更欄的資料角色:

  1. 在 [資料來源] 頁面上,按一下 [工作表 1]

    工作區將更新為如下所示:

    這稱為工作表,您可以在其中組建地圖。螢幕的左側是 [資料] 窗格。資料來源中的所有列以欄位形式列在此窗格中。例如, [Country] (國家/地區)和 [State] (市/縣)。這些欄位包含列中的所有原始資料。請注意,Tableau 已產生緯度和經度欄位: [緯度(產生)] 和 [經度(產生)] 這是因為您為資料指派了地理角色。

    資料窗格中的欄位分為度量和維度。放在 [資料] 窗格的 [維度] 部分中的欄位通常為分類資料,例如日期和客戶 Id,而放在 [資料] 窗格的 [度量] 部分中的欄位通常為定量資料,例如銷售額和數量。

  2. 在 [資料] 窗格中的 [維度] 下,選取一個欄位(例如 [Row ID] (列 ID)),並將其向下拖到 [度量] 部分。

    該欄位將新增到 [度量] 部分,並從藍色變為綠色。您剛剛將維度轉換為度量。若要將某個欄位從度量轉換為維度,請將該欄位從 [度量] 部分向上拖到 [維度] 部分。

    有關詳情,請參閱維度和度量(藍色和綠色)(連結在新視窗開啟)

步驟 4:建立地理階層

因為您在工作表空間中,所以可以建立地理階層。這不是建立地圖檢視的必需操作,但建立地理階層將允許您按指定順序快速鑽取到資料包含的地理詳細資料層級。

建立地理階層:

  1. 在 [資料] 窗格中,以右鍵按一下地理欄位 [Country] (國家/地區),然後選取 [階層] > [建立階層]
  2. 在開啟的 [建立階層] 對話方塊中,為階層指定一個名稱(例如 [地圖項目] ),然後按一下 [確定]

    在 [維度] 部分的底部,將會建立包含 [Country] (國家/地區)欄位的 [地圖專案] 階層。

  3. 在 [資料] 窗格中,將 [State] (市/縣)欄位拖到該階層,並將其放在 [Country] (國家/地區)欄位下方。

  4. 為 [City] (城市)和 [Postal Code] (郵遞區號)欄位重複步驟 3。

    完成後,您的階層應為如下順序:

    • 國家/地區
    • State(縣/市)
    • City(城市)
    • Postal Code(郵遞區號)

步驟 5:組建基本地圖

因為您已連線並聯接資料、設定了資料格式並組建了地理階層,所以現在就可以開始組建地圖。首先將組建一個基本地圖檢視。

  1. 在 [資料] 窗格中,按兩下 [Country] (國家/地區)

    該 [Country] (國家/地區)欄位將新增到 [標記] 卡上的 [詳細資料] ,而 [緯度(產生)] 和 [經度(產生)] 欄位將新增到 [欄] 和 [列] 架。系統會建立一個具有一個資料點的地圖檢視。由於為 [Country] (國家/地區)指派了地理角色,因此 Tableau 將建立地圖檢視。如果按兩下任何其他欄位(例如某個維度或度量),Tableau 會將該欄位新增到 [列] 或 [欄] 架或者 [標記] 卡,具體情況取決於檢視中已有的內容。但是,地理欄位始終放在 [標記] 卡上的 [詳細資料] 中。

    由於此資料來源僅包含一個國家/地區(美國),因此該國家/地區就是唯一顯示的資料點。您將需要新增更多詳細資料層級才能看到其他資料點。由於已建立了地理階層,因此可以輕鬆完成此操作。

  2. 在 [標記] 卡上,按一下 [Country] (國家/地區)欄位上的 [+] 圖示。

    將向 [標記] 卡上的 [詳細資料] 新增 [State] (市/縣)欄位,並且地圖將更新以包括資料來源中每個市/縣的資料點。

    如果未建立階層,則 [Country] (國家/地區)欄位上的 [+] 圖示將不可用。在這種情況下,若要新增 [State] (市/縣)作為另一個詳細資料層級,請手動將 [State] (市/縣)從 [資料] 窗格拖到 [標記] 卡上的 [詳細資料]

恭喜!您現在有了一個可以自訂並在後續步驟中作為基礎的基本地圖檢視。

步驟 6:從點變更為多邊形

Tableau 中的預設地圖類型通常為點圖。但是,為地理資料指派了地理角色後,可以輕鬆地將這些資料點變更為多邊形。

附註:填充地圖對於城市或機場不可用。

  1. 在 [標記] 卡上,按一下 [標記類型] 下拉清單,並選取 [填充地圖]

    地圖將更新為多邊形地圖。

步驟 7:新增視覺詳細資料

您可以將度量和維度新增到 [標記] 卡,向檢視中新增視覺詳細資料。在本例中,您將向檢視中新增色彩和標籤。

新增色彩

  • 從 [度量] 中,將 [Sales] (銷售額)拖到 [標記] 卡上的 [色彩]

    每個市/縣按銷售總額著色。由於銷售額是一種度量,因此將使用定量調色板。如果將維度放在 [色彩] 上,則會使用分類調色板。

新增標籤

  1. 從 [度量] 中,將 [Sales] (銷售額)拖到 [標記] 卡上的 [標籤]

    每個市/縣按銷售總額進行標記。但是,需要為數位設定一點格式。

  2. 在 [資料] 窗格中,以右鍵按一下 [Sales] (銷售額),並選取 [預設屬性] > [數位格式]

  3. 在開啟的 [預設數位格式] 對話方塊中,選取 [數位(自訂)] ,然後執行以下操作:

    • 對於 [小數位] ,輸入 0

    • 對於 [單位] ,選取 [千(K)]

    • 按一下 [OK] (確定)。

    標籤和色彩圖例將更新,包含指定的格式。

步驟 8:自訂背景地圖

背景地圖是標記後面的所有內容(邊界、海洋、位置名稱等)。您可以自訂此背景地圖的樣式,以及新增地圖層和資料層。除了自訂背景地圖外,您也可以連線到自己的 WMS 伺服器或 Mapbox 地圖。有關詳情,請參閱使用 Web 地圖服務 (WMS) 伺服器(連結在新視窗開啟)使用 Mapbox 地圖(連結在新視窗開啟)

自訂背景地圖:

  1. 選取 [地圖] > [地圖層]

    [地圖層] 窗格顯示在工作區的左側。將在此窗格中進行所有背景地圖自訂操作。

  2. 在 [地圖層] 窗格中按一下 [樣式] 下拉清單,並選取 [正常]

    背景地圖更新為如下所示:

  3. 在 [地圖層] 窗格中的 [地圖層] 下,選取 [海岸線] ,然後清除 [國家/地區邊界] [國家/地區名稱] [州/省界] [州/省名稱]

  4. 在 [地圖層] 窗格的頂端,按一下 [X] 返回到 [資料] 窗格。

    背景地圖現在已簡化,可以吸引對您的資料的注意。

步驟 9:建立自訂領地

在組建地圖檢視時,您可能希望將現有位置分組在一起來建立自己的領地或地區,例如組織的銷售領地。

  1. 在 [資料] 窗格中,以右鍵按一下 [State] (市/縣),並選取 [建立] > [群組]

  2. 在開啟的 [建立群組] 對話方塊中,選取 [California] (加利福尼亞州)、 [Oregon] (俄勒岡州)] 和 [Washington] (華盛頓州),然後按一下 [群組] 。您建立的每個群組表示一個領地。

    附註:若要選取多項,請在選取市/縣時按住 Ctrl(在 Mac 上按住 Command)。

  3. 以右鍵按一下剛剛建立的新組,並選取 [重命名]

  4. 將組重命名為 [西海岸]

  5. 對於下一個領地,選取 [Alabama] (阿拉巴馬州) [Florida] (佛羅里達) [Georgia] (喬治亞州) [Louisiana] (路易斯安那州) [Mississippi] (密西西比州) [South Carolina] (南卡羅來納州) [Texas] (德克薩斯州),然後按一下 [群組]

  6. 將此群組重命名為 [南部]

  7. 對於第三個領地,選取 [Connecticut] (康涅狄格州) [Delaware] (德拉瓦州) [District of Columbia] (哥倫比亞特區) [Maine] (緬因州) [Maryland] (馬里蘭州) [Massachusetts] (麻塞諸塞州) [New Hampshire] (新罕布什爾州) [New Jersey] (新澤西州) [New York] (紐約) [Pennsylvania] (賓夕法尼亞州) [Rhode Island] (羅德島州) [Vermont] (佛蒙特州)以及最後的 [West Virginia] (西佛吉尼亞州),然後按一下 [分組]

  8. 將此組重命名為 [東海岸]

  9. 選取 [包括其他] 以將其餘各州分組。

  10. [其他] 群組重命名為 [中部]

  11. 按一下 [OK] (確定)。

    [資料] 窗格中其他地圖項目的下方將出現一個 [State (group)] (市/縣(組))欄位。

  12. 從 [資料] 窗格中,將 [State (group)] (市/縣(群組))拖到 [標記] 卡上的 [色彩]

    檢視更新為如下所示:

    請注意,每個群組有不同的色彩。

  13. 在 [標記] 卡上按一下 [色彩] 圖示,並選取 [編輯色彩]

  14. 在出現的 [編輯色彩] 對話方塊中,選取 [指派調色盤] ,然後按一下 [確定]

    標記將更新為新色彩。

  15. 從 [度量] 中,將 [Sales] (銷售額)拖到 [標記] 卡上的 [工具提示]

    將滑鼠暫留在某個市/縣上時,將出現一個工具提示,其中包含該市/縣的銷售額,以及其他資訊。稍後您將學習如何編輯此工具提示。

  16. 在 [標記] 卡上,按一下 [Country] (國家/地區)欄位上的減號 (-) 圖示,從詳細資料層級中移除 [State] (市/縣)。

    如果未建立階層,您可以從檢視中拖出 [State] (市/縣),將其移除。可透過從檢視中拖出任何欄位來將該欄位移除。

    市/縣將不再出現在地圖上。注意到標籤以及工具提示中的銷售總額是如何更新的嗎?這是因為自訂領地將在組層級計算彙總,而不會為組內的每個位置單獨計算。因此,舉例來說,您在 [西海岸] 群組中看到的總銷售額是加利福尼亞州、俄勒岡州和華盛頓州合併在一起的總銷售額。

步驟 10:建立雙軸地圖

到目前為止,您已建立了兩個地圖檢視:一個顯示各州的銷售額,一個顯示各地區的銷售額。可以將這些地圖相互疊放嗎?可以!在 Tableau 中,您可以建立具有兩層標記的地圖。這在 Tableau 中稱為雙軸地圖,通常用於將點疊放在多邊形上。在本例中,您將疊放兩個多邊形地圖。

建立雙軸地圖:

  1. 從 [資料] 窗格中,將 [經度(產生)] 拖到 [欄] 架,並將其放在第一個 [經度] 欄位的右側。

    檢視會使用兩個相同的地圖進行更新。

    [標記] 卡上現在有三個標籤:每個地圖檢視各一個標籤,以及同時適用於兩種檢視的標籤(全部)。您可以使用這些來控制地圖檢視的可視詳細資料。頂端的 [Longitude] (經度)索引標籤對應於檢視左側的地圖,底部的 [Longitude] (經度)索引標籤對應於檢視右側的地圖。

  2. 在 [標記] 卡上,選取頂端的 [經度(產生)] 索引標籤。

  3. 從 [度量] 中,將 [Sales] (銷售額)拖到頂端的 [經度(產生)] 標記卡上的 [色彩]

    左側的地圖將更新。

  4. 在頂端的 [經度(產生)] 標記卡上,按一下 [Country] (國家/地區)欄位上的加號圖示,以向下切入回 [State] (市/縣)詳細資料層級。

  5. 在 [標記] 卡上按一下 [色彩] ,然後選取 [編輯色彩]

  6. 在開啟的 [編輯色彩] 對話方塊中,按一下 [調色盤] 下拉清單,選取 [灰色] ,然後按一下 [確定]

    此時,地圖將如下所示:

  7. 在 [欄] 架上,以右鍵按一下右側的 [經度(產生)] 欄位,並選取 [雙軸]

  8. 在 [標記] 卡上,選取底部的 [經度(產生)] 索引標籤。

  9. 在底部的 [經度(產生)] 標記卡上,將兩個 [SUM(Sales)] 欄位都從檢視中拖出,以將其刪除。

    各個地圖的標籤不再重疊。

  10. 在底部的 [經度(產生)] 標記卡上,按一下 [色彩] ,然後為 [不透明度] 輸入 50%

    如果您希望看到位於底層上的地圖,則此步驟很重要。

    地圖檢視更新為如下所示:

    您現在可以看到每個市/縣在各個組中的業績情況。

  11. 在底部的 [(經度(產生)] 標記卡上,按一下 [工具提示]

    一個 [編輯工具提示] 對話方塊將開啟。

  12. 複製以下文字並將其貼上到 [編輯工具提示] 對話方塊中,然後按一下 [確定]

    <State (group)> 地區銷售總額:<SUM(Sales)>

    工具提示類似於如下:

    恭喜!您已建立了雙軸地圖!接下來只需完成一步。

    有關雙軸地圖的詳情,請參閱 Tableau 社群上的雙軸地圖 - 多種方式(連結在新視窗開啟)

步驟 11:自訂其他人與您的地圖交互的方式

既然已建立了地圖檢視,您就可以自訂使用者與地圖檢視的對話模式。例如,您現在可能希望任何人能夠放大或縮小地圖,或者進行平移。或者,您可能希望顯示地圖示度?您可以在 [地圖選項] 對話方塊中自訂這兩個選項以及其他選項。

自訂其他人與您的地圖交互的方式:

  1. 選取 [地圖] > [地圖選項]

  2. 在出現的 [地圖選項] 對話方塊中,執行以下操作:

    • 選取 [顯示地圖示度]

    • 清除 [顯示地圖搜尋]

    • 清除 [顯示檢視工具列]

    標度將顯示在地圖的右下角,地圖左上角的地圖搜尋圖示和工具列將消失。您仍然能夠使用鍵盤快速鍵進行平移和縮放。有關詳情,請參閱縮放和平移檢視,以及選取標記(連結在新視窗開啟)

    大功告成!您的地圖檢視現在已準備好,可以轉譯或與儀表板中的另一個檢視合併。有關儀表板的詳情,請參閱建立儀表板(連結在新視窗開啟)

想要檢查您的工作?請從 Tableau Public 下載範例工作簿(連結在新視窗開啟)

後續步驟

學習一些地圖視覺化基礎知識。(連結在新視窗開啟)

瞭解可在 Tableau 中組建的地圖類型,以及如何建立它們。(連結在新視窗開啟)

在尋找更高級的內容?查看 Tableau 社群上的地圖系列文章(連結在新視窗開啟)

瀏覽有關地圖的其他說明內容(連結在新視窗開啟)

觀看線上視訊教程。(連結在新視窗開啟)

有具體的疑問或問題?請查看 Tableau 社群上的地圖論壇(連結在新視窗開啟),或搜尋知識庫(連結在新視窗開啟)


觀看視訊:若要檢視 Tableau 中示範的相關概念,請觀看以下免費訓練視訊:地圖入門(連結在新視窗開啟)(3 分鐘)和 Tableau 中的地圖(連結在新視窗開啟)(4 分鐘)。使用 tableau.com(連結在新視窗開啟) 帳戶登入。

感謝您的意見回饋!