Tableau 新增功能

浏览新功能摘要来了解当前支持的版本。

查看发行说明和已知问题

最佳做法是查看您要安装或升级到的 Tableau Desktop 版本的发行说明。这对于升级尤其重要,因为它可以帮助您了解版本更改的影响,但首次安装 Tableau Desktop 的客户也可能在已修复问题列表中找到有用的信息。

版本 2020.3 中新增

安装和部署 Tableau

升级时可保留最近的工作簿和设置

现在,当您将 Tableau Desktop 升级到下一个主要版本时,您最近的工作簿将自动导入并还原到“开始”页面,以及您最近的连接列表和“发现”窗格中任何特定于组织的设置。在以前的版本中,虽然您仍然可以在“我的 Tableau 存储库”中找到工作簿,但开始页面将是空的。

连接到数据并准备数据

关系、数据建模和“数据”窗格的增强功能

在 2020.2 中,Tableau 引入了关系。关系是在 Tableau 中合并数据进行多表分析的一种灵活的新方法。数据源现在支持新逻辑层中的多表数据模型。Tableau 可识别数据源中的单独表,并在本机详细级别为每个表执行聚合。若要详细了解关系和数据建模,请参见“新增功能”主题中的使用关系为多表分析合并数据

在 2020.3 中,您可以基于计算字段创建关系,并使用关系定义中的运算符比较用于关系的字段。

在“数据源”页面上,现在可以使用拖放来移动和替换数据模型中的表。

在“数据”窗格中,增加了一个用于搜索的筛选器,让您能更轻松地查找感兴趣的字段。

此外,您现在可以将“数据解释”功能与包含多个相关表的数据源一起使用。必须正确设置关系的关联基数和引用完整性设置,“数据解释”功能才能分析多表相关数据。

覆盖跨数据库联接的功能限制

通过允许 Tableau 使用连接到的数据库(而不是 Hyper)执行联接,您可以在联接来自单一文件连接和单一数据库连接的数据时提高性能。但使用此选项必须满足某些条件。

为了能够在使用此选项时进行试验并确定最佳性能配置,作为管理员,您可以覆盖文件大小、联接类型和单个文件连接限制,并强制 Tableau 使用实时数据库连接来执行联接。

有关详细信息,请参见提高跨数据库联接的性能

使用并集联接合并空间文件

有了 Tableau 2020.3,浏览地理数据比以往任何时候都更加灵活。现在,只要空间文件位于相同数据源中并采用单表格式,就可以使用并集联接将它们合并在一起。有关详细信息,请参见合并数据(Link opens in a new window)

设计视图和分析数据

使用预测建模函数创建预测模型和预测

使用两个新的表计算函数 MODEL_QUANTILE 和 MODEL_PERCENTILE,您可以使用强大的统计引擎依据数据中进行预测和生成预测,以及识别意外值,所有这些功能都使用熟悉的表计算界面。

可以在所有详细级别对数据进行筛选、聚合和转换,并自动重新计算输入和预测以匹配屏幕上的数据。有关详细信息,请参见预测建模函数在 Tableau 中的工作方式。或者,请查看此博客文章:使用预测建模函数在 Tableau 中生成预测

在清除参数动作选择指定值

现在,在使用参数动作时,可以在清除可视化项中的选择时指定参数值。以前,作者没有直接的方法来指明可视化项将在交互期间返回的参数值。有关详细信息,请参见参数动作

针对动态参数轻松刷新数据源

以前,只有在打开工作簿并且首次连接到字段的数据源时,才会对动态参数查询进行求值。现在,只需单击按钮,即可从直接工作簿中对查询进行求值。在 Tableau Desktop 中,只需按 F5 或从数据源的上下文菜单中选择“刷新”。在 Tableau Online 或 Tableau Server 中,单击工具栏中的“数据源刷新”按钮。有关动态参数以及如何使用它们的详细信息,请参见此博客文章

集控件的增强功能

回想一下,使用集控件,用户只需直接与视图中的卡片交互,即可添加或移除集成员。现在,您的集控件将遵循视图中的任何上下文筛选器。如果您是使用大型数据源的企业,使用上下文筛选器来提高性能,并缩小集域的范围以仅包含感兴趣的数据,则这一点尤其重要。 集控件现在也可用于 Web 制作环境。有关集控件的详细信息,请参见创建集

使用仪表板对象下载交叉表文件

使用“下载”对象(以前称为“导出”对象),仪表板查看者现在能够以交叉表文件形式下载选定的工作表。在 Tableau Desktop、Tableau Online 或 Tableau Server 中制作 时,尽管您可以添加“下载”对象,但只能从 Web 浏览器下载交叉表。

有关详细信息,请参见添加仪表板对象并设置其选项

使用 IN 运算符比较字段

使用新的 IN 逻辑函数轻松地比较值列表。在布尔计算中,IN 运算符将接受两个或多个字段,如果这两个字段中的任一值相同,则返回“true”值。IN 运算符将集合交的功能与逻辑函数的灵活性和速度相结合。有关详细信息,请参见逻辑函数(Link opens in a new window)

在 Web 上准备、制作和查看数据

在 Tableau Online 或 Tableau Server 中筛选视图和数据源上的数据

现在,在 Tableau Online 或 Tableau Server 中制作时,您可以为工作簿和数据源创建、编辑和移除筛选器。这些改进包括分类、离散和相对日期筛选器。若要在工作簿上设置筛选器,请将字段拖到筛选器功能区。

如果您有权编辑数据源,可以通过选择“数据源”选项卡来创建数据源筛选器。在“筛选器”下,选择“添加”。

有关详细信息,请参见筛选视图中的数据以及筛选数据源中的数据

在 Tableau Online 或 Tableau Server 将交叉表下载到 Excel

现在,您可以在使用 Tableau Online 和 Tableau Server 时将视图下载为 .xlsx 文件格式。此下载选项保留数字格式,包括国际分隔符。有关详细信息,请参见下载视图和工作簿

在 Tableau Online 或 Tableau Serve 中使用 Mapbox 或 WMS 服务连接

自 Tableau 2020.3 起,您现在可以发布具有 Mapbox 或 WMS 服务器连接的工作簿。有关详细信息,请参见使用 Mapbox 地图(Link opens in a new window)使用 Web 地图服务 (WMS) 服务器(Link opens in a new window)

Tableau Online 和 Tableau Server 中针对相对日期筛选器的辅助功能改进

现在,在 Web 制作环境中,相对日期筛选器既可以通过键盘访问,也可以与屏幕阅读器兼容。您可以在此处找到有关 Tableau 中的辅助功能的详细信息。

在 Tableau Online 或 Tableau Server 中创建筛选器和“转到工作表”动作

您第一次可以在 Tableau Online 和 Tableau Server 中制作时创建动作。现在,可以从仪表板和单个工作表中执行“筛选动作”和“转到工作表”动作。在 Web 制作模式下,对选定字段的筛选已大大简化,允许您指定源字段和目标字段,而无需打开单独的对话框。

有关详细信息,请参见筛选动作从一个视图导航到另一个视图、仪表板或故事

使用“数据问答”(Ask Data) 功能精确优化日期

现在,您可以优化现有查询以显示特定日期。“时间段”选项显示一个连续日期范围,而“日期值”选项显示可以在多个时间段中重复的范围。(例如,若要查看多年第 1 季度的综合销售业绩,请在“日期值”下选择“季度”。)

有关详细信息,请参见调整日期筛选器

使用“数据问答”(Ask Data) 功能以自然语言显示建议的问题

如果您是数据源所有者或 Tableau 管理员,现在可以使用用户熟悉的语言显示建议的问题,而不是显示为正式的查询。用户可以单击显示的文本,或在“数据问答...”框中输入。

有关详细信息,请参见自定义建议的问题

在 Tableau Online 和 Tableau Server 上协作和浏览

查找与您共享的项目

当与您共享项目时,该项目将添加到您的“与我共享”页面。这样可以方便以后查找共享项目,而无需搜索收件箱或请求其他链接。有关详细信息,请参见共享 Web 内容

Shared with Me page

数据刷新时获取订阅

现在,您可以将电子邮件订阅的频率设置为仅在数据刷新时发送。订阅允许您按选择的频率和计划接收视图或工作簿的电子邮件快照。将频率设置为“数据刷新时”意味着您将知道电子邮件中的快照包含最新数据。有关详细信息,请参见创建视图或工作簿订阅

为 PDF 订阅选择新选项

现在,当您在 Tableau Online 或 Tableau Server 中创建或修改视图或工作簿订阅时,您可以选择 PDF 附件的页面大小和方向。有关详细信息,请参见创建视图或工作簿订阅

用于组织收藏夹的辅助功能改进

现在,您可以使用键盘组织收藏夹以执行拖放交互。有关详细信息,请参见Web 上适用于Tableau 的键盘辅助功能

加载项

Tableau Catalog 更新 - 数据管理加载项的一部分

Tableau Catalog 包括在单独许可的 Tableau Server 和 Tableau Online 数据管理加载项中。有关 Tableau Catalog 的详细信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

此版本中包括以下功能:

在 Tableau Desktop 中查看数据质量警告 - 当您在 Tableau Desktop 中打开带有数据质量警告的工作簿时,警告图标(蓝色圆圈或带感叹号的黄色三角形)会出现在工作簿工作表页面的“数据”选项卡上。有关详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“设置数据质量警告”。

添加了“敏感数据”警告类型 - 您可以使用此新警告类型为组织中的敏感数据设置数据质量警告。有关详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“设置数据质量警告”。

嵌入资产列在外部资产中 - 您现在可以看到列在“外部资产”页面中的嵌入资产。有关详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“嵌入式资产出现在外部资产中”。

标记外部资产 - 向数据库、表和列中添加标记,这样,除其他内容外,您可以标记具有个人身份信息 (PII) 的表和列。有关详细信息,请参见标记项

早期版本中的新增功能

版本 2020.2 中新增

连接到数据并准备数据

使用关系为多表分析合并数据

关系是在 Tableau 中合并数据进行多表分析的一种灵活的新方法。数据源现在支持新逻辑层中的多表数据模型。Tableau 可识别数据源中的单独表,并在本机详细级别为每个表执行聚合。

Creator 可以使用关系合并表。在逻辑表之间使用关系可以更轻松地在正确的详细级别探索和分析多表数据,而无需编写专用计算来控制平均值和总计等聚合。在分析期间,Tableau 会根据工作表的当前上下文查询数据,并仅引入当前可视化项所需的数据。

使用表之间的关系的数据源的示例。逻辑层中的表充当数据模型物理层中表的容器。

为了支持多表分析,Tableau 界面的几个部分已更改。“数据源”页面(画布、数据网格)、“查看数据”窗口和工作表中的“数据”窗格均已更新,以支持多表分析体验。有关详细信息,请参见界面不同部分的变化(Link opens in a new window)

有关关系和数据源更改的详细信息,请参见以下主题:

观看视频:有关数据源增强功能的概述以及在 Tableau 中使用关系的简介,请参阅这个时长 5 分钟的视频。

在此 Tableau 博客文章:关系,第 1 部分:在 Tableau 中引入新的数据建模(Link opens in a new window)中详细了解关系查询的工作方式。

针对 Snowflake 连接配置代理

您可以使用自定义驱动程序参数字段通过 Snowflake 代理来配置连接。请参见Snowflake

连接到 Azure Synapse Analytics(新连接器名称)

Microsoft 重命名了其产品,Tableau 的连接器也进行了重命名。Azure SQL 数据仓库连接器现在名为 Azure Synapse Analytics。请参见Azure SQL Synapse Analytics

连接到 Esri ArcGSI Server

现在,您可以将 Tableau 连接到 Esri ArcGIS Server。请参见Esri ArcGIS Server

连接到 Oracle 中的空间字段

您现在可以连接到 Oracle 数据源中的空间数据字段。有关详细信息,请参见连接到数据库中的空间数据(Link opens in a new window)

设计视图和分析数据

添加集控件,允许用户快速修改集的成员

使用集控件,受众无需编辑模式即可选择集的成员。用户只需直接与视图中的卡片交互,即可添加或移除集成员。再加上“集动作”,您拥有两个功能强大的补充功能,便于对您感兴趣的集进行可视化。

有关详细信息,请参见创建集,或查看此博客文章:使用集控件在用户友好的包中进行强大的分析

通过与可视化项直接交互,在集内添加或移除值

现在,使用“集动作”,您和您的受众可以使用可视化项本身以增量方式向集内添加值或从中移除值。只需与可视化项交互,并选择要包含或排除的标记。再加上新的“集控件”功能,您可以通过两种强大的方式来深入了解数据。

有关详细信息,请参见集动作

通过“数据解释”功能控制用于分析的字段

现在,您可以指定在分析期间对哪些字段进行建模。通过选择在解释中包含和排除哪些字段,仪表板作者可以隐藏冗余结果并添加默认情况下排除的字段。

有关详细信息,请参见使用“数据解释”功能检查视图中的“解释”窗口的各个部分

在 Web 上准备、制作和查看数据

在浏览器中上载和打开工作簿

用户现在可以将 Tableau 工作簿上载到 Tableau 站点,而无需通过 Tableau Desktop、REST API 或 TabCmd 进行发布。在 Tableau 站点中,具有“Creator”或“Explorer(可发布)”站点角色的用户可以选择“新建”>“工作簿上载”以将 .twb 或 .twbx 文件(最多 50 MB)上载到项目。有关详细信息,请参见将工作簿上载到 Tableau 站点

针对“数据问答”(Ask Data) 功能自定义建议的问题

数据源所有者和 Tableau 管理员可以为数据源自定义建议的问题,并根据组织中用户的需求进行定制。有关详细信息,请参见自定义建议的问题

使用“数据问答”(Ask Data)功能为多个数据源添加同义词

当字段或值在整个组织中具有类似的用法时,可以使用数据角色跨多个数据源应用相同的同义词。举例来说,如果每个子公司对业务部门使用相同的名称,或者产品线具有一组一致的子产品,则数据角色是很好的选择。

对同义词使用数据角色可以节省大量时间,因为您可以在 Tableau Online 或 Tableau Server 中集中管理它们。从“数据问答”(Ask Data)功能中,您可以发布新的数据角色,并应用在“数据问答”(Ask Data)功能或 Tableau Prep(Link opens in a new window) 中创建的现有数据角色。

有关详细信息,请参见为多个数据源添加同义词

整理收藏夹内容

拖放卡片可为收藏夹创建自定义排序顺序。在 Tableau Online 或 Tableau Server 上的网格视图中与收藏夹交互时,此选项可用。有关详细信息,请参见标记收藏夹

Favorites reorder drag and drop

创建指标以跟踪数据

指标可帮助您跟踪数据的更改。您可以从 Tableau Online 或 Tableau Server 上的视图中创建指标。使用指标来监视关键数字,如每日销售额。有关详细信息,请参见创建指标并排查其问题

Multiple metrics cards

使用 Tableau Online 和 Tableau Server 进行协作

仪表板的下载为交叉表改进之处

现在,您可以为针对仪表板下载为交叉表,而无需先选择工作表。之前,在选择要导出到 .csv 文件的工作表之前,该按钮处于禁用状态。现在,您可以选择“下载”->“交叉表”,从选项列表中选择相应的工作表。有关导出到交叉表的详细信息,请参见从 Tableau Desktop 导出数据

编辑图例和工具提示的增强功能

现在,使用 Tableau 2020.2,即使注销,工具提示的大小调整和位置更改也会保持不变。有关详细信息,请参见设置标题、说明、工具提示和图例的格式(Link opens in a new window)

加载项

Tableau Catalog 更新 - 数据管理加载项的一部分

Tableau Catalog 包括在单独许可的 Tableau Server 和 Tableau Online 数据管理加载项中。有关 Tableau Catalog 的详细信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

此版本中包括以下功能:

提高重要警告的可见性 - 您可以将数据质量警告设置为高度可见,以便受警告影响的可视化项的用户看到通知,并且警告在 Tableau 的其他地方以更突出的黄色显示。有关详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“设置数据质量警告”,以及在视图中浏览和分析数据中的“使用‘数据详细信息’查看可视化项信息”。

仪表板显示在“世系”窗格中 - 当您在世系中选择“仪表板”项时,可以看到下游仪表板的列表。有关详细信息,请参见 Tableau Server(Link opens in a new window)Tableau Online(Link opens in a new window) 帮助中的“为影响分析使用世系”。

针对“已认证”和数据质量警告进行筛选外部资产 - 除了使用搜索来缩小针对外部资产的选择之外,您现在还可以按“已认证”和数据质量警告筛选数据库、文件和表。

连接时有更多的筛选器 - 连接到数据时,可以依据连接类型筛选数据库和表。

版本 2020.1 中新增

安装和部署 Tableau

自定义“发现”窗格

现在,您可以自定义显示在 Tableau Desktop 中的“开始”页面上的“发现”窗格,以显示自定义内容,而不是默认情况下显示的链接、博客文章和 Tableau 新闻。只需创建自己的网页(托管在您提供的 Web 服务器上),然后使用新的 DISCOVERPANEURL 安装属性指向它。启动 Tableau Desktop 时,将会显示自己的自定义内容时。为了帮助您快速入门,Tableau Desktop 提供了一个模板(Link opens in a new window),该模板模拟了 Tableau 提供的“发现”窗格的相同布局。只需下载该模板,并将链接替换为自定义内容即可。

使用此功能可提供特定于组织的内容的链接和信息,以便用户更轻松地快速开始使用 Tableau。

若要将 Tableau Desktop 配置为显示自定义发现窗格内容,请在通过命令行 (Windows) 进行安装的过程中,包括属性 DISCOVERPANEURL="https://yourwebpageURL"。如果要在安装完成后更新发现窗格内容,请为安装了 Tableau Desktop 的每台计算机将 DiscoverPaneURL 设置为自定义 URL 的 DiscoverPane 添加到注册表 (Windows) 或 .plist 文件 (MacOS) 中。

注意:此功能目前仅适用于 Tableau Desktop

有关详细信息,请参见 Tableau Desktop 和 Tableau Prep 部署指南中的安装程序属性(Link opens in a new window)在安装之后更改安装设置(Link opens in a new window)

支持基于登录名的许可证管理

基于登录名的许可证管理 可帮助您为在 Tableau ServerTableau Online 上具有 Creator 角色的用户管理许可。具有 Explorer 或 Viewer(查看者)角色的用户无法使用此功能。如果将基于角色的订阅与 Tableau ServerTableau Online 结合使用,则可以使用 基于登录名的许可证管理 来简化许可证管理,从而不必使用单独的 Tableau DesktopTableau Prep Builder 产品密钥。您只需要管理本地 Tableau Server 的一个或多个产品密钥,或者,如果是 Tableau Online,您根本无需管理任何产品密钥。

连接到数据并准备数据

Salesforce 连接器有更新

我们更新了 Salesforce 连接器,以提供更快的性能、更出色的灵活性,以及更多可使用的数据。首先,我们改变了连接到 Salesforce 数据的方式;连接器现在根据数据集的规模动态切换 API,从而大大提高了性能。此外,Salesforce 连接器现在支持使用 SOQL 语言,就像现在可以使用自定义 SQL 一样,为您的分析增加了灵活性。最后,您现在将能够连接到其他数据对象,如 Salesforce Activity History 和 Campaign Influence,使您能够在 Tableau 中查看和了解更多的数据。

设计视图和分析数据

使用动态参数自动刷新参数

现在,您可以将参数的当前值设置为独立于视图的单值计算的结果。此外,还可以基于某个数据源列刷新参数的值列表(或域)。这意味着,每次打开工作簿且 Tableau 连接到参数引用的数据源时,工作簿中引用该参数的每个位置都将使用最新的值或域。

有关详细信息,请参见有关动态参数的此博客文章。此外,请参见创建参数

使用 Buffer 函数可视化地图上的区域

找到一个点周围的区域曾经需要复杂的计算,而且不能保证准确。使用新的 Buffer 函数,我们可以定义距我们想要可视化的点的确切距离。此区域将准确反映地图的实际区域,即使在查看由于地图投影而扭曲的点时也是如此。有关详细信息,请参见空间函数(Link opens in a new window)

以动画方式显示标记过渡

为可视化项设置动画,以更好地突出显示数据中不断变化的模式、显示峰值和异常值,并查看数据点如何进行聚类和分离。

动画在筛选、排序和缩放设置、不同页面以及对筛选器、参数和设置操作的更改之间进行视觉过渡。当可视化项以动画方式显示对这些更改的响应时,查看者可以更清楚地看到数据有何不同,从而帮助他们做出更明智的决策。有关详细信息,请参见设置动画格式

将仪表板导出为 PDF、PowerPoint 或图像

新的“导出”对象可让您的受众快速创建仪表板的 PDF 文件、PowerPoint 幻灯片或 PNG 图像。样式和格式设置选项类似于“导航”对象(以前称为“按钮”对象)。您可以选择显示文本或图像,指定自定义边框和背景颜色,以及提供信息性工具提示。

有关详细信息,请参见添加仪表板对象并设置其选项

在“数据解释”功能中查看状态

“数据解释”窗口现在包含一个状态栏,用于提供解释通知、消息和所调查字段的摘要。在宽数据集(超过 500 列)上使用“数据解释”功能,性能也有所提高。此外,“数据解释”窗口现在可以调整大小。

有关详细信息,请参见使用“数据解释”功能检查视图“数据解释”功能:状态信息

在 Web 上准备、制作和查看数据

自动将手机布局添加到新仪表板

Web 制作环境现在包括“仪表板”>“向新仪表板中添加手机布局”命令,该命令默认处于选定状态。在大多数情况下,自动生成的手机布局是较小屏幕的理想选择,但您始终可以在 Tableau Desktop 中对其进行编辑。有关详细信息,请参见针对不同设备类型创建仪表板布局

Web 上改进的工具提示格式

通过改进的工具提示格式设置,在 Web 上为作品设置格式变得更加容易。现在,当您在 Web 制作环境中设置工作簿的格式时,您可以包括工具提示内部可视化项和自定义缩进。有关详细信息,请参见在工具提示中创建视图(工具提示内部可视化项)(Link opens in a new window)

加载项

Tableau Catalog 更新 - 数据管理加载项的一部分

Tableau Catalog 包括在单独许可的 Tableau Server 和 Tableau Online 数据管理加载项中。有关 Tableau Catalog 的详细信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

此版本中包括以下功能:

增加了连接器- 连接到来自外部资产的更多数据。我们增加了对以下连接器的支持:Google Big Query、Google Drive、Google Sheets、Box、Dropbox 和 OneDrive。

创建工作簿- 从“外部资产”页面或者数据库或表页面为 Catalog 支持的连接创建工作簿。有关详细信息,请参见Creator:Web 制作入门指南中的“Tableau Catalog 用户通过外部资产创建工作簿”。

针对“已认证”和数据质量警告进行筛选 - 按“已认证”筛选数据源、数据库、文件和表,按连接筛选数据源,以及按数据质量警告筛选数据库和表。有关详细信息,请参见Creator:连接到 Web 上的数据中的“打开‘连接到数据’页面”或使用 Tableau Server 或 Tableau Online 连接到数据中的“通过 Tableau Desktop 连接”。

增强的“数据详细信息”窗格 -

  • 查看一个迷你图,其中包含过去 12 周内查看工作表或仪表板的次数。
  • 很容易看到视图上有警告。
  • 展开字段以查看字段元数据,例如说明或计算。
  • 当工作簿中的字段继承其说明时,查看说明的来源。

    有关详细信息,请参见在视图中浏览和分析数据中的“使用‘数据详细信息’查看可视化项信息”。

版本 2019.4 中新增

安装和部署 Tableau

与 Tableau 共享使用情况数据

Tableau 会收集数据,帮助我们了解产品的使用情况,以便改进现有功能并开发新的功能。我们将依据 Tableau 隐私政策(Link opens in a new window)收集和处理所有使用情况数据。但是,如果您不想参加,则可以选择退出。

选择退出选项已更改。“使用情况数据收集”默认情况下已启用。如果您不想参与,请在安装后从安装程序或“自定义安装程序 (MacOS)”对话框或者从“帮助”菜单中选中“不发送产品使用情况数据”复选框。

有关详细信息,请参见 Tableau Desktop 和 Tableau Prep 部署指南中的关闭使用情况报告(Link opens in a new window)

不再为 MacOS 自动安装默认数据库驱动程序

在 Mac 上安装 Tableau Desktop 时,我们只会自动安装 PostgreSQL 数据库驱动程序。如果需要其他驱动程序来连接到数据,您可以通过驱动程序下载(Link opens in a new window)页面安装这些驱动程序。

连接到数据并准备数据

增加了对六个数据连接器的支持

使用以下连接器可将 Tableau 连接到数据:

增加了对连接器插件的支持

您可以使用通过 Tableau 连接器 SDK 创建的连接器来连接到数据。有关详细信息,请参见使用 Tableau 连接器 SDK 构建的连接器插件。有关 Tableau 连接器 SDK 的信息,请参见 GitHub 上的 Tableau 连接器 SDK(Link opens in a new window)

在 Tableau 中转换 SAP HANA 级别分层结构

在将 Tableau 连接到具有级别分层结构的 SAP HANA 计算视图时,“数据”窗格中将显示 SAP HANA 级别分层结构的结构。如果要在 Tableau 中修改 SAP HANA 级别分层结构,则需要将其转换为用户分层结构。有关详细信息,请参见将 SAP HANA 级别分层结构转换为用户分层结构

设计视图和分析数据

制作最多包含 50 列的表格并水平滚动

现在,您可以制作最多包含 50 列的宽表。此外,具有离散字段的宽表现在可以水平滚动。

若要更改行和水平行标签的最大数量,作者必须在 Tableau Desktop 中使用“表选项”对话框。

有关更多详细信息,请参见定义表结构。此外,请参见 datavis.blog(Link opens in a new window) 上 Tableau Public 大使 Ambassador Marc 发布的有关包含 50 列的表(Link opens in a new window)的这篇博文。

“数据解释”功能考虑的更多数据

“数据解释”功能现在可对数据源中可能影响标记值的非可视化度量进行分析。解释将为源可视化项中的所有标记显示目标度量与非可视化度量之间的关系。

现在可以对具有聚合类型 AGG 的计算字段(例如比率计算)进行分析。对于所有非可视化维度和度量值解释,非可视化计算字段被视为解释的候选项。

从工作表转到相关仪表板和故事

若要快速转到工作表出现在其中的仪表板和故事,请右键单击工作表标签,并打开新的“使用范围”菜单。 将此视为仪表板和故事中提供的“转到工作表”命令的配套功能。结合使用这两个功能,您可以快速优化工作表设计和数据,以更好地适应仪表板布局和故事点。

有关详细信息,请参见在工作表、仪表板和故事之间导航

轻松识别和选择父布局容器

父布局容器的自定义名称现在将显示在每个仪表板对象的菜单中,使您能够轻松识别和选择它们。

有关详细信息,请参见使用布局容器组合项目

自动将手机布局添加到现有仪表板

若要在打开缺少手机布局的旧仪表板时自动创建这些布局,请选择“仪表板”>“向现有仪表板中添加手机布局”

有关详细信息,请参见自动添加手机布局

使用沙盒化仪表板扩展程序确保数据安全性

新的沙盒化仪表板扩展程序在受保护的环境中运行,无法访问 Web 上的任何其他资源或服务。作为作者,您可以快速将沙盒化扩展程序合并到仪表板中,因为它们不需要 Tableau 管理员的批准。

若要查看所有可用的沙盒化扩展程序,请转到 extensiongallery.tableau.com(Link opens in a new window)

有关详细信息,请参见使用仪表板扩展程序

嵌套排序的增强功能

对离散度量和维度执行嵌套排序如同通过 Tableau Desktop 的嵌套排序(Link opens in a new window)功能一样轻松。

使用 WMS 或 Mapbox 背景地图时改进的工作流程

使用新的简化地图对话框将 Mapbox 或 Web 地图服务背景地图添加到可视化项。现在可以通过“背景地图”菜单直接访问每个背景地图。

有关详细信息,请参见使用 Web 地图服务 (WMS) 服务器(Link opens in a new window)使用 Mapbox 地图(Link opens in a new window)

在 Web 上准备、制作和查看数据

发现建议的视图

Tableau Server 和 Tableau Online 上新的“建议”页面会向您推荐视图以供浏览。建议可帮助您在站点上找到可能无法以其他方式找到的有用内容。有关详细信息,请参见在您的 Tableau 站点上发现推荐视图

Recommendations

从“数据问答”(Ask Data)功能的建议类别中进行选择

为了帮助您使用“数据问答”(Ask Data)功能快速回答问题,我们将建议分为四类:基本数据分析、日期和时间、筛选器以及可视化项类型。这些建议为您的分析提供了一个很好的起点,您以后可以轻松地根据需要进行修订。

有关详细信息,请参见使用“数据问答”(Ask Data)功能自动生成视图

共享指向“数据问答”(Ask Data)功能可视化项的链接

您可以快速共享“数据问答”(Ask Data)功能可视化项,甚至无需保存工作表。只需单击查询框上方的链接图标,然后复制有权访问数据源的任何人都可以查看的链接。

使用“数据问答”(Ask Data)功能比较随时间发生的变化

现在,通过“数据问答”(Ask Data)功能,您可以将时间段与像“年同比”、“季度同比”这样的短语或按月、周或日的类似比较进行比较。差异可以采用绝对数字或百分比表示。

有关详细信息,请参见比较随时间发生的变化

在手机上查看优化的工作表

当您在手机上查看单个工作表时,Tableau 会自动以垂直排列方式显示筛选器、图例和其他卡片。

在 Web 上编辑工具提示

现在,当使用您在 Tableau Desktop 中学到的相同过程在 Web 上编辑工作簿时,您可以设置格式、编辑和使用工具提示。

有关详细信息,请参见设置标题、说明、工具提示和图例的格式

使用地图图层自定义 Web 上的地图

地图图层允许您使用 Tableau 的 Web 编辑功能自定义地图的外观。

有关详细信息,请参见自定义地图的外观

使用 Tableau Online 和 Tableau Server 进行协作

通过 Tableau 站点快速共享内容

通过新的共享功能,您无需撰写单独的电子邮件,就可以通过 Tableau 站点与他人共享内容。此外,如果通过选择筛选器或标记对视图进行修改,现在在共享时将会捕获这些更改。有关详细信息,请参见共享 Web 内容

Share menu option

请求访问内容

您现在可以请求访问您无权查看项目、工作簿或视图的内容。当有人请求访问时,Tableau 会向控制该内容权限的人员发送一封电子邮件。举例来说,如果请求的工作簿位于在项目级别(锁定项目)控制权限的项目中,则项目所有者将收到一封电子邮件,其中包含有关请求的信息、指向所请求内容的链接,以及有关如何授予访问权限或管理权限的说明。

有关访问权限选项的详细信息,请参见管理 Web 项目

Tableau Online 和 Tableau Server 中针对 Viewer(查看者)的辅助功能改进

在 Tableau Online 或 Tableau Server 中选择指向视图或工作簿的链接时,可以使用屏幕阅读器或键盘导航在工具栏菜单中导航,以便进行协作、与可访问的视图交互,或使用“跳转到内容”选项跳过导航面板和工具栏,并直接跳转到视图。此更新还增加了用于键盘导航的焦点指示器。以前,需要嵌入视图才能在此级别通过辅助功能获得该体验。有关详细信息,请参见Web 上适用于Tableau 的键盘辅助功能,或者参见常见问题解答:辅助功能(Link opens in a new window),了解 Tableau 的辅助功能一致性报告 (VPAT)。

版本 2019.3 中新增

增加了对意大利语的支持

Tableau 已增加了对意大利语的支持。现在可将 Tableau 设置为用十一种语言之一来显示用户界面:

  • 中文(简体)
  • 中文(繁体)
  • 英语(英国)
  • 英语(美国)
  • 法语
  • 德语
  • 意大利语
  • 日语
  • 朝鲜语
  • 葡萄牙语
  • 西班牙语

有关详细信息,请参见设置显示语言(适用于 Tableau Desktop)或更改语言和区域设置(适用于 Tableau Online 和 Tableau Server)。

除了在所有 Tableau 产品中支持意大利语之外,还提供了这些语言版本的帮助。若要阅读您的首选语言版本的帮助,请导航到 Tableau 帮助主页面的底部,并从页脚中选择语言。

Menu of language options

帮助设计

更轻松地提供反馈

每个帮助页面的右下角会显示一个蓝色的“发送反馈”图标,使您能更轻松地发送有关主题中的内容的反馈。单击该图标可以让我们知道主题对您是否有帮助,还可以针对需要改进的方面提出意见。

连接到数据并准备数据

使用数据库连接执行跨数据库联接

在过去的版本中,当在文件和数据库之间执行跨数据库联接时,Tableau 会将数据源中的所有数据拉取到 Hyper 并在该处执行联接。根据数据集的大小,此操作可能需要一段时间。

现在,为了提高性能,您可以选择允许 Tableau 改为使用所连接的数据库来执行联接。如果选择此选项,Tableau 将决定哪个选项更快(Hyper 还是连接的数据库)。如果 Tableau 使用连接的数据库来执行联接,则会将文件数据源中的数据复制到连接的数据库的临时表中。选择此选项之前,请确保数据库来自受信任的来源。

若要查看此新选项,请在“数据源”选项卡中通过支持的文件类型添加一个连接,并通过支持的数据源添加一个连接。此版本支持以下文件类型和数据源:

文件类型:

  • Microsoft Excel
  • PDF
  • 文本文件(.csv、.txt、.tsv 或 .tab)

数据源:

  • Microsoft SQL Server
  • Oracle
  • PostgreSQL
  • Vertica

“跨数据库联接”选项显示在画布的右上角。若要更改跨数据库联接的执行方式,请单击“编辑”

“跨数据库联接”对话框中,选择要使用的选项。

所选选项将显示在画布中。可以随时更改您的选择。此选项在 Tableau Desktop 中提供,用于在 Tableau Server 中进行 Web 编辑。

有关配置跨数据库联接处理选项的详细信息,请参见提高跨数据库联接的性能(Link opens in a new window)

使用 Tableau Catalog 连接到数据库和表(需要数据管理加载项)

Tableau Catalog 作为 Tableau Server 和 Tableau Online 数据管理加载项的一部分提供。在环境中启用了 Tableau Catalog 后,除了在 Tableau Server 和 Tableau Online 上连接到发布的数据源外,您还可以通过 Tableau Desktop 上的“搜索数据”连接到数据库和表。有关详细信息,请参见使用 Tableau Server 或 Tableau Online 连接到数据。有关 Tableau Catalog 的信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

“Tableau Server”与新的“搜索数据”页面一起移到“连接”窗格的上方

在 Tableau Desktop 上的“连接”窗格中,“Tableau Server”移到窗格顶部的“搜索数据”下。选择“Tableau Server”连接到 Tableau Online 或 Tableau Server。

连接到 Tableau Server 2019.3 或更高版本时,您可以在“搜索数据”页面上搜索并选择要连接到的已发布数据源。在环境中启用 Tableau Catalog 之后(需要数据管理加载项),您还可以搜索并连接到数据库和表。

有关详细信息,请参见使用 Tableau Server 或 Tableau Online 连接到数据。有关 Tableau Catalog 的信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

在 Web 上连接到空间文件以及其他空间连接器改进之处

在 Tableau Server 或 Tableau Online 中进行 Web 制作时连接到空间文件作为 Creator,您可以在创建新工作簿并连接到数据时在“文件”选项卡中上传只需要一个文件(封装在 .zip 中的 KML、.geojson、.topojson 和 Esri Shapefile,以及扩展名为 .gdb.zip 的 Esri 文件地理数据库)的空间文件格式。在 Tableau Desktop 中,您现在可以连接到 .zip 文件夹以及 Esri 文件地理数据库文件夹中的 Shapefile。有关详细信息,请参见 Web 上的Creator:连接到 Web 上的数据依据空间文件创建 Tableau 地图

连接到 Databricks

使用 Databricks 连接器可将 Tableau 连接到 Databricks 数据库。有关详细信息,请参见Databricks

改进的 TabPy 连接

客户可以为 TabPy 启用基本身份验证,从而要求为连接使用用户名和密码。利用日志记录的改进之处,将能够更精确地跟踪哪些用户执行了哪些代码。有关详细信息,请参见使用分析扩展程序传递表达式

设计视图和分析数据

使用“数据解释”功能浏览和检查视图

使用“数据解释”功能检查、发现和深入了解可视化项中的标记。“数据解释”功能可为所选标记提出统计解释的建议,包括当前视图中未使用的数据源中可能相关的数据,使您能通过一种新的方式来浏览数据。

当具有编辑权限的 Creator 和 Explorer 在 Desktop 中编辑视图,或者在 Tableau Online 或 Tableau Server 中的 Web 上编辑视图时,他们可以使用“数据解释”功能。

解释为您提供有关可能会影响标记值的数据点的相关信息及可视化项。您可以随后打开可视化项以进一步研究。有关详细信息,请参见使用“数据解释”功能检查视图

使用简化的工作流程创建手机布局

若要始终为工作簿创建手机布局,请选择“仪表板”>“向新仪表板中添加手机布局”。(此命令以前的标签为“自动生成手机布局”。)

单击新的锁形图标可在自动 和手动 手机布局之间快速切换,您也可以通过弹出式菜单来选择布局。

  • “自动生成布局”可将任何更改自动同步到“默认”仪表板,从而节省了时间。

  • “编辑布局”可创建完全独立于“默认”仪表板的布局,使您能够手动添加和排列项目。

    如果您选择编辑手机布局,请选择“优化布局”快速优化筛选器的放置、移除空白区域并进行其他操作。(此命令以前的标签为“重新排列布局”。)

有关详细信息,请参见针对不同设备类型创建仪表板布局

在 ISO-8601 日历和标准公历之间快速切换

利用 Tableau 2019.3,您现在可以通过“日期属性”对话框在使用基于周的 ISO-8601 日历和标准公历之间切换。

可以使用 ISO-8601 基于周的日历来创建 4-4-5 季度,通过这种方式可将每个季度拆分为包含 4 周、4 周和 5 周的分段,这种日历系统在财务和零售报告中很受欢迎。

有关详细信息,请参见ISO-8601 基于周的日历(Link opens in a new window)

可用于参数操作的更多聚合

参数操作现在支持级联(Link opens in a new window)、第一个四分位点和第三个四分位点聚合。并且,您可以在创建和编辑参数操作时创建参数。

使用 MAKEPOINT 将投影的坐标转换为纬度/经度

将投影的坐标转换为纬度和经度值以在空间分析和空间联接中使用。在实时数据源上创建时,此函数允许您使用计算字段将数据与其他空间文件联接,从而可以轻松地为空间分析创建数据源。有关详细信息,请参见空间函数在 Tableau 中联接空间文件

使用 DISTANCE 测量地图上两个点之间的距离

使用空间函数 Distance 计算地图上两个相关点之间的距离。您可以指定千米、英里、米或英尺作为度量单位。只能使用实时数据源创建此函数。有关详细信息,请参见空间函数

在 Web 上准备、制作和查看数据

在进行 Web 制作时使用 Tableau Catalog 连接到数据库和表(需要数据管理加载项)

Tableau Online 和 Tableau Server 的数据管理加载项中提供了 Tableau Catalog。在环境中启用了 Tableau Catalog 后,除了通过“此站点上”选项卡导航到连接到发布的数据源外,您还可以连接到更多种类的数据,如数据库和表。有关详细信息,请参见Creator:连接到 Web 上的数据。有关 Tableau Catalog 的详细信息,请参见 Tableau ServerTableau Online 帮助中的“关于 Tableau Catalog”。

在网页中嵌入“数据问答”(Ask Data)功能

使用“数据问答”(Ask Data)功能提出问题后,工具栏中将出现一个“嵌入代码”图标。单击该图标复制可合并到任何网页中的代码。

当嵌入了“数据问答”(Ask Data)功能的网页加载时,“数据问答”(Ask Data)功能将打开一个没有可视化项的数据源,同时等待用户提出问题。

若要查看网页中嵌入的“数据问答”(Ask Data)功能,用户必须具有 Tableau 许可证和连接到数据源的权限。

有关详细信息,请参见在网页中嵌入“数据问答”(Ask Data)功能

使用“数据问答”(Ask Data)功能调整相对日期筛选器

若要使用“数据问答”(Ask Data)功能调整相关日期筛选器,请单击像“last”(最后)、“previous”(以前)、“next”(下一)”或“following”(接下来)这样的单词。有关详细信息,请参见自定义字段及其数据

使用“数据问答”(Ask Data)功能显示上下文中的顶部和底部离群值

当您指定像“排名最前的 5 个国家/地区”这样的数值限制时,“数据问答”(Ask Data)功能现在将在完整维度列表的上下文中显示这些离群值。

有关详细信息,请参见数值限制(排名最前和排名最后值)

使用“数据问答”(Ask Data)功能为字段值添加同义词

如果您是数据源所有者或 Tableau 管理员,您以前无法为字段名添加同义词,但现在您也可以为字段值添加这些同义词。有关详细信息,请参见为“数据问答”(Ask Data)功能添加同义词

搜索 Tableau 站点并改善结果

在 Tableau Online 和 Tableau Server 上搜索时,您现在可以查看一整页搜索结果。这些结果按类型分段,并且您可以对结果进行筛选和排序以提高精度。有关详细信息,请参见搜索 Tableau 站点

Search results page

设置上下文筛选器

您现在可以创建上下文筛选器(“筛选器”功能区中的“添加到上下文”选项)和相关筛选器(视图中显示的筛选器控件中的“仅相关值”选项)。

保存并发布数据源和工作簿

以 PDF 附件形式接收订阅

订阅会通过电子邮件按您设置的间隔将您的视图或工作簿的快照发送给您,现在您能够以 PDF 附件形式接收这些快照。要将订阅设置为 PDF,请在 Tableau Online 或 Tableau Server 中创建订阅时选择“格式”>“PDF”“图像和 PDF”。有关详细信息,请参见创建视图或工作簿订阅

依据所选工作簿的工作表创建 PowerPoint 文件

如果希望依据 Tableau 工作簿或仪表板创建 PowerPoint 文件,您可以选择要包括的工作表和故事。每个选定工作表(如果导出故事,则为故事点)将成为生成的 PowerPoint 文件中自己的幻灯片。有关详细信息,请参见将视图从 Tableau Desktop 导出到另一个应用程序

使用 Tableau Online 和 Tableau Server 进行协作

共享更多内容类型

除了以前可以共享的视图外,还可获得易于共享的项目、工作簿、数据源和流程链接。有关详细信息,请参见共享 Web 内容

Share menu option

版本 2019.2 中新增

自定义语言

帮助重新设计

连接到数据并准备数据

设计视图和分析数据

在 Web 上准备、制作和查看数据

保存并发布数据源和工作簿

使用 Tableau Online 和 Tableau Server 进行协作

自定义语言

为 Tableau 选择十种不同的语言

Tableau 新增了对两种新语言的支持:中文(繁体)和英语(英国)。现在可将 Tableau 设置为用十种语言之一来显示用户界面:

  • 中文(简体)
  • 中文(繁体)
  • 英语(英国)
  • 英语(美国)
  • 法语
  • 德语
  • 日语
  • 朝鲜语
  • 葡萄牙语
  • 西班牙语

有关详细信息,请参见设置显示语言(适用于 Tableau Desktop)或更改语言和区域设置(适用于 Tableau Online 和 Tableau Server)。

除了在所有 Tableau 产品中支持两种新语言之外,还提供了这些语言版本的帮助。若要阅读您的首选语言版本的帮助,请导航到 Tableau 帮助主页面的底部,并从页脚中选择语言。

Menu of language options

帮助设计

更轻松地提供反馈

每个帮助页面的右下角会显示一个蓝色的“发送反馈”图标,使您能更轻松地发送有关主题中的内容的反馈。单击该图标可以让我们知道主题对您是否有帮助,还可以针对需要改进的方面提出意见。

连接到数据并准备数据

连接到 PostgreSQL + PostGIS 和 Pivotal Greenplum + PostGIS 空间数据

使用 Tableau 通过 PostGIS 扩展程序连接到 Pivotal Greenplum 或 PostgreSQL 中的空间数据。使用这些新的空间连接器,您可以使用 CustomSQL 来筛选和验证空间数据,或者使用 RAWSQL_SPATIAL 函数返回空间对象来进行高级空间分析。有关详细信息,请参见连接到数据库中的空间数据

使用 Marketo 连接器的新增功能

Marketo 连接器包括以下新功能:

  • 使用 Bulk API 来检索“All Activities”、“Leads”和“Leads by List - <list name>”表的数据,从而减少 API 调用次数。
  • 支持使用“Daily API Usage”(每日 API 使用情况)和“Weekly API Usage”(每周 API 使用情况)表来检索进行的 API 调用的次数,以便能够监视 API 使用情况并且未超出您的配额。
  • 访问所有 Marketo 表,使您能够访问以前不可用的数据。

有关 Marketo 连接器的信息,请参见Marketo

使用 SSL 连接到 TabPy 外部服务

在以前的版本中,不支持 TabPy 的 SSL 连接。在 Tableau Server 2019.2 中,您可以配置 SSL 连接。在安全环境中使用 Python 语言为高级分析和机器学习构建可视化项。TabPy 可通过 Tableau Server 远程托管,或者您可以配置 SSL 连接来保护传输中的数据。有关详细信息,请参见使用分析扩展程序传递表达式

设计视图和分析数据

使用参数动作以交互方式设置参数值

使用参数动作可让受众通过直接与可视化项交互(例如单击或选择标记)来更改参数值。可以使用参数动作来推动参考线、计算、筛选器和 SQL 查询。有关详细信息,请参见参数动作

参数动作开创了新的可能性,可以在不使用计算的情况下创建摘要值和统计数据。可以设置参数动作,让用户能够选择自动聚合到单一参数值中的多个标记。例如,参数动作可以显示当前所选标记的 AVG(Sales) 或 COUNTD(Orders)。

使用矢量平铺背景地图平移、缩放和浏览

Tableau 中的地图现在使用矢量平铺来更快地浏览地理数据。现在,当您平移或缩放时,地图显示得更清晰且更平滑,并且标签和图标可动态调整大小或形状以适应视图。新的矢量平铺地图取代了驱动 Tableau 背景地图的基础技术,带来了更平滑且更清晰的体验。Tableau 地图的背景绘图法也已更新。

使用新的地图样式和图层自定义地图的外观

您可以使用三种新的内置地图样式来自定义 Tableau 地图的外观:街道、卫星和户外。这些样式中的每一种都包括新的地图图层选项,例如“兴趣点”和“建筑平面图”,以便您可以自定义分析所显示的信息。有关详细信息,请参见自定义地图的外观

使用 MakePoint 创建空间字段和使用空间联接

使用函数 MakePoint 将文本文件、Excel 或其他数据源中的值转换为空间字段。此函数允许您使用计算字段以空间方式联接纬度/经度数据,从而可以轻松地聚合数据。有关详细信息,请参见空间函数空间函数

使用 MakeLine 创建起点-终点地图

使用空间函数 MakeLine 将地图上的相关点转换为起点-终点地图。有关详细信息,请参见空间函数

在仪表板中替换工作表

可以快速选择仪表板工作表并将其替换为另一个工作表,同时保留任何填充、边框或背景颜色以及整体布局。

有关详细信息,请参见创建仪表板并添加或替换工作表

为仪表板中的导航按钮使用文本

按钮对象可让您的受众从一个仪表板导航到另一个仪表板,或者导航到其他工作表或故事。以前,这些按钮只能显示图像,但现在您可以改为显示文本来指明按钮的目标。

有关详细信息,请参见导航和下载对象的详细选项

在仪表板中显示和隐藏浮动容器

显示/隐藏按钮使仪表板查看者能够切换浮动布局容器的可见性,从而仅在必要时显示这些容器。如果要暂时隐藏一组筛选器以显示更多可视化项,这些按钮特别有用。

有关详细信息,请参见通过单击按钮显示和隐藏浮动容器

自定义参考线工具提示

向参考线工具提示中添加自定义文本和字段。有关详细信息,请参见参考线、参考区间、参考分布和参考箱(Link opens in a new window)

禁用排序图标

现在可以禁用视图中的排序图标,该图标允许您在发布前控制视图的排序。有关详细信息,请参见在可视化项中对数据进行排序(Link opens in a new window)

在 Web 上准备、制作和查看数据

使用“数据问答”(Ask Data)功能(Ask Data)以对话风格提出问题

当您在“数据问答”(Ask Data)功能(Ask Data)中看到新问题时,您可以采用自然的对话风格快速修订现有问题。在显示为“调整问题或清除所有内容以重新开始”的文本框中,执行以下任何操作:

  • 使用像“by country”或“in December”这样的措辞添加函数。
  • 通过键入“replace [现有字段名] with [新字段名]”来替换字段
  • 通过键入“remove [字段名]”来移除字段
  • 通过键入“reset”或“clear”来清除可视化项。

有关详细信息,请参见使用对话风格调整问题的措辞

使用“数据问答”(Ask Data)功能(Ask Data)应用简单的计算

为了增强数据分析,“数据问答”(Ask Data)功能(Ask Data)支持两个度量之间的简单计算,您可以使用下面的符号来应用这些计算:

+ 对度量进行加总

- 得出度量的差

*

/

有关详细信息,请参见应用简单的计算

通过“数据问答”(Ask Data)功能(Ask Data)创建多个工作表

可以依据数据源快速创建多个不同的可视化项,然后将它们保存在新工作簿中。在“数据问答”(Ask Data)功能(Ask Data)中任何可视化项的下方,只需单击指定工作表右侧的“添加工作表”图标。

有关详细信息,请参见添加包含其他可视化项的工作表

了解用户如何使用“数据问答”(Ask Data)功能(Ask Data)

如果您是数据源所有者或 Tableau 管理员,“数据问答”(Ask Data)功能(Ask Data)提供了一个仪表板,其中显示最常见的查询和字段、用户单击的可视化结果数以及其他有用信息。筛选器使您能够将数据范围缩小到特定用户和时间范围。这些统计信息可帮助您优化数据源以提高用户的成功率。

有关详细信息,请参见了解用户如何将“数据问答”(Ask Data)功能(Ask Data)与数据源结合使用

其他“数据问答”(Ask Data)(Ask Data)增强功能

  • “数据问答”(Ask Data)功能(Ask Data)现在支持热图可视化项,非常适合于显示多个维度和度量中的离群值。

  • 将鼠标光标悬停在左侧的连续度量上时,工具提示中将显示直方图,快速显示可用值的范围。

  • 诸如“Date”、“Year”和“Month”等术语现在为在分析函数中使用保留,因此应避免在字段名中使用。有关保留的术语的完整列表,请参见“数据问答”(Ask Data)功能(Ask Data)用于分析函数的字段名
  • 字段名的同义词现在只能由数据源所有者和 Tableau 管理员更改,从而为用户提供了更一致的体验。有关详细信息,请参见为“数据问答”(Ask Data)功能添加同义词

在 Web 制作过程中创建、编辑和移除参数

现在,在 Web 制作过程中,您可以创建参数以替换计算、筛选和参考线中的常量值。有关详细信息,请参见创建参数

使用 Viewer(查看者)角色保存自定义视图

以前,创建自定义视图需要 Creator 或 Explorer 许可证,但现在 Viewer(查看者)也可以创建视图。具有自定义视图 URL 的任何人都可以看到应用的筛选器和其他更改。但是,其他人只能在“自定义视图”对话框中看到 Creator 和 Explorer 创建的公共自定义视图。

有关详细信息,请参见使用自定义视图

在 Tableau Online 和 Tableau Server 中将参数与存储过程结合使用

在 Tableau Online 或 Tableau Server 中创建数据源时,现在可以向联接中添加带有参数的存储过程。当存储过程包含参数时,您将看到一个显示参数及其类型(在数据库中定义)的对话框,并编辑这些参数值。有关详细信息,请参见使用存储过程

在状态栏中查看视图的总标记数及更多信息

浏览器左下角的状态栏向作者显示有关其视图的信息,其中包括选定标记与总标记数的对比、行和列,以及聚合。有关状态栏的详细信息,请参见状态栏信息

Web 制作中的“放置字段”菜单

在 Web 上创建或编辑视图时,可以使用下拉字段菜单更改字段的聚合。只需右键单击并拖动(在 macOS 上,右键单击并按住 Option,然后拖动)任何卡或功能区(比如“行”、“列”或“筛选器”)上的字段,并选择所需的聚合类型。这会将该字段与所选的聚合一起放在卡或功能区上。

保存并发布数据源和工作簿

将故事导出到 PowerPoint

现在,当您使用“导出到 PowerPoint”导出工作簿时,每个故事点将成为 Tableau 生成的 PowerPoint 文件中的单独幻灯片。有关将工作簿导出到 PowerPoint 的详细信息,请参见将视图从 Tableau Desktop 导出到另一个应用程序

使用 Tableau Online 和 Tableau Server 进行协作

发现 Tableau Server 和 Tableau Online 的新面孔

利用若干新的页面和导航更改,您的 Tableau 站点现在可以让您更轻松地开始操作和找到相关内容。

快速访问最重要的内容

登录到 Tableau Online 或 Tableau Server 时,您首先看到的将是新的主页。在主页上,您可以看到最近查看过的可视化项、查找最新的收藏夹内容,并发现站点上的热门内容,所有这些内容都集中在一个地方。页面顶部的欢迎横幅和操作根据您的站点角色定制,可帮助您开始操作。

Home page content overview

专用的“收藏夹”“最近”页面使您可以访问您所有最重要的内容。使用每页右侧的排序和筛选选项可以准确查找所需的内容。单击收藏夹内容的星型图标可随时添加或移除该内容。除了主页以外,您还可以从左侧导航面板访问“收藏夹”和“最近”页面。

轻松地在站点中导航

利用左侧新的导航面板,您能够在站点上的重要页面之间快速跳转,包括“浏览”页面,您可在该页面上集中看到所有站点内容。导航面板会根据屏幕大小自动调整,并且可以折叠来为您提供最佳浏览空间。

Navigation panel collapsing

在受到最少干扰的情况下查看数据

当您在 Tableau Online 或 Tableau Server 中浏览或制作可视化项时,左侧导航面板将消失,以便为您提供更多空间来进行分析。紧凑的标题允许您轻松地浏览项目分层结构、搜索站点以及根据需要访问收藏夹。

Visualization header showing favorites

若要了解有关 Tableau 站点导航的详细信息,请参见浏览 Tableau 站点

为自己订阅现有数据驱动型通知

当您在任何视图中选择“通知”时,一个新的面板会显示对于您正在查看的可视化项已经存在的通知。只需选择“添加我”即可将自己添加到现有通知。若要创建对其他人可见的通知,请在创建通知时选择“对其他人可见”。在 2019.2 之前创建的通知对其他人不可见,但可以更新为对其他人可见。若要了解详细信息,请参见从 Tableau Online 或 Tableau Server 中发送数据驱动型通知

版本 2019.1 中新增

帮助设计

右侧导航菜单

已经进行了更新来帮助您在我们的内容中导航,其中包括用于快速扫描并在页面上选择不同主题的新的右键菜单。

连接到数据并准备数据

连接到 Azure SQL 数据仓库

使用 Azure SQL 数据仓库连接器可将 Tableau 连接到 Azure SQL 数据仓库数据库。有关详细信息,请参见Azure SQL Synapse Analytics

连接到 Google Ads

您现在可以将 Tableau 连接到 Google Ads 帐户。有关详细信息,请参见Google Ads(Link opens in a new window)

连接到 Google Drive

使用 Google Drive 连接器直接访问 Google Drive 上的平面文件。有关详细信息,请参见Google Drive(Link opens in a new window)

连接到 MariaDB 

使用 MariaDB 连接器可将 Tableau 连接到 MariaDB 数据。有关详细信息,请参见MariaDB

将 SSL 与 TIBCO Data Virtualization 连接器结合使用

您现在可以使用 SSL 将 Tableau 连接到 TIBCO Data Virtualization。有关详细信息,请参见TIBCO Data Virtualization

使用新的 Snowflake 连接器功能

Snowflake 连接器现在支持使用 OAuth 作为身份验证方法。还增加了对布尔值以及对 Median 和 Percentile 函数的支持。有关将 Tableau 连接到 Snowflake 数据仓库的信息,请参见Snowflake

将集成身份验证与 Denodo 连接器结合使用

将 Tableau 连接到 Denodo 时,您可以使用集成身份验证作为身份验证方法。有关详细信息,请参见 Denodo

在处理 Microsoft Excel 数据时保持大小写

如果在执行联接时需要保持数据的大小写(例如,区分假名的日语数据),您可以从“数据”菜单中启用“保持字符大小写(Excel)”选项。启用此选项后,Tableau 唯一标识具有不同大小写的值(而不是将这些值合并),从而产生不同的行数。

有关详细信息,请参见关于使用多连接数据源(Link opens in a new window)

设计视图和分析数据

按两个轴进行排序以及其他嵌套排序改进

对于 Tableau Desktop 2019.1,嵌套排序功能进行了重大升级。新的嵌套排序功能包括在两个轴上进行排序、通过排序对话框访问嵌套排序,以及选择单个字段来对其进行嵌套排序。有关详细信息,请参见在可视化项中对数据进行排序(Link opens in a new window)

新的地图地理编码数据

Tableau 地图背后的地理编码数据库已经更新。尽管大多数地图看起来和之前版本的 Tableau 相同,但在某些情况下,数据的形状可能看起来略有不同,或包含不同的地理编码数据。有关特定位置数据的信息,请参见支持的地图数据(Link opens in a new window)

为仪表板项目指定唯一名称以便于识别

为了更好地区分仪表板项目,您现在可以使用“布局”窗格的“项目分层结构”区域或画布上每个对象的下拉菜单来重命名这些项目。

有关详细信息,请参见设置单独仪表板项目的大小、位置并对其进行重新排序和重命名

为仪表板中的 Web 内容灵活地设定目标

您第一次可以为 URL 动作指定精确目标,并可在新浏览器标签页或网页对象之间选择。如果仪表板有多个网页对象,则可以使用唯一的 URL 动作来设定每个对象的目标,从而创建视觉动态设计。因为您可以重命名网页对象,所以管理这些对象更加容易。

在此示例中,在视图中选择标记会将纬度和经度参数传递到两个不同的网页对象,每个对象都通过唯一的 URL 动作设定了目标。(earth.nullschool.net(Link opens in a new window) 提供的神奇网站图像。)

有关详细信息,请参见使用 URL 动作打开网页在仪表板中以交互方式显示网页

自动创建手机布局

默认情况下,每当您创建新的仪表板时,都会自动生成经过优化的手机布局。若要仅为特定仪表板创建它们,请从“仪表板”菜单中取消选择“自动生成手机布局”

默认“使用自动布局”选项可自动同步对“默认”仪表板所做的任何更改,从而节省了时间。如果选择“自己编辑布局”,则手机布局将完全独立,因此您需要手动添加和排列项目以反映对“默认”仪表板的更改。

有关详细信息,请参见针对不同设备类型创建仪表板布局

在 Web 上准备、制作和查看数据

畅享改进的内容浏览

利用 Tableau Online 和 Tableau Server 2019.1,您可以通过一种新方式来浏览共享内容。打开某个项目时,您将能够看到在一个网格或列表中看到该项目包含的所有内容(工作簿、视图、数据源、流程和嵌套项目)。由于您不再需要为不同的内容类型导航单独的页面,因此查找内容更加容易。有关详细信息,请参见浏览 Tableau 站点

Project showing a mixture of content types

进行“数据问答”(Ask Data)以自动创建可视化项

“数据问答”(Ask Data)功能引入了一种全新的数据交互方式,使您能键入问题并立即在 Tableau 中得到回答。答案以自动数据可视化项的形式体现,不再需要手动拖放字段或了解数据结构的细微差别。

利用对像时间系列和空间分析这样的关键分析概念的支持,以及对像“last year”(去年)、“earliest”(最早)和“most popular”(最热门)这样的对话短语的理解,“数据问答”(Ask Data)使您能自然地提出复杂的问题。

拥有数据源直接访问权限的所有用户角色(Creator、Explorer 和交互者)都可使用“数据问答”(Ask Data)功能(Ask Data)。

有关详细信息,请参见使用“数据问答”(Ask Data)功能自动生成视图

使用新的用于 Web 制作的云连接器

使用 Box、Dropbox、Google Drive、Google BigQuery 和 OneDrive 连接器将 Tableau Online 或 Tableau Server 连接到您的数据。有关详细信息,请参见 Creator:连接到 Web 上的数据

利用这些改进为 Web 制作准备数据

在 2019.1 中,在 Tableau Online 或 Tableau Server 中连接到新数据源的作者现在可以运行初始 SQL,并可以连接到自定义 SQL 查询,以及添加联接计算来解决联接中字段之间的不匹配。

使用矢量平铺背景地图平移、缩放和浏览

在 Tableau Online 或 Tableau Public 上创建或发布到其中的地图现在使用矢量平铺图来提高地理数据浏览速度。现在,当您平移或缩放时,地图显示得更清晰且更平滑,并且标签和图标可动态调整大小或形状以适应视图。新的矢量平铺地图取代了驱动 Tableau 背景地图的基础技术,带来了更平滑且更清晰的体验。Tableau 地图的背景绘图法也已更新。

在 Tableau Online 和 Tableau Public 中查看新的人口统计数据

Tableau Online 和 Tableau Public 具有与 Tableau Desktop 相比不同的新人口统计数据来源。如果您的地图在 Tableau Desktop 中使用人口统计数据层,则在将地图发布到 Tableau Online 或 Tableau Public 时,您可能会注意到一些细微差异,包括时间段和图例中的值间断。此外,当发布到 Tableau Online 或 Tableau Public 时,Tableau Desktop 中使用“块组”数据层选项的地图将自动更新为“人口普查区”。将地图发布到 Tableau Online 或 Tableau Public 时,Tableau Desktop 中出现的六个人口统计数据层将不会出现:

  • 人口增长预测
  • 家庭增长预测
  • 住房单元增长预测
  • 有效购买收入(中值)
  • 年建造建筑(中值)
  • 居住时间(年平均值)

将地图从 Tableau Desktop 发布到 Tableau Server 不会导致任何差异。

在台式机和移动设备布局之间切换

如果 Tableau Online 或 Tableau Server 用户发现手机布局或平板电脑布局限制太多,他们可以在工具栏中单击“查看台式机布局”。此切换按钮允许用户随时切换回移动设备布局。

有关详细信息,请参见确认设备将显示哪个布局

筛选器改进

按住 Ctrl 并单击(在 Mac 上按住 Control 并单击)可以在视图的多值筛选器中选择多个值。所选值可以是非连续的,并用灰色突出显示指明。选择了值之后,您可以单击其中任何一个复选框来同时清除或选择值。

保存并发布数据源和工作簿

导出并将工作簿下载到 PowerPoint

只需单击一次,便可将工作簿中的所有视图和仪表板导出到 PowerPoint。此选项会创建一个新的 PowerPoint 文件,其中包含工作簿中每个工作表的静态图像。如果文件是从 Tableau Online 或 Tableau Server 中生成的,新的 PowerPoint 文件将提供一个链接回工作簿的链接,您可以通过该链接查看最新的数据并与之交互。若要针对 PowerPoint 优化图像,请在仪表板布局中选择“大小”>“PowerPoint (1600x900)”。有关详细信息,请参见将视图从 Tableau Desktop 导出到另一个应用程序

在 Web 上预览设备布局

若要查看设计在移动设备上的显示方式,请在发布完成时在浏览器中单击“预览设备布局”。然后在可视化项上方选择设备类型,并从右侧的菜单中选择特定仪表板。

有关详细信息,请参见用于发布工作簿的全面步骤

使用 Tableau Online 和 Tableau Server 进行协作

订阅挂起时收到通知

如果订阅了视图或工作簿,您将会定期收到包含该内容的电子邮件快照。现在,如果某些原因导致订阅失败,您将收到电子邮件通知,其中包含用于恢复或删除失败通知的链接。有关详细信息,请参见创建视图或工作簿订阅

版本 2018.3 中新增

帮助重新设计

搜索、导航和布局改进

产品帮助内的搜索结果已扩展为包括所有 Tableau 产品和帮助文章的结果。帮助布局和导航(例如目录位置和浏览路径)已更新,创造出更加一致的跨产品帮助体验。

连接到数据并准备数据

使用多个表存储数据提取数据

您可以将数据提取配置为将其数据存储在多个表中。将数据提取数据存储在多个表中可以潜在地改善性能,并帮助缩小文件大小。有关详细信息,请参见决定应以何种方式存储数据提取数据

新的“其他数据库 (JDBC)”连接器

使用“其他数据库 (JDBC)”连接器可连接到“连接”下未列出的文件或数据库类型,以及所使用的数据库驱动程序实施 JDBC(Java 数据库连接)标准的文件或数据库类型。有关详细信息,请参见其他数据库 (JDBC)

新的受支持空间文件

使用“空间文件”连接器来连接到 TopoJSON 文件、Esri 文件地理数据库和多层 KML(锁眼标记语言)文件。有关详细信息,请参见依据空间文件创建 Tableau 地图

设计视图和分析数据

构建密度地图和图表

在 Tableau Desktop、Tableau Online 或 Tableau Server 中创建和交互

使用密度标记来创建可帮助您标识数据中的“热点”的地图和图表。密度标记使用户能深入了解密集填充的数据,并将其形象地显示为一个平滑表面,该平滑表面可呈现以其他方式显示时会由于重叠标记而被隐藏的模式或相对浓度。有关构建密度地图和图表的详细信息,请参见在 Tableau 中创建显示趋势或密度的热图使用密度标记进行构建(热图)密度标记

使用集动作让受众能够更改集值

在 Tableau Desktop 中创建以便在 Tableau Desktop、 Tableau Server 或 Tableau Online 中交互

让受众能够通过与可视化项中的标记直接交互来选择那些值位于集中。您可以使用集动作来直观地推动计算,并创建包含多方面比较分析(如成比例涂刷)的可视化项。

可以跨多个集使用集动作来实现更复杂的交互。在此示例中,集和计算字段与“Category”(类别)和“Sub-Categories”(子类)的集动作协同工作,根据所选的标记来更新可视化项。当用户单击某个类别时,其子类会显示出来。当用户单击某个子类时,其制造商会显示出来。有关详细信息,请参见集动作

必须在 Tableau Desktop 中创建集动作,才能在 Tableau Online 和 Tableau Server 中使用。

加密的 RServe 连接

从 Tableau Desktop 中通过加密的通道以外部服务形式连接到 RServe。使用 RServe 集成的 SSL/TLS 安全连接传输数据。有关详细信息,请参见使用分析扩展程序传递表达式

更轻松地从仪表板中导航

两项新的仪表板功能可以使导航到其他工作表更为轻松:两者都会保留选定的筛选器和标记,并使您能导航到以单独视图形式发布的工作表(不含可见标签)。

  • 利用按钮对象可以快速地从一个仪表板导航到另一个仪表板,或者导航到其他工作表或故事。若要显示按钮的目标,请添加当用户将指针悬停在对象时出现的自定义图像和信息性工具提示文本。

    有关详细信息,请参见添加仪表板对象并设置其选项

  • “转到工作表”动作”(只能在 Tableau Desktop 中创建)使用户能在单击标记或工具提示菜单项时导航到其他仪表板、工作表或故事。

    有关详细信息,请参见动作和仪表板

仪表板中的透明工作表背景

若要将工作表设为透明,请将其背景颜色设置为“无”。通过将透明工作表与透明筛选器、荧光笔和参数合并,直观地跨整个仪表板集成元素。有关详细信息,请参见将元素与透明度直观地集成

自动重新排列手机布局

在调整手机布局上的仪表板项目时,单击“手机”右侧的弹出式菜单,并选择“重新排列布局”以优化筛选器的位置、移除空白和执行其他操作。

在下面的示例中,筛选器自动移到更高的位置,以便手机用户无需向下滚动便可看到它们。

有关详细信息,请参见针对不同设备类型创建仪表板布局

在 Web 上准备、制作和查看数据

改进的内容浏览

利用 Tableau Online 和 Tableau Server 2018.3,您可以快速预览我们经过重新组织的 Web 制作环境 (UI)。新的 UI 使您能在一个网格或列表中查看多种内容类型(视图、工作簿、数据源、流程、项目)。例如,您现在可以查看特定项目及其子项目内的所有内容。

这种新的体验旨在使内容发现更加直观,并且是一组旨在改进自助服务和 Tableau 内容管理的计划更改中的第一项。

若要试用新的 UI,请要求管理员启用我们已针对其提供的站点级别设置。有关详细信息,请参见 Tableau Server 2018.3 帮助中的预览更新内容浏览体验(Link opens in a new window)(本文也适用于 Tableau Online)。

访问新的 UI 之后,登录到我们的早期反馈(Link opens in a new window)站点。您可以在该站点上与我们分享您的想法并获取我们的定期开发更新内容。

向仪表板中添加图像对象

在 Web 上进行制作时,您现在可以向仪表板中添加图像。新的图像对象让您能调整图像契合度、添加在单击图像时打开的目标 URL,以及添加可为使用屏幕阅读器的用户改善仪表板辅助功能的替代文本。

在 Web 上查看仪表板时,单击“编辑”。从左侧的“对象”部分,将“图像”拖到右侧的仪表板。

有关详细信息,请参见添加仪表板对象并设置其选项

复制为交叉表

若要基于 Tableau Online 或 Tableau Server 中当前工作表的数据创建新的交叉表工作表,请右键单击(在 Mac 上按住 Control 单击)工作表标签,并选择“复制为交叉表”。此操作会向工作簿中插入一个新工作表,并用原始工作表中的数据交叉表视图来填充该工作表。

创建、移动注释并调整其大小

通过右键单击视图(在工作表或仪表板中),然后选择注释类型(点、标记或区域)来创建和删除注释。单击注释将其选定,然后拖动以移动标记,或者单击选择手柄以调整其大小。再次右键单击注释可编辑或移除注释。

版本 2018.2 中新增

安装和部署 Tableau

独立于 Tableau Desktop 安装 Tableau Bridge

Tableau Bridge 现在是独立于 Tableau Desktop 进行安装的独立客户端。有关 Tableau Bridge 要求、与 Tableau Desktop 以前版本的兼容性以及安装过程的详细信息,请参见 Tableau Online 帮助中的安装 Tableau Bridge

注意:如果将 Tableau Bridge 与 Tableau Desktop 安装在同一台计算机上,您可以从“服务器”菜单中启动 Tableau Bridge,就像您在以前版本中所做的一样。

连接到数据并准备数据

联接空间文件

您现在可以联接两个空间文件、空间数据库表(仅限 Microsoft SQL Server)或跨两个数据源的空间字段。有关详细信息,请参见在 Tableau 中联接空间文件

Intuit QuickBooks Online 连接器的增强功能

Intuit QuickBooks Online 连接器有若干更改和增强,可为您提供更多灵活性。“Sales and Expenses Line Items”(销售额和支出行项目)表中加入了新的事务类型:“Vendor Credit”(供应商贷项)、“Credit Memo”(贷项通知单)、“Journal Entry”(日记账分录)、“Deposit”(保证金)、“Estimate”(估算)、“Bill Payment”(账单付款)、“Payment”(付款)、“Purchase Order”(采购订单)和“Refund Receipt”(退款收据)。此外,“Credit Memo”(贷项通知单)和“Vendor Credit”(供应商贷项)中添加了帐户信息。

个别事务表现在有名为“Transaction Type”(事务)的新字段,使您能将其他表联接到“Sales and Expenses Line Items”(销售额和支出行项目)表。

设计视图和分析数据

通过单击执行嵌套排序

您现在可以使用嵌套排序操作,而不必创建计算字段或合并维度。有关详细信息,请参见嵌套排序(Link opens in a new window)

使用仪表板扩展程序扩展功能

借助第三方开发者创建的自定义对象,扩展程序可以增加仪表板功能。利用扩展程序,您可以向仪表板中添加独特的功能,或直接将它们与 Tableau 外部的应用程序集成。

添加扩展程序很容易。在 Tableau Desktop 中或者 Tableau Online 或 Tableau Server 的 Web 制作模式下,只需将“扩展程序”对象拖到仪表板即可。然后,单击“扩展程序库”以从所有可用扩展程序中选择,或者单击“我的扩展程序”以选择您之前下载的扩展程序。(若要直接浏览扩展程序库,请转到 extensiongallery.tableau.com(Link opens in a new window)。)

有关详细信息,请参见使用仪表板扩展程序

将仪表板项目与网格可视对齐

为了呈现视觉效果一致的设计,请在网格上排列仪表板项目和调整其大小。选择“仪表板”>“显示网格”,或通过按 G 键快速打开和关闭网格。

有关详细信息,请参见设置单独仪表板项目的大小、位置并对其进行重新排序和重命名

使用箭头键精确地调整浮动项目的位置和大小

若要精确放置浮动项目,可按箭头键移动 1 个像素,或按 Shift + 箭头键移动 10 个像素。若要调整项目大小,请将 Alt (Windows) 或 Option (macOS) 添加到上面的快捷方式。

在拖动浮动仪表板项目时查看预览

为了让您对移动的项目在新位置中的外观了然于心,在您拖动这些项目时将会出现预览。

将透明的筛选器、参数和荧光笔以浮动方式放在仪表板上

若要直观地将筛选器、参数和荧光笔连接到相关数据,请将现在默认为透明的这些项目浮动放置。文本始终保持完全不透明,从而保持易读性。

有关详细信息,请参见平铺或浮动放置仪表板项目

针对移动设备自动优化仪表板布局

当您创建设备布局时,Tableau Desktop 现在可自动针对设备类型进行优化,调整仪表项目的排列方式,使其最适合于手机或平板电脑。通常,这些自动布局将满足移动用户的所有需求,但您始终能进一步自定义布局。

有关详细信息,请参见针对不同设备类型创建仪表板布局

在对数轴上显示负值

在 Tableau Desktop 和 Web 制作中,当您为轴选择“对数”标度时,您现在可以选择指定 “对称”以在对数标度轴上显示包含 0 或负值的数据。若要了解相关详细信息,请参见将轴标度更改为倒序或对数

在计算字段中使用 ISO 8601 日期标准

创建日期计算时,您现在可以选择使用 ISO 8601 国际标准来解析计算。有关详细信息,请参见日期函数(Link opens in a new window)

在 Web 上准备、制作和查看数据

用于 Web 制作的键盘快捷方式

使用键盘快捷方式在 Web 上快速创建和编辑视图。有关详细信息,请参见用于 Web 制作的快捷方式

创建多连接数据源和跨数据库联接

向数据源中添加另一个连接,并使用跨数据库联接来合并不同数据库中的表。可以保存您的多连接数据源以供组织中的其他人使用。若要了解有关跨数据库联接的详细信息,请参见联接数据(Link opens in a new window)

在 Web 上合并数据

可以创建新的并集,并添加到 Tableau Online 和 Tableau Server 中同一连接中的并集。若要了解详细信息,请参见合并数据(Link opens in a new window)

在 Web 上对数据进行转置

在 Web 上处理基于文件的数据源时,您可以对数据进行转置,从交叉表格式转换为分列格式。有关详细信息,请参见对数据进行转置(从列到行)(Link opens in a new window)

在 Web 上复制数据

通过选择值然后按 Ctrl+C (Windows) 或 (Command+C) (macOS) 来复制数据网格中的值。或者,若要复制元数据网格中的值,请选择这些值,右键单击,并选择“复制”。

架构搜索

使用架构搜索在“数据”窗格中快速查找字段。

注释改进

通过右键单击视图(在工作表或仪表板中),然后选择点或标记注释来创建和删除注释。再次右键单击注释可编辑或移除注释。

轴上的“编辑轴”按钮

现在可通过两种方式打开“编辑轴”对话框。将光标悬停在靠近轴顶部(垂直轴)或右侧(水平轴)的位置,并单击出现的下拉箭头。或者双击轴。

更好地控制排序

您现在可以通过在视图中的“行”或“列”功能区上右键单击维度字段来访问“排序”对话框。

使用 Tableau Online 和 Tableau Server 进行协作

借助 @提及让同事加入数据对话

若要让用户参与到讨论您在视图中找到引人注目的数据的对话中来,请在注释中 @提及他们。在您开始键入名称时,组织中具有 Tableau 帐户的匹配用户将出现在列表中,您可从中进行选择。有关详细信息,请参见向视图添加注释

在自定义视图上快速创建数据通知

如果更改了视图(例如,通过调整筛选器),您现在可以创建通知,而无需先保存自定义视图。有关详细信息,请参见从 Tableau Online 或 Tableau Server 中发送数据驱动型通知

保存并发布数据源和工作簿

检查您的工作簿在旧版本中的外观

在将工作簿导出到旧版本的 Tableau 之前,务必要了解工作簿将受到怎样的影响。“文件”>“导出为”命令现在能让您了然于心,告知您工作簿是否将受到影响,以及哪些功能不受支持。

版本 2018.1 中新增

Tableau 许可

新的基于用户的短期许可证现在可用

Tableau 现在提供了不同类型基于用户的短期许可证,以各种价位授予一系列 Web 制作及其他能力。这样,组织将能更灵活地使用适合的许可证来满足不同用户的数据分析和可视化需求。若要了解详细信息,请参见基于用户的许可证,或者,若要查看每个许可证的能力,请参见 Tableau 定价

安装和部署 Tableau

通过命令行注册 Tableau Desktop

通过命令行安装 Tableau Desktop 时(适用于 Windows),您现在可以在安装过程中注册产品,而不必通过用户界面或单独的命令行操作来完成新用户注册。

添加一个包含安装程序选项 REGISTER=“1” 的命令行。在安装过程中,安装程序将运行 -register 过程,并添加注册信息。此过程使用注册表以下位置中的注册信息:HKEY_CURRENT_USER\Software\Tableau\Registration\Data.

有关向注册表和 -register 属性的属性设置中添加注册信息的信息,请参见部署 Tableau Desktop(Link opens in a new window)中的“注册 Tableau Desktop”和“安装程序属性”。

Mac OS 系统要求

Mac 版 Tableau Desktop 版本 2018.1 需要 Mac OS X 10.11 El Capitan 或更高版本。所有 Tableau Desktop 版本 10.0 至 10.5 均与 Mac OS X 10.10 Yosemite 兼容。

连接到数据并准备数据

支持 SAP NetWeaver Business Warehouse 的远程配置文件

Tableau 现在支持使用位于远程 HTTP 服务器上的横向 XML 文件。

连接到 Microsoft SQL Server 中的空间列

现在,当您在 Tableau 中连接到可以在连接到 Microsoft SQL Server 时,将能使用空间列。您也可以使用自定义 SQL 和 RAWSQL 在 Tableau 中执行高级空间分析。有关详细信息,请参见连接到数据库中的空间数据

新的连接器名称

从 Tableau 2018.1.4 开始,Cisco Information Server 连接器重命名为 TIBCO Data Virtualization

设计视图和分析数据

应用阶梯线和跳跃线

通过在“标记”卡中单击“路径”属性,将“线”标记类型更改为阶梯线或跳跃线。

阶梯线和跳跃线可帮助您查看和比较一段时间内的变化的增量模式。为在一段时间内保持不变并且变化或增量显著的数值数据(例如帐户余额、库存水平或利率)使用这些线类型。有关详细信息,请参见在标记之间绘制路径

分析对象提示

“分析”窗格中,可用的分析对象会因可视化项中数据的当前状态而异。例如,如果视图包含堆叠标记,则无法将趋势线应用于视图。“分析”窗格中的工具提示解释了某个分析对象不可用的原因,或者会提供有关要在视图中使用该对象所需进行操作的提示。

筛选分层数据

当视图中的数据包含分层结构时,这些字段的筛选器可以使用“分层结构中的所有值”选项。您的筛选体验现在将与分层结构中的父/子关系相适应。

有关筛选选项的详细信息,请参见为筛选器卡交互和外观设置选项

隐藏工具提示内部可视化项工作表

您现在可以隐藏用作工具提示内容可视化项的工作表,用相同的方式也可以隐藏故事或仪表板中使用的工作表。在用作工具提示内容可视化项的目标工作表中,单击“隐藏”

若要再次显示工具提示内部可视化项工作表,请在源工作表中单击“取消隐藏所有工作表”。有关工具提示内部可视化项的更多详细信息,请参见在工具提示中创建视图(工具提示内部可视化项)

重新调整保存的群集

群集另存为组,以便您能够在其他工作表和工作簿中使用,但是它们不会自动刷新。在基础数据发生变化时,您现在可以使用“重新调整”选项来刷新和重新计算已保存群集的数据。请参见在数据中查找群集中的重新调整保存的群集,了解相关详细信息。

为不同的数值数据类型同步双轴

在包含双轴的图表中,您现在可以同步不匹配的数值数据类型的双轴。例如,您可以同步一个使用整数数据类型的轴和一个使用小数数据类型的轴。

仅使用箭头在故事中导航

如果喜欢简洁明了的导航样式,请选择新的仅箭头选项。有关详细信息,请参见创建故事

依据生成的及自定义纬度和经度字段创建双轴(分层)地图

您现在可以依据 Tableau 生成的纬度和经度字段与自定义纬度和经度字段的组合来创建双轴地图。有关详细信息,请参见通过生成的纬度和经度字段与自定义纬度和经度字段的组合创建双轴地图

在 Web 上制作和查看数据

在 Web 上连接到数据

利用 Creator 用户许可证,您可以在浏览器中直接连接到数据。上载 Excel 或基于文本的数据源、连接到云数据库中或企业中的服务器上存储的数据,或连接到保存到站点的已发布数据。有关详细信息,请参见 Creator:在 Web 上连接到数据

在 Web 上准备数据

通过“Creator”用户许可证,使用“数据源”选项卡来准备数据进行分析。创建联接、添加新数据源、使用 Data Interpreter 清理数据等。有关详细信息,请参见 Creator:在 Web 上准备数据

在 Web 上调整标题大小

调整行标题的宽度和列标题的高度。

向嵌入视图中添加可访问工具栏

作者可以启用可访问工具栏,以便所有用户都能添加注释、下载视图或将其与其他人共享。有关详细信息,请参见针对辅助功能制作视图中的发布和嵌入视图

其他 Web 制作增强功能

  • “智能显示”现在可用于仪表板。
  • 双击注释可编辑其文本。
  • 隐藏或显示工具提示内部可视化项工作表。在用作工具提示内容可视化项的目标工作表中,单击“隐藏”。若要再次显示工具提示内部可视化项工作表,请在源工作表中单击“取消隐藏所有工作表”
  • 通过使用“分层结构中的所有值”筛选选项来筛选视图中的分层数据。
  • 通过在“标记”卡中单击“路径”属性,将“线”标记类型更改为阶梯线或跳跃线。
  • 双击轴可编辑轴设置。

使用 Tableau Online 和 Tableau Server 进行协作

使用仪表板起始模板快速分析基于云的数据

如果使用 Tableau Online,仪表板起始模板可帮助您快速制作和分析基于云的系统(如 Salesforce、ServiceNow、Marketo 和 Eloqua)中的数据。只需创建一个新工作簿,并选择若干针对关键业务指标量身定制的美观、信息丰富的设计即可。有关详细信息,请参见基于云数据的仪表板起始模板

通过删除注释来简化讨论主题

如果注释不必要或不准确,您可以快速将其删除。只需单击右上角的“X”。有关详细信息,请参见向视图添加注释

版本 10.5 中新增

安装和部署 Tableau

通过命令行激活 Tableau Desktop

通过命令行安装 Tableau Desktop 时,您现在不必通过用户界面完成激活流程即可激活产品,而是可以添加一个包括安装程序选项 ACTIVATE_KEY "<key>" 的命令行。在安装过程中,安装程序将运行 -activate 并应用您提供的产品密钥来自动激活产品。

有关通过命令行安装 Tableau Desktop 的详细信息,请参见部署 Tableau Desktop(Link opens in a new window)

通过命令行关闭驱动程序下载 (Windows)

安装 Tableau Desktop 时,将会为您自动安装大多数常用驱动程序。若要阻止自动安装全部或部分这些驱动程序,您可以在安装期间关闭该选项。

  • 若要阻止自动安装所有驱动程序,请执行以下操作之一:

    • 在安装过程中,从安装程序屏幕中单击“自定义”。然后清除“安装数据库驱动程序: Microsoft SQL Server、 PostreSQL 和 Amazon Redshift”复选框。

    • 从命令行中设置 DATABASEDRIVERS = "0"

  • 若要阻止自动安装一个或多个这些驱动程序,请执行以下操作:

    • 保持选中“安装数据库驱动程序: Microsoft SQL Server、PostreSQL 和 Amazon Redshift”复选框,或从命令行中设置 DATABASEDRIVERS = "1"

    • 添加一个命令行,并将 DRIVER_MSSQLDRIVER_POSTGRESDRIVER_REDSHIFT 设置为“0”以禁用单独的驱动程序。

有关通过命令行安装 Tableau Desktop 的详细信息,请参见部署 Tableau Desktop(Link opens in a new window)

桌面操作系统要求(64 位取代 32 位)

从版本 10.5 开始,Tableau Desktop、Tableau Reader 和 Tableau Public(桌面版)只能在 64 位操作系统上运行。版本 10.4 是 Tableau Desktop、Tableau Reader 和 Tableau Public 支持 32 位 Windows 操作系统的最后一个版本。

连接到数据并准备数据

数据提取使用新的 .hyper 格式

从版本 10.5 开始,当您创建数据提取时,它将使用新的 .hyper 格式。这种新格式的数据提取利用改善的数据引擎,后者支持的分析和查询性能与之前的数据引擎相同,但适用于更大的数据提取。同样,如果使用版本 10.5 对 .tde 数据提取执行数据提取任务,数据提取将升级为 .hyper 数据提取。有关详细信息,请参见数据提取升级为 .hyper 格式

值计算方式的更改

为了提高数据源效率和可扩展性,并生成与商用数据库一致的结果,版本 10.5 中数据源中值的计算方式可能不同。在某些情况下,这些变化可能会导致版本 10.4(及更早版本)与版本 10.5(及更高版本)之间视图中的值和标记出现差异。这适用于数据提取数据源,并且可能适用于多连接数据源、使用文件数据实时连接的数据源、连接到 Google Sheets 数据的数据源、基于云的数据源、纯数据提取数据源以及 WDC 数据源。有关详细信息,请参见视图中值和标记的变化

Google 身份验证方法更新

从 2017 年 10 月开始,对于部分 Tableau 连接器,Google 的更新安全性要求更改了连接工作流。现在,当连接到使用 Oauth 身份验证的数据时,Tableau 会在外部默认浏览的选项卡中打开。受影响的连接器包括 Google SheetsGoogle BigQueryGoogle AnalyticsDropboxOneDriveBox

新的 Box 连接器

使用 Box 连接器可连接到 Box 数据。有关详细信息,请参见Box

对 IBM DB2 和 BigInsights 数据库 SSL 身份验证的支持

您现在可以使用 SSL 身份验证连接到 IBM DB2 和 IBM BigInsights 数据库。有关详细信息,请参见IBM DB2IBM BigInsights

使用数据提取 API

您可以使用 Extract API 2.0 创建 .hyper 数据提取。对于以前使用 Tableau SDK 执行的任务(例如发布数据提取),您可以使用 Tableau Server REST API 或 Tableau Server 客户端 (Python) 库。对于刷新任务,您也可以使用 Tableau Server REST API。有关详细信息,请参见Tableau Hyper API

SAP HANA 的故障转移支持

Tableau 支持连接到配置为进行故障转移的服务器。有关详细信息,请参见SAP HANA

SAP Sybase ASE 的 SSO 支持

您现在可以使用单点登录 (SSO) 连接到 SAP Sybase ASE 数据。有关详细信息,请参见SAP Sybase ASE

OData V4 支持

Tableau 现在支持 Odata 版本 4.0。有关详细信息,请参见OData

Oracle Eloqua 连接器更新

Oracle Eloqua 连接器现在支持增量刷新、对包含超过 250 个字段的表进行验证,并支持更多的表。有关详细信息,请参见Oracle Eloqua

设计视图和分析数据

在工具提示中显示可视化项

当您制作视图并寻找方法向受众展示有关数据的更多详细信息时,您可以在工具提示中嵌入可视化项(即“工具提示内部可视化项”)。

当您在工具提示中显示相关视图时,可以帮助您的受众更深入地了解数据,同时可最大限度地提高当前视图的可用空间。有关详细信息,请参见在工具提示中创建视图(工具提示内部可视化项)

幂次趋势线

向视图中添加趋势线时,现在可以使用“幂次”选项。若要了解相关详细信息,请参见向可视化项中添加趋势线以及趋势线模型类型中的“幂次”模型类型。

地图数据更新和添加

在 Tableau 10.5 中,东南亚、中美洲和南美洲新增了一些城市。

包括 2018 至 2023 年统计预测的人口统计数据现在可用。

美国行政管理和预算局定义的美国核心基础统计区域 (CBSA) 和大都市统计区域

(MSA) 已更新到 2015 年定义。

美国邮政编码现在已有更新。

此外,中国现在已有以下更新:

  • 北京、重庆、上海和天津地区在“二级行政区域/郡县”地理角色中不再包含市级行政区。

  • 中国的“二级行政区域”功能(地级市、地区、盟、自治州)在 Tableau 中被视为市。这些区域的中心点也包括在“城市”地理角色中。

  • 其他城市(例如铁门关市)现在包括在“城市”地理角色中。

  • “一级和二级行政区域名称”功能现在与中华人民共和国国家统计局发布的名称一致。

将仪表板维度扩展到 10,000 像素

为了针对非常大的屏幕或垂直移动设备布局优化设计,您现在可以将仪表板宽度和高度扩展到 10,000 像素。

发布数据源和工作簿

在 Tableau Desktop 中降级工作簿

如果将 Tableau Desktop 中的工作簿升级到较新版本,您现在可以将其降级到以前的版本,以便使用 Tableau Desktop 10.2 及更高版本的用户仍然能够打开该工作簿。若要降级工作簿,请在 Tableau Desktop 中选择“文件”>“导出为”,并选择要降级到的版本。然后将其保存到“我的 Tableau 存储库”或所选位置。

降级的工作簿可在所选版本及更高版本中打开。将工作簿降级时,任何以前版本中不可用的功能将被移除。

有关版本兼容性的详细信息,请参见使工作簿与旧版本兼容

注意:对于其包含的 Tableau 数据提取已在 10.5 中刷新的工作簿,此功能不可用。数据提取已转换为使用新的 .hyper 格式,而此格式无法降级回 .tde 格式。

在 Web 制作中新建

编辑轴

您现在可以在 Web 上编辑轴。若要在 Web 上打开“编辑轴”对话框,请在视图中双击轴。“编辑轴”对话框中可用的选项包括“同步双轴”、清除轴范围(“重置”)以及编辑刻度线。您还可以在字段上下文菜单(在“行”或“列”功能区上右键单击度量字段)中启用或禁用“双轴”。

其他增强功能

  • 向仪表板中添加文本对象并对其进行编辑。

  • 编辑工作表和仪表板标题。双击标题打开“编辑标题”对话框。

  • 编辑趋势线并查看趋势模型的说明。若要查看趋势模型,请将光标悬停在趋势线的任何部分上。若要在 Web 上编辑趋势线,请单击趋势线并将光标保持在原处,然后单击“编辑”菜单。

  • 趋势线现在包括“幂次”选项。

  • 通过将一个维度拖到“数据”窗格中的另一个维度上来创建分层结构。

  • 为字段设置默认颜色属性。

  • 对于定量颜色图例,提供了高级设置(未包括日期)。

使用 Tableau Online 和 Tableau Server 进行协作

为用户配置文件上载自定义图像

默认情况下,用户和组现在具有反映其前两个首字母的配置文件图像。为了帮助您直观地区分配置文件类型,用户图像是圆形的,而组图像是方形的。

用户配置文件支持自定义图像。若要上载图像,请转到您的“帐户设置”页面,并单击您姓名旁边的当前图像或首字母。

如果您的组织使用 Active Directory,则默认配置文件图像来自该系统。但在 Active Directory 下一次与 Tableau server 同步之前,会暂时显示两个字母的图像。

在组中订阅用户,并添加自定义消息

若要快速订阅多个用户,您可以选择 Tableau 管理员创建的整个组。组中的每个用户将会被单独订阅,使收件人列表保持完全可定制。

您还可以向订阅电子邮件中添加自定义消息,阐明其内容。

有关详细信息,请参见创建视图或工作簿订阅

在 Tableau Online 或 Tableau Server 上重命名工作簿

无需只是为了重命名工作簿而将其重新发布。现在,您可以在 Tableau Online 或 Tableau Server 上直接重命名工作簿。重命名时,工作簿 URL 保持不变,因此已共享的任何链接仍然有效。

只需导航到主“工作簿”区域,单击工作簿右上角的弹出菜单,并选择“重命名”

若要重命名工作簿,用户需要“保存”权限。对于您拥有的工作簿,您将默认拥有该权限,但可能需要为其他用户添加该权限。有关详细信息,请参见 Tableau 站点管理员帮助中的设置权限和所有权

版本 10.4 中新增

安装和部署 Tableau

在安装过程中删除以前版本的 Tableau Desktop(仅限 Windows)

从命令行安装最新版本的 Tableau Desktop 或 Tableau Reader 时,现在可以从机器中自动删除这些应用程序的以前安装版本。从版本 10.4 开始,可以将 REMOVEINSTALLEDAPP 安装程序属性设置设定为“1”,并且在安装过程中,安装程序将检测并删除先前安装的 9.3 之后的任何版本。如果计算机已安装了 Tableau Desktop 或 Tableau Reader 9.2 或更早版本,则将不会自动卸载这些版本。您必须改为手动卸载它们。

注意:Tableau Public 不使用此安装程序属性,因为它总是在安装新版本时删除以前的版本。

有关如何使用命令行设置安装程序属性的详细信息,请参见 Tableau Desktop 部署指南中的部署 Tableau Desktop(Link opens in a new window)

降级并将工作簿发布到较早版本的 Tableau Server

在以前的版本中,当 Tableau Desktop 和 Tableau Server 使用不同的应用程序主要版本时,向 TableBook Server 发布工作簿可能会有问题。例如,如果尝试将 Tableau Desktop 10.3 中制作的工作簿发布到运行于 10.2 版本的 Tableau Server,则会收到如下所示的错误。

现在,在 Tableau Desktop 10.4(Windows 和 Mac)中,如果将工作簿发布到较早版本的 Tableau Server(10.2 及更高版本)时,而会收到一条警告消息,此消息告诉您工作簿将降级到您正在发布到的版本。系统会删除工作簿中所包含但旧版本中未提供的任何特性或功能,以保持兼容性。

注意:将工作簿发布到 Tableau Server 10.1 及更早版本时,新的降级选项不可用。

你仍然可以在当前版本的 Tableau Desktop 中打开降级的工作簿,但是可能需要添加回工作簿降级时删除的功能。有关兼容性的详细信息,请参见 Tableau Desktop 部署指南中的 Tableau Desktop 和 Tableau Server 之间的版本兼容性(Link opens in a new window)

连接到数据并准备数据

认证和推荐的数据源

你有没有想过你是否可以信任你的基础数据,或者希望可以避免创建一个全新的数据源?使用其他人之前发布的经过认证的推荐数据源,信心十足地快速制作 Tableau 视图。

Tableau Online 和 Tableau Server 都支持已认证数据源。这些数据源由站点管理员和项目负责人仔细选择,并显示独特的认证徽章。将光标悬停在徽章上,了解谁通过了数据源认证,阅读他们提供的任何描述性说明,并确认连接类型。

下面是当您在 Tableau Desktop 中连接到数据时已认证数据源的外观。

以下介绍如何识别 Tableau Online 或 Tableau Server 中的认证数据源。

Tableau Server 支持已推荐数据源这些数据源包括个人认证的数据源,以及根据组织的使用模式为您自动选择的其他数据源。当您登录到 Tableau Server 时,可以访问 Tableau Desktop 中数据源设置页面右侧的推荐数据源。

连接器子集支持推荐的数据源。有关详细信息,请参见使用已认证和已推荐数据源及表

新的 Denodo 连接器

使用 Denodo 连接器连接到 Denodo 数据。有关详细信息,请参见 Denodo

Mac 上的其他数据库 (ODBC) 连接器

如果您要连接的数据库驱动程序实施 ODBC 标准时,那么现在可以使用 Mac 上的其他数据库 (ODBC) 连接器连接到数据库。有关详细信息,请参见其他数据库 (ODBC)

Oracle 连接器支持 SSL

配置 Oracle 客户端后,您现在可以在本地使用 SSL 连接到 Oracle。有关详细信息,请参见Oracle

SAP GUI 7.4 支持

Tableau 支持新的 SAP UI 横向 XML 格式。有关详细信息,请参见对 SAPUILandscape.xml 的支持

创建没有特殊许可证的 SAP BW 数据提取

从 10.4 开始,您可以创建 SAP BW 数据提取,而不需要特殊的产品密钥。在 10.4 之前,SAP BW 数据提取是不受支持的测试版功能。有关详细信息,请参见对 SAP BW 数据提取的支持

设计视图和分析数据

精确的仪表板间距,带边框和背景颜色控制

如果您以前使用空白对象来完善仪表板布局,则您真的会非常喜欢新的间距控件。利用填充,您可以精确地在仪表板上放置各个项,同时边框和背景颜色可使其非常醒目。

A. 外边距 B. 蓝色边框 C. 带浅蓝色背景的内边距

为了帮助您快速生成有吸引力的布局,默认的外部填充针对不同类型的仪表板项进行了优化。布局容器默认情况下没有外部填充,工作表和对象有四个像素,整个仪表板有八个像素,用于无故障地导出图像和 PDF。

过去,相邻的仪表板项至少被四个像素进行分隔,但现在您可以指定零外部填充来创建无缝设计。

Tableau Desktop 以及 Tableau Server 和 Tableau Online 的 Web 制作工作区中都提供了仪表板间距。有关更多详细信息,请参见在项目周围添加边距、边框和背景色

Windows 对高 DPI 的支持

如果在 Windows 计算机上启用了 DPI 缩放,现在可以自信地制作视图,并且知道它们在 100% 缩放比例下可以像在 200% 缩放比例下一样漂亮。

高 DPI 缩放之前 高 DPI 缩放之后

对线性几何图形的支持

从 Tableau 10.4 开始,您可以连接到包含线性几何图形的空间文件。

若要使用线性几何图形创建地图,请执行以下操作:

  1. 连接到空间数据。

  2. 导航到工作表。

  3. “数据”窗格中,双击“Geometry”(几何图形)字段。

    您可以对大小和颜色进行编码,并向视图添加更多详细级别。

    有关详细信息,请参见依据空间文件创建 Tableau 地图(Link opens in a new window)

地图数据更新和添加

在 Tableau 10.4 中,有 32,000 多个新的美国城市可用。此外,现在支持以下 NUTS 代码:

  • DE401
  • DEB3I
  • DEG0I
  • DK012
  • DK021
  • EL641
  • ES521
  • HU321
  • NL230
  • NL327
  • AT113
  • FR623
  • AT322
  • LI000

MATLAB 集成

您可以使用 SCRIPT_ 函数访问 Tableau 中的 MATLAB® 模型(部署在 MATLAB 生产服务器上),或者使用 MATLAB 预处理数据,并将该数据保存到 Tableau 数据提取中以便进一步分析。

有关详细信息,请参见放置 MATLAB 模型和算法以在 Tableau 中使用(Link opens in a new window)以及使用分析扩展程序传递表达式

嵌入式视图中符合 WCAG 标准的下拉式筛选器

在嵌入式视图中访问时,单值(下拉)和多值(下拉)筛选器现在符合 WCAG 标准。

有关详细信息,请参见针对辅助功能构建数据视图针对辅助功能制作视图

在 Web 制作中新建

在 Web 上打开视图工具栏

在以前的版本中,当在 Web 上制作时,您只能在使用地图视图时查看和使用“视图工具栏”。现在,您可以在 Web 制作过程中为工作簿中的任何视图或仪表板打开视图工具栏。

从顶部菜单中,选择“工作表”>“显示视图工具栏”,并选择选项。

从仪表板中,选择要显示视图工具栏的仪表板区域,然后执行以下操作之一:

  • 从顶部菜单中,选择“工作表”>“显示视图工具栏”

  • 选择下拉箭头,然后从上下文菜单中选择适当的选项。

在 Web 上编辑组

从 Tableau 版本 10.4 开始,您可以编辑组。

若要编辑组,请在“数据”窗格中,右键单击组字段,并选择“编辑组”

在打开的“编辑组”对话框中,可以在现有组中添加或删除成员,以及在组字段中创建新组。您也可以选择“包括其他组”。

在 Web 上创建别名

从 Tableau 版本 10.4 开始,您可以为维度中的成员创建别名,以使其标签在视图中以不同方式显示。

若要为字段创建别名,请执行以下操作:

  1. “数据”窗格中,右键单击一个维度,并选择“别名”

  2. 在“编辑别名”对话框的“值(别名)”下,选择成员并输入新名称。

设置线条格式

当您在 Web 上制作时,您可以快速更改工作簿中的所有行。选择“格式”>“工作簿”,然后展开“设置工作簿格式”中的“线条”部分,并进行选择。有关详细信息,请参见在工作簿级别设置格式

仪表板和故事的 RTF 编辑

您现在可以在 Web 上编辑仪表板标题和区域,以及故事标题和说明。

为此,请双击它们,然后在打开的对话框中更新文本。

有关详细信息,请参见设置标题、说明、工具提示和图例的格式(Link opens in a new window)

分享和协作

Tableau Server 和 Tableau Online 上的增强注释

注释已经完全重新设计,以启动有关数据发现的对话。新的“注释”窗格显示在视图右侧,而不是底部,因此您可以同时查看讨论和数据。个人资料图片也会自动显示,可帮助您快速识别其他用户。若要与他们共享已筛选的视图,请添加交互式快照以及您的注释,以突出显示您要描述的数据。

您在台式机浏览器中添加的任何注释也会出现在 Tableau Mobile 中(反之亦然),因此您可以轻松地在行动中与同事沟通。即使修改包含内容的工作簿(只要视图名称保持不变),视图仍将保留注释。

有关详细信息,请参见向视图添加注释

了解谁在 Tableau Server 和 Tableau Online 上查看了视图

如果您拥有自己的视图,则可以快速找出组织中何人查看了您的视图。在主站点页面顶部,单击“视图”。然后将光标悬停在您感兴趣的具体视图中,从右上角的菜单中选择“谁查看了此视图?”

版本 10.3 中新增

帮助重新设计

合并的帮助系统

从版本 10.3 开始,Tableau Desktop 帮助现在称为 Tableau 帮助。Tableau 帮助包含与在 Tableau Desktop、Tableau Server 和 Tableau Online 中分析和使用数据相关的所有帮助主题。此帮助适用于创建工作簿或数据源并发布它们的人员,以及想要在 Tableau 中查看视图、与视图交互和共享视图的人员。

我们欢迎您提供有关此更改的反馈,以及您可能具有的关于如何使我们的内容更好的任何反馈或想法。请使用任何页面顶部的反馈栏(“此页面是否有帮助?”),以打开注释字段并提交您的反馈。

在 Web 上使用 Tableau提供了曾位于 Tableau Server 和 Tableau Online 帮助中的主题链接。

连接到数据并准备数据

连接到 .pdf 文件

现在,您可以使用 PDF 文件连接器来连接到 .pdf 文件中的表。有关详细信息,请参见 PDF 文件

合并更多数据

您可以合并 .pdf 文件以及 Aster Database、Cloudera Hadoop、Hortonworks Hadoop、IBM DB2、IBM PDA (Netezza)、Pivotal Greenplum Database、SAP Sybase ASE、SAP Sybase IQ 和 Teradata 中的表。有关合并的详细信息,请参见合并数据

推荐的表和联接

当您设置 Tableau 数据源或修改现有数据源时,看看组织中的其他人在表中填充了什么内容会很有帮助。当您(从 Tableau Desktop 中)登录到 Tableau Server 的同时连接到数据库时,左侧窗格中,“推荐”列表将显示在发布到 Tableau Server 的数据源和工作簿中最常用的表。

将推荐的表添加到画布后,经常联接到其中的其他表将显示在“推荐”列表中。双击一个表以自动在表之间创建推荐联接,默认情况下,将使用最常用的字段和联接类型。注意: 如果在数据库中指定了外键,它们将覆盖这些推荐联接。

连接器子集支持推荐的表和联接。有关详细信息,请参见使用已认证和已推荐数据源及表

新连接器

新的 Amazon Athena 连接器

使用 Amazon Athena 连接器连接到 Amazon Athena 数据。有关详细信息,请参见 Amazon Athena

新的 Dropbox 连接器

使用 Dropbox 连接器连接 Dropbox 上的数据。有关详细信息,请参见 Dropbox

新的 MongoDB BI 连接器

使用 MongoDB BI 连接器连接到 MongoDB BI 数据。有关详细信息,请参见 MongoDB BI 连接器

新的 OneDrive 连接器

使用 OneDrive 连接器连接到 OneDrive 上的数据。有关详细信息,请参见 OneDrive

新的 ServiceNow ITSM 连接器

使用 ServiceNow ITSM 连接器连接到 ServiceNow ITSM 数据。有关详细信息,请参见 ServiceNow ITSM

JSON 架构更新

Tableau 会扫描 JSON 文件的前 10,000 行中的数据,并从该过程中推断架构。有时,行中存在没有为创建推断架构而扫描的更多字段。现在,Tableau 会指明检测到您可能希望包含在分析中的其他字段的时间。有关详细信息,请参见JSON 文件

设计视图和分析数据

双击缩放

在以前的版本中,当您双击为 X 和 Y 轴都使用连续度量的视图(也称为定量/定量视图,例如散点图),并且视图工具栏已关闭时,Tableau 将会自动放大。

这会产生令人困惑的用户体验。现在,对于这些定量/定量非地图视图类型,当您双击视图时,默认情况下 Tableau 不再放大。此更改适用于新工作簿和升级的工作簿。对于表和交叉表图表类型,双击缩放功能默认情况下也处于关闭状态。

工具提示选择

此功能使您能按类别从工具提示中选择视图中类似的标记。工具提示中包括的任何离散维度或度量将变为活动链接,您可以单击链接来选择视图中具有相同值的其他标记。

下面的示例演示如何通过单击工具提示中的“Machines”(机器)来选择视图中具有相同子类(本例中为“Machines”)的所有标记。

此功能可在 Tableau Desktop、Tableau Server 和 Tableau Mobile 上工作。对于新工作表,该功能默认情况下已启用,而对于升级的工作表则默认禁用。若要禁用或启用该功能,请在工作表级别单击标记卡上的“工具提示”,打开“编辑工具提示”对话框,然后清除或选中“允许按类别选择”复选框。

有关详细信息,请参见在工具提示中按类别突出显示数据

离散日期筛选器的最新日期预设

可以设置离散日期筛选器以筛选到数据源中的最新日期值。可以使用此设置确保数据源中的最近日期在筛选器中处于选定状态。有关详细信息,请参见“筛选离散日期” 的最新日期预设,位于“筛选视图中的数据中“筛选日期”(桌面)下面。

在 Tableau Server 和 Tableau Online 上,视图在浏览器中第一次加载时将应用预设值,但在刷新浏览器或数据时不会应用预设值。

将表计算筛选器应用于总计

当您显示总计,并且想要将一个表计算筛选器应用于总计时,现在可以在该筛选器的下拉菜单中选择“应用于总计”(在“过滤器”功能区上)。此选项使您能定义何时应将表计算筛选器应用于合计。有关详细信息,请参见 AirWatch 帮助中的“筛选器表计算”(筛选视图中的数据中)。

地图数据更新和添加

针对 Tableau 版本 10.3 更新了以下数据:

  • 对 2016 年最终命名方案更新了法国地区名称。

  • NUTS(地域统计单位命名法)代码和机场代码不再需要国家/地区作为父项即可在地图上进行地理编码。

  • 荷兰陆地和省份已更新。

  • 使用 2016 年的数据更新了澳大利亚 LGA。

此外,卢旺达地区(uturere)现在受 Tableau 支持,并且可以使用“县”地理角色进行地理编码。还添加了新西兰邮政编码的多边形。有关 Tableau 支持的其他地图数据的更多信息,请参见Tableau 支持用于构建地图视图的位置数据(Link opens in a new window)

均匀分布布局容器项

将布局容器添加到仪表板后,您可以(在桌面上和在 Web 制作中)使用“均匀分布”命令使其包含的项均匀间隔。有关详细信息,请参见设置仪表板大小和布局

轻松访问故事动作

当您将鼠标悬停在故事导航区域上时,会出现新的故事工具栏。使用它来恢复故事更改、对故事点应用更新、删除故事点,或者利用当前定制故事点创建一个新故事点。

使用数字进行故事导航

故事“布局”选项卡包含一个新的导航选项:“数字”。使用此选项可使故事导航器显示一系列数字,而不是说明框或点。有关详细信息,请参见创建故事

Web 制作的新增功能

从版本 10.3 开始,Tableau Server 和 Tableau Online 的 Web 制作主题现在位于 Tableau 帮助中。若要查看以前版本中的 Web 制作功能,请参见 Tableau Server 新增功能

编辑定量颜色图例

您现在可以在 Web 制作中编辑连续颜色图例的调色板。您可以从“标记”卡中或通过单击图例上的下拉箭头打开“编辑颜色”对话框。

“标记”卡: 图例:

您还可以通过输入十六进制值为起始和结束颜色设置自定义颜色。

在分离的图例上编辑颜色

当您为视图中的度量创建单独的颜色图例时,您不再仅限于从 Tableau Desktop 中发布视图后只能使用默认调色板或分配给每个颜色图例的调色板。

在 Web 制作模式下,您可以为每个图例选择不同的调色板。单击图例上的下拉箭头以打开“编辑颜色”对话框,然后选择调色板。您还可以使用十六进制值设置自定义的开始和结束颜色。

自定义用户与您的地图交互的方式

在 Web 制作模式下,您现在可以使用“地图选项”对话框,通过以下方式来自定义受众与地图视图的交互方式。

  • 显示地图标度
  • 隐藏地图搜索
  • 隐藏视图工具栏
  • 关闭平移和缩放

有关详细信息,请参见自定义用户与地图的交互方式(Link opens in a new window)

在 Web 上设置数字格式

现在,您可以在 Tableau Server 和 Tableau Online 上指定视图中度量的基本数字格式。有关详细信息,请参见在 Tableau Server 或 Tableau Online 上设置数字和 Null 值的格式(Link opens in a new window)

创建故事

在 Web 制作模式下,您现在可以创建故事以讲述数据,提供上下文,演示决策与结果的关系,或者只是创建一个极具吸引力的案例。有关详细信息,请参见创建故事

创建和编辑数据桶

在 Tableau Server 和 Tableau Online 中依据连续度量创建数据桶并编辑它们,这类似于您在 Tableau Desktop 中的操作方法。有关详细信息,请参见依据连续度量创建数据桶

在视图中将字段拖到“智能显示”

选择感兴趣的维度和度量并将其拖到视图区域。“智能显示”视图会自动创建。然后,您可以单击其他“智能显示”选项来尝试不同的视图类型。

在视图中向上和向下钻取连续的层次结构

在具有连续层次结构的视图中,将鼠标悬停在连续轴上的标题附近以显示 + 和 - 控件。单击以向下或向上钻取。

保存数据源

现在,您可以选择将已发布工作簿中嵌入的数据源另存为 Tableau Server 和 Tableau Online 上其他用户可以连接到的已发布的单独数据源。保存数据源时,可以选择更新工作簿以连接到新保存的数据源。

 

分享和协作

Tableau Online 和 Tableau Server 中数据驱动的通知

当数据达到您的重要业务阈值时,数据驱动型通知会自动向您指定的关键人员发送电子邮件通知。除甘特图和地图之外,您可以对所有图表类型设置通知。

首先,选择图表的连续数字轴:

然后单击工具栏中的“通知”:

出现“创建通知”弹出窗口时,设置触发通知电子邮件的数据条件和阈值。在视图中,红线显示了阈值相对于当前数据的所在位置。只需指定电子邮件主题行、计划和收件人,即可开始提醒您的组织注意关键指标。

若要管理您拥有或接收的通知,请单击 Tableau Online 或 Tableau Server 页面右上角的名称,单击“我的内容”,然后单击“通知”

有关更多详细信息,请参见从 Tableau Online 或 Tableau Server 中发送数据驱动型通知

版本 10.2 中新增

安装和部署 Tableau

连接到数据并准备数据

设计视图和分析数据

发布数据源和工作簿

在 Mac 上安装 Tableau Desktop 向导

新的可自定义的安装向导将指导您完成安装过程。默认情况下,它会安装最常用的数据库驱动程序(Amazon Redshift、MySQL、Oracle、PostgreSQL、Simba Spark 和 Simba SQL),并创建桌面快捷方式。

有关安装 Tableau Desktop 的详细信息,请参见 Tableau Desktop 部署指南(Link opens in a new window)

检查产品维护更新

您现在可以随时检查这些更新,而不必等待产品维护更新可供下载的通知,或者在关闭提示之后却又希望自己没有关闭。只需从 Tableau Desktop 的“帮助”菜单中选择“检查产品更新”,Tableau 将会检查以确定是否有更新的维护发布版本可用。将显示以下选项之一:

  • 如果有新的更新,则会显示一个对话框,使您能够下载并安装最新更新。

  • 如果没有新的更新,则会显示一条消息,指明未找到新的更新。

  • 如果更新已在进行,则会显示一条消息,指明正在进行更新。

适用于自动更新过程的 3 天等待期同样也适用于此功能。如果为 Tableau 关闭了自动更新,则此选项不可用。有关如何为产品管理自动更新的详细信息,请参见 Tableau Desktop 部署指南中的控制产品更新(Link opens in a new window)

自动保存工作簿

Tableau Desktop 现在每隔几分钟即会为您自动保存工作,不再会出现因为 Tableau 意外关闭而丢失数小时工作的情况。

新的自动保存功能默认情况下已启用。如果 Tableau 崩溃,系统将自动创建工作簿的可恢复版本,其扩展名为 .twbr,保存在原始文件所在的相同位置,或保存在 My Tableau Repository/Workbooks 文件夹中。新工作簿在保存时将命名为“Book1”加一个数字 ID。重新打开 Tableau 时,恢复对话框将显示一个已恢复文件的列表,您可以选择并打开这些文件以继续执行流程。您也可以从同一个对话框中删除不需要的文件。

用户可通过 Tableau Desktop 中的“帮助”菜单打开或关闭此功能。管理员也可以通过从命令行中更改 AUTOSAVE 安装程序属性设置来关闭此功能。如果管理员关闭此功能,则无法从“帮助”菜单中使用“自动保存”选项。

有关如何使用命令行打开或关闭自动保存功能的详细信息,请参见 Tableau Desktop 部署指南中的部署 Tableau Desktop(Link opens in a new window)

对跨数据库联接的 Salesforce 支持

Salesforce 支持使用跨数据库联接来合并表。有关详细信息,请参见联接数据中的“合并不同数据库中的表”部分。

合并更多数据

您可以合并 Amazon Redshift、Google BigQuery、HP Vertica、Microsoft SQL、MySQL、Oracle 和 PostgreSQL 数据库中的表。您还可以合并 JSON 文件。有关合并的详细信息,请参见合并数据

可扩展的标记卡

如果您曾经处理过需要在标记卡上有大量字段的视图,但因为不滚动就无法看到所有字段而感到沮丧,标记卡现在得到了增强,可以解决此问题。标记卡现在会自动扩展来填充所有可用空白空间。

按度量显示图例

如果在视图中包括“度量值”“度量名称”字段,您现在可以按度量对数据进行颜色编码,从而使您能够进一步区分数据的各个部分。

在以前的版本中,当您使用这些字段并将“度量值”添加到“标记”卡上的“颜色”时,Tableau 将创建应用于视图中所有标记的单一颜色图例。现在,当您将“度量值”拖到“标记”卡上的“颜色”时,您可以选择为视图中的每个度量创建单独颜色图例的选项,然后为每个度量选择唯一的调色板。

还可通过选择合并图例的选项来轻松地合并独立颜色图例。当您在合并图例和单独图例之间切换时,Tableau 甚至能记住您的调色板。

单一合并图例

下面的示例演示当您将“度量值”拖到“标记”卡上的“颜色”时的默认行为。Tableau 将创建适用于视图中所有标记的单一颜色图例。

在“标记”卡上,单击“度量值”字段上的下拉箭头,然后从上下文菜单中选择“使用单独图例”,为每个度量创建一个图例。Tableau 将为每个图例分配默认调色板,但您可以根据需要对其进行编辑,如下面的示例中所示。

多个图例

若要将单独图例重新合并为适用于所有度量的单一图例,请在“标记”卡上单击“度量值”字段上的下拉箭头,并从上下文菜单中选择“合并图例”

改善的日期识别

如果您的日期值被解读为字符串或整数,请将字段的数据类型更改为“日期”“日期和时间”,而不是创建计算来更改其类型。有关详细信息,请参见将字段转换为日期字段

连接到空间文件

您现在可以连接到 Shapefile、MapInfo 表、KML(锁眼标记语言)文件,以及 Tableau Desktop 中的 GeoJSON 文件。有关详细信息,请参见依据空间文件创建 Tableau 地图(Link opens in a new window)主题,以及空间文件(Link opens in a new window)示例连接器主题。

连接到更多 Presto 数据

除了从 Teradata 中连接到 Presto 141t 之外,对于 Presto 版本 0.148,Tableau 现在可以连接到 Presto 本地和 Amazon EMR Presto 实例。有关 Presto 连接器的详细信息,请参见Presto

新 SharePoint 列表连接器

使用 SharePoint 列表连接器连接到 SharePoint 列表。有关详细信息,请参见Sharepoint 列表

新 Apache Drill 连接器

使用 Apache Drill 连接器连接到 Apache Drill 数据。有关详细信息,请参见Apache Drill

在 Mac 上连接到 Aster Database

您可以在 Mac 上连接到 Aster Database。您可以从 Tableau 网站上的驱动程序下载(Link opens in a new window)页下载 Mac 的驱动程序。

在地图上显示标度

您现在可以在地图上显示标度,使受众能够了解您的数据点之间的距离。有关详细信息,请参见显示地图标度(Link opens in a new window)

地理编码地域统计单位命名法 (NUTS) 代码

您现在可以使用“NUTS 欧洲”地理角色对 Tableau 中的 NUTS 1 - 3 级代码进行地理编码。

为字段分配“NUTS 欧洲”地理角色:

  • 在“数据”窗格中,单击字段旁边的数据类型图标,选择“地理角色”,然后从列表中选择“NUTS 欧洲”

有关详细信息,请参见 Tableau 中的地理角色类型(Link opens in a new window)

地图数据更新和添加

印度地区和邮政编码、新西兰邮政编码、澳大利亚 LGA 以及沙特阿拉伯城市数据已更新。

此外,Tableau 现在可自动识别以下城市和国家/地区的二级行政区域,并可使用“郡县”地理角色对其进行地理编码。有关详细信息,请参见Tableau 支持用于构建地图视图的位置数据(Link opens in a new window)

  • 柏林
  • 布基纳法索
  • 埃塞俄比亚
  • 几内亚
  • 几内亚比绍
  • 印度尼西亚
  • 科特迪瓦
  • 马来西亚
  • 马里
  • 缅甸
  • 尼日利亚
  • 挪威
  • 菲律宾
  • 塞内加尔
  • 塞拉利昂
  • 冈比亚
  • 多哥
  • 赞比亚

使用计算自定义联接以解决字段之间的格式不匹配

联接中所使用字段之间的格式不匹配通常可能会导致联接中断,或使您无法首先创建联接。在许多情况下,可通过使用计算自定义联接的方式来解决字段之间的格式不匹配。有关详细信息,请参见联接数据

使用 Tableau Online 快速共享内容

若要与其他人快速共享内容,请注册 Tableau Online 的免费试用版:单击“工具栏”中的“共享”按钮,然后单击“创建站点”。(如果您已经登录到 Tableau Online 或 Tableau Server,单击“共享”按钮时将显示标准发布选项。)

将数据导出为 CSV

将您在 Tableau 中合并和准备的所有数据导出为 CSV 文件,而无需首先创建或使用基准文件。有关详细信息,请参见从 Tableau Desktop 导出数据

新的关联函数和协方差函数

提供了三个新的聚合函数:

  • CORR:返回两个表达式的皮尔森相关系数。

  • COVAR:返回两个表达式的样本协方差。

  • COVARP:返回两个表达式的总体协方差。

有关详细信息,请参见Tableau 函数(按字母顺序)(Link opens in a new window)

此外,还提供了三个相关的表计算函数:

  • WINDOW_CORR:返回定义窗口内两个表达式的皮尔森相关系数。

  • WINDOW_COVAR:返回定义窗口内两个表达式的样本协方差。

  • WINDOW_COVARP:返回定义窗口内两个表达式的总体协方差。

有关详细信息,请参见表计算函数

Mac 上的 TLS 相互身份验证

Tableau Desktop for Mac 现在支持 Tableau Server 的 TLS 双向身份验证。如果您的组织使用客户端证书进行计算机或用户身份验证,并且在 Tableau Server 上启用了相互身份验证,则您可以像使用支持 TLS 双向身份验证的任何其他应用程序一样进行身份验证。Windows 上的 Tableau Desktop 也支持 TLS 双向身份验证。

使用数字进行故事点导航

现在,您可以指定数字作为受众逐步浏览您的故事的方式。如果您有大量的个别故事点并且希望避免使用导航器上的滚动条,这可能很有用。

有关故事布局和格式设置的详细信息,请参见创建故事

在整个工作簿中设置行的格式

您可以通过单击“格式”>“工作簿”在一个位置快速更改工作簿中每个视图的行格式。如果对工作簿的行设置进行更改,则“设置工作簿格式”窗格中该设置的旁边将出现一个灰色的点。

有关详细信息,请参见在工作簿级别设置格式

在 Web 上支持符合 WCAG 标准的视图

您在 Tableau Desktop 中创作、发布到 Tableau Server 或 Tableau Online 并嵌入在符合 WCAG 标准的网页中的嵌入式视图现在符合 WCAG 2.0 AA 一致性规范和第 508 节的标准。

WCAG 一致性规范还不支持在 Tableau Desktop、Tableau Reader 或 Tableau Public 中向用户提供的视图。WCAG 一致性规范还不支持通过 Tableau Server 或 Tableau Online 在 Web 上创建或编辑的视图。

嵌入视图的以下部分符合 WCAG 标准:

  • 工作表标签

  • 工作表的视图区域

  • 标题和说明

  • 分类图例

  • 单个值(列表)筛选器(即单选按钮)和多个值(列表)筛选器(即复选框)。

  • “查看数据”窗口

嵌入视图中 Tableau 界面的某些方面尚未得到支持,例如其他筛选器类型、参数和视图工具栏。在可视化项中使用这些控件可能会让使用辅助技术的用户很难完全理解您的视图。

还支持为嵌入视图使用键盘导航、辅助技术的编程上下文(使用 ARIA 角色)、非文本元素的替代文本和对比度标准,以及登录 Tableau Server 或 Tableau Online 时的身份验证。

有关创建可访问视图的详细信息,请参见设计无障碍视图的最佳做法针对辅助功能制作视图

支持 SAP BW 单点登录

您可以配置从 Tableau 到 SAP NetWeaver Business Warehouse(SAP BW)的单点登录 (SSO) 支持。有关详细信息,请参见 Tableau Server 帮助中的为 SAP BW 启用单点登录(Link opens in a new window)

感谢您的反馈! 提交反馈时出错。请重试,或向我们发送消息