Excel

本文介绍如何将 Tableau 连接到 Microsoft Excel 文件数据并设置数据源。Tableau 可连接到 .xls 和 .xlsx 文件。

若要连接到 .csv 文件,请使用文本文件连接器。

进行连接并设置数据源

  1. 打开 Tableau 后,在“连接”下面单击“Excel”

  2. 选择要连接到的 Excel 工作簿,然后单击“打开”

    或者,在 Windows 上的 Tableau Desktop 中,要使用基于 Microsoft Jet 的连接来连接到 Excel 文件,请在“打开”对话框中,单击“打开”下拉菜单,然后选择“使用旧版连接打开”。此时会显示“数据源”页面。

    重要信息:从 Tableau 2019.1 开始,您不再能够创建新的旧版 Excel 或文本连接。使用这些旧版连接创建的现有工作簿在 2019.4 之前将继续工作,届时会计划移除对旧版连接的所有支持。请参见 Tableau 社区中的旧版连接替代方案文档,了解使用旧版连接的替代方案。

  3. 在“数据源”页面上,执行以下操作:

    1. (可选)在页面顶部选择默认数据源名称,然后输入要在 Tableau 中使用的唯一数据源名称。例如,使用可帮助其他数据源用户推断出要连接的数据源的数据源命名约定。

    2. 如果 Excel 文件具有一个表,请单击工作表标签开始进行分析。

      使用自定义 SQL 连接到特定查询,而非整个数据源。有关详细信息,请参见连接到自定义 SQL 查询

      您也可以按照连接到工作表的方式连接到命名范围或 Excel 表(也称为 Excel 列表)。命名范围和 Excel 表都充当 Tableau 中的表。

      通过选择一个单元格范围,然后在“公式”选项卡上选择“定义名称”,可在 Excel 中创建命名范围。与创建命名范围相类似,通过选择一个单元格范围,然后选择“插入”>“表”,可在 Excel 中创建 Excel 表。连接到 Tableau 中的命名范围或 Excel 表时,“数据源”页面中的工作表旁边将出现一个图标,如下所示。

      您可以同时连接到多个 Excel 工作簿,只有数据源中的每个链接具有唯一名称。

    注意: Tableau 不支持 Excel 中的数据透视表。

Microsoft Excel 数据源示例

下面显示了 Microsoft Excel 数据源示例。

注意: 如果 Excel 文件中包含宽度超过 254 个字符的列,Tableau Desktop 将无法为在 Tableau Desktop 8.2 之前创建的工作簿使用这些字段。并且,您无法使用旧版连接来连接到此数据。在 Tableau Desktop 中建立连接之前,请先移除这些列,修改这些列以使其宽度在 254 个字符以内,或升级 Excel 数据源。有关升级数据源的详细信息,请参见升级数据源

获取更多数据

通过添加更多表或连接到不同数据库中的数据,将更多数据提供到数据源中。

  • 从当前文件添加更多数据:从左窗格中,将其他表拖到画布上,以使用联接或并集合并数据。有关详细信息,请参见联接数据合并数据

  • 从不同数据库添加更多数据:在左窗格中,单击“连接”旁边的“添加”。有关详细信息,请参见联接数据

    如果左窗格中未列出您需要的连接器,请选择“数据”>“新数据源”以添加新数据源。有关详细信息,请参见混合您的数据

设置 Excel 表选项

Excel 表选项的范围局限于连接。若要更改表选项,请在画布上单击表下拉箭头,然后指定数据在第一行中是否包括字段名称。如果是这样,这些名称将成为 Tableau 中的字段名称。如果未包括字段名称,Tableau 会自动生成这些名称。您随后可以对字段进行重命名。

使用 Data Interpreter 清理您的数据

如果 Tableau 检测到它可以帮助优化数据源以进行分析,则会提示您使用数据解释器。数据解释器能够检测您可以使用的子表,并且能够删除以后可能会在分析中引起问题的唯一格式。有关详细信息,请参见使用 Data Interpreter 清理 Excel、CSV、PDF 和 Google Sheets 中的数据

关于 .ttde 和 .hhyper 文件

在计算机的目录中导航时,您可能会注意到 .ttde 或 .hhyper 文件。当您创建连接到数据的 Tableau 数据源时,Tableau 会创建 .ttde 或 .hhyper 文件。此文件(也称为阴影数据提取)用于帮助提高 Tableau Desktop 中的数据源加载速度。尽管阴影数据提取包含类似于标准 Tableau 数据提取的基础数据和其他信息,但阴影数据提取将以其他格式保存,并且无法用于恢复数据。

在某些情况下,您可能需要从计算机中删除阴影数据提取。有关详细信息,请参见 Tableau 知识库中的由于 TTDE 文件的缘故导致磁盘空间不足

值计算方式的更改

从版本 10.5 开始,当您使用数据提取数据源以及使用文件数据(如 Excel)实时连接的数据源时,数据中值的计算方式可能与以前版本的 Tableau 不同。此更改意味着,版本 10.4(及更早版本)和版本 10.5(及更高版本)之间视图中的数据和标记可能会存在差异。此更改的目的是为了改善 Excel 数据源的效率和可扩展性。有关详细信息,请参见视图中值和标记的变化

对于 Excel 数据源,此更改的一个示例与区分大小写有关。在版本 10.4(及更早版本)中,在进行比较和排序时,字符串值被视为不区分大小写,因此处理方式相同,并存储为单一字符串值。在版本 10.5(及更高版本)中,对于排序和比较目的,值会保留为不区分大小写。但是,值在用于存储时区分大小写。当值显示在数据源页面上时,这一点变得很明显。

例如,假设您的数据中有一个列包含值“House”、“HOUSE”和“houSe”。视您使用的 Tableau 版本而定,您会看到以下字符串值:

  • 在版本 10.4 及更低版本中,您在数据源页面和视图上都会看到:“House”、“House”和“House”。

  • 在版本 10.5 及更高版本中,您在数据源页面上会看到:“House”、“HOUSE”和“houSe”。但在视图中您将看到:“House”、“House”和“House”。

如果在执行联接时需要保持数据的大小写,则可以从“数据”菜单中启用“保持字符大小写(Excel)”选项。有关此选项的详细信息,请参见关于使用多连接数据源

另请参见

感谢您的反馈! 提交反馈时出错。请重试,或向我们发送消息