.hyper 形式への抽出のアップグレード

新しい .hyper 抽出の形式

バージョン 10.5 以降、新しい抽出を作成すると、.tde 形式ではなく .hyper 形式が使用されます。.hyper 形式の抽出は、以前のデータ エンジンと同じ高速分析とクエリ パフォーマンスをサポートしますが、より大きいサイズの抽出に対応する改善されたデータ エンジンを使用します。

.hyper 抽出の使用には多くのメリットがありますが、主なメリットは次のとおりです。

  • より大きいサイズの抽出の作成: 数十億行のデータを含む抽出を作成できます。.hyper 抽出はより多くのデータをサポートできるため、以前は個別に作成する必要があった .tde 抽出を単一の .hyper 抽出に統合できます。

  • より高速な抽出の作成と更新: Tableau は常に抽出の作成と更新のパフォーマンスを最適化していますが、バージョン 2019.3 は大きいサイズのデータ セットの場合でもより高速な抽出の作成と更新をサポートしています。

  • 抽出データ ソースを使用しているビューの操作時により高いパフォーマンスを体感: 小さいサイズの抽出は引き続き効率的に実行され、大きいサイズの抽出はさらに効率的に実行されます。

何が抽出のアップグレードを引き起こすか

引き続きバージョン 2019.3 で .tde 抽出を開いたり使用したりすることはできますが、.tde 抽出で抽出タスクを実行すると、.tde 抽出が .hyper 抽出にアップグレードされます。抽出のアップグレード後は、以下の下位制限に注意する必要があります。

  • アップグレードされた抽出は .tde 抽出に変換し直すことはできない。

  • アップグレードされた抽出を以前のバージョンの Tableau Desktop で開くことはできない。これは、.tde 抽出を操作する方法に影響する場合があります。

  • Tableau Desktop で [バージョン名を付けてエクスポート] を使用して .hyper 抽出が含まれたワークブックをダウングレードすることはできない。

  • 抽出を古いバージョンのものとして Tableau Desktop から Tableau Server へパブリッシュすることはできない。

  • [Tableau ワークブックのダウンロード] オプションを使用して Tableau Server または Tableau Online からダウンロードされたワークブックは、.hyper 抽出が含まれている場合、Tableau Desktop 10.4 以前で開くことができません。

抽出のアップグレードを引き起こすタスク

.tde 抽出の .hyper 抽出へのアップグレードは、1.) 抽出の更新 (完全または増分)、2.) 抽出へのデータの追加、3.) 手動による抽出のアップグレード、これら 3 つのタイミングで行われます。Tableau Desktop を使用して抽出がアップグレードされると、.tde 抽出が他のワークブックから参照されている場合、抽出は自動的に削除されません。

抽出のアップグレードを行うタスクの他に、Tableau Desktop の外部で実行される抽出タスクを使用したときに .tde 抽出へのアップグレードが引き起こされることがあります。これには次のタスクが含まれます。

  • 手動更新 (Tableau Server および Tableau Online)

  • Tableau Bridge からパブリッシュされた抽出データ ソースの増分更新 (Tableau Online)

  • スケジュールされた抽出データソースの完全更新または増分更新 (Tableau Server および Tableau Online)

  • Tableau Bridge からのスケジュールされた増分抽出の更新 (Tableau Online)

抽出のアップブレードによる影響

Tableau Desktop のバージョン番号が、他のユーザーが使用している Tableau Desktop バージョンと一致しない、または Tableau Server バージョンや Tableau Online のバージョンと一致しない環境で作業している場合は、実行するタスクによっては、抽出の互換性の問題が発生することがあります。

Tableau サポート ページの「抽出の互換性シナリオ」の詳しい説明や以下の概要を確認し、抽出のアップグレードが行われるタイミングやユーザーが経験する可能性のある互換性の問題について十分に理解してください。

注: 次の表では、「10.4」は Tableau 10.4 以前を表し、「10.5」は Tableau 10.5 以降を表します。

Tableau Desktop を使用するタスク

異なるバージョンの Tableau Desktop で実行されるタスクについて、次のような抽出関連の互換性シナリオに注意する必要があります。

 

タスク

10.4 ワークブック 10.5 ワークブック
.tde 抽出 .tde 抽出 .hyper 抽出
新規作成 10.4 で 不可 不可
10.5 で 不可 不可
開く 10.4 で ワークブックを開けない。10.5 以降でワークブックを開くよう求められる ワークブックを開けない。10.5 以降でワークブックを開くよう求められる
10.5 で
更新または追加 10.4 で 不可 不可
10.5 で ワークブック バージョンは変わらないが、抽出は .hyper 形式にアップグレードされる ワークブック バージョンは変わらないが、抽出は .hyper 形式にアップグレードされる
ワークブックのパブリッシュ 10.5 から Tableau Server 10.4 へ パブリッシュできない。[パブリッシュ] ダイアログに "server is running an older version than your copy of Tableau Desktop (サーバーで Tableau Desktop のコピーより古いバージョンを実行しています)" というメッセージの後に "workbook cannot be downgraded (ワークブックをダウングレードできません)" というエラー メッセージが表示される パブリッシュできない。[パブリッシュ] ダイアログに "server is running an older version than your copy of Tableau Desktop (サーバーで Tableau Desktop のコピーより古いバージョンを実行しています)" というメッセージの後に "workbook cannot be downgraded (ワークブックをダウングレードできません)" というエラー メッセージが表示される
10.5 から Tableau Server 10.5 または Tableau Online へ
  10.4 から Tableau Server 10.5 または Tableau Online へ    
抽出データ ソースのパブリッシュ 10.5 から Tableau Server 10.4 へ パブリッシュできない。"cannot publish, make sure you are connected to a compatible version (パブリッシュすることができません。互換性のあるサーバー バージョンに接続していることを確認してください)" というエラー メッセージが表示される パブリッシュできない。"cannot publish, make sure you are connected to a compatible version (パブリッシュすることができません。互換性のあるサーバー バージョンに接続していることを確認してください)" というエラー メッセージが表示される
10.5 から Tableau Server 10.5 または Tableau Online へ
パブリッシュされたデータ ソースへの接続 10.4 から Tableau Server 10.5 または Tableau Online へ
10.5 から Tableau Server 10.5 または Tableau Online へ

Tableau Server 10.5 または Tableau Online でのタスク

以前のバージョンの Tableau Desktop で作成された抽出を使用する場合、Tableau Server 2019.3 または Tableau Online で実行されるタスクについて、次のような抽出関連の互換性シナリオに注意する必要があります。

 

シナリオ

10.4 ワークブック 10.5 ワークブック
.tde 抽出 .tde 抽出 .hyper 抽出
Web 作成における編集/保存 Tableau Server 10.4 で 不可 不可
Tableau Server 10.5 または Tableau Online で ワークブックがバージョン 10.5 に変わり、抽出は .tde 形式のまま
Web 作成における編集/保存後、更新または追加 Tableau Server 10.4 で
Tableau Server 10.5 または Tableau Online で ワークブックがバージョン 10.5 に変わり、抽出は .hyper 形式にアップグレードされる ワークブック バージョンは変わらないが、抽出は .hyper 形式にアップグレードされる
ダウンロードして開く Tableau Desktop 10.4 で ワークブックを開けない。"this workbook uses a .hyper extract and is not compatible with this version; open the workbook in version 10.5 or later (このワークブックは .hyper 抽出を使用しているため、このバージョンと互換性がありません。このワークブックはバージョン 10.5 以降で開いてください)" というエラー メッセージが表示されて、抽出を見つけるよう求められる ワークブックを開けない。"this file was created by a newer version; upgrade Tableau (このファイルは新しいバージョンで作成されています。Tableau をアップグレードしてください)" というエラー メッセージが表示される
Tableau Desktop 10.5 で
バージョン名を付けてエクスポート Tableau Desktop 10.5 から オプションがグレー表示になる オプションがグレー表示になる

抽出の作成、更新、追加タスクの自動化

以前のバージョンの Tableau で作成された抽出を使用する場合、抽出の作成、更新、追加タスクを自動化する際に、次のような抽出関連の互換性シナリオに注意する必要があります。

 

シナリオ

.tde 抽出 .hyper 抽出
新しい抽出の作成 Tableau SDK を使用 不可
Extract API 2.0 を使用 不可
更新または追加 10.4 Tableau コマンドライン ユーティリティを使用 不可
10.5 Tableau コマンドライン ユーティリティを使用 ワークブック バージョンは変わらないが、抽出は .hyper 形式にアップグレードされる  √

抽出を .tde 形式で保持する理由

Tableau Desktop をアップグレードできない場合は、抽出を .tde 形式のまま保持する必要があります。

抽出を .tde 形式で保持する方法

抽出を .tde 形式で保持するには、抽出をアップグレードしないでください。抽出のアップグレードを回避するため、抽出のアップグレードを引き起こすタスクセクションに一覧されたタスクは、Tableau Desktop 2019.3 を使用して .tde 抽出に対して実行しないでください。その上で、.tde バージョンの抽出を維持する必要がある場合は、次の提案について検討してください。

  • .tde 抽出を再度作成する必要がある場合には、Tableau Desktop 2019.3 を使用して抽出の更新とデータの追加のタスクを実行しますが、以前のバージョンの Tableau Desktop と元のデータに接続する機能を維持します。

  • 以前のバージョンの Tableau Desktop を使用して、抽出の更新やデータの追加などの抽出タスクを実行します。

  • 可能であれば、どの抽出をアップグレードする必要があり、どの抽出をアップグレード対象外とするか特定できるまでは、Tableau Server、Tableau Online または Tableau Bridge での既存の抽出更新スケジュールを無効にします。

抽出のアップグレード後に予測されること

抽出のアップグレード後、バージョン 2019.3 で作業する際に、他にもいくつかの変更点があります。

抽出を開く際の変更点

.tde 抽出が .hyper 抽出にアップグレードされた後は、以前のバージョンの Tableau Desktop を使用してアップグレードされた抽出を開くことができません。抽出を開く際の問題を解決するために、以下の提案のいくつかを考慮してください。

  • Tableau Desktop の 2019.3 へのアップグレード: 可能な場合は、.hyper 抽出のメリットを体験できるように、Tableau Desktop2019.3 へアップグレードすることを検討してください。詳細については、「Tableau Desktop 展開ガイド」の「Tableau Desktop のアップグレード」を参照してください。

  • 以前のバージョンの Tableau Desktop を使用した抽出の再作成: .tde 抽出を再作成するには、以前のバージョンの Tableau Desktop を使用して元のデータに接続できなければなりません。詳細については、Tableau ナレッジ ベースの接続先とデータの準備および「以前のバージョンの Tableau のダウンロード」を参照してください。

  • 以前のバージョンのパブリッシュされた抽出データ ソースまたはワークブックの取得: Tableau Server または Tableau Online でリビジョン履歴が有効な場合は、パブリッシュされた抽出データ ソースまたは抽出データ ソースを使用するパブリッシュされたワークブックをダウンロードできます。注: 抽出データ ソースを使用する以前のワークブックを取得した場合、それは .twb 形式で保存されるため、以前のバージョンの Tableau Desktop でワークブックを開いた後に、抽出を再作成する必要があります。詳細については、コンテンツのリビジョンの操作を参照してください。

抽出を共有する際の変更点

抽出データ ソースのデータを誰かと直接共有する必要がある場合は (電子メールやファイル共有などで)、抽出を .tdsx ファイルとして保存するようにしてください。もしくは、抽出データを含むワークブックを .twbx として保存してください。.tdsx または .twbx の代わりに .hyper ファイルのみ共有する場合、接続情報や列名の変更など、.hyper 抽出に関するメタデータが失われます。詳細については、Tableau ファイル タイプとフォルダーを参照してください。

抽出ファイル サイズ相違の可能性

.tde 抽出のファイル サイズはデータの複雑度によって異なります。抽出のアップグレード後は、対応する .hyper 抽出ファイルのファイル サイズについても同じ理由からさまざまになります。.hyper 抽出が抽出のアップグレード後に大きくなる場合もあれば、小さくなる場合もあります。

[バージョン名を付けてエクスポート] オプションへの変更

ワークブックに .hyper 抽出が含まれる場合、[ファイル] メニューの [バージョン名を付けてエクスポート] オプションは使用できません。Tableau の以前のバージョンを使用して .hyper 抽出が含まれるワークブックを開く必要がある場合は、ワークブックから抽出を削除してから [バージョン名を付けてエクスポート] オプションを使用してワークブックをダウングレードする必要があります。ワークブックをダウングレードしたら、.tde 抽出を再作成する必要があります。

その他の問題

抽出のアップグレード後に発生したエラーについては、Tableau ナレッジ ベースの以下の記事を参照してください。

抽出のアップグレード後のビューにおける変更点

抽出がアップグレードされた後、抽出データ ソースを使用しているビューでいくつかの変化に気付くことがあります。これは、抽出内の値が、バージョン 2019.3 では違う方法で計算されている可能性があるためです。変化には、ビュー内のマーク数の減少、サマリー データを調べたときの NULL 値の増加、またはビュー自体の異なる形状への変化などがあります。一部の稀なケースでは、ビューが空白になる場合もあります。このバージョンの Tableau で抽出を操作する際に気付く可能性がある変化の詳細については、ビュー内の値とマークの変更を参照してください。

抽出の手動アップグレード

抽出をローカルで管理する場合は、Tableau Desktop を使用して、.tde 抽出を .hyper 抽出に手動でアップグレードできます。

  1. Tableau Desktop で、.tde 抽出を使用しているワークブックを開きます。

  2. [データ] メニューで抽出データ ソースを選択し、[抽出] > [アップグレード] を選択します。

  3. [ファイル] > [保存] を選択します。これにより、ワークブックが保存され、抽出のアップグレードも完了します。
ご意見をお寄せくださりありがとうございます。 ご意見の送信中にエラーが発生しました。もう一度実行するか、当社にメッセージを送信してください