Make Workbooks Compatible with Older Versions

You can downgrade workbooks to share them with people using older versions of Tableau products.

Important: When you downgrade to an older version, any features or functionality that aren't available in that version are removed for compatibility. Additionally, any calculated fields created in the newer version that use functions unavailable in the older version will have to be manually corrected or removed upon downgrade.

Export to an earlier version from Tableau Desktop

  1. In Tableau Desktop select File > Export As Version and select the version that you want to downgrade to. (The earliest version you can export is Tableau Desktop 10.5.)

  2. Export As Version drop-down menu with available export versions shown

  3. Save the workbook to your My Tableau Repository or a selected folder.

Downgrade a workbook when publishing to Tableau Server

If you're using a newer version of Tableau Desktop with an older version of Tableau Server, you can downgrade to the older Tableau Server version when you choose Server > Publish Workbook. A warning message appears indicating that workbook will be downgraded when published:

Publish Workbook to Tableau Server dialog with warning: "Server is running an older version than your copy of Tableau Desktop. The workbook will be downgraded and may lose some functionality. All datasources must be embedded in the workbook."

If you later open the downgraded workbook in the newer version of Tableau Desktop, you'll see a message like the one shown below. You may then need to add back the features that were removed when the workbook was downgraded.

Warning message: The workbook will be upgraded from version 10.3 to version 10.4 when it is saved. The upgraded file cannot be read by earlier versions of the application.

Note: Data sources are not downgraded during publishing.

Download an older version from Tableau Online or Tableau Server

If you're using Tableau Online or Tableau Server, you can download a workbook to be opened in an older version of Tableau Desktop.

  1. To identify which version of Tableau Desktop you're using, select Help > About Tableau from the top menu.

    Tableau Desktop Help menu with About Tableau selected

  2. In Tableau Server or Tableau Online, open the view you'd like to download.

  3. Click the Download button, and then click Tableau Workbook.

  4. Select the version that you want to export to. (The earliest version you can download is Tableau Desktop 10.5.)

For more information, see Download Views and Workbooks.

Additional compatibility resources

In the Tableau Deployment Guide, check out Make Workbooks Compatible Between Versions to learn more about how different versions of Tableau products interact.

Thanks for your feedback!