Sometimes you want to pull in data from an outside source for some quick analysis. Rather than create a whole data source and then connect in Tableau, you can copy and paste the data directly into your workbook. Tableau automatically creates a data source that you can begin analysing.

When you paste data on the data source page, Tableau creates a new connection in the existing data source.

When you paste data on the sheet, Tableau creates a new data source that you can begin analysing. When you paste the data as a data source, the data source is saved as a text file to your Tableau Repository when you save the workbook.

You can copy and paste data from a variety of office applications including Microsoft Excel and Microsoft Word. You can also copy and paste HTML tables from web pages. Tables that are copied as comma separated values or tab delimited can be pasted into Tableau.

Note: Not all applications use these formats when copying.

  1. Select the data you want and copy it to the clipboard.

  2. Open Tableau Desktop and do one of the following:

    1. On the data source page, select Data > Paste Data as Connection or Paste Data as Data Source.

    2. On the sheet, select Data > Paste to paste the data as a data source.

  3. Select File > Save to save the data source.

    When you save the workbook, the data source either becomes a part of the existing data source or is added to your repository, depending on which of the methods you choose. If you paste the data as a data source, the data source is saved with the workbook when you save the workbook as a packaged workbook (.twbx).

Thanks for your feedback!