Tableau Prep Builder 新增功能

瀏覽新功能摘要來瞭解目前支援的版本。

附注:從版本 2019.1.2 開始,Tableau Prep 現在稱為 Tableau Prep Builder。

在版本 2020.3.1 中新增

儲存和共用工作

將流程輸出資料儲存到外部資料庫

您現在可以將完整或累加式流程結果輸出至支援的資料庫,並使用已清理、準備完成的流程資料建立、取代或附加資料表資料。Tableau Prep Builder 支援將流程資料儲存至下列資料庫:

  • Amazon Redshift
  • Microsoft SQL Server
  • MySQL
  • Oracle
  • PostgreSQL
  • Snowflake
  • Teradata

在輸出步驟中,在「將輸出儲存至」下拉清單中,選擇「資料庫資料表」。然後,選擇要該處儲存流程輸出的資料庫和資料表。您還可以輸入資料表名稱以在資料庫中建立新資料表。欄位比較可預覽顯示流程欄位和資料表欄位兩者的相符狀態。狀態欄位會顯示有關不相符欄位的詳細資訊。

您還可以新增可以在將資料載入資料庫資料表之前或之後執行的 SQL 指令碼。可以使用這些指令碼在執行流程之前建立資料表資料的副本、新增索引、對資料庫資料表新增資料庫約束等等。

有關將流程輸出儲存到資料表的詳情,請參閱將流程輸出資料儲存到外部資料庫(版本 2020.3.1 及更高版本)

不再支援 Tableau 資料擷取 (.tde) 檔案

從版本 2020.3.1 起,流程輸出不再支援 Tableau 資料擷取 (.tde) 檔案。任何發佈到伺服器版本 2020.3 及更高版本且輸出至 Tableau 資料擷取 (.tde) 檔案格式的流程,都必須轉換為 Hyper 擷取 (.hyper) 檔案,否則流程將執行失敗。流程輸入仍支援 Tableau 資料擷取 (.tde) 檔案。

有關建立和發佈資料擷取的詳情,請參閱建立和發佈擷取及資料來源

建立 .json 認證檔以從命令列執行流程變得更容易

如果使用命令列執行流程,且連線至或輸出至伺服器或資料庫,現在建立 .json 認證檔時可以使用更簡便的語法。在舊版中,您需要使用連線認證指定單獨的「inputConnection」和「outputConnection」陣列。從版本 2020.3.1 起,您不再需要區分「inputConnection」和「outputConnection」。相反的,只需要使用新的「tableauServerConnections」或「databaseConenctions」陣列輸入伺服器連線或資料庫連線的認證一次。

仍將繼續支援使用「inputConnection」和「outputConnection」陣列的舊 .json 認證檔。

有關詳細資訊,請參閱透過命令列重新整理輸出檔案

在版本 2020.2.3 中新增

連線至資料

使用 Snowflake 連線到資料時使用 OAuth 身份驗證

現在,當您使用 Snowflake 連接到資料時可以使用以下任何身份驗證方法,就像 Tableau Desktop 一樣:

  • 使用者名稱與密碼

  • SAML IdP

  • OAuth

有關使用此連線器連線至資料來源的詳情,請參閱 Tableau Desktop 說明中的 Snowflake(Link opens in a new window)

在版本 2020.2.2 中新增的功能

連線至資料

使用 Tableau Server 或 Tableau Online 連線至資料

以前的版本可以連線至儲存在 Tableau Server 或 Tableau Online 上的已發佈資料來源。現在,如果 Tableau Catalog 已啟用 資料管理附加元件(Link opens in a new window),還可以搜尋並連線至儲存在 Tableau Server 或 Tableau Online 中的資料庫和資料表。

只需在「連線」窗格新的「搜尋資料」區段中選擇 Tableau Server,即可登入您的伺服器。此時會開啟「搜尋資料」對話方塊,以便您在已整理的資料來源中搜尋和選取。

其他中繼資料(如:資料來源說明、資料品質警告和認證)可協助您找到要尋找的資料來源,無需離開 Tableau Prep Builder。還可以使用右上角的篩選器選項,依連線類型、資料品質警告和認證篩選結果。

如果 Tableau Catalog 未啟用資料管理附加元件,則只會顯示已發佈資料來源,且您無法檢視中繼資料。

有關連線至資料的詳情,請參閱連線到發布的資料來源(版本 2019.3.1 及更新版本)

使用 Alibaba MaxCompute 連線至資料

如果資料儲存在資料倉儲中,現在可以使用 Alibaba MaxCompute 連線至此資料來源。有關使用此連線器連線至資料來源的詳情,請參閱 Tableau Desktop 說明中的 Alibaba MaxCompute(Link opens in a new window)

在版本 2020.2.1 中新增的功能

連線至資料

連線至 Salesforce.com 資料

Tableau Prep Builder 現在可以連線到 Salesforce 資料,因此可以清理和準備這些資料,以便在 Tableau 中進行分析。目前尚未支援使用自訂 SOQL 和建立標準連線。

有關詳情,請參閱連線到 Salesforce 資料(版本 2020.2.1 及更高版本)

使流程資料保持最新狀態

使用累加式重新整理時僅處理最新資料

如果流程資料不斷變更,現在可以使用累加式重新整理,僅檢索和處理自上次執行流程以來的最新資料列,以節省時間和資源。只需為流程設定累加式重新整理參數,指示 Tableau Prep Builder 如何從輸入資料中偵測和檢索新列。還可以設定在「輸出」步驟中執行流程時更新輸出資料表的方式。

可透過「輸出」步驟中的新選項選擇將新資料附加到現有資料表或使用 Tableau Prep Builder 的現有功能,並將資料表資料取代為新資料。此選項在累加式重新整理和完整重新整理類型中均可使用。

使用 Tableau Prep Conductor 按排程設定和執行流程,或在 Tableau Prep Builder 中或使用命令列介面累加執行個別流程。

附註:需要 Tableau Server 版本 2020.2 及更高版本(並已啟用 Tableau Prep Conductor)才能使用累加式重新整理來排程流程。

有關使用累加式重新整理設定和執行流程的詳情,請參閱使用累加式重新整理重新整理流程資料

在版本 2020.1.4 中新增

連線至資料

透過 Impala 連線至資料

Tableau Desktop 一樣,您現在可透過 Impala 輕鬆連線至較大的資料集合。

有關透過 Impala 連線到資料來源的詳情,請參閱 Tableau Desktop 說明中的 Impala(Link opens in a new window)

清理和調整資料

按一下即可轉換日期值。

為讓您更輕鬆地進行資料清理,Tableau Prep Builder 已為日期新增額外的快速清理功能表。若您需要轉換日期值以顯示年份、月份或日等 DATEPART,可以從全新「轉換日期」功能表中選取以下功能表選項,不必撰寫複雜的欄位計算。

有關套用清除操作至日期的詳情,請參閱套用清理作業

儲存和共用工作

保持與伺服器的連線

您不再需要於每次開啟 Prep Builder 時登入 Tableau Server 或 Tableau Online 了。現在 Tableau Prep Builder 會在您關閉應用程式時記住您的伺服器名稱和登入資訊。這樣在您下次開啟應用程式時,將直接處於已登入伺服器的狀態。

這個節省時間的選項將協助您順利連線至發布資料來源或插入儲存的流程步驟。若您需要瞭解特定功能是否與伺服器版本相容,系統會立即顯示相容性警告,不需要您先登入伺服器。

有關詳情,請參閱以資料來源形式發佈

在版本 2020.1.3 中新增

安裝和部署 Tableau Prep Builder

支援登入型授權管理

以登入為基礎的授權管理 可協助您在 Tableau ServerTableau Online 上管理具有 Creator 角色之使用者的授權。具有 Explorer 或 Viewer 角色的使用者不能使用此功能。如果使用角色型訂閱搭配 Tableau ServerTableau Online,您就可以使用 以登入為基礎的授權管理 來簡化授權管理,藉此免除使用個別的 Tableau DesktopTableau Prep Builder 產品金鑰。您只需要為內部 Tableau Server 管理一或多個產品金鑰;如果是 Tableau Online,則完全不需要管理任何產品金鑰。

連線至資料

使用 Initial SQL 將參數傳遞到資料來源

現在起,您可以使用 Initial SQL 將參數傳遞到資料來源,以提供更多有關 Tableau Prep 應用程式、版本及流程名稱的詳情。Tableau Prep Builder 支援以下參數:

  • TableauApp - 傳回用來存取您資料來源的應用程式 - Prep Builder 或 Prep Conductor。

  • TableauVersion - 傳回應用程式版本號碼。如果是 Tableau Prep Builder,會傳回確切的版本號碼,例如 2020.1.1。如果是 Tableau Prep Conductor,會傳回已啟用 Tableau Prep Conductor 的主要伺服器版本,例如 2020.1。

  • FlowName - 傳回 .tfl 檔案的名稱。

有關透過 Initial SQL 連線到資料來源時使用參數的詳情,請參閱在 Initial SQL 陳述式中包含參數(版本 2020.1.3 及更新版本)

清理和調整資料

使用「詳細資料層級」(LOD)、「順序」和「列數」等計算來清除資料

如果您資料的彙總層級與您所需的層級不同,或是您需要在一個列集合間執行計算,現在就可以使用 FIXED 詳細資料層級 (LOD)和 RANK 及 ROW_NUMBER 等分析函數計算來建立資料集合中所需的資料。

例如,新增 FIXED LOD 計算可變更表中的欄位細微性。使用新的 ROW_NUMBER () 分析函數可快速尋找重複的列,使用其中一個新的 RANK () 函數則是可以尋找具有類似資料之選定列的前 N 個或最後 N 個值。

如果您想要在建立這些類型的運算式時享有更具引導式的體驗,則可以使用新的視覺計算編輯器。

有關使用這些導出欄位清除資料的詳情,請參閱建立詳細資料層級和順序計算

在版本 2020.1.1 中新增

連線至資料

映像流程輸入返回其原始連線

如果使用多個輸入來組建流程,則在需要更新或交換連接時,嘗試尋找的用於不同輸入的個別表或資料來源並非總是顯而易見。為了更輕易地尋找流程輸入和表,我們新增了在「連線」窗格中,反白顯示所選輸入的連接器和表的新功能。

只需在「流程」窗格中選擇一個或多個「輸入」步驟,相關連接器和表即會在「連線」窗格中反白顯示。

有關如何連線到資料以組建流程的詳細資訊,請參閱連線至資料(Link opens in a new window)

清理和調整資料

暫停資料更新以提升效能

每次對資料套用清理操作時,Tableau Prep Builder 都會重新整理檢視,以便您立即查看變更結果。在組建新流程時,持續的回饋可協助您快速瞭解接下來應執行的步驟,但有時候套用這些變更需要一些時間。為了提升效能並更快地將變更套用至資料,您現在可以暫停這些持續的資料更新,並大量套用變更。

只需在頂端功能表上選按「暫停資料更新」按鈕,Tableau Prep Builder 便會暫停資料更新,並將「設定檔」窗格檢視切換成「清單」檢視,讓您快速套用變更。

只顯示欄位中繼資料,而非每次變更時重新整理檢視。當您完成變更並希望查看欄位值的結果時,請按一下「恢復資料更新」按鈕以切換回標準資料更新模式。

附註:在暫停資料更新期間,任何需要資料值才能執行工作的清理操作都將處於停用狀態。

有關暫停資料更新以大量套用清理操作的詳細資訊,請參閱暫停資料更新以提升效能

Tableau Prep 版本相容性

偵測並啟用不相容的功能

Tableau Prep Builder 版本 2019.3.1 中,我們新增了警告圖示和工具提示,讓您在組建流程時,能輕易查看哪些功能與您的 Tableau Server 版本不相容,以協助您在打算發佈流程並按照排程執行流程時,能明智地決定流程中應包含哪些功能。

此版本中,對於使用可能與伺服器版本不相容的新功能的情況,我們提升了更高的清晰度。

現在,登入伺服器後,Tableau Prep Builder 可以偵測哪些功能與您的 Tableau Server 版本不相容,並停用這些功能。這讓您在打算發佈流程並按照排程執行流程時,不需再臆測可以包含哪些功能。

如果您仍希望使用該功能,並從命令列或用 Tableau Prep Builder 手動執行流程,則可以直接在功能表啟用該功能。只需按一下「使用功能」按鈕,即可將該功能套用至流程,且所有不相容的功能都將啟用並可供使用。

Tableau Prep Builder 版本 2019.3.1 中推出的警告選項仍將識別與伺服器不相容的功能,以便您希望在 Tableau Server 中使用排程執行流程時,可以輕易地尋找和刪除這些功能。

有關使用不相容功能的詳細資訊,請參閱 Tableau Prep 版本相容性

使流程資料保持最新

發佈流程時為雲端連接器新增或內嵌認證

在以前的版本中,如果要發布和排程包含雲端連接器的流程,則需要提前設定 Tableau ServerTableau Online 的認證。否則,Tableau Prep Conductor 將無法偵測您的認證,且流程將無法執行。現在只需要幾個簡單的步驟,即可直接從 Tableau Prep Builder 的「發布」對話方塊新增和內嵌雲端連接器的認證。

只需登入伺服器並選取「伺服器」>「發佈流程」。在「發佈流程」對話方塊中,將顯示新的警告文字,指出您具有需要驗證的輸入連線。按一下訊息中的「編輯連線」連結,或「連線」部分中的「編輯」連結,然後在「驗證」下拉式清單中,選取「新增認證」

輔助訊息將確認您的選擇。按一下「繼續」以前往 Tableau ServerTableau Online 中的「帳戶設定」頁面,並新增認證。

完成後,返回 Tableau Prep Builder,按一下「完成」,您的新認證將自動內嵌於流程中。

有關在發布期間新增雲端連接器認證的詳細資訊,請參閱發佈流程

在 2019.4.2 版本中新增

連線至資料

使用新的連接器連線到更多資料

在此版本中,我們已新增下列新資料連接器:

  • Alibaba AnalyticDB for MySQL
  • Alibaba Data Lake Analytics
  • Databricks
  • Kyvos
  • Qubole Presto

有關如何使用這些連接器連線至資料的詳情,請參閱 Tableau Desktop 和 Web 製作說明的支援的連接器(Link opens in a new window)。有關連線至資料以組建流程的一般資訊,請參閱連線至資料(Link opens in a new window)

清理和調整資料

將欄樞紐為列變得更容易

現在,當您需要將資料從欄樞紐為列時,可以在「設定檔」窗格中手動選取欄位,並樞紐這些欄位,或 Tableau Prep Builder 可為您建議要進行樞紐或為您建立樞紐的欄位。這兩個選項都會自動產生您的樞紐步驟,因此您可以快速執行任何其他樞紐動作,例如重新命名樞紐欄位,或在其他欄位上進行樞紐。

若要從「設定檔」窗格中手動將欄樞紐為列,只要選取您要進行樞紐的欄位,接著按一下滑鼠右鍵或按住 Ctrl 並按一下 (MacOS),然後從功能表選取「將欄樞紐為列」,即可建立新的樞紐步驟,並樞紐您的欄位。

如果 Tableau Prep Builder 偵測到可樞紐的欄位,將會在「設定檔」窗格工具列中顯示建議選項。按一下工具列中的燈泡 圖示,並選取樞紐建議。該建議會顯示將樞紐的欄位。只要按一下「套用」即可產生「樞紐」步驟,並樞紐您的欄位。

有關樞紐資料的詳情,請參閱樞紐您的資料。有關如何使用建議來清除資料的詳情,請參閱採用建議套用清除操作(版本 2018.3.2 及更新版本)

其他增強功能

看看長期執行操作的意見反應

為了在處理大型資料集合或流程時,為您提供更多可見性,我們在「流程」窗格的頂端新增了進度列指示器,以便 Tableau Prep Builder 在處理資料時,為您提供狀態更新。現在,您可以更清楚地瞭解 Tableau Prep Builder 在後台進行的操作,因此,您不必再猜想是否仍在處理資料或是否發生問題。

支援登入型授權管理

以登入為基礎的授權管理 可協助您在 Tableau ServerTableau Online 上管理具有 Creator 角色之使用者的授權。具有 Explorer 或 Viewer 角色的使用者不能使用此功能。如果使用角色型訂閱搭配 Tableau ServerTableau Online,您就可以使用 以登入為基礎的授權管理 來簡化授權管理,藉此免除使用個別的 Tableau DesktopTableau Prep Builder 產品金鑰。您只需要為內部 Tableau Server 管理一或多個產品金鑰;如果是 Tableau Online,則完全不需要管理任何產品金鑰。

在2019.4.1 版本中新增

連線至資料

連線到雲端中的更多資料

在此版本中,我們已新增以下雲端連接器:

  • Box
  • DropBox
  • Google Drive
  • OneDrive

如果您打算將流程發布至 Tableau Server 或 Tableau Online,則可能需要其他組態才能儲存這些連接器的認證。有關連線到雲端資料連接器的詳情,請參閱連線到雲端資料來源。

其他增強功能

與 Tableau 共用使用情況資料

Tableau 會收集有助於我們瞭解產品使用情況的資料,以便我們可以改進現有功能並開發新功能。所有使用情況資料都是根據 Tableau 隱私權政策(Link opens in a new window)收集並處理的。但如果您不想參與,可以選擇退出。

退出選項已變更。預設情況下,會啟用使用情況資料收集。如果您不想參與,請從安裝程式或自訂安裝程式 (MacOS) 對話方塊,或在安裝後從「說明」功能表選取「不傳送產品使用情況資料」核取方塊。

有關詳情,請參閱 Tableau Desktop and Tableau Prep 部署指南中的關閉使用情況報告(Link opens in a new window)

不再為 MacOS 自動安裝預設資料庫驅動程式

在 Mac 上安裝 Tableau Prep Builder 時,指會自動安裝 PostgreSQL 資料庫驅動程式。如果您需要其他驅動程式才能連線至資料,可以從「驅動程式下載」(Link opens in a new window)頁面安裝這些驅動程式。

在版本 2019.3.2 中新增

建立與組織流程

只要按一下就能在目標位置插入步驟

在以前的版本中,您可在流程中現有步驟的後面插入清理步驟,該流程會向右擴展,提供空間給新的步驟。但在現有步驟後面新增其他任何步驟類型都會在您的流程中建立分支,導致您必須透過移除並新增流程行的方式來重新連接。

在此版本中,我們已新增全新插入功能表,讓您只要按一下,就能在現有步驟間插入任何步驟類型(甚至包括複製的步驟)。只要將滑鼠遊標停留在您想在流程行上插入步驟的位置,然後使用新「插入」功能表,就能選取並在正確位置插入您想要的步驟類型。

附註: 「新增」功能表的「插入步驟」功能表項目已移動到此新功能表。此選項不可用於「輸入」和「輸出」步驟類型。

有關在流程中新增及插入步驟的詳情,請參閱新增或插入步驟

使用流程巡覽器輕鬆檢閱龐大的流程

處理龐大的流程時,您可能難以用來回滾動的方式找到步驟並進行修正或變更。全新的流程巡覽器會顯示於流程窗格右下角。此工具是整個流程的縮小影像。您可以使用此工具來放大和縮小、按一下影像以直接巡覽倒流城中的相應部分、調整流程大小等。若不想顯示此工具,您只要按一下就能將其最小化或還原。

有關連線至資料以組建流程的詳情,請參閱使用流程巡覽器工具

檢查和篩選資料

使用自訂資料角色分組類似值

Tableau Prep Builder 2019.3.1 版中,我們推出了使用資料集合中的欄位值建立自訂資料角色的功能。您可在此版本中使用這些自訂資料角色,根據拼字和發音為欄位中的值群組,藉由自動比對並使用最接近的有效值來取代的方式,修正無效值。

只要將自訂資料角色套用至欄位及任何不符合標準值(以紅色驚嘆號標記)的值即可。

若要修正無效值,您可以按一下欄位上的「建議」 圖示,將建議套用至群組,並使用有效值取代無效值;或在「更多選項」 功能表選取「分組和取代」>「拼字」「發音 + 拼字」,藉此選取您想修正的無效值。

有關建立及使用自訂資料角色的詳情,請參閱按資料角色分組類似值

清理和調整資料

使用新清單檢視將清理動作套用至欄位

目前您可在設定檔窗格、結果窗格或資料網格中套用清理作業。但您能同時查看的欄位數會受到螢幕尺寸限制。為了讓您更輕鬆地掃描所有欄位並執行動作,我們已新增全新清單檢視功能,讓您將設定檔窗格或結果窗格轉換為清單。選取此選項後,您流程的所有步驟都會維持此檢視狀態,但您可以隨時變更。

您可在此檢視中套用作業至多個欄位(例如「移除」「僅保留」),或快速套用清理作業(例如「重命名欄位」「複製欄位」)。您也可從「更多選項」 功能表套用其他清理作業,但「分組和取代」「篩選條件」「拆分值」等作業會帶您返回「設定檔」窗格或「結果」窗格檢視以完成這些動作。

有關在清單檢視中清理欄位的詳情,請參閱選取檢視

透過可重複使用的步驟利用您與他人的工作

若您經常在處理資料時重複執行相同動作,可以選取一個或多個流程步驟和其相關動作,或是選取整個流程,然後將其儲存以在您建立及管理的其他流程中重複使用。您可以將步驟儲存到本機,或發佈到 Tableau ServerTableau Online 與他人共用。

若要建立可重複使用的步驟,請直接選取您想儲存的步驟,以滑鼠右鍵按一下並選取「將步驟儲存為流程」,然後選取要將步驟儲存到本機檔案或伺服器。發佈流程步驟到伺服器時,系統會自動新增「已儲存步驟」標籤,讓您之後能輕鬆找到這些流程步驟。

您可在儲存後開啟及插入任何流程。在流程窗格內,以滑鼠右鍵按一下或按住 Ctrl 並按一下 (MacOS) 畫布的任何區域,然後選取「插入流程」,或在頂端功能表選取「編輯」>「插入流程」。在「新增流程」對話方塊中,您可以從檔案或伺服器選取並插入已儲存的流程步驟。對話方塊會自動篩選並顯示所有附有「已儲存步驟」標籤的流程,但您可以變更篩選條件並插入任何您有權存取的流程。

選取的流程會新增至流程窗格,然後您可在流程中隨意移動及連接步驟。有關建立及使用可重複使用的流程步驟的詳情,請參閱清理和調整資料

儲存和共用工作

停用在 Mac OS 上使用命令列執行流程時的鑰匙圈對話方塊

使用者在 MacOS 上使用命令列執行流程使,我們已使其無須於每次執行流程時手動輸入 MacOS 鑰匙圈認證。

有關詳情,請參閱透過命令列重新整理輸出檔案中的「停用 SSL 驗證 (MacOS)」命令選項。

在版本 2019.3.1 中新增

連線至資料

使用 Google BigQuery 連線至資料

使用 Google BigQuery,在雲端中連線到更多資料。與 Tableau Desktop 一樣,您現在可以連線到儲存在 Google BigQuery 中的資料,如果已設定 Google OAuth 連線,則可以將流程發布至 Tableau Server 和 Tableau Online。

附註Tableau Prep Builder 目前不支援使用 Google BigQuery 自訂屬性。此外,包含 Google BigQuery 連接器的流程也無法從命令列執行。而是要手動執行流程,或在 Tableau ServerTableau Online 中根據排程執行流程。

有關如何連線到 Google BigQuery 的詳情,請參閱 Tableau Desktop 說明中的 Google BigQuery(Link opens in a new window)。有關連線至資料的詳細資訊,請參閱連線至資料(Link opens in a new window)

連線至已發布的資料來源以供流程輸入使用

無論是從 Tableau Desktop 產生已發布的資料來源,或作為 Tableau Prep Builder 的輸出,或將其發布至 Tableau ServerTableau Online,您現在可以連線至已發布的資料來源,並使用這些資料來源作為流程的輸入資料來源。

只需從「連線」窗格選取「Tableau Server」,然後登入您的伺服器或站點。

登入之後,會顯示可用資料來源的清單。選取您的資料來源,或使用搜尋選項以尋找您的資料來源,並將其拖曳至流程窗格以開始流程。

附註:目前不支援包含使用者篩選條件的已發布資料來源。

有關連線至資料與組建流程的詳情,請參閱連線至資料(Link opens in a new window)

檢查和篩選資料

建立自訂資料角色

您可以使用資料角色來識別及驗證欄位值。在之前版本中,Tableau Prep Builder 提供一組標準資料角色,您可以將其套用至欄位,以快速識別無效值。在此版本中,您現在可以使用資料集中的欄位值建立自訂資料角色,然後將這些角色發布至 Tableau ServerTableau Online,以在您的流程中使用,或與其他人共用資料角色,以便比以往更容易識別和清除無效值。

需選取要使用的欄位,然後從「更多選項」 功能表選取「發布為資料角色」

發布自訂資料角色之後,一旦登入發布自訂資料角色的站點或伺服器,即可從新的「自訂」功能表選項選取該資料角色,以將其套用至欄位。

您可以在 Tableau ServerTableau Online 上檢視及管理已發布的自訂資料角色。檢視已發布至站點或伺服器的所有自訂資料角色,將它們移至不同的專案、變更權限或刪除這些自訂資料角色。

有關建立和使用自訂資料角色的詳情,請參閱建立自訂資料角色(版本 2019.3.1 及更新版本)(Link opens in a new window)

清理和調整資料

在流程中使用 R 和 Python 指令碼

您現在可以使用 R 和 Python 指令碼以執行更複雜的清除操作,或將預測的模組化資料整合到您的流程中。使用 Rserve 或 TabPy,透過 R 或 Python 指令碼步驟從流程傳遞資料作為輸入,然後傳回作為輸出資料,您可以使用 Tableau Prep Builder 的特性和功能繼續清理該資料。

有關如何在流程中包含指令碼的詳情,請參閱在流程中使用 R 和 Python 指令碼(Link opens in a new window)

儲存和共用工作

建立流程時發現不相容的功能

Tableau Prep Builder 每個月發行新版本。如果新版本推出新的功能或連接器,而且您打算將流程發布至舊版的 Tableau ServerTableau Online,相容性可能會成為問題。目前,您在發佈流程時可以查看是否有不相容的功能,但是到那時您已建立流程,因此返回刪除不相容的功能可能會需要一些時間。

在此版本中,相容性警示更顯而易見。您現在可以在建立流程時看到任何不相容的功能,以便對於此時包含的功能做出明智的決定。

只需登入 Tableau Server,然後在建立流程時,如果您選擇 Tableau Server 版本不支援的功能,則會顯示警示。按一下畫布右上角的「警示」以檢視所有警示和錯誤,或將游標懸停在流程窗格中步驟或註釋上的警示,以檢視警示詳細資訊。

按一下「在流程中檢視」連結,以快速巡覽至步驟、註釋、欄位,或變更與其相關的警告。步驟、欄位和變更已標記警示圖示並反白顯示,因此您可以快速找到並解決問題,然後繼續進行操作。

有關解決相容性問題的詳情,請參閱 Tableau Prep 版本相容性(Link opens in a new window)

使流程資料保持最新狀態

Tableau Data Management 附加元件包含 Tableau Prep Conductor

Tableau Prep Conductor 包含在為 Tableau Server 或 Tableau Online 單獨授權的 Data Management 附加元件中。有關詳情,請參閱授權 Tableau Prep Conductor

發佈流程至 Tableau Online

您現在可以發佈流程至 Tableau Server 或 Tableau Online,並根據排程執行流程,讓資料保持在最新狀態。Tableau Online 不支援直接連線至內部部署資料來源。如果發佈流程至連線至內部部署資料來源的 Tableau Online,您可以編輯連線以將連線自動轉換至發佈的資料來源。

有關發佈流程至 Tableau Online 的詳情,請參閱將流程發布至 Tableau Server 或 Tableau Online(Link opens in a new window)

其他增強功能

Tableau Prep Builder 目前支援義大利文

現在,您可以使用 11 種不同語言之一設定使用者介面(功能表、訊息等)。有關設定顯示語言的詳情,請參閱 Tableau Desktop 和 Tableau Prep Builder 部署指南中的設定顯示語言(Link opens in a new window)

在版本 2019.2.3 中新增

檢查和篩選資料

選取要篩選的特定值

有了全新的「選定值」篩選條件,您現在可以挑選並選擇要針對欄位保留或排除的值,甚至是不在樣本中的值。在「設定檔」窗格、「結果」窗格或資料網格中,按一下「更多選項」 按鈕,然後選取「篩選條件」>「選定值」

這個新的視覺指標可讓您選取要保留或排除的值,並顯示您所選定的值。如果您使用的是資料的樣本,而且想要包含或排除您正在使用的樣本中的值,只要新增所需的值,Tableau Prep Builder 便會同時將保留或排除選項套用至這些新值。

如需篩選欄位值的詳細資訊,請參閱 檢查資料(Link opens in a new window)

按一下即可複製欄位

在先前的版本中,如果您想要在欄位中實驗清理操作,但不想要變更原始資料,就必須編寫計算以複製欄位。現在,您只要按一下便可輕鬆地複製欄位。選取要複製的欄位,然後從「更多選項」功能表中選取「複製欄位」

系統會建立新的欄位,並將欄位放置在「設定檔」窗格、資料格或「結果」窗格的最左邊,並使用相同名稱以及輔助按鍵。例如「Ship Date -1」。

如需複製欄位及其他清理選項的詳情,請參閱套用清理作業(Link opens in a new window)清理和調整資料(Link opens in a new window)

清理和調整資料

使用模糊匹配和清理建議,修正無效的資料角色值

您可以使用資料角色來快速識別無效的欄位值。在您指派資料角色之後,您可以使用兩種模糊匹配演算法之一;「拼字」「拼字 + 發音」以快速將資料角色的無效值分組和匹配至該資料角色的類似標準值。

除了針對您的欄位建議資料角色之外。Tableau Prep Builder 現在也可以建議您使用「拼字」「拼字 + 發音」演算法,針對分派至資料角色的欄位,自動修正無效值。如果偵測到建議的修正,「設定檔」卡上會顯示燈泡 圖示。按一下該圖示然後套用建議的變更,即可自動分組並以該資料角色的類似標準值取代無效值。

此功能僅可用於下列資料角色:

  • 機場
  • 城市
  • 國家/地區
  • 郡/縣
  • 州/省

有關套用資料角色至欄位及使用分組和取代來修正資料角色無效值的詳情,請參閱使用資料角色以驗證您的資料(Link opens in a new window)

在版本 2019.2.2 中新增

連線至資料

使用其他資料庫 (ODBC) 連接器連接至更多資料

如需連線至「連線」窗格中未列出的資料來源,您可以使用支援 SQL 的「其他資料庫 (ODBC)」連接器來連線至任何資料來源,並實作 ODBC API。藉由「其他資料庫 (ODBC)」連接器採用與在 Tableau Desktop 中所使用的類似方式來連接資料,不過方式有一些差異:

  • 您只能使用「DSN(資料來源名稱)」選項連線。
  • 若要在 Tableau Server 中發佈及執行流程,必須使用相符的 DSN 來設定伺服器。
  • 提供適用於 Windows 和 MacOS 的單一連接體驗。不支援為 ODBC 驅動程式 (Windows) 提示連線屬性。
  • Tableau Prep Builder 僅支援64位元驅動程式。

有關使用其「他資料庫連接器 (ODBC)」連接至資料的詳細資訊,請參閱連線至資料(Link opens in a new window)

在連接至資料時指定 Initial SQL 命令

您現在可以指定 Initial SQL 命令,在連接至支援的資料庫時,會在資料庫的連接建立時執行。例如,連接至 Amazon Redshift 時,您可以輸入SQL 陳述式,以便在連接至資料庫時套用篩選器,如同在「輸入」步驟中新增篩選器一樣。SQL 命令會在資料採樣和載入至 Tableau Prep Builder 之前套用。

如果您變更 Initial SQL 命令並重新整理「輸入」步驟,則會再次執行 Initial SQL 命令,並更新「輸入」步驟。當您執行流程時,Initial SQL 命令會在處理所有資料之前先執行,如果您排定 Tableau Server 的流程,就會執行 Initial SQL 做為資料載入體驗的一部分。

有關詳細資訊,請參閱連線至資料(Link opens in a new window)

注意:Tableau Prep Builder 的 Initial SQL 尚未支援參數。

檢查和篩選資料

僅在清理您的資料時保留所需的欄位

在之前版本中,您可以在連接至資料後清除核取方塊,以移除「輸入」步驟中不需要的欄位;在清除或動作步驟中,您可以選取一個或多個欄位,並按一下滑鼠右鍵以移除欄位。現在,您可以在「設定檔」窗格或資料網格中選取一個或多個欄位,也可以按一下滑鼠右鍵,以便僅保留選取的欄位及所有其他欄位。

有關詳情,請參閱保留或移除欄位(Link opens in a new window)

清理和調整資料

重新排列流程中的步驟

您是否曾經建立龐大的複雜流程,但是使用 Tableau Prep Builder 的預設配置卻會讓您的流程難以遵循?現在您可以在畫布中選取並移動您的步驟,採用對您而言是有意義的方式來組織流程。例如,您可以跨越不同的流程行進行修正、移動流程步驟以清理額外的空白,或重新安排流程步驟以顯示清楚的事件順序。

下列流程十分混亂而且難以遵循:

使用這個新功能,您可以在流程中選取一個或多個步驟向上、下、左、右四方拖曳至所需的位置。

注意:具有某些限制,流程步驟不可移至會中斷由左至右之程序流程的位置。拖曳流程步驟至允許的位置時,會顯示橘色方塊。如果該位置並非允許位置,則不會顯示任何橙色方塊,而且當您嘗試拖放步驟時,步驟就會返回原始位置。

有關詳情,請參閱建立與組織流程(Link opens in a new window)

在版本 2019.2.1 中新增

連線至資料

使用新的資料庫連接器連線到更多資料

我們增加了更多連接器來協助您連線至資料和清除資料。現在,您可以連線到下列資料庫中儲存的資料:

  • Amazon Athena
  • 其他資料庫 (JDBC)

有關連線到特定連接器的詳細資訊,請參閱 Tableau Desktop 和 Web 製作說明的支援的連接器(Link opens in a new window)。有關連線至資料以建立流程的詳細資訊,請參閱連線至資料(Link opens in a new window)

使流程資料保持最新狀態

發佈流程時,檢視檔案安全清單位置

您可以將流程發佈至 Tableau Server,並根據排程自動執行這些流程,然後使用 Tableau Prep Conductor 重新整理流程輸入或輸出。如果您的流程包含連線至網路共用的輸入或輸出步驟,則系統管理員必須事先在組織安全清單中加入該檔案位置,否則當您嘗試在 Tableau Server 中執行流程時,將會失敗。

在 Tableau Prep Builder 版本 2019.2.1 中,如果您發佈的流程其中包含連線至網路共用之輸入或輸出步驟,且檔案必須包含在組織的安全清單中,系統就會在發佈時通知您。若要查看列出的安全位置,只要按一下警告訊息中的連結,然後將您的檔案移到所顯示的其中一個位置即可。

如需有關發佈流程的詳情,請參閱將流程發布至 Tableau Server 或 Tableau Online(Link opens in a new window)如需如何將檔案位置新增至組織的安全清單的詳細資訊,請參閱步驟 4:安全清單輸入和輸出位置(Link opens in a new window)

其他增強功能

為您的使用者介面選取 10 種不同語言

Tableau 已新額外增兩種語言,可以選擇設定使用者介面(功能表、訊息等):

  • en_GB (英式英文)

  • zh_TW(繁體中文)

有關設定顯示語言的詳細資訊,請參閱 Tableau Desktop 和 Tableau Prep Builder 部署指南中的設定顯示語言(Link opens in a new window)一節。

藉由流程縮圖檢視,快速找出您在 Tableau 伺服器上執行的流程

若您將流程發佈至 Tableau Server,現在可以切換至縮圖檢視以及檢視您的流程配置的圖形呈現,藉此協助您一眼就能快速找出自己的流程。

在版本 2019.1.4 中新增

連線至資料

使用新的資料庫連接器連線到更多資料

我們增加了更多連接器來協助您連線和清理您的資料。現在,您可以連線到下列資料庫中儲存的資料:

  • SAP HANA
  • Azure SQL 資料倉儲
  • MariaDB

附註:使用 SAP HANA 連線至資料時,不支援在開啟流程和使用初始 SQL 查詢連線時提示變數和參數。

有關連線到特定連接器的詳細資訊,請參閱 Tableau Desktop 和 Web 製作說明的支援的連接器(Link opens in a new window)部份。有關連線至資料以建立流程的詳細資訊,請參閱連線至資料(Link opens in a new window)

清理和調整資料

在欄位中按資料角色分組類似值

Tableau Prep Builder 2018.2.3 版本中,我們引入了資料角色以協助您標準化欄位值和快速尋找無效值。現在,如果您將資料角色指派到欄位,則可以使用該資料角色將值與資料角色所定義的標準值進行比對和分組。只需要將資料角色指派到欄位,然後從「分組和取代」功能表選取「資料角色符合」。此新選項將根據拼字和發音將無效值與大部份類似值進行比對。

例如,如果您的欄位中列出了 Saint Martin 和 Saint Maarten 之類的國家/地區,並且您將「國家/地區」資料角色指派到該欄位,則可以使用新的「資料角色相符」選項分組欄位,然後將這些值對應到標準化資料角色值「Saint-Martin」。如果資料集中不存在該值的標準化拼字,Tableau Prep Builder 會為您自動將其新增到群組並使用此標準值分組相符的值。

此功能適用於下列資料角色,目前僅支援英語(美國)。

  • 機場
  • 城市
  • 國家/地區
  • 郡/縣
  • 州/省

有關將資料角色指派至欄位或使用資料角色對值進行分組的詳情,請參閱使用資料角色以驗證您的資料(Link opens in a new window)

分組欄位值時調整結果

使用「分組和取代」清理選項按「拼字」「發音」分組類似值時,您現在可以使用欄位上的建議滑桿調整分組參數的嚴格程度,讓您更好地控制結果。

從 5 個閾值設定進行選取以控制群組包含的值數量以及建立的群組數量。

有關使用模糊比對群組欄位的詳情,請參閱編輯欄位值(Link opens in a new window)

在版本 2019.1.3 中新增

連線至資料

根據資料表關聯快速聯結資料

當您連線至包含定義了資料表關聯之資料表的資料庫(例如 Vertica 或 Microsoft SQL Server)時,Tableau Prep Builder 現在可以偵測並顯示此資訊。

例如,您現在可以看到資料表中哪些欄位是唯一識別碼,哪些欄位是相關欄位(外部索引鍵)以及這些欄位的任何相關資料表。

「輸入」窗格中會顯示稱為「連結金鑰」的新欄,其圖示出現在唯一識別碼、相關欄位或兩者組合的欄位旁。

「連結金鑰」欄位中,按一下相關欄位或組合欄位,以檢視相關資料表,然後按一下,將相關資料表新增至流程或建立聯結。

建立聯結時,Tableau Prep Builder 使用定義的欄位關聯聯結資料表,並顯示定義聯結子句的欄位預覽。從這裡,您可以按一下新的聯結步驟,根據需要清除並編輯聯結條件。

對於包含相關欄位的資料表,您也可以查看所有相關資料表的清單,並從「流程」窗格的功能表中建立聯結。透過「新增聯結」功能表選項,從清單中選取您要聯結的資料表,Tableau Prep Builder 根據構成兩個資料表之間關聯的欄位建立聯結。

此功能可供任何定義了資料表關聯的受支援資料庫連接器使用。有關使用「連結金鑰」新增或聯結資料表的詳情,請參閱在輸入步驟中加入資料(版本 2019.1.3 及更新版本)(Link opens in a new window)

清理和調整資料

請參閱工具列上的所有清除建議

如果 Tableau Prep Builder 偵測到並提供您欄位的清除建議,欄位的「設定檔」卡上會出現燈泡 圖示。現在您可以從一個便捷清單的所選步驟中的工具列上查看任何欄位的所有清除建議。

只要按一下清單中的項目,Tableau Prep Builder 就可以讓您直接進入欄位,以便套用建議的變更。有關清除建議的詳情,請參閱採用建議套用清除操作(版本 2018.3.2 及更新版本)(Link opens in a new window)

附註:此選項不可用於「聯結」、「輸入」和「輸出」步驟類型。

其他增強功能

在流程中尋找特定變更

您可以透過按一下「流程」窗格中某一步的變更圖示,或者按一下「設定檔」或「結果」窗格中設定檔卡上的變更圖示,快速尋找您在流程中所作的特定變更。只要按一下代表您要尋找之變更的圖示,然後從變更清單中選取註解。變更會在「變更」窗格、「設定檔」「結果」 窗格以及資料網格中反白顯示(如果適用)。

如需有關檢視變更的詳細資訊,請參閱查看您所做的變更(Link opens in a new window)

從「開始」頁面中管理最近檢視的流程

當您儲存流程並關閉 Tableau Prep Builder 時,會將流程的縮圖儲存到「開始」頁面,以便您快速尋找最常用的流程。但是作為資料準備巨星,您的「開始」頁面可能會很快變得擁擠!為了在您完成流程處理時協助您快速找到所需的流程並降低雜亂,我們已經新增一些新功能至「開始」頁面。

  • 流程縮圖上改進的圖形更準確地代表流程配置,以幫助您快速查看流程。

  • 如果圖形不提供足夠的資訊,請將滑鼠懸停在流程縮圖上,以立即檢視流程的輸入與輸出詳細資料,以及最後開啟的時間。

  • 從開始頁面上移除您不再需要的最近檢視之流程,以便清除雜亂。這個選項只會從「最近流程」視圖中移除流程,不會刪除流程。

在版本 2019.1.2 中新增

使流程資料保持最新狀態

排程流程以在 Tableau Server 中自動執行

將新的資料管理附加元件新增至 Tableau Server 版本 2019.1 及更新版本,然後您可以使用 Tableau Prep Conductor 排程並管理您的流程執行。將流程發佈到 Tableau Server,然後排定工作以執行流程並自動更新您的流程輸入及輸出。使用錯誤和警示選項以及管理檢視,追蹤並管理您的流程處理安全狀況。

有關詳情,請參閱使流程資料保持最新狀態(Link opens in a new window)

說明設計

已經進行更新以協助您瀏覽我們的內容,包括可用於快速掃描和選取頁面上不同主題的最新右側功能表。

在版本 2019.1.1 中新增

清理和調整資料

將列樞紐至欄

如果您處理的是交叉表或試算表中的資料,則其格式可能讓您無法在 Tableau 中輕鬆分析它。有時,您的資料可能分為很多欄,需要將這些欄轉換為列,或者您可能擁有較少的欄,但是資料值代表多個事物。

為了使您的資料調整比以往更容易,現在您可以選取適合自己的樞紐分析選項。在樞紐分析步驟中,現在您可以選取下列選項之一:

  • 欄至列:將一個或多個欄位拖曳至「樞紐欄位」窗格以將欄樞紐為列。

  • 列至欄:將欄位拖曳至樞紐欄位窗格以使用欄位值建立新欄,然後拖曳至欄位中,用來填入這些欄並選取您要彙總它們的方式。

有關詳情,請參閱樞紐您的資料(Link opens in a new window)

使用萬用字元搜尋樞紐欄位

如果您的資料集合具有大量欄位,或者如果欄位隨著時間頻繁新增或移除,則您在將欄樞紐為列時可以使用萬用字元搜尋,以根據萬用字元模式匹配即時樞紐您的資料。如果新增或移除了與模式匹配的新欄位,則在執行流程時 Tableau Prep Builder 偵測架構變更並且樞紐結果自動更新。

若要使用萬用字元搜尋來樞紐資料,請新增樞紐分析步驟,然後按一下「按一下這裡建立萬用字元樞紐」連結,開啟萬用字元搜尋欄位。輸入萬用字元搜尋模式,以尋找名稱符合您所輸入之值的欄位。按一下「搜尋選項...」按鈕,選取您是否要納入包含您所輸入之模式,隨您所輸入之模式開始或結束的欄位。

按一下 Enter 以套用模式,Tableau Prep Builder 自動樞紐這些欄位。

有關詳情,請參閱樞紐您的資料(Link opens in a new window)

使用說明新增內容至變更

新增說明至「變更」窗格中的任何變更,以新增內容至清除作業。只要開啟「變更」窗格,在清單的變更上按一下滑鼠右鍵或按 Ctrl +按一下 (Mac) 並選取「新增說明」。然後在出現的文字欄位鍵入說明。

說明出現在生成的變更文字下方,帶有註解 圖示。

有關詳情,請參閱對流程步驟和清除動作新增說明(Link opens in a new window)

使用清除建議快速分割固定寬度文字檔案中的資料

在之前版本中,如果您處理儲存在固定寬度文字檔案中的資料,在單個欄中包含資料值字串的檔案受到固定資源限制的約束,則您可能必須對檔案執行一些預先清除或使用複雜計算將值分離至單獨欄中。

現在,當您連線到此類型的資料來源時,清除建議功能會偵測這些欄類型,並為您建議分割選項。只要連線到您的資料來源,然後新增清除步驟。在設定檔窗格中,按一下設定檔卡上的建議圖示。

按一下「套用」以分割欄位,然後檢查結果,並根據需要清除或重新命名每個新欄位。

有關詳細資訊,請參閱採用建議套用清除操作(版本 2018.3.2 及更新版本)(Link opens in a new window)

在版本 2018.3.3 中新增

連線至資料

新增新檔時自動重新整理輸入聯集

如果在輸入步驟中使用萬用字元模式來查找和聯集 Microsoft Excel 或文字 (.csv) 檔案,則在下次您開啟流程或透過命令列執行流程時,新增到同一資料夾中、與模式匹配的新檔案會自動包括在聯集中。

附註:已封裝流程檔 (.tflx) 不會自動獲取新檔案,因為該檔案已與流程已封裝在一起。若要包括新檔案,請開啟流程檔 (.tfl) 以獲取新檔案,然後重新封裝流程以包括新檔資料。

有關在輸入步驟中聯集檔案的詳情,請參閱輸入步驟中的聯集檔案和資料庫資料表(Link opens in a new window)

清理和調整資料

重用清理操作

在清理資料時,您通常會在整個流程中反復執行相同的清理操作或動作。為了使資料的清理和調整更加高效,我們新增了在整個流程中複製和貼上這些操作或動作的功能,這樣您就能執行清理操作或動作一次,然後在需要的地方重用該操作或動作。

  • 複製一個或多個步驟以在流程的另一個區域中使用它們。此選項不可用於包括萬用字元聯集的輸入步驟。

  • 從一個步驟的「變更」窗格中複製操作,然後將其貼上在另一個步驟的「變更」窗格中,從而在該步驟中應用該相同操作。

  • 將一個操作從「變更」窗格拖放到「設定」窗格中的一個欄位,以將該操作應用於其他欄位。您也可以在「變更」窗格中複製操作,並將其拖放到步驟中的其他欄位,以將該操作套用於多個欄位。此選項不可用於影響多個欄位(例如計算欄位)的操作。

有關詳情,請參閱清理和調整資料(Link opens in a new window)

移除額外的空格

我們新增了兩個新的快速清理操作,幫助您移除欄位值中額外的空格:

  • 移除額外的空格:將此選項與文字欄位值結合使用以移除前導和尾隨空格,以及將字元之間的額外空格取代為單一空格。

  • 移除所有空格:使用此選項從文字值中移除所有空格,包括前導和尾隨空格以及字元之間的任何空格。

有關詳情,請參閱編輯欄位值(Link opens in a new window)

檢查和篩選資料

快速查找欄位在流程中的使用之處

在組建流程時,如果未看到所有期望的欄位值,您現在可以輕鬆地跟蹤欄位的每處使用位置 - 甚至能追溯到欄位的來源。只需在一個步驟的「設定」窗格或「結果」窗格中選取一個欄位,流程窗格中的步驟將突出顯示。這將向您展示欄位在流程中所採用的路徑,從而能夠比以往更為輕鬆地排查流程的故障。

有關詳細資訊,請參閱在流程中跟蹤欄位(Link opens in a new window)

其他增強功能

同時開啟多個 Tableau Prep Builder 視窗

在 Windows 中或 Mac 上,按一下「檔案」>「新建」,為流程開啟一個新視窗,而不是取代您正在其中工作中的目前視窗。開啟流程檔(.tfl 或 .tflx)時,也會開啟一個新視窗,這樣您就能輕鬆地同時處理或比較多個流程。

安裝之後關閉使用情況報告

為了幫助我們改進 Tableau Prep Builder,您可以與我們共用使用情況模式資料。我們決不會收集任何具體使用者資料,只會收集任何匿名使用情況資料。例如,資料來源連線類型(例如 .csv、sql 或 Amazon Redshift)、大資料集與小資料集、流程中的步驟數或使用的操作類型(但不會收集資料細節,例如步驟名稱或使用的公式),諸如此類。

您的資料是機密的,我們決不會與任何人共用此資訊。但如果要在安裝之後關閉此選項,您可以這樣做。轉到「說明」>「設定和效能」,並按一下「共用使用情況資料以改進 Tableau Prep Builder」以清除核取記號。有關詳情,請參閱 Tableau Desktop 和 Tableau Prep Builder 部署指南中的使用情況報告(Link opens in a new window)

在版本 2018.3.2 中新增

清理和調整資料

使用清理建議快速提高資料品質

為了幫助您快速找出並修復資料問題,Tableau Prep 現在可以檢查資料欄位並提出變更建議,您可以進行這些變更來修復問題。Tableau Prep 會檢查您的資料欄位,如果確定了建議的變更,欄位的「設定檔」卡上會出現一個燈泡圖示。

按一下燈泡圖示可查看建議的變更,然後將滑鼠指標暫停在建議卡上並按一下「套用」以將變更自動套用到欄位。變更記錄在「變更」窗格中,並且可隨時移除。

在下面的範例中,Tableau Prep 將欄位值確定為 URL,並建議為欄位套用資料角色來說明確定無效的值。

除「輸入」、「輸出」和「聯結」步驟類型外的所有步驟類型中提供了此功能。此版本中的建議類型包括:

  • 資料角色
  • 篩選器
  • 將無效值取代為 Null 值
  • 移除欄位
  • 剪裁空格

有關詳細資訊,請參閱採用建議套用清除操作(版本 2018.3.2 及更新版本)

其他增強功能

透過命令列執行流程時更加靈活

透過命令列執行流程時,如果您連線至資料庫或將輸出檔案發佈到伺服器,則需要一個包括所有必需認證的 credentials.json 檔案。在過去的版本中,如果只連線至資料庫或將流程輸出發佈到伺服器,您仍然需要在 credentials.json 檔案中包括空陣列,否則流程將會失敗。

現在,您不再需要在 credentials.json 檔案中包括空陣列。舉例來說,如果只連線至資料庫,您不再需要在 .json 檔中包括 outputConnection 陣列。

有關如何透過命令列執行流程的詳情,請參閱透過命令列重新整理輸出檔案

效能改進

為了幫助您更快更高效地使用流程,我們增強了以下功能:

  • 關閉產品時會立即歸還 Tableau Prep 使用的記憶體空間。

  • 如果遇到意外錯誤,您現在可以重試動作或過程以使您保持在流程中。

  • 載入資料或在流程中檢視資料時效能提高,可縮短處理時間。

  • 如果連線到以下連線器,您現在可以使用搜尋欄位來快速查找架構:
    • Amazon EMR Hadoop Hive
    • Cloudera Hadoop
    • Hortonworks Hadoop Hive
    • MapR Hadoop Hive
    • Presto
    • Spark SQL

已在以前版本中新增

在版本 2018.3.1 中新增

安裝和部署 Tableau Prep

變更預設存放庫位置

預設情況下,當您安裝 Tableau Prep 時,我的 Tableau Prep 存放庫自動安裝在電腦上的您的「文件」資料夾中。但如果您可存放流程和資料來源的位置存在相關限制,您現在可以在安裝 Tableau Prep 之後將「我的 Tableau Repository」轉移到其他目錄。

若要移動該目錄,請開啟 Tableau Prep,然後從頂端功能表中選取「檔案」>「存放庫位置」。選取要將存放庫轉移到其中的資料夾。

有關詳情,請參閱 Tableau Desktop 和 Tableau Prep 部署指南中的變更「我的 Tableau Prep 存放庫」位置(Link opens in a new window)

連線至資料

清理存放在 PDF 檔案中的資料

分析存放在 PDF 檔案中的資料可能很難處理。現在您可以直接連線到 PDF 檔案並使用 Tableau Prep 清理資料。

有關如何連線到 PDF 檔案中的資料的詳情,請參閱 Tableau Desktop 說明中的 PDF 檔案(Link opens in a new window)

附註:資料連線器不向後相容。包括這些連線器的流程可在以前版本的 Tableau Prep 中開啟,但除非移除這些資料連線器,否則將會出錯或無法執行。

適用於資料庫表的萬用字元聯集

如果要處理存放在單個資料來源中的資料庫表,您現在可以使用萬用字元搜尋在輸入步驟中聯集表。隨後,您可以使用與在「輸入」步驟中聯集多個檔相同的步驟,在「輸入」步驟中包括選定表中的所有資料。

若要使用這種類型的聯集,各個表必須位於同一資料來源中,並且您必須連線到支援萬用字元聯集的資料來源。

以下資料來源支援這種類型的聯集:

  • Amazon Redshift

  • Microsoft SQL Server

  • MySQL

  • Oracle

  • PostgreSQL

有關詳情,請參閱輸入步驟中的聯集檔案和資料庫資料表(Link opens in a new window)

清理和調整資料

將欄位值取代為 Null

如果有要包括在分析中的資料列,但想要排除特定欄位值,您可以將這些值變更為 Null 值。只需選取要取代的欄位值,然後以滑鼠右鍵按一下(在 Mac 上按住 Ctrl 按一下)所選的值,並從功能表中選取「取代為 Null」

有關取代欄位值的詳細資訊,請參閱編輯欄位值

在任何步驟中套用清理操作

修復流程中的問題更加高效。現在,如果您在聯結、聯集、樞紐或彙總時發現資料中的問題,您可以直接在該步驟中修復這些問題,而不必新增額外的清理步驟。

由於操作順序很重要,因此系統會將清理操作放在聯結、聯集、樞紐或彙總步驟之前或之後,並在該步驟的「變更」窗格中跟蹤此資訊。

還會將變更的注釋新增到「流程」窗格中的步驟。對於「輸入」步驟,註解顯示在步驟的左側,並會新增到「輸入」欄位清單,以便您能夠輕鬆地查看哪個欄位應用了變更。對於所有其他步驟類型,註解顯示在「流程」窗格中步驟的上方。

某些清理操作仍然必須在清理步驟中執行,只有部分清理操作可用於「輸入」和「輸出」步驟。下表列出了可用於每種步驟類型的清理操作:

  輸入 清理 彙總 樞紐 聯結 聯集 輸出
篩選器 X X X X X X  
分組和取代   X X X X X  
清理   X X X X X  
拆分值   X X X X X  
重命名欄位 X X X X X X  
編輯值   X X X X X  
變更資料類型 X X X X X X  
建立計算欄位   X X X X X  
移除欄位 X X X X X X  

有關詳細資訊,請參閱關於清除操作

在版本 2018.2.3 中新增

連線至資料

連線到存放在 MongoDB Business Intelligence (BI) 中的資料

如果將資料存放在 Mongo DB Business Intelligence 中,您現在可以連線至資料並使用 Tableau Prep 對其進行清理。

有關如何使用 Mongo DB Business Intelligence 連線至資料的詳情,請參閱 Tableau Desktop 說明中的 MongoDB BI 連線器(Link opens in a new window)

附註:資料連線器不向後相容。包括這些連線器的流程可在以前版本的 Tableau Prep 中開啟,但除非移除這些資料連線器,否則將會出錯或無法執行。

檢查和篩選資料

為欄位值指定資料角色

您現在可以為欄位值指派資料角色,並使用 Tableau Prep 幫助您查找資料集中的不準確之處或離群值。

資料角色告知 Tableau Prep 欄位值的含義或代表的內容,例如電子郵件地址或者諸如城市或郵遞區號等地理角色。為欄位指派資料角色之後,Tableau Prep 可檢查欄位值並標記不匹配的值,以便您能夠進行更仔細的檢查。

若要僅查看有效或無效的值,請使用下拉式功能表上的新篩選器選項:

在此版本中,我們支援以下資料角色:

  • 電子郵件

  • URL

  • 地理角色(基於目前地理資料,並且與 Tableau Desktop 使用的資料相同)

    • 機場
    • 區號(美國)
    • CBSA/MSA
    • 城市
    • 國會選區(美國)
    • 國家/地區
    • 郡/縣
    • 歐洲 NUTS
    • 州/省
    • 郵遞區號

有關詳情,請參閱使用資料角色以驗證您的資料(Link opens in a new window)

聯結或聯集資料

在聯結子句中直接修復不匹配的欄位

在聯結兩個資料表時,通常會有一些相同但由於資料錄入錯誤而不匹配的欄位值。Tableau Prep 可將不匹配的欄位值標為紅色,從而幫助確定聯結子句中不匹配的欄位。但如果能夠在聯結子句中修復這些欄位值,豈不是更好?現在就能這樣做了。

現在,當您聯結兩個資料集時,您可以直接在聯結子句中對要聯結的欄位值進行編輯來修復它們。只需在欄位值中按兩下即可對其進行編輯。

選取要變更的欄位 內聯編輯

系統會為相應的聯結資料集將清理動作自動推回到流程中的上一個清理步驟。

聯結步驟之前沒有清理步驟?沒問題。Tableau Prep 會自動為您新增一個清理步驟,以便從聯結中捕獲清理操作。

有關如何直接在聯結子句中清理欄位值的資訊,請參閱彙總、加入或聯集資料(Link opens in a new window)

在版本 2018.2.2 中新增

安裝和部署 Tableau Prep

設定顯示語言

啟動 Tableau Prep 時,它現在將檢測電腦上設定的區域設定,並以相應的語言顯示使用者介面、日期和數位格式。如果要變更使用者介面的顯示語言,您可以從頂端功能表中的「說明」>「選取語言」下選取支援的語言。

有關詳情,請參閱 Tableau Desktop 和 Tableau Prep 部署指南中的設定顯示語言

連線至資料

連線到 Microsoft Access 中存放的資料

如果使用 Microsoft Access 進行資料錄入和存放資料表,您現在可以透過檔案瀏覽器連線到(版本 2007 或更高版本中的)Access 檔案,並使用 Tableau Prep 清理資料。

此連線器需要 64 位元驅動程式。

有關如何將 Tableau Prep 連線至資料的詳細資訊,請參閱 Tableau Desktop 說明中的 Access(Link opens in a new window)

附註:資料連線器不向後相容。包括這些連線器的流程可在以前版本的 Tableau Prep 中開啟,但除非移除這些資料連線器,否則將會出錯或無法執行。

清理和調整資料

變更流程步驟的配色方案

預設情況下,Tableau Prep 會為流程中的每個步驟指派一種顏色,幫助您在組建流程時更輕鬆地跟蹤對資料所做的變更。但您可以選取配色方案。

您現在可以從調色板中進行選取來變更一個或多個步驟的配色方案。只需在「流程」窗格中選取要變更的步驟,以滑鼠右鍵按一下所選步驟,並從上下文功能表中選取「編輯步驟顏色」

不喜歡它的外觀?從頂端功能表中按一下「復原」,或從調色板功能表中選取「重設步驟顏色」

有關詳情,請參閱變更流程配色方案(Link opens in a new window)

為步驟新增說明

如果與其他人共用流程,傳達您所做的變更以及相關原因可能很麻煩。為了簡化這一點,您現在可以為流程中任何單獨的步驟新增簡短說明,說明將直接顯示在流程窗格中。

有關將說明新增至流程步驟的詳情,請參閱對流程步驟和清除動作新增說明(Link opens in a new window)

使用模糊匹配來查找並修復拼寫錯誤

為了幫助您快速確定並清理由於拼寫錯誤而導致的相同值的多個變體,我們為模糊匹配清理功能新增了另一個選項。使用新的「拼寫」選項來查找由於多出或缺少字母而不同的文字值,並將其分組。此選項適合於任何支援的語言。

「拼寫」選項使用 Levenshtein 距離演算法來計算兩個文字值之間的編輯距離,然後在編輯距離小於預設閾值時將它們分組在一起。

有關詳細資訊,請參閱編輯欄位值

儲存和共用工作

從命令列中執行流程

為了使資料在 Tableau Prep 中保持最新,您會執行流程。但是,每次要執行流程時都開啟 Tableau Prep 可能很費時間。為了說明簡化此流程,您現在可以從命令列中執行流程,而不必將其在 Tableau Prep 中開啟。

若要從命令列中執行流程,您將需要:

  • 要執行的流程 (.tfl) 檔的路徑。

  • 一個 .json 檔案,其中包含流程為其輸入步驟連線到的任何資料庫的資料庫認證,以及在其中發佈輸出的伺服器的認證。

    如果流程為輸入或輸出連線到或發佈至本機檔案或存放在網路共用上的檔案,則不需要此檔案。

    附註:不支援連線到或發佈存放在網路共用上的受密碼保護的檔案。

  • 執行流程的電腦上的管理員授權權。

此選項在 Windows 電腦(支援工作計畫程式)和 Mac 電腦上均可用。若要使用此過程,您需要 Tableau Prep 的啟用版本,並且必須在安裝了 Prep 的同一台電腦上執行該過程。

有關如何從命令列中執行流程的資訊,請參閱透過命令列重新整理輸出檔案

在版本 2018.2.1 中新增

安裝和部署 Tableau Prep

透過命令列停用 Tableau Prep

像 Tableau Desktop 一樣,如果您的電腦上不再需要 Tableau Prep,您現在可以使用 -return 選項透過命令列將其停用。

有關詳細資訊,請參閱停用產品金鑰(Link opens in a new window)。有關命令列中可用於 Tableau Prep 的其他安裝程式屬性的詳細資訊,請參閱部署 Tableau Desktop(Link opens in a new window) 中的 「安裝程式選項」及相關部分。

使用虛擬桌面支援來優化 Tableau Prep 安裝

就像 Tableau Desktop 一樣,您現在可以設定虛擬桌面支援,針對非持久性虛擬桌面或定期重新映射的電腦優化 Tableau Prep 的安裝。借助虛擬桌面支援,系統會使用 Tableau 託管的「授權執行」(ATR) 服務在預先確定的一段時間後自動停用 Tableau Prep 授權,從而無需手動停用產品金鑰。

有關如何設定此選項的詳細資訊,請參閱 Tableau Desktop 和 Tableau Prep 部署指南中的設定虛擬桌面支援(Link opens in a new window)

連線至資料

連線到雲端資料來源和 Hadoop Hive

您們增加了對以下連線器的支援,使您能連線到雲端資料和 Hadoop 中存放的資料。

  • Snowflake

  • Amazon EMR Hadoop Hive

  • Cloudera Hadoop(Hive 和 Impala)

  • Hortonworks Hadoop Hive

  • MapR Hadoop Hive

  • Apache Drill

  • SparkSQL

有關如何將 Tableau Prep 連線至資料的詳細資訊,請參閱 Tableau Desktop 說明中支援的連線器(Link opens in a new window)下適用於您的連線器的主題。

這些資料連線器不向後相容。包括這些連線器的流程可在以前版本的 Tableau Prep 中開啟,但除非移除這些資料連線器,否則將會出錯或無法執行。

瀏覽資料

用於只保留所需資料的新篩選器選項

不再需要編寫複雜的計算即可保留或排除 Null 值,或對文字值設定萬用字元匹配。作為替代,選取欄位上的新篩選器選項之一即可立即看到所做變更的效果,而不必先編寫計算,並隨後在所做變更未產生所需結果的情況下恢復變更。

有關詳細資訊,請參閱檢查資料

清理和調整資料

在計算欄位中使用 ISO-8601 日期標準

建立計算欄位來支援歐洲日曆更加輕鬆。Tableau Prep 現在為以下日期部分支援 ISO-8601 國際日期標準:

  • "iso-year"

  • "iso-quarter"

  • "iso-week"

  • "iso-weekday"

在 DATEPART、DATETRUNC、DATENAME、DATEDIFF 和 DATEADD 函數中使用這些日期部分。

例如,Week Number = STR(DATEPART('iso-year', [Week Date])) + "-" + STR(DATEPART('iso-week', [Week Date]))

有關如何在計算欄位中使用日期函數的詳細資訊,請參閱 Tableau Desktop 說明中的日期函數(Link opens in a new window)

在資料網格中應用清理操作

在以前的版本中,資料網格會向您顯示資料的預覽,但可用的清理選項很少。現在您可以在任何地方對資料進行操作。如果在資料網格中處理詳細值,請折疊「設定」窗格,並在資料網格中執行與「設定」窗格中的可用清理操作相同的清理操作。

有關詳細資訊,請參閱清理和調整資料

使用多選對「設定」窗格中的值進行分組

若要快速對一組欄位值進行分組,您現在可以在「設定檔」卡中選取多個值,然後以滑鼠右鍵按一下開啟功能表並選取「分組」。該值將分組在您以滑鼠右鍵按一下開啟功能表時選取的欄位值下。分組的值旁邊將顯示一個迴紋針圖示。

以滑鼠右鍵按一下分組的值再次開啟功能表,以取消分組或編輯值。

有關對值分組的詳細資訊,請參閱編輯欄位值(Link opens in a new window)

其他增強功能

我們還提供了以下增強功能來改善可用性:

  • 向流程中新增步驟時,功能表上將顯示新的圖示,用於提供視覺提示並幫助您瞭解 Tableau Prep 的視覺語言。

  • 「設定」窗格中新的動畫可幫助吸引您的注意力,以便更好地瞭解所做變更的效果。

     

聯結或聯集資料

使用聯集建議來清理不匹配的欄位

在聯集兩個或更多檔案後修復不匹配的欄位更加輕鬆。「聯集摘要」窗格中新的「不匹配欄位」部分顯示不匹配的欄位的清單,以及這些欄位的來源的資料來源。使用以下選項之一,直接在此部分中合併不匹配的欄位:

  • 在清單中選取一個欄位。如果 Tableau Prep 基於類似的資料類型和欄位名確定具有類似特徵的欄位,它將以黃色突出顯示該欄位,同時推薦一個匹配項。按一下將游標暫停在推薦的匹配欄位上時出現的加號 按鈕來合併兩個欄位。

  • 在清單中選取兩個或更多欄位,以滑鼠右鍵按一下這些欄位之一,並選取「合併欄位」

    有關聯集和解決不匹配欄位的詳細資訊,請參閱聯集資料

為所有聯結類型確定不匹配的欄位

不管您如何聯合資料表,都能輕鬆確定不匹配的欄位。在以前的版本中,「聯結子句」表只會在欄位彼此相等時顯示排除的欄位值。但現在,您可以在匹配聯結子句時使用任何運算子查看此資料,例如「End Date >= Modified Date」。

有關詳細資訊,請參閱聯結資料(Link opens in a new window)

在版本 2018.1.2 中新增

安裝和部署 Tableau Prep

透過命令列啟用和註冊 Tableau Prep (Windows)

像 Tableau Desktop 一樣,您現在可以透過包括含以下屬性的命令列,從命令列中啟用和註冊 Tableau Prep:

  • ACTIVATE_KEY="<key>"。此安裝程式執行 -activate 來套用產品金鑰。

  • REGISTER=“1”.在安裝過程中,安裝程式將執行 -register 處理序,並新增註冊資訊。

有關這些安裝程式屬性以及如何透過命令列啟用和註冊 Tableau Prep 的詳細資訊,請參閱部署 Tableau Desktop(Link opens in a new window) 中的「安裝程式選項」及相關部分。

連線至資料

連線到存放在統計檔案中或 Presto 上的資料

我們增加了兩個新的連線器來幫助您連線到來自更多位置的資料。

  • 統計檔案。連線到 SAS (*.sas7bdat)、SPSS (*.sav) 和 R (*.rdata) 資料檔案。

  • Presto。有關如何設定 Presto 連線的詳細資訊,請參閱 Tableau Desktop 說明中的Presto(Link opens in a new window)

這些資料連線器不向後相容。包括這些連線器的流程可在以前版本的 Tableau Prep 中開啟,但除非移除這些資料連線器,否則將會出錯或無法執行。

在輸入步驟中聯集 Data Interpreter 找到的子表

使用 Data Interpreter 來清理 Microsoft Excel 資料,並且現在想要聯集產生的子表?您現在可以使用萬用字元聯集來聯集輸出步驟中所有找到的子表。

只需將其中一個子表拖到「流程」窗格,然後使用萬用字元搜尋條件來選取要聯集的其餘子表,並將所有子表資料包括在輸入步驟中。

有關詳細資訊,請參閱連線至資料

載入表時更好的回饋

首次連線至資料庫時,有時可能看起來未發生任何事情。現在,新的指示符將指出資料仍在載入。

瀏覽資料

對「設定」窗格和「資料」網格中的欄位進行重新排序

您現在可以透過拖放對「設定檔」窗格和「資料」網格中的欄位重新排序,並且兩個窗格將保持同步。即使您重命名欄位,我們也會保持欄位順序。欄位不再會自動重新排序。

清理和調整資料

使用拖動選取功能來移除流程中的多個步驟

移除流程的整個部分更加容易。您現在可在「流程」窗格中按一下,並使用滑鼠拖動並選取要移除的流程部分。然後以滑鼠右鍵按一下即可一次性移除所有選取的步驟。有關詳細資訊,請參閱清理和調整資料(Link opens in a new window)

在一個動作中對多個欄位群組進行樞紐

Tableau Prep 中的樞紐選項已經擴展,可更好地支援更複雜的試算表或文字檔。您現在可以執行單一樞紐,或選取欄位組進行樞紐。

例如,若要對試算表進行樞紐來按月和按年查看銷售額、稅款和總計,您可以對每組欄位進行樞紐來獲取所需的結果。有關詳細資訊,請參閱清理和調整資料(Link opens in a new window)

原始試算表 對多群組欄位進行樞紐之後

合併欄位時改善的欄位命名

當您合併欄位時,欄位名稱不再是級聯方式。相反,目標欄位的欄位名會保留。有關詳細資訊,請參閱合併欄位(Link opens in a new window)

級聯式欄位命名 簡化的欄位命名

其他增強功能

我們還提供了以下增強功能來改善可用性和效能:

  • 將游標暫停在「變更」窗格中的條目上時,將會顯示一個新的編輯圖示,可幫助您快速確定哪些專案是可編輯的。

  • 為步驟重命名將不再會自動執行流程,使您的創作體驗保持流暢。

  • 「連線」窗格將在連線到 Microsoft Excel 檔時自動開啟,其中包含多個工作表,可幫助您快速獲取資料。

 

感謝您的意見回饋! 提交意見回饋時發生錯誤。重試或傳送訊息給我們