Tableau Prep Builder 新增功能

浏览新功能摘要来了解当前支持的版本。

注意:从版本 2019.1.2 开始,Tableau Prep 现在称为 Tableau Prep Builder。

版本 2020.3.1 新增功能

保存和共享工作

将流程输出数据保存到外部数据库

现在,您可以将完整或增量流程结果输出到支持的数据库,并使用干净的、准备好的流程数据创建、替换或附加表数据。Tableau Prep Builder 支持将流程数据保存到以下数据库:

  • Amazon Redshift
  • Microsoft SQL Server
  • MySQL
  • Oracle
  • PostgreSQL
  • Snowflake
  • Teradata

在输出步骤中的“将输出保存到”下拉菜单中,选择“数据库表”。然后,选择要在其中保存流程输出的数据库和表。您还可以输入表名以在数据库中创建新表。字段比较预览显示流程中的字段和表中的字段之间的匹配状态。状态字段显示有关不匹配字段的详细信息。

您还可以添加可以在将数据加载到数据库表之前或之后运行的 SQL 脚本。可以使用这些脚本在运行流程之前创建表数据的副本、添加索引、向数据库表添加数据库约束等。

有关将流程输出保存到表的信息,请参见将流程输出数据保存到外部数据库(版本 2020.3.1 及更高版本)

Tableau 数据提取 (.tde) 文件不再受支持

从版本 2020.3.1 开始,流程输出不再支持 Tableau 数据提取 (.tde) 文件。发布到服务器版本 2020.3 及更高版本、输出到 Tableau 数据提取 (.tde) 文件格式的任何流程都必须转换为 Hyper 数据提取 (.hyper) 文件,否则流程将无法运行。流程输入仍然支持 Tableau 数据提取 (.tde) 文件。

有关创建和发布数据提取的详细信息,请参见创建和发布数据提取及数据源

创建用于通过命令行运行流程的 .json 凭据文件变得更容易

如果您使用命令行运行流程,并连接或输出到服务器或数据库,则现在可以在创建 .json 凭据文件时使用更简化的语法。在以前的版本中,您需要随连接凭据一起指定单独的“inputConnection”和“outputConnection”数组。 从版本 2020.3.1 开始,您不再需要区分“inputConnection”或“outputConnection”。相反,您只需要使用新的“tableauServerConnections”或“databaseConenctions”数组输入一次服务器连接或数据库连接的凭据。

将继续支持使用“inputConnection”和“outputConnection”数组的旧版 .json 凭据文件。

有关详细信息,请参见通过命令行刷新流程输出文件

版本 2020.2.3 新增功能

连接到数据

使用 Snowflake 连接到数据时使用 OAuth 身份验证

现在,当您使用 Snowflake 连接到数据时,可以使用以下任何身份验证方法,就像 Tableau Desktop 一样:

  • 用户名和密码

  • SAML IdP

  • OAuth

有关使用此连接器连接到数据源的详细信息,请参见 Tableau Desktop 帮助中的 Snowflake(Link opens in a new window)

版本 2020.2.2 新增功能

连接到数据

使用 Tableau Server 或 Tableau Online 连接到数据

在以前的版本中,您可以连接到存储在 Tableau Server 或 Tableau Online 上的已发布数据源。现在,如果您有启用了 Tableau Catalog 的数据管理加载项(Link opens in a new window),则还可以搜索并连接到存储在 Tableau Server 或 Tableau Online 中的数据库和表。

只需在“连接”窗格新的“搜索数据”部分选择“Tableau Server”并登录到服务器即可。“搜索数据”对话框将打开,您可以搜索并从精选的数据源中进行选择。

其他元数据(例如数据源说明、数据质量警告和认证)可帮助您找到要查找的数据源,而无需离开 Tableau Prep Builder。您还可以使用右上角的筛选器选项按连接类型、数据质量警告和认证来筛选结果。

如果没有启用了 Tableau Catalog 的数据管理加载项,则只会显示已发布的数据源,您将无法查看元数据。

有关连接到数据的详细信息,请参见连接到发布的数据源(版本 2019.3.1 及更高版本)

使用 Alibaba MaxCompute 连接到数据

如果数据存储在数据仓库中,您现在可以使用 Alibaba MaxCompute 连接到此数据源。有关使用此连接器连接到数据源的详细信息,请参见 Tableau Desktop 帮助中的 Alibaba MaxCompute(Link opens in a new window)

版本 2020.2.1 新增功能

连接到数据

连接到 Salesforce.com 数据

ableau Prep Builder 现在可以连接到 Salesforce 数据,以便您可以清理并准备数据以便在 Tableau 中进行分析。目前不支持使用自定义 SOQL 和创建标准连接。

有关详细信息,请参见连接到 Salesforce 数据(版本 2020.2.1 及更高版本)

使流程数据保持最新

使用增量刷新仅处理最新数据

如果流程数据不断变化,现在可以通过使用增量刷新来仅检索和处理自流程上次运行以来的最新数据行,从而节省时间和资源。只需为流程配置增量刷新参数,指示 Tableau Prep Builder 如何从输入数据中检测和检索新行。您还可以配置当流程在“输出”步骤中运行时更新输出表的方式。

通过“输出”步骤中的新选项,您可以选择将新数据追加到现有表或使用 Tableau Prep Builder 的现有功能,并将表数据替换为新数据。此选项可用于增量刷新和完全刷新类型。

使用 Tableau Prep Conductor 按计划设置和运行流程,或在 Tableau Prep Builder 中或者通过命令行界面以增量方式运行单个流程。

注意:需要 Tableau Server 版本 2020.2 及更高版本(启用了 Tableau Prep Conductor)才能使用增量刷新来计划流程。

有关使用增量刷新设置和运行流程的详细信息,请参见使用增量刷新来刷新流程数据

版本 2020.1.4 新增功能

连接到数据

使用 Impala 连接到数据

就像 Tableau Desktop 一样,您现在可以使用 Impala 轻松连接到较大的数据集。

有关使用 Impala 连接到数据源的详细信息,请参见 Tableau Desktop 帮助中的 Impala(Link opens in a new window)

清理和调整数据

只需单击一下即可转换日期值

为了帮助简化数据清理,Tableau Prep Builder 添加了另一个适用于日期的快速清理菜单。如果需要转换日期值以显示 DATEPART(如年份、月份或日),则可以从新的“转换日期”菜单中选择以下菜单选项之一,而不是编写复杂的字段计算。

有关对日期应用清理操作的详细信息,请参见应用清理操作

保存和共享工作

保持与服务器的连接

每次打开 Prep Builder 时,您不再需要登录到 Tableau Server 或 Tableau Online。现在,Tableau Prep Builder 会在关闭应用程序时记住您的服务器名称和登录信息,以便下次打开应用程序时您已登录到服务器。

这个可以节省时间的选项将帮助您无缝连接以发布数据源或插入保存的流程步骤,并且,如果您需要知道某个功能是否与服务器版本兼容,兼容性警告将立即显示,而无需首先登录到服务器。

有关详细信息,请参见以数据源形式发布

版本 2020.1.3 新增功能

安装和部署 Tableau Prep Builder

支持基于登录名的许可证管理

基于登录名的许可证管理 可帮助您为在 Tableau ServerTableau Online 上具有 Creator 角色的用户管理许可。具有 Explorer 或 Viewer(查看者)角色的用户无法使用此功能。如果将基于角色的订阅与 Tableau ServerTableau Online 结合使用,则可以使用 基于登录名的许可证管理 来简化许可证管理,从而不必使用单独的 Tableau DesktopTableau Prep Builder 产品密钥。您只需要管理本地 Tableau Server 的一个或多个产品密钥,或者,如果是 Tableau Online,您根本无需管理任何产品密钥。

连接到数据

使用初始 SQL 将参数传递到数据源

现在,您可以使用初始 SQL 将参数传递到数据源,以提供有关 Tableau Prep 应用程序、版本和流程名称的更多详细信息。Tableau Prep Builder 支持以下参数:

  • TableauApp - 返回用于访问数据源的应用程序 - Prep Builder 或 Prep Conductor。

  • TableauVersion - 返回应用程序版本号。对于 Tableau Prep Builder,它将返回确切的版本号,例如 2020.1.1。对于 Tableau Prep Conductor,它将返回已启用 Tableau Prep Conductor 的主要服务器版本,例如 2020.1。

  • FlowName - 返回 .tfl 文件的名称。

有关在使用初始 SQL 连接到数据源时使用参数的详细信息,请参见在初始 SQL 语句中包括参数(版本 2020.1.3 及更高版本)

清理和调整数据

使用详细级别 (LOD)、排名和行号计算来清理数据

如果数据聚合级别与所需级别不同,或者您需要跨一组行执行计算,您现在可以使用 FIXED 详细级别 (LOD) 以及 RANK 和 ROW_NUMBER 分析函数计算来创建数据集中所需的数据。

例如,添加 FIXED LOD 计算以更改表中字段的粒度。使用新的 ROW_NUMBER() 分析函数快速查找重复行,或使用新的 RANK() 函数之一来查找具有类似数据的所选行的前 N 个或后 N 个值。

如果希望在构建这些类型的表达式时获得更多指引,您可以使用新的可视化计算编辑器。

有关使用这些计算字段清理数据的详细信息,请参见创建详细级别和排名计算

版本 2020.1.1 新增功能

连接到数据

将流程输入映射回其原始连接

如果使用多个输入来构建流程,则在需要更新或交换连接时,尝试查找用于不同输入的单个表或数据源并不总是显而易见。为了更轻松地查找流程输入和表,我们添加了一个新功能,在“连接”窗格中突出显示所选输入的连接器和表。

只需在“流程”窗格中选择一个或多个输入步骤,相关连接器和表即会在“连接”窗格中突出显示。

有关如何连接到数据以构建流程的详细信息,请参见连接到数据(Link opens in a new window)

清理和调整数据

暂停数据更新以提高性能

每次对数据应用清理操作时,Tableau Prep Builder 都会刷新视图,以便您能够立即看到更改的效果。在构建新流程时,这种持续的反馈可帮助您快速了解接下来要执行的步骤,但有时应用这些更改可能需要一些时间。为了提高性能并更快地应用数据更改,您现在可以暂停这些不断进行的数据更新并批量应用更改。

只需在顶部菜单上选择“暂停数据更新”按钮,Tableau Prep Builder 即会暂停数据更新,并将“配置”窗格视图切换到“列表”视图,以便您能够快速应用更改。

系统将只显示字段元数据,而不是在每次更改时刷新视图。完成更改并希望在字段值上查看结果时,单击“恢复数据更新”按钮以切换回标准数据更新模式。

注意:在暂停数据更新时,将禁用任何需要数据值才能执行任务的清理操作。

有关暂停数据更新以批量应用清理操作的详细信息,请参见暂停数据更新以提高性能

与 Tableau Prep 的版本兼容性

检测并启用不兼容的功能

Tableau Prep Builder 版本 2019.3.1 中,我们添加了警告图标和工具提示,以便您可以在构建流程更轻松地查看时哪些功能与您的 Tableau Server 版本不兼容,帮助您在计划发布流程并按计划运行流程时,做出有关流程中包含的功能的明智决策。

在此版本中,我们在处理可能与服务器版本不兼容的新功能时增加了更大的透明度。

现在,在登录到服务器后, Tableau Prep Builder 可以检测哪些功能与您的 Tableau Server 版本不兼容,并禁用这些功能。 这样,如果您计划发布流程并按计划运行流程,您就不必猜测可以包括哪些功能。

如果仍要使用该功能并使用 Tableau Prep Builder 或通过命令行手动运行流程,则可以直接从菜单中启用该功能。只需单击“使用功能”按钮,该功能将应用于您的流程,并且所有不兼容的功能将启用并可供使用。

Tableau Prep Builder 版本 2019.3.1 中引入的警告选项仍将标识哪些功能与服务器不兼容,以便在想要使用 Tableau Server 中的计划运行流程的情况下,您可以轻松地查找和移除这些功能。

有关处理不兼容功能的详细信息,请参见与 Tableau Prep 的版本兼容性

使流程数据保持最新

发布流程时为云连接器添加或嵌入凭据

在以前的版本中,如果要发布和计划包含云连接器的流程,则需要提前在 Tableau ServerTableau Online 中配置凭据。否则,Tableau Prep Conductor 无法检测您的凭据,并且流程将无法运行。现在,只需几个简单的步骤,即可直接从 Tableau Prep Builder 的“发布”对话框中添加和嵌入云连接器的凭据。

只需登录到您的服务器,并选择“服务器”>“发布流程”。 在“发布流程”对话框中,将显示一条新的警告文本,指出您的输入连接需要身份验证。单击消息中的“编辑连接”链接或“连接”部分中的“编辑”链接,然后在“身份验证”下拉列表中,选择“添加凭据”

另一条消息将确认您的选择。单击“继续”转到 Tableau ServerTableau Online 中的“帐户设置”页面,然后添加凭据。

完成后,返回到 Tableau Prep Builder,单击“完成”,您的新凭据即会自动嵌入到流程中。

有关在发布期间添加云连接器凭据的详细信息,请参见发布流程

版本 2019.4.2 新增功能

连接到数据

使用新的连接器连接到更多数据

在此版本中,我们新增了以下新的数据连接器:

  • Alibaba AnalyticDB for MySQL
  • Alibaba Data Lake Analytics
  • Databricks
  • Kyvos
  • Qubole Presto

有关如何使用这些连接器连接到数据的详细信息,请参见 Tableau Desktop 和 Web 制作帮助的支持的连接器(Link opens in a new window)。有关连接到数据以构建流程的一般信息,请参见连接到数据(Link opens in a new window)

清理和调整数据

将列转置为行变得更容易

当您需要将数据从列转置为行时,现在可以在配置窗格中手动选择字段来转置它们,Tableau Prep Builder 也可以推荐要转置的字段并为您创建转置。这两个选项都会自动生成转置步骤,以便您可以快速执行任何其他转置操作,比如重命名转置的字段或对其他字段进行转置。

若要从配置窗格中手动将列转置为行,只需选择要转置的字段,然后右键单击或按住 Ctrl 单击 (MacOS),并从菜单中选择“将列转置为行”以创建新的转置步骤并转置字段。

如果 Tableau Prep Builder 检测到可转置的字段,则配置窗格工具栏中将显示一个建议选项。单击工具栏中的灯泡 图标并选择转置建议。该建议显示它将转置哪些字段。只需单击“应用”即可生成“转置”步骤并转置字段。

有关转置数据的详细信息,请参见转置您的数据。有关如何使用建议来清理数据的详细信息,请参见使用建议应用清理操作(版本 2018.3.2 及更高版本)

其他增强功能

查看有关长时间运行的操作的反馈

为了在处理大型数据集或流程时为您提供更高的可见性,我们在“流程”窗格顶部新增了一个进度指示器,以在 Tableau Prep Builder处理数据时为您提供状态更新。现在,您可以更清楚地了解 Tableau Prep Builder 正在幕后执行的操作,因此您不再需要怀疑您的数据是否仍在处理中,或者是否发生了问题。

支持基于登录名的许可证管理

基于登录名的许可证管理 可帮助您为在 Tableau ServerTableau Online 上具有 Creator 角色的用户管理许可。具有 Explorer 或 Viewer(查看者)角色的用户无法使用此功能。如果将基于角色的订阅与 Tableau ServerTableau Online 结合使用,则可以使用 基于登录名的许可证管理 来简化许可证管理,从而不必使用单独的 Tableau DesktopTableau Prep Builder 产品密钥。您只需要管理本地 Tableau Server 的一个或多个产品密钥,或者,如果是 Tableau Online,您根本无需管理任何产品密钥。

版本 2019.4.1 新增功能

连接到数据

连接到云中的更多数据

在此版本中,我们新增了以下云连接器:

  • Box
  • DropBox
  • Google Drive
  • OneDrive

如果您计划将流程发布到 Tableau Server 或 Tableau Online,则可能需要进行其他配置来保存这些连接器的凭据。有关连接到云数据连接器的详细信息,请参见连接到云数据源

其他增强功能

与 Tableau 共享使用情况数据

Tableau 会收集数据,帮助我们了解产品的使用情况,以便改进现有功能并开发新的功能。所有使用情况数据均依据 Tableau 隐私政策(Link opens in a new window)收集和处理。 但是,如果您不想参与,则可以选择退出。

选择退出选项已更改。默认情况下已启用使用情况数据收集。如果您不想参与,请从安装程序、“自定义安装程序”(MacOS) 对话框或在安装之后从“帮助”菜单中选中“不发送产品使用情况数据”复选框。

有关详细信息,请参见 Tableau Desktop 和 Tableau Prep 部署指南中的关闭使用情况报告(Link opens in a new window)

不再为 MacOS 自动安装默认数据库驱动程序

在 Mac 上安装 Tableau Prep Builder 时,我们只会自动安装 PostgreSQL 数据库驱动程序。如果您需要其他驱动程序来连接到数据,可以从驱动程序下载(Link opens in a new window)页面安装它们。

版本 2019.3.2 新增功能

构建和组织流程

只需单击一下,即可在所需的位置插入步骤

在以前的版本中,您可以在流程中的现有步骤后插入清理步骤,并且流程将向右扩展来为新步骤腾出空间。但是,在现有步骤后添加任何其他步骤类型会导致创建一个流程分支,然后您必须通过移除和添加流程线来重新连接该分支。

在此版本中,我们添加了一个新的插入菜单,使您只需单击一次便可在现有步骤之间插入任何步骤类型(甚至复制的步骤)。只需将光标悬停在要插入步骤的流程线上,并使用新的“插入”菜单选择并插入所需的步骤类型,即可在所需的位置插入。

注意: “添加”菜单中的“插入步骤”菜单项已转移到这个新菜单中。此选项不可用于“输入”和“输出”步骤类型。

有关在流程中添加和插入步骤的详细信息,请参见添加或插入步骤

使用流程导航器轻松查看大型流程

处理大型流程时,来回滚动以查找和修复步骤或更改可能很困难。新的流程导航工具显示在流程窗格的右下角。此工具是整个流程的微缩图像。您可以使用它放大和缩小该图像,单击图像的某些部分直接导航到流程的该部分,调整流程大小,以及执行其他操作。如果不想显示该工具,只需单击一下便可将其最小化或还原。

有关连接到数据并构建流程的详细信息,请参见使用流程导航工具

检查和筛选数据

使用自定义数据角色对类似值进行分组

Tableau Prep Builder 版本 2019.3.1 中,我们引入了使用数据集中的字段值创建自己的自定义数据角色的功能。在此版本中,您现在可以使用这些自定义数据角色,根据拼写和发音对字段中的值进行分组,以便通过匹配无效值并将其替换为最接近的有效值来自动修复无效值。

只需将自定义数据角色应用于字段,并且任何与标准值不匹配的值都标有红色感叹号。

为了修复无效值,您可以单击字段上的“建议” 图标,将建议应用于组并将无效值替换为有效值,或者从“更多选项”菜单中选择“分组和替换”>“拼写”“发音 + 拼写”以选择修复无效值的方式。

有关创建和使用自定义数据角色的详细信息,请参见按数据角色对类似值进行分组

清理和调整数据

使用新列表视图对字段应用清理操作

目前,您可以在配置窗格、结果窗格或数据网格中应用清理操作。但是,一次可以看到的字段数受屏幕的大小所限。为了更轻松地扫描所有字段和执行操作,我们添加了一个新的列表视图,使您能够配置窗格或结果窗格转换为列表。选择此选项后,此视图状态将在流程的所有步骤中保持不变,但您可以随时对其进行更改。

在此视图中,您可以将像 “移除”“只保留”这样的操作应用于多个字段,或者快速应用像“重命名字段”“复制字段”这样的清理操作。您还可以通过“更多选项” 菜单应用其他清理操作,但像“分组和替换”“筛选”“拆分值”这样的操作会将您返回到配置窗格或结果窗格视图来完成操作。

有关在列表视图中清理字段的详细信息,请参见选择视图

通过可重用的步骤来利用您的工作和其他人的工作

如果您通常对数据反复执行相同的操作,则可以选择一个或多个流程步骤及其关联的操作或整个流程,并将其保存以在您创建和管理的其他流程中重复使用。您可以将步骤保存在本地,或将其发布到 Tableau ServerTableau Online 以与其他人共享。

若要创建可重用的步骤,只需选择要保存的步骤,右键单击并选择“将步骤另存为流程”,然后选择是将步骤保存到本地文件还是服务器。 将流程步骤发布到服务器时,系统会自动添加“已保存的步骤”标记,以便以后能轻松查找流程步骤。

保存后,可以打开并插入任何流程。在流程窗格画布中右键单击或按住 Ctrl 并单击 (MacOS),并选择“插入流程”,或从顶部菜单中选择“编辑”>“插入流程”。 在“添加流程”对话框中,您可以从文件或服务器中选择并插入保存的流程步骤。 该对话框会自动筛选以显示带有“已保存的步骤”标记的所有流程,但您可以更改筛选器并插入您有权访问的任何流程。

所选流程将添加到流程窗格中,然后您可以在流程中所需的步骤移动和连接步骤。有关创建和使用可重用流程步骤的详细信息,请参见清理和调整数据

保存和共享工作

从命令行运行流程时禁用 Mac OS 的钥匙串对话框

在 MacOS 通过命令行运行流程时,我们无需用户在每次流程运行时手动输入其 MacOS 钥匙串凭据。

有关详细信息,请参见通过命令行刷新流程输出文件中的“禁用 SSL 验证 (MacOS)”命令选项。

版本 2019.3.1 新增功能

连接到数据

使用 Google BigQuery 连接到数据

使用 Google BigQuery 连接到云中的更多数据。与 Tableau Desktop 一样,您现在可以连接到 Google BigQuery 中存储的数据,并将流程发布到 Tableau Server 和 Tableau Online(如果已配置 Google Oauth 连接)。

注意: Tableau Prep Builder 当前不支持使用 Google BigQuery 自定义属性。此外,包含 Google BigQuery 连接器的流程也不能通过命令行运行。作为替代,请手动运行流程,或者在 Tableau ServerTableau Online 中按计划运行流程。

有关如何连接到 Google BigQuery 的详细信息,请参见 Tableau Desktop 帮助中的 Google BigQuery(Link opens in a new window)。有关连接到数据的详细信息,请参见连接到数据(Link opens in a new window)

为流程输入连接到发布的数据源

无论是从 Tableau Desktop 中还是从 Tableau Prep Builder 中以输出形式生成发布的数据源并将其发布到 Tableau ServerTableau Online,您现在都可以连接到发布的数据源,并使用其作为流程的输入数据源。

只需从“连接”窗格中选择“Tableau Server”,然后登录到服务器或站点。

登录后,将显示可用数据源的列表。选择数据源,或使用搜索选项查找数据源并将其拖到流程窗格以启动流程。

注意:当前不支持包括用户筛选器的已发布数据源。

有关连接到数据和构建流程的详细信息,请参见连接到数据(Link opens in a new window)

检查和筛选数据

创建自定义数据角色

您可以使用数据角色来标识和验证字段值。在以前的版本中,Tableau Prep Builder 提供了一组可应用于字段来快速标识无效值的标准数据角色。在此版本中,您现在可以使用数据集中的字段值创建自己的自定义数据角色,然后将其发布到 Tableau ServerTableau Online 以在流程中使用它们或与他人共享您的数据角色,从而比以往更轻松地标识和清理无效值。

只需选择要使用的字段,并从“更多选项” 菜单中选择“以数据角色形式发布”

发布自定义数据角色之后,一旦登录到在其中发布了自定义数据角色的站点或服务器,您就可以从新的“自定义”菜单选项中选择该角色,将其应用于您的字段。

您可以在 Tableau ServerTableau Online 上查看及管理发布的自定义数据角色。查看发布到站点或服务器的所有自定义数据角色、将其移动到其他项目、更改权限或将其删除。

有关创建和使用自定义数据角色的详细信息,请参见创建自定义数据角色(版本 2019.3.1 及更高版本)(Link opens in a new window)

清理和调整数据

在流程中使用 R 和 Python 脚本

您现在可以使用 R 和 Python 脚本来执行更复杂的清理操作,或者在流程中并入预测建模数据。数据使用 Rserve 或 TabPy 通过 R 或 Python 脚本步骤以输入形式从流程中传递,然后以您可以使用 Tableau Prep Builder 的功能和函数继续清理的输出数据的形式返回。

有关如何在流程中包括脚本的详细信息,请参见在流程中使用 R 和 Python 脚本(Link opens in a new window)

保存和共享工作

在构建流程时找出不兼容的功能

Tableau Prep Builder 每个月都会发布新版本。如果新版本中引入了新功能或连接器,并且您打算将流程发布到较旧版本的 Tableau ServerTableau Online,则可能会出现兼容性问题。当前您可以在发布流程时看到是否有不兼容的功能,但在此时您已经构建了流程,因此返回删除不兼容的功能需要时间。

在此版本中,兼容性通知更加透明。您现在可以在构建流程时看到任何不兼容的功能,这样您就可以立即做出有关所包含功能的明智决策。

只需登录到 Tableau Server,在您构建流程时,如果选择的功能在您的 Tableau Server 版本中不受支持,就会显示通知。单击画布右上角的“通知”可查看所有通知和错误,或将光标悬停在流程窗口中步骤或注释的通知上以查看通知详细信息。

单击“在流程中查看”链接可快速导航到警告与之关联的步骤、注释、字段或更改。步骤和更改都标有通知图标并突出显示,因此您可以快速查找并解决问题,并继续处理流程。

有关解决兼容性问题的详细信息,请参见与 Tableau Prep 的版本兼容性(Link opens in a new window)

使流程数据保持最新

Tableau 数据管理加载项包括 Tableau Prep Conductor

Tableau Prep Conductor 包括在单独许可的 Tableau Server 或 Tableau Online 数据管理加载项中。有关详细信息,请参见许可 Tableau Prep Conductor

将流程发布到Tableau Online

您现在可以将流程发布到 Tableau Server 或 Tableau Online,并按计划运行流程以使数据保持最新。Tableau Online 不支持直接连接到本地数据源。如果将流程发布到连接到本地数据源的 Tableau Online,您可以编辑连接以自动将连接转换为发布的数据源。

有关将流程发布到 Tableau Online 的详细信息,请参见将流程发布到 Tableau Server 或 Tableau Online(Link opens in a new window)

其他增强功能

Tableau Prep Builder 现在提供意大利语版本

现在可以采用 11 种不同的语言之一配置用户界面(菜单、消息等)。有关配置显示语言的详细信息,请参见 Tableau Desktop 和 Tableau Prep Builder 部署指南中的设置显示语言(Link opens in a new window)

版本 2019.2.3 新增功能

检查和筛选数据

选择要筛选的特定值

借助新的“选定值”筛选器,您现在可以选取和选择要为字段保留或排除的值,即使这些值不在样本中。在“配置”窗格、“结果”窗格或数据网格中,单击“更多选项” 按钮,然后选择“筛选”>“选定值”

这个新的可视指示器允许您选择要保留或排除的值,并直观地显示您已选定的值。如果正在处理数据样本,并且想要包括或排除不在所处理的样本中的值,只需添加所需的值,Tableau Prep Builder 也会将保留或排除选项应用于这些新值。

有关筛选字段值的详细信息,请参见检查您的数据(Link opens in a new window)

通过单击复制字段

在以前的版本中,如果想要在一个字段上试验清理操作但不想更改原始数据,您将必须编写一个计算来复制该字段。现在,您只需单击便可轻松地复制字段。选择要复制的字段,然后从“更多选项”菜单中选择“复制字段”

系统即会使用相同名称和修饰符创建一个新字段,并将其放在“配置”窗格、数据网格或“结果”窗格的最左侧。例如,“Ship Date -1”(发货日期 -1)。

有关复制字段和其他清理选项的详细信息,请参见清理和调整数据(Link opens in a new window)应用清理操作(Link opens in a new window)

清理和调整数据

使用模糊匹配和清理建议修复无效的数据角色值

可以使用数据角色来快速确定无效的字段值。分配数据角色之后,您可以使用两个模糊匹配算法(“拼写”“拼写 + 发音”)之一对数据角色的无效值进行快速分组,并将其与适用于该数据角色的类似标准化值匹配。

除了为您的字段建议数据角色之外,Tableau Prep Builder 现在还可使用“拼写”“拼写 + 发音”算法建议如何为分配给数据角色的字段修复无效值。如果检测到建议的修复,则配置卡上将出现一个灯泡 图标。单击该图标并应用建议的更改,以自动对无效值进行分组,并将其替换为适用于该数据角色的类似标准化值。

此功能仅可用于以下数据角色:

  • 机场
  • 城市
  • 国家/地区
  • 郡/县
  • 州/省/市/自治区

有关将数据角色应用于字段并使用分组和替换修复数据角色的无效值的详细信息,请参见使用数据角色验证数据(Link opens in a new window)

版本 2019.2.2 新增功能

连接到数据

使用其他数据库连接器 (ODBC) 连接到更多数据

如果需要连接到“连接”窗格中未列出的数据源,您可以使用支持 SQL 标准并实现 ODBC API 的“其他数据库 (ODBC)”连接器连接到任何数据源。使用“其他数据库 (ODBC)”连接器连接到数据的工作方式与您在 Tableau Desktop 中使用该连接器的方式类似,但有一些不同之处:

  • 您只能使用 DSN(数据源名称)选项进行连接。
  • 若要在 Tableau Server 中发布并运行流程,必须使用匹配的 DSN 配置服务器。
  • Windows 和 MacOS 上的连接体验是一致的。不支持 ODBC 驱动程序 (Windows) 的提示连接属性。
  • Tableau Prep Builder 仅支持 64 位驱动程序。

有关使用“其他数据库”ODBC 连接器连接到数据的详细信息,请参见连接到数据(Link opens in a new window)

在连接到数据时指定初始 SQL 命令

在连接到支持初始 SQL 命令的数据库时,您现在可以指定初始 SQL 命令,该命令将在进行数据库连接时运行。例如,在连接到 Amazon Redshift 时,您可以输入 SQL 语句,以便在连接到数据库时应用筛选器,就像在“输入”步骤中添加筛选器一样。SQL 命令将在数据抽样之前应用,并加载到 Tableau Prep Builder 中。

如果更改初始 SQL 命令并刷新“输入”步骤,则会再次运行初始 SQL 命令,并更新“输入”步骤。在运行流程时,初始 SQL 命令将在处理所有数据之前运行,如果在 Tableau Server 上计划流程,则初始 SQL 将在每次数据加载时运行。

有关详细信息,请参见连接到数据(Link opens in a new window)

注意:Tableau Prep Builder 中的初始 SQL 尚不支持参数。

检查和筛选数据

在清理数据时仅保留所需的字段

在以前的版本中,您可以通过在连接到数据后清除复选框来移除“输入”步骤中不需要的字段,在清理或操作步骤中,您可以选择一个或多个字段,并且只需右键单击便可将其移除。现在,您可以在“配置”窗格或数据网格中选择一个或多个字段,并右键单击以仅保留选定字段和移除所有其他字段。

有关详细信息,请参见保留或移除字段(Link opens in a new window)

清理和调整数据

重新排列流程中的步骤

您是否曾经构建过复杂的大型流程,但 Tableau Prep Builder 的默认布局让流程很难执行?现在,您可以在画布中选择并移动步骤,以对您有意义的方式组织流程。例如,您可以修复交叉的流程线条,移动流程步骤以清理额外的空白,或者重新排列流程步骤以显示清晰的事件序列。

下面的流程混乱不清,难以执行:

使用这项新功能,您可以在流程中选择一个或多个步骤,并将其向上、向下、向左或向右拖放到所需位置。

注意:存在一些限制,并且无法将流程步骤移到会中断从左到右处理流程的位置。将流程步骤拖到允许的位置时,将显示一个橙色的框。如果不允许该位置,则不会显示橙色框,当您尝试放置步骤时,它们将返回到原始位置。

有关详细信息,请参见构建和组织流程(Link opens in a new window)

版本 2019.2.1 新增功能

连接到数据

使用新的数据库连接器连接到更多数据

我们增加了更多的连接器来帮助您连接到数据和清理数据。现在,您可以连接到存储在以下数据库中的数据:

  • Amazon Athena
  • 其他数据库 (JDBC)

有关连接到特定连接器的详细信息,请参见 Tableau Desktop 和 Web 制作帮助的支持的连接器(Link opens in a new window)。有关连接到数据以构建流程的详细信息,请参见连接到数据(Link opens in a new window)

使流程数据保持最新

发布流程时查看文件安全列表位置

您可以将流程发布到 Tableau Server 以自动按计划运行流程,并使用 Tableau Prep Conductor 刷新流程输入或输出。如果流程包括的输入或输出具有与网络共享的连接,您的系统管理员必须提前在组织的安全列表中加入文件位置,否则当您尝试在 Tableau Server 中运行流程时,流程将失败。

在 Tableau Prep Builder 版本 2019.2.1 及更高版本中,如果发布的流程包括连接到网络共享的输入或输出步骤,则在需要将文件包括在组织安全列表的情况下,您将在发布时收到通知。若要查看安全列出的位置,只需单击警告消息中的链接,然后将文件移动到显示的位置之一。

有关发布流程的详细信息,请参见将流程发布到 Tableau Server 或 Tableau Online(Link opens in a new window)有关如何将文件位置添加到组织安全列表中的详细信息,请参见步骤 4:安全列表输入和输出位置(Link opens in a new window)

其他增强功能

为用户界面选择 10 种不同的语言

Tableau 增加了两种额外的语言,您可以从中进行选择来配置用户界面(菜单、消息等):

  • en_GB(英国英语)

  • zh_TW(繁体中文)

有关配置显示语言的详细信息,请参见 Tableau Desktop 和 Tableau Prep Builder 部署指南中的设置显示语言(Link opens in a new window)

使用流程缩略图视图在 Tableau Server 上快速查找流程

将流程发布到 Tableau Server 时,您现在可以切换到缩略图视图并查看流程布局的图形表示形式,以帮助您一眼快速地找到流程。

版本 2019.1.4 新增功能

连接到数据

使用新的数据库连接器连接到更多数据

我们增加了更多的连接器来帮助您连接到数据和清理数据。现在,您可以连接到存储在以下数据库中的数据:

  • SAP HANA
  • Azure SQL 数据仓库
  • MariaDB

注意:使用 SAP HANA 连接到数据时,在打开流程并使用初始 SQL 查询不支持的连接时提示输入变量和参数。

有关连接到特写连接器的信息,请参见 Tableau Desktop 和 Web 制作帮助的支持的连接器(Link opens in a new window)部分中的连接详细信息。有关连接到数据以构建流程的详细信息,请参见连接到数据(Link opens in a new window)

清理和调整数据

按数据角色对字段中的类似值进行分组

Tableau Prep Builder 版本 2018.2.3 中,我们引入了数据角色来帮助您对字段值进行标准化,并快速查找无效的值。现在,如果为字段分配数据角色,您可以使用该数据角色,通过数据角色定义的标准值来匹配值和对值进行分组。只需为字段分配数据角色,然后从“分组和替换”菜单中选择“数据角色匹配”。此新选项随后将根据拼写和发音将无效值与最相似的有效值匹配。

举例来说,如果有一个列出国家/地区(例如 Saint Martin 和 Saint Maarten)的字段,并且您为该字段分配“国家/地区”数据角色,则您可以使用新的“数据角色匹配”选项对字段进行分组,并将这些值映射到标准化数据角色值“Saint-Martin”。如果数据集中没有值的标准化拼写,则 Tableau Prep Builder 会自动为您将其添加到组中,并使用此标准值对匹配值进行分组。

此功能适用于以下数据角色,当前仅支持美国英语。

  • 机场
  • 城市
  • 国家/地区
  • 郡/县
  • 州/省/市/自治区

有关将为字段分配数据角色或使用数据角色对值进行分组的详细信息,请参见使用数据角色验证数据(Link opens in a new window)

在对字段值进行分组时调整结果

使用“分组和替换”清理选项按“拼写”“发音”对类似值进行分组时,您现在可以使用字段上的简单滑块来调整分组参数的严格程度,从而使您能更大程度地控制结果。

从 5 个阈值设置中进行选择,以控制组中包括的值数量,以及创建的组数量。

有关使用模糊匹配对字段进行分组的详细信息,请参见编辑字段值(Link opens in a new window)

版本 2019.1.3 新增功能

连接到数据

基于表关系快速联接数据

当连接到的数据库包含定义了表关系的表时(例如 Vertica 或 Microsoft SQL Server)时, Tableau Prep Builder 现在可以检测并显示此信息。

例如,现在可以看到表中的哪些字段是唯一标识符,哪些字段是字段(外键),以及这些字段的任何相关表。

一个名为“链接键”的新列将显示在“输入”窗格中,唯一标识符字段、相关字段或两者的组合旁边会有图标。

“链接键”字段中,单击相关字段或组合字段以查看相关表,然后只需单击一次便可将相关表添加到流程或创建联接。

创建联接时,Tableau Prep Builder 将使用定义的字段关系来联接表,并显示定义联接子句的字段的预览。在这里,您可以单击新的“联接”步骤,以根据需要清理和编辑联接条件。

对于包含相关字段的表,您还可以查看所有相关表的列表,并通过“流程”窗格的菜单创建联接。从“添加联接”菜单选项中,从列表中选择要联接的表, Tableau Prep Builder 将基于组成两个表之间的关系的字段创建联接。

此功能可用于定义了表关系的任何受支持的数据库连接器。有关使用“链接键”来添加或联接表的详细信息,请参见在“输入”步骤中联接数据(版本 2019.1.3 及更高版本)(Link opens in a new window)

清理和调整数据

在工具栏中查看所有清理建议

如果 Tableau Prep Builder 检测到并为您的字段提供了清理建议,则该字段的“配置”卡上会显示一个灯泡 图标。现在,您可以通过工具栏在一个方便的列表中查看所选步骤中任何字段的所有清理建议。

只需单击列表中的某项,Tableau Prep Builder 即可转到该字段,您可以在其中应用建议的更改。有关清理建议的详细信息,请参见使用建议应用清理操作(版本 2018.3.2 及更高版本)(Link opens in a new window)

注意:此选项不可用于“联接”、“输入”和“输出”步骤类型。

其他增强功能

查看流程中的特定更改

现在,通过单击“流程”窗格中某个步骤上的更改图标,或单击“配置”或“结果”窗格中的某个配置卡,您可以快速查找在流程中进行的特定更改。只需单击表示要查找的更改的图标,然后从更改列表中选择注释。更改将在“更改”窗格、“配置”“结果”窗格以及数据网格(如果适用)中突出显示。

有关查看所做更改的详细信息,请参见查看您所做的更改(Link opens in a new window)

通过“开始”页面管理最近查看的流程

当您保存流程并关闭 Tableau Prep Builder 时,该流程的缩略图将保存到“开始”页面,以便您可以快速找到最常用的流程。但作为一个数据准备摇滚巨星,您的“开始”页面可能很快就会拥挤不堪!为了帮助您快速找到所需的流程并在完成流程处理时减少杂乱程度,我们向“开始”页面添加了一些新功能。

  • 流程缩略图上改进的图形可更准确地表示流程布局,从而帮助您一眼就能找到流程。

  • 如果图形未提供足够的信息,请将鼠标指针悬停在一个流程缩略图上,以立即查看该流程的输入和输出详细信息,以及其上次打开时间。

  • 通过从“开始”页面中移除不再需要的流程来清理杂乱情况。此选项仅从“最近的流程”视图中移除流程,而不会删除流程。

版本 2019.1.2 新增功能

使流程数据保持最新

将流程计划为在 Tableau Server 中自动运行

将新的数据管理加载项添加到 Tableau Server 2019.1 和更高版本,并且您可以使用 Tableau Prep Conductor 来计划和管理流程运行。将流程发布到 Tableau Server,然后安排任务运行流程,并自动更新流程输入和输出。使用错误和通知选项以及管理视图来跟踪和管理流程处理运行状况。

有关详细信息,请参见使流程数据保持最新(Link opens in a new window)

帮助设计

进行更新了来帮助您导航内容,包括一个新的右侧菜单,用于快速扫描和选择页面上的不同主题。

版本 2019.1.1 新增功能

清理和调整数据

将行转置为列

如果您使用交叉表或电子表格中的数据,则其格式可能不是可在 Tableau 中轻松进行分析所需的格式。有时,您的数据可能有多个需要转换为行的数据列,或者您的列较少,但数据值却表示多个事物。

为了比以往更轻松地调整数据,您现在可以选择适合自己的转置选项。在转置步骤中,您现在可以选择以下选项之一:

  • 列转置为行:将一个或多个字段拖到“转置的字段”窗格以将列转置为行。

  • 行转置为列:将字段拖到“转置的字段”窗格以使用字段值创建新列,然后拖入字段以用于填充这些列,并选择所需的列聚合方式。

有关详细信息,请参见转置您的数据(Link opens in a new window)

使用通配符搜索来转置字段

如果有包含大量字段的数据集,或者在一段时间内频繁添加或移除字段,您可以在将列转置为行时使用通配符搜索,以便根据通配符模式匹配来即时转置数据。如果添加或移除了与模式匹配的新字段,Tableau Prep Builder 会在运行流程时检测到架构更改,并且转置结果会自动更新。

若要使用通配符搜索来转置数据,请添加一个转置步骤,然后单击“单击此处创建通配符转置”链接打开通配符搜索字段。输入通配符搜索模式以查找名称与所输入的值匹配的字段。单击“搜索选项...”按钮选择是否要包括其中包含所输入模式、以该模式开头或以该模式结尾的字段。

按 Enter 应用模式,Tableau Prep Builder 将自动转置字段。

有关详细信息,请参见转置您的数据(Link opens in a new window)

使用说明为更改添加上下文

“更改”窗格中为任何更改添加说明,以便为您的清理操作添加上下文。只需打开“更改”窗格,右键单击或者按住 Ctrl 并单击 (Mac) 列表中的某项更改,并选择“添加说明”。然后在出现的文本字段中键入说明。

说明将出现在为带有注释 图标的更改生成的文本的下方。

有关详细信息,请参见为流程步骤和清理动作添加说明(Link opens in a new window)

使用清理建议来快速拆分固定宽度文本文件中的数据

在以前的版本中,如果您使用存储在固定宽度文本文件(即包含的数据值字符串受固定字符限制所限的文件)的数据,则您必须对文件执行一些预清理操作,或者使用复杂的计算将值分隔出来,放在单独的列中。

现在,当您连接到这种类型的数据源时,清理建议功能将检测到这些类型的列,并为您提供拆分选项建议。只需连接到数据源,然后添加清理步骤即可。在“配置”窗格中,单击配置卡上的建议图标。

单击“应用”以拆分字段,然后检查结果并根据需要清理或重命名每个新字段。

有关详细信息,请参见使用建议应用清理操作(版本 2018.3.2 及更高版本)(Link opens in a new window)

版本 2018.3.3 新增功能

连接到数据

添加新文件时自动刷新输入并集

如果在输入步骤中使用通配符模式来查找和合并 Microsoft Excel 或文本 (.csv) 文件,则在下次您打开流程或通过命令行运行流程时,添加到同一文件夹中、与模式匹配的新文件会自动包括在并集中。

注意:打包流程文件 (.tflx) 不会自动获取新文件,因为文件已与流程打包在一起。若要包括新文件,请打开流程文件 (.tfl) 以获取新文件,然后重新打包流程以包括新文件数据。

有关在输入步骤中合并文件的详细信息,请参见在输入步骤中合并文件和数据库表(Link opens in a new window)

清理和调整数据

重用清理操作

在清理数据时,您通常会在整个流程中反复执行相同的清理操作或动作。为了使数据的清理和调整更加高效,我们添加了在整个流程中复制和粘贴这些操作或动作的功能,这样您就能执行清理操作或动作一次,然后在需要的地方重用该操作或动作。

  • 复制一个或多个步骤以在流程的另一个区域中使用它们。此选项不可用于包括通配符并集的输入步骤。

  • 从一个步骤的“更改”窗格中复制操作,然后将其粘贴在另一个步骤的“更改”窗格中,从而在该步骤中应用该相同操作。

  • 将一个操作从“更改”窗格拖放到“配置”窗格中的一个字段,以将该操作应用于其他字段。您也可以在“更改”窗格中复制操作,并将其拖放到步骤中的其他字段,以将该操作应用于多个字段。此选项不可用于影响多个字段(例如计算字段)的操作。

有关详细信息,请参见清理和调整数据(Link opens in a new window)

移除额外的空格

我们添加了两个新的快速清理操作,帮助您移除字段值中额外的空格:

  • 移除额外的空格:将此选项与文本字段值结合使用以移除前导和尾随空格,以及将字符之间的额外空格替换为单一空格。

  • 移除所有空格:使用此选项从文本值中移除所有空格,包括前导和尾随空格以及字符之间的任何空格。

有关详细信息,请参见编辑字段值(Link opens in a new window)

检查和筛选数据

快速查找字段在流程中的使用之处

在构建流程时,如果未看到所有期望的字段值,您现在可以轻松地跟踪字段的每处使用位置 - 甚至能追溯到字段的来源。只需在一个步骤的“配置”窗格或“结果”窗格中选择一个字段,流程窗格中的步骤将突出显示。这将向您展示字段在流程中所采用的路径,从而能够比以往更为轻松地排查流程的故障。

有关详细信息,请参见在流程中跟踪字段(Link opens in a new window)

其他增强功能

同时打开多个 Tableau Prep Builder 窗口

在 Windows 中或 Mac 上,单击“文件”>“新建”打开一个新流程窗口,而不是替换您正在其中工作中的当前窗口。打开流程文件(.tfl 或 .tflx)时也将打开一个新窗口,这样您就能轻松地同时处理或比较多个流程。

安装之后关闭使用情况报告

为了帮助我们改进 Tableau Prep Builder,您可以与我们共享使用情况模式数据。我们决不会收集任何具体用户数据,只会收集任何匿名使用情况数据。例如,数据源连接类型(例如 .csv、sql 或 Amazon Redshift)、大数据集与小数据集、流程中的步骤数或使用的操作类型(但不会收集数据细节,例如步骤名称或使用的公式),诸如此类。

您的数据是机密的,我们决不会与任何人共享此信息。但如果要在安装之后关闭此选项,您可以这样做。转到“帮助”>“设置和性能”,并单击“共享使用情况数据以改进 Tableau Prep Builder”以清除复选标记。有关详细信息,请参见 Tableau Desktop 和 Tableau Prep Builder 部署指南中的使用情况报告(Link opens in a new window)

版本 2018.3.2 新增功能

清理和调整数据

使用清理建议快速提高数据质量

为了帮助您快速找出并修复数据问题,Tableau Prep 现在可以检查数据字段并提出更改建议,您可以进行这些更改来修复问题。Tableau Prep 会检查您的数据字段,如果确定了建议的更改,字段的“配置”卡上会出现一个灯泡图标。

单击灯泡图标可查看建议的更改,然后将鼠标指针悬停在建议卡上并单击“应用”以将更改自动应用到字段。更改记录在“更改”窗格中,并且可随时移除。

在下面的示例中,Tableau Prep 将字段值确定为 URL,并建议为字段应用数据角色来帮助确定无效的值。

除“输入”、“输出”和“联接”步骤类型外的所有步骤类型中提供了此功能。此版本中的建议类型包括:

  • 数据角色
  • 筛选
  • 将无效值替换为 Null 值
  • 移除字段
  • 剪裁空格

有关详细信息,请参见使用建议应用清理操作(版本 2018.3.2 及更高版本)

其他增强功能

通过命令行运行流程时更加灵活

通过命令行运行流程时,如果您连接到数据库或将输出文件发布到服务器,则需要一个包括所有必需凭据的凭据 .json 文件。在过去的版本中,如果只连接到数据库或将流程输出发布到服务器,您仍然需要在凭据 .json 文件中包括空数组,否则流程将会失败。

现在,您不再需要在凭据 .json 文件中包括空数组。举例来说,如果只连接到数据库,您不再需要在 .json 文件中包括 outputConnection 数组。

有关如何通过命令行运行流程的详细信息,请参见通过命令行刷新流程输出文件

性能改进

为了帮助您更快更高效地使用流程,我们增强了以下功能:

  • 关闭产品时会立即归还 Tableau Prep 使用的内存空间。

  • 如果遇到意外错误,您现在可以重试操作或过程以使您保持在流程中。

  • 加载数据或在流程中查看数据时性能提高,可缩短处理时间。

  • 如果连接到以下连接器,您现在可以使用搜索字段来快速查找架构:
    • Amazon EMR Hadoop Hive
    • Cloudera Hadoop
    • Hortonworks Hadoop Hive
    • MapR Hadoop Hive
    • Presto
    • Spark SQL

早期版本新增功能

版本 2018.3.1 新增功能

安装和部署 Tableau Prep

更改默认存储库位置

默认情况下,当您安装 Tableau Prep 时,“我的 Tableau Prep 存储库”自动安装在计算机上的您的“文档”文件夹中。但如果您可存储流程和数据源的位置存在相关限制,您现在可以在安装 Tableau Prep 之后将“我的 Tableau 存储库”转移到其他目录。

若要移动该目录,请打开 Tableau Prep,然后从顶部菜单中选择“文件”>“存储库位置”。选择要将存储库转移到其中的文件夹。

有关详细信息,请参见 Tableau Desktop 和 Tableau Prep 部署指南中的更改“我的 Tableau Prep 存储库”位置(Link opens in a new window)

连接到数据

清理存储在 PDF 文件中的数据

分析存储在 PDF 文件中的数据可能很难处理。现在您可以直接连接到 PDF 文件并使用 Tableau Prep 清理数据。

有关如何连接到 PDF 文件中的数据的详细信息,请参见 Tableau Desktop 帮助中的 PDF 文件(Link opens in a new window)

注意:数据连接器不向后兼容。包括这些连接器的流程可在以前版本的 Tableau Prep 中打开,但除非移除这些数据连接器,否则将会出错或无法运行。

适用于数据库表的通配符并集

如果要处理存储在单个数据源中的数据库表,您现在可以使用通配符搜索在输入步骤中合并表。随后,您可以使用与在“输入”步骤中合并多个文件相同的步骤,在“输入”步骤中包括选定表中的所有数据。

若要使用这种类型的并集,各个表必须位于同一数据源中,并且您必须连接到支持通配符并集的数据源。

以下数据源支持这种类型的并集:

  • Amazon Redshift

  • Microsoft SQL Server

  • MySQL

  • Oracle

  • PostgreSQL

有关详细信息,请参见在输入步骤中合并文件和数据库表(Link opens in a new window)

清理和调整数据

将字段值替换为 Null

如果有要包括在分析中的数据行,但想要排除特定字段值,您可以将这些值更改为 Null 值。只需选择要替换的字段值,然后右键单击(在 Mac 上按住 Ctrl 单击)所选的值,并从菜单中选择“替换为 Null”

有关替换字段值的详细信息,请参见编辑字段值

在任何步骤中应用清理操作

修复流程中的问题更加高效。现在,如果您在联接、合并、转置或聚合时发现数据中的问题,您可以直接在该步骤中修复这些问题,而不必添加额外的清理步骤。

由于操作顺序很重要,因此系统会将清理操作放在联接、合并、转置或聚合步骤之前或之后,并在该步骤的“更改”窗格中跟踪此信息。

还会将更改的注释添加到“流程”窗格中的步骤。对于“输入”步骤,注释显示在步骤的左侧,并会添加到“输入”字段列表,以便您能够轻松地查看哪个字段应用了更改。对于所有其他步骤类型,注释显示在“流程”窗格中步骤的上方。

某些清理操作仍然必须在清理步骤中执行,只有部分清理操作可用于“输入”和“输出”步骤。下表列出了可用于每种步骤类型的清理操作:

  输入 清理 聚合 转置 联接 合并 输出
筛选 X X X X X X  
分组和替换   X X X X X  
清理   X X X X X  
拆分值   X X X X X  
重命名字段 X X X X X X  
编辑值   X X X X X  
更改数据类型 X X X X X X  
创建计算字段   X X X X X  
移除字段 X X X X X X  

有关详细信息,请参见关于清理操作

版本 2018.2.3 新增功能

连接到数据

连接到存储在 MongoDB Business Intelligence (BI) 中的数据

如果将数据存储在 Mongo DB Business Intelligence 中,您现在可以连接到数据并使用 Tableau Prep 对其进行清理。

有关如何使用 Mongo DB Business Intelligence 连接到数据的详细信息,请参见 Tableau Desktop 帮助中的 MongoDB BI 连接器(Link opens in a new window)

注意:数据连接器不向后兼容。包括这些连接器的流程可在以前版本的 Tableau Prep 中打开,但除非移除这些数据连接器,否则将会出错或无法运行。

检查和筛选数据

为字段值指定数据角色

您现在可以为字段值分配数据角色,并使用 Tableau Prep 帮助您查找数据集中的不准确之处或离群值。

数据角色告知 Tableau Prep 字段值的含义或代表的内容,例如电子邮件地址或者诸如城市或邮政编码等地理角色。为字段分配数据角色之后,Tableau Prep 可检查字段值并标记不匹配的值,以便您能够进行更仔细的检查。

若要仅查看有效或无效的值,请使用下拉菜单上的新筛选器选项:

在此版本中,我们支持以下数据角色:

  • 电子邮件

  • URL

  • 地理角色(基于当前地理数据,并且与 Tableau Desktop 使用的数据相同)

    • 机场
    • 区号(美国)
    • CBSA/MSA
    • 城市
    • 国会选区(美国)
    • 国家/地区
    • 郡/县
    • NUTS 欧洲
    • 州/省/市/自治区
    • 邮政编码

有关详细信息,请参见使用数据角色验证数据(Link opens in a new window)

联接或合并数据

在联接子句中直接修复不匹配的字段

在联接两个数据表时,通常会有一些相同但由于数据录入错误而不匹配的字段值。Tableau Prep 可将不匹配的字段值标为红色,从而帮助确定联接子句中不匹配的字段。但如果能够在联接子句中修复这些字段值,岂不是更好?现在就能这样做了。

现在,当您联接两个数据集时,您可以直接在联接子句中对要联接的字段值进行编辑来修复它们。只需在字段值中双击即可对其进行编辑。

选择要更改的字段 内联编辑

系统会为相应的联接数据集将清理操作自动推回到流程中的上一个清理步骤。

联接步骤之前没有清理步骤?没问题。Tableau Prep 会自动为您添加一个清理步骤,以便从联接中捕获清理操作。

有关如何直接在联接子句中清理字段值的信息,请参见聚合、联接或合并数据(Link opens in a new window)

版本 2018.2.2 新增功能

安装和部署 Tableau Prep

设置显示语言

启动 Tableau Prep 时,它现在将检测计算机上设置的区域设置,并以相应的语言显示用户界面、日期和数字格式。如果要更改用户界面的显示语言,您可以从顶部菜单中的“帮助”>“选择语言”下选择支持的语言。

有关详细信息,请参见 Tableau Desktop 和 Tableau Prep 部署指南中的设置显示语言

连接到数据

连接到 Microsoft Access 中存储的数据

如果使用 Microsoft Access 进行数据录入和存储数据表,您现在可以通过文件浏览器连接到(版本 2007 或更高版本中的)Access 文件,并使用 Tableau Prep 清理数据。

此连接器需要 64 位驱动程序。

有关如何将 Tableau Prep 连接到数据的详细信息,请参见 Tableau Desktop 帮助中的 Access(Link opens in a new window)

注意:数据连接器不向后兼容。包括这些连接器的流程可在以前版本的 Tableau Prep 中打开,但除非移除这些数据连接器,否则将会出错或无法运行。

清理和调整数据

更改流程步骤的配色方案

默认情况下,Tableau Prep 会为流程中的每个步骤分配一种颜色,帮助您在构建流程时更轻松地跟踪对数据所做的更改。但您可以选择配色方案。

您现在可以从调色板中进行选取来更改一个或多个步骤的配色方案。只需在“流程”窗格中选择要更改的步骤,右键单击所选步骤,并从上下文菜单中选择“编辑步骤颜色”

不喜欢它的外观?从顶部菜单中单击“撤消”,或从调色板菜单中选择“重置步骤颜色”

有关详细信息,请参见更改流程配色方案(Link opens in a new window)

为步骤添加说明

如果与其他人共享流程,传达您所做的更改以及相关原因可能很麻烦。为了简化这一点,您现在可以为流程中任何单独的步骤添加简短说明,说明将直接显示在流程窗格中。

有关为流程步骤添加说明的详细信息,请参见为流程步骤和清理动作添加说明(Link opens in a new window)

使用模糊匹配来查找并修复拼写错误

为了帮助您快速确定并清理由于拼写错误而导致的相同值的多个变体,我们为模糊匹配清理功能添加了另一个选项。使用新的“拼写”选项来查找由于多出或缺少字母而不同的文本值,并将其分组。此选项适合于任何支持的语言。

“拼写”选项使用 Levenshtein 距离算法来计算两个文本值之间的编辑距离,然后在编辑距离小于默认阈值时将它们分组在一起。

有关详细信息,请参见编辑字段值

保存和共享工作

从命令行中运行流程

为了使数据在 Tableau Prep 中保持最新,您会运行流程。但是,每次要运行流程时都打开 Tableau Prep 可能很费时间。为了帮助简化此流程,您现在可以从命令行中运行流程,而不必将其在 Tableau Prep 中打开。

若要从命令行中运行流程,您将需要:

  • 要运行的流程 (.tfl) 文件的路径。

  • 一个 .json 文件,其中包含流程为其输入步骤连接到的任何数据库的数据库凭据,以及在其中发布输出的服务器的凭据。

    如果流程为输入或输出连接到或发布至本地文件或存储在网络共享上的文件,则不需要此文件。

    注意:不支持连接到或发布存储在网络共享上的受密码保护的文件。

  • 运行流程的计算机上的管理员权限。

此选项在 Windows 计算机(支持任务计划程序)和 Mac 计算机上均可用。若要使用此过程,您需要 Tableau Prep 的激活版本,并且必须在安装了 Prep 的同一台计算机上运行该过程。

有关如何从命令行中运行流程的信息,请参见通过命令行刷新流程输出文件

版本 2018.2.1 新增功能

安装和部署 Tableau Prep

通过命令行停用 Tableau Prep

像 Tableau Desktop 一样,如果您的计算机上不再需要 Tableau Prep,您现在可以使用 -return 选项通过命令行将其停用。

有关详细信息,请参见停用产品密钥(Link opens in a new window)。有关命令行中可用于 Tableau Prep 的其他安装程序属性的详细信息,请参见部署 Tableau Desktop(Link opens in a new window) 中的“安装程序选项”及相关部分。

使用虚拟桌面支持来优化 Tableau Prep 安装

就像 Tableau Desktop 一样,您现在可以配置虚拟桌面支持,针对非持久性虚拟桌面或定期重新映像的计算机优化 Tableau Prep 的安装。借助虚拟桌面支持,系统会使用 Tableau 托管的“授权运行”(ATR) 服务在预先确定的一段时间后自动停用 Tableau Prep 许可证,从而无需手动停用产品密钥。

有关如何配置此选项的详细信息,请参见 Tableau Desktop 和 Tableau Prep 部署指南中的配置虚拟桌面支持(Link opens in a new window)

连接到数据

连接到云数据源和 Hadoop Hive

您们增加了对以下连接器的支持,使您能连接到云数据和 Hadoop 中存储的数据。

  • Snowflake

  • Amazon EMR Hadoop Hive

  • Cloudera Hadoop(Hive 和 Impala)

  • Hortonworks Hadoop Hive

  • MapR Hadoop Hive

  • Apache Drill

  • SparkSQL

有关如何将 Tableau Prep 连接到数据的详细信息,请参见 Tableau Desktop 帮助中支持的连接器(Link opens in a new window)下适用于您的连接器的主题。

这些数据连接器不向后兼容。包括这些连接器的流程可在以前版本的 Tableau Prep 中打开,但除非移除这些数据连接器,否则将会出错或无法运行。

浏览数据

用于只保留所需数据的新筛选器选项

不再需要编写复杂的计算即可保留或排除 Null 值,或对文本值设置通配符匹配。作为替代,选择字段上的新筛选器选项之一即可立即看到所做更改的效果,而不必先编写计算,并随后在所做更改未产生所需结果的情况下恢复更改。

有关详细信息,请参见检查您的数据

清理和调整数据

在计算字段中使用 ISO-8601 日期标准

创建计算字段来支持欧洲日历更加轻松。Tableau Prep 现在为以下日期部分支持 ISO-8601 国际日期标准:

  • “iso-year”

  • “iso-quarter”

  • “iso-week”

  • “iso-weekday”

在 DATEPART、DATETRUNC、DATENAME、DATEDIFF 和 DATEADD 函数中使用这些日期部分。

例如,Week Number = STR(DATEPART('iso-year', [Week Date])) + "-" + STR(DATEPART('iso-week', [Week Date]))

有关如何在计算字段中使用日期函数的详细信息,请参见 Tableau Desktop 帮助中的日期函数(Link opens in a new window)

在数据网格中应用清理操作

在以前的版本中,数据网格会向您显示数据的预览,但可用的清理选项很少。现在您可以在任何地方对数据进行操作。如果在在数据网格中处理详细值,请折叠“配置”窗格,并在数据网格中执行与“配置”窗格中的可用清理操作相同的清理操作。

有关详细信息,请参见清理和调整数据

使用多选对“配置”窗格中的值进行分组

若要快速对一组字段值进行分组,您现在可以在“配置”卡中选择多个值,然后右键单击打开菜单并选择“分组”。值将分组在您右键单击打开菜单时选择的字段值下。分组的值旁边将显示一个回形针图标。

右键单击分组的值再次打开菜单,以取消分组或编辑值。

有关对值分组的详细信息,请参见编辑字段值(Link opens in a new window)

其他增强功能

我们还提供了以下增强功能来改善可用性:

  • 向流程中添加步骤时,菜单上将显示新的图标,用于提供视觉提示并帮助您了解 Tableau Prep 的视觉语言。

  • “配置”窗格中新的动画可帮助吸引您的注意力,以便更好地了解所做更改的效果。

     

联接或合并数据

使用并集建议来清理不匹配的字段

在合并两个或更多文件后修复不匹配的字段更加轻松。“并集摘要”窗格中新的“不匹配字段”部分显示不匹配的字段的列表,以及这些字段的来源数据源。使用以下选项之一,直接在此部分中合并不匹配的字段:

  • 在列表中选择一个字段。如果 Tableau Prep 基于类似的数据类型和字段名确定具有类似特征的字段,它将以黄色突出显示该字段,同时推荐一个匹配项。单击将光标悬停在推荐的匹配字段上时出现的加号 按钮来合并两个字段。

  • 在列表中选择两个或更多字段,右键单击这些字段之一,并选择“合并字段”

    有关合并数据和解决不匹配字段的详细信息,请参见合并数据

为所有联接类型确定不匹配的字段

不管您如何联接表,都能轻松确定不匹配的字段。在以前的版本中,“联接子句”表只会在字段彼此相等时显示排除的字段值。但现在,您可以在匹配联接子句时使用任何运算符查看此数据,例如“End Date >= Modified Date”。

有关详细信息,请参见联接数据(Link opens in a new window)

版本 2018.1.2 新增功能

安装和部署 Tableau Prep

通过命令行激活和注册 Tableau Prep (Windows)

像 Tableau Desktop 一样,您现在可以通过包括含以下属性的命令行,从命令行中激活和注册 Tableau Prep:

  • ACTIVATE_KEY="<key>"。此安装程序运行 -activate 来应用产品密钥。

  • REGISTER=“1”。在安装过程中,安装程序将运行 -register 进程,并添加注册信息。

有关这些安装程序属性以及如何通过命令行激活和注册 Tableau Prep 的详细信息,请参见部署 Tableau Desktop(Link opens in a new window) 中的“安装程序选项”及相关部分。

连接到数据

连接到存储在统计文件中或 Presto 上的数据

我们增加了两个新的连接器来帮助您连接到来自更多位置的数据。

  • 统计文件。连接到 SAS (*.sas7bdat)、SPSS (*.sav) 和 R (*.rdata) 数据文件。

  • Presto。有关如何配置 Presto 连接的详细信息,请参见 Tableau Desktop 帮助中的Presto(Link opens in a new window)

这些数据连接器不向后兼容。包括这些连接器的流程可在以前版本的 Tableau Prep 中打开,但除非移除这些数据连接器,否则将会出错或无法运行。

在输入步骤中合并 Data Interpreter 找到的子表

使用 Data Interpreter 来清理 Microsoft Excel 数据,并且现在想要合并生成的子表?您现在可以使用通配符并集来合并输出步骤中所有找到的子表。

只需将其中一个子表拖到“流程”窗格,然后使用通配符搜索条件来选择要合并数据的其余子表,并将所有子表数据包括在输入步骤中。

有关详细信息,请参见连接到数据

加载表时更好的反馈

首次连接到数据库时,有时可能看起来未发生任何事情。现在,新的指示符将指出数据仍在加载。

浏览数据

对“配置”窗格和“数据”网格中的字段进行重新排序

您现在可以通过拖放对“配置”窗格和“数据”网格中的字段重新排序,并且两个窗格将保持同步。即使您重命名字段,我们也会保持字段顺序。字段不再会自动重新排序。

清理和调整数据

使用拖动选择功能来移除流程中的多个步骤

移除流程的整个部分更加容易。您现在可在“流程”窗格中单击,并使用鼠标拖动并选择要移除的流程部分。然后右键单击即可一次性移除所有选择的步骤。有关详细信息,请参见清理和调整数据(Link opens in a new window)

在一个操作中对多个字段组进行转置

Tableau Prep 中的转置选项已经扩展,可更好地支持更复杂的电子表格或文本文件。您现在可以执行单一转置,或选择字段组进行转置。

例如,若要对电子表格进行转置来按月和按年查看销售额、税款和总计,您可以对每组字段进行转置来获取所需的结果。有关详细信息,请参见清理和调整数据(Link opens in a new window)

原始电子表格 对多组字段进行转置之后

合并字段时改善的字段命名

当您合并字段时,字段名称不再是级联方式。相反,目标字段的字段名会保留。有关详细信息,请参见合并字段(Link opens in a new window)

级联式字段命名 简化的字段命名

其他增强功能

我们还提供了以下增强功能来改善可用性和性能:

  • 将光标悬停在“更改”窗格中的条目上时,将会显示一个新的编辑图标,可帮助您快速确定哪些项目是可编辑的。

  • 为步骤重命名将不再会自动运行流程,使您的创作体验保持流畅。

  • “连接”窗格将在连接到 Microsoft Excel 文件时自动打开,其中包含多个工作表,可帮助您快速获取数据。

 

感谢您的反馈! 提交反馈时出错。请重试,或向我们发送消息