Tableau Prep Builder의 새 버전에 새로운 기능 또는 커넥터가 도입된 경우 이전 버전에서 작업하면 흐름을 열 때 호환성 문제가 발생할 수 있습니다.

참고: 버전 2020.4부터 Tableau ServerTableau Online에서 직접 흐름을 만들고 편집할 수 있습니다. 웹에서 만든 흐름은 항상 사용 중인 서버 버전과 호환됩니다. 웹에서 흐름을 작성하는 것에 대한 자세한 내용은 Tableau Server(링크가 새 창에서 열림)Tableau Online(링크가 새 창에서 열림) 도움말에서 웹에서의 Tableau Prep을 참조하십시오.

마찬가지로 Tableau Server 또는 Tableau Online에 흐름을 게시하고 Tableau Prep Conductor를 사용하여 실행하도록 예약하는 경우 현재 사용 중인 버전의 Tableau Server 또는 Tableau Online에서 지원하지 않는 새 기능 또는 커넥터가 흐름에 포함되어 있으면 흐름의 예약 및 실행을 차단하는 호환성 오류가 발생할 수 있습니다.

버전 번호 형식

Tableau Desktop과 Tableau Prep Builder의 버전 번호는 형식이 서로 다릅니다. 예:

Tableau Desktop과 Tableau Prep Builder의 유지 관리 릴리스는 동일한 순서를 따르지 않습니다.

  릴리스 업그레이드 예 첫 번째 유지 관리 버전 예
Prep Builder 2022.1.1 2022.1.2
Desktop 2022.1 2022.1.1

버전 찾기

참고: 특정 버전의 Tableau Prep Builder를 다운로드하려면 제품 다운로드 및 릴리스 정보(링크가 새 창에서 열림) 페이지를 열고 페이지 왼쪽의 목록에서 Tableau Prep Builder를 선택합니다.

Tableau Prep Builder

제품의 릴리스 버전을 확인하려면 Tableau Prep Builder를 열고 상단 메뉴에서 다음 중 하나를 수행합니다.

  • Windows: 버전에 따라 상단 메뉴에서 도움말 > Tableau Prep Builder 정보 또는 Tableau Prep 정보를 클릭합니다.
  • Mac: 버전에 따라 상단 메뉴에서 Tableau Prep Builder > Tableau Prep Builder 정보 또는 Tableau Prep > Tableau Prep 정보를 클릭합니다.

릴리스 번호는 대화 상자의 왼쪽 아래에 표시됩니다.

Tableau Server

Tableau Prep Conductor는 Tableau Server 버전 2019.1에 Data Management Add-on의 일부로 도입되었습니다. Tableau Server에서 실행되도록 흐름을 예약하려면 Tableau Server 버전 2019.1 이상을 사용해야 하며, Tableau Prep Conductor를 사용하도록 설정해야 합니다.

Tableau Server 버전을 확인하려면 웹 브라우저에서 Tableau Server를 엽니다. 상단 메뉴 모음에서 오른쪽 맨 위의 정보 아이콘 을 클릭하고 Tableau Server 정보를 선택합니다. 사용 중인 Tableau Server 버전을 알려 주는 대화 상자가 열립니다. Tableau Prep Conductor를 사용하도록 설정하는 방법에 대한 자세한 내용은 Tableau Server 도움말에서 2단계: 서버에 대한 흐름 설정 구성(링크가 새 창에서 열림)을 참조하십시오.

Tableau Online

Tableau Prep Conductor는 Tableau Online 버전 2019.3에 Data Management Add-on의 일부로 도입되었습니다. Tableau Online에서 실행되도록 흐름을 예약하려면 Tableau Online 버전 2019.3 이상을 사용해야 하며, Tableau Prep Conductor를 사용하도록 설정해야 합니다.

Tableau Online 버전을 확인하려면 웹 브라우저에서 Tableau Online을 엽니다. 상위 메뉴 모음에서 오른쪽 맨 위의 정보 아이콘을 클릭하고 Tableau Online 정보를 선택합니다. 사용 중인 Tableau Online 버전을 알려 주는 대화 상자가 열립니다. Tableau Prep Conductor를 사용하도록 설정하는 것에 대한 자세한 내용은 Tableau Online 도움말에서 Tableau Prep Conductor(링크가 새 창에서 열림)를 참조하십시오.

Tableau Prep Builder의 여러 버전 간 호환성

일반적으로 새 버전의 Tableau Prep Builder는 이전 버전에서 만든 흐름을 열 수 있습니다. 그러나 Tableau Prep Builder의 이전 버전과 새 버전 간에 흐름을 열려고 하거나 다른 컴퓨터에서 동일한 버전의 Tableau Prep Builder 흐름을 열려고 하면 호환성 문제가 발생할 수 있습니다.

예:

  • 흐름에 흐름이 열린 버전에서 지원되지 않는 입력 커넥터 또는 기능이 포함되어 있습니다.
  • 흐름을 열 때 사용하는 컴퓨터에 필요한 입력 커넥터가 설치되어 있지 않거나 커넥터에 호환되지 않는 드라이버 버전이 있습니다. Tableau Prep Builder를 사용하려면 흐름 입력 커넥터에서 작동하도록 64비트 드라이버를 설치해야 합니다.

호환성이 문제인 경우 흐름을 열려고 하면 흐름이 열리지만 오류가 포함되어 있거나, 흐름이 전혀 열리지 않고 오류 메시지가 수신될 수 있습니다. 아래 예에서는 흐름이 열리지 않고 오류 메시지가 표시되며 문제 해결을 위해 호환되지 않는 기능 및 옵션이 나열됩니다.

Tableau Prep Builder와의 호환성 문제 해결

호환성 문제를 해결하려면 다음 중 하나를 시도해 보십시오.

  • 최신 버전의 Tableau Prep Builder로 업그레이드합니다.

    더 알아보기 패널 아래쪽의 업데이트 단추를 클릭하여 최신 버전의 제품을 다운로드하고 Tableau Desktop 및 Tableau Prep Builder 배포 가이드에서 Tableau Prep Builder 설치(링크가 새 창에서 열림) 지침을 따릅니다. 더 알아보기 패널에서 업데이트 단추에 액세스할 수 없는 경우 최신 버전의 제품을 다운로드하는 방법에 대한 지침은 Tableau Prep Builder 설치 항목에 포함되어 있습니다.

  • 컴퓨터가 Tableau Prep Builder와 호환되는지 확인합니다. 예를 들어 흐름에 사용되는 커넥터에 대해 64비트 드라이버가 설치되어 있는지 확인합니다. 드라이버를 설치하려면 드라이버 다운로드(링크가 새 창에서 열림) 페이지를 참조하십시오.
  • 호환되지 않는 기능이 제거된 흐름의 복사본을 엽니다.

서로 다른 버전의 Tableau Prep Builder 및 Tableau Server 간 호환성

최신 버전의 Tableau Prep Builder에서 이전 버전의 Tableau Server에 게시하면 호환성 문제가 발생할 수 있습니다. 예를 들어 Tableau Prep Builder 버전 2021.3.1에 추가된 새로운 기능은 Tableau Server 버전 2021.2와 호환되지 않을 수 있지만 Tableau Server 버전 2021.4 및 Tableau Server의 향후 주 버전(예: 버전 2022.1)과는 호환됩니다.

Tableau Server에서 Tableau Prep Conductor는 흐름이 게시되면 흐름에 포함된 기능을 검색합니다. 지원되지 않는 기능이 발견되면 Tableau Server에 흐름을 게시할 수 있지만 흐름을 실행하거나, 예약하거나, 작업에 추가할 수 없습니다. Tableau Online은 정기적으로 자동으로 업데이트되므로 일반적으로 모든 버전의 Tableau Prep Builder와 호환됩니다.

이전 버전의 Tableau Server가 있는 경우 Tableau Prep Builder에서 수동으로 또는 명령줄을 사용하여 호환되지 않는 흐름을 계속 실행할 수 있습니다. 이 프로세스 사용에 대한 자세한 내용은 명령줄에서 흐름 출력 파일 새로 고침을 참조하십시오.

호환되지 않는 기능 검색

사용 중인 Tableau Prep Builder의 버전에 따라 여러 방식으로 호환되지 않는 기능을 확인할 수 있습니다.

Tableau Prep Builder(버전 2020.1.1 이상)

Tableau Server에 로그인하면 Tableau Prep Builder에서 호환되지 않는 기능을 감지하여 사용하지 않도록 설정합니다. 호환되지 않는 모든 기능은 회색으로 표시됩니다. 해당 기능을 계속 사용하고 흐름을 수동으로 또는 명령줄에서 실행하려는 경우 메뉴에서 해당 기능을 사용하도록 설정할 수 있습니다.

참고: Tableau Prep Builder 버전 2020.1.4부터 서버에 로그인하면 응용 프로그램을 닫은 경우에도 Tableau Prep Builder에서 사용자 서버 이름 및 자격 증명이 저장되어 있으므로 다음번에 응용 프로그램을 열면 이미 서버에 로그인되어 있습니다.

  1. 사용하지 않도록 설정된 기능을 마우스오버하여 서버 버전과 호환되지 않기 때문에 사용되지 않는 것인지 여부를 확인한 다음 기능 사용 단추를 클릭합니다. 이 옵션은 흐름 패널과 프로필 패널, 결과 패널 및 데이터 그리드의 메뉴에서 사용할 수 있습니다.

    참고: 데이터 업데이트가 일시 중지되었거나 특정 단계 또는 데이터 유형에서 옵션을 사용할 수 없는 경우와 같이 다른 이유인 경우 기능을 사용할 수 없습니다.

  2. 선택된 기능이 적용되고 모든 호환되지 않는 기능을 사용하도록 설정되며 사용할 수 있게 됩니다. 호환되지 않는 기능은 Tableau Server 버전에서 일정을 사용하여 흐름을 실행하려는 경우 쉽게 찾아서 제거할 수 있도록 경고 플래그가 지정됩니다.

이 기능을 완전히 사용하지 않고 모든 호환되지 않는 기능을 사용하려면 다음을 수행하십시오.

  1. 상단 메뉴에서 도움말 > 설정 및 성능 > 호환되지 않는 기능 사용 안 함을 선택합니다.

  2. 호환되지 않는 기능 사용 안 함을 선택하여 이 옵션 옆에 있는 확인 표시를 지웁니다. 이 기능을 다시 사용하려면 호환되지 않는 기능 사용 안 함을 선택합니다. 이 옵션은 기본적으로 사용하도록 설정되어야 합니다.

Tableau Prep Builder(버전 2019.3.1 이상)

Tableau Prep Builder에서 흐름을 작성할 때 흐름을 추가하면 호환되지 않는 기능이 검색되고 이러한 기능에 알림 아이콘 플래그가 지정됩니다. 이러한 알림을 보려면 서버에 로그인해야 합니다. 이 새로운 알림 시스템은 흐름에서 호환되지 않는 기능을 신속하게 식별하여 기능을 흐름에 유지할지 또는 제거 할지를 결정할 수 있습니다.

흐름 패널에서 알림 위로 마우스오버하여 호환되지 않는 기능에 대한 정보를 보거나 새 알림 센터를 사용하여 자세한 내용을 확인하십시오. 알림 센터에서 흐름에서 보기 링크를 클릭하여 경고를 트리거한 단계, 주석, 필드 또는 변경으로 직접 이동합니다.

Tableau Prep Builder(모든 버전)

호환되지 않는 기능이 있는 흐름을 게시하면 다음 메시지가 표시되고 로그인한 Tableau Server 버전에서 지원되지 않는 기능이 나열됩니다. Tableau Prep Builder 버전 2019.2.3 이하에서는 흐름에서 호환되지 않는 기능을 확인할 수 있는 유일한 방법입니다.

참고: 기능이 도입된 Tableau Prep Builder 버전이 오류 메시지에 나열됩니다. Tableau Prep Builder는 유지 관리 버전을 릴리스하지 않으므로 기능이 호환되려면 Tableau Server가 차기 주 릴리스 버전을 실행해야 합니다. 아래의 예제에서 필드 복제 기능은 Tableau Prep Builder 버전 2019.2.3에서 도입되었으므로 2019.2.3 Tableau Server 유지 관리 버전과 호환되지 않습니다. 대신 Tableau Server의 차기 주 릴리스 버전인 2019.3과 호환됩니다.

계속해서 흐름을 게시하면 게시가 성공적으로 완료됩니다. 그러나 Tableau Server 또는 Tableau Online에서 흐름을 열면 다음과 같은 메시지가 나타납니다.

Tableau Server에서 흐름을 예약하고 실행하려면 다음 중 하나를 수행합니다.

  • 사용 중인 Tableau Prep Builder의 버전과 호환되는 Tableau Server(링크가 새 창에서 열림)의 최신 주 릴리스를 조회합니다. 예를 들어 Tableau Prep Builder 버전 2019.2.3에 도입된 기능을 사용하는 경우 Tableau Server에서 흐름을 실행하려면 서버 버전이 2020.3 이상이어야 합니다.

    Tableau Online은 일반적으로 분기마다 정기적으로 자동 업데이트됩니다. 게시 전에 먼저 흐름을 테스트하여 Tableau Online의 현재 버전과 호환되는지 확인합니다.

  • 흐름을 게시하기 전에 호환되지 않는 기능을 흐름에서 제거한 다음 흐름을 게시합니다.

  • 이미 Tableau Server에 흐름을 게시한 경우 서버에서 직접 흐름을 편집하거나(버전 2019.4 이상), 흐름을 다운로드하고 기능을 제거하거나, 해당 버전에서 사용 가능한 기능만 사용하여 이전 버전의 Tableau Prep Builder에서 흐름을 만듭니다.

    참고: 특정 버전의 Tableau Prep Builder를 다운로드하려면 제품 다운로드 및 릴리스 정보(링크가 새 창에서 열림) 페이지를 열고 페이지 왼쪽의 목록에서 Tableau Prep Builder를 선택합니다.

호환성 문제 해결

흐름이 Tableau Server에 이미 게시되어 있는 경우 현재 버전의 Tableau Prep Builder에서 호환되지 않는 기능을 제거하려면 아래 단계를 시도하십시오. 기능을 제거하고 더 이상 버전 비호환 메시지 또는 경고가 나타나지 않으면, 흐름을 Tableau Server 또는 Tableau Online에 다시 게시하고 Tableau Prep Conductor를 사용하여 예약합니다.

참고: Tableau Prep Conductor는 Data Management Add-on의 일부입니다. Tableau Server 또는 Tableau Online예약 기능을 사용하여 흐름을 실행하려면 이 기능을 사용하도록 설정해야 합니다. Data Management Add-on에 대한 자세한 내용은 Tableau Data Management Add-On(링크가 새 창에서 열림)을 참조하십시오. Tableau Server 또는 Tableau Online에서 Tableau Prep Conductor를 사용하도록 설정하는 것에 대한 자세한 내용은 Tableau Server 도움말에서 2단계: 서버에 대한 흐름 설정 구성(링크가 새 창에서 열림) 또는 Tableau Online 도움말에서 Tableau Prep Conductor(링크가 새 창에서 열림)를 참조하십시오.

호환되지 않는 기능 식별

Tableau Server에서 작업하는 경우 흐름에 호환되지 않는 기능이 현재 나열되지 않습니다. 흐름에서 제거할 기능 목록을 확인하려면 흐름을 Tableau Prep Builder에서 열고 흐름에서 해당 기능을 찾아 제거해야 합니다.

  1. 흐름을 엽니다. Tableau Prep Conductor를 사용 중인 경우 추가 작업 메뉴에서 다운로드를 클릭하여 흐름을 다운로드하고 Tableau Prep Builder에서 열거나, 간단히 Tableau Prep Builder에서 흐름을 엽니다.

  2. 흐름을 다운로드한 경우 다운로드한 흐름을 클릭하여 엽니다.
  3. 버전에 따라 다음 중 하나를 수행합니다.

    • 버전 2019.3.1 이상: 상위 메뉴에서 서버 > 로그인을 선택합니다. 흐름과 호환되지 않는 동일한 서버를 선택해야 합니다. 호환되지 않는 단계, 주석, 필드 또는 변경 내용에는 알림 아이콘이 표시되어야 합니다.

      흐름 패널의 오른쪽 상단에서 알림을 클릭하여 호환되지 않는 각 기능의 세부 정보를 확인합니다. 흐름에서 보기를 클릭하여 호환되지 않는 기능으로 이동하고 조치를 취합니다.

    • 버전 2019.2.3 이하: 상위 메뉴에서 서버 > 흐름 게시를 선택합니다. 서버에 다시 로그인해야 하는 경우 흐름과 호환되지 않는 동일한 서버를 선택해야 합니다. 서버 버전과 호환되지 않는 기능이 나열된 경고 메시지가 나타납니다. 기능을 참고하여 흐름에서 해당 기능을 식별하고 제거할 수 있습니다. 그런 다음 취소를 클릭하여 대화 상자를 닫습니다.

  4. 상위 메뉴에서 파일 > 다른 이름으로 저장을 클릭하여 흐름의 복사본을 저장합니다. 흐름에서 호환되지 않는 기능을 제거하려면 다음 섹션의 옵션을 사용하십시오.

흐름에서 호환되지 않는 기능 제거

다양한 방법을 사용하여 흐름에서 기능을 찾아 제거할 수 있습니다. 이 섹션에서는 비호환성 오류를 해결하는 데 도움이 되는 몇 가지 옵션을 보여 줍니다.

호환되지 않는 데이터 원본

데이터 원본이 호환되지 않는 경우(예: Tableau Prep Conductor에서 아직 지원되지 않는 새 커넥터가 추가됨) 지원되는 데이터 원본에 연결해야 합니다.

데이터 연결을 변경하려면 다음 작업을 수행합니다.

  1. 연결 패널에서 커넥터의 드롭다운 화살표를 클릭하고 제거를 선택하여 데이터 원본 연결을 제거합니다.

    이렇게 하면 흐름이 일시적으로 오류 상태가 됩니다.

  2. 호환되는 데이터 원본에 연결하고 흐름 패널로 끌어옵니다. 새 입력 단계를 흐름에 연결하려면 해당 단계를 연결하려는 흐름의 첫 번째 단계로 끌어오고 추가 옵션의 연결 단계에 놓습니다.

  3. 다른 모든 커넥터를 대체하려면 이러한 단계를 반복합니다. 그런 다음 흐름을 저장하고 다시 게시합니다.

호환되지 않는 기능

호환되지 않는 기능을 제거하려면 기능이 사용된 단계를 찾아 제거해야 합니다. 호환되지 않는 기능 식별의 지침에 따라 호환되지 않는 기능을 찾을 수 있습니다.

  1. 기능이 단계 유형인 경우 흐름 패널에서 기능이 사용되는 단계를 클릭합니다. 단계를 마우스 오른쪽 단추로 클릭하거나 Ctrl 키를 누른 채로 클릭(MacOS)하고 제거를 선택합니다.

  2. 기능이 정리 작업인 경우 흐름 패널에서 기능이 사용되는 단계를 클릭합니다. 흐름 패널 또는 프로필이나 결과 패널에서 주석을 마우스오버하여 변경 내용 목록을 확인할 수 있습니다.

    참고: Tableau Prep Builder 버전 2019.1.3 이상에서 흐름 패널 또는 프로필 카드의 단계에서 찾고 있는 변경 내용을 나타내는 아이콘을 마우스오버하고 변경 내용 목록에서 주석을 선택할 수 있습니다. 변경 내용은 변경사항 패널, 프로필 또는 결과 패널에서 하이라이트되고 데이터 그리드에서 하이라이트됩니다.

  3. 필요한 경우 변경사항 패널을 열고 제거해야 하는 기능과 일치하는 변경 내용을 선택합니다. 변경 내용을 클릭하여 선택하고 제거를 클릭하여 흐름에서 삭제합니다.

  4. 다음 단계를 반복하여 다른 기능을 대체합니다. 그런 다음 흐름을 저장하고 다시 게시합니다.
피드백을 제공해 주셔서 감사합니다!