What's New in Tableau Prep Builder

Browse summaries of new features for currently supported versions.

Note: Starting in version 2019.1.2, Tableau Prep is now called Tableau Prep Builder.

Added in version 2019.2.3

Examine and Filter Your Data

Select specific values to filter

With the the new Selected Values filter, you can now pick and choose the values that you want to keep or exclude for a field, even values that aren't in your sample. In the Profile pane, Results pane or data grid click the More options button then select Filter > Selected Values.

This new visual indicator lets you select the values that you want to keep or exclude and visually shows you what you've selected. If you are working with a sample of your data and want to include or exclude values that aren't in the sample you are working with, simply add the values you need and Tableau Prep Builder applies the keep or exclude option to these new values too.

For more information about filtering field values, see Filter values.

Duplicate fields in one click

In prior releases if you wanted to experiment with your cleaning operations on a field but didn't want to change the original data, you would have to write a calculation to duplicate the field. Now you can easily duplicate your fields in one click. Select the field you want to duplicate, then from the More options menu, select Duplicate Field.

A new field is created and placed in the far left of the Profile pane, data grid, or Results pane with the same name and a modifier. For example, "Ship Date -1".

For more information about duplicating fields and other cleaning options, see Duplicate fields (version 2019.2.3 and later)Apply cleaning operations in other steps

Clean and Shape Data

Fix invalid data role values with fuzzy matching and cleaning recommendations

You can use data roles to quickly identify field values that aren't valid. After you assign the data role you can use one of two fuzzy matching algorithms; Spelling and Spelling + Pronunciation to quickly group and match invalid values for the data role to similar standardized values for that data role.

In addition to suggesting data roles for your fields. Tableau Prep Builder can now also suggest how to automatically fix invalid values for fields assigned to a data role using the Spelling and Spelling + Pronunciation algorithms. If a suggested fix is detected, a light bulb icon appears on the profile card. Click the icon and apply the suggested change to automatically group and replace invalid values with similar standardized values for that data role.

This feature is only available for the following data roles:

  • Airport
  • City
  • Country/Region
  • County
  • State/Province

For more information about applying data roles to your fields, see Assign data roles to your data. For more information about using group and replace to fix invalid values for data roles, see Group similar values by data role .

Added in version 2019.2.2

Connect to Data

Connect to more data with the Other Databases (ODBC) connector

If you need to connect to data sources that aren't listed in the Connections pane, you can connect to any data source using the Other Databases (ODBC) connector that supports the SQL standard and implements the ODBC API. Connecting to data using the Other Databases (ODBC) connector works similarly to how you might use it in Tableau Desktop, however there are a few differences:

  • You can only connect using the DSN (data source name ) option.
  • To publish and run your flow in Tableau Server, the server must be configured using a matching DSN.
  • There is a single connection experience for both Windows and MacOS. Prompting for connection attributes for ODBC drivers (Windows) isn't supported.
  • Only 64-bit drivers are supported by Tableau Prep Builder.

For more information about connecting to data using the Other Databases ODBC connector, see Connect to Data.

Specify an Initial SQL command when connecting to your data

You can now specify an Initial SQL command, when connecting to databases that support it, that will run when a connection is made to the database. For example when connecting to Amazon Redshift, you can enter a SQL statement to apply a filter when connecting to the database just like adding filters in the Input step. The SQL command will apply before data is sampled and loaded into Tableau Prep Builder.

If you change the Initial SQL command and refresh the Input step, the Initial SQL command is run again and the Input step is updated. When you run the flow, the initial SQL command is run before processing all of the data and if you schedule flows on Tableau Server, the initial SQL is run every time as part of the data loading experience.

For more information, see Connect to Data.

Note: Parameters are not yet supported for Initial SQL in Tableau Prep Builder.

Examine and Filter Your Data

Keep only the fields you need while cleaning your data

In prior releases you could remove unwanted fields in the Input step by clearing the check boxes after connecting to your data, In a cleaning or action step you could select one or more fields and simply right-click to remove them. Now, you can select one or more fields in the Profile pane or data grid and right-click to keep only the selected fields and all other fields are removed.

For more information, see Keep or remove fields.

Clean and Shape Data

Rearrange steps in your flow

Have you ever built a large complicated flow, but the default layout that Tableau Prep Builder uses makes your flow hard to follow? Well now you can select and move your steps in the canvas to organize your flow in a way that makes sense to you. For example, you can fix crossed flow lines, move your flow steps to clean up extra white space, or rearrange your flow steps to show a clear sequence of events.

The following flow is confusing and hard to follow:

Using this new feature, you can select one or more steps in the flow and drag them up, down, left or right and drop them right where you want them.

Note: Some restrictions do apply and flow steps can't be moved to a position that disrupts the left-to-right process flow. When dragging flow steps to an allowed location, an orange box displays. If the location isn't allowed, no orange box displays and the steps return to their original location when you try to drop them.

For more information , see Build your flow.

Added in version 2019.2.1

Connect to Data

Connect to more data with new database connectors

We've added more connectors to help you connect to and clean your data. Now you can connect to data stored in the following databases:

  • Amazon Athena
  • Other Databases (JDBC)

For more information about connecting to specific connectors, see Supported Connectors in the Tableau Desktop and Web Authoring help. For more information about connecting to data to build a flow see Connect to Data.

Keep Flow Data Fresh

View file safe list locations when publishing a flow

You can publish a flow to Tableau Server to automatically run your flows on a schedule and refresh the flow input or output using Tableau Prep Conductor. If your flow includes input or output steps with connections to a network share, your system administrator must include the file locations in your organization's safe list ahead of time, otherwise when you try to run the flow in Tableau Server, it will fail.

In Tableau Prep Builder version 2019.2.1 and later, if you publish a flow that includes input or output steps with connections to a network share, you are notified at publishing time if the files need to be included in your organization's safe list. To see safe listed locations, simply click the link in the warning message and move your files to one of the locations shown.

For more information about publishing flows, see Publish a Flow to Tableau Server. For more information about how to add file locations to your organization's safe list, see Step 4 - Safe list Input and Output locations.

Additional enhancements

Select from 10 different languages for your user interface

Tableau has added two additional languages that you can choose from to configure your user interface (menus, messages, etc.):

  • en_GB (British English)

  • zh_TW (Traditional Chinese)

For more information about configuring your display language, see Set your display language in the Tableau Desktop and Tableau Prep Builder deployment guide.

Quickly find your flow on Tableau server with flow thumbnail views

When you publish your flows to Tableau Server, you can now switch to the thumbnail view and view a graphic representation of your flow layout to help you quickly spot your flow at a glance.

Added in version 2019.1.4

Connect to Data

Connect to more data with new database connectors

We've added even more connectors to help you connect to and clean your data. Now you can connect to data stored in the following databases:

  • SAP HANA
  • Azure SQL Data Warehouse
  • MariaDB

Note: When connecting to data using SAP HANA, prompting for variables and parameters when opening a flow and using Initial SQL to query the connection isn't supported.

For information about connecting to specific connectors, see connection details in the Supported Connectors section of the Tableau Desktop and Web Authoring help. For more information about connecting to data to build a flow see Connect to Data.

Clean and Shape Data

Group similar values in a field by data role

In Tableau Prep Builder version 2018.2.3 we introduced data roles to help you standardize field values and quickly find values that weren't valid. Now if you assign a data role to your fields, you can use that data role to match and group values with the standard value defined by your data role. Simply assign a data role to your field, then select Data Role Matches from the Group and Replace menu. This new option then matches invalid values to the most similar valid value based on spelling and pronunciation.

For example if you have a field that lists countries such as Saint Martin and Saint Maarten, and you assign the Country/Region data role to the field, you can group fields using the new Data Role Matches option and map these values to the standardized data role value "Saint-Martin". If the standardized spelling of the value doesn't exist in your data set, Tableau Prep Builder automatically adds it to the group for you and groups the matching values using this standard value.

This feature applies to the following data roles and is currently only supported for U.S.English.

  • Airport
  • City
  • Country/Region
  • County
  • State/Province

For more information about assigning data roles to a field, see Assign data roles to your data. For more information about using data roles to group field values, see Edit multiple values using Group and Replace with fuzzy match .

Adjust your results when grouping field values

When you use the Group and Replace cleaning option to group similar values by Spelling or Pronunciation, you can now use a simple slider on the field to adjust how strict the grouping parameters are, giving you more control over your results.

Select from 5 threshold settings to control the number of values included in a group and the number of groups that get created.

For more information about grouping fields using fuzzy matching, see Cleaning (fixing) variations of the same value.

Added in version 2019.1.3

Connect to Data

Quickly join your data based on table relationships

When you connect to databases that include tables where table relationships are defined, such as Vertica or Microsoft SQL Server, Tableau Prep Builder can now detect and show this information.

For example, you can now see which fields in a table are unique identifiers and which fields are related fields (foreign key) as well any related tables for these fields.

A new column called Linked Keys shows in the Input pane with an icon next to the fields that are unique identifiers, related fields or a combination of both.

In the Linked Keys field, click on a related field or combination field to view related tables, then in one click, add the related table to your flow or create a join.

When creating a join, Tableau Prep Builder uses the defined field relationship to join your tables and shows a preview of the fields that define the join clause. From there you can click on the new Join step to clean and edit your join conditions as needed.

For tables that contain related fields, you can also see a list of all related tables and create a join from the menu in the Flow pane. From the Add Join menu option, select the table that you want to join on from the list and Tableau Prep Builder creates the join based on the fields that make up the relationship between the two tables.

This feature is available for any supported database connector where table relationships are defined. For more information about using Linked Keys to add or join tables, see Join data in the Input step.

Clean and Shape Data

See all cleaning recommendations in the toolbar

If Tableau Prep Builder detects and provides cleaning recommendations for your fields, a light bulb icon appears on the Profile card for the field. Now you can see all cleaning recommendations for any field from the toolbar in a selected step in one convenient list.

Simply click on an item in the list and Tableau Prep Builder takes you right to the field where you can apply the suggested change. For more information about cleaning recommendations, see Apply cleaning operations using recommendations.

Note: This option isn't available for Join, Input and Output step types.

Other enhancements

Find specific changes in your flow

You can now quickly find specific changes that you made in a flow by clicking on the change icon on a step in the Flow pane or on a profile card in the Profile or Results pane. Simply click on the icon that represents the change you are looking for then select the annotation from the list of changes. The change is highlighted in the Changes pane, Profile or Results pane and data grid if applicable.

For more information about viewing your changes, see View your changes.

Manage recently viewed flows from the Start page

When you save a flow and close Tableau Prep Builder, a thumbnail for the flow is saved to your Start page so you can quickly find your most used flows. But as a data prep rock star, your Start page can get crowded fast! To help you quickly find the flow you need and reduce the clutter when you're finished working with a flow, we've added a few new features to the Start page.

  • Improved graphics on the flow thumbnail more accurately represents the flow layout to help you spot your flow at a glance.

  • If the graphic doesn't give you enough information, hover over a flow thumbnail to instantly view the input and output details for the flow as well as when it was last opened.

  • Clear the clutter by removing recently viewed flows from the start page that you no longer need. This option removes the flow from the Recent Flows view only and won't delete the flow.

Added in version 2019.1.2

Keep Flow Data Fresh

Schedule flows to run automatically in Tableau Server

Add the new Data Management Add-on to Tableau Server version 2019.1 and later and you can use Tableau Prep Conductor to schedule and manage your flow runs. Publish a flow to Tableau Server, then schedule tasks to run the flow and automatically update your flow inputs and outputs. Use the error and alert options and Administrative views to track and manage your flow processing health.

For more information, see Keep Flow Data Fresh.

Help Design

Updates have been made to help you navigate our content, including a new right-hand menu to quickly scan and select different topics on a page.

Added in version 2019.1.1

Clean and Shape Data

Pivot rows to columns

If you work with data in a cross-tab or spreadsheet it might not be in the format you need to easily analyze it in Tableau. Sometimes your data may have many columns of data that need to be converted into rows, or you may have fewer columns but the data values represent multiple things.

To make shaping your data easier than ever, you can now choose the pivot option that is right for you. In a pivot step, you can now select one of the following options:

  • Columns to Rows: Drag one or more fields to the Pivoted Fields pane to pivot columns to rows.

  • Rows to Columns: Drag a field to the Pivoted Fields pane to create new columns using the field values, then drag in the field to use to populate those columns and choose how you want to aggregate them.

For more information, see Pivot your data

Use wildcard search to pivot fields

If you have a data set with a large number of fields or if fields are frequently added or removed over time, you can use a wildcard search when pivoting columns to rows to instantly pivot your data based on a wildcard pattern match. If new fields are added or removed that match the pattern, Tableau Prep Builder detects the schema change when you run the flow and the pivot results are automatically updated.

To use wildcard search to pivot your data, add a pivot step then click the Click here to create wildcard pivot link to open the wildcard search field. Enter a wildcard search pattern to find fields with names that match the values you entered. Click the Search Options ... button to select whether you want to include fields that contain, start with or end with the pattern you entered.

Click enter to apply the pattern and Tableau Prep Builder automatically pivots the fields.

For more information, see Pivot your data

Use descriptions to add context to changes

Add descriptions to any change in the Changes pane to add context to your cleaning operations. Simply open the Changes pane, right-click or Ctrl-click (Mac) on a change in the list and select Add Description. Then type a description in the text field that appears.

The description appears below the generated text for the change with a comment iconn.

For more information see Clean and Shape Data.

Use cleaning recommendations to quickly split data in fixed-width text files

In prior releases if you work with data stored in fixed-width text files, files that contain strings of data values in a single column constrained by a fixed character limit, you might have had to perform some pre-cleaning on the file or use complex calculations to separate out the values into separate columns.

Now when you connect to this type of data source, the cleaning recommendations feature detects these types of columns and suggests split options for you. Simply connect to your data source then add a cleaning step. In the Profile pane, click on the recommendation icon on the profile card.

Click Apply to split the fields, then check the results and clean or rename each new field as needed.

For more information, see Apply cleaning operations using recommendations.

Added in version 2018.3.3

Connect to Data

Automatically refresh input unions when new files are added

If you use a wildcard pattern to find and union Microsoft Excel or text (.csv) files in the input step, new files that are added to the same folder that match the pattern are automatically included in the union the next time you open the flow or run it from the command line.

Note: Packaged flow files (.tflx) won't automatically pick up new files because the files are already packaged with the flow. To include new files, open the flow file (.tfl) to pick up the new files then repackage the flow to include the new file data.

For more information about unioning files in the Input step, see Union files and database tables in the Input step.

Clean and Shape Data

Reuse cleaning operations

When cleaning your data you often perform the same cleaning operations or actions over and over throughout your flow. To help make cleaning and shaping your data more efficient, we've added the ability to copy and paste these operations or actions throughout your flow so you can perform a cleaning operation or action once, then reuse it where you need it.

  • Copy one or more steps to use them in another area of your flow. This option is not available for Input steps that include a wildcard union.

  • Copy an operation from the Changes pane in one step and paste it in the Changes pane for another step to apply that same operation in that step.

  • Drag and drop an operation from the Changes pane to a field in the Profile pane to apply that operation to a different field. You can also copy an operation in the Changes pane and drag and drop it to other fields in the step to apply that operation to multiple fields. This option is not available for operations that impact multiple fields, such as calculated fields.

For more information, see Clean and Shape Data.

Remove extra whitespace

We've added two new quick cleaning operations to help you remove extra whitespace in your field values:

  • Remove Extra Spaces: Use this option with text fields values to remove leading and trailing whitespace and replace extra whitespace in-between characters with a single space.

  • Remove All Spaces: Use this option to remove all whitespace from text values, including leading and trailing whitespace and any whitespace in between characters.

For more information, see Cleaning (fixing) variations of the same value.

Examine and Filter Your Data

Quickly find where fields are used in a flow

When building your flow, if you aren't seeing all the field values that you expect, you can now easily trace everywhere a field was used - even back to where a field originated. Just select a field in the Profile pane or Results pane in a step and the steps in the flow pane will highlight. This shows you the path that field has taken in your flow, making troubleshooting your flow easier than ever.

For more information, see Trace fields in a flow.

Other Enhancements

Open multiple windows of Tableau Prep Builder at once

In Windows or on the Mac click File >New to open a new window for a flow instead of replacing the current window you are working in. When opening a flow file (.tfl or .tflx) this also opens a new window so you can easily work on or compare multiple flows at the same time.

Turn off usage reporting after install

To help us improve Tableau Prep Builder, you can share usage pattern data with us. We never collect any specific user data, only anonymous usage data. For example data source connection types (such as .csv, sql or Amazon Redshift), large data sets versus small data sets, number of steps in a flow or types of operations used (but no data specifics such as step names or formulas used), and so on.

Your data is confidential and we will never share this information with anyone. But if you want to turn this option off after installation, you can. Go to Help >Settings and Performance and click on Share Usage Data To Improve Tableau Prep Builder to clear the check mark. For more information, see Usage reporting in the Tableau Desktop and Tableau Prep Builder Deployment guide.

Added in version 2018.3.2

Clean and Shape Data

Improve data quality fast using cleaning recommendations

To help you find and fix problems with your data fast, Tableau Prep can now examine your data fields and suggest changes you can make to fix the problem. Tableau Prep examines your data fields and when a recommended change is identified, a light bulb icon appears on the Profile card for the field.

Click the light bulb icon to see the recommended changes, then hover over the recommendations card and click Apply to automatically apply them to the field. The change is recorded in the Changes pane and can be removed at any time.

In the example below Tableau Prep identified the field values as URL's and recommends applying a data role to the field to help identify values that aren't valid.

This feature is available in all step types except Input, Output and Join step types. In this release, recommendation types include:

  • Data roles
  • Filter
  • Replace invalid values with Null values
  • Remove fields
  • Trim spaces

For more information, see Apply cleaning operations using recommendations.

Other Enhancements

Added flexibility when running flows from the command line

When running flows from the command line, if you connect to databases or publish output files to a server, you need a credentials .json file that includes all required credentials. In past releases if you only connected to databases or published the flow output to a server, you would still need to include the empty array in the credentials .json file or the process would fail.

Now you no longer need to include the empty array in the credentials .json file. For example, if you only connect to databases you no longer need to include the outputConnection array in the .json file.

For more information about running flows from the command line, see Refresh output files from the command line.

Performance improvements

To help make working with your flows faster and more efficient, we've made the following enhancements:

  • Shutting down the product returns the memory space Tableau Prep was using right away.

  • If you receive an unexpected error you can now retry your action or process to keep you in the flow.

  • Improved performance when loading data or viewing data in a flow to reduce processing time.

  • If you connect to the following connectors, you can now use a search field to quickly find your schema:
    • Amazon EMR Hadoop Hive
    • Cloudera Hadoop
    • Hortonworks Hadoop Hive
    • MapR Hadoop Hive
    • Presto
    • Spark SQL

Added in previous versions

Added in version 2018.3.1

Install and Deploy Tableau Prep

Change your default repository location

By default, when you install Tableau Prep, the My Tableau Prep Repository is automatically installed in your Documents folder on your computer. But if you have restrictions about where you can store your flows and data sources, you can now move your My Tableau Repository to a different directory after Tableau Prep is installed.

To move your directory, open Tableau Prep, then from the top menu, select File > Repository Location. Select the folder where you want to move the repository.

For more information, see Change your My Tableau Prep Repository location in the Tableau Desktop and Tableau Prep Deployment Guide.

Connect to Data

Clean data stored in PDF files

Analyzing data stored in PDF files can be difficult to work with. Now you can connect directly to your PDF files and clean your data using Tableau Prep.

For more information about how to connect to your data in PDF files, see PDF file in the Tableau Desktop help.

Note: Data connectors are not backward compatible. Flows that include these connectors may open in a prior version of Tableau Prep, but will have errors or can't run unless the data connections are removed.

Wildcard union for database tables

If you work with database tables stored in a single data source you can now union your tables in the input step using a wildcard search. You can then include all of the data from the selected tables in the Input step using the same process that you use to union multiple files in the Input step.

To use this type of union, the tables must be in the same data source and you must connect to a data source that supports wildcard union.

The following data sources support this type of union:

  • Amazon Redshift

  • Microsoft SQL Server

  • MySQL

  • Oracle

  • PostgreSQL

For more information, see Union files and database tables in the Input step.

Clean and Shape Data

Replace field values with Null

If you have data rows that you want to include in your analysis but you want to exclude certain field values you can change them to a Null value. Simply select the field values that you want to replace, then right-click (Ctrl+click on Mac) on the selected value and select Replace with Null from the menu.

For more information about replacing field values, see Cleaning (fixing) variations of the same value.

Apply cleaning operations in any step

Fixing problems in your flow just got more efficient. Now if you spot problems in your data as you join, union, pivot or aggregate, you can fix these problems directly in that step without having to add an additional cleaning step.

Since the order of operations matters, the cleaning operation is placed either before or after the join, union, pivot or aggregate and this information is tracked in the Changes pane for that step.

Annotations for the change are also added to the step in the Flow pane. For Input steps, annotations show to the left of the step and are added to the Input field list so you can easily see which field had changes applied. For all other step types, the annotations show above the step in the Flow pane.

Some cleaning operations must still be performed in a cleaning step and only some cleaning operations are available for Input and Output steps.  The table below lists the cleaning operations available for each step type:

  Input Clean Aggregate Pivot Join Union Output
Filter X X X X X X  
Group and Replace   X X X X X  
Clean   X X X X X  
Split Values   X X X X X  
Rename Field X X X X X X  
Edit Value   X X X X X  
Change Data Type X X X X X X  
Create Calculated Field   X X X X X  
Remove Field X X X X X X  

For more information, see Apply cleaning operations.

Added in version 2018.2.3

Connect to Data

Connect to data stored in MongoDB Business Intelligence (BI)

If you store your data in Mongo DB Business Intelligence, you can now connect to your data and clean it with Tableau Prep.

For more information about how to connect to your data using Mongo DB Business Intelligence, see MongoDB BI Connector in the Tableau Desktop help.

Note: Data connectors are not backward compatible. Flows that include these connectors may open in a prior version of Tableau Prep, but will have errors or can't run unless the data connections are removed.

Examine and Filter Your Data

Specify a data role for your field values

You can now assign a data role to your field values and use Tableau Prep to help you find inaccuracies or outliers in your data set.

Data roles tell Tableau Prep what the field values mean or represent, for example email addresses or a geographic role such as city or zip code. When a data role is assigned to a field, Tableau Prep examines the field values and flags the values that don't match so that you can take a closer look.

To view only the values that are valid or not valid, use the new filter option on the drop-down menu:

In this release we support the following data roles:

  • Email

  • URL

  • Geographic roles (Based on current geographic data and is the same data used by Tableau Desktop)

    • Airport
    • Area code (U.S.)
    • CBSA/MSA
    • City
    • Congressional District (U.S.)
    • Country/Region
    • County
    • NUTS Europe
    • State/Province
    • Zip code/Postal code

For more information see Assign data roles to your data.

Join or Union Data

Fix mismatched fields directly in the join clause

When you join two tables of data you will often have field values that are the same but are mismatched due to data entry errors. Tableau Prep helps identify mismatched fields in your join clauses by turning the mismatched field values red. But wouldn't it be great if you could just fix those field values right in your join clause? Well now you can.

Now when you join two data sets you can edit the field values that you join on, right in the join clause to fix them. Simply double-click in a field value to edit it.

Select field to change Edit in-line

The cleaning action is automatically pushed back to the previous cleaning step in the flow for the appropriate join data set.

No cleaning step before the join step? No problem. Tableau Prep automatically adds one for you to capture the cleaning operation from the join.

For information about how to clean field values directly in a join clause, see Join or Union Data.

Added in version 2018.2.2

Install and Deploy Tableau Prep

Set your display language

When you start up Tableau Prep, it now detects the locale set on your computer and displays the user interface, dates, and number formats in the appropriate language. If you want to change the display language for the user interface you can select from the supported languages from the top menu under Help > Choose Language.

For more information see Set your display language in the Tableau Desktop and Tableau Prep deployment guide.

Connect to Data

Connect to data stored in Microsoft Access

If you use Microsoft Access for data entry or to store your data tables you can now connect to your access files (from version 2007 or higher) through a file browser and clean your data with Tableau Prep.

This connector requires a 64-bit driver.

For more information about how to connect Tableau Prep to your data, see Access in the Tableau Desktop help.

Note: Data connectors are not backward compatible. Flows that include these connectors may open in a prior version of Tableau Prep, but will have errors or can't run unless the data connections are removed.

Clean and Shape Data

Change the color scheme for your flow steps

By default, Tableau Prep assigns each step in your flow a color to help you easily track the changes you make to your data as you build your flow. But you have choices when it comes to this color scheme.

You can now pick from a color palette to change the color scheme for one or more steps. Just select the steps in the Flow pane that you want to change, right-click the selected steps and select Edit Step Color from the context menu.

Don't like how it looks? Click Undo from the top menu or select Reset Step Color from the color palette menu.

For more information, see Build your flow.

Add descriptions to your steps

If you share your flows with others, communicating the changes that you made and why can be cumbersome. To make it easier, you can now add a short description to any individual step in your flow and it displays right in the flow pane.

For more information about adding descriptions to flow steps, see Build your flow.

Use fuzzy match to find and fix spelling errors

To help you quickly identify and clean up multiple variations of the same value due to spelling errors, we've added another option to our fuzzy match cleaning feature. Use the new Spelling option to find and group text values that differ because of additional or missing letters. This option works in any supported language.

The Spelling option uses the Levenshtein distance algorithm to compute an edit distance between two text values and then groups them together when the edit distance is less than a default threshold value.

For more information, see Cleaning (fixing) variations of the same value.

Save and share your work

Run flows from the command line

To keep data fresh in Tableau Prep you run your flow. However, opening Tableau Prep every time you want to run flows can take time. To help streamline this process, you can now run flows from the command line without having to open it in Tableau Prep.

To run a flow from the command line, you'll need:

  • The path to the flow (.tfl) file that you want to run.

  • A .json file that contains the database credentials for any databases that the flow connects to for its input steps and the credentials for the server where the output is published.

    If your flow connects to or publishes to local files or files that are stored on a network share for inputs or outputs, then this file isn't needed.

    Note: Connecting to or publishing files that are stored on a network share that are password protected isn't supported.

  • Administrator permissions on the machine where you are running the flow.

This option is available on both Windows (Task Scheduler is supported) and Mac machines. To use this process, you need an activated version of Tableau Prep and the process must be run on the same machine where Prep is installed.

For information about how to run flows from the command line, see Refresh output files from the command line.

Added in version 2018.2.1

Install and Deploy Tableau Prep

Deactivate Tableau Prep from the command line

Like Tableau Desktop, if you no longer need Tableau Prep on your computer you can now deactivate it from the command line using the -return option.

For more information see Deactivate the product key. For more information about other installer properties that are available for Tableau Prep from the command line, see the Installer options and relevant sections in Deploy Tableau Desktop.

Use virtual desktop support to optimize Tableau Prep Installations

Just like Tableau Desktop you can now configure virtual desktop support to optimize your installations of Tableau Prep for non-persistent virtual desktops or for computers that are regularly reimaged. With virtual desktop support, Tableau Prep licenses are automatically deactivated after a predetermined period of time using a Tableau-hosted “Authorization to Run” (ATR) service, eliminating the need to manually deactivate the product key.

For more information about how to configure this option, see Configure Virtual Desktop Support in the Tableau Desktop and Tableau Prep deployment guide.

Connect to Data

Connect to cloud data sources and Hadoop Hive

We've added support for the following connectors so that you can connect to cloud data and data stored in Hadoop.

  • Snowflake.

  • Amazon EMR Hadoop Hive

  • Cloudera Hadoop (Hive and Impala)

  • Hortonworks Hadoop Hive

  • MapR Hadoop Hive

  • Apache Drill

  • SparkSQL

For more information about how to connect Tableau Prep to your data, see the topic for your connector under Supported Connectors in the Tableau Desktop help.

These data connectors are not backward compatible. Flows that include these connectors may open in a prior version of Tableau Prep, but will have errors or can't run unless the data connections are removed.

Explore Your Data

New filter options to keep only the data you want

No more writing complex calculations to keep or exclude Null values or to set up a wildcard match on text values. Instead select one of the new filter options on a field to see the impact of your changes right away without having to first write a calculation and then revert your change if it doesn't give you the results you want.

For more information, see Filter values.

Clean and Shape Data

Use the ISO-8601 date standard in calculated fields

Creating calculated fields to support European calendars just got easier. Tableau Prep now supports the ISO-8601 international date standard for the following date parts:

  • "iso-year"

  • "iso-quarter"

  • "iso-week"

  • "iso-weekday"

Use these date parts in functions DATEPART, DATETRUNC, DATENAME, DATEDIFF, and DATEADD.

For example Week Number = STR(DATEPART('iso-year', [Week Date])) + "-" + STR(DATEPART('iso-week', [Week Date]))

For more information about how to work with date functions in calculated fields, see Date Functions in the Tableau Desktop help.

Apply cleaning operations in the data grid

In prior versions, the data grid showed you a preview of your data, but had few cleaning options available. Now you can act on your data anywhere. If you want to work with the detailed values in the data grid, collapse the Profile pane and perform the same cleaning operations that are available in the Profile pane in the data grid.

For more information, see Clean and Shape Data.

Use multi-select to group values in the Profile pane

To quickly group a set of values for a field, you can now multi-select the values in the Profile card, then right-click to open the menu and select Group. The values are grouped under the field value that you select when you right-click to open the menu. A paperclip icon shows next to the grouped value.

Right-click the grouped values to open the menu again to ungroup or edit the values.

For more information about grouping values, see Cleaning (fixing) variations of the same value

Other enhancements

We've also made the following enhancements to improve usability:

  • New icons show on the menu when adding steps to your flow to provide visual cues and help you learn the visual language of Tableau Prep.

  • New animations in the Profile pane help catch your eye to better see the impact of your changes.

     

Join or Union Data

Use union recommendations to clean mismatched fields

Fixing mismatched fields after unioning two or more files just got easier. A new Mismatched Fields section in the Union summary pane shows a list of fields that don't match and the data source where they originated. Merge your mismatched fields directly in this section using one of the following options:

  • Select a field in the list. If Tableau Prep identifies a field with similar characteristics, based on similar data types and field names, it highlights the field in yellow, suggesting a match. Click the plus button that appears on hover on the suggested matched field to merge the two fields.

  • Select two or more fields in the list, right-click on one of them and select Merge Fields.

    For more information about unioning data and resolving mismatched fields, see Union your data.

Identify mismatched fields for all join types

Easily identify fields that don't match no matter how you join tables. In prior versions the Join Clauses tables showed field values that were excluded only when one field equaled another. But now you can see this data using any operator when matching join clauses, such as "End Date >= Modified Date".

For more information, see Join your data.

Added in version 2018.1.2

Install and Deploy Tableau Prep

Activate and register Tableau Prep from the command line (Windows)

Like Tableau Desktop, you can now activate and register Tableau Prep from the command line by including a command line with the following properties:

  • ACTIVATE_KEY="<key>". The installer runs -activate to apply the product key.

  • REGISTER=“1”. During the installation process, the installer will run the -register process and add the registration information.

For more information about these installer properties and how to activate and register Tableau Prep from the command line, see the Installer options and relevant sections in Deploy Tableau Desktop.

Connect to Data

Connect to data stored in statistical files or on Presto

We've added two new connectors to help you connect to data from more locations.

  • Statistical files. Connect to to SAS (*.sas7bdat), SPSS (*.sav), and R (*.rdata) data files.

  • Presto. For more information about how to configure your connection to Presto, see Presto in the Tableau Desktop help.

These data connectors are not backward compatible. Flows that include these connectors will open in a prior version of Tableau Prep, but will have errors or can't run unless the data connections are removed.

Union sub-tables found by Data Interpreter in the Input step

Using Data Interpreter to clean your Microsoft Excel data and now you want to union the resulting sub-tables? You can now use wildcard union to union all of the found sub-tables in the Input step.

Simply drag one of your sub-tables to the Flow pane, and then use the wildcard search criteria to select the remaining sub-tables to union the data and include all the sub-table data in the Input step.

For more information see Union files and database tables in the Input step.

Better feedback when loading tables

When you connect to a database for the first time, it can sometimes seem like nothing happened. Now a new indicator tells you that the data is still loading.

Explore Your Data

Reorder fields in the Profile pane and the Data grid

You can now drag and drop to reorder your fields in both the Profile pane and the Data grid and the two panes will stay in sync. We also maintain the field order even when you rename a field. Fields are no longer reordered automatically.

Clean and Shape Data

Use drag-select to remove multiple steps in your flow

Removing whole sections of your flow just got easier. You can now click in the Flow pane and use your mouse to drag and select the section of the flow that you want to remove. Then right-click to remove all of the selected steps at once. For more information see Build your flow.

Pivot multiple groups of fields in a single action

The pivot option in Tableau Prep has been expanded to better support more complex spreadsheets or text files. You can now perform either a single pivot or select groups of fields to pivot.

For example to pivot a spreadsheet to see sales, tax, and totals by month and year you can pivot each group of fields to get the results you want. For more information, see Pivot your data.

Original Spreadsheet After pivoting on multiple groups of fields

Improved field naming when merging fields

When you merge fields, the field names are no longer concatenated. Instead the field name of the target field persists. For more information, see Merge fields.

Concatenated field naming Simplified field naming

Other enhancements

We've also made the following enhancements to improve usability and performance:

  • A new edit icon shows on hover on entries in the Changes pane to help you quickly see which items are editable.

  • Renaming a step will no longer automatically run the flow so your authoring experience is seamless.

  • The Connections pane automatically opens when you connect to a Microsoft Excel file with multiple sheets to help you quickly get to your data.

 

Thanks for your feedback! There was an error submitting your feedback. Try again or send us a message.