在 Google Workspace 中访问 Tableau 内容

Google Workspace 的 Tableau 加载项可让您从 Google Docs、Google Slides 和 GoogleSheets 中安全地访问 Tableau 内容。您可以将 Tableau 视图和 Pulse 指标作为图像嵌入到文档和演示文稿中,将实时数据从 Tableau Cloud 导入 Google Sheets,以及将数据从 Google Sheets 导出到 Tableau Cloud 进行分析。

为了使 Tableau 加载项在 Google Workspace 中可用,您的 Google Workspace 管理员必须将 Tableau 加载项添加到允许列表中。有关以管理员身份安装 Tableau 加载项的信息,请参见为 Google Workspace 设置 Tableau 加载项。

最低要求

功能Tableau CloudTableau Server 最低版本
在 Google Docs 和 Slides 中嵌入 Tableau 图像支持2023.1 或更高版本
将自定义视图与 Google Sheets 配合使用支持2024.3 或更高版本 (REST API 3.24)
将数据导入 Google Sheets支持2026.1 或更高版本。仅当与 Tableau Cloud 或 Tableau Server 版本 2026.1 或更高版本建立连接时,“导入”按钮才会出现。
从 Google Sheets 发布到 Tableau Cloud支持Tableau Server 上不支持。

Tableau Server 版本要求:Tableau 加载项的主要功能需要 Tableau Server 2024.3 或更高版本。

Google Sheets 中的特定功能具有更高的版本依赖关系:

数据导入:此功能使用 VDS API,仅与 Tableau Server 2026.1 或更高版本兼容。

发布到 Tableau Cloud:此功能依赖于“在 Tableau API 中浏览”,后者仅在 Tableau Cloud 上可用,在 Tableau Server 上不受支持。

在 Google Docs 和 Google Slides 中使用 Tableau 加载项

使用 Tableau 加载项将 Tableau 视图和 Pulse 指标作为图像快照直接嵌入到 Google Docs 和 Google Slides 中。您可以使用直接 URL 或通过浏览 Tableau 站点来查找资产。如果基础数据更新,您可以将刷新这些图像以显示最新版本。

插入 Tableau 图像

  1. 打开 Google 文档或 Google 幻灯片,然后单击右侧面板中的 Tableau 图标。

  2. 从下拉菜单中选择您的 Tableau 站点。

  3. 使用以下方法之一查找要嵌入的 Tableau 内容:

    • URL:输入 Pulse 指标或 Tableau 视图的直接链接,以在加载项中生成预览。

    • 搜索视图:输入视图名称以搜索您的站点,并选择相应结果进行预览。

    • 搜索 Pulse 指标:在嵌入之前查找特定的 Pulse 指标以预览其当前趋势线。

  4. 预览内容,然后选择要插入图像的幻灯片或文档选项卡。

  5. 选择“Insert”(插入)。图像将添加到您的文档中。

    Google Workspace 中的 Tableau 加载项,用于嵌入 Tableau 图像。

刷新 Tableau 图像

从 Tableau 嵌入的图像是静态快照。您可以刷新这些图像,以确保它们在基础源更改时表示最新数据。

  1. 若要刷新文件中的所有 Tableau 图像,请选择“All”(全部)。

  2. 若要仅刷新某些映像,请选择“Some”(部分)。

  3. 选中要更新的图像旁边的框,然后单击“Refresh”(刷新)。

Tableau 加载项将每次刷新的结果记录为文件中的注释,从而提供审核跟踪。此跟踪可识别启动刷新的用户、刷新发生的时间以及每个图像的状态。如果您的图像没有正常更新,请查阅“疑难解答”部分以获取常见问题的解决方案。

查看 Smartchips 和 PreviewLinks(仅限 Tableau Cloud)

当您将链接到 Tableau 视图或 Pulse 指标的 URL 粘贴到 Google 文档或 Google 幻灯片中时,它会自动扩展为包含缩略图和有关视图或指标的元数据的丰富预览。

在 Google Docs 中,URL 会展开为 Smartchips,即您可以将鼠标悬停其上以查看更多详细信息的交互式内联预览。

在 Google Slides 中,URL 会展开为 PreviewLinks。Slides 会提示您将 URL 替换为标题。这是一次性替换 - 如果视图标题或指标值稍后更改,链接标题不会自动更新。

在 Google Sheets 中使用 Tableau 加载项

Google Sheets 的集成支持双向数据流:它允许您将 Tableau 视图或已发布数据源中的信息提取到电子表格中,还支持将 Google Sheets 数据发布回 Tableau Cloud。

Google Sheets 中的 Tableau 加载项扩展程序,用于导入和导出数据。

从 Tableau 导入数据

您可以从 Tableau 已发布数据源或特定工作表或视图导入数据。体验会因选择哪种方式而异 — 已发布数据源提供带有字段选择和聚合控件的完整查询生成器,而工作表和视图导入则按原样引入数据,无需额外筛选。

  1. 打开 Google 工作表,然后单击右侧面板中的 Tableau 图标。

  2. 从下拉菜单中选择您的 Tableau 站点。

  3. 选择一种数据源类型。

从工作表或视图导入

  1. 按名称搜索视图,或将 Tableau URL 直接粘贴到 URL 字段中。

  2. 选择结果以查看数据预览。

  3. 指定要导入哪些行。

最多可导入 500 万个单元格。如果所选的数据量超过此数量,数据将在 500 万个单元格处被截断。

Google Workspace 上的 Tableau 加载项扩展程序中的“Rows to import”(要导入的行)下拉菜单。

  1. 选择“Rows to import”(要导入的行)下的下拉箭头,并指定要导入哪些行。

    • “Autofit to capacity”(自动适应容量):导入行,直到导入达到 500 万个单元格的限制。

    • “First N rows”(前 N 行):导入前 N 行,具体行数由您在“Number of rows”(行数)字段中输入的数字确定。

    • “Last N rows”(最后 N 行):导入最后 N 行,具体行数由您在“Number of rows”(行数)字段中输入的数字确定。

  2. 选择“Import Data from Tableau”(从 Tableau 导入数据)。该工作表中的完整数据将以表格形式写入您的工作表。字段选择和聚合对于工作表和视图导入不可用。

注意:如果选择仪表板,则只能导入第一个工作表。若要导入仪表板中的特定工作表,请直接导航到该工作表,而不是选择仪表板。

从已发布数据源导入

  1. 确保您要导入的已发布数据源标有“GoogleSheets”。只有带有此标记的数据源才会出现在下拉列表中。
    有关标记数据源的详细信息,请参见使用标记。

  2. 选择下拉箭头以查看可用于导入的数据源。

    从适用于 Google Workspace 的 Tableau 加载项中的 Tableau 数据源下拉菜单导入。

  3. 选择要导入的数据源,并选择“Build new query”(生成新查询)。

  4. 使用字段选择器选择要导入的字段。

  5. 使用“Select All”(全选)或“Select None”(全不选)来快速管理您的选择。

  6. 如果需要行级别未聚合数据,请选择“Disaggregate Data”(解聚数据)。(可选)。

    注意:解聚大型数据源可能需要一段时间或导致超时。应用聚合后,字段级别解聚不再可用。

  7. 修改字段特征和聚合(可选)。

  8. 选择“Configure Import”(配置导入)。

  9. 查看导入预览,然后选择“Import Data from Tableau”(从 Tableau 导入数据)。

注意:当前,当您从包含大量字段的已发布数据源导入数据时,您可能会看到此警告:“The list has been truncated to fit the Google add-on card limit”(该列表已被截断以适应 Google 加载项卡限制)。Google Workspace 面板一次只能显示有限数量的项。如果数据源包含大量的维度和度量(通常为 50 个或更多),则无法显示完整列表。为了解决此问题,请创建一个较小版本的已发布数据源,其中仅包含 Google Sheets 导入所需的字段。

从 URL 导入

  1. 将 Tableau URL 粘贴到搜索框中,然后选择“Search”(搜索)。

  2. 预览内容,然后选择“Import Data from Tableau”(从 Tableau 导入数据)。

  3. 选择“OK”(确定)。

刷新 Tableau 数据

  1. 从 Tableau 加载项菜单中选择“Update Data”(更新数据)。

  2. 选中要刷新的数据对应的复选框。

  3. 选择您的刷新行为。您可以选择将刷新的数据插入到新工作表中,或覆盖现有数据。

    适用于 Google Workspace 的 Tableau 加载项中的数据刷新选项。

  4. 选择“Refresh Data”(刷新数据)。

Tableau 加载项将每次刷新的结果记录为文件中的注释,从而提供审核跟踪。此跟踪标识启动刷新的用户、刷新发生的时间以及每次刷新的状态。如果您的数据未正常更新,请查阅“疑难解答”部分以获取常见问题的解决方案。

配置数据导入

最多可导入 500 万个单元格。如果所选的数据量超过此数量,数据将在 500 万个单元格处被截断。

如果您正在使用大型数据集,请考虑以下方法以保持在限制范围内:

  • 通过在数据源级别应用筛选器以减少行计数,在导入之前筛选 Tableau 中的数据。

  • 在查询编辑器中选择较少的字段。

  • 使用聚合而不是行级别数据来减少单元格计数。

数据聚合

默认情况下,Tableau 加载项会根据您在字段选取器中的选择将聚合应用于度量字段(例如 SUM 或 AVG)。如果需要行级别数据,请在完成字段选择之前选择解聚。

刷新区块中的数据

为了处理大量数据,Tableau 加载项设计为以增量段的形式刷新数据,而不是通过一个大的请求来刷新数据。这种分块方法可以防止 API 超时,并确保可靠地交付大量数据集。您可以通过工作表注释中显示的指示器监视此操作的进度。

注意:单个查询受 Google 的超时限制约束。如果查询运行时间超过 30 秒,则会出现通知,并且该过程将在后台继续。

将 Google Sheets 数据导出到 Tableau Cloud

您可以将数据从 Google 工作表发布到您的 Tableau Cloud 站点。Tableau 加载项使用“在 Tableau API 中浏览”打开预加载了工作表数据的 Tableau Cloud Web 制作会话。

  1. 打开 Google 工作表,然后从右侧面板中选择 Tableau 加载项。

  2. 从下拉菜单中选择您的 Tableau Cloud 站点。

  3. 选择“Export Data”(导出数据),然后选择要发布的工作表。

  4. 选择“Export to Tableau Cloud”(导出到 Tableau Cloud)。

    Google Workspace 中 Tableau 加载项的“Export Data”(导出数据)对话框。

这将启动到 Tableau Web 制作体验中,使用 Google 工作表数据作为 Tableau 已发布数据源。

  1. 选择“Publish”(发布),将数据源导出到 Tableau Cloud 站点。

注意:Google Sheets 中的数据透视表、合并单元格和图像与 Tableau Cloud 不兼容。如果您的工作表包含不兼容的内容,则在移除该内容之前无法将其导出。

共享 Tableau 内容

当您共享包含 Tableau 内容的 Google 文档、幻灯片或工作表时,系统会将 Tableau 图像或数据作为文档的一部分进行共享,就像任何其他内容一样。但是,Tableau 权限不会随文档共享。想要刷新 Tableau 映像或重新导入数据的每个用户都必须对相关数据源或视图具有适当的权限。

Docs 和 Slides 中的刷新活动将记录为文档上的注释。每个刷新注释都会记录触发刷新的用户、时间戳以及每次图像刷新的状态。这提供了审计跟踪,用于了解数据上次更新的时间以及由谁更新。

数据连接疑难解答

我没有看到我的所有数据

如果未看到您的所有数据,则您的查询可能已超过 500 万个单元格的限制。若要成功导入整个数据集,请尝试使用以下方法减少导入的数据量:

  • 应用 Tableau 筛选器以限制导入的数据量。

  • 减少为导入选择的字段数。

  • 在开始导入过程之前,使用聚合来压缩信息。

导入花费很长时间或似乎处于卡滞状态

大量导入内容是以区块形式导入的,这对于大型数据集可能需要一些时间。如果刷新在后台运行,您可以在文件的注释部分中跟踪刷新的状态。

我无法刷新数据

如果尝试刷新与您共享的 Tableau 内容,请确保您具有访问 Tableau 中的数据的适当权限。无论是否共享了 Google 文档,基础 Tableau 数据权限始终适用。

我在 Tableau 加载项中找不到我的已发布数据源

已发布数据源必须在 Tableau 中标记为“GoogleSheets”,才会出现在加载项的数据源列表中。

连接仪表板时,我只能看到一个数据工作表

该应用程序只能从仪表板内的第一个数据工作表中检索数据。若要从仪表板内的特定工作表导入数据,我们建议您转到工作簿中的该工作表并从该处导入。

我找不到我的自定义视图

如果要访问自定义视图,则需要选择“从 URL 导入”功能。

我看不到我的 Smartchips 或 PreviewLinks

Smartchips (Google Docs) 和 PreviewLinks (Google Slides) 仅适用于 Tableau Cloud。由于 Google Workspace 平台存在需要全局 URL 允许列表的限制,因此 Tableau Server 不支持它们。如果您正在使用 Tableau Cloud 但仍未看到智能内容,请确保粘贴受支持的 Tableau URL。

我无法修改字段的聚合

选择解聚按钮后,导入将在行详细级别呈现。若要聚合行级别数据,请在完成字段选择并运行导入之前取消选择“解聚”按钮。

我无法发布我的 Google Sheets 数据

将数据从 Google Sheets 发布到 Tableau 的功能仅在 Tableau Cloud 上可用。此功能不可用于 Tableau Server。

我无法导入 Tableau 自定义视图

自定义视图支持需要 Tableau Server REST API 版本 3.23 或更高版本。

我的已发布数据源中缺少字段

目前,当您从包含大量字段的已发布数据源导入数据时,您的数据可能会被截断以适应 Google 加载项卡的限制。Google Workspace 面板一次只能显示有限数量的项。如果数据源包含大量的维度和度量(通常为 50 个或更多),则无法显示完整列表。

为了解决此问题,请创建一个较小版本的已发布数据源,其中仅包含 Google Sheets 导入所需的字段。

我无法导出某个 Google 工作表

Google Sheets 中的数据透视表、合并单元格和图像与 Tableau Cloud 不兼容。如果您的工作表包含不兼容的内容,它将在导出对话框中显示为灰色,您无法将其导出。请从 Google 工作表中移除所有数据透视表、合并单元格或图像,然后重试。

感谢您的反馈!您的反馈已成功提交。谢谢!