변경된 기능 - 업그레이드하기 전에 알아야 할 사항

이 문서에는 버전 9.3부터 시작하여 Tableau Server의 중요한 변경 사항이 나와 있습니다. 이 목록은 누적됩니다. 초기 버전(예: 10.1)에서 업그레이드하는 경우 현재 버전과 업그레이드할 대상 버전 사이의 모든 버전에 대한 변경 목록을 확인하십시오. Windows 기반 Tableau Server에서 Linux 기반 Tableau Server로 업그레이드하는 경우 양쪽 버전의 "변경된 기능"을 확인하십시오.

버전 2019.4의 변경된 기능

버전 2019.4에는 업그레이드 전에 확인해야 하는 다음과 같은 변경 사항이 포함되어 있습니다.

Tableau Server 2019.4의 모든 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

Tableau Server 설치 프로그램 재작성

Tableau Server 2019.4 릴리스에는 새롭게 재작성된 Tableau Server용 설치 프로그램이 포함되어 있습니다.

이 업데이트로 인해 설치 프로그램에서 사용할 수 있는 몇 가지 명령줄 스위치 및 옵션이 변경되었습니다. Tableau Server 설치 또는 업그레이드를 자동화한 경우 Server 설치 프로그램의 현재 명령줄 옵션을 검토해야 합니다. 자세한 내용은 Tableau Server의 설치 스위치 및 속성을 참조하십시오.

Windows용 새 tabcmd 설치 프로그램

Tableau Server 2019.4 릴리스에는 Windows에서 tabcmd를 설치하는 새롭게 재작성된 설치 프로그램이 포함되어 있습니다.

이 업데이트의 내용

Tableau Server 작업 관리에 대한 업데이트

작업 관리 페이지에 다음을 비롯한 여러 업데이트와 새로운 옵션이 적용되었습니다.

  • 이제 작업 페이지에 각 작업에 대한 평균 실행 시간평균 큐 대기 시간 정보가 포함됩니다.

  • 작업 취소 환경에 개선되었습니다. 이제 서버 및 사이트 관리자가 사용자 지정 참고 사항을 입력할 수 있을 뿐만 아니라 작업 취소 시 이메일을 받을 수신자를 선택할 수 있습니다.

  • 작업 세부 정보 대화 상자에 작업이 성공적으로 실행된 마지막 시간, 작업 Creator 이름 등과 같은 자세한 정보가 제공됩니다.
  • 이제 흐름 실행 작업 취소가 지원됩니다. 이전의 Tableau Server 버전 2019.3에서는 추출 새로 고침 및 구독만 지원되었습니다.
  • 작업 유형 암호화 작업이 추가되었습니다.

  • 이제 실패한 작업에 일시 중단된 작업이 포함됩니다. 일시 중단된 작업은 실패한 작업의 하위 상태이며 다른 실패한 작업과 구분할 수 있도록 고유한 아이콘이 적용됩니다.

자세한 내용은 Tableau Server의 작업 관리를 참조하십시오.

 

버전 2019.3의 변경된 기능

버전 2019.3에는 업그레이드 전에 확인해야 하는 다음과 같은 변경 사항이 포함되어 있습니다.

Tableau Server 2019.3의 모든 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

기본 암호 그룹에 이전 암호에 대한 기본 지원이 포함되지 않음

2019.3 버전의 Tableau Server에는 SSL 연결의 Triple-DES, IDEA 및 CAMELIA 암호에 대한 기본 지원이 포함되지 않습니다. 이러한 암호는 충분히 안전한 것으로 간주되지 않습니다. 이전 버전의 보안 강화 검사 목록에는 기본적으로 사용되는 Triple-DES 암호의 해제를 권장하는 내용이 포함되었습니다.

환경에 따라 업그레이드 전과 후에 추가 구성을 수행해야 할 수 있습니다.

  • 검사 목록에 설명된 대로 Triple-DES 암호를 사용하지 않도록 설정한 경우 2019.3으로 업그레이드하기 전에 다음 명령을 실행하는 것이 좋습니다.

    tsm configuration set -k ssl.ciphersuite -d

    tsm pending-changes apply

    이 명령은 Tableau Server를 2019.2(및 이전) 기본 암호 그룹 구성으로 되돌립니다. 2019.3으로 업그레이드한 후에는 Triple-DES, IDEA 및 CAMELIA가 기본적으로 지원되는 암호에서 제거됩니다.

    ssl_ciphersuite 키를 달리 변경한 경우에는 이 명령을 실행하지 마십시오.

  • ssl_ciphersuite 키를 변경하지 않은 경우 설치 시 업그레이드 프로세스의 일부로 키 값이 새로운 기본값으로 업데이트됩니다. ssl_ciphersuite 키의 새로운 기본값은 HIGH:MEDIUM:!aNULL:!MD5:!RC4:!3DES:!CAMELLIA:!IDEA:!SEED입니다.

  • 사용자를 위해 계속해서 Triple-DES를 지원해야 하는 경우 더 많은 보안 암호를 지원하는 최신 브라우저로 업그레이드하는 것이 좋습니다. 이 방법을 선택할 수 없는 경우 업그레이드 후 다음 명령을 실행할 수 있습니다. 첫 번째 명령은 Triple-DES를 지원하는 2019.3 이전 구성으로 ssl_ciphersuite 키를 설정합니다.

    tsm configuration set -k ssl.ciphersuite -v "HIGH:MEDIUM:!aNULL:!MD5:!RC4"

    tsm pending-changes apply

사용량 데이터가 Tableau로 전송됩니다.

Tableau Server 2019.3부터 서버 사용량 데이터가 기본적으로 Tableau로 전송됩니다. 새 설치 및 업그레이드가 여기에 해당합니다. 설치 또는 업그레이드 중이나 Tableau Server를 설치한 후 언제든지 기능을 취소할 수 있습니다. 사용량 데이터에 대한 자세한 내용은 서버 사용량 데이터를 참조하십시오.

서버 사용량 데이터를 전송하지 않게 하려면:

  • Tableau Server를 처음 설치하는 경우 초기 노드 설정을 구성하는 동안 이 기능을 사용하지 않도록 설정할 수 있습니다. 자세한 내용은 초기 노드 설정 구성을 참조하십시오.

  • Tableau Server를 업그레이드하는 경우 upgrade-tsm 스크립트가 이 옵션에 대한 정보와 사용하지 않도록 설정하는 방법에 대해 알려줍니다.

  • Tableau Server를 설치하거나 업그레이드했으며 서버 사용량 데이터 전송을 사용하지 않도록 설정하려는 경우 TSM 유지 관리 페이지 또는 명령줄에서 이 작업을 수행할 수 있습니다. 자세한 내용은 서버 사용량 데이터를 참조하십시오.

암호를 제공하지 않고 업그레이드

Tableau Server 2019.3부터 버전 2019.2 이상에서 업그레이드할 때 upgrade-tsm 스크립트에서 더 이상 사용자 및 암호를 지정할 필요가 없습니다. 버전 2019.3 이상에서는 TSM CLI로 직접 액세스 기능을 이용하여 사용자가 로그인한 계정을 업그레이드 인증에 사용합니다. --user 옵션을 사용하여 이 동작을 재정의하고 관리 사용자를 지정할 수 있습니다. 이렇게 할 경우 --password 옵션을 사용하여 암호를 제공하거나 메시지에 따라 암호를 입력해야 합니다. 2019.2.0 이전 버전에서 업그레이드할 경우 여전히 암호를 묻습니다.

버전 2019.2의 변경된 기능

버전 2019.2에는 업그레이드 전에 확인해야 하는 다음과 같은 변경 사항이 포함되어 있습니다.

Tableau Server 2019.2의 모든 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

최소 하드웨어 요구 사항이 변경됨

버전 2019.2부터 Tableau Server를 설치하려면 최소 4개의 코어와 16GB의 RAM이 필요합니다. 설치 프로그램은 설치하기 전에 설치하려는 컴퓨터가 이러한 최소 요구 사항을 충족하는지 확인합니다. 컴퓨터가 이러한 하드웨어 최소 요구 사항을 충족하지 않으면 Tableau를 설치할 수 없습니다. 자세한 내용은 Tableau Server의 최소 하드웨어 요구 사항 및 권장 사항을 참조하십시오. 이 변경 사항에 대한 자세한 내용은 Tableau 블로그 게시물 Updated machine requirements for Tableau Server trials(Tableau Server 평가판의 업데이트된 컴퓨터 요구 사항)를 참조하십시오.

업그레이드를 위해서는 각 노드에 최소 15%의 디스크 여유 공간이 필요합니다.

버전 2019.2로의 업그레이드에는 Tableau가 내부적으로 사용하는 PostGRES 데이터베이스에 대한 버전 업데이트가 포함됩니다. 이 업데이트는 업그레이드하기 전에 데이터베이스 백업을 수행하며 각 노드에 최소 15%의 여유 공간이 필요하다는 것을 의미합니다.

"Referrer-Policy" HTTP 헤더가 추가됨

2019.2부터 Tableau Server에는 Referrer-Policy HTTP 헤더 동작을 구성하는 기능이 포함되어 있습니다. 이 정책은 모든 "보안" 연결에 대한 원본 URL을 포함하는 기본 동작에서 사용하도록 설정됩니다(no-referrer-when-downgrade 정책). 이전 버전에서는 Referrer-Policy 헤더가 Tableau Server가 전송하는 응답에 포함되지 않았습니다. 이 변경은 대부분의 브라우저에 대한 사용자 시나리오에 영향을 미칠 가능성이 거의 없습니다. 그러나 2019.2로 업그레이드한 후 브라우저 기반 사용자 시나리오를 테스트하는 것이 좋습니다. 사용자 시나리오가 영향을 받는 경우 이 헤더 동작을 사용하지 않도록 설정하거나 변경할 수 있습니다. 자세한 내용은 HTTP 응답 헤더를 참조하십시오.

맵 관련 인터넷 주소가 변경됨

2019.2부터 Tableau Server는 포트 443을 사용하여 두 개의 새로운 맵 위치에 액세스해야 합니다. 

  • mapsconfig.tableau.com
  • api.mapbox.com

이러한 주소는 이전 버전에서 사용되는 주소인 maps.tableau.com을 대체합니다. 적절한 인터넷 액세스를 위해 Tableau Server를 구성하는 방법에 대한 자세한 내용은 Tableau Server의 프록시 구성을 참조하십시오.

버전 2019.1의 변경된 기능

Tableau Server 2019.1의 모든 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

고해상도 축소판

버전 2019.1 이상에서는 통합 문서 및 뷰에 더 높은 해상도의 축소판이 사용됩니다. Tableau Server 버전 2019.1 이상으로 업그레이드하면 백그라운더가 축소판 업그레이드 큐에 넣기 작업 및 축소판 업그레이드 작업을 실행합니다. 이 작업은 아래 그림에 표시된 것과 같이 Tableau 버전 2018.2 이상에서 편집되거나 게시되지 않은 모든 뷰의 축소판을 새로 고치고 낮은 해상도의 축소판 이미지(192 x 192 픽셀)에서 높은 해상도의 축소판 이미지(300 x 300 픽셀)로 변환합니다.

축소판 업그레이드 작업이 축소판 이미지를 새로 고치면 뷰의 수정한 날짜가 축소판 업데이트 날짜와 일치하도록 변경됩니다. 축소판 업그레이드 작업은 내장된 뷰의 축소판을 업데이트할 때 통합 문서의 수정한 날짜를 변경하지 않습니다.

축소판 업그레이드 작업이 완료될 때까지 축소판이 흐리게 나타날 수 있습니다. 보유한 통합 문서의 수에 따라 이 작업은 몇 분에서 몇 시간 동안 실행될 수 있습니다. Tableau Server 2019.1로 업그레이드한 후 최대 일주일 동안 축소판 이미지가 저해상도로 나타날 수 있습니다. 자세한 내용은 축소판 업그레이드 작업을 참조하십시오.

프로젝트 카드 이미지

버전 2019.1 이상에서 프로젝트 카드에 프로젝트 카드 이미지를 표시하려면 해당 이미지를 프로젝트 설명의 마지막 항목으로 추가하고 !(느낌표)로 묶어야 합니다. 자세한 내용은 프로젝트 이미지 추가를 참조하십시오.

버전 2018.3의 변경된 기능

버전 2018.3에는 업그레이드 전에 숙지해야 하는 몇 가지 변경 사항이 있습니다.

Tableau Server 2018.3의 모든 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

부동형 워크시트 캡션이 투명해짐

부동형 캡션을 다시 보이게 만들려면 콘텐츠 작성자가 캡션 배경에 색상을 지정해야 합니다.

일부 데이터 엔진의 tsm configuration set 옵션 변경 사항

tsm set configuration 옵션에 새로운 두 구성 옵션 hyper.hard_concurrent_query_thread_limithyper.soft_concurrent_query_thread_limit가 추가되었습니다.

새 옵션은 Tableau Server 버전 2018.3 이하에서 사용할 수 있는 hyper.num_job_worker_threadshyper.num_task_worker_threads 옵션을 대체합니다. hyper.num_job_worker_threadshyper.num_task_worker_threads는 더 이상 사용되지 않으며 2019.1 이상에서 더 이상 작동하지 않습니다.

SSL 오프로딩 및 SAML

버전 2018.3부터 Tableau Server는 IdP에서 반환되는 SAML 응답 메시지의 유효성을 검사합니다. 조직에서 Tableau Server로 인증 요청을 보내기 전에 프록시 서버에서 IdP의 SSL 연결을 종료하는 경우 2018.2에서 업그레이드한 후부터 사용자가 SAML을 사용하여 로그인하지 못할 수 있습니다.

이 시나리오에서 SSL은 프록시 서버에서 "오프로드"됩니다. 이것은 https 요청이 프록시 서버에서 종료된 다음 http를 통해 Tableau Server로 전달된다는 의미입니다. SSL은 프록시에서 오프로드되므로 Tableau Server는 수신한 프로토콜(http)로 유효성을 검사하지만 IdP 응답은 https로 형식화되어 있으므로, 프록시 서버에 https로 설정된 X-Forwarded-Proto 헤더가 포함되어 있지 않으면 유효성 검사가 실패합니다. 자세한 내용은 Tableau Server의 프록시 구성을 참조하십시오.

버전 2018.2의 변경 사항

버전 2018.2에는 업그레이드 전에 확인해야 할 몇 가지 중요한 변경 사항이 있습니다.

Tableau Server 2018.2의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

다음 섹션에서는 Tableau Server 2018.2의 중요한 변경 사항을 요약하여 설명하고 추가적인 정보로 연결되는 링크를 제공합니다.

Tableau 서비스 관리자

버전 2018.2부터 Windows 기반 Tableau Server에서 TSM(Tableau 서비스 관리자)을 사용할 수 있습니다. TSM은 서버 구성 유틸리티 및 tabadmin 명령줄 유틸리티를 대체하는 웹 기반 서버 구성 및 관리 유틸리티입니다. 이전 버전의 Tableau에 익숙한 서버 관리자에게 있어서 이는 많은 변화를 의미합니다. TSM에 대한 자세한 내용과 이전 구성 유틸리티 및 tabadmin과의 차이점을 알아보려면 다음 항목을 참조하십시오.

이전 버전의 Tableau Server(버전 2018.1 이하)에서 업그레이드하려면 몇 가지 특수한 단계를 수행해야 합니다. 이 상황에 해당하는 경우 다음 항목을 읽어 보십시오.

2노드 클러스터의 리포지토리 이동은 지원되지 않음

TSM(Tableau 서비스 관리자)이 도입되면서 2노드 클러스터의 초기(주) 노드에서 리포지토리를 이동할 수 없습니다. 버전 2018.1 이상에서는 두 번째 노드에 두 번째 리포지토리를 추가한 다음 첫 번째 리포지토리를 제거할 수 있습니다. TSM을 사용하면 2노드 클러스터에 두 번째 리포지토리를 추가할 수 없습니다. 즉, 초기 노드에서 리포지토리를 이동할 수 없습니다.

Tableau Server Apache 로그에 대한 업데이트

/logs/httpd에 저장되는 Apache 로그 파일의 레코드 형식이 다음과 같이 개선되었습니다.

  • 서버 이름이 UseCanonicalName 설정에 따라 표시됩니다. 따라서 다중 노드 서버 배포의 여러 노드를 더 쉽게 구분할 수 있습니다.
  • 이제 날짜 및 시간이 단일의 date-and-time 문자열로 추적됩니다. 이 문자열은 Tableau Desktop을 비롯한 다양한 데이터 분석 도구에서 단일 값으로 바로 인식됩니다.
  • 표준 시간대의 구문 분석이 쉬워졌습니다.
    • Linux에서는 UTC의 숫자 오프셋이 제공됩니다.
    • Windows에서는 표준 시간대의 이름이 따옴표 안에 표시됩니다.

Tableau Server 버전 2018.1 이하 릴리스의 로그 항목 예를 보면 날짜, 시간 및 표준 시간대 형식이 어떻게 변경되었는지 알 수 있습니다.

::1 - - 2018-05-09 08:51:48.872 GMT Daylight Time 80 "POST /vizql/w/Regional/v/Obesity/sessions/A971A92AF77A4F4A9813065BDCEB24D6-0:0/commands/tabsrv/render-tooltip-server HTTP/1.1" "-" 200 445 "593" 135021 WvKolPH4UcM5KrzUbLi8EwAAA@E

비교를 위해 Tableau Server 버전 2018.2의 다음 로그 항목을 확인해 보십시오.

10.210.24.3 127.0.0.1 - 2018-05-09T16:07:58.120 "GMT Daylight Time" 80 "POST /vizql/w/Superstore/v/Overview/bootstrapSession/sessions/185CCDC854A44765BB0298E93B403879-0:3 HTTP/1.1" "-" 200 136026 "784" 2370951 WvMOzgKIhfzh9kFWO@ow2gAAA1Y

이제 읽기 전용 사이트 역할이 사용되지 않음

Tableau Server 버전 2018.1에 도입되었던 읽기 전용 사이트 역할이 이제 사용되지 않습니다. 버전 2018.1에서 이 사이트 역할에 할당된 모든 사용자는 버전 2018.2로 업그레이드한 후 Viewer(뷰어) 사이트 역할에 재할당됩니다. 사이트 역할에 대한 자세한 내용은 사용자의 사이트 역할 설정을 참조하십시오.

tabcmd initialuser 명령이 암호를 묻는 메시지를 표시함

이전 버전에서는 tabcmd initialuser 명령을 사용할 때 --password 매개 변수를 초기 관리자 암호로 설정해야 했습니다. 이 버전의 Tableau Server에 포함된 tabcmd에서는 --password 매개 변수를 명령에서 설정하지 않고 셸에서 입력할 수 있습니다. initialuser를 참조하십시오.

버전 2018.1에서 변경된 기능

버전 2018.1에는 업그레이드 전에 확인해야 하는 몇 가지 변경 사항이 있습니다.

Tableau Server 2018.1의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

제거된 tabadmin 명령 옵션

이전 버전부터 사용되고 있지 않은 --license--administrator 옵션은 tabcmd createsiteusers, tabcmd createuserstabcmd syncgroup 명령을 사용할 때 더 이상 사용할 수 없습니다. 이러한 변경 사항으로 인해 여전히 --license 또는 --administrator 옵션을 사용하는 스크립트는 더 이상 작동하지 않습니다. 스크립트를 업데이트하려면 이러한 명령에서 --role 옵션을 사용하여 라이선스 수준이나 사이트 역할을 지정합니다. 자세한 내용은 tabcmd 명령을 참조하십시오.

버전 10.5에서 변경된 기능

버전 10.5에는 업그레이드 전에 숙지해야 하는 몇 가지 변경 사항이 있습니다.

Tableau Server 10.5의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

다음 섹션에서는 Tableau Server 10.5의 중요한 변경 사항을 요약하여 설명하고 추가적인 정보로 연결되는 링크를 제공합니다.

Tableau Server 구성 변경 사항

Hyper는 Tableau Server 10.5에서 새로운 데이터 엔진을 구동하고 아래에 설명되어 있는 변경 사항을 도입합니다. 자세한 내용은 Tableau Server 데이터 엔진을 참조하십시오.

버전 10.5부터 파일 저장소, Vizportal, VizQLServer, 데이터 서버 또는 백그라운더를 설치할 경우 Tableau 설치 프로그램에서 데이터 엔진을 자동으로 설치하며 이러한 데이터 엔진을 개별적으로 설치할 수 없습니다. 이러한 프로세스 중 하나의 인스턴스가 있는 모든 노드에도 데이터 엔진 프로세스의 단일 인스턴스가 있습니다. 더 이상 한 노드에서 데이터 엔진의 여러 인스턴스를 구성할 수 없습니다. Tableau Server 프로세스에 대한 자세한 내용은 Tableau Server 프로세스를 참조하십시오.

이전에 버전 10.4 이하의 분산 설치에서는 추출을 만들거나 새로 고치는 동안 백그라운더 프로세스가 데이터 엔진(tdeserver64.exe) 프로세스의 임시 인스턴스를 시작했습니다. Tableau Server 10.5에서는 백그라운더를 설치할 때 데이터 엔진의 단일 인스턴스가 자동으로 설치됩니다. 백그라운더 프로세스에서는 동일한 노드에 설치되어 있는 이 데이터 엔진의 단일 인스턴스를 사용합니다. 구성 권장 사항에 대한 자세한 내용은 분산 설치 권장 사항을 참조하십시오.

업그레이드가 다중 노드 클러스터의 현재 구성(특히 특정 프로세스가 개별 노드에 분리되어 있는 경우)에 영향을 미칠 수 있습니다. 자세한 내용은 Tableau Server 데이터 엔진을 참조하십시오.

추출 변경 사항

버전 10.5부터 새 추출은 새 .hyper 형식을 사용합니다. 향상된 데이터 엔진은 .tde 파일 형식과 .hyper 파일 형식을 모두 읽을 수 있으므로 최신 버전의 Tableau Server에서는 .tde 추출을 사용하는 통합 문서를 계속 보고 읽을 수 있습니다.

Tableau Server 또는 Tableau Desktop 업그레이드 프로세스 중에 기존 추출은 자동으로 업그레이드되지 않습니다. .tde 추출에서 특정 추출 작업을 수행하는 경우에만 추출이 .hyper 형식으로 업그레이드됩니다. 예를 들어 자동 또는 예약된 새로 고침은 .tde 추출을 .hyper 추출로 업그레이드합니다.

참고: 추출 API 2.0을 사용하여 추출(.hyper)을 만들려면 Tableau 10.5 이상이 필요합니다. Tableau 10.4 이하를 사용하는 경우 이전과 마찬가지로 Tableau SDK를 사용하여 .tde 추출을 만드십시오. Tableau SDK는 더 이상 유지 관리되지 않습니다. 자세한 내용은 추출 API 2.0(영어)을 참조하십시오.

버전 호환성

업그레이드된 추출은 하위 호환성이 없습니다. 추출이 .tde 형식에서 .hyper 형식으로 업그레이드된 후에는 Tableau Desktop 10.4 이하에서 열거나 새로 고칠 수 없습니다. 조직의 Tableau Server와 모든 Tableau Desktop을 동일한 버전으로 유지하고 같은 일정에 10.5로 업그레이드하는 것이 좋습니다. 구체적인 추출 호환성 시나리오에 대한 자세한 내용은 추출 업그레이드의 영향를 참조하십시오.

Viewer(뷰어)(게시 가능) 및 라이선스 없음(게시 가능) 사이트 역할 제거됨

Viewer(뷰어)(게시 가능)라이선스 없음(게시 가능) 사이트 역할은 더 이상 사용되지 않으며 앞으로는 사용할 수 없습니다. Tableau Server 10.4 이하에서 이러한 사이트 역할 중 하나를 갖는 사용자는 Tableau Server 10.5에서 사이트 역할이 재할당됩니다.

더 이상 사용되지 않는 사이트 역할 10.5에서 재할당되는 사이트 역할
Viewer(뷰어)(게시 가능) Viewer(뷰어)
라이선스 없음(게시 가능) 라이선스 없음

중첩된 프로젝트 및 콘텐츠 탐색

이제 더 넓은 영역에서 콘텐츠를 하위 섹션으로 분리하려는 경우 프로젝트 계층을 만들 수 있습니다. 예를 들어 부서별 프로젝트를 만들 수 있습니다. 각 최상위 프로젝트에서 대상 독자가 사용하는 방식에 따라 콘텐츠를 분리할 수 있습니다. 예를 들어 인증된 데이터에 연결하는 작업과 진행 중인 공동 작업을 분리할 수 있습니다. 자세한 내용은 다음 문서를 참조하십시오.

중첩된 프로젝트 및 tabcmd

tabcmd를 사용하여 프로젝트 계층에서 최상위 프로젝트만 지정할 수 있습니다. 하위 프로젝트 또는 하위 프로젝트 내의 콘텐츠에 수행할 작업을 자동화하려면 해당하는 Tableau REST API 호출을 사용해야 합니다.

일부 작업은 REST API를 통해 사용할 수 없습니다. Windows 기반 Server를 사용하며 예약되지 않은 추출 새로 고침을 실행하거나 추출에 파일을 추가하려는 경우 가능한 대안은 Tableau 데이터 추출 명령줄 유틸리티를 사용하는 것입니다.

필터링된 검색이 기본적으로 숨겨짐

이제 필터링된 검색 옵션이 페이지 오른쪽에 위치하고 기본적으로 숨겨집니다. 필터 패널이 열려 있으면 이 토글이 어두운 아이콘()으로 표시되고, 필터 패널이 닫혀 있으면 밝은 아이콘()으로 표시됩니다. 검색에 대한 자세한 내용은 콘텐츠 검색을 참조하십시오.

필터링된 검색을 사용하려면 아이콘을 클릭합니다.

버전 10.4에서 변경된 기능

버전 10.4에는 업그레이드 전에 확인해야 하는 다음과 같은 변경 사항이 포함되어 있습니다.

Tableau Server 10.4의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

다음 섹션에서는 Tableau Server 10.4의 중요한 변경 사항을 요약하여 설명하고 추가적인 정보로 연결되는 링크를 제공합니다.

대시보드 레이아웃

작성 기능에 정확한 대시보드 간격 기능이 추가되어 기존 대시보드의 요소가 몇 픽셀씩 이동될 수 있습니다. 이것은 바둑판식 및 부동형 요소에 모두 영향을 줄 수 있습니다. 업그레이드를 테스트하는 동안 기존 대시보드의 레이아웃을 확인하는 것이 좋습니다. 자세한 내용은 Tableau 사용자 도움말에서 대시보드 간격의 정확성 개선을 참조하십시오.

버전 10.3의 변경된 기능

버전 10.3에서 업그레이드에 영향을 미치는 변경 사항은 없습니다.

Tableau Server 10.3의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

버전 10.2의 변경된 기능

버전 10.2에서 업그레이드에 영향을 미치는 변경 사항은 없습니다.

Tableau Server 10.2의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

버전 10.1에서 변경된 기능

버전 10.1에는 업그레이드 전에 숙지해야 하는 몇 가지 변경 사항이 있습니다.

Tableau Server 10.1의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

다음 섹션에서는 Tableau Server 10.1의 중요한 변경 사항을 요약하여 설명하고 추가적인 정보로 연결되는 링크를 제공합니다.

더 이상 Tableau Server와 함께 TabcmdInstaller.exe가 설치되지 않음

Tableau Server를 설치할 때 tabcmd 유틸리티를 위한 설치 프로그램이 더 이상 \extras 폴더에 설치되지 않습니다. 유틸리티 자체(tabcmd.exe)는 Tableau Server를 설치할 때 여전히 주 노드에 설치되지만 다른 컴퓨터에 이 유틸리티를 설치하기 위한 별도의 설치 프로그램은 없습니다. 추가 컴퓨터에 tabcmd 유틸리티를 설치해야 한다면 Tableau Software에서 유틸리티를 다운로드할 수 있습니다. 자세한 내용은 tabcmd를 참조하십시오.

버전 10.0에서 변경된 기능

버전 10.0에는 업그레이드 전에 숙지해야 하는 몇 가지 변경 사항이 있습니다.

Tableau Server 10.0의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

다음 섹션에서는 Tableau Server 10.0의 중요한 변경 사항을 요약하여 설명하고 추가적인 정보로 연결되는 링크를 제공합니다.

Tableau Server 설치 프로그램 변경 사항

이 섹션에 설명된 변경 사항은 업그레이드 프로세스에 중대한 영향을 미칩니다.

이전 버전을 수동으로 제거하지 않아도 됨

버전 10.0부터는 이전 버전을 수동으로 제거하지 않고 Tableau Server를 업그레이드할 수 있습니다(이전 버전이 64비트 8.2 이상인 경우). 설치 프로그램을 실행하면 기존 버전의 Tableau Server가 인식되고 업그레이드 프로세스 중에 제거됩니다.

참고: 버전 10.0으로 업그레이드하는 경우 원한다면 업그레이드 전에 기존 버전을 수동으로 제거하고 10.0 이전 버전과 동일한 업그레이드 프로세스를 수행할 수 있습니다.

설치 프로그램에서 백업 옵션을 사용할 수 있음

새 작업 흐름에 따라 설치 프로그램에서 기존 버전의 Tableau Server를 제거하도록 하면 설치 프로세스 중에 Tableau 설치의 전체 백업이 만들라는 메시지가 표시됩니다. 이 백업은 안전을 위한 수단으로 업그레이드 중에 예기치 않은 문제가 발생한 경우 사용됩니다. 설치의 최신 백업이 이미 있는 경우 업그레이드 중에 백업을 건너뛰어 시간을 절약할 수 있습니다. 자세한 내용은 Tableau Server 업그레이드 옵션을 참조하십시오.

2노드 설치가 리포지토리의 단일 인스턴스로 제한됨

Tableau Server의 2노드 설치를 구성하는 경우 단일 리포지토리로 제한됩니다. 리포지토리가 두 개인 2노드 설치를 업그레이드하는 경우 한 인스턴스를 제거하라는 메시지가 나타납니다. 자세한 내용은 2노드 클러스터에 Tableau Server 설치를 참조하십시오.

tableausoftware.com에서 tableau.com으로 도메인 변경

버전 10.0부터 라이선스 서버가 tableau.com에 위치합니다. 10.0 이전 버전에서 이 서버는 tableausoftware.com에 위치했습니다. 버전 10.0의 경우 tableausoftware.com을 지정하는 모든 방화벽 규칙 또는 프록시 구성을 업데이트해야 합니다. 프록시 설정에 대한 자세한 내용은 Tableau Server의 프록시 구성을 참조하십시오.

참고: Tableau Server 이전 버전에서는 계속해서 tableausoftware.com 도메인에 있는 라이선스 서버에 액세스합니다. 조직에서 10.0 이전 버전의 Tableau Server를 실행하는 경우 프록시 및 방화벽 설정에 계속 tableausoftware.com을 사용해야 합니다.

최소 하드웨어 요구 사항이 조정됨

버전 10.0의 Tableau Server는 2코어 컴퓨터에 설치될 수 있습니다. (이전에 Tableau Server에는 최소 4개의 코어가 필요했습니다.) 2코어 구성을 사용하여 제한된 하드웨어에서 Tableau Server를 테스트할 수 있습니다. 이 구성은 평가와 프로토타입 제작 전용입니다. 자세한 내용은 Tableau Server의 최소 하드웨어 요구 사항 및 권장 사항을 참조하십시오.

Tableau Server를 더 이상 32비트 응용 프로그램으로 사용할 수 없음

버전 10.0의 Tableau Server는 64비트 응용 프로그램으로만 사용할 수 있습니다. 32비트 버전의 Tableau Server를 버전 10으로 업그레이드하는 것과 관련된 정보는 32비트에서 64비트 Tableau Server로 업그레이드를 참조하십시오.

Tableau Server가 더 이상 Windows Vista 또는 Windows Server 2008을 지원하지 않음

버전 10.0부터 Tableau Server가 더 이상 Microsoft Windows Vista 또는 Windows Server 2008을 지원하지 않습니다(Windows Server 2008 R2는 여전히 지원됨).

Tableau Server에서 Microsoft Internet Explorer의 이전 버전이 더 이상 지원되지 않음

버전 10.0부터 Tableau Server가 더 이상 Microsoft Internet Explorer 8, 9 또는 10을 지원하지 않습니다.

이 변경 사항은 Windows 8 또는 Windows Server 2012(R2 제외)에 Tableau Server를 처음 설치하는 고객에게 영향을 미칩니다. 두 운영 체제 모두 Internet Explorer 11을 지원하지 않습니다.

Tableau Server 구성을 완료하려면 서버 컴퓨터의 브라우저를 사용하여 관리자 계정을 추가해야 합니다. 그러려면 Tableau Server에서 지원되는 브라우저가 필요합니다. 따라서 Windows 8.0 및 Windows Server 2012(R2 제외)에서는 최신 버전의 Chrome, Firefox 또는 Safari를 사용해야 합니다. 초기 설치가 완료된 후에는 이 브라우저를 제거할 수 있습니다.

참고: Tableau Server의 업그레이드 또는 복원에는 브라우저가 필요하지 않으므로 위 변경 사항은 초기 설치 및 구성에만 영향을 미칩니다.

Microsoft의 Internet Explorer 지원 정책에 대한 자세한 내용은 Microsoft 지원 주기를 참조하십시오.

Tableau Server가 Microsoft Internet Explorer 11 이상을 호환성 모드에서 지원하지 않음

Tableau Server 버전 10.0은 Internet Explorer 11 이상에서 레거시 호환성 모드를 지원하지 않습니다.

이 변경 사항은 Internet Explorer가 HTML DOCTYPE 값을 사용하여 호환성 모드로 설정된 웹 페이지에서 내장된 Tableau 뷰를 보는 사용자에게 영향을 미칩니다. 따라서 호환성 모드를 강제하는 SharePoint 구성에서 문제가 될 수 있습니다. 브라우저가 호환성 모드로 전환되는 웹 페이지가 사용자에게 표시되지 않도록 하려면 Internet Explorer가 호환성 모드로 전환되지 않도록 구성을 조정하거나 Chrome, Firefox 또는 Safari와 같은 지원되는 다른 브라우저를 사용합니다.

API 서버 프로세스(wgserver)가 제거되었음

API 서버 프로세스(wgserver)가 Tableau Server에서 제거되었습니다. 이 프로세는 버전 9.3에서 사용할 수 있었지만 기본적으로 해제되어 있었습니다. 이전에 API 서버 프로세스는 REST API를 지원하기 위해 사용되었지만 버전 9.3부터 이 기능은 응용 프로그램 서버 프로세스로 이동되었습니다. 이제 이전 버전의 Tableau Server에서 명시적으로 사용하도록 설정한 경우에도 이 API 서버 프로세스가 제거됩니다. REST API 변경 사항에 대한 자세한 내용은 REST API의 새로운 기능을 참조하십시오.

참고: 기록과 관련된 이유로 일부 tabadmin 구성 옵션은 "wgserver"를 옵션 이름으로 사용하지만 이 이름이 이전 API 서버를 나타내지는 않습니다.

버전 9.3의 변경된 기능

버전 9.3에는 업그레이드 전에 확인해야 하는 몇 가지 변경 사항이 있습니다.

Tableau Server 9.3의 새로운 기능에 대한 자세한 내용은 Tableau Server의 새로운 기능을 참조하십시오.

Tableau Server 9.3으로 업데이트하면 다음과 같은 영향이 있습니다.

하드웨어에 기반하는 새 기본 구성

Tableau Server 설치 프로그램이 컴퓨터의 하드웨어를 감지하고 단일 서버 설치 및 다중 서버 설치의 주 서버에 대한 최적의 기본 구성을 만듭니다. 새로운 기본 구성은 Tableau Server 프로세스 유형에 대해 실행할 프로세스의 수를 결정합니다.

이전에 기본 구성을 수락한 단일 서버 또는 다중 서버 설치에서 업그레이드하면 업그레이드 프로세스가 구성을 새 하드웨어에 기반하는 기본 구성으로 변경합니다. 그러나 사용자 지정 개수의 서버 프로세스를 구성한 서버를 업그레이드할 경우 업그레이드에서 단일 서버 및 다중 서버 업그레이드에 대해 사용자 지정 구성을 둘 다 유지합니다.

업그레이드 후 이전 기본 구성으로 되돌릴 경우, 다음 테이블을 사용하여 주 서버의 CPU 코어 수를 기반으로 Tableau Server 구성 유틸리티에 설정할 프로세스 수를 결정합니다.

프로세스 수

  VizQL 서버 데이터 서버 백그라운더
  9.3 이전 9.3 9.3 이전 9.3 9.3 이전 9.3
8개 코어 2 2 1 2 1 2
12개 코어 2 3 1 2 1 2
16개 이상 코어 2 4 1 2 1 2

참고: Tableau Server를 설치한 컴퓨터에 8개 미만의 CPU 코어가 있는 경우 각 프로세스에 하나의 코어를 실행하는 기본 구성이 변경되지 않았습니다.

9.3의 기본값에 대한 자세한 내용은 주 서버 설치 기본값을 참조하십시오.

Tableau Server에 대한 프로세스 수 설정에 대한 자세한 내용은 프로세스 재구성을 참조하십시오.

고가용성 Postgres 리포지토리 - 더 빠른 장애 조치

수동 리포지토리를 활성 상태로 만든 후 프로세스를 다시 시작할 필요가 없도록 장애 조치 프로세스가 개선되었습니다. 따라서 리포지토리 장애 조치 시 발생하는 가동 중단이 크게 줄어듭니다.

분산 설치 - 수동 작업자 업그레이드

타사 소프트웨어에 대한 업데이트 때문에 버전 9.3으로 업그레이드할 경우 작업자 노드를 수동으로 업그레이드해야 합니다. 9.3 설치 중에 작업자 노드는 자동으로 업그레이드할 수 없음을 알리는 메시지가 표시됩니다. 업그레이드에 대한 자세한 내용은 업그레이드 수행을 참조하십시오.

API 서버(wgserver)가 더 이상 사용되지 않음

API 서버 프로세스가 더 이상 사용되지 않습니다. 버전 9.3에서 프로세스를 Tableau Server에서 계속 사용할 수 있지만 신규 설치의 경우 기본적으로 비활성화됩니다. 이전에 API 서버 프로세스는 REST API를 지원하기 위해 사용되었지만 버전 9.3부터 이 기능은 응용 프로그램 서버 프로세스로 이동되었습니다. 이전 버전의 Tableau Server에서 API 서버 프로세스를 명시적으로 활성화한 경우 9.3에서 계속 활성화됩니다.

 

피드백을 제공해 주셔서 감사합니다! 피드백을 제출하는 동안 오류가 발생했습니다. 다시 시도하거나 메시지를 보내주십시오.