Packaged Workbooks

Workbooks often reference external resources. For example, workbooks might reference background images or local file data sources such as Excel files, Access files, and Tableau extract files (.hyper or .tde).

When you save a workbook, links to these resources are also saved. The next time you open the workbook, the views are automatically updated with any changes that may have occurred to the data and images. In most cases, you will want to save the workbook in this way. But if you plan to share the workbook with someone who does not have access to the referenced resources or to Tableau Server, you might want to save a packaged workbook instead.

Packaged workbooks contain the workbook along with a copy of any local file data sources and background images. The workbook is no longer linked to the original data sources and images. These workbooks are saved with a .twbx file extension. Other users can open the packaged workbook using Tableau Desktop or Tableau Reader.

Create a .twbx with file-based data sources

  1. Select File > Save As.

  2. Specify a file name for the packaged workbook in the Save As dialog box.

  3. Select Tableau Packaged Workbooks on the Save as type drop-down list.

  4. Click Save.

The default location is the Workbooks folder of the Tableau repository. However, you can save packaged workbooks to any directory you choose.

The following files are included in packaged workbooks:

  • Background images

  • Custom geocoding

  • Custom shapes

  • Local cube files

  • Microsoft Access files

  • Microsoft Excel files

  • Tableau extract files (.hyper or .tde)

  • Text files (.csv, .txt, etc.)

If you are sharing packaged workbooks that contain Microsoft Excel or Access 2007 data sources, the people opening the workbook must either have Microsoft Excel and Access 2007 or the Office 2007 Data Connectivity Components installed on their computers. The data connectivity components are available on the Tableau Tableau Drivers page.

Create a .twbx with non-file-based data sources

If the workbook contains connections to enterprise data sources or other non-file-based data sources, such as Microsoft SQL, Oracle, or MySQL, the data must be extracted from the data sources for it to be included in a packaged workbook (.twbx).

  1. In the workbook, right-click the data source in the Data pane and choose Extract Data.

  2. In the Extract Data dialog box, click the Extract button to extract all data from the data source.

    After the extract completes, the data source icon changes to indicate that an extract is active for that data source. Instead of a single cylinder, there are two cylinders connected by an arrow.

  3. Optional: Repeat the above steps for each data source in the workbook.

  4. Select File > Save As.

  5. From the Save as type drop-down menu, select Tableau Packaged Workbook (*.twbx).

    After the extracts have been created for all non-file-based data sources and the packaged workbook has been saved, you can send your workbook.

Create a .twbx with Tableau Server data sources

If the workbook contains connections to a published Tableau Server data source, you must download a local copy of the Tableau Server data source, take an extract of it, and then replace the connection to the local copy for it to be included in a packaged workbook (.twbx).

  1. In the workbook, right-click the published data source in the Data pane, and then select Create Local Copy.

    A copy of the published data source is added to the Data pane.

  2. Right-click the local copy, and select Extract Data.
    Note: If the local copy is a published extract you can skip this step.

  3. In the Extract Data dialog box, click the Extract button to extract all data from the data source. Creating an extract of the data source allows the person you are sharing the workbook with to have access to a copy of the data source.

  4. In the Data pane, right-click the published data source, and then select Replace Data Source.

  5. Verify that the published data source will be replaced by the local data source, and then click OK.

  6. Right-click the published data source, and then click Close.

  7. Select File > Save As.

  8. From the Save as type drop-down menu, select Tableau Packaged Workbook (*.twbx).

    After the local copy and extract of the local copy is created and the packaged workbook saved, you can send your workbook.

Unpackage a .twbx

Packaged workbooks can be unpackaged.

On a Windows or macOS computer, rename the file with a .zip extension (for example, from myfile.twbx to myfile.zip) and then double-click it.

When you unpackage a workbook, you get a regular workbook file (.twb), along with a folder that contains the data sources and images that were packaged with the workbook.

Thanks for your feedback! There was an error submitting your feedback. Try again or send us a message.