Extrahieren des Upgrades in das .hyper-Format

Neues .hyper-Extraktformat

Ab Version 10.5 wird beim Erstellen eines neuen Extrakts anstelle des .tde-Formats das .hyper-Format verwendet. Extrakte im .hyper-Format profitieren von der verbesserten Daten-Engine. Diese unterstützt dieselbe schnelle analytische und Abfrageleistung wie die Daten-Engine zuvor, aber sogar für noch größere Extrakte.

Darüber hinaus bietet die Verwendung von .hyper-Extrakten viele Vorteile. Zu den Hauptvorteilen zählen:

  • Erstellen größerer Extrakte: Sie können Extrakte mit Milliarden an Datenzeilen erstellen. Da .hyper-Extrakte mehr Daten unterstützen können, können Sie die .tde-Extrakte konsolidieren, die Sie zuvor separat in einem einzelnen .hyper-Extrakt erstellen mussten.

  • Schnelleres Erstellen und Aktualisieren von Extrakten: Tableau hat zwar schon immer an der Leistung bei der Erstellung und Aktualisierung von Extrakten geschraubt, Version 2021.3 ist in dieser Hinsicht jedoch unübertroffen – und dies selbst bei noch größeren Datensätzen.

  • Bessere Leistung bei der Interaktion mit Ansichten, die Extraktdatenquellen verwenden: Während kleinere Extrakte weiterhin effizient funktionieren, funktionieren größere Extrakte effizienter.

Ursachen eines Extrakt-Upgrades

Auch wenn Sie .tde-Extrakte weiterhin in Version 2021.3 öffnen und mit ihnen interagieren können, wird der .tde-Extrakt auf einen .hyper-Extrakt aktualisiert, wenn Sie eine Extraktaufgabe für einen .tde-Extrakt ausführen. Nach dem Upgrade des Extrakts sollten Sie folgende Einschränkungen bei der Rückwärtskompatibilität beachten:

  • Es ist nicht möglich, den Extrakt, für den ein Upgrade vorgenommen wurde, zurück zu einem .tde-Extrakt zu konvertieren.

  • Es ist nicht möglich, einen Extrakt, für den ein Upgrade vorgenommen wurde, in einer früheren Version von Tableau Desktop zu öffnen. Dies wirkt sich möglicherweise darauf aus, wie Sie und andere Benutzer möglicherweise mit .tde-Extrakten interagieren.

  • Sie können Als Version exportieren in Tableau Desktop nicht verwenden, um eine Arbeitsmappe herabzustufen, die einen .hyper-Extrakt enthält.

  • Sie können den Extrakt nicht als ältere Version über Tableau Desktop in Tableau Server veröffentlichen.

  • Das Öffnen einer Arbeitsmappe in Tableau Desktop 10.4 und früher, die von Tableau Server oder Tableau Online mithilfe der Option Tableau-Arbeitsmappe herunterladen heruntergeladen wurde, ist nicht möglich, falls die Arbeitsmappe einen .hyper-Extrakt enthält.

Ein Extrakt-Upgrade verursachende Aufgaben

Es gibt drei unterschiedliche Vorgehensweisen für das Aktualisieren eines .tde-Extrakts auf einen .hyper-Extrakt: 1. während einer Extraktaktualisierung (vollständig oder inkrementell), 2. beim Anfügen von Daten an einen Extrakt und 3. beim manuellen Aktualisieren eines Extrakts. Nachdem ein Extrakt mit Tableau Desktop aktualisiert wurde, wird es nicht automatisch entfernt, falls der .tde-Extrakt in anderen Arbeitsmappen referenziert wird.

Neben den Aufgaben, die zu einem Extrakt-Upgrade führen, können auch bei außerhalb von Tableau Desktop ausgeführten Extrakt-Aufgaben Upgrades an Ihrem .tde-Extrakt vorgenommen werden. Dies umfasst die folgenden Aufgaben:

  • Manuelle Aktualisierung (Tableau Server und Tableau Online)

  • Inkrementelle Aktualisierung einer veröffentlichten Extraktdatenquelle über Tableau Bridge (Tableau Online)

  • Eine geplante vollständige oder inkrementelle Extraktdatenquellen-Aktualisierung (Tableau Server und Tableau Online)

  • Eine geplante inkrementelle Extraktaktualisierung über Tableau Bridge (Tableau Online)

Auswirkung der Extraktaktualisierung

Wenn Sie in einer Umgebung arbeiten, in der die Versionsnummer von Tableau Desktop weder mit der von anderen verwendeten Tableau Desktop-Version noch mit der Version von Tableau Desktop oder Tableau Online übereinstimmt, kommt es möglicherweise zu Problemen mit der Extraktkompatibilität in Abhängigkeit von der Aufgabe, die Sie ausführen möchten.

Sie finden eine detaillierte Erklärung der Extraktkompatibilitätsszenarien(Link wird in neuem Fenster geöffnet) auf der Support-Seite von Tableau oder eine zusammenfassende Erklärung weiter unten. Diese verhelfen Ihnen zu einem besseren Verständnis dafür, wann es zu Extraktaktualisierungen und potenziellen Kompatibilitätsproblemen für Sie und andere Personen kommen kann.

Hinweis: In den folgenden Tabellen steht "10.4" für Tableau 10.4 und früher. Demgegenüber steht "10.5" für Tableau 10.5 und höher.

Aufgaben mit Tableau Desktop

Sie sollten die folgenden Kompatibilitätsszenarien in Bezug auf Extrakte bei in verschiedenen Versionen von Tableau Desktop durchgeführten Aufgaben kennen.

 

Aufgaben

Arbeitsmappe der Version 10.4 Arbeitsmappe der Version 10.5
.tde-Extrakt .tde-Extrakt .hyper-Extrakt
Neu erstellen in 10.4 Nicht möglich Nicht möglich
In 10.5 Nicht möglich Nicht möglich
Öffnen in 10.4 Arbeitsmappe kann nicht geöffnet werden, Sie werden aufgefordert, die Arbeitsmappe in 10.5 oder höher zu öffnen Arbeitsmappe kann nicht geöffnet werden, Sie werden aufgefordert, die Arbeitsmappe in 10.5 oder höher zu öffnen
In 10.5
Aktualisieren oder anfügen in 10.4 Nicht möglich Nicht möglich
In 10.5 Version der Arbeitsmappe bleibt unverändert, Extrakt wird aber zum .hyper-Format aktualisiert Version der Arbeitsmappe bleibt unverändert, Extrakt wird aber zum .hyper-Format aktualisiert
Arbeitsmappe veröffentlichen von 10.5 in Tableau Server 10.4 Veröffentlichung nicht möglich; im Dialogfeld "Veröffentlichen" wird zuerst die Meldung "Server führt eine ältere Version als Ihre Kopie von Tableau Desktop aus" und dann die Fehlermeldung "Für die Arbeitsmappe kann kein Downgrade durchgeführt werden" angezeigt Veröffentlichung nicht möglich; im Dialogfeld "Veröffentlichen" wird zuerst die Meldung "Server führt eine ältere Version als Ihre Kopie von Tableau Desktop aus" und dann die Fehlermeldung "Für die Arbeitsmappe kann kein Downgrade durchgeführt werden" angezeigt
von Tableau Server 10.5 in Tableau Server 10.5 oder Tableau Online
  von 10.4 in Tableau Server 10.5 oder Tableau Online    
Extraktdatenquelle veröffentlichen von 10.5 in Tableau Server 10.4 Kann nicht veröffentlicht werden, es wird die Fehlermeldung "Die Veröffentlichung kann nicht durchgeführt werden. Stellen Sie sicher, dass Sie mit einer kompatiblen Version verbunden sind" angezeigt Kann nicht veröffentlicht werden, es wird die Fehlermeldung "Die Veröffentlichung kann nicht durchgeführt werden. Stellen Sie sicher, dass Sie mit einer kompatiblen Version verbunden sind" angezeigt
von Tableau Server 10.5 in Tableau Server 10.5 oder Tableau Online
Herstellen einer Verbindung zu einer veröffentlichten Datenquelle von 10.4 in Tableau Server 10.5 oder Tableau Online
von Tableau Server 10.5 in Tableau Server 10.5 oder Tableau Online

Aufgaben in Tableau Server 10.5 oder Tableau Online

Bei der Arbeit mit in einer früheren Version von Tableau Desktop erstellten Extrakten sollten Sie die folgenden Kompatibilitätsszenarien in Bezug auf Extrakte bei in Tableau Server 2021.3 oder Tableau Online ausgeführten Aufgaben kennen.

 

Szenario

Arbeitsmappe der Version 10.4 Arbeitsmappe der Version 10.5
.tde-Extrakt .tde-Extrakt .hyper-Extrakt
Bearbeiten/Speichern in der Webdokumenterstellung für Tableau Server 10.4 Nicht möglich Nicht möglich
für Tableau Server 10.5 oder Tableau Online Arbeitsmappe wird zu Version 10.5 geändert, Extrakt verbleibt im .tde-Format
Bearbeiten/Speichern in der Webdokumenterstellung, dann Aktualisieren oder Anfügen für Tableau Server 10.4
für Tableau Server 10.5 oder Tableau Online Arbeitsmappe wird zu Version 10.5 geändert, und Extrakt wird zum .hyper-Format aktualisiert Version der Arbeitsmappe bleibt unverändert, Extrakt wird aber zum .hyper-Format aktualisiert
Herunterladen und öffnen in Tableau Desktop 10.4 Arbeitsmappe kann nicht geöffnet werden, es wird die Fehlermeldung "Diese Arbeitsmappe verwendet einen .hyper-Extrakt und ist mit dieser Version nicht kompatibel. Öffnen Sie die Arbeitsmappe in Version 10.5 oder höher" angezeigt. Anschließend wird gefragt, wo nach dem Extrakt gesucht werden soll Arbeitsmappe kann nicht geöffnet werden, es wird die Fehlermeldung "Diese Datei wurde in einer neueren Version erstellt. Aktualisieren Sie Tableau" angezeigt.
in Tableau Desktop 10.5
Exportieren als Version von Tableau Desktop 10.5 Option ist ausgegraut Option ist ausgegraut

Automatisierung von Extrakterstellungs-, Aktualisierungs- und Anfügeaufgaben

Bei der Arbeit mit in früheren Versionen von Tableau erstellten Extrakten sollten Sie die folgenden Kompatibilitätsszenarien in Bezug auf Extrakte bei der Automatisierung von Extrakterstellungs-, Aktualisierungs- und Anfügeaufgaben kennen.

 

Szenario

.tde-Extrakt .hyper-Extrakt
Neuen Extrakt erstellen Mit Tableau SDK Nicht möglich
Mit Extrakt-API 2.0 Nicht möglich
Aktualisieren oder anfügen mit Tableau-Befehlszeilenprogramm für Version 10.4 Nicht möglich
mit Tableau-Befehlszeilenprogramm für Version 10.5 Version der Arbeitsmappe bleibt unverändert, Extrakt wird aber zum .hyper-Format aktualisiert  √

Gründe für die Beibehaltung eines Extrakts im .tde-Format

Wenn Sie kein Upgrade für Tableau Desktop vornehmen können, muss Ihr Extrakt im .tde-Format bleiben.

Möglichkeiten zum Beibehalten eines Extrakts im .tde-Format

Damit ein Extrakt im .tde-Format verbleibt, sollten Sie kein Upgrade für den Extrakt vornehmen. Führen Sie, um zu vermeiden, dass für den Extrakt ein Upgrade auf einen .tde-Extrakt mithilfe von Tableau Desktop2021.3 vorgenommen wird, keine der im Abschnitt Ein Extrakt-Upgrade verursachende Aufgaben aufgeführten Aufgaben aus. Beachten Sie in diesem Fall die folgenden Vorschläge, wenn Sie eine .tde-Version eines Extrakts beibehalten müssen:

  • Führen Sie die Aufgaben zum Aktualisieren von Extrakten und zum Anfügen von Daten mit Tableau Desktop2021.3 aus. Behalten Sie jedoch eine frühere Tableau Desktop-Version und die Möglichkeit aufrecht, eine Verbindung zu den ursprünglichen Daten herstellen zu können, falls Sie den .tde-Extrakt neu erstellen müssen.

  • Verwenden Sie eine frühere Version von Tableau Desktop zum Ausführen von Extraktaufgaben. Dazu zählt beispielsweise die Extraktaktualisierung oder das Anfügen von Daten.

  • Deaktivieren Sie wenn möglich vorhandene Extraktaktualisierungszeitpläne für Tableau Server, Tableau Online oder Tableau Bridge, bis Sie ermitteln können, für welche Extrakte Upgrades erforderlich sind und für welche nicht.

Folgendes ist nach einer Extraktaktualisierung zu erwarten

Nach der Extraktaktualisierung können Sie von bestimmten weiteren Änderungen bei der Arbeit in Version 2021.3 ausgehen.

Änderungen beim Öffnen von Extrakten

Nach der Konvertierung eines .tde-Extrakts in einen .hyper-Extrakt ist es nicht möglich, den konvertierten Extrakt mithilfe einer früheren Version von Tableau Desktop zu öffnen. Im Folgenden finden Sie einige Vorschläge, die Probleme beim Öffnen von Extrakten beheben sollen.

  • Aktualisierung von Tableau Desktop auf 2021.3: Nach Möglichkeit sollten Sie ein Upgrade von Tableau Desktop auf 2021.3 vornehmen, um von .hyper-Extrakten zu profitieren. Weitere Informationen finden Sie im Tableau Desktop-Bereitstellungshandbuch unter Aktualisieren von Tableau Desktop(Link wird in neuem Fenster geöffnet).

  • Extrakt mithilfe einer vorherigen Version von Tableau Desktop neu erstellen: Zum Neuerstellen Ihres .tde-Extrakts müssen Sie in der Lage sein, unter Verwendung einer vorherigen Version von Tableau Desktop eine Verbindung zu den ursprünglichen Daten herzustellen. Weitere Informationen finden Sie unter Verbinden mit und Vorbereiten von Daten und Herunterladen von vorherigen Tableau-Versionen(Link wird in neuem Fenster geöffnet) in der Tableau Knowledge Base.

  • Vorherige Versionen einer veröffentlichten Extraktdatenquelle oder Arbeitsmappe abrufen: Bei aktiviertem Revisionsverlauf auf Tableau Server oder Tableau Online können Sie eine vorherige Version einer veröffentlichten Extraktdatenquelle oder einer veröffentlichten Arbeitsmappe herunterladen, die eine Extraktdatenquelle verwendet. Hinweis: Ältere von Ihnen abgerufene Arbeitsmappen, die eine im .twb-Format gespeicherte Extraktdatenquelle verwenden, erfordern, dass Sie den Extrakt neu erstellen, nachdem Sie die Arbeitsmappe in einer früheren Version von Tableau Desktop geöffnet haben. Weitere Informationen finden Sie unter Arbeiten mit Inhaltsrevisionen.

Änderungen bei der Freigabe von Extrakten

Wenn Sie die Daten in der Extraktdatenquelle direkt mit einer anderen Person teilen müssen (beispielsweise per E-Mail oder Dateifreigabe), sollten Sie den Extrakt unbedingt als .tdsx-Datei speichern. Alternativ können Sie die Arbeitsmappe mit den Extraktdaten als .twbx-Datei speichern. Wenn Sie anstelle einer .tdsx- oder .twbx-Datei nur die .hyper-Datei teilen, fehlen Metadaten über den .hyper-Extrakt wie die Verbindungsinformationen und Änderungen an Spaltennamen. Weitere Informationen finden Sie unter Tableau-Dateitypen und -Ordner.

Potenzielle Unterschiede bei der Extraktgröße

Die Größe von .tde-Extraktdateien kann je nach Komplexität Ihrer Daten variieren, und nach einer Extraktkonvertierung kann die Größe der entsprechenden .hyper-Extraktdateien ebenfalls aus den gleichen Gründen variieren. Es kann sein, dass einige .hyper-Extrakte nach der Extraktkonvertierung größer oder auch kleiner sind.

Änderungen an der Option "Als Version exportieren"

Falls Ihre Arbeitsmappe einen .hyper-Extrakt enthält, ist die Option Als Version exportieren im Menü "Datei" nicht verfügbar. Wenn Sie eine Arbeitsmappe, die einen .hyper-Extrakt enthält, mit einer älteren Version von Tableau öffnen müssen, müssen Sie zuerst den Extrakt aus der Arbeitsmappe entfernen, bevor Sie mithilfe der Option Als Version exportieren ein Downgrade der Arbeitsmappe durchführen können. Nach dem Downgrade der Arbeitsmappe müssen Sie den .tde-Extrakt neu erstellen.

Weitere Probleme

Informationen zu Fehlermeldungen, die nach einer Extraktaktualisierung angezeigt werden, finden Sie in den folgenden Artikeln in der Tableau Knowledge Base:

Änderungen an Ihrer Ansicht nach einem Extrakt-Upgrade

Nach dem Upgrade eines Extrakts bemerken Sie ggf. einige Änderungen an einer Ansicht, von der die Extraktdatenquelle verwendet wird. Der Grund dafür ist, dass Werte in Ihrem Extrakt in Version 2021.3 anders berechnet werden können. Zu den Änderungen zählen ggf. weniger Markierungen in der Ansicht, mehr Nullwerte, wenn Sie die Zusammenfassungsdaten untersuchen, oder dass die Ansicht an sich eine andere Form aufweist. In einigen seltenen Fällen ist die Ansicht möglicherweise sogar leer. Weitere Informationen über die Art der Änderung, zu der es unter Umständen kommt, wenn Sie in dieser Version von Tableau mit Extrakten interagieren, finden Sie unter Änderungen an Werten und Markierungen in der Ansicht.

Manuelles Upgrade Ihres Extrakts

Wenn Sie Extrakte lokal verwalten, können Sie Ihren .tde-Extrakt mit Tableau Desktop manuell auf einen .hyper-Extrakt aktualisieren.

  1. Öffnen Sie in Tableau Desktop eine Arbeitsmappe, in der ein .tde-Extrakt verwendet wird.

  2. Wählen Sie im Menü Daten die Extraktdatenquelle aus, und wählen Sie dann Extrakt > Upgrade aus.

  3. Wählen Sie Datei > Speichern aus. Daraufhin wird die Arbeitsmappe gespeichert, und das Extrakt-Upgrade ist abgeschlossen.
Vielen Dank für Ihr Feedback!