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Tableau Cloud Manual Migration
Guide
This guide explains how to manually migrate your Tableau Server deployment to Tableau

Cloud. In a nutshell, this guide is useful for administrators who are running a Tableau Server

with fewer than 100 users and who are comfortable with a fully manual, self-service migration

process.

If you have a lot more users and your data requirements are more complex, you may benefit

from working with professional services or an experienced migration partner to migrate to

Tableau Cloud. Further down, this topic includes guidance on how to plan your migration.

But first, let's make sure you understand why moving to Tableau Cloud is probably the smart

move for your organisation.

Why migration can make sense
If you are running a single Tableau Server for a small group of users, then it's almost

impossible not to save time and money by moving your operation to Tableau Cloud. The easy

win for moving to Tableau Cloud is savings in time, which tends to be in short supply for most

of us. And if you are a data scientist or analyst who has found themselves unexpectedly run-

ning a Tableau Server installation, migrate and get back to your data!

What about bigger organisations? If your organisation exceeds 100 users, then you will also

undoubtedly benefit from savings of cost and time at scale. Tableau Cloud is built to handle

big organisations, but this guide isn't. If you're looking to migrate a bigger organisation, check

out Tableau Cloud Migration where you can learn more about working with professional ser-

vices or an experienced migration partner.

For many organisations, Tableau Cloud will be faster and more reliable, with less bother than

whatever you are doing now to keep your Tableau Server humming. You will never need to
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face another major server upgrade, or even a maintenance release update, which, as you

know, is really just an upgrade smuggled in under another name. Tableau Cloud is always run-

ning the latest release, with the most up-to-date features. Reliability and performance are

baked into the service. After the migration process, your time with Tableau Cloud will be spent

managing users and data. That's it. You won't be troubleshooting service errors or combing

logs or restarting, and restarting.

Work with your account manager to figure out the costs for supporting your users. As you eval-

uate overall cost, remember that the single metric of per-user licensing expense does not

provide an apples to apples comparison between SAAS and self-hosting a server. This com-

parison is especially impoverished if you are not including the time spent managing Tableau

Server, and the capital cost of refreshing or leasing hardware. The annual cost of running a

single server in the cloud can be more than $10,000 a year. And of course any analysis must

include your staffing cost of maintenance, periodic updates and troubleshooting.

Dive deeper
l For a quick and relevant evaluation of moving to Tableau Cloud, see the blog post,
Should I Move My Analytics to Tableau Cloud?

l For more information about the advantages of moving from on-premises or self-hosted
to Tableau Cloud, see GigaOm's research article, CxO Decision Brief: SaaS Business
Intelligence Platforms.

l For a case study detailing cost savings and performance improvement in the real world,
see Splunk migration to Tableau Cloud eliminates server admin overhead and drives
better dashboard performance.

When migration doesn't make sense
The following list describes scenarios where continuing to manage your own instance of

Tableau Server instead of migrating can make sense. We’re committed to continually improv-

ing Tableau Cloud and will update this list as we release new features to address these gaps.

However, it is important that you verify that Tableau Cloud meets your requirements before

you decide to migrate. Please be sure to validate your requirements before moving forward

with a migration.

Tableau Software v

Tableau Cloud Manual Migration Guide

https://www.tableau.com/en-gb/blog/should-i-move-my-analytics-cloud
https://gigaom.com/reprint/cxo-decision-brief-saas-business-intelligence-platforms-tableau/
https://gigaom.com/reprint/cxo-decision-brief-saas-business-intelligence-platforms-tableau/
https://www.tableau.com/en-gb/solutions/customer/splunk-migrates-tableau-cloud-eliminates-server-admin-overhead
https://www.tableau.com/en-gb/solutions/customer/splunk-migrates-tableau-cloud-eliminates-server-admin-overhead


l Regulation and data residency: Your business operates in a space that must comply
with a regulatory (such as FedRAMP, PCI, etc.) or data residency requirement that
Tableau Cloud does not yet meet. Please review our list of current compliances and
check back often to learn when new certifications become available.

l Data sources: Your organisation relies on a data solution that does not work with
Tableau Cloud, is not supported by Tableau Bridge, or is otherwise beyond the scope
of your ownership to extract in a compatible way. Examples of such data sources
include cube data sources, custom connectors, packaged Tableau connector (.taco)
files, among others. The next topic, Plan Your Migration, walks through the different
supported data sources and options available in Tableau Cloud. You can also down-
load the free Tableau Cloud Migration Technical Readiness Assessment to see which
data sources you’re currently using and whether they are supported on Tableau Cloud.

l Site capacity: If you have more than 100 GB of data, take a look at Advanced Man-
agement for Tableau Cloud. Otherwise, review Tableau Cloud Site Capacity to optim-
ise any necessary consolidation. The Tableau Cloud Migration Technical Readiness
Assessment can help you identify assets that will require consolidation.

l Authentication: If you require LDAP for an external identity store, Kerberos authen-
tication or Kerberos delegated authentication.

l Data management: Tableau Prep Flows are not supported by Tableau Bridge. If you
require automated data updates with Tableau Prep Flows for data behind a private net-
work, see How to Run Tableau Prep Conductor Flows with On-Premises Data in
Tableau Cloud. Tableau Prep Flows using Python are also not supported by Tableau
Bridge.

Who should read this
This guide is written for the person or team of people who will be performing the migration to

Tableau Cloud. The guide is designed for Tableau Server installations that have 100 users or

less. This guide provides a step-wise, manual process to get your organisation from Tableau

Server to a fully-functional site in Tableau Cloud in a week or two.

After you migrate and create the core administrative functionality (identity/user, site con-

figuration, authentication, data connection, etc) in Tableau Cloud, the bulk of content migra-

tion can be shared with the creators at your organisation. A "creator" is a user who has a

Creator role-based licence. Depending on your goals, either you (the admin) or your creators
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can migrate content. For this reason, we've created a chunk of migration-related content you

can point your creators to. Users who migrate content need to have a Creators licence and

access to Tableau Desktop. If the creators will be migrating Tableau Prep flows, then they

must also have Tableau Prep Builder installed.

Post-migration
In this guide we will do our best to cover as much of the Tableau Cloud platform as possible,

but there are some features that administrators cannot set up on behalf of their end users.

Users will need to make some updates to their content after a migration is complete. There are

also some features that are better to recreate anew in Tableau Cloud with the benefit of using

cloud-native functionality.

Feature differences in Tableau Cloud

As mentioned previously, running Tableau Cloud vs managing your own Tableau Server is

much less labour intensive from an administrative perspective. You can find a summarised list

of the feature differences in the Tableau Server help topic, Technical Considerations for Migrat-

ing from Tableau Server to Tableau Cloud (Windows | Linux). Below are a few of the most com-

mon items.

l In Tableau Cloud, as the administrator, you do not have direct access to the Tableau
Server Repository (Windows | Linux). Instead, you can use Admin Insights to under-
stand what’s going on in your Tableau environment, including the current licensing state
and performance.

l Guest access is not available on Tableau Cloud. Instead use Connected Applications to
broaden access.

l Custom fonts are not available on content.
l Tableau Cloud uses a single site model to simplify administration. If you have multiple
Tableau Server sites, your content may need to be consolidated onto a single site.

Run the Tableau Cloud Migration Technical Readiness Assessment to understand if there are

any use cases that may need to be adapted before migrating to Tableau Cloud.
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Tasks that need to be completed by end users

There are some features that administrators cannot set up on behalf of their end users or that

require manual re-configuration. We’ve made a complete list available separately as an End-

User Migration Checklist so that you can share it directly with your users, but these tasks

include:

l Webhooks
l Embedding solutions updates
l Update REST API scripts
l Configuring Analytics Extensions

Version compatibility
 As a general rule, our documentation is based on recent-to-current versions of Tableau

Server, but because the process covered in this guide is not a programmatic or automated

migration, we don't foresee issues with migrating from older versions of Tableau Server to

Tableau Cloud. Strictly speaking, the process in this guide is more "port" than

"migration" when it comes to administrative configurations.

Licensing
Tableau Cloud uses Role-Based Subscription licensing. Tableau Server supports Role-

Based Subscription licensing and legacy pricing models. If you are on a different

(earlier) licensing model, please contact your Tableau account team to convert your licensing

to Role-Based Subscription.

Additional Support
After reading through this material you may decide that you'd prefer not to take on a manual

migration yourself, and would rather leave it to an expert. If so, please reach out to one of our

experienced migration partners to learn how they can help you accelerate a migration to

Tableau Cloud.
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Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist
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Plan Your Migration

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to

manually migrate Tableau Server deployments with fewer than 100 users to Tableau

Cloud.

This topic walks you through two important planning tasks you should complete before migrat-

ing: your data connectivity strategy and establishing your authentication mechanism. You can

find a summarised list of the feature differences in the Tableau Server help topic, Technical

Considerations for Migrating from Tableau Server to Tableau Cloud (Windows | Linux). Run

the Tableau Cloud Migration Technical Readiness Assessment to understand if there are any

use cases that may need to be adapted before migrating to Tableau Cloud.

Learn about Tableau Cloud
If you are new to Tableau Cloud, we recommend that you learn more about the platform by

signing up for a self-guided course online. These courses can serve as an introduction to

Tableau Cloud and will give you some context as you plan your migration.

If you are familiar with administering Tableau Server today, you’ll find that many of your tasks

are largely the same in Tableau Cloud. With the move to Tableau Cloud though, tasks related

to deploying and managing the software will be handled by Tableau as a managed service.

You can leave the upgrades to us. Head to the blog post, Should I Move My Analytics to

Tableau Cloud? for more details. With Tableau Cloud, you will be able to focus more of your

energy on ensuring smooth data connectivity, equipping users with best practices and devel-

oping an analytics community. For more details about what managing a Tableau Cloud site

involves, as well as a bunch of resources to get you started as an administrator, visit the

Tableau Cloud Site Admin page.
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Planning your data strategy for Tableau Cloud
Tableau Cloud can connect to dozens of data sources, but it’s essential that you develop a

data connectivity plan before you begin a migration. In this section we’ll walk you through the

best way to do that, and we'll describe the two ways Tableau Cloud connects to data.

The goal at this point is to validate that you can support your current data requirements after

your migration to Tableau Cloud.

Cleaning house: Does your content give you joy?

Before you begin to evaluate the various data types and how you'll migrate all of your data

sources, workbooks and projects into Tableau Cloud, we recommend that you use this migra-

tion as an opportunity to do some house cleaning. Most organisations running Tableau Server

for more than a year or two collect some amount of stale content: workbooks, data sources,

projects and flows. We recommend taking these steps before you migrate:

l You can use the Stale Content (Windows | Linux) admin view in Tableau Server to
identify content that is no longer in use. It doesn't usually make sense to move ancient,
archived content to Tableau Cloud. Let it go!

l Like most organisations who have been running Tableau Server for a while, your con-
tent hierarchy and permission structure has probably "evolved" organically and probably
a bit messily. As you plan the migration, develop a strategy that will optimise project,
group and permissions structures in your new Tableau Cloud site.

l If you are a Tableau Data Management customer, use the tools to manage data clean-
ing, combining and processing for the pending move.

Make a list and create a data source strategy

After you clean up existing content, it's time to take inventory of your data sources. The goal of

this exercise is to determine how you will support users in your organisation with the data

sources that they are currently using.

For each data source:
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l Cross check it with the Tableau Cloud connector table in the following section. If it's
supported, you've got a direct path forward. If it's not in the table...

l Cross check it with Connectivity with Bridge to determine if your data type is supported
by Tableau Bridge.

l If the data source is a static file, Tableau Cloud supports uploading Excel or text-based
data sources (.xlsx, .csv, .tsv) directly from the browser or Tableau Desktop. The max-
imum file size you can upload is 1 GB. More likely, your users are connecting to these
types of files in a shared, common directory. If this is the case, you can upload these
files to a public cloud space such as Google Drive, Dropbox or OneDrive, for example.
Or you can use Bridge. You (or your users) can then configure Tableau Cloud to con-
nect to these spaces for a live data connection.

l Run the Tableau Cloud Migration Technical Readiness Assessment to understand if
there are any use cases that may need to be adapted before migrating to Tableau
Cloud.

Supported Tableau Cloud connectors

The following connectors are supported in Tableau Cloud

Alibaba AnalyticsDB for

MySQL‡

Alibaba Data Lake Analytics‡

Alibaba MaxCompute‡

Amazon Athena‡

Amazon Aurora for MySQL‡

Amazon EMR Hadoop Hive‡

Amazon Redshift‡

Apache Drill‡

Azure Data Lake Storage

Gen2‡

Exasol‡

Google BigQuery*‡

Google Cloud SQL

(MySQL compatible)‡§

Google Drive‡

Hortonworks Hadoop Hive

IBM DB2‡

Impala‡

Kyvos‡

OData‡

OneDrive*‡

Oracle‡

Pivotal Greenplum Data-

base‡

PostgreSQL‡

Presto‡

Qubole Presto‡

Salesforce‡

SAP HANA (for virtual

connections only)‡
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Azure Synapse Analytics (SQL

Server compatible)

Box‡

Cloudera Hadoop‡

Databricks‡

Datorama by Salesforce‡

Denodo‡

Dremio by Dremio‡

Dropbox*‡

Esri Connector‡

MariaDB‡

Microsoft Azure

SQL Database‡

Microsoft Azure Synapse

Analytics‡

Microsoft SQL Server‡

MongoDB BI Connector‡

MySQL‡

SharePoint Lists‡

SingleStore (formerly

MemSQL)‡

Snowflake‡

Spark SQL‡

Teradata**‡

Vertica‡

*For more information about using OAuth 2.0 standard for Google BigQuery, OneDrive and

Dropbox connections in Tableau Cloud, see OAuth Connections.

**Teradata web authoring currently doesn’t support query banding functionality. See Teradata

for details.

‡Supports virtual connections if you have Data Management. See About Virtual Connections

and Data Policies in the Tableau Cloud help for details.

§Tableau Cloud doesn't support SSL using Google Cloud SQL.

User accounts and authentication
The second essential planning step is to identify the authentication mechanism you would like

to use for Tableau Cloud users.
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The default user account on Tableau Cloud is called TableauID. TableauID requires multi-

factor authentication (MFA) to ensure secure access to Tableau Cloud. See About multi-

factor authentication and Tableau Cloud in the Tableau Cloud documentation.

If your organisation uses an identity provider (IdP) to enable authentication, you can probably

use that for Tableau Cloud. We support Salesforce authentication and Google OpenID nat-

ively. You can also configure SAML for Azure, Okta, OneLogin, AD FS, PingOne or any

IdP that supports standard SAML 2.0 authentication.

Before you proceed, review the Tableau Cloud Authentication options to develop a plan.

If your organisation manages identities with Azure AD, Okta or OneLogin, then you can also

automatically provision users and groups in Tableau Cloud. See Automate User Provisioning

and Group Synchronisation through an External Identity Provider.

Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. You are here: Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist
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Create and Configure a Tableau
Cloud Site

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to manu-

ally migrate Tableau Server deployments with fewer than 100 users to Tableau Cloud.

The migration process that is described in this guide starts by working with your account man-

ager to transition your Tableau licences from Server to Cloud. If you would like to test out

Tableau Cloud prior to your migration, you're also welcome to trial Tableau Cloud at any time.

Step 1: Work with a Tableau Account Manager
to transition licensing
The first step in your migration is to work with your Account Manager to transition your licens-

ing from Server to Cloud. After this is done, you have 60 days of access to both products. Most

customers with 100 users or less complete this migration process within a week, so there

should be ample time to access both products as you transition. You can work with your

Account Manager if more time is required.

Step 2: Specify an authentication method
The default authentication method will be Username and Password (TableauID). Multi-Factor

Authentication is required for TableauID users to ensure secure access to Tableau Cloud. We

also support many industry standards Single Sign On options. For more information see

Authentication to determine which authentication method makes the most sense for your

organisation.
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Step 3: Familiarise yourself with the site
Walk through the site settings and ensure that they are configured appropriately for your

organisation's needs.

Step 4: Configure data connectivity
The way Tableau Cloud connects to data differs based on where the data are stored. Each

method may require different preparation and is laid out below. If you’re not sure which option

is right for you, please reach out to your account manager.

Publicly available cloud data

Publicly available cloud data includes Google Drive, Dropbox, OneDrive and Snowflake, for

example.

If the connection is a database, you may need to enable Tableau Cloud to query it. To enable

connectivity, see Authorise Access to Cloud Data Published to Tableau Cloud.

For flat files like Excel and .csv files: we recommend saving these files in a cloud store like

Google Drive, Dropbox, or OneDrive. You can then enable direct connectivity to the data from

Tableau Cloud. If that is not an option, you will need to configure Tableau Bridge to maintain

connectivity to flat files saved locally.

On-Premises, local files or private cloud data

Local files, private cloud data, and on-premises data might be SQL Server, Oracle or local

Excel files for example.

If you have Private data requirements, you will need to install and configure Tableau Bridge.

Tableau Bridge provides secure communication between Tableau Cloud and data behind fire-

walls. Install Bridge behind your firewall on a separate computer that has access to your data.

See About the Bridge Client.
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Optional: For local files (Excel, CSV, etc), you can save them in a cloud store like Google

Drive, Dropbox, Onebox instead of using Tableau Bridge.

Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. You are here: Create and Configure Tableau Cloud Site 00
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist
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Migrate Virtual Connections

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to

manually migrate Tableau Server deployments with fewer than 100 users to Tableau

Cloud.

If your organisation relies on virtual connections in Tableau Server, you must migrate those

before proceeding. If you do not have virtual connections configured for Tableau Server, skip

this procedure.

Migrating virtual connections from Tableau Server to Tableau Cloud is a manual process. You

must recreate the virtual connection (or the published data source and virtual connection) on

your Tableau Cloud site, replace the data source in each workbook with the new virtual con-

nection, and then copy/paste any calculation formulas from the original workbook data source

to the updated one.

Step 1: Recreate and test the virtual connection on Tableau Cloud

See Create a Virtual Connection.

Step 2: Recreate published data sources built with the virtual connection

You will need to recreate all published data sources that use the virtual connections:

1. Follow the procedure at Use a Virtual Connection.
2. Create a Published Data Source in Tableau Cloud so that it exactly mirrors the original

Server data source. The following details must match:
l All fields in the original data source must exist in the new data source
l Field names: case must also match
l Measure and dimension must map from original to new fields
l Default field settings. See Edit Default Settings for Fields.

3. Make note if Tableau Bridge is required for the data source.

Step 3: Update workbooks to replace previous data sources
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Run the following procedure from Tableau Desktop for each workbook that you want to

migrate to Tableau Cloud:

1. Sign in to Tableau Server, navigate to the workbook that you are migrating, and then

download the workbook.

2. Within the workbook select File > Close. Do not close Tableau Desktop.

3. Sign out of Tableau Server: Server > Signed into http://example > Sign out. You will
get a warning about signing out while connected to Tableau Server. ClickOK.

4. Sign in to Tableau Cloud: Server > Sign in > Tableau Cloud.

5. From the Desktop home screen, select the workbook file to open it again.

You will receive two Unable to complete action error messages. Close the error mes-

sages. When the worksheet opens, it will display theWorksheet Unavailablemessage.

Do not edit the connection from the main window.

6. If you’ve already created a new published data source skip to Step 8. Otherwise, update

the data source by navigating to Data > New Data Source.

l Navigate to the new virtual connection that you created for this workbook, and
then click Connect.

l Open the original Tableau Server workbook and copy the formulas. Paste the for-
mulas in the updated Cloud workbook.

7. Create a new data source that exactly matches the previous data source. Field names

must match exactly.

8. Replace data source: On the Data tab, right-click the data source that you just created,

and then click Replace Data Source. In Replace Data Source specify the correct
source in the Replacement selector, and then clickOK.

9. Right-click on the old data source and select Close.
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10. To publish the data sources:
l Separately to Tableau Cloud, select Publish>Data Source>Data Source
Name.

l Embedded in the workbook, select Publish > Workbook.

Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. You are here: Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist
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Migrate Data Sources, Workbooks
and Prep Flows to Tableau Cloud

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to manu-

ally migrate Tableau Server deployments with fewer than 100 users to Tableau Cloud.

For many organisations running a manual migration, it may make sense to have users (or a

subset of users) migrate content they are familiar with to the new Tableau Cloud site. The con-

tent migration steps described in this topic can be completed by users (with Creator roles) in

your organisation.

Before you begin
Before you embark on content migration, we want to reinforce the recommendation to do a full

inventory and clean up of your existing Tableau Server environment. See Cleaning house:

Does your content give you joy?

Keep the Tableau Server lights on! During your migration process, ensure that all content
and business processes remain operational in your Tableau Server system. Do not decom-

mission your Tableau Server environment until you have verified and validated that your con-

tent and procedures have been properly migrated to Tableau Cloud.

Step 1: Create projects for your site with min-
imum access policy
We recommend setting up your new Tableau Cloud site with a minimum access policy. It's

important to know that after a user is added to Tableau Cloud they can begin accessing con-

tent on the platform.
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Before you begin, we recommend reviewing Quick Start: Permissions for a refresher course

on how permissions interact and inherit in Tableau. If you are familiar with these concepts in

the context of Tableau Server, then you're good to go. Tableau Cloud permissions use the

same logic as Server.

Follow these steps to set up projects with a minimum access policy.

1. Configure template permissions on the Default project before creating more projects.

2. Remove permissions for All Users group. Removing All Users ensures that projects are

configured with explicit permissions for users who need to access the content.

3. Create groups. Groups simplify permission management as your organisation and/or

content scales.

For more general project permission guidance, see Use Projects to Manage Content Access.

Step 2: Add users with Creator roles
After you have configured the minimum access policy, now is the time to add any users who

will be migrating content. If you are not relying on users to migrate content, then you can add

them later in the process. See Configure Permission and Content Access for Migrated Users.

Follow these guidelines for adding the creator users:

l Review site roles: Set Users' Site Roles.
l You can add users manually or you can import them with a CSV file.
l After you've added the users and set their roles, add them to the appropriate groups
that you set up in the previous step.

Step 3: Migrate published data sources
If multiple workbooks use a single published data source, you only need to migrate the pub-

lished data source once.
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1. On Tableau Desktop, sign in to your Tableau Server environment, navigate to the work-

book(s) that you want to migrate, and click Download.

2. On the Datamenu in Tableau Desktop, select the data source, select Create Local
Copy, and then save the local copy of the data source.

3. Working from a Sheet, select Data > Replace Data Source. Enter the following
options:

l Current: The current Local Copy Replacement: the local copy you saved
l In the Data pane, right-click the original published data source, and then select
Close.

4. Select Server and then click Sign Out.

5. Select the data source in the Datamenu and select Publish to Server.

6. In Tableau Desktop, sign in to Tableau Cloud, then publish the data source.

7. If necessary, schedule a refresh of that data source in Tableau Cloud. For more inform-

ation, see Recreate Refresh Schedules for Tableau Cloud.

If the newly published data source is the only data source in the workbook, then follow the next

two steps to publish the workbook as well. If the workbook has multiple published data

sources, skip to the next step.

1. When Publishing the data source, verify that Update workbook to use the published
data source is selected.

2. Select Server > Publish Workbook to publish the workbook to Tableau Cloud.

Step 4: Migrate workbooks with multiple pub-
lished data sources
Repeat the following process for all published data sources that you would like to migrate to

Tableau Cloud.
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1. On Tableau Desktop, sign in to your Tableau Server environment, navigate to the pub-

lished data source that you want to migrate, and click Download.

2. The file will open in Tableau Desktop. On the Datamenu in Tableau Desktop, select
the data source, select Create Local Copy, and then save the local copy of the data
source.

3. In the Data pane, right-click the original published data source, and then select Close.

4. Repeat steps 2-3 for all Published Data Sources in the workbook.

5. Select Server and then click Sign Out.

6. Working from a Sheet, select Data > Replace Data Source. Enter the following
options:

l Current: The current Local Copy
l Replacement: the local copy you saved

7. After all Published Data Sources are replaced, select Select > Publish Workbook to
publish the workbook to Tableau Cloud.

If the workbook also has an Embedded Data Source requiring Tableau Bridge, those data

sources will need to be published separately as during the migration. See Publish a Data

Source.

Step 5: Migrate workbooks with embedded
data sources

1. On Tableau Desktop, sign in to your Tableau Server environment, navigate to the work-
book(s) that you want to migrate, and click Download.

2. Select Server and then click Sign Out.
3. Select Server and then click Sign In to sign into Tableau Cloud.
4. Publish the data source:

l If the data source requires Tableau Bridge for automated refresh, the data
source will need to be published as a published data source before publishing
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the workbook. See Publish on-premises data.
l If the data source does not require Tableau Bridge, select Server > Publish
Data Source, and verify that Update workbook to use the published data
source is selected.

5. Select Select > Publish Workbook.

Step 6: Migrate Tableau Prep flows
For all publicly available cloud data, you may need to enable Tableau Cloud to query it. To

enable connectivity, see Authorise Access to Cloud Data Published to Tableau Cloud.

Repeat the following procedure for all Tableau Prep flows that you would like to migrate to

Tableau Cloud. Run this procedure on a computer that is running Tableau Prep Builder.

1. Sign in to your Tableau Server environment, navigate to the flow that you want to
migrate and click Download.

2. The flow will open in Tableau Prep Builder:
a. If the flow connects to at least one published data source, you will be auto-

matically prompted to sign in to your server. If you are not automatically promp-
ted, from the top menu select Server > Sign in and sign in to Tableau Server.

b. Navigate from the top menu and select Server. In the Signed in to server URL,
click Sign Out.

c. If the flow connects to at least one published data source, you will see the fol-
lowing warning:

d. Click Sign Out.
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3. Navigate to the top menu and select Server > Sign in >Quick Connect to Tableau
Cloud to sign in to Tableau Cloud.

4. If the flow does not contain any published data sources, proceed to the next step. If the
flow connects to at least one published data source

a. Open the Connections pane and connect to the new version of the Published
Data Source on Tableau Cloud.

b. Drag and drop the new connection to replace the existing Tableau Server Pub-
lished Data Source input step.

c. Right-click on the existing connection in the connections flyout and delete the
Tableau Server Published Data Source.

d. Repeat steps for all other connected published data sources in the flow.
5. If your flow outputs to any published data source(s), navigate to the output step(s) and

update them to reference the new published data source on Tableau Cloud.
l Repeat steps for all other output published data sources in the flow.

6. After all published data sources are replaced, select Server > Publish Flow or click
the Publish button in the top right-hand corner to publish the flow to Tableau Cloud.

Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. You are here: Migrate Data Sources, Workbooks and Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist
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Recreate Refresh Schedules for
Tableau Cloud

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to manu-

ally migrate Tableau Server deployments with fewer than 100 users to Tableau Cloud.

Establish new refresh schedules for extract
data sources

l For extract Data Sources, navigate to the published or embedded data source in

Tableau Cloud. Select Extract Refreshes > New Extract Refresh > Select an
extract schedule.

For data sources requiring Tableau Bridge, ensure Bridge is configured for the con-

nection before establishing extract refreshes. See Use Bridge for Private Cloud Data.

Establish new refresh schedules for Tableau
Prep flows
Scheduling flows are available to Data management customers only.

l To establish new refresh schedules for Tableau Prep flow, navigate to the flow in
Tableau Cloud. Select Scheduled Tasks > New Task > Select and configure the
schedule. Do the same for any Linked Tasks. For more information, see Schedule Flow
Tasks.

Custom schedules for flows are not supported in Tableau Cloud.
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Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. You are here: Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist
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Configure Permission and Content
Access for Migrated Users

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to manu-

ally migrate Tableau Server deployments with fewer than 100 users to Tableau Cloud.

Now that you've added your data sources, workbooks and Prep flows to Tableau Cloud, you're

ready to add your users. Before we do that, it's important to understand how Tableau determ-

ines who has access to what data. Tableau Cloud allows you to designate who has access to

content and allows you to restrict the data access within a data source.

We will use content access tools to restrict who has access to a content item, and row level

security tools to restrict the data a user can see within a data source.

Content access
Projects, nested projects and individual content items are all subject to permission rules. You

can see how those rules are used in your Tableau Server environment and then recreate them

in Tableau Cloud. See Permissions.

Row level security
If you have any data sources or workbooks with row level security, your row level security per-

missions and calculations will need to be updated for Tableau Cloud because user names and

group names may change during a conversion. See Restrict Access at the Data Row Level

and Create a Data Policy for Row-Level Security.
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Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. You are here: Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. End-User Migration Checklist

xxx Tableau Software

Tableau Cloud Manual Migration Guide



Add Remaining Users to Tableau
Cloud

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to manu-

ally migrate Tableau Server deployments with fewer than 100 users to Tableau Cloud.

Now that you've migrated over all the content and set up your projects, groups and per-

missions, you can add the rest (or all) of your users.

Add users
As soon as you add users, they will be able to access content. Make sure to follow the pro-

cedures in Configure Permission and Content Access for Migrated Users before adding users.

We also recommend learning about user site roles before migrating to Tableau Cloud. See Set

Users' Site Roles.

You can add users manually as shown below. If you have a lot of users and want to batch-

import them with a CSV file, see Import Users.

Add users manually

1. When you’re signed in to the Tableau Server site, select Users.

2. On the Users page, click Add Users, and then click Enter Email Addresses.
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3. If Google or SAML authentication is not enabled on this site, skip to the next step.

If Google or SAML authentication is enabled on this site, you can select the authen-

tication type for the new users.

l Select Add users for [Google/SAML] authentication if you enabled your site
for Google or SAML authentication and want the imported users to sign in to the

site through an external identity provider.

l Select Add users for Tableau authentication if you want these users to have
the default email address and password authentication.

You can go to the Users page to change users’ authentication type any time
after you add them.

Note: To work with Tableau Server by way of tabcmd, the Tableau Data
Extract Utility, or the Tableau APIs, users must authenticate with a

TableauID account.

4. In the Enter email addresses box, enter the users’ email addresses. If you add more
than one user, separate each address with a semicolon.

For example, tdavis@example.com; jjohnson@example.com; hwilson@example.com

5. Select a site role from the drop-down list, to assign that site role to all users you’re

adding.
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For site role definitions, see Set Users’ Site Roles.

6. Click Add Users.

If a new user’s email address is already associated with an account on tableau.com, the user

is prompted to sign in using the existing email address and password for that account.

If a new user’s email address is not already associated with an account on tableau.com, the

user is prompted to provide a first and last name and password.

Until the user provides these values, their entry in the Tableau Server user list shows the email

address preceded by a period. For example:

.snguyen@example.com

After the user signs in, the entry is updated to show the full name. For example:

Susan Nguyen

Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. You are here: Add Users to Tableau Cloud
8. End-User Migration Checklist
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End-User Migration Checklist

You are in the Tableau Cloud Manual Migration Guide. This guide describes how to

manually migrate Tableau Server deployments with fewer than 100 users to Tableau

Cloud.

Welcome to Tableau Cloud!

You're here because your Tableau administrator has recently migrated your Tableau Server

environment to Tableau Cloud, Tableau's fully managed analytics platform.

As a part of your migration, the following tasks need a few minutes of your time to make sure

that you have a smooth transition to Tableau Cloud. If you were using any of the below fea-

tures on Tableau Server, they will need to be re-created on Tableau Cloud. Review this list to

understand what features need to be re-created and follow the steps provided to do so!

Work with your Tableau administrator to access both Tableau Server and Tableau Cloud

while you migrate these items.

n URL actions: You’ll need to update URL actions that originated on Tableau Server so
that they point to Tableau Cloud URLs, or you can use updated field variables. See
URL Actions.

n Subscriptions: You’ll need to resubscribe to views, workbooks and flows on the
Tableau Cloud site. See Create a Subscription to a View or Workbook.

n Custom views: A custom view is a copy of a view that has your selections and filters
applied. You’ll need to reapply custom views on your Tableau Cloud site. See Use Cus-
tom Views.

n Row-level security: User and group names can change in a migration. If you used
groups and user names in row-level security solutions within Tableau data policies,
data sources or workbooks, they will need to be updated following a migration.

n Ask Data lenses: You’ll need to reconfigure Ask Data Lenses on Tableau Cloud. See
Create Lenses that Focus Ask Data for Specific Audiences.

n Favorites: You must recreate your favorites. You can add any type of content to your
favourites, except for embedded data sources. See Mark Favourites.
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n Collections: Collections will need to be recreated by users in Tableau Cloud.
n User account settings: Update your email settings and user interface options. See

Manage Your Account Settings.
n Saved credentials for data sources: You must update all data sources and flows that

previously included your saved credentials. See Manage Saved Credentials for Data
Connections.

n Webhooks: You must recreate Webhooks on Tableau Cloud. See Tableau Webhooks.
n Embedding solutions: If Tableau Server views are embedded in any other applic-

ations, those solutions will need to be updated to use Tableau Cloud configurations.
This includes, but isn’t limited to, the URL of the content item, how the web page inter-
acts with the items, and authentication to the visualisation.

n Dashboard extensions: Depending on the use case, dashboard extensions may need
to be adapted to the new Tableau Cloud environment. See Dashboard Extensions. Your
Tableau administrator may need to set up dashboard extension support on your Cloud
site.

n Data Management: If your organisation has purchased the Data Management add-on,
then you must update data quality warnings and field descriptions. See Virtual Con-
nections and Data Policies.

Migration workflow
This guide is organised according to a step-wise process for migrating to Tableau Cloud:

1. Plan Your Migration
2. Create and Configure a Tableau Cloud Site
3. Migrate Virtual Connections
4. Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
5. Recreate Refresh Schedules for Tableau Cloud
6. Configure Permission and Content Access for Migrated Users
7. Add Remaining Users to Tableau Cloud
8. You are here: User Migration Checklist

Tableau Software xxxv

Tableau Cloud Manual Migration Guide

https://help.tableau.com/current/pro/desktop/en-gb/useracct.htm
https://help.tableau.com/current/pro/desktop/en-gb/manage_stored_credentials.htm
https://help.tableau.com/current/pro/desktop/en-gb/manage_stored_credentials.htm
https://help.tableau.com/current/developer/webhooks/en-gb/index.html
https://help.tableau.com/current/pro/desktop/en-gb/dashboard_extensions.htm
https://help.tableau.com/current/online/en-gb/dashboard_extensions_server.htm
https://help.tableau.com/current/online/en-gb/dashboard_extensions_server.htm
https://help.tableau.com/current/online/en-gb/dm_vconn_overview.htm
https://help.tableau.com/current/online/en-gb/dm_vconn_overview.htm

	Tableau Cloud Manual Migration Guide
	Why migration can make sense
	Dive deeper

	When migration doesn't make sense
	Who should read this
	Post-migration
	Feature differences in Tableau Cloud
	Tasks that need to be completed by end users

	Version compatibility
	Licensing
	Additional Support
	Migration workflow

	Plan Your Migration
	Learn about Tableau Cloud
	Planning your data strategy for Tableau Cloud
	Cleaning house: Does your content give you joy?
	Make a list and create a data source strategy
	Supported Tableau Cloud connectors


	User accounts and authentication
	Migration workflow

	Create and Configure a Tableau Cloud Site
	Step 1: Work with a Tableau Account Manager to transition licensing
	Step 2: Specify an authentication method
	Step 3: Familiarise yourself with the site
	Step 4: Configure data connectivity
	Publicly available cloud data
	On-Premises, local files or private cloud data

	Migration workflow

	Migrate Virtual Connections
	Migration workflow

	Migrate Data Sources, Workbooks and Prep Flows to Tableau Cloud
	Before you begin
	Step 1: Create projects for your site with minimum access policy
	Step 2: Add users with Creator roles
	Step 3: Migrate published data sources
	Step 4: Migrate workbooks with multiple published data sources
	Step 5: Migrate workbooks with embedded data sources
	Step 6: Migrate Tableau Prep flows
	Migration workflow

	Recreate Refresh Schedules for Tableau Cloud
	Establish new refresh schedules for extract data sources
	Establish new refresh schedules for Tableau Prep flows
	Migration workflow

	Configure Permission and Content Access for Migrated Users
	Content access
	Row level security
	Migration workflow

	Add Remaining Users to Tableau Cloud
	Add users
	Add users manually

	Migration workflow

	End-User Migration Checklist
	Migration workflow


