Tableau Online 版本兼容性

Tableau Online 是一种基于云的安全解决方案,用于共享、分发和协作处理在 Tableau 中创建的内容。发布 Tableau 的新主要版本时,通常会升级 Tableau Online 服务器。发生这种情况时,您需要考虑如何保持与现有环境兼容,现有环境可能包含 Tableau Desktop 安装、Tableau Bridge,以及使用 Tableau 命令行实用工具(如 tabcmd 和 Tableau 数据提取实用工具)的任何现有脚本或进程。

关于主要升级的构成的信息,请参见升级 Tableau Desktop 和 Tableau Prep Builder

何时升级 Tableau Desktop 和 Tableau Bridge 以使用 Tableau Online

Tableau Online 升级到新的主要版本之后,您仍然可以从早期版本的 Tableau Desktop 中发布数据源和工作簿。但是,您将需要升级到 Tableau Desktop 的最新主要版本以执行以下操作:

  • 下载并打开一个在 Tableau Online Web 编辑环境中编辑和保存的已发布工作簿。

  • 制作数据源的本地副本。

  • 如果通过 Tableau 身份验证启用了多重身份验证 (MFA),则 Bridge 客户端必须运行 Tableau Bridge 版本 2021.1 及更高版本。有关使用 MFA 的 Tableau 的详细信息,请参见关于多重身份验证和 Tableau Online(链接在新窗口中打开)

如果您尝试在比 Tableau Online 服务器版本早的 Tableau Desktop 版本中使用此类工作簿或数据源,则您将收到以下错误:

This file was created by a newer version of Tableau. Please upgrade Tableau Desktop to the version (or greater) that the file was saved in.

当您安装新的 Tableau Desktop 主要版本时,将安装最新的 Tableau Bridge 客户端。它会自动启动并还原您使用以前的版本设置的任何数据提取刷新。

何时为站点管理升级 tabcmd

如果您使用 tabcmd 管理您的 Tableau Online 站点,例如,自动执行工作簿上载、管理用户等任务,那么您将需要 tabcmd 的最新支持版本以运行这些任务。使用 tabcmd 的过时版本会导致错误和不可预知的结果。

欲了解详细信息和 tabcmd 的当前支持版本,请参见 Tableau Online 帮助中的安装 tabcmd(链接在新窗口中打开)

使用 Tableau 数据提取实用工具刷新数据源

Tableau 数据提取命令行实用工具随 Tableau Desktop 一起自动安装。如果您使用此工具在 Tableau Online 上向已发布数据源推送数据,请考虑以下要求:

  • 您将需要使用站点 ID,而不是站点名称。

    站点 ID 是 Tableau Online URL 的一部分。例如,在以下示例中,站点 ID 为 WidgetWorks

    https://online.tableau.com/t/WidgetWorks/view/projects

    有关 -t 选项的详细信息,请参见 Tableau Online 帮助中的自动执行数据提取刷新任务(链接在新窗口中打开)

  • 在您向 Tableau Online 发布数据源后,您必须使用与 Tableau Online 版本匹配的 Tableau Desktop 版本附带的数据提取实用工具来刷新已发布数据源中的数据。

感谢您的反馈!