Tableau Desktop 製品の更新の制御

Tableau Desktop 製品の更新を自動的にチェックしてインストールできます。ユーザーは [製品の更新をチェック] 機能を使用して製品の更新を明示的に確認することもできます。これらの機能は自動的に有効化されていますが、インストール プロセス中 (Windows) またはその後 (Windows または Mac) に、これらの機能を無効化することができます。

Tableau Desktop でユーザーの製品の更新機能をオフにするには、AutoUpdateAllowed プロパティ値の設定を変更します。その場合、[製品の更新をチェック] 機能もオフになります。この機能により、ユーザーは好きなときに最新の Tableau Desktop メンテナンス アップデートをチェックしたり、コンピューターにインストールしたりできます。

製品の更新は、ドット リリース (メンテナンス) バージョンにのみ適用されます。各バージョンは次のように表示されます。

2021.3.1

2021.3 はリリース バージョン、1 はドット (メンテナンス) バージョンを表します。この場合、2021.3.1 がリリースされると製品の更新が適用されますが、2021.3 のリリース時には適用されません。

ユーザーの製品の更新を制御できることに加えて、TableauAutoUpdate.xml(新しいウィンドウでリンクが開く) ファイルを変更することで、ユーザーが更新する Tableau Desktop のドット バージョンも制御できます。

注: 新しいリリース バージョンの Tableau Desktop Public Edition または Tableau Reader が利用可能になると、以前のバージョンのサポートは終了します。ユーザーは、最新のバージョンに更新するよう伝える通知を自動的に受信します。また、一度にインストールできるのは、Tableau Desktop Public Edition の 1 つのバージョンのみです。

この記事では、インストール時に自動製品更新の設定を変更する方法と、ユーザーが更新可能な製品のメンテナンス バージョンを制御する方法について説明します。

インストール後に製品の更新設定を変更する方法については、インストール後のインストール設定の変更を参照してください。

インストール後に製品の更新をオフにする (Windows のみ)

  • Tableau Desktop のコマンド ライン プロセスでインストーラーを実行する場合、AUTOUPDATE プロパティの値を "0" に設定することで、ユーザーに対する製品の自動アップデートをオフにすることができます。例:

tableauDesktop-64bit-2021-3-1.exe AUTOUPDATE="0"

  • UI を介して更新をオフにするには、[ヘルプ] >[設定とパフォーマンス] に移動し、[Enable Automatic Product Updates (製品の自動アップデートを有効にする)] をオフにします。
  • 設定とパフォーマンスのヘルプメニュー。自動製品アップデート、自動保存、グラフィックの高速化を有効化する選択が表示されています。

 

 

ユーザーが取得するメンテナンス バージョンの指定

TableauAutoUpdate.xml ファイルを変更することにより、製品更新によってユーザーに提供される Tableau Desktop のメンテナンス バージョンを指定できます。TableauAutoUpdate.xml (新しいウィンドウでリンクが開く)ファイルは、更新する製品、更新先のバージョン、更新を検索する場所 (つまり、ダウンロード サーバーのパス) を更新プロセスが決定する際に使用するデータを含む XML スキーマです。最初に、新しい TableauAutoUpdate.xml ファイルをコピーまたは作成し、ユーザーのコンピューターを構成して、ファイルが保存されているダウンロード サーバーを示します。

TableauAutoUpdate.xml ファイルのコピーおよび変更

TableauAutoUpdate.xml ファイルを Tableau ダウンロード(新しいウィンドウでリンクが開く) サイトからコピーし、お使いの環境に合わせて変更してから、ダウンロード サーバーのルート ディレクトリに保存することもできます。

  1. TableauAutoUpdate.xml の一覧にある製品バージョンが、ユーザーによる更新先のバージョンであることを確認します。

  2. 製品の更新を含むダウンロード サーバー上のフォルダーを示すよう各 version の latestVersionPath 属性を編集します。

  3. (オプション) 不必要なインストーラーをすべて削除します。

独自の TableauAutoUpdate.xml ファイルの作成

独自の TableauAutoUpdate.xml ファイルを作成および使用する場合は、次の手順を実行する必要があります。

  1. 必要な情報を収集します。

  2. ハッシュ ファイルの生成

  3. TableauAutoUpdate.xml ファイルの作成

  4. ファイルの場所を示すようユーザー コンピューターを構成します。

必要な情報を収集する

TableauAutoUpdate.xml ファイルの作成前に以下の情報を収集します。

XML ファイルの version エントリでは、以下のものが必要です。

  • latestVersion:ユーザーのコンピューターにインストールする更新のバージョン番号。[Tableau のバージョン情報] ダイアログ ボックスに表示されます。ユーザーが Tableau Desktop を起動すると、Tableau は新しいバージョンが利用可能かどうかを確認します。

  • latestVersionPath:インストーラーを含むダウンロード サーバーにあるフォルダーの名前です。まだ存在しない場合は、サーバーにこのフォルダーを作成します。

    注: インストーラーは Downloads/TableauAutoUpdate にダウンロードされます。TEMP/TableauAutoUpdate フォルダーが存在しない場合、インストーラーは Downloads フォルダーにダウンロードされます。

  • name: Tableau Desktop の release (X.x) の形式のバージョン番号。例: 2020.2。

  • releaseNotesVersion: ユーザーにインストールしてもらいたいバージョン番号、release.maintenance の形式 (X.x.x)。例: 2020.1.1。このパラメーターにはリリース ノートへの正しいリンクが表示されます。

更新する製品ごとに XML ファイルで installer エントリを作成する必要があります。

製品要素ごとに、次の情報を収集します。

  • hash:インストーラーの SHA-512 ハッシュを生成します。この文字列は正しいものである必要があります。そうでないと、Tableau でインストーラーが使用されません。詳細については、ハッシュ ファイルの生成を参照してください。

  • name:ダウンロードするインストーラー ファイルの名前。

  • size:ファイルのバイトのサイズ。

  • type:Tableau がダウンロードする正しいインストーラーを検索するのに使用する、事前定義された製品タイプ。タイプは次のリストから使用する必要があります: desktop64、desktopMac、reader64、readerMac、public64、または publicMac。

ハッシュ ファイルの生成

SHA512SUM や Certutil などのユーティリティを使用し、インストーラーごとに SHA-512 ハッシュを生成します。通常、Tableau 実行可能ファイルをダウンロードし、ハッシュをローカルで生成するなら、より迅速にハッシュを生成できます。

それぞれのユーティリティの動作は異なるため、ユーティリティのヘルプを表示するには、コマンド プロンプトでユーティリティ名、その後ろに -hまたは-?を入力します。

例: sha512sum -h

TableauAutoUpdate.xml ファイルの作成

これまでに収集した情報に基づき、TableauAutoUpdate.xmlファイルを作成します。各バージョンに対して 1 つの version 要素を作成し、version 要素内で、更新する各製品タイプに対して 1 つの installer エントリを作成します。XML ファイルをダウンロード サーバーのルートに保存します。

次の XML ファイルの例では、64 ビット バージョンの Tableau Desktop を 2020.2.1 に更新します。バージョン 9.2.1 の Tableau Desktop を更新する例も含まれています。MacOS に Tableau をインストールする場合は、.pkg 形式のファイルを使用します。.dmg 形式のファイルをダウンロードする場合は、.dmg ファイルをマウントしてから、同梱された .pkg ファイルをコピーして製品をインストールする必要があります。

注: お使いのバージョンが Tableau Public や Tableau Reader の現在リリースされているバージョン (Tableau 2020.2 など) の場合は、public_supported="true" reader_supported="true" を設定します。ご利用の Tableau Desktop Public Edition または Tableau Reader のバージョンが以前のバージョン (Tableau 9.2 など) である場合は、public_supported="false" および reader_supported="false を設定します。

<?xml version="1.0" ?>
<versions xmlns="http://www.tableau.com/schemas/InstallerVersions/V1">
  <version 
        public_supported="true" 
        reader_supported="true" 
        showEula="false" 
        releaseNotesVersion="2020.2.1" 
        name="2020.1" 
        latestVersionPath="esdalt/2020.2.1" 
        latestVersion="20202.19.0123.2221" 
        hashAlg="sha512">
    <installer name="TableauDesktop-2020-2-1.pkg" type="desktopMac" 
               size="192202277" hash="<128-byte_hash>"/>
    <installer name="TableauPublicDesktop-64bit-2020-2-1.exe" type="public64" 
               size="147025920" hash="<128-byte_hash>"/>
    <installer name="TableauReader-2020-2-1.pkg" type="readerMac" 
               size="190243904" hash="<128-byte_hash>"/>
    <installer name="TableauPublic-2020-2-1.pkg" type="publicMac" 
               size="186465418" hash="<128-byte_hash>"/>
    <installer name="TableauReader-64bit-2020-2-1.exe" type="reader64" 
               size="167346176" hash="<128-byte_hash>"/>
    <installer name="TableauDesktop-64bit-2020-2-1.exe" type="desktop64" 
               size="186908672" hash="<128-byte_hash>"/>
  </version>
  <version 
        public_supported="false" 
        reader_supported="false" 
        showEula="false" 
        releaseNotesVersion="9.2.1" 
        name="9.2" 
        latestVersionPath="esdalt/9.2.1" 
        latestVersion="9200.16.0114.0755" 
        hashAlg="sha512">
    <installer name="TableauDesktop-9-2-1.dmg" type="desktopMac" 
               size="183617138" hash="<128-byte_hash>"/>
    <installer name="TableauDesktop-64bit-9-2-1.msi" type="desktop64" 
               size="177065984" hash="<128-byte_hash>"/>
  </version>
  <version 
        public_supported="false" 
        reader_supported="false" 
        showEula="false" 
        releaseNotesVersion="9.1.4" 
        name="9.1" 
        latestVersionPath="esdalt/9.1.4" 
        latestVersion="9100.16.0114.0755" 
        hashAlg="sha512">
    <installer name="TableauDesktop-9-1-4.dmg" type="desktopMac" 
               size="183617138" hash="<128-byte_hash>"/>
    <installer name="TableauDesktop-64bit-9-1-4.msi" type="desktop64" 
               size="177065984" hash="<128-byte_hash>"/>
 </version>
</versions>

ユーザーのコンピューターおよびダウンロード サーバーの構成

TableauAutoUpdate.xml ファイルを作成した後、この手順に従ってユーザーのコンピューターにファイルの場所を示します。

  1. それぞれのユーザーのコンピューターにある server レジストリ エントリが、お使いのダウンロード サーバーを示すよう設定します。
    • Windows: お使いの環境にある製品およびオペレーティング システムの種類 (64 ビット) ごとにエントリを作成します。以下のエントリは 64 ビットの Tableau Desktop 用です。

      HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau <version>\AutoUpdate
      Server = "<MyDownLoadServerName>"

      例:

      HKEY_LOCAL_MACHINE\SOFTWARE\Tableau\Tableau 2020.2\AutoUpdate
      Server = "MyCompanyDownloadServer"
    • Mac:各ユーザーの設定ファイルを、ダウンロード サーバーの一覧を表示するように変更します。defaults コマンドを使用します。

      defaults write com.tableau.Tableau-<version> AutoUpdate.Server "<MyDownLoadServerName>"

      例:

      defaults write com.tableau.Tableau-2020.2 AutoUpdate.Server "MyCompanyDownloadServer"
  2. HTTPS がダウンロード サーバーで有効になっていることを確認してください。Tableau はサーバーと通信する際、ダウンロード サーバー名にプレフィックスとして常に https:// を追加します。

  3. TableauAutoUpdate.xml をダウンロード サーバーのルートに保存します。

  4. Tableau インストーラーを、latestVersionPathパラメーターで指定されているダウンロード サーバーの場所にアップロードします。

TableauAutoUpdate.xml はユーザーに提供できる新しいリリースが出るたびに更新します。

フィードバックをお送りいただき、ありがとうございます。フィードバックは正常に送信されました。ありがとうございます!